Telegrams

 Anlage: SharpfinObs Version: E62P

<alphabetical order>

All objects: in numerical order

0001 IIDENT                      0273 SDFRFOTA                    1016 ST_ENTER_CALIB
0002 INETZAUFNAHME               0276 IASUSTATUS                  1017 SH_ENTER_CALIB
0003 SDLDCMD                     027A SKALIBRIERUNG               1018 SH_CUR_DET_DATA
0004 SDLDDATA                    0282 SDFRPOWERREQ                1019 ST_3D_PARAMS
0005 IFEHLER                     0283 IDFRPOWERREQ                101A SH_3D_PARAMS
0006 IFEHLER2                    02A7 AFDAUFNPOS                  101B S3DPARAMS
0007 SINIT                       02AE ST_CP_DATA                  101C I3DPARAMS
0008 IINIT                       02AF SORGDATEN                   101D ST_ACSOS_CMD
0009 AKENNDATEN                  02B0 SDLPROGDATEN                101F ST_DOWNLOAD_FD
000A IKENNDATEN                  02B1 SORGANSELECT                1020 RQ_FDR_VERSION_CHECK
000B SJUSTAGECMD                 02B2 SEXAMLIST                   1021 SH_FDR_VERSION_CHECK
000C IJUSTAGECMD                 02B3 SPROGRAMLIST                1022 ST_FD_CONNECT
000D SAPPLIKATION                02B4 SDLDATA                     1023 SH_FD_CONNECT
000E SBETRIEB                    02B5 IFILTERANZ                  1024 ST_IMPORT_FDDATA
000F SDOWNLOAD                   02B6 IDFRALLGANZ2                1025 SH_IMPORT_FDDATA
0011 IFESTATUS                   02B7 IDEXI                       1026 ST_EXPORT_FDDATA
0012 SRESET                      02B8 IERRORLOG2                  1027 SH_EXPORT_FDDATA
0014 SRESETFEHLER                02B9 IDOSEREQUESTED              1028 ST_EXAM_STUDY
0015 IFEHLERQUIT                 02BA SORGPOSITIONS               1029 SH_EXAM_STUDY
0016 STESTCMD                    02BC SAUFNDATEN                  102A RQ_DET_POS
0017 ITESTCMD                    02BD SIONDATEN                   102B SH_DET_POS
0018 SFKREKONFIG                 02BE SDLDATEN                    1030 ST_SKELMAL
0019 AISTWERTE                   02BF SREGELDATEN                 1031 SH_SKELMAL
001A IISTWERTEQUIT               02C0 SSTRAHLERWAHL               1032 ST_ACTUATOR
0020 IBINOK                      02C1 ISTRAHLERWAHL               1035 SH_COMP_STATE
0022 IERRORLOGSYNC               02C2 SAUFNAUSL                   1121 ST_PAT
0023 IFEHLERANZ2                 02C3 SDLAUSL                     1161 ST_ZOOM
0026 REP_SYS_MSG                 02C4 IAUFNDATEN                  11A1 ST_SS
0027 REP_CONFIRM                 02C5 IGENSTATUS2                 11A3 SH_SS
002E IIONTVAL                    02C6 ISESTATUS                   11B1 ST_IMG_INV
0032 IXCU_INFO_STATUS            02C7 IDLSTATUS                   1211 ST_COLPAR_A
0064 SBEDGG                      02C8 IAUFNSTATUS                 1212 ST_COLPAR_B
0065 SBEDKS                      02C9 ISTATUSGENAUFN              1213 SH_COLPAR_A
0066 SBEDGEN                     02CA ISTRAHLGAUFN                1214 SH_COLPAR_B
0067 SBEDSP                      02CB ISTATABSCHALT               1217 ST_COLPAR_OGP_A
0068 SBEDSYS                     02CC ISTRAHLGDL                  1234 SH_ORTHO
0069 SBEDORG                     02CE SRAUMLICHT                  1241 ST_FILTER_A
006A SBEDSTRM                    02CF SLIHVERZ                    1242 ST_FILTER_B
006B SBEDEINBL                   02D0 ASTRFR                      1243 SH_FILTER_A
006C SBEDBVFS                    02D2 SPATWECHSEL                 1244 SH_FILTER_B
006D SBEDDFR                     02D3 IPERIPHASE                  1311 SH_READY
006E SBEDALLG                    02D4 IERWSESTATUS                1312 SH_VERSION
006F SAUSLBED                    02D5 SREGELSTOP                  1315 ST_PWR_OFF
0070 SBEDZOOM                    02D6 IREGELSTOP                  1317 SH_VERSION_CHECK
0075 SBEDTOMO                    02D7 IDLPULSEDDATEN              1321 ST_MODE
0079 IKOLLAUFL                   02D8 INOTSTROM                   1322 SH_MODE
007B IDLANZ                      02D9 IDLDATEN001                 1331 REP_ERR
007C IDLISTANZ                   02DA SALTERNATIVELIST            1332 REP_TRACE
007D IROEANZ                     02DB IBSIGNAL                    1333 REP_BEEP
007F IXRAY                       02DC IFLUORODATA                 1341 RQ_OBJECT
0080 IBVFSANZ                    02DE IWATERVALACQ                1342 RJ_OBJECT
0081 ISTRMANANZ                  02E5 SGENMODE                    1360 ST_TEXT_LONG
0082 IKASSANZ                    02E8 SMAGN                       1361 ST_DTEXT
0083 IERWKASSANZ                 02E9 IMAGN                       1385 SH_DISP_LONG
0084 IAUFNZANZ                   02EA STUIBUTTONS_2               1386 SH_DISP_VALUE
0085 ITOMOANZ                    02F2 STEACHINGMODEAUSL           1387 SH_DISP_ICON
0086 IGGANZ2                     02F4 ICPEXI                      1510 ST_SEARCH_RUN
008B ISTEPANZ                    02F8 VAUFNDATEN                  1511 SH_SEARCH_RUN
008C ISYSTEMANZ                  02F9 VIONDATEN                   1512 ST_GRID
008E IGENANZ                     0320 SLIMIT                      1513 SH_GRID
008F IIONANZ                     0321 SBLENDENPOS                 1514 SH_ERROR_RESET
0090 INACHANZ                    0322 SVERSTELLUNG                1801 ST_CONFIG
0092 ISPANZ                      0323 IBLENDE                     1802 SH_CONFIG
0095 SFANZLOESCHEN               0324 IFFA                        1803 ST_ADJUST
0099 IALLGANZ                    0328 SFILTER                     1804 SH_ADJUST
009A IPRINTAUFN                  0329 IFILTER                     1805 ST_DIAG
00A0 IERWALLGANZ                 032A SRASTER                     1806 SH_DIAG
00A3 IDLPULSEDISTANZ             032B IRASTER                     1807 ST_DOWNLOAD
00A4 IBLENDESELANZ               032D ASUCHLAUF                   1808 SH_DOWNLOAD
00A5 SNACHANZLOESCHEN            032E SSUCHLAUF                   1809 ST_DATA_TRANS
00A6 IDFRBEDANZ                  032F ISUCHLAUF                   180A SH_DATA_TRANS
00A8 IBEDPOWERREQ                0331 IBLENDENDATA                180B ST_RADIATION
00AB SPULTUPDATE                 0333 IRASTERANZ                  180C SH_RADIATION
00AD IDFPANZ2                    0334 SLICHTVISIER_2              1811 ST_SYSTEM_STATE
00AE IORGANANZ2                  0384 SBILD                       1821 RQ_IMAGE
00AF IDFRPATPOS                  0386 IBILD                       1822 SH_IMAGE
00B0 IDAPVALUE                   038E STV_PARA                    1823 ST_SERVICE_WF
00B1 SBEDGEN2                    03A3 IFLUOROACTANZ               1824 SH_SERVICE_WF
00B2 IXRPT                       03B6 SDETEKTORSTART              2204 UI_TABCARD
00C8 SBEDVCU                     03B7 IDETNR                      2205 SH_UI_TABCARD
00C9 SVCUNAHBED                  03B8 IDETEKTORSTATUS             2219 UI_COLLIMATOR
00CA IVCUNAHBED                  03BE SFLUORODATA                 2231 UI_XCU
00CB IVCUBEDANZ                  03BF SREGELDATEN2                2232 SH_UI_XCU
012C SBV                         03C9 IGENREADY                   2233 UI_COORDINATES
012D SIRIS                       03CA IUGENLOG                    2234 SH_UI_IMAGE
012E IBV                         0427 SGGAKTPOS                   2238 UI_STRING
012F IIRIS                       0429 IGGAKTPOS2                  2285 UI_SLIDER
018F IIONANZ2                    0430 RQ_FDR_DATA                 2297 SH_PROG_NAME
0190 SBEWEGUNG                   0431 SH_FDR_DATA                 2299 SH_LIST
0191 SBETRIEBSART                0432 A_POWER_RESET               229A ST_STATE
0192 SSCHICHT                    0433 I_POWER_RESET               2328 TEST_WWDATEN
0193 SSTELLUNG                   0434 S_POWER_RESET               2329 TEST_ADRDATEN
0195 SSPRITZE                    0435 ST_REMOVE_IMGS              232A TEST_EIN_AUS
0197 ISTELLUNG                   0436 ST_ADJUST_WLAN              232C TEST_APSDATEN
0198 ISCHICHTSCHUSS              0438 ST_FDR_DATA                 232D TEST_3DLOADCALC
0199 ISCHICHTANTR                0439 SVOLUMEREGLIST              2416 UIPACTION
019A IBEWEGUNG2                  04BA IZOOMANZ                    2511 SH_PREP
019B IBETRIEBSART                04BB IZOOM                       2526 SH_COL_A
019C ISPRITZE                    04BC SZOOM                       2612 ST_STEP
019D IKOLLISION                  04BE ST_KVCURVE                  2623 SH_POSITION
019E SBREMSUNG                   04BF SREGELDATENDL               2892 ST_DATA_2
019F IBREMSUNG                   0BB8 SCLOSE                      2893 ST_DATA_3
01A0 IGGFFA                      0BB9 ADATE                       2894 ST_DATA_CHUNK
01A2 SMYELO                      0BBA SDATE                       2901 INIT_CONNECTION
01A3 IMYELO                      0BBB SSELECTCOMP                 2902 INLIST_ENH
01A4 IGGFOTA                     0BBD SSERVINIT                   2903 INLIST_RED
01A5 SGGPERISCAN                 0BBE ASERVINIT                   2911 LCM_ON
01A6 IGGPERISCAN                 0BBF SSERVJUSTCMD                2912 LCM_OFF
01A9 SGGPOS                      0BC0 SSERVTESTCMD                2913 ERRORLOG_ON
01AA IGGPOS                      0BC2 SSERVERRORLOG               2914 ERRORLOG_OFF
01AC SSPINE                      0BC4 SSERVDOWNLOAD               9200 INIT_MSG
01AD IORTHO                      0BC5 SSERVDLDCMD                 9201 ERROR_MSG
01AE SORTHO                      0BC6 SSERVDLDDATA                9202 TURN_ON
01AF IORTHOACTSIZE               0BC7 SGROUP                      9203 TURN_OFF
01B0 SORTHOACTSIZE               0BC8 IDATE                       9204 DUMMY_MSG
01B6 ISOD                        0BC9 IINFOCOMP                   9300 MONITOR_ON
01B7 IACSS                       0BCA ISERVINIT                   9301 MONITOR_OFF
01B8 IORGPOSITIONS               0BCB ISERVJUSTCMD                9302 SEND_LIST
01B9 SGGNAVIPOS                  0BCC ISERVTESTCMD                9401 TOPO_NET_RQ
01F4 IKASSDATEN                  0BCE ISTATUSREPORT               9402 TOPO_NET_RP
01F5 SKASSPOS                    0BD2 ISERVQUIT                   9403 TOPO_VERI_RQ
01F6 IKASSPOS                    0BD3 ISERVSTORE                  9404 TOPO_VERI_RP
01F7 STEILUNG                    0BD4 ASERVBETRIEB                9405 CLIENT_DATA_RQ
01F8 IBILDFORMAT                 0BD5 ISERVBETRIEB                9406 CLIENT_DATA_RP
0257 IANLBEREIT2                 0BD6 AINFOCOMP                   9501 ERR_INFO
0259 IREGSTPMARKDFR              0BE0 SSERVBETRIEB                9603 CONNECTION
025A IDFRSTATUS                  0BE1 ISERVBETRIEBQUIT            9703 TRACELOG_ON
025B ISPRITZEMARKDFR             0BE3 SSERVBETRIEB2               9704 TRACELOG_OFF
025D IANLBEREIT                  0F0B APASSWORT                   E000 CAN_NMT_MODULE_CONTROL
025E ITISCHPOS                   0F10 IPASSWORT                   E080 CAN_SYNC
0260 SDFRNAHBED2                 1005 UI_SCU                      E09C SE_EMERGENCY
0261 IDFRSTATUS2                 1008 ST_ORTHO                    E19C SE_PDO1_TX
0262 SDFRPATWECHSEL              1009 ST_STPAR_RFP                E21C SE_PDO1_RX
0265 SDFRSERIE                   100A SH_STPAR_RFP                E29C SE_PDO2_TX
0268 IDFRNAHBED                  100B SH_STPAR_TUI                E31C SE_PDO2_RX
0269 IOGPSTORE                   100E ST_ORGAN_PROG               E39C SE_PDO3_TX
026A SDFRBLENDENDATA             100F SH_ORGAN_PROG               E59C SE_SDO_TX
026B IBLENDEANZ                  1011 SH_GLOB_GAIN                E61C SE_SDO_RX
026D SACQREQ                     1012 ST_PRE_PRO_PAR              E71C SE_NMT_ERROR_CONTROL
026E IDFRABSCHALTUNG             1013 SH_PRE_PRO_PAR              E800 CAN_FILTER
0270 SDFRREDBF                   1014 RQ_DET_TEMP                 FFFD _GEN_DEFINITIONS_SHARPFIN
0272 SDFRFOBVA                   1015 SH_DET_TEMP                 FFFE _GEN_DEFINITIONS_RFP


Changes in version VE62P for RadFluoro Platform:
- parameter ierrorlog2/ifehleranz2.FEHLERTEXT2: increased size from 120 to 500 characters
    reason: request from Salmon for 'maintenance intervall' message
- parameter st/sh_adjust.IDENTIFIER: new enum define ACS_ADJUST_ID_CTRL_XRAY
    reason: required for service function x-ray control (in UGEN)


_GEN_DEFINITIONS_RFP

<All Objects>

Object: _GEN_DEFINITIONS_RFP ___ID: FFFE

Description: this is not a real object, but only place holder for additional definitions
              ACQPLANE definitions are currently used by CCU
              OHM usage is unknown
              PARAM32 is used for ist enum-definitions
              JUSTCMD enum definitions are used in sServJustCmd
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ACQPLANE select acquisition plane
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_PLANE_A        1
                     ACS_PLANE_B        2
                     ACS_PLANE_A_AND_B  3
          Dimension: none

OHM Modes used in the header of each object
ACS_MODE_FUNCTIONAL = 0    The receipt is controlled by the inlist of the receiver
ACS_MODE_DIRECT     = 1    Objects which should be sent directly to one receiver
ACS_MODE_MESSAGE    = 2    Objects, created and sent only by the axcs server
ACS_MODE_MONITOR    = 3    Objects only used by ACSOS, if ACSOS is running as
                           a network monitor
ACS_MODE_SERVICE    = 4    Objects for the service to get more information about
                           internal states
ACS_MODE_ERROR      = 5    All the error objects of the axcs server itself
ACS_MODE_LCM        = 6    Objects between the axcs servers and the component
                           that is registered as the 'lab connection monitor'
ACS_MODE_TRACE      = 7    If a trace tool is connected it will get all objects
                           with this mode
ACS_MODE_TEST       = 0x20 (only use for AXN internal tests)
          Type:  Byte     (DEC)
          Range: 0 ... 7
          Dimension: none

PARAM_32 content and meaning of this parameter depends on the code of the previous parameter
          Type:  Integer32     (DEC)
          Range: -2147483647 ... 2147483647
                     RUECKWAERTS          -1
                     BILDDRHUNG_0         0
                     LOSGELASSEN          0
                     TASTE_LOSLASSEN      0
                     BILDDRHUNG_90        1
                     GEDRUECKT            1
                     TASTE_GEDRUECKT      1
                     TASTE_PLUS_REPEAT    1
                     VORWAERTS            1
                     BILDDRHUNG_180       2
                     TASTE_PLUS_DRUCK_1   2
                     BILDDRHUNG_270       3
                     TASTE_MINUS_REPEAT   3
                     TASTE_MINUS_DRUCK_1  4
          Dimension: depends on FKTSCODEGEN

TESTCMD command ID, service telegram ID
meaning in sServTestCmd:
1 - activate CAN trace
5 - set tubeload to 62%
6 - set tubeload to 80%
255 - deactivate password
meaning in sTestCmd towards Generator:
255 - DCV_REGELUNG_SIM
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

REGION Region number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

JUSTCMD dummy parameter to host the ENUM defines being used for CMDKENNUNG in sServJustCmd
          Type:  Enum8     (DEC)
          Range: 0 ... 20
                     JUSTCMD_WW_KORR_BERECHNUNG      1    Water Equivalent Calibration
                     JUSTCMD_IRIS_ABGLEICH           2    code for Iris adjustment and
                                                          blackening correction
                                                          Send of sIris based on new adjusts
                     JUSTCMD_IBINOK_CMD              3    turn off sending iBinOk
                                                          warnings will be shown as errors
                     JUSTCMD_DOSISL_ABGLEICH         4    dose rate adjustment /
                                                          FluoroDoseFactor
                     JUSTCMD_DOSIS_ABGLEICH          5    dose adjustment
                                                          Deactive fluoro and buzzer timer
                                                          for tube adjust and suppress grid
                                                          error message cause there is no
                                                          user to change grid, allow
                                                          collimator opening greater than
                                                          limit
                     JUSTCMD_DOWNLOAD                6    DownloadMode
                                                          suppress showing errors
                     JUSTCMD_HS_TRIGGER_DEAKT        7    generator shall not wait for
                                                          HV-Trigger from image system (PMS
                                                          can release radiation w/o ImgSys
                                                          being ready)
                     JUSTCMD_IGNORE_PULSED_DLFILTER  8    filter 0mm is allowed in pulsed
                                                          fluoro
                     JUSTCMD_IGNORE_SAUSLBED         9    ignore sAusBed(DL) from MCU,
                                                          accept sAuslBed from
                                                          BEDEINH=SERVICEPC
                                                          (used in surgery for SW controlled
                                                          radiation)
                     JUSTCMD_GEN_MONITORING          10   send to GEN-IF by PMS
                                                          If activated GEN-IF sends
                                                          iGenStatus not just direct to XCU
                                                          but also indirect.
                                                          (used in surgery)
                     JUSTCMD_NO_SBLENDENPOS          11   XCU will stop sending sBlendenPos
                                                          (allowing PMS to do so)
                     JUSTCMD_NO_AIR_KERMA_REDUC      12   deactivates
                                                          air-kerma-rate-limitation of
                                                          fluoro curve
                     JUSTCMD_SET_ACQ_IDX             13   set acquisition index
                     JUSTCMD_XRAY_BY_HANDSWITCH      14   Release of x-ray only allowed by
                                                          hand-switch
                     JUSTCMD_OVERRIDE_REL_OGP_POS    15   RELATIVE_CP_POS_USAGE will be
                                                          overwritten to "absolute" in
                                                          ST_STPAR_RFP (used for centering
                                                          adjustment)
                     JUSTCMD_DARK_IWATERVAL          16   send iWatervalAcq also on "dark"
                                                          acquisitions (for image chain test
                                                          from remote)
                     JUSTCMD_SFTP_DATA               17   transfers data needed to establish
                                                          the sFTP connection
                     JUSTCMD_TUBELOAD                18   artificially increases the tube
                                                          load value to 62%
          Dimension: none


_GEN_DEFINITIONS_SHARPFIN

Object: _GEN_DEFINITIONS_SHARPFIN ___ID: FFFD

Description: contains some special parameters that contain some special defines, which are
              still used in Sharpfin but shall be removed later on
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  Sharpfin

List of Parameters:

FKTSCODE_OLD dummy parameter to keep the obsolete enum definitions of FKTSCODEBVFS and FKTSCODESTRM
          Type:  Enum16     (DEC)
          Range: 500 ... 610
                     SCHRIFTEINBLENDUNG  502   lead letters (not in use)
                     FORMATAUTOMATIK     503   format auto (1=free collimation; 2=full auto;
                                               3=semi auto; 4=full auto height; 5=full auto
                                               width; 6=bucky mode)
                     BILDUMKEHR          601   image flip
                                               PARAM is defined as parameter BUMKEHR
                     HELLIGK_KONTR_NORM  602   set brightness/contrast to default
                     HELLIGKEIT          603   set brightness
                     KONTRAST            604   set contrast
                     BILDDREHUNG         605   image rotation; valid values for PARAM:
                                               BILDDRHUNG_0, BILDDRHUNG_90, BILDDRHUNG_180,
                                               BILDDRHUNG_270
          Dimension: none

FESTATUS_OLD dummy parameter to keep the obsolete enum definitions of FESTATUS
          Type:  Byte     (DEC)
          Range: 1 ... 13
                     BASIS_HW_TEST_AKTIV       1
                     WARTEND                   2
                     DLD_BEREIT                3
                     DLD_HARDWARETEST_AKTIV    4
                     DLD_HARDWARETEST_OK       5
                     DLD_LOESCHEN_AKTIV        6
                     DLD_LOESCHEN_OK           7
                     DLD_PROGRAMMIERUNG_AKTIV  8
                     DLD_PROGRAMMIERUNG_OK     9
          Dimension: none

TECHNIK_OBS exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _0_PUNKT_TECHNIK              0    0-pnt-technique (XCU determines kV,
                                                        mAs, ms automatically)
                     _1_PUNKT_TECHNIK              1    1-pnt-technique (kV given, mA
                                                        typically max., generator switches
                                                        off when dose reported by AEC
                                                        matches the one given in sIonDaten)
                     _2_PUNKT_TECHNIK              2    2-pnt-technique (kV and mAs given;
                                                        XCU determines mA; generator
                                                        switches off when mAs reached)
                     _3_PUNKT_TECHNIK              3    3-pnt-technique (User determines kV,
                                                        mAs, ms manually)
                     _3_PUNKT_T_MIT_IONT           4    3-pnt-technique using AEC (User
                                                        determines dose as given value, mAs,
                                                        ms as limit; Generator receives
                                                        dose, mAs and ms as limit and will
                                                        turn off X-ray if one of the three
                                                        limits is reached.)
                     MAS_SCHICHTEN                 5    tomo with fixed mAs
                     PLANIIONT                     6    tomo with automatic exposure control
                     PLANIIONT_MIT_MAS             7    tomo with automatic exposure control
                                                        plus a manual limit given by the
                                                        user
                     _1_PUNKT_TECHNIK_RED_STROM    8    1-Pnt Technique with reduced (to 10
                                                        % of nominal value) current, all
                                                        other parameters as in
                                                        1-pnt-technique
                     DR_0_PUNKT_TECHNIK            10   First pulse is done in 1pnt
                                                        technique using AEC (compared to
                                                        dose in sIonDaten).
                                                        Subsequent pulses are done in
                                                        0-pnt-technique using DEXI (compared
                                                        to dose in iDoseRequested).
                     DR_1_PUNKT_TECHNIK            11   1-pnt-technique for DFR (for all
                                                        pulses)
                     DSA_KONSTANTZEIT              12   DR constant time mode, exposure time
                                                        for each acquistion is determined in
                                                        the organ program
                     DR_SCHICHTEN                  13   DR tomo, seen from exposure control
                                                        the same 12
                     PERI_ANGIO_MIT_DR             14   peristepping (acquiring images from
                                                        up to 8 positions of the body with
                                                        automatic run and hold of the stand
                                                        at the positions)
                     PERIVISION_MODE               15   perivision, same a peristepping but
                                                        with supbtractions (two runs, one
                                                        for masking, one for acquiring)
                     CARD_MODE                     16   Card mode, same as 10, but
                                                        regulation is faster and therefore
                                                        not so exact
                     PHLEBOSTEPPING                17   same as 14 but other direction
                                                        (starting from feet and ending at
                                                        pelvis)
                     PHLEBOVISION                  18   same as 15 but other direction
                                                        (starting from feet and ending at
                                                        pelvis)
                     SPINE_RECONSTRUCTION          19   similar to peristepping BUT images
                                                        will be stitched together, so height
                                                        collimators are closed at 5 cm and
                                                        we require 20 to 40 positions
                                                        instead of 8
                     DR_1_PUNKT_TECHNIK_RED_STROM  20   1-pnt-technique with reduced
                                                        current, all other parameters as
                                                        used in 1-.pnt-technique
                     DUAL_ENERGY_HEI               21   Dual Energy technique for Ysio; Used
                                                        for x-ray parameter for the first
                                                        shot
                     DUAL_ENERGY_LEI               22   Dual Energy technique for Ysio; used
                                                        for x-ray parameter for the second
                                                        shot
                     DE_HEI_RED_CURRENT            23   Dual Energy: High Energy Image
                                                        parameters for 1 point with reduced
                                                        current technique.
                     DE_LEI_RED_CURRENT            24   Dual Energy: Low Energy Image
                                                        parameters for 1 point with reduced
                                                        current technique
                     DE_HEI_2_POINT                25   Dual Energy: High Energy Image
                                                        parameters for 2 point technique
                                                        (for future use)
                     DE_LEI_2_POINT                26   Dual Energy: Low Energy Image
                                                        parameters for 2 point technique
                                                        (for future use)
                     SPINE_RECONSTRUCTION_2PT      27   Scan with 2pt technique
                     DFR_2PT_1PT_BSIG_NO_AEC       28   First pulse is done in 2-point
                                                        technique using the given kV/mAs.
                                                        Subsequent pulses are done in
                                                        0-point technique using DEXI.
          Dimension: none


A_POWER_RESET

Object: A_POWER_RESET ___ID: 0432

Description: Request to send the status of power supply switches in power supply unit (e.g.
              generator)
Sender     :   FLC   SCU
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

POWER_SUPPLY_NO number of power supply
          Type:  Byte     (DEC)
          Range: 1 ... 6
                     ACS_PSWITCH_GB_TABLE      1   In GreatBarracuda this relay switches the
                                                   power for the table
                     ACS_PSWITCH_GB_IMGSYS     2   In GreatBarracuda this relay switches the
                                                   power for the image system
                     ACS_PSWITCH_GB_STAND_AIC  3   In GreatBarracuda this relay switches the
                                                   power for the 24V supplies for the AIC
                                                   board as well as for the controllers and
                                                   drives
                     ACS_PSWITCH_GB_DETECTORS  4   In GreatBarracuda this relay switches the
                                                   power for the fixed detector(s)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ADATE

Object: ADATE ___ID: 0BB9

Description: request for date and time, sent from any component to XCU in order to receive
              time from XCU in telegram iDate
Sender     :   ACSOS   CCU-IF   DXP   FLC   GEN-IF   GG_A   KASS-IF   PMS   RAD-STD   SCU
              SCU-IF   SOU-IF   TEST-SW   TUI-IF   XWP
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs
This object has no parameters


AFDAUFNPOS

Object: AFDAUFNPOS ___ID: 02A7

Description: request for the current stand positions of Ysio systems. Necessary to store
              current stand positions in the organ program database of the DFR
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro
This object has no parameters


AINFOCOMP

Object: AINFOCOMP ___ID: 0BD6

Description: requesting version strings of all components currently stored in XCU to be
              sent by XCU in telegram iInfoComp.
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs
This object has no parameters


AISTWERTE

Object: AISTWERTE ___ID: 0019

Description: requesting the component to send current positions and status to the XCU. XCU
              will wait for iIstWerteQuit. XCU will wait for iIstWertequit for several
              seconds, so not sending iIstWertequit on aIstWerte will delay the system boot.
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   SCU-IF   TUI-IF   UGEN   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro
This object has no parameters


AKENNDATEN

Object: AKENNDATEN ___ID: 0009

Description: requesting sw/fw version string of a component sent from XCU to any component.
              The component should answer in iKennDaten with all of its Versions.
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   TUI-IF
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs and XCU_obsolete_IF
This object has no parameters


APASSWORT

Object: APASSWORT ___ID: 0F0B

Description: requesting password for service (sent from any component to XCU). The telegram
              is no longer used to get the password. Only the host-id is transferred via
              aPassWort / iPassWort mechanism, because in most systems the imaging system is
              the host for the password.
              This is used for license key as well as in surgery for compatibility check
              between Trolley and MainUnit (XCU->SCU).
Sender     :   FLC   PMS   UIS   XWP
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro
This object has no parameters


APIDs

<Server IDs>

All Funktionseinheiten:

0010 FLC_TV     second AP ID of FLC, resp for Camera, FD
0010 HIC_IF     interface to HarmonicImageChain (realized in UIS)
0011 SCU        stand control unit
0011 SCU-RFP    Stand Control Unit of Ysio and Lum dTF and Lum dRF
0014 RAD2       stand of RAD2/3 system
                   (which needs to be different from YSIO-SCU in order to get a new band of
                   error numbers)
0015 CCU_A      collimator control unit plane A (i.e. Ysio and Sharpfin)
0016 CCU_B      collimator control unit plane B (and Luminos)
001A UAL        XCS Traffic Logger (in Image System)
001B SMRT_SENS  Smart Sensing Subsystem
001C OPT_TRK    optical tracking module for 3D camera (also called CAM_IC in UIS)
0020 GG_A       Stand Control of Luminos dRF, Omnia, Luminos RF until version VC10
                   SCU-IF towards XCU in LdTF and dRF from VD10 on
0020 RAD-STD    SCU-IF for Ysio, Luminos dTF, dRF and Omnia
0020 DXP        System Control Lithoskop
0021 SM_A       Collimator Control of LdRF (till VC10), Omnia, Luminos RF
                   CCU-IF towards XCU in dTF and dRF (VD10 onwards)
0021 CCU_IF_DTF Interface to CCU-B for collimator in Luminos dTF, dRF and Omnia
0021 CCU_MCU    Collimator (CCU of S1 running on MCU; also used in RAD3)
0022 BD_A       Control Console ("Bedienung") of LdRF (till VC10), Omnia, Luminos RF,
                   Interface to XCU in dTF and dRF(VD10 onwards)
0023 KS_A       Cassette System (CAS of Luminos dTF (Interface to XCU), Luminos RF)
0024 BD_SIR_SX  2. Control Console Luminos RF directly on stand
0028 DCU_MCU    DAP meter control unit running on MCU-HW of surgery system and in Rad3
0029 DCU_SCU    DAP meter control unit running on RADCON board (for Ysio tube)
002A DCU_SCU_2  2nd DAP meter control unit running on RADCON board (for Luminos tube)
002B VDAP       virtual DAP
0030 GG_B       Luminos RF Spotfilm Device Control Console
0031 SM_B       Luminos RF Spotfilm Device Cassette system
0032 BD_B       Luminos RF Spotfilm Device Collimator Control Unit
0033 KS_B       Luminos RF Spotfilm Device Image Intensifier Control unit (Zoom)
003A INO1       reserved for innovations
0048 XWP        workstation e.g. for 3D reco (XWP, former Leonardo)
0050 UGEN       (unified) generator
0050 GEN-IF     Interface from Generator F80/R80/RF/F55 (CAN) to XCU (XCS)
0051 GEN_MOBI   Interface to Mobile Generator
005A TUI_1      TUI 1
005B TUI_2      TUI 2
005C TUI_3      TUI 3
005D TUI_IF     Interface between TUIs and XCU
005E UIP        default AP-ID of user interface platform
0060 REP        reporting system (reporter and event logger)
0061 PMS        service software
0062 ACSOS      monitoring tool ACSOS
0063 ACSOS_2    Test Automation SITA, CRST test system, ACSOS 2
0065 SFS        support functions for PMS
0066 CSF_A      common software functions RTC A
0067 CSF_B      common software functions on RTC B (or on RadCon controller)
0073 TEST-SW    Test Software for CAN2AXCS Telegrams
007E STATE_TEST_1 state control test system (1)
007F STATE_TEST_2 state control test system (2)
0080 RCC        Remote Control Console Luminos RF
0081 RCC2       2nd Remote Control Console Luminos RF
0082 TCC        table control console for Luminos Fusion
0090 VCI        Virtual Can Interface
00E1 CCU_IF     CCU - interface to Ysio/LdTF running on XCU (RFU)
00E2 SCU_IF     SCU - interface to Ysio/LdTF running on XCU (RFU)
00E3 SOU_IF     Stand operating unit - interface to Ysio/LdTF running on XCU
00E4 CS_IF      Cassette system - interface to Ysio/LdTF running on XCU
00E5 EXS_IF     interface to WLAN modules (via SMNP)
00EA VCU        VideoManager Control Unit
00EB LIT_IF     Interface to Modularis - used in surgery
00F0 XCU        X-ray Control Unit (central control unit in RFU and S1 systems)
00F1 SER_PC     service software in RFU systems
00F3 FLC        imaging system Fluorospot Compact
00F3 UIS        Unified Image System
00F4 FLC_SER    for ecom service in RAD3
F000 ALL        all components possible
F001 AXN        AXN Server (axnroot)
FFFF NA         not applicable, for future use, for trial


ASERVBETRIEB

Object: ASERVBETRIEB ___ID: 0BD4

Description: requesting elapsed time of system (working hours) and amount of exposure taken
              on the tube since lifetime (Sent from service PC to XCU) Will be answered by
              iServBetrieb
Sender     :   FLC   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro
This object has no parameters


ASERVINIT

Object: ASERVINIT ___ID: 0BBE

Description: requesting configuration data (sent from Service PC to XCU). XCU will answer
              with iServInit. If 0 is given for the init number all init blocks of this AP
              ID will be sent.
Sender     :   FLC   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

INITKENNUNG number of init block
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ASTRFR

Object: ASTRFR ___ID: 02D0

Description: Request of telegram for enable X-ray. Only used in Luminos Fusion / RF classic
              systems between Stand and Control Console.
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  SharpfinObs
This object has no parameters


ASUCHLAUF

Object: ASUCHLAUF ___ID: 032D

Description: Hereby the collimator requests a search run at the XCU (collimators may loose
              steps while normal operation, therefore they do a search run after some time
              to sync. However search runs do not allow X-ray. So a search can only be
              allowed if the system is idle. Telegram is sent from collimator to XCU. Used
              in Fluoro_II and S1 systems only; in Ysio dTF and dRF the XCU determines point
              of time when a search run is necessary.
Sender     :   SM_A
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs
This object has no parameters


CAN_FILTER

Object: CAN_FILTER ___ID: E800

Description: For Can to AXCS Interface
Sender     :   TEST-SW   VCI
Receiver   :   TEST-SW   VCI
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

SE_CAN_FILTER_ACTION For Can to AXCS Interface: Filter some Can Telegrams.
          Type:  Enum16     (DEC)
          Range: 0 ... 4
                     ACS_SE_CAN_SHOW    0
                     ACS_SE_CAN_SET     1
                     ACS_SE_CAN_GET     2
                     ACS_SE_CAN_ADD     3
                     ACS_SE_CAN_REMOVE  4
          Dimension: none

SE_COUNT_CAN_OBJ_IDS For Can to AXCS Interface: Count the amount of Can Obj Ids which have to be filtered.
          Type:  Dcount     (CNT)
          Range: 0 ... 100
          Dimension: none

{CAN_OBJ_IDS For Can to AXCS Interface: Which object ID has to be filtered.
{          Type:  Word     (HEX)
{          Range: 0x0 ... 0xFFFF
{          Dimension: none


CAN_NMT_MODULE_CONTROL

Object: CAN_NMT_MODULE_CONTROL ___ID: E000

Description: For Can to AXCS Interface.
Sender     :   VCI
Receiver   :   TEST-SW
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


CAN_SYNC

Object: CAN_SYNC ___ID: E080

Description: For Can to AXCS Interface.
Sender     :   VCI
Receiver   :   TEST-SW
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


CLIENT_DATA_RP

Object: CLIENT_DATA_RP ___ID: 9406

Description: reply of client data; sent with MODE = SERVICE (4); must not be in the inlist
Sender     :   AXN
Receiver   :   PMS
Mode       :  SERVICE(04)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

AP_ID application process ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUM_TIME_CNT counter for the dummy time
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: multiple of base

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_OBJECTS number of objects (the axnroot later than VC11E is able to handle max. 600 objects)
          Type:  Dcount     (CNT)
          Range: 0 ... 600
          Dimension: number of data blocks

{OBJECT_ID ID of the object
{          Type:  Word     (HEX)
{          Range: 0x0 ... 0xFFFE
{          Dimension: none


CLIENT_DATA_RQ

Object: CLIENT_DATA_RQ ___ID: 9405

Description: request of client data; has to be sent with MODE = SERVICE (4)
Sender     :   PMS
Receiver   :   AXN
Mode       :  SERVICE(04)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


CONNECTION

Object: CONNECTION ___ID: 9603

Description: connections between servers; is sent with MODE = LCM (6); must not be in the
              inlist
Sender     :   AXN
Receiver   :   PMS   XCU
Mode       :  LCM(06)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

CONNECTION add or remove connection
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ADD_CON  1   add connection of a server
                     ACS_REMOVE   2   remove connection of a server
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_SERVER servers with an own TCP/IP address
          Type:  Dcount     (CNT)
          Range: 0 ... 32
          Dimension: none

{SERVER_ID ID of axcs server.
110 till 119 reserved for SP applications
{          Type:  Enum8     (DEC)
{          Range: 1 ... 255
{                       ACS_SERV_ECC_1      5     ECC 1 or TUI 1
{                       ACS_SERV_ECC_2      6     ECC 2 or TUI 2
{                       ACS_SERV_ECC_3      7     ECC 3 or TUI 3
{                       ACS_SERV_WS         11    workstation
{                       ACS_SERV_VOICE      12    voice control
{                       ACS_SERV_UGEN       13    unified generator (unfortunately colliding
{                                                 with Kojen-PCs (ACS_SERV_TEST1))
{                       ACS_SERV_TEST_2     14    CRST testautomat, Factory test PC, ACSOS2,
{                                                 ALCIP, XCU TestSystem
{                       ACS_SERV_WS2        19    2. workstation, Carto XP, Carto 3
{                       ACS_SERV_WSHW       20    Workstation HW (AXBP)
{                       ACS_SERV_XCU        24    XCU in RFU systems
{                       ACS_SERV_UIS        25    UIS in XP systems
{                       ACS_SERV_STAND      26    Stand in RFU systems or system control DXP
{                                                 in Lithoskop
{                       ACS_SERV_TEST_4     28    test station 4 in RFU systems
{                       ACS_SERV_STREAM     80    camera streaming device
{                       ACS_SERV_CVC        82    CVC board (Jetson Nano) as part of Smart
{                                                 Sensing Subsystem
{                       ACS_SERV_ECC_DEF    100   default address, not used in a running
{                                                 system
{                       ACS_SERV_VIDEO_MGR  111   Video Manager, video switch to show 3rd
{                                                 party applications in Urology and Surgery
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


DUMMY_MSG

Object: DUMMY_MSG ___ID: 9204

Description: dummy message; is sent with MODE = MESSAGE (2); must not be in the inlist
Sender     :   AXN
Receiver   :   ALL
Mode       :  MESSAGE(02)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ERR_INFO

Object: ERR_INFO ___ID: 9501

Description: error message of a server; sent with MODE = ERROR (5); must not be in the
              inlist. It is also axn internally used as an acknowledge.
Sender     :   AXN
Receiver   :   FLC   UIS   XCU
Mode       :  ERROR(05)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

TIME seconds since January 1st 1970; ACS_LNIL if the time is not available
note that this is in local time since this is the "logging time" (and many subsystems do only have this time)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: sec

ERR_MSG_ID ID of an error message
Values are 32 bit values laid out as follows:

 3 3 2 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1
 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
+---+-+-+-----------------------+-------------------------------+
|Sev|C|R|     Facility          |               Code            |
+---+-+-+-----------------------+-------------------------------+
where
  Sev - is the severity code
        (00-success,01-Info,10-warning,11-error)
  C - is the Customer code flag
  R - is a reserved bit
  Facility - is the facility code (8=CSA, C=relevant)
  Code - is the facility's status code (error number)
          Type:  Dword     (HEX)
          Range: 0x0 ... 0xFFFFFFFF
          Dimension: none

ACK_MSG error already sent to error logger
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_MSG_NOT_SEND_TO_LOG  0   err_info not yet send to error logger
                                                  client
                     ACS_MSG_SEND_TO_LOG      1   err_info was send to error logger client,
                                                  axnroot removes it from the internal queue
          Dimension: none

AP_ID application process ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

LOSTR_ERR_INFO length of the string in the object ERR_INFO
          Type:  Dcount     (CNT)
          Range: 0 ... 80
          Dimension: count of elements

{ETXT internal error text, variable length, 1 char UNICODE
{          Type:  String16 [ 1 ]     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


ERROR_MSG

Object: ERROR_MSG ___ID: 9201

Description: Error message of a server to a client; is sent with MODE = MESSAGE (2); must
              not be in the inlist.
              This telegram is sent as soon as a component sends an indirect telegram that
              is not in the inlist of any component.
Sender     :   AXN
Receiver   :   ACSOS   ALL
Mode       :  MESSAGE(02)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SERV_ERR kind of error
          Type:  Enum8     (DEC)
          Range: 0 ... 0
                     ACS_NO_TARGET  0
          Dimension: none

OBJECT_ID ID of the object
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: none


ERRORLOG_OFF

Object: ERRORLOG_OFF ___ID: 2914

Description: withdrawing of the error logger; sent with MODE = ERROR (5)
Sender     :   ACSOS   REP
Receiver   :   AXN
Mode       :  ERROR(05)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


ERRORLOG_ON

Object: ERRORLOG_ON ___ID: 2913

Description: registration of the error logger; sent with MODE = ERROR (5)
Sender     :   ACSOS   REP
Receiver   :   AXN
Mode       :  ERROR(05)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


I3DPARAMS

Object: I3DPARAMS ___ID: 101C

Description: Transfers actual 3D parameters (e.g. current start position) from XCU to Image
              System
Sender     :   XCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TRAJCT_START_POSITION Start position of the trajectory. The direction depends on the trajectory itself (e.g. height for upright trajectories)
This parameter is also put into DICOM to match the nearest calibration position.
          Type:  Dword     (DEC)
          Range: 0 ... 200000
          Dimension: 0.1mm

CERA_VOL_ROT_A rotation angle of reconstructed volume (depends on trajectory)
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1°

CERA_VOL_ROT_B rotation angle of reconstructed volume (depends on trajectory)
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1°

CERA_VOL_ROT_C rotation angle of reconstructed volume (depends on trajectory)
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1°

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


I_POWER_RESET

Object: I_POWER_RESET ___ID: 0433

Description: actual status of the power supply of the FD. It shall be sent upon request by
              A_POWER_RESET and anytime the status has been changed.
              Not used in surgery systems.
Sender     :   GEN-IF   UGEN
Receiver   :   FLC   SCU   UIS   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

POWER_SUPPLY_NO number of power supply
          Type:  Byte     (DEC)
          Range: 1 ... 6
                     ACS_PSWITCH_GB_TABLE      1   In GreatBarracuda this relay switches the
                                                   power for the table
                     ACS_PSWITCH_GB_IMGSYS     2   In GreatBarracuda this relay switches the
                                                   power for the image system
                     ACS_PSWITCH_GB_STAND_AIC  3   In GreatBarracuda this relay switches the
                                                   power for the 24V supplies for the AIC
                                                   board as well as for the controllers and
                                                   drives
                     ACS_PSWITCH_GB_DETECTORS  4   In GreatBarracuda this relay switches the
                                                   power for the fixed detector(s)
          Dimension: none

POWER_SUPPLY_STATUS actual status of power supply
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IACSS

Object: IACSS ___ID: 01B7

Description: XCU informs if ACSS is possible (for YSIO) and tells in Bit-Array the reason,
              why ACSS is not possible. The information is used by TUI. SCU is informed via
              ST_STPAR about ACSS (Automatic collimation size sensing) is possible.
Sender     :   XCU
Receiver   :   CCU-IF   SCU-IF   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ACSS Information if ACSS is possible; sent from stand to XCU (SH_STPAR_RFP); XCU then distributes (iACSS)
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ACSS_OFF      0   ACSS is not possible.
                     ACS_ACSS_ON       1   ACSS is possible.
                     ACS_ACSS_ORTHO    2   This shall be used if ortho start position is
                                           reached, and user wants to perform collimation.
                                           In this case ACSS shall be enabled towards CCU
                                           even though central beam might currently not hit
                                           the detector.
                     ACS_ACSS_OBLIQUE  3   oblique position; fluoro shall be possible,
                                           collimation shall be adapted but measuring fields
                                           shall be on manual
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACSS_CONDITIONS Only for developers: which conditions for ACSS are true (=1) or false (=0).
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_ACSS_FD_AVAILABLE       0x0001 Is a target available in the current
                                                        system?
                     ACS_ACSS_SYSTEM_READY       0x0002 Is current system ready?
                     ACS_ACSS_SID_VALID          0x0004 Is the SID value valid?
                     ACS_ACSS_SID_SUFFICIENT     0x0008 Is the SID value sufficient (large
                                                        enough)?
                     ACS_ACSS_ANGLE_A_RIGHT      0x0010 Is the alpha beam angle righted?
                     ACS_ACSS_ANGLE_B_RIGHT      0x0020 Is the beta beam angle righted?
                     ACS_ACSS_POSITION_X         0x0040 Is the beam X position inside of the
                                                        detector?
                     ACS_ACSS_POSITION_Y         0x0080 Is the beam Y position inside of the
                                                        detector?
                     ACS_ACSS_NOT_ROTATED        0x0100 Is the image not rotated relative to
                                                        the patient?
                     ACS_ACSS_BEAM_HITS          0x0200 Does the central beam hit the
                                                        detector?
                     ACS_ACSS_NO_TRACKING        0x0400 Not used, always set. (Kept for
                                                        version compatibility)
                     ACS_ACSS_TUBE_NOT_VERT_ROT  0x0800 Is tube vertical rotation not
                                                        greater than 3 degrees?
                                                        (within all perpendicular
                                                        rotations,
                                                        i.e. ( abs(rotation) + 3 ) % 90 ) <=
                                                        6)
                     ACS_ACSS_NOT_DECENTERED     0x1000 Is the beam not decentered, or
                                                        decentered ACSS is not disabled?
                     ACS_ACSS_COLL_NOT_CALIBR    0x2000 Is collimator calibration not in
                                                        progress?
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IALLGANZ

Object: IALLGANZ ___ID: 0099

Description: general stati (pressure switch of tube pressure and door switch) of system,
              sent by XCU for displays
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and Sharpfin

List of Parameters:

ADRUCKSCH oil pressure switch of tube housing
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     KEIN_DRUCK  1
                     DRUCK       2
          Dimension: none

ATUERKON room door status
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     TUER_GESCHLOSSEN  1
                     TUER_OFFEN        2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IANLBEREIT

Object: IANLBEREIT ___ID: 025D

Description: ready status for fluoro and acquisition, sent from XCU. The acq status is used
              to control the checkmark in status line of the ImgSys and the colour of the
              TUI status line.Only 1 (ready) sets checkmark and colour=green.
Sender     :   XCU
Receiver   :   CCU-IF   FLC   RAD-STD   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

ANLAUFNBEREIT Status of exposure condition in the system
          Type:  Byte     (DEC)
          Range: 0 ... 29
                     NEIN                           0    no
                     JA                             1    yes
                     COLLIMATOR_NOT_READY           2    System not ready because collimator
                                                         is not ready.
                     GRID_NOT_READY                 3    System not ready because grid is
                                                         not ready.
                     FILTER_NOT_READY               4    System not ready because filter is
                                                         not ready.
                     BETRIEBSART_NOT_ALLOWED        5    System not ready because
                                                         acquisition system is not allowed.
                     DOOR_OPEN                      6    System not ready because door is
                                                         open.
                     ASU_STATUS_NOT_READY           7    System not ready because ASUStatus
                                                         is not ready.
                     DFR_STATUS_NOT_READY           8    System not ready because DFRStatus
                                                         is not ready.
                     DETEKTOR_STATUS_NOT_READY      9    System not ready because Detector
                                                         Status is not ready.
                     CASSETTE_STATUS_NOT_READY      10   System not ready for acquisition
                                                         because KassStatus is not ready.
                     XRAY_DISABLE_SWITCH_NOT_READY  11   System not ready because x-ray
                                                         disable switch is activated.
                     ORGAN_PROGRAM_NOT_READY        12   System not ready for acquisition
                                                         because no organ program is
                                                         selected.
                     DAP_NOT_READY                  13   System not ready because Dose Area
                                                         Product for this patient is
                                                         complete.
                     WW_NOT_READY                   14   System not ready because water
                                                         value is not ready.
                     AUFNGENSTATUS_NOT_READY        15   System not ready for acquisition
                                                         because generator is not ready.
                     LIMITSTATUS_NOT_READY          16   System not ready because Limit is
                                                         not ready.
                     MAIN_CONTACT_NOT_READY         17   System not ready because main
                                                         contact was pressed during startup
                                                         and was not reset.
                     PRE_CONTACT_NOT_READY          18   System not ready because precontact
                                                         was pressed during startup and was
                                                         not reset.
                     ERROR_NOT_CONFIRMED            19   System not ready because an error
                                                         was not confirmed yet.
                     PRESSURE_SWITCH_NOT_READY      20   System not ready because the
                                                         pressure switch is not ready.
                     INTERMEDIATE_SID_POSITION      21   SID between two allowed positions
                     MEASURING_FIELDS_NOT_READY     22   System not ready because measuring
                                                         fields are not ready.
                     INVALID_SW_VERSIONS            23   PMS detected invalid SW Versions in
                                                         System.
                     INVALID_CONFIG                 24   PMS detected invalid configuration.
                     CALIB_SWITCH_ON                25   No Acquisition possible because
                                                         calib switch is activated.
                     ANL_ORTHO_UI_NOT_IN_STEP_1     26   The Ortho UI (on ImgSys) is not in
                                                         step 1; therefore the latest
                                                         iOrgDaten being distributed was not
                                                         the one to be used for next shot
                                                         (because acq will start with step 1
                                                         always)
                     SCANNING_REQUIRES_FLUORO       27   for peri scanning it is required to
                                                         make a fluoro before an acquisition
                                                         can be made.
                     STAND_MOVING                   28
                     DFR_SERIES_REQUIRES_FLUORO     29   in case there is no AEC chamber (or
                                                         one that is only good for RAD as in
                                                         G1) it is required to make a fluoro
                                                         before an acquisition can be made.
          Dimension: none

ANLDLBEREIT Status of fluoro condition in the system
          Type:  Byte     (DEC)
          Range: 0 ... 26
                     NEIN                           0    no
                     JA                             1    yes
                     COLLIMATOR_NOT_READY           2    System not ready because collimator
                                                         is not ready.
                     GRID_NOT_READY                 3    System not ready because grid is
                                                         not ready.
                     FILTER_NOT_READY               4    System not ready because filter is
                                                         not ready.
                     BETRIEBSART_NOT_ALLOWED        5    System not ready because
                                                         acquisition system is not allowed.
                     DOOR_OPEN                      6    System not ready because door is
                                                         open.
                     ASU_STATUS_NOT_READY           7    System not ready because ASUStatus
                                                         is not ready.
                     DFR_STATUS_NOT_READY           8    System not ready because DFRStatus
                                                         is not ready.
                     DETEKTOR_STATUS_NOT_READY      9    System not ready because Detector
                                                         Status is not ready.
                     CASSETTE_STATUS_NOT_READY      10   System not ready for acquisition
                                                         because KassStatus is not ready.
                     XRAY_DISABLE_SWITCH_NOT_READY  11   System not ready because x-ray
                                                         disable switch is activated.
                     FLUORO_PROGRAM_NOT_READY       12   System not ready for fluoro because
                                                         fluoro program is not ready.
                     DAP_NOT_READY                  13   System not ready because Dose Area
                                                         Product for this patient is
                                                         complete.
                     WW_NOT_READY                   14   System not ready because water
                                                         value is not ready.
                     DLGENSTATUS_NOT_READY          15   System not ready for fluoro because
                                                         generator is not ready.
                     LIMITSTATUS_NOT_READY          16   System not ready because Limit is
                                                         not ready.
                     MAIN_CONTACT_NOT_READY         17   System not ready because main
                                                         contact was pressed during startup
                                                         and was not reset.
                     PRE_CONTACT_NOT_READY          18   System not ready because precontact
                                                         was pressed during startup and was
                                                         not reset.
                     ERROR_NOT_CONFIRMED            19   System not ready because an error
                                                         was not confirmed yet.
                     PRESSURE_SWITCH_NOT_READY      20   System not ready because the
                                                         pressure switch is not ready.
                     INTERMEDIATE_SID_POSITION      21   SID between two allowed positions
                     MEASURING_FIELDS_NOT_READY     22   System not ready because measuring
                                                         fields are not ready.
                     INVALID_SW_VERSIONS            23   PMS detected invalid SW Versions in
                                                         System.
                     INVALID_CONFIG                 24   PMS detected invalid configuration.
                     CALIB_SWITCH_ON                25   No Acquisition possible because
                                                         calib switch is activated.
                     ANL_ORTHO_UI_NOT_IN_STEP_1     26   The Ortho UI (on ImgSys) is not in
                                                         step 1; therefore the latest
                                                         iOrgDaten being distributed was not
                                                         the one to be used for next shot
                                                         (because acq will start with step 1
                                                         always)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IANLBEREIT2

Object: IANLBEREIT2 ___ID: 0257

Description: system status
Sender     :   XCU
Receiver   :   SCU-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

SYS_STATE_COLOR status of the system for display
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_STATE_NEUTRAL         0   the system is up and running (w/o error)
                                                   but not ready for x-ray
                     ACS_STATE_READY_FOR_XRAY  1   the system is ready to x-ray as soon as a
                                                   release button is pressed
                     ACS_STATE_WARNING         2   the system is currently not ready for
                                                   exposure but needs some user action
                                                   (there is a warning/error pending)
                     ACS_STATE_ERROR           3   the system is not ready for x-ray and
                                                   full functionality cannot be restored by
                                                   a user action
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANLAUFNBEREIT Status of exposure condition in the system
          Type:  Byte     (DEC)
          Range: 0 ... 29
                     NEIN                           0    no
                     JA                             1    yes
                     COLLIMATOR_NOT_READY           2    System not ready because collimator
                                                         is not ready.
                     GRID_NOT_READY                 3    System not ready because grid is
                                                         not ready.
                     FILTER_NOT_READY               4    System not ready because filter is
                                                         not ready.
                     BETRIEBSART_NOT_ALLOWED        5    System not ready because
                                                         acquisition system is not allowed.
                     DOOR_OPEN                      6    System not ready because door is
                                                         open.
                     ASU_STATUS_NOT_READY           7    System not ready because ASUStatus
                                                         is not ready.
                     DFR_STATUS_NOT_READY           8    System not ready because DFRStatus
                                                         is not ready.
                     DETEKTOR_STATUS_NOT_READY      9    System not ready because Detector
                                                         Status is not ready.
                     CASSETTE_STATUS_NOT_READY      10   System not ready for acquisition
                                                         because KassStatus is not ready.
                     XRAY_DISABLE_SWITCH_NOT_READY  11   System not ready because x-ray
                                                         disable switch is activated.
                     ORGAN_PROGRAM_NOT_READY        12   System not ready for acquisition
                                                         because no organ program is
                                                         selected.
                     DAP_NOT_READY                  13   System not ready because Dose Area
                                                         Product for this patient is
                                                         complete.
                     WW_NOT_READY                   14   System not ready because water
                                                         value is not ready.
                     AUFNGENSTATUS_NOT_READY        15   System not ready for acquisition
                                                         because generator is not ready.
                     LIMITSTATUS_NOT_READY          16   System not ready because Limit is
                                                         not ready.
                     MAIN_CONTACT_NOT_READY         17   System not ready because main
                                                         contact was pressed during startup
                                                         and was not reset.
                     PRE_CONTACT_NOT_READY          18   System not ready because precontact
                                                         was pressed during startup and was
                                                         not reset.
                     ERROR_NOT_CONFIRMED            19   System not ready because an error
                                                         was not confirmed yet.
                     PRESSURE_SWITCH_NOT_READY      20   System not ready because the
                                                         pressure switch is not ready.
                     INTERMEDIATE_SID_POSITION      21   SID between two allowed positions
                     MEASURING_FIELDS_NOT_READY     22   System not ready because measuring
                                                         fields are not ready.
                     INVALID_SW_VERSIONS            23   PMS detected invalid SW Versions in
                                                         System.
                     INVALID_CONFIG                 24   PMS detected invalid configuration.
                     CALIB_SWITCH_ON                25   No Acquisition possible because
                                                         calib switch is activated.
                     ANL_ORTHO_UI_NOT_IN_STEP_1     26   The Ortho UI (on ImgSys) is not in
                                                         step 1; therefore the latest
                                                         iOrgDaten being distributed was not
                                                         the one to be used for next shot
                                                         (because acq will start with step 1
                                                         always)
                     SCANNING_REQUIRES_FLUORO       27   for peri scanning it is required to
                                                         make a fluoro before an acquisition
                                                         can be made.
                     STAND_MOVING                   28
                     DFR_SERIES_REQUIRES_FLUORO     29   in case there is no AEC chamber (or
                                                         one that is only good for RAD as in
                                                         G1) it is required to make a fluoro
                                                         before an acquisition can be made.
          Dimension: none

ANLDLBEREIT Status of fluoro condition in the system
          Type:  Byte     (DEC)
          Range: 0 ... 26
                     NEIN                           0    no
                     JA                             1    yes
                     COLLIMATOR_NOT_READY           2    System not ready because collimator
                                                         is not ready.
                     GRID_NOT_READY                 3    System not ready because grid is
                                                         not ready.
                     FILTER_NOT_READY               4    System not ready because filter is
                                                         not ready.
                     BETRIEBSART_NOT_ALLOWED        5    System not ready because
                                                         acquisition system is not allowed.
                     DOOR_OPEN                      6    System not ready because door is
                                                         open.
                     ASU_STATUS_NOT_READY           7    System not ready because ASUStatus
                                                         is not ready.
                     DFR_STATUS_NOT_READY           8    System not ready because DFRStatus
                                                         is not ready.
                     DETEKTOR_STATUS_NOT_READY      9    System not ready because Detector
                                                         Status is not ready.
                     CASSETTE_STATUS_NOT_READY      10   System not ready for acquisition
                                                         because KassStatus is not ready.
                     XRAY_DISABLE_SWITCH_NOT_READY  11   System not ready because x-ray
                                                         disable switch is activated.
                     FLUORO_PROGRAM_NOT_READY       12   System not ready for fluoro because
                                                         fluoro program is not ready.
                     DAP_NOT_READY                  13   System not ready because Dose Area
                                                         Product for this patient is
                                                         complete.
                     WW_NOT_READY                   14   System not ready because water
                                                         value is not ready.
                     DLGENSTATUS_NOT_READY          15   System not ready for fluoro because
                                                         generator is not ready.
                     LIMITSTATUS_NOT_READY          16   System not ready because Limit is
                                                         not ready.
                     MAIN_CONTACT_NOT_READY         17   System not ready because main
                                                         contact was pressed during startup
                                                         and was not reset.
                     PRE_CONTACT_NOT_READY          18   System not ready because precontact
                                                         was pressed during startup and was
                                                         not reset.
                     ERROR_NOT_CONFIRMED            19   System not ready because an error
                                                         was not confirmed yet.
                     PRESSURE_SWITCH_NOT_READY      20   System not ready because the
                                                         pressure switch is not ready.
                     INTERMEDIATE_SID_POSITION      21   SID between two allowed positions
                     MEASURING_FIELDS_NOT_READY     22   System not ready because measuring
                                                         fields are not ready.
                     INVALID_SW_VERSIONS            23   PMS detected invalid SW Versions in
                                                         System.
                     INVALID_CONFIG                 24   PMS detected invalid configuration.
                     CALIB_SWITCH_ON                25   No Acquisition possible because
                                                         calib switch is activated.
                     ANL_ORTHO_UI_NOT_IN_STEP_1     26   The Ortho UI (on ImgSys) is not in
                                                         step 1; therefore the latest
                                                         iOrgDaten being distributed was not
                                                         the one to be used for next shot
                                                         (because acq will start with step 1
                                                         always)
          Dimension: none


IASUSTATUS

Object: IASUSTATUS ___ID: 0276

Description: status for DFR (ASU=acquisition sync unit), sent from DFR to XCU. Similar to
              iDFRStatus. iASUStatus is dynamic status that may be changed while X-ray or
              X-ray preparation is running to sync, iDFRStatus is static - no Xray prep if
              iDFRStatus is not true.
Sender     :   FLC   HIC_IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DFRAUFNBEREIT DFR is ready for exposure or the reason, why DFR is not ready for exposure
(note: just 1 and 19 are "ready")
          Type:  Byte     (DEC)
          Range: 0 ... 38
                     NEIN                            0    no
                     JA                              1    yes
                     NO_PATIENT                      2    DFR not ready because no patient
                                                          is selected
                     NO_IMAGE_MEMORY                 3    DFR not ready because there is not
                                                          enough image memory available
                     SERVICE_MODE_                   4    DFR not ready because it is in
                                                          service mode.
                     FD_ERROR_                       5    DFR not ready because there is an
                                                          Detector error.
                     FLC_ON_ERROR                    6    DFR not ready because there is an
                                                          error concerning the ImageSystem
                     ACQ_BLOCKED_BY_HIPAA            7    DFR is not ready because it is
                                                          blocked by HIPAA
                     NO_OGP_SELECTED                 8    DFR is not ready because no OGP
                                                          has been selected.
                     FD_RECOVERING                   9    DFR is not ready because the FD is
                                                          recovering.
                     FD_TOO_HOT                      11   DFR is not ready because the
                                                          Detector is too hot.
                     NO_XRAY_BEC_FOLDER_PROTECTED    12   DFR not ready because the
                                                          patient's folder is closed.
                     FLC_IN_DOC_MODE                 13   ImageSystem is in Documentation
                                                          mode
                     FLC_IN_POSTPROC_MODE            14   ImageSystem is in post processing
                                                          mode
                     FD_OFFSET_IN_PROGRESS           15   FD offset is in progress
                     FD_WLAN_TOO_LOW                 16   For Ysio: WLAN power is too low
                                                          for acquisition.
                     FLC_BLOCKING_DIALOG_OPEN        17   a blocking operation is active at
                                                          ImgSys (e.g. Exam Manager or other
                                                          dialog)
                     FD_BATTERY_TOO_LOW              18   Battery of mobile detector is too
                                                          low for Acquisition.
                     LOW_BATT_ACQ_POSSIBLE           19   Battery of wireless FD is low but
                                                          acquisition still possible (for
                                                          future use)
                     FD_NOT_IN_OP_STATE              20   Detector not in operating state
                     FD_CONFG_OUT                    21   Detector configured out
                     FD_IMG_RECOV                    22   Detector image recovery in
                                                          progress
                     NO_FD_CABLE_FOR_ORTHO           23   wi-D BK cable not connected for
                                                          Ortho acquisition
                     DFR_ORTHO_UI_NOT_IN_STEP_1      24   The Ortho UI (on ImgSys) is not in
                                                          step 1; therefore the latest
                                                          iOrgDaten being distributed was
                                                          not the one to be used for next
                                                          shot (because acq will start with
                                                          step 1 always
                     FLC_IN_COMPOSING_MODE           25   no fluoro or acquisition possible
                                                          since ImgSys is in ortho composing
                                                          mode
                     FLC_NO_IMAGE_PARTITION          26   no image partition is available
                                                          (service ongoing)
                     DROC_IQAP_IMG_RECEIVED          27   DROC has received and saved the
                                                          exposure image successfully when
                                                          performing IQAP acquisition (used
                                                          in RAD3 VA10 only)
                     DROC_IN_VIEW_MODE               32   DROC is in view mode (used in
                                                          RAD3)
                     DROC_IN_PRINT_MODE              33   DROC is in print mode (used in
                                                          RAD3)
                     AUTO_ORTHO_RANGE_NOT_CONFIRMED  37   The ortho range being
                                                          automatically determined by camera
                                                          image and AI software has not been
                                                          confirmed by user
                     IN_ORTHO_STITCHING_MODE         38   DROC is in ortho stiching mode
                                                          (used in RAD3)
          Dimension: none

DFRDLBEREIT DFR ready for fluoro or the reason why it is not ready
(note: just 1 and 19 are "ready")
          Type:  Byte     (DEC)
          Range: 0 ... 26
                     NEIN                          0    no
                     JA                            1    yes
                     NO_PATIENT                    2    DFR not ready because no patient is
                                                        selected
                     NO_IMAGE_MEMORY               3    DFR not ready because there is not
                                                        enough image memory available
                     SERVICE_MODE_                 4    DFR not ready because it is in
                                                        service mode.
                     FD_ERROR_                     5    DFR not ready because there is an
                                                        Detector error.
                     FLC_ON_ERROR                  6    DFR not ready because there is an
                                                        error concerning the ImageSystem
                     ACQ_BLOCKED_BY_HIPAA          7    DFR is not ready because it is
                                                        blocked by HIPAA
                     NO_OGP_SELECTED               8    DFR is not ready because no OGP has
                                                        been selected.
                     FD_RECOVERING                 9    DFR is not ready because the FD is
                                                        recovering.
                     NO_FLUORO_RAD_MODE_SELECTED   10   DFR not ready for fluoro because rad
                                                        mode is selected.
                     FD_TOO_HOT                    11   DFR is not ready because the
                                                        Detector is too hot.
                     NO_XRAY_BEC_FOLDER_PROTECTED  12   DFR not ready because the patient's
                                                        folder is closed.
                     FLC_IN_DOC_MODE               13   ImageSystem is in Documentation mode
                     FLC_IN_POSTPROC_MODE          14   ImageSystem is in post processing
                                                        mode
                     FD_OFFSET_IN_PROGRESS         15   FD offset is in progress
                     FD_WLAN_TOO_LOW               16   For Ysio: WLAN power is too low for
                                                        acquisition.
                     FLC_BLOCKING_DIALOG_OPEN      17   a blocking operation is active at
                                                        ImgSys (e.g. Exam Manager or other
                                                        dialog)
                     FD_BATTERY_TOO_LOW            18   Battery of mobile detector is too
                                                        low for Acquisition.
                     LOW_BATT_ACQ_POSSIBLE         19   Battery of wireless FD is low but
                                                        acquisition still possible (for
                                                        future use)
                     FD_NOT_IN_OP_STATE            20   Detector not in operating state
                     FD_CONFG_OUT                  21   Detector configured out
                     FD_IMG_RECOV                  22   Detector image recovery in progress
                     NO_FD_CABLE_FOR_ORTHO         23   wi-D BK cable not connected for
                                                        Ortho acquisition
                     DFR_ORTHO_UI_NOT_IN_STEP_1    24   The Ortho UI (on ImgSys) is not in
                                                        step 1; therefore the latest
                                                        iOrgDaten being distributed was not
                                                        the one to be used for next shot
                                                        (because acq will start with step 1
                                                        always
                     FLC_IN_COMPOSING_MODE         25   no fluoro or acquisition possible
                                                        since ImgSys is in ortho composing
                                                        mode
                     FLC_NO_IMAGE_PARTITION        26   no image partition is available
                                                        (service ongoing)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IAUFNDATEN

Object: IAUFNDATEN ___ID: 02C4

Description: exposure data of the last taken exposure measured by the X-ray generator, sent
              from generator to XCU. The parameter ANFMA is not in use in F80 because
              generator does not send this data via CAN.
Sender     :   GEN-IF   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

MASIST mAs value of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 100500
          Dimension: 0.01 mAs

MSIST duration of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

ANFMA the current, the last exposure has been started with. Current may fall during exposure depending on selected technique
          Type:  Integer16     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA

EP_SUM_ACT current operation point of dose regulation (water value in EP)
          Type:  Integer16     (DEC)
          Range: 0 ... 4000
          Dimension: 1/16 EP

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

PULSE amount of pulses combined in this telegram (this is used if frame rate is too high to send a separate telegram for each pulse)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IAUFNSTATUS

Object: IAUFNSTATUS ___ID: 02C8

Description: status of generator for exposure, sent from generator to XCU. The generator
              may send a "0" in case of an error, alter the tube or when filament is warming
              up.
Sender     :   GEN-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and Sharpfin

List of Parameters:

AUFNBEREIT ready for exposure
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IAUFNZANZ

Object: IAUFNZANZ ___ID: 0084

Description: Counter of free exposures for cassettes. Film cassette may be used for more
              than on subdivision. This telegram will tell the relation between
              unexposed/exposed cassette subdivisions, sent from XCU to displays
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

FRAUFN how many exposures are unexposed (to be used) on this film
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BELAUFN how many exposures are already exposed on this film in cassette mode
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBEDPOWERREQ

Object: IBEDPOWERREQ ___ID: 00A8

Description: Status for Shutdown request, if DFR-system controls the power supply of the
              rest of the X-ray system, sent from XCU to DFR
Sender     :   XCU
Receiver   :   FLC
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

SHOW_POWERDOWN Status of shutdown sequence
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     IN_ARBEIT           1   in progress
                     BEENDET             2   cancelled
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBETRIEBSART

Object: IBETRIEBSART ___ID: 019B

Description: X-ray mode the stand is in, sent from stand/gantry to XCU. The status of stand
              is requested by XCU using sBetriebsart and determines the target. The stand
              tells XCU ready or a reason why the stand is not ready.
Sender     :   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BETRIEBSART Exposure mode
          Type:  Byte     (DEC)
          Range: 1 ... 10
                     NORMALBETRIEB    1    normal mode (cassette or film mode)
                     SCHICHTBETRIEB   2    tomo
                     DFR_AUFNAHME     3    DFR acquisition (=HW triggered regardless whether
                                           image intensifier or FD is used)
                     DFR_SCHICHTEN    4    DFR Tomo, HW-triggered TOMO and FD Tomo (although
                                           FD Tomo is not HW triggered)
                     PERIPHERE_ANGIO  5    Peristepping
                     DSA_ANGIO        6    Perivision
                     ORTHO_LONGLEG    7    Ortho mode in FD
                     DR_LITHO         8    Litho mode like DFR but with cross hair in image
                     DUAL_ENERGY      9    Dual Energy technique for Ysio
                     RUN_3D           10   acquisition of 3D volume (used in G1)
                                           (similar to DFR series, but different WW
                                           calculation)
          Dimension: none

TARGET target for the exposure (RFU only)
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     BILDVERSTAERKER     0   fixed FD (or image intensifier)
                     FREIEAUFNAHME       1   free exposure
                     RASTERWANDGERAET    2   bucky wall stand
                     KATAPULTRASTERLADE  3   KRL
                     ZIELGERAET          4   spotfilm device
          Dimension: none

BASTATUS status of the component for current X-ray mode
          Type:  Byte     (DEC)
          Range: 1 ... 30
                     BEREIT                          1
                     NICHT_BEREIT                    2
                     BEREIT_FUER_DL                  3
                     ACS_NOT_READY_MOVE_BUTTON       4    Stand not ready, can be solved by
                                                          pressing move button.
                     ACS_BEAM_DOES_NOT_HIT_TARGET    5    Stand not ready because beam does
                                                          not hit the target at all
                     ACS_SID_INTERMEDIATE            6    Stand not ready because SID is in
                                                          intermediate position.
                     ACS_TUBE_PIVOTED                7    Stand is not ready because tube is
                                                          pivoted.
                     ACS_STAND_TILTED_NO_PERI        8    Stand not ready for peri because
                                                          it is tilted.
                     ACS_STAND_IN_COLLISION          9    Stand not ready because it is in
                                                          collision position.
                     ACS_TUBE_IN_PARK_POSITION       10   under table system not ready
                                                          because tube is in park position.
                     ACS_STAND_NOT_IN_STARTPOSITION  11   Stand not ready for Tomo because
                                                          it has not reached start position.
                     ACS_CASS_INSTEAD_OF_DET         12   Target Detector is chosen but
                                                          Cassette is in Tray.
                                                          Note: this value is no longer in
                                                          use.
                     ACS_DETECTOR_UNLOADED           13   Detector is not in tray. Sent from
                                                          SCU Interface to XCU.
                     ACS_ORTHO_RANGE_NOT_DEFINED     14   range for ortho acquisition has
                                                          not been defined yet
                     ACS_COLLIMATION_GREATER_FD_SIZ  15   at least one pair of collimator
                                                          blades' opening is larger than the
                                                          defined FD detector area
                     ACS_INVALID_ORTHO_STARTPOS      16   invalid ortho start position / pos
                                                          in OGP not for ortho
                     ACS_BEAM_DOES_NOT_HIT_CHAMBER   17   Stand not ready because beam does
                                                          not hit the iontomat chamber.
                     ACS_DETECTOR_IN_PARK_POSITION   18   detector (of Luminos dTF) is in
                                                          park position; thus fluoro is not
                                                          allowed
                     ACS_TUBE_NOT_IN_PARK_POSITION   19   fluoro system not ready since rad
                                                          tube is not in park position
                     ACS_3D_TRAJECTORY_SELECTED      20
                     ACS_3D_TRAJ_START_POS           21
                     ACS_3D_TRAJ_TEST_RUN            22
                     ACS_3D_END_POS_REACHED          23
                     ACS_3D_COLLISION_CHECKED        24
                     ACS_3D_SCAN_RUNNING             25
                     ACS_STD_ACSS_OFF                26
                     ACS_3D_TRAJ_ABORTED             27
                     ACS_3D_START_POS_REACHED        28
                     ACS_3D_TRAJ_SCAN_COMPLETE       29
                     ACS_3D_GOTO_TRANSFER_POS        30
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBEWEGUNG2

Object: IBEWEGUNG2 ___ID: 019A

Description: The stand tells the XCU the movement or position of one or more of its drives.
              Some special positions are only told as boolean, such as SID is in an
              intermediate position.
              (enhanced iBewegung in order to transfer several axes at a time to reduce AXCS
              traffic)
Sender     :   SCU-IF
Receiver   :   XCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTANZAHL amount of actions
          Type:  Count     (CNT)
          Range: 1 ... 20
          Dimension: number of data blocks

{ANTRIEB drive: subunit which is able to perform a unit movement
{          Type:  Byte     (DEC)
{          Range: 0 ... 131
{                       FFA_STRAHLER                    0     SID tube
{                       ISOCENTER_HOEHE                 1     isocenter height
{                       TARGET_LAENGS                   2     target longitudinal
{                       TARGET_QUER                     3     target transveral
{                       TARGET_HEBEN_SENKEN             4     lift target
{                       TARGET_DREHEN                   5     rotate target
{                       SCHWENKWINKEL_SAEULE            6     angle of column
{                       TUBUSKRAFT                      7     force of tubus
{                       TISCHPLATTENDREHUNG             8     rotate table
{                       FFA_TARGET                      9     SID target
{                       TISCH_HOEHE                     10    table height
{                       TISCH_GERAET_KIPPEN             11    table tilt
{                       TISCH_LAENGS                    12    table longitudinal
{                       TISCH_QUER                      13    table transversal
{                       KIPPMULDE                       14    baby cradle
{                       SCHICHTHOEHE                    15    tomo height
{                       GERAET_HEBEN_SENKEN             16    lift gantry
{                       ACS_TUBE_ROT_HOR                17    rotate tube
{                       STRAHLER_LAENGS                 18    tube longitudinal
{                       STRAHLER_QUER                   19    tube transversal
{                       SPAETERE_ANWENDUNG              20    (reserved for future use)
{                       TUBUS_EIN_AUSFAHREN             21    move tubus (compression unit)
{                       C_BOGEN_ORBITAL                 22    c-arm orbital
{                       C_BOGEN_ANGULAR                 23    c-arm angular
{                       ISOCENTER_LAENGS                24    isocenter longitudinal
{                       FFA_BEWEGUNG                    25    SID movement
{                       ACS_SID_VALID_OR_INVALID        26    SID valid or invalid (in low
{                                                             cost systems there is no
{                                                             potentiometer to acquire the
{                                                             SID continuously, there are
{                                                             only two switches for upper
{                                                             and lower SID. If the tube is
{                                                             in between both positions, the
{                                                             collimators cannot be
{                                                             calculated because they
{                                                             require the exact SID
{                                                             position. In order not to
{                                                             expose more space than
{                                                             necessary, X-ray is blocked if
{                                                             SID is invalid.
{                                                             ANTRIEBSTATUS: 0=manual
{                                                             determined; 1=Valid; 2=Invalid
{                       ACS_CALIBRATION_SWITCH          27    Calibration switch in Ysio
{                                                             stand.
{                                                             PARAM: 0=No Information, 1=on,
{                                                             2=off
{                       ACS_SID_OR_SOD                  28    Not in use. Only a placeholder
{                                                             for the corresponding ANZCODE.
{                       ACS_ACSS_POSSIBLE_              29    For Ysio:
{                                                             XCU determines, if ACSS is
{                                                             active or not and sends
{                                                             information via SCU Interface
{                                                             to stand.
{                       ACS_SOD_H                       50    SOD value (in 0.1mm)
{                       ACS_AEC_CENTER_Y                56    offset between detector center
{                                                             and center of AEC chamber
{                       ISOCENTER_QUER                  59    isocenter lateral
{                       ACS_AUTO_MOVE_TARGET            66    see parameter
{                                                             sh_stpar_rfp.auto_move_target
{                       ACS_DET_TABLE_OUT               68    Detector or cassette in table
{                                                             is pulled out.
{                                                             Meaning of Physposition:
{                                                             0:        detector is in tray
{                                                             >0:      detector is pulled
{                                                             out
{                                                             ACS_INIL: detector is in
{                                                             intermediate position
{                       ACS_DET_WALL_OUT                69    Detector or cassette in wall
{                                                             stand is pulled out.
{                                                             Meaning of Physposition:
{                                                             0:        detector is in tray
{                                                             >0:      detector is pulled
{                                                             out
{                                                             ACS_INIL: detector is in
{                                                             intermediate position
{                       ACS_CENTRAL_BEAM_HITS           78    the x-ray beam does not or
{                                                             does only partially hit the
{                                                             detector, such that fluoro
{                                                             must be blocked
{                       ACS_DETECTOR_ORIENTATION        98    For Ysio: Orientation of
{                                                             detector relative to normal
{                                                             patient position.
{                                                             Physposition:
{                                                             1= Position 1, Pixel (0,0) in
{                                                             upper left corner (0°)
{                                                             2= Position 2, Pixel (0,0) in
{                                                             upper right corner (90°
{                                                             clockwise)
{                                                             3= Position 3, Pixel (0,0) in
{                                                             lower right corner (180°
{                                                             clockwise)
{                                                             4= Position 4, Pixel (0,0) in
{                                                             lower left corner (270°
{                                                             clockwise)
{                       ACS_BEAM_ANGLE_ALPHA            101   Beam angle alpha of tube for
{                                                             Ysio
{                       ACS_TUBE_ROT_VERTICAL           102   vertical rotation of tube for
{                                                             Ysio
{                       ACS_BEAM_POS_X                  103   deviation between center of
{                                                             beam towards center of target
{                                                             (FD, cassette, I.I.) in
{                                                             patient longitudinal direction
{                       ACS_BEAM_POS_Y                  104   deviation between center of
{                                                             beam towards center of target
{                                                             (FD, cassette, I.I.) in
{                                                             patient lateral direction
{                       ACS_DET_WALL_TILT               105   Tilting angle of detector in
{                                                             wallstand.
{                                                             Value in physposition in 0.1°
{                       ACS_POSITION_VALID_FOR_STORAGE  106   Information whether a stand
{                                                             position is valid to be stored
{                                                             in an organ program.
{                                                             Physposition: 0: no
{                                                             information, 1: position is
{                                                             valid, 2: position is not
{                                                             valid
{                       ACS_MOVING_BEAM                 107   Physposition: 0: Beam is
{                                                             stopped 1: Beam is moving
{                       ACS_MOVING_DETECTOR             108   Physposition: 0: Detector (or
{                                                             cassette tray) is stopped, 1:
{                                                             Detector (or cassette tray) is
{                                                             moving
{                       ACS_MOVING_TABLE                109   Physposition: 0: Table is
{                                                             stopped, 1: Table is moving
{                       ACS_AUTO_MOVEMENT               110   stand performs automatic
{                                                             movement:
{                                                             0 =
{                                                             ACS_AUTO_MOVEMENT_INACTIVE
{                                                             1 = ACS_AUTO_MOVEMENT_ACTIVE
{                                                             2 = ACS_AUTO_MOVEMENT_PENDING
{                       ACS_ORTHO_POS1                  111   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       ACS_ORTHO_POS2                  112   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       ACS_TDD                         113   Table Detector Distance in
{                                                             0.1mm
{                       ACS_ORTHO_STEP                  114   current step (or state) in the
{                                                             ortho flow::
{                                                             1 not in Ortho position (Move
{                                                             button has to be pressed)
{                                                             2 mark first ortho pos
{                                                             3 mark second ortho pos
{                                                             4 ready to move to first Image
{                                                             pos
{                                                             5 ready for apply X-ray
{                                                             6 X-ray is running
{                                                             7 X-ray is over and stand is
{                                                             moving to ortho start pos
{                                                             8 ortho is completed
{                                                             9 ortho is finished
{                                                             10 ortho is aborted
{                                                             11 ortho cannot be started
{                       ACS_SOFTSTOP                    115   activates or deactivates the
{                                                             SoftStop function
{                       ACS_PATIENT_TRANSFER            116   param: 1=on; 0=off
{                       ACS_TOMOADJUST                  117   system shall move to a
{                                                             position in which the tomo
{                                                             fulcrum height (Schichthöhe)
{                                                             can be adjusted using the
{                                                             laser line of the collimator
{                       ACS_MOVE_DISABLE                118   block any movement on users
{                                                             request
{                       ACS_BEAM_ANGLE__BETA            119   Beam angle beta of tube for
{                                                             Ysio
{                       ACS_FINAL_POSITION_REACHED      120   The OGP position is reached.
{                                                             This value is taken as a
{                                                             trigger to (re)send the OGP
{                                                             collimation values to the
{                                                             collimator
{                       ACS_STORE_POS                   121   store the current stand
{                                                             position
{                       ACS_RECALL_POS                  122   recall the previously stored
{                                                             stand position
{                       ACS_COLOR_ORBITAL               123   see A_COLOR_ORBITAL in ANZCODE
{                       ACS_COLOR_ANGULAR               124   see A_COLOR_ANGULAR in ANZCODE
{                       ACS_BYPASS_PARK_POS             125   (used in Luminos Fusion)
{                       ACS_CP_POSITION_MATCH           131   The (relative or absolute) CP
{                                                             position is more or less
{                                                             reached
{          Dimension: none

{ANTRIEBSTATUS status of the drive
{          Type:  Enum8     (DEC)
{          Range: 0 ... 5
{                       ACS_NO_INFORMATION      0
{                       STOP_MIT_ZIELPOSITION   1   target reached and stopped
{                       IN_FAHRT                2   moving
{                       BLOCKIERT               3   blocked
{                       STOP_OHNE_ZIELPOSITION  4   stopped but target position not reached
{                       ANSTRG_NICHT_MOEGLICH   5   drive defective
{          Dimension: none

{PHYSPOSITION Physical position of the drive
{          Type:  Integer16     (DEC)
{          Range: -32000 ... 32000
{          Dimension: 0.1 mm,0.1Grad,N


IBILD

Object: IBILD ___ID: 0386

Description: imaging system tells XCU the image flip and image rotation. Must be sent on
              request of sBild (if not XCU creates an error after some seconds time-out) or
              iBild has to be sent if imaging system changes flip or rotation based upon a
              direct input on its user interface
Sender     :   FLC
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

AVR_STATUS status of the automatic gain control
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     AVR_BETRIEB         1   AGC active
                     AVR_ENDE            2   AGC is on upper limit
                     AVR_FESTVERST       3   AGC deactivated, one of the pre-programmed
                                             fixed amplification factors is active
                     AVR_STOP            4   freeze AGC at current value
          Dimension: none

V_BUK Image flip vertical and rotation
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
                     BILD_V_BUK_AUS_DREHUNG_0  0x00   no flip, no rot
                     BILD_V_BUK_EIN            0x01   flip vertically
          Dimension: none

H_BUK image flip horizontal
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IMG_ROTATION defines the image rotation
          Type:  Integer16     (DEC)
          Range: 0 ... 359
          Dimension: degree

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBILDFORMAT

Object: IBILDFORMAT ___ID: 01F8

Description: The SCU informs the XCU about the size of the FD, that has been just inserted
              by the user.
Sender     :   CCU-IF   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BILDFORMAT_Q image format division landscape
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.1 mm

BILDFORMAT_L image format division portrait
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.1 mm

TARGET_CHANGED 0: target has not changed
1: telegram sent since target has been changed
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBINOK

Object: IBINOK ___ID: 0020

Description: alive telegram of XCU <i bin OK> = < I am OK >, sent from XCU to any
              component. For usual AXNRoot or ARCNET master are sending dummies to each
              component every 600 ms. However in case of a high network load between two or
              other components the dummy may not be sent to a component that is not involved
              in this network traffic of those two components. If the dummy is used as an
              indicator for the aliveness of the XCU it will fail. But iBinOK will be sent
              anyway.
Sender     :   XCU
Receiver   :   ACSOS   BD_A   CCU-IF   FLC   GG_A   KASS-IF   REP   SCU-IF   SM_A   SOU-IF
              UAL   VCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

VERSION_XCU
          Type:  String16 [ 16 ]     (ASCII)
          Range: 32 ... 32
          Dimension: unicode

SVN_REVISION
          Type:  String16 [ 16 ]     (ASCII)
          Range: 32 ... 32
          Dimension: unicode

VERSION_AXCS version of used AXCS headerfile
          Type:  String16 [ 4 ]     (ASCII)
          Range: 8 ... 8
          Dimension: unicode


IBLENDE

Object: IBLENDE ___ID: 0323

Description: Collimator positions, sent from collimator to XCU. Important is that a
              collimator sends the status of each modified collimator at the end of movement
              with "3" = position reached. Otherwise exposures may be blocked by XCU.because
              a moving collimator may cause artefacts in exposures.
Sender     :   CCU-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DLSTEUERUNG fluoro control, a cassette that is not in park position e.g. in load position or is currently being moved will be in X-ray beam and disturb a fluoro image, so fluoro has to disabled in those cases, same applies for collimator, if it does a search run or is "in the way"
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     DL_GESPERRT         1   fluoro blocked
                     DL_FREIGEGEBEN      2   fluoro enabled
          Dimension: none

GESCHLOSSEN Collimator status: closed or open
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     GESCHLOSSEN         1   closed (reached minumum position)
                     NICHT_GESCHLOSSEN   2   normal position
          Dimension: none

MOVE_COL RFU only: kind of movement of the collimator
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_COL_MAN_MOVEMENT   0   manual movement by an user
                     ACS_COL_AUTO_MOVEMENT  1   automatic movement of the collimator
          Dimension: none

COL_TRACKING RFU only:
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_COL_TRACK       1   tracking of collimator blades to keep current
                                             collimation on target stable, following the SID
                                             (as ACS_YES)
                     ACS_COL_NO_TRACK    2   no movement of collimator blades when SID is
                                             changing (as ACS_NO)
                                             in RFU: tracking still enabled but DSA
                                             collimator does no longer follow
                     ACS_COL_TRACK_NONE  3   no moving of colliator blades when SID or
                                             centering is changing (used during 3D run)
          Dimension: none

LIGHT_LOC RFU only: light localizer
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
                     ACS_TOGGLE          3   toggle
          Dimension: none

COLL_ROT_SWITCH RFU only: actual state of switch for collimator rotation
1=ON=collimator aligned
2=OFF=collimator rotated
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BLENDENPOSITION position of the collimator: width for type 1-3 and 8-12, position relative to a zero pos in case of other types (4-6)
A value 0xFFFF means, that collimator shall drive to full open for current zoom level
{          Type:  Word     (DEC)
{          Range: 0 ... 65533
{          Dimension: 0.1 mm

{BLENDENWINKEL angle of the collimator, usually only used for collimators 4 to 16, because 1 to 3 cannot be rotated
{          Type:  Integer16     (DEC)
{          Range: 0 ... 3600
{          Dimension: 0.1 degree

{BLENDENSTATUS Status of the collimator. Exposure is only possible with status 3 or 4.
{          Type:  Enum8     (DEC)
{          Range: 1 ... 5
{                       AKTIV              1   collimator is moving
{                       GESTOPPT           2   collimator is on error and stopped
{                       POSITION_ERREICHT  3   position successfully reached
{                       HTB_AUSGEFAHREN    4   reached outmost position (relative to current
{                                              zoom format at detector)
{                                              (formerly was special for finger and wedges,
{                                              and indicated that all have been removed)
{                       MOST_CLOSED        5   reached most closed position
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


IBLENDEANZ

Object: IBLENDEANZ ___ID: 026B

Description: display of collimators, e.g. on careprofile of Fluorospot compact, sent from
              XCU to any displaying component. iBlendeAnz is used for CareProfile in ImgSys
              (display of collimator edges in LIH without X-ray) and for auto-crop or
              auto-shutter mechanism in imaging system
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SOURCE_OF_RANGE this parameter tells the source of the collimator size or ortho range
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION   0
                     ACS_SRCRNG_MANUAL    1   collimator size was determined using knobs at
                                              the collimator or
                                              ortho size has been determined by tube tilting
                     ACS_SRCRNG_VIRTUAL   2   collimator size was determined by dragging the
                                              virtual collimator
                     ACS_SRCRNG_AUTOALGO  3   colimator size was determined by automatic
                                              algorithm (SmartSensing)
          Dimension: none

COL_MANUAL Defines User-Events for XCU
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0xF
                     BUTTON_EVENT_HOME_ALL        0x01   Home Button All active
                     BUTTON_EVENT_HOME_RECT_IRIS  0x02   Home Button Rect/Iris active
                     JOY_KNOB_MOVE_EVENT_RECT     0x04   Joystick or Knobs active
          Dimension: it's a set

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BLENDENPOSITION position of the collimator: width for type 1-3 and 8-12, position relative to a zero pos in case of other types (4-6)
A value 0xFFFF means, that collimator shall drive to full open for current zoom level
{          Type:  Word     (DEC)
{          Range: 0 ... 65533
{          Dimension: 0.1 mm

{BLENDENWINKEL angle of the collimator, usually only used for collimators 4 to 16, because 1 to 3 cannot be rotated
{          Type:  Integer16     (DEC)
{          Range: 0 ... 3600
{          Dimension: 0.1 degree

{BLENDENSTATUS Status of the collimator. Exposure is only possible with status 3 or 4.
{          Type:  Enum8     (DEC)
{          Range: 1 ... 5
{                       AKTIV              1   collimator is moving
{                       GESTOPPT           2   collimator is on error and stopped
{                       POSITION_ERREICHT  3   position successfully reached
{                       HTB_AUSGEFAHREN    4   reached outmost position (relative to current
{                                              zoom format at detector)
{                                              (formerly was special for finger and wedges,
{                                              and indicated that all have been removed)
{                       MOST_CLOSED        5   reached most closed position
{          Dimension: none

{COLBUTTONSTATE status of the collimator control buttons (used in surgery)
{          Type:  Enum8     (DEC)
{          Range: 0 ... 5
{                       ACS_NOT_DEFINED  0   not defined
{                       NORMAL           1   This TUI Button should be normally visible.
{                       HTB_AUSGEFAHREN  4   reached outmost position (relative to current
{                                            zoom format at detector)
{                                            (formerly was special for finger and wedges,
{                                            and indicated that all have been removed)
{                       MOST_CLOSED      5   reached most closed position
{          Dimension: none


IBLENDENDATA

Object: IBLENDENDATA ___ID: 0331

Description: dimension and size of collimators, sent from collimator to XCU. Used to tell
              imaging system the size of semi transparent blades (also called wedge filter
              of HTB)
Sender     :   CCU-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BLENDENBREITE width of collimator, the width is important in order to show the correct width in a care profile graphic on DFR, the width is known by the collimator, so the collimator sends the value to the DFR
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: 0.1 mm


IBLENDESELANZ

Object: IBLENDESELANZ ___ID: 00A4

Description: selection of the collimator that should be controlled by the keyboard button,
              sent from XCU to collimator
Sender     :   XCU
Receiver   :   RAD-STD   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{ANZEIGESTATUS status of collimator display
{          Type:  Byte     (DEC)
{          Range: 0 ... 1
{                       BLENDE_PASSIV      0   collimator deselected
{                       BLENDE_SELEKTIERT  1   collimator selected
{          Dimension: none


IBREMSUNG

Object: IBREMSUNG ___ID: 019F

Description: status of brakes, sent from stand/gantry to XCU. Should be sent upon request
              of sBremsung. Brakes are used in undertable stands to stop the manual moving
              of the spotfilm device (imaging tower) when an acquisition has been requested
              by the customer in order to avoid artefacts caused by moving tube or FD
              detector.
Sender     :   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

BREMSE brake command
          Type:  Byte     (DEC)
          Range: 1 ... 9
                     ZG_BREMSE        1   Spotfilm device brake (for undertable stands like
                                          sireskop the SFD can manually moved  in order to
                                          get no motion artefacts caused by SFD movements
                                          the SFD will be braked during exposure
                     KOMPRESSION      2   compression
                     ZG_TISCHMITTE    3   spotfilm device table
                     ZG_PARKPOSITION  4   Spotfilm device in park position braked
                     BREMSE_5         5
                     BREMSE_6         6
                     BREMSE_7         7
                     BREMSE_8         8
                     BREMSE_9         9
          Dimension: none

BRSTATUS Status of brake
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     BREMSE_ANGEZOGEN  1   brake active
                     BREMSE_GELOEST    2   break released
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBSIGNAL

Object: IBSIGNAL ___ID: 02DB

Description: actual brightness signal of latest exposure or fluoro frame; will be
              calculated at the end of the acquisition of any fluoro or exposure image in
              case of an image intensifier system
Sender     :   FLC
Receiver   :   GEN-IF   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs

List of Parameters:

THRESHOLD brightness percentage that the generator should use as the set-point for its dose regulation (will typically be set to 100=10%)
          Type:  Dword     (DEC)
          Range: 0 ... 10000
          Dimension: 0.1%

BSIGNAL brightness of the last acquired frame in the region of interest (in percent of maximum brightness)
note: a value of 0 will be ignored by generator (compensation of dropouts during transitions like zoom change or framerate change)
          Type:  Dword     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1%

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBV

Object: IBV ___ID: 012E

Description: reporting zoom of detector, sent from ImageSystem (which parametrizes
              ImageChain) to XCU
Sender     :   GEN-IF   GG_A   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IBVFSANZ

Object: IBVFSANZ ___ID: 0080

Description: XCU informs displays and imaging systems upon current zoom level and effective
              width of maximum allowed collimation opening. The parameter BUMKEHR for image
              flip and rotation is also send in sBild. iBVFSAnz is sent as soon as iBV or
              iBild has been received by XCU.
Sender     :   XCU
Receiver   :   FLC   GEN-IF   RAD-STD   SCU   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

BVFORMAT effective zoom size of current image intensifier or FD format
          Type:  Integer16     (DEC)
          Range: 1000 ... 6000
          Dimension: 0.1mm

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

BUMKEHR image flip and rotation
          Type:  Byte     (DEC)
          Range: 0 ... 96
                     KEINE_ANGABE_NORMAL   0    no image flip
                     UMKEHR_HORIZONTAL     1    horizontal image flip
                     UMKEHR_VERTIKAL       2    vertical image flip
                     UMKEHR_VERT_HORIZ     3    horizontal and vertical image flip
                     ACS_BILD_DREHUNG_90   32   image rotated by 90° clockwise
                     ACS_BILD_DREHUNG_180  64   image rotated by 180°
                     ACS_BILD_DREHUNG_270  96   image rotated by 270° clockwise
          Dimension: none


ICPEXI

Object: ICPEXI ___ID: 02F4

Description: send clinical and physical dexi for debugging purpose (e.g. SITA)
Sender     :   UIS
Receiver   :   UAL
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

RAW_DEXI RAW dexi is the unmodified mean brightness value within the measuring field (region of interest). The value is used inside the image system to calculate the dose (parameter DOSE_ACT above) with the help of the detector mode specific adjustment parameters.
Note: this parameter is for debugging purpose only - it is not used by system.
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

EXI_CLINICAL clinical EXI value
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: nGy

EXI_PHYSICAL physical EXI value
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: nGy


IDAPVALUE

Object: IDAPVALUE ___ID: 00B0

Description: DoseAreaProduct sent from DAP chamber (DCU resp.) to XCU. The XCU shall
              forward this telegram any time while system is in mode X-ray on, if the DAP
              value sent by DAP chamber has changed compared to the last value sent. DFP_RAW
              is without applying correction (CU-filter or overtable / undertable
              correction). If no X-ray is requested or the last request has been canceled or
              terminated for more than 300 ms, then changes in the DAP chamber will be
              ignored and no iDAPValue will be sent. As the DAP chamber sends a new value
              via CAN every 65 ms the max rate of iDAPValue is 65 ms.
Sender     :   DCU   DCU2
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DFP_RAW nonweighted raw data of the dose area product as received directly from the measurement chamber.
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IDATE

Object: IDATE ___ID: 0BC8

Description: Since the time master in normal systems is the imaging system, this telegram
              is sent cyclically every 2 seconds by ImgSys in order to synchronize others
              (e.g. ACSOS).
Sender     :   FLC   UIS   XCU
Receiver   :   ACSOS   FLC   PMS   SCU   XCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

YEAR Year
          Type:  Byte     (DEC)
          Range: 0 ... 99
          Dimension: none

MONTH Month
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

DAY Day
          Type:  Byte     (DEC)
          Range: 1 ... 31
          Dimension: none

HOUR Hour
          Type:  Byte     (DEC)
          Range: 0 ... 23
          Dimension: none

MINUTE Minute
          Type:  Byte     (DEC)
          Range: 0 ... 59
          Dimension: none

SECOND Second
          Type:  Byte     (DEC)
          Range: 0 ... 59
          Dimension: none

MILLISECOND
          Type:  Word     (DEC)
          Range: 0 ... 999
          Dimension: ms


IDETEKTORSTATUS

Object: IDETEKTORSTATUS ___ID: 03B8

Description: This telegram is used as the SW trigger for the x-ray pulse
Sender     :   FLC   HIC_IF
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DETSTATUS Detector status
          Type:  Byte     (DEC)
          Range: 1 ... 11
                     DET_AUFNAHMEBEREIT  3    trigger for x-ray pulse
                     DET_DAT_STOP        7    all data of current image transferred
                     DET_ERROR           11   Detector encountered a problem (see additional
                                              parameter)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DET_ERROR_CODE optional error number
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: none


IDETNR

Object: IDETNR ___ID: 03B7

Description: ImgSys sends the serial number (or other ID) of the actually attached and
              selected detector to XCU
              (for display in status line via iDFRAllgAnz2)
Sender     :   FLC   FLC_TV
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

FD_SERIAL FD serial number, max 32 chars UNICODE
          Type:  String16 [ 32 ]     (ASCII)
          Range: 64 ... 64
          Dimension: unicode


IDEXI

Object: IDEXI ___ID: 02B7

Description: Imaging system sends raw DEXI (digital exposure index) value to XCU after
              every frame (fluoro and exposure). The DOSE_ACT is calculated by multiplying
              RAW_DEXI by the corresponding adjust factor for that DIPP-MODE.
              RFU specific: The DIPP mode starts with 2D which is ASCII the letter U. and
              then followed by real number. (e.g. U02).
Sender     :   FLC   HIC_IF   UIS
Receiver   :   GEN-IF   UGEN   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DOSE_ACT Actual Dose sent by Image System (Image Chain) to XCU, Digital Exposure Index. Will be sent to generator, to do the regulation
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: 0.01 nGy

DIPP_MODE DIPP operational modes
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
                     DIPPMODE_BYPASS    0xE111
                     DIPPMODE_SHUTDOWN  0xE222
                     DIPPMODE_IDLE      0xEEEE
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

RAW_DEXI RAW dexi is the unmodified mean brightness value within the measuring field (region of interest). The value is used inside the image system to calculate the dose (parameter DOSE_ACT above) with the help of the detector mode specific adjustment parameters.
Note: this parameter is for debugging purpose only - it is not used by system.
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IDFPANZ2

Object: IDFPANZ2 ___ID: 00AD

Description: This telegram reports dose values that are cummulated for a patient.
              The DOSE is calculated by dividing the DFP by the collimator area that results
              in the SKIN FA (distance skin of patient to focus of tube). Doserate should be
              filled on fluoro and if frame rate is equal or larger than 6 f/s.
              The DAP value shown on imaging system may vary from this value, because
              imaging system will reload old DAP previous values from a patient, if this
              patient is selected a second or more times.
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DFP_ACCUM Dose Area Product (Dosis Flächen Produkt) accumulated since last patient selection
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

DOSE_FOR_DAP Accumulated Air Kerma (skin dose) for actual patient. It equates to the sum of DOSE_ACCUM_FL (Fluoro Kerma) and DOSE_ACCUM_ACQ (Acquisition Kerma)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: 0.1 mGy

DOSERATE_FOR_DAP Air Kerma Rate. Value filled during active Acquistion (framerate >= 6fps) and Fluoro (at any framrerate). In other states the value equates to 0.
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: 0.1 mGy/min

DOSE_DATA_TYPE
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION       0
                     ACS_DOSE_DEFAULT_VALUES  1   Default values after patient registration
                     ACS_DOSE_ACTUAL_VALUES   2   Actual values for current patient
                     ACS_DOSE_INVALID_VALUES  3   Invalid values, do not display (DAP meter
                                                  might be defective or not configured)
          Dimension: none

SKINFA Distance between Tube (Focus) and Skin of patient for calculation of Air Kerma and Air Kerma Rate from DAP
          Type:  Byte     (DEC)
          Range: 1 ... 255
          Dimension: cm

SKDOSEPERC current percentage of reference air kerma relative to skin dose limit
          Type:  Word     (DEC)
          Range: 0 ... 65000
          Dimension: 0.1%

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

DOSE_ACCUM_FL accumulated Kerma for fluoro (w/o contribution of acquisition)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: 0.1 mGy

DOSE_ACCUM_ACQ accumulated Kerma for acquistion (w/o contribution of fluoro)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: 0.1 mGy

DICOM_TAG indicator into which DICOM tag the skin dose needs to be reported
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION  0
                     ACS_DICOM_113860    1   skin dose for 3D
                     ACS_DICOM_113861    2   skin dose for BWS or Free Exposure (SID only)
                     ACS_DICOM_113862    3   skin dose for UnderTable (Agile UT)
                     ACS_DICOM_113863    4   skin dose for OverTable (dRF,Agile OT, Ysio
                                             Table)
                     ACS_DICOM_113864    5   skin dose for lateral 15cm from Table
                                             Centerline
                     ACS_DICOM_113964    6   skin dose for Free Exposure (SOD+SID measured)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SKINFOCUSDIST Skin-Source-Distance (like SKINFA but larger range)
          Type:  Word     (DEC)
          Range: 0 ... 1000
          Dimension: cm


IDFRABSCHALTUNG

Object: IDFRABSCHALTUNG ___ID: 026E

Description: reason, why DFR has stopped the acquisition, sent from DFR to XCU For usual an
              acquisition is stopped by generator (when reaching dose or mAs) or by customer
              in case of series. If DFR stops acq it should tell the reason to invoke an
              appropriate error message sent by XCU.
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ABSCHGRUND reason why an Exposure has been terminated
          Type:  Enum8     (DEC)
          Range: 0 ... 24
                     ACS_NO_INFORMATION     0
                     MAX_SZENENLAENGE       1    max scene length reached
                     KEINE_KAPAZITAET       2    out of RAM/Disk space
                     IONTOMAT_OFF           3
                     MAS_SWITCH             4
                     TIME_SWITCH            5
                     DOOR_CONTACT           6
                     ERROR_SWITCHOFF        7
                     PRESSURE_SWITCH        8
                     MAIN_CONTACT_OPEN      9
                     MIN_DOSE               10
                     GENERAL                11
                     CIRCUIT_OPEN           12   safety circuit opened at least at one point
                     GRID_MOVEMENT          13   Grid movement during acquisition
                     FILTER_MOVEMENT        14   Movement of filter during acquisition
                     COLLIMATOR_MOVEMENT    15   Movement of collimator during acquisition
                     STAND_SHUTDOWN         16   Stand sent shutdown (iBetriebsart)
                     COLLIMATOR_SEARCH_RUN  17
                     RLR_OVERHEAT           18   Overheat of tube load calculator
                     CASSETTE               19   Position of Cassette (iKassPos)
                     DFR                    20   Status of DFR (iDFRStatus)
                     ASU_STATUS             21   Status of ASU (iASUStatus)
                     FD_STATUS              22   Status of FD detector (iDetektorStatus)
                     TURNOFF_EVENT          23   Received an event which turns off
                                                 acquisition (iBedPowerReq or power fail
                                                 interrupt)
                     FFA_INTERMEDIATE       24   FFA in an intermediate position
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IDFRALLGANZ2

Object: IDFRALLGANZ2 ___ID: 02B6

Description: Display of unicode messages direct on DFR screen. There is one line available
              that may be used. The width is limited to app 17 chars, depending on character
              width in text. For usual only 'FUNCTION 5 and COMMAND = 1 is used with
              NO_TEXT=1.
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

FUNCTION Function of display on DFR screen
          Type:  Enum8     (DEC)
          Range: 1 ... 10
                     FLUORO_FILTER                   1
                     ACQUISITION_FILTER              2
                     DOSE_AREA_PRODUCT               3
                     DOSE_OR_DOSERATE_FOR_FLUORO     4
                     DOOR_OR_ERRORMESSAGE            5
                     UPS_OR_ERRORMESSAGE_2           6
                     X_RAY_DISABLE_OR_ERRORMESSAGE3  7
                     SS_OFF_OR_SPINE_RECONSTRUCTION  8
                     COMPRESSION_FORCE               9
                     COLLIMATOR_NOT_IN_0_DEGREE_POS  10
          Dimension: none

COMMAND Command for display on DFR screen; 0: clear; 1: Set
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     ACS_CLEAR_DISPLAY  0   Clear display on DFR.
                     ACS_SET_DISPLAY    1   Set display on DFR with given text.
          Dimension: none

NO_TEXT Number of Text strings for display on dfr screen
          Type:  Dcount     (CNT)
          Range: 0 ... 5
          Dimension: number of data blocks

{DISP_STYLE attribute of the displayed value
{          Type:  Enum8     (DEC)
{          Range: 0 ... 4
{                       ACS_DISP_NORMAL           0   normal display
{                       ACS_DISP_BLANK            1   the field should be blank
{                       ACS_DISP_BLINKING         2   blinking
{                       ACS_DISP_INVERT           3   inverted
{                       ACS_DISP_INVERT_BLINKING  4   inverted and blinking
{          Dimension: none

{DUMMY1
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{TEXT message text (80 char unicode)
{          Type:  String16 [ 80 ]     (ASCII)
{          Range: 160 ... 160
{          Dimension: unicode


IDFRBEDANZ

Object: IDFRBEDANZ ___ID: 00A6

Description: Display of remote controlled function setting of the imaging system in a
              control console like TUI.
Sender     :   FLC   XCU
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTANZAHL amount of actions
          Type:  Count     (CNT)
          Range: 1 ... 20
          Dimension: number of data blocks

{AKTCODE Code for remote control
{          Type:  Enum16     (DEC)
{          Range: 0 ... 2500
{                       BLAETTERN                    0      0=no action;
{                                                           1=image forward;
{                                                           -1=image backward;
{                                                           2=scene plus.;
{                                                           -2=scene minus
{                                                           3=page down (in doc mode)
{                                                           -3=page up (in doc mode)
{                                                           4=next multiframe scene (skip
{                                                           single images)
{                                                           -4=previous multiframe scene
{                                                           (skip single images)
{                       DISPLAY_MODE                 1      change from single display to
{                                                           4x4 display:
{                                                           0=no action
{                                                           1=Single image
{                                                           -1=splitmon (Stack Mode)
{                                                           2=Change Mode
{                                                           -2=Stripe Mode
{                       CHANGE_MARK                  2
{                       HARDCOPY                     3
{                       STORE_MONITOR                4
{                       DELETE_IMAGE                 5
{                       STORE_REFERENZ               6
{                       RECALL_REFERENZ              7
{                       TRANSFER_IMAGE               8      Transfer Image to network (DICOM
{                                                           export)
{                       VIDEOLOOP_REPLAY             9      control/show video loop status:
{                                                           0=no action; 1=replay
{                                                           active;2=replay stopped;-1=mode
{                                                           changed
{                       RL_MARKIERUNG                10     control left/right marker:
{                                                           0=no action; 1=no mark; 2=R;
{                                                           3=L; 4=misc1; 5=misc2; 6=misc3;
{                                                           7=misc4
{                       SUBTRAKTION_NATIV            11     sDFRNahBed: toggle between sub
{                                                           and native display
{                                                           iDFRNahBed: 1=sub; 2=nat;
{                                                           3=sub&nat
{                       REMASKING                    12     switch remasking on (PARAM=1) or
{                                                           off (PARAM=2)
{                       DETECTOR_SELECTION           13     If more than one wireless
{                                                           detector is attached to the
{                                                           system, the user can select at
{                                                           the TUI, if large or small
{                                                           detector shall be taken.
{                                                           AKTDATA: 1=large; 2=small
{                       FILTERUNGSPROGRAMM           14
{                       FILTERKERN                   15
{                       FILTERENHANCEMENT            16
{                       VERGROESSERUNG               17     switch on/off fixed digital zoom
{                                                           (x2):
{                                                           -1 = toggle
{                                                           1 = switch zoom off
{                                                           2 = switch zoom on
{                       INVERTIERUNG                 18
{                       ANATOMIC_BACKGROUND          19
{                       PEAK_OPACIFICATION           20
{                       AUTOSHUTTER                  21
{                       ZIELFADENKREUZ               22     AKTDATA=1: crosshair on
{                                                           AKTDATA=0: crosshair off
{                       ROADMAP_FLH                  23
{                       TRANSFER_REFMON              24     transfer image to reference
{                                                           monitor:
{                                                           AKTDATA=1: conventional AtoB
{                                                           AKTDATA=2: swap images: AtoB and
{                                                           BtoA
{                       W1                           25     brightness native
{                       W2                           26     contrast native
{                       W3                           27     brightness subtracted
{                       W4                           28     contrast subtracted
{                       SHUTTER_HOR                  29     horizontal shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       SHUTTER_VER                  30     vertical shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       ROAM_HOR                     31     roam horizontally: 1=right;
{                                                           2=left
{                       ROAM_VER                     32     roam verticallly
{                       KREIS_SHUT                   33     circular shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       STORE_FL_SZENE               34
{                       DISPLAY_FRAME                35     Reference monitor assigned to
{                                                           ultra sound device
{                                                           Aktdata:  0= reference 1 =
{                                                           Ultrasound
{                       CARE_POS                     36     switch ShowCarePosition on or
{                                                           off
{                                                           AKTDATA: 0=off; 1=on; -1=toggle
{                       ENDO_GRAB                    37     Aktdata: 0=stop movie / 1=start
{                                                           movie / 2=store endo image
{                       EMERGENCY_LEVEL              38     Aktdata:    0=OFF / 1=ON
{                       TABCARD_TOGGLE               39     Aktdata:    0=No Action / 1=Pat
{                                                           / 2=Exam / 3=Postproc / 4=Doc
{                       FLIP_IMG_HORIZONTAL          40     Aktdata:   0=No Action / 1=Off /
{                                                           2=On / -1=Toggle
{                       FLIP_IMG_VERTICAL            41     Aktdata:    0=No Action / 1=Off
{                                                           / 2=ON / -1=Toggle
{                       DOSECHANGE_LOW_STANDARD      42     Aktdata: 0 = Standard Dose; 1 =
{                                                           Low Dose
{                       DVD_RECORDER                 43     Param: 0 = NO_CHANGE; 1 =
{                                                           START_DVD_RECORDING; 2 =
{                                                           STOP_DVD_RECORDING
{                       MARK_R_POSITION              44     Aktdata: 0 = NO RIGHT MARK; 1 =
{                                                           UPPERLEFT; 2 = UPPERRIGHT; 3 =
{                                                           MIDLEFT; 4 = MIDRIGHT; 5 =
{                                                           LOWERLEFT; 6 = LOWERRIGHT; 7 =
{                                                           NO_MARK_SELECTED
{                       MARK_L_POSITION              45     Aktdata: 0 = NO LEFT MARK; 1 =
{                                                           UPPERLEFT; 2 = UPPERRIGHT; 3 =
{                                                           MIDLEFT; 4 = MIDRIGHT; 5 =
{                                                           LOWERLEFT; 6 = LOWERRIGHT; 7 =
{                                                           NO_MARK_SELECTED
{                       FORMAT_SEGMENTATION          46     Aktdata: 0 = NO_INFORMATION; 1 =
{                                                           FULL; 2 = 2VER; 3 = 2AVER; 4 =
{                                                           2HOR; 5 = 2AHOR; 6 = 3VER; 7 =
{                                                           1OF4
{                       REFRESH_ORGAN_PROGRAM        47     Param: 0 = no change; 1 =
{                                                           refresh
{                       REDO_ORGAN_PROGRAM           48     Used for Ysio, last organ
{                                                           program shall be used again.
{                       TOD                          49     Used to set table object
{                                                           distance, param between TOD_MIN,
{                                                           TOD_MAX
{                       LABEL_SELECT                 50     select label language; 1=R/L
{                                                           2=D/G 3=DEX/SIN
{                       PAT_EDIT                     51     button 'new patient' or 'correct
{                                                           patient data' pressed
{                                                           0=close pat dialog
{                                                           1=new patient
{                                                           2=show pat data
{                                                           3=generate ID
{                                                           4=delete
{                                                           5=filter
{                                                           6=unfilter
{                                                           7=protect
{                                                           8=unprotect
{                                                           9=save changes (=correct pat
{                                                           data)
{                       PAT_REGISTER                 52     button 'exam', 'add to worklist'
{                                                           or  'emergency patient' pressed
{                                                           AKTDATA: 1=exam, 2=add to
{                                                           worklist 3=emergency
{                       PAT_LIST                     53     buttons 'worklist' or 'previous
{                                                           patients' pressed
{                                                           AKT_DATA: 1=worklist,
{                                                           2=prevPatient, 0="return to
{                                                           patlist"
{                       PAT_CLOSE                    54     button 'end exam' pressed
{                                                           AKTDATA.bit0: (unused)
{                                                           AKTDATA.bit1: print summary
{                                                           AKTDATA.bit2: export summary
{                                                           AKTDATA.bit3: send MPPS
{                       WINDOW_LUT                   55     This allows the selection of a
{                                                           predefined LUT (set of window
{                                                           values)
{                                                           AKTDATA>0 number of fixed
{                                                           setting
{                                                           AKTDATA=0 deselects all (free
{                                                           window values)
{                                                           -1 step to next setting
{                                                           (used in surgery and urology)
{                       SAVE_FOR_UNDO                56     on receiving this code, FLC
{                                                           shall save the current set of
{                                                           image processing parameters for
{                                                           latter undo function
{                       UNDO_PROC                    57     FLC shall undo the recent change
{                                                           of image processing parameters
{                                                           AKTDATA=0: reset to loading
{                                                           default
{                                                           AKTDATA=1: go back to parameter
{                                                           set previously being saved with
{                                                           SAVE_FOR_UNDO
{                       INJCT_SYMB                   58     show injector symbol
{                                                           in iDFRNahBed also: mask has
{                                                           been successfully acquired
{                                                           (averaged)
{                       AVERAGING                    59     determines the averaging applied
{                                                           for LIH
{                                                           1=low; 2=normal; 3=high
{                                                           (fixed modification factor
{                                                           applied to value out of
{                                                           application/OGP)
{                       MOTION_DET                   60     selector to set the level for
{                                                           motion detection and k-factor
{                                                           (used in surgery)
{                                                           motion detector off: 1=low;
{                                                           2=standard; 3=high; 4=heart
{                                                           motion detector on: 11=low;
{                                                           12=standard;13=high
{                       IMG_ROTATE_REL               61     rotate image by the amount given
{                                                           in degrees AKTDATA relative to
{                                                           the current position
{                       IMG_ROTATE_ABS               62     rotate image to the value given
{                                                           in degrees AKTDATA
{                       MOVIE_SPEED                  63     defines the speed of the movie
{                                                           replay; iDFRNahBed uses code 0,
{                                                           iDFRBedAnz use codes 1-3
{                                                           following values are defined:
{                                                           0 - step to next; 1-slow;
{                                                           2-normal, 3-fast
{                       SELECT_FRAME                 64     image system shall show the
{                                                           frame number given in AKTDATA
{                                                           out of the current scene
{                       SET_SCENE_LIMIT              65     sets or resets the lower or
{                                                           upper delimiter for scene
{                                                           replay
{                                                           1=set lower limit, 2=set upper
{                                                           limit, 101=reset lower limit,
{                                                           102=reset upper limit
{                       STORAGE_RATE                 66     set storage rate reduction;
{                                                           param:
{                                                           1=100% store every frame
{                                                           2=50% store every other frame
{                                                           3=33% store every third frame
{                                                           4=25%, 5=20%, 10=10%
{                       ENABLE_AUTO_STORE            67     control autostore (in surgery):
{                                                           0=disable auto storage of fluoro
{                                                           scenes
{                                                           1=enable auto storage of LIH
{                                                           2= enable auto storage of LSH
{                                                           (last scene hold)
{                       AUTOWINDOW                   68     set the auto window function
{                                                           (0=off; 1=on)
{                       EXPORT_DIALOG                69     show export sub/nat select
{                                                           dialog (used in iDFRBedAnz for
{                                                           surgery)
{                                                           AKTDATA.bit0: 1-show, 0-hide
{                                                           AKTDATA.bit1: store native
{                                                           AKTDATA.bit2: store subtracted
{                                                           AKTDATA.bit3: store raw data
{                                                           AKTDATA.bit4: 1-PeakOp 0-entire
{                                                           scene
{                       DIGITAL_ZOOM                 70     slider position for digital zoom
{                                                           (used in surgery)
{                       BUTTONFIELD_ENA              71     enables or disables the buttons
{                                                           in the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                                                           note: since first button will
{                                                           always be active, bit0 is used
{                                                           to indicate, if there is a next
{                                                           page (i.e. if element16 rather
{                                                           than element0 is existing)
{                       MODE_RANGE                   72     activates or deactivates the
{                                                           range selection mode
{                       SELECT_RANGE_START           73     transfers the item number of the
{                                                           range start
{                                                           (used for multi-select in DOC
{                                                           mode in surgery)
{                       BUTTONFIELD_SEL              74     activates or deactivates the
{                                                           buttons in the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                       HOLD_REF                     75     ImageSystem shall freeze the
{                                                           reference monitor
{                       ENTER_SERVICE                76     start service
{                       CALC_PEAKOP                  77     triggers the calculation and
{                                                           storage of a new PeakOp image
{                       MODE_PAN                     78     enter(1) or leave(0) Pan Mode
{                                                           (CURSOR_HOR and CURSOR_VER refer
{                                                           to panning)
{                       CURSOR_HOR                   79     move cursor horizontally by the
{                                                           given amount
{                                                           (used for pan, pixel shift, draw
{                                                           line and quant)
{                       CURSOR_VER                   80     move cursor vertically  by the
{                                                           given amount
{                                                           (used for pan, pixel shift, draw
{                                                           line and quant)
{                       MODE_PIXEL_SHIFT             81     enter (1) or leave(0) the pixel
{                                                           shift mode
{                                                           (CURSOR_HOR and CURSOR_VER refer
{                                                           to pixel shift)
{                                                           (note: pixel shift values are in
{                                                           1/16 pixels
{                       AUTO_PIXEL_SHIFT             82     activates or deactivates auto
{                                                           pixel shift
{                                                           0=off; 1=on
{                       CALC_PIXEL_SHIFT             83     ImageSystem is requested to
{                                                           calculate the pixels shift (for
{                                                           all successful images?!)
{                       MODE_DRAW_LINE               84     activate or deactivate the draw
{                                                           line mode
{                                                           0=deactivate draw line mode
{                                                           1=activate draw line mode
{                                                           2=set point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=cancel
{                                                           6=end line
{                                                           7=edit line
{                       MODE_QUANT                   85     control the quant mode
{                                                           0=deactivate quant mode
{                                                           1=activate quant mode
{                                                           2=set point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=reset quant
{                                                           6=delete line
{                                                           7=calc contour
{                                                           8=correct contour
{                                                           9=move line 1 up
{                                                           10=move line 1 down
{                                                           11=move line 2 up
{                                                           12=move line 2 down
{                       CLOSE_PAT_DIALOG             86     show close patient dialog (used
{                                                           in surgery)
{                                                           AKTDATA.bit0: 1-show, 0-hide
{                                                           AKTDATA.bit1: print summary
{                                                           AKTDATA.bit2: export summary
{                                                           AKTDATA.bit3: send MPPS
{                                                           AKTDATA.bit8: 1-PatExistsDialog,
{                                                           0-ClosePatDialog
{                       BLOW_UP                      87     enable (1) or disable(0) blowup
{                                                           mode (i.e. segment from overview
{                                                           is shown enlarged on 2nd
{                                                           display)
{                       MODE_MULTISEL                88     activates/deactivates the multi
{                                                           selection mode (used in surgery
{                                                           to mark images)
{                       SHUTTER_CTRL                 89     bit0=left shutter; bit1=right
{                                                           shutter; bit2=upper shutter;
{                                                           bit3=lower shutter
{                                                           bit4: 1=shutter disabled;
{                                                           0=shutter normal
{                                                           bit5: 1=rotate shutter; 0=normal
{                                                           (move in/out)
{                                                           bit8-15: signed char specifying
{                                                           the amount to move the shutter
{                       NUM_MARKED                   90     number of elements (images in
{                                                           study or frames in image) that
{                                                           are marked
{                       RADIATION_ON_RQ              91     in sDFRNahBed XCU requests FLC
{                                                           to show the passcode dialog (to
{                                                           enable or disable x-ray):
{                                                           AKTDATA: 1=show passcode dialog;
{                                                           0=close passcode dialog
{                                                           FLC replies with iDFRNahBed:
{                                                           AKTDATA: 1=request granted;
{                                                           0=request denied
{                       BUTTONFIELD_MARK_VESS        92     activates or deactivates a
{                                                           vessel symbol on the buttons in
{                                                           the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                       MODE_ANNOTATE                93     control the annotate measure
{                                                           mode
{                                                           0=deactivate annotate measure
{                                                           mode
{                                                           1=activate annotate measure
{                                                           mode
{                                                           2=set 1st point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=calibrate
{                                                           6=delete graph
{                                                           7=set 2nd point
{                                                           8=text mode
{                                                           9=line mode
{                                                           10=angle mode
{                                                           11=free text mode
{                       SELECT_ANNOTATION            94     indicates the selection out of
{                                                           the list of predefined
{                                                           annotation text strings (that
{                                                           has been sent with sAnnotation)
{                       SHUTTER_MENU                 95     shall be sent from TUI-IF to
{                                                           FLC, if the shutter submenu is
{                                                           opened or closed
{                       AUTOLOOP                     96     autoloop button (used in surgery
{                                                           only); overrides the setting of
{                                                           the OGP/application:
{                                                           PARAM=0: image system shall show
{                                                           LIH
{                                                           PARAM=1: loop display shall be
{                                                           started right after acquisition
{                       SELECT_PEAKOP                97     select PeakOp (used in surgery)
{                                                           PARAM: -1=previous; +1=next
{                       SHOW_CARE_PROF               98     This code triggers display of
{                                                           care profile graphics on
{                                                           ImageSystem
{                       CHANGE_BRIGHTNESS            99     change window brightness (FLC
{                                                           knows if nat or sub)
{                                                           (used for button based control
{                                                           in surgery)
{                                                           AKTDATA=4: decrease brightness
{                                                           AKTDATA=2: increase brightness
{                                                           AKTDATA=0: off
{                       CHANGE_CONTRAST              100    change window contrast (FLC
{                                                           knows if nat or sub)
{                                                           (used for button based control
{                                                           in surgery)
{                                                           AKTDATA=4: decrease contrast
{                                                           AKTDATA=2: increase contrast
{                                                           AKTDATA=0: off
{                       SELECT_BUTTON                101    select a button in the overview
{                                                           buttonfield (on surgery xCP)
{                                                           AKTDATA contains the button
{                                                           number (0-15)
{                       MODE_MANAGED                 102    activates managed mode on FLC
{                       MODE_3D_DISP                 103    opens/activates 3D display and
{                                                           submenu
{                       ROT_FLIP_MENU                104    indicates, that the Rotate/Flip
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       BRIGHT_CONT_MENU             105    indicates, that the
{                                                           Brightness/Contrast submenu has
{                                                           been opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0) on TUI
{                       CLOSE_KEYB                   106    keyboard on TUI has been closed
{                       EDGE_ENH_MENU                107    indicates, that the Edge
{                                                           Enhancement submenu has been
{                                                           opened (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       SUB_NAT_MENU                 108    indicates, that the Sub/Nat
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       PEAK_OP_MENU                 109    indicates, that the PeakOp
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       DELETE_PAT_DIALOG            110    show delete patient dialog (used
{                                                           in surgery)
{                       SELECT_SCENE                 111    set/show the current scene
{                                                           number
{                                                           (currently only used in
{                                                           iDFRBedAnz)
{                       MODAL_BOX_DIALOG             112    On this code in iDFRBedAnz TUI
{                                                           shall open(1) or close(0) a
{                                                           special message box.
{                                                           On this code in sDFRNahBed2 FLC
{                                                           shall close the modal box.
{                       RESET_ZOOM                   113    zoom (and pan) shall be reset
{                                                           (ViewAll functionality)
{                       CANCEL_PROGRESS              114    cancel button on the generic
{                                                           progress bar on TUI
{                       MOVIE_MENU                   115    TUI-IF reports that the movie
{                                                           menu is opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0)
{                       COLLIMATOR_MENU              116    shall be sent from TUI-IF to
{                                                           FLC, if the collimator submenu
{                                                           is opened or closed
{                       MODE_DUAL_3D_DISPLAY         117    opens/activates dual display
{                                                           mode and submenu
{                       SWITCH_INPUT_FIELD           118    switches input field focus (e.g.
{                                                           in patient registration dialog)
{                                                           1=jump to next input field
{                                                           -1=jump to previous input field
{                       TUI_TABCARD_SWITCH           119    in sBedDFR/sDFRNahBed: TUI
{                                                           informs FLC on selected tabcard
{                                                           in iDFRNahBed/iDFRBedAnz: FLC
{                                                           selects a tabcard at TUI
{                                                           (used in surgery)
{                                                           1 = prep tabcard
{                                                           2 = proc tabcard
{                                                           3 = ext tabcard
{                                                           4 = IGS tabcard
{                       SURG_METAL_CORR              120    control metal correction feature
{                                                           (image processing)
{                                                           AKTDATA: 0=off; 1=on
{                       HIDE_GRAPHICS                121    hide all graphic overlays
{                       LARGE_TUI_PREVIEW            122    switch on/off stream for large
{                                                           image display on TUI
{                       SUBAUTOWIN                   123    autowindow for road and sub
{                                                           (1=trigger)
{                       ONSUB_ONNAT                  124    determines, if the values for
{                                                           WINDOW_LUT and INVERTIERUNG are
{                                                           to be applied on subtracted or
{                                                           native image
{                                                           0 = apply to both
{                                                           1 = apply to native
{                                                           2 = apply to subtracted
{                       SPATIAL_NOISE_FILTER         125    spatial noise filter setting
{                                                           0 = off
{                                                           1 = low
{                                                           2 = medium
{                                                           3 = high
{                       RADIATION_ON_YES             126    "yes" button at radiation on
{                                                           dialog pressed
{                       NO_ZOOMDOSE_ADPT             127    AKTDATA:
{                                                           0: normal zoom dose adaption
{                                                           1: no zoom dose adaption
{                       KWIRE                        128    indicates, that FLC shall the
{                                                           k-wire functionality
{                                                           (AKTDATA=1) switched on
{                                                           (AKTDATA=0) switched off
{                       STORE_NGS                    129    Store NGS stream as single image
{                                                           (similar to STORE_MONITOR)
{                       OPENAPPS_MAN_IMG_TRANS       130    Manual image transfer from
{                                                           imaging system to AppHost
{                       IMAGE_FOR_APP_AVAILABLE      131    a new image is available to be
{                                                           transferred to the APP
{                       STORE_SNAPSHOT               132    Snapshot active (cummulated
{                                                           fluoro image).
{                                                           This code is used to inform XCU
{                                                           in iDFRNahBed that certain
{                                                           functions must be (temporarily)
{                                                           disabled.
{                                                           (AKTDATA=0) not active
{                                                           (AKTDATA=1) snapshot active
{                       DOSE_CONTROL_ROI_MENU        133    Indicates, that the region of
{                                                           interest (ROI) for dose control
{                                                           submenu has been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed at TUI
{                       DOSE_CONTROL_ROI             134    Region of interest (ROI) for
{                                                           dose control settings shall be
{                                                           set to
{                                                           (AKTDATA=1) on
{                                                           (AKTDATA=2) off
{                                                           (AKTDATA=3) enabled
{                                                           (AKTDATA=4) disabled
{                       SCAN_3D_RECO_PROGRESS        136    indicates, that the
{                                                           reconstruction progress has
{                                                           been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed on TUI
{                       SCAN_3D_PLANE                137    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = ACS_SCAN_PLANE_ORB, 2 =
{                                                           ACS_SCAN_PLANE_ANG
{                       SCAN_3D_OBJECT               138    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = Tissue, 2 = Bone
{                       SCAN_3D_QUALITY              139    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = Low, 2 = Standard, 3 = High, 4
{                                                           = Obese
{                       NAVI_3D_ACTIVE               140
{                       SCAN_3D_PAT_ORIENTATION      141    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = supine, 2 = prone, 3 = left, 4
{                                                           = right
{                       SCAN_3D_SYS_POSITION         142    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = left, 2 = right, 3 = head, 4 =
{                                                           foot
{                       ZOOM_PAN_MENU                143    Indicates, that the zoom / pan
{                                                           menu has been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed on TUI
{                       SYSUNLOCK_ON_REQ             144    Request to show the Hipaa login
{                                                           dialog
{                                                           (AKTDATA=1) to open on FLC
{                       PAT_SIZE_SELECTION           150    This code is used in RAD3 system
{                                                           for patient size selection.
{                                                           AKTDATA=1: small size
{                                                           AKTDATA=2: medium size
{                                                           AKTDATA=3: big size
{                                                           AKTDATA=4: customized size
{                       KVM_SWITCH_CONTROL           200    Request to AppHost to switch KVM
{                                                           to imaging system.
{                                                           0 = No changes, 1 = Switch to
{                                                           imaging system
{                                                           KVM status from
{                                                           AppHost(iDFRNahBed):
{                                                           0 = no information, 1 = switched
{                                                           to imaging system, 2 = switched
{                                                           to AppHost
{                       APL_OPENAPPS_IN_USE          201
{                       VDM_ACTIVATE_3D_VIEW         2001
{                       VDM_ACTIVATE_VRT_PRESET      2002
{                       VDM_ENLARGE_3D_VIEW          2003
{                       VDM_STANDARD_ORIENTATION_3D  2004
{                       VDM_MOVE_MPR_PLANE_S         2005
{                       VDM_MOVE_MPR_PLANE_C         2006
{                       VDM_MOVE_MPR_PLANE_T         2007
{                       VDM_ROTATE_MPR_PLANE_S       2008
{                       VDM_ROTATE_MPR_PLANE_C       2009
{                       VDM_ROTATE_MPR_PLANE_T       2010
{                       VDM_ROTATE_VRT_X             2011
{                       VDM_ROTATE_VRT_Y             2012
{                       VDM_ROTATE_VRT_Z             2013
{                       VDM_MPR_THICKN_MENU          2014   indicates, that the MPR
{                                                           Thickness submenu has been
{                                                           opened/closed on TUI
{                       VDM_PARALLEL_RANGE_MENU      2015   indicates, that the Parallel
{                                                           Range submenu has been
{                                                           opened/closed on TUI
{                       VDM_HIDE_REF_LINES           2016
{                       VDM_ORTHO_ALIGNMENT          2017
{                       VDM_MPR_THICKNESS_REL        2018
{                       VDM_MPR_THICKNESS_ABS        2019   AKTDATA contains the MPR
{                                                           thickness in 0.1mm
{                                                           value -1 is used as reset
{                       VDM_SWAP_VOLUMES             2020   Swap the volume in between
{                                                           monitor A and B if AKDATA is 1.
{                                                           If AKTDATA is 0 then no
{                                                           swapping.
{                       VDM_VOL_REGIST_MENU          2021   indicates, that the Volume
{                                                           Registration submenu has been
{                                                           opened (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       VDM_SYNC_ADAPT_MONITOR       2022   Adapt changes in the monitor
{                                                           specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNC_LINK                2023   Switch linking between monitors
{                                                           on and off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNC_SYNC                2024   Synchronize settings from the
{                                                           monitor where the changes are
{                                                           adapted to the other one.
{                       VDM_SYNCW_ADAPT_MONITOR      2025   Adapt windowing changes in the
{                                                           monitor specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNCW_LINK               2026   Switch windowing parameter
{                                                           linking between monitors on and
{                                                           off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNCW_SYNC               2027   Synchronize windowing settings
{                                                           from the monitor where the
{                                                           changes are adapted to the other
{                                                           one.
{                       VDM_SYNCZ_ADAPT_MONITOR      2028   Adapt zoom/pan changes in the
{                                                           monitor specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNCZ_LINK               2029   Switch zoom/pan parameter
{                                                           linking between monitors on and
{                                                           off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNCZ_SYNC               2030   Synchronize zoom/pan settings
{                                                           from the monitor where the
{                                                           changes are adapted to the other
{                                                           one.
{                       VDM_MPR_THICKNESS_MON        2031   Monitor identifier text in MPR
{                                                           Thickness dialog.
{                                                           AKTDATA=0: ""
{                                                           AKTDATA=1: "Monitor A"
{                                                           AKTDATA=2: "Monitor B"
{                       VDM_REGIST_PAN_HOR           2032   Pan the second volume in the
{                                                           selected segment horizontally
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is right
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_PAN_VER           2033   Pan the second volume in the
{                                                           selected segment vertically
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is up
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_ROTATE            2034   Rotate the second volume in the
{                                                           selected segment
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive directions is
{                                                           clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_AUTO              2035   Start auto registration process
{                       VDM_REGIST_STORE             2036   Store the current registration
{                       VDM_REGIST_SELECT            2037   Set the selected registration
{                                                           AKTDATA = the current selection
{                       VDM_REGIST_CONSTR_MENU       2038   The Constraint Registration
{                                                           dialog was opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0)
{                       VDM_CLIPPLANE_MPR_MOVE       2039   Move clip plane forward or
{                                                           backward in MPR mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is forward
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_MPR_ROTATE     2040   Rotate clip plane left or right
{                                                           in MPR mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is right
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_MOVE       2041   Move clip plane forward or
{                                                           backward in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is forward
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_ROT_HOR    2042   Rotate clip plane around the
{                                                           horizontal axis clockwise or
{                                                           counter-clockwise in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_ROT_VER    2043   Rotate clip plane around the
{                                                           vertical axis clockwise or
{                                                           counter-clockwise in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_ENABLE         2044   Enable (AKTDATA=1) or disable
{                                                           (AKTDATA=0) the clip plane
{                       VDM_CLIPPLANE_ALIGN          2045   Align clipplane to the selected
{                                                           segment
{                       VDM_WORKMODE                 2046   switch from simple to advanced
{                                                           view
{                                                           - 1 for Simple View
{                                                           - 2 for Advanced View
{                                                           - (3 for Registration)
{                       APL_ACTIVATE_APP             2401   function related to "AppLink
{                                                           menu"
{                       APL_CONF_SWITCH_AFTER_XRAY   2403   function related to AppLink menu
{          Dimension: none

{AKTDATA Data for the command
{          Type:  Integer16     (DEC)
{          Range: -32000 ... 32000
{          Dimension: none


IDFRNAHBED

Object: IDFRNAHBED ___ID: 0268

Description: Imaging system confirms setting requested in telegram sDFRNahBed2.
Sender     :   FLC
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTANZAHL amount of actions
          Type:  Count     (CNT)
          Range: 1 ... 20
          Dimension: number of data blocks

{AKTCODE Code for remote control
{          Type:  Enum16     (DEC)
{          Range: 0 ... 2500
{                       BLAETTERN                    0      0=no action;
{                                                           1=image forward;
{                                                           -1=image backward;
{                                                           2=scene plus.;
{                                                           -2=scene minus
{                                                           3=page down (in doc mode)
{                                                           -3=page up (in doc mode)
{                                                           4=next multiframe scene (skip
{                                                           single images)
{                                                           -4=previous multiframe scene
{                                                           (skip single images)
{                       DISPLAY_MODE                 1      change from single display to
{                                                           4x4 display:
{                                                           0=no action
{                                                           1=Single image
{                                                           -1=splitmon (Stack Mode)
{                                                           2=Change Mode
{                                                           -2=Stripe Mode
{                       CHANGE_MARK                  2
{                       HARDCOPY                     3
{                       STORE_MONITOR                4
{                       DELETE_IMAGE                 5
{                       STORE_REFERENZ               6
{                       RECALL_REFERENZ              7
{                       TRANSFER_IMAGE               8      Transfer Image to network (DICOM
{                                                           export)
{                       VIDEOLOOP_REPLAY             9      control/show video loop status:
{                                                           0=no action; 1=replay
{                                                           active;2=replay stopped;-1=mode
{                                                           changed
{                       RL_MARKIERUNG                10     control left/right marker:
{                                                           0=no action; 1=no mark; 2=R;
{                                                           3=L; 4=misc1; 5=misc2; 6=misc3;
{                                                           7=misc4
{                       SUBTRAKTION_NATIV            11     sDFRNahBed: toggle between sub
{                                                           and native display
{                                                           iDFRNahBed: 1=sub; 2=nat;
{                                                           3=sub&nat
{                       REMASKING                    12     switch remasking on (PARAM=1) or
{                                                           off (PARAM=2)
{                       DETECTOR_SELECTION           13     If more than one wireless
{                                                           detector is attached to the
{                                                           system, the user can select at
{                                                           the TUI, if large or small
{                                                           detector shall be taken.
{                                                           AKTDATA: 1=large; 2=small
{                       FILTERUNGSPROGRAMM           14
{                       FILTERKERN                   15
{                       FILTERENHANCEMENT            16
{                       VERGROESSERUNG               17     switch on/off fixed digital zoom
{                                                           (x2):
{                                                           -1 = toggle
{                                                           1 = switch zoom off
{                                                           2 = switch zoom on
{                       INVERTIERUNG                 18
{                       ANATOMIC_BACKGROUND          19
{                       PEAK_OPACIFICATION           20
{                       AUTOSHUTTER                  21
{                       ZIELFADENKREUZ               22     AKTDATA=1: crosshair on
{                                                           AKTDATA=0: crosshair off
{                       ROADMAP_FLH                  23
{                       TRANSFER_REFMON              24     transfer image to reference
{                                                           monitor:
{                                                           AKTDATA=1: conventional AtoB
{                                                           AKTDATA=2: swap images: AtoB and
{                                                           BtoA
{                       W1                           25     brightness native
{                       W2                           26     contrast native
{                       W3                           27     brightness subtracted
{                       W4                           28     contrast subtracted
{                       SHUTTER_HOR                  29     horizontal shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       SHUTTER_VER                  30     vertical shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       ROAM_HOR                     31     roam horizontally: 1=right;
{                                                           2=left
{                       ROAM_VER                     32     roam verticallly
{                       KREIS_SHUT                   33     circular shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       STORE_FL_SZENE               34
{                       DISPLAY_FRAME                35     Reference monitor assigned to
{                                                           ultra sound device
{                                                           Aktdata:  0= reference 1 =
{                                                           Ultrasound
{                       CARE_POS                     36     switch ShowCarePosition on or
{                                                           off
{                                                           AKTDATA: 0=off; 1=on; -1=toggle
{                       ENDO_GRAB                    37     Aktdata: 0=stop movie / 1=start
{                                                           movie / 2=store endo image
{                       EMERGENCY_LEVEL              38     Aktdata:    0=OFF / 1=ON
{                       TABCARD_TOGGLE               39     Aktdata:    0=No Action / 1=Pat
{                                                           / 2=Exam / 3=Postproc / 4=Doc
{                       FLIP_IMG_HORIZONTAL          40     Aktdata:   0=No Action / 1=Off /
{                                                           2=On / -1=Toggle
{                       FLIP_IMG_VERTICAL            41     Aktdata:    0=No Action / 1=Off
{                                                           / 2=ON / -1=Toggle
{                       DOSECHANGE_LOW_STANDARD      42     Aktdata: 0 = Standard Dose; 1 =
{                                                           Low Dose
{                       DVD_RECORDER                 43     Param: 0 = NO_CHANGE; 1 =
{                                                           START_DVD_RECORDING; 2 =
{                                                           STOP_DVD_RECORDING
{                       MARK_R_POSITION              44     Aktdata: 0 = NO RIGHT MARK; 1 =
{                                                           UPPERLEFT; 2 = UPPERRIGHT; 3 =
{                                                           MIDLEFT; 4 = MIDRIGHT; 5 =
{                                                           LOWERLEFT; 6 = LOWERRIGHT; 7 =
{                                                           NO_MARK_SELECTED
{                       MARK_L_POSITION              45     Aktdata: 0 = NO LEFT MARK; 1 =
{                                                           UPPERLEFT; 2 = UPPERRIGHT; 3 =
{                                                           MIDLEFT; 4 = MIDRIGHT; 5 =
{                                                           LOWERLEFT; 6 = LOWERRIGHT; 7 =
{                                                           NO_MARK_SELECTED
{                       FORMAT_SEGMENTATION          46     Aktdata: 0 = NO_INFORMATION; 1 =
{                                                           FULL; 2 = 2VER; 3 = 2AVER; 4 =
{                                                           2HOR; 5 = 2AHOR; 6 = 3VER; 7 =
{                                                           1OF4
{                       REFRESH_ORGAN_PROGRAM        47     Param: 0 = no change; 1 =
{                                                           refresh
{                       REDO_ORGAN_PROGRAM           48     Used for Ysio, last organ
{                                                           program shall be used again.
{                       TOD                          49     Used to set table object
{                                                           distance, param between TOD_MIN,
{                                                           TOD_MAX
{                       LABEL_SELECT                 50     select label language; 1=R/L
{                                                           2=D/G 3=DEX/SIN
{                       PAT_EDIT                     51     button 'new patient' or 'correct
{                                                           patient data' pressed
{                                                           0=close pat dialog
{                                                           1=new patient
{                                                           2=show pat data
{                                                           3=generate ID
{                                                           4=delete
{                                                           5=filter
{                                                           6=unfilter
{                                                           7=protect
{                                                           8=unprotect
{                                                           9=save changes (=correct pat
{                                                           data)
{                       PAT_REGISTER                 52     button 'exam', 'add to worklist'
{                                                           or  'emergency patient' pressed
{                                                           AKTDATA: 1=exam, 2=add to
{                                                           worklist 3=emergency
{                       PAT_LIST                     53     buttons 'worklist' or 'previous
{                                                           patients' pressed
{                                                           AKT_DATA: 1=worklist,
{                                                           2=prevPatient, 0="return to
{                                                           patlist"
{                       PAT_CLOSE                    54     button 'end exam' pressed
{                                                           AKTDATA.bit0: (unused)
{                                                           AKTDATA.bit1: print summary
{                                                           AKTDATA.bit2: export summary
{                                                           AKTDATA.bit3: send MPPS
{                       WINDOW_LUT                   55     This allows the selection of a
{                                                           predefined LUT (set of window
{                                                           values)
{                                                           AKTDATA>0 number of fixed
{                                                           setting
{                                                           AKTDATA=0 deselects all (free
{                                                           window values)
{                                                           -1 step to next setting
{                                                           (used in surgery and urology)
{                       SAVE_FOR_UNDO                56     on receiving this code, FLC
{                                                           shall save the current set of
{                                                           image processing parameters for
{                                                           latter undo function
{                       UNDO_PROC                    57     FLC shall undo the recent change
{                                                           of image processing parameters
{                                                           AKTDATA=0: reset to loading
{                                                           default
{                                                           AKTDATA=1: go back to parameter
{                                                           set previously being saved with
{                                                           SAVE_FOR_UNDO
{                       INJCT_SYMB                   58     show injector symbol
{                                                           in iDFRNahBed also: mask has
{                                                           been successfully acquired
{                                                           (averaged)
{                       AVERAGING                    59     determines the averaging applied
{                                                           for LIH
{                                                           1=low; 2=normal; 3=high
{                                                           (fixed modification factor
{                                                           applied to value out of
{                                                           application/OGP)
{                       MOTION_DET                   60     selector to set the level for
{                                                           motion detection and k-factor
{                                                           (used in surgery)
{                                                           motion detector off: 1=low;
{                                                           2=standard; 3=high; 4=heart
{                                                           motion detector on: 11=low;
{                                                           12=standard;13=high
{                       IMG_ROTATE_REL               61     rotate image by the amount given
{                                                           in degrees AKTDATA relative to
{                                                           the current position
{                       IMG_ROTATE_ABS               62     rotate image to the value given
{                                                           in degrees AKTDATA
{                       MOVIE_SPEED                  63     defines the speed of the movie
{                                                           replay; iDFRNahBed uses code 0,
{                                                           iDFRBedAnz use codes 1-3
{                                                           following values are defined:
{                                                           0 - step to next; 1-slow;
{                                                           2-normal, 3-fast
{                       SELECT_FRAME                 64     image system shall show the
{                                                           frame number given in AKTDATA
{                                                           out of the current scene
{                       SET_SCENE_LIMIT              65     sets or resets the lower or
{                                                           upper delimiter for scene
{                                                           replay
{                                                           1=set lower limit, 2=set upper
{                                                           limit, 101=reset lower limit,
{                                                           102=reset upper limit
{                       STORAGE_RATE                 66     set storage rate reduction;
{                                                           param:
{                                                           1=100% store every frame
{                                                           2=50% store every other frame
{                                                           3=33% store every third frame
{                                                           4=25%, 5=20%, 10=10%
{                       ENABLE_AUTO_STORE            67     control autostore (in surgery):
{                                                           0=disable auto storage of fluoro
{                                                           scenes
{                                                           1=enable auto storage of LIH
{                                                           2= enable auto storage of LSH
{                                                           (last scene hold)
{                       AUTOWINDOW                   68     set the auto window function
{                                                           (0=off; 1=on)
{                       EXPORT_DIALOG                69     show export sub/nat select
{                                                           dialog (used in iDFRBedAnz for
{                                                           surgery)
{                                                           AKTDATA.bit0: 1-show, 0-hide
{                                                           AKTDATA.bit1: store native
{                                                           AKTDATA.bit2: store subtracted
{                                                           AKTDATA.bit3: store raw data
{                                                           AKTDATA.bit4: 1-PeakOp 0-entire
{                                                           scene
{                       DIGITAL_ZOOM                 70     slider position for digital zoom
{                                                           (used in surgery)
{                       BUTTONFIELD_ENA              71     enables or disables the buttons
{                                                           in the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                                                           note: since first button will
{                                                           always be active, bit0 is used
{                                                           to indicate, if there is a next
{                                                           page (i.e. if element16 rather
{                                                           than element0 is existing)
{                       MODE_RANGE                   72     activates or deactivates the
{                                                           range selection mode
{                       SELECT_RANGE_START           73     transfers the item number of the
{                                                           range start
{                                                           (used for multi-select in DOC
{                                                           mode in surgery)
{                       BUTTONFIELD_SEL              74     activates or deactivates the
{                                                           buttons in the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                       HOLD_REF                     75     ImageSystem shall freeze the
{                                                           reference monitor
{                       ENTER_SERVICE                76     start service
{                       CALC_PEAKOP                  77     triggers the calculation and
{                                                           storage of a new PeakOp image
{                       MODE_PAN                     78     enter(1) or leave(0) Pan Mode
{                                                           (CURSOR_HOR and CURSOR_VER refer
{                                                           to panning)
{                       CURSOR_HOR                   79     move cursor horizontally by the
{                                                           given amount
{                                                           (used for pan, pixel shift, draw
{                                                           line and quant)
{                       CURSOR_VER                   80     move cursor vertically  by the
{                                                           given amount
{                                                           (used for pan, pixel shift, draw
{                                                           line and quant)
{                       MODE_PIXEL_SHIFT             81     enter (1) or leave(0) the pixel
{                                                           shift mode
{                                                           (CURSOR_HOR and CURSOR_VER refer
{                                                           to pixel shift)
{                                                           (note: pixel shift values are in
{                                                           1/16 pixels
{                       AUTO_PIXEL_SHIFT             82     activates or deactivates auto
{                                                           pixel shift
{                                                           0=off; 1=on
{                       CALC_PIXEL_SHIFT             83     ImageSystem is requested to
{                                                           calculate the pixels shift (for
{                                                           all successful images?!)
{                       MODE_DRAW_LINE               84     activate or deactivate the draw
{                                                           line mode
{                                                           0=deactivate draw line mode
{                                                           1=activate draw line mode
{                                                           2=set point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=cancel
{                                                           6=end line
{                                                           7=edit line
{                       MODE_QUANT                   85     control the quant mode
{                                                           0=deactivate quant mode
{                                                           1=activate quant mode
{                                                           2=set point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=reset quant
{                                                           6=delete line
{                                                           7=calc contour
{                                                           8=correct contour
{                                                           9=move line 1 up
{                                                           10=move line 1 down
{                                                           11=move line 2 up
{                                                           12=move line 2 down
{                       CLOSE_PAT_DIALOG             86     show close patient dialog (used
{                                                           in surgery)
{                                                           AKTDATA.bit0: 1-show, 0-hide
{                                                           AKTDATA.bit1: print summary
{                                                           AKTDATA.bit2: export summary
{                                                           AKTDATA.bit3: send MPPS
{                                                           AKTDATA.bit8: 1-PatExistsDialog,
{                                                           0-ClosePatDialog
{                       BLOW_UP                      87     enable (1) or disable(0) blowup
{                                                           mode (i.e. segment from overview
{                                                           is shown enlarged on 2nd
{                                                           display)
{                       MODE_MULTISEL                88     activates/deactivates the multi
{                                                           selection mode (used in surgery
{                                                           to mark images)
{                       SHUTTER_CTRL                 89     bit0=left shutter; bit1=right
{                                                           shutter; bit2=upper shutter;
{                                                           bit3=lower shutter
{                                                           bit4: 1=shutter disabled;
{                                                           0=shutter normal
{                                                           bit5: 1=rotate shutter; 0=normal
{                                                           (move in/out)
{                                                           bit8-15: signed char specifying
{                                                           the amount to move the shutter
{                       NUM_MARKED                   90     number of elements (images in
{                                                           study or frames in image) that
{                                                           are marked
{                       RADIATION_ON_RQ              91     in sDFRNahBed XCU requests FLC
{                                                           to show the passcode dialog (to
{                                                           enable or disable x-ray):
{                                                           AKTDATA: 1=show passcode dialog;
{                                                           0=close passcode dialog
{                                                           FLC replies with iDFRNahBed:
{                                                           AKTDATA: 1=request granted;
{                                                           0=request denied
{                       BUTTONFIELD_MARK_VESS        92     activates or deactivates a
{                                                           vessel symbol on the buttons in
{                                                           the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                       MODE_ANNOTATE                93     control the annotate measure
{                                                           mode
{                                                           0=deactivate annotate measure
{                                                           mode
{                                                           1=activate annotate measure
{                                                           mode
{                                                           2=set 1st point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=calibrate
{                                                           6=delete graph
{                                                           7=set 2nd point
{                                                           8=text mode
{                                                           9=line mode
{                                                           10=angle mode
{                                                           11=free text mode
{                       SELECT_ANNOTATION            94     indicates the selection out of
{                                                           the list of predefined
{                                                           annotation text strings (that
{                                                           has been sent with sAnnotation)
{                       SHUTTER_MENU                 95     shall be sent from TUI-IF to
{                                                           FLC, if the shutter submenu is
{                                                           opened or closed
{                       AUTOLOOP                     96     autoloop button (used in surgery
{                                                           only); overrides the setting of
{                                                           the OGP/application:
{                                                           PARAM=0: image system shall show
{                                                           LIH
{                                                           PARAM=1: loop display shall be
{                                                           started right after acquisition
{                       SELECT_PEAKOP                97     select PeakOp (used in surgery)
{                                                           PARAM: -1=previous; +1=next
{                       SHOW_CARE_PROF               98     This code triggers display of
{                                                           care profile graphics on
{                                                           ImageSystem
{                       CHANGE_BRIGHTNESS            99     change window brightness (FLC
{                                                           knows if nat or sub)
{                                                           (used for button based control
{                                                           in surgery)
{                                                           AKTDATA=4: decrease brightness
{                                                           AKTDATA=2: increase brightness
{                                                           AKTDATA=0: off
{                       CHANGE_CONTRAST              100    change window contrast (FLC
{                                                           knows if nat or sub)
{                                                           (used for button based control
{                                                           in surgery)
{                                                           AKTDATA=4: decrease contrast
{                                                           AKTDATA=2: increase contrast
{                                                           AKTDATA=0: off
{                       SELECT_BUTTON                101    select a button in the overview
{                                                           buttonfield (on surgery xCP)
{                                                           AKTDATA contains the button
{                                                           number (0-15)
{                       MODE_MANAGED                 102    activates managed mode on FLC
{                       MODE_3D_DISP                 103    opens/activates 3D display and
{                                                           submenu
{                       ROT_FLIP_MENU                104    indicates, that the Rotate/Flip
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       BRIGHT_CONT_MENU             105    indicates, that the
{                                                           Brightness/Contrast submenu has
{                                                           been opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0) on TUI
{                       CLOSE_KEYB                   106    keyboard on TUI has been closed
{                       EDGE_ENH_MENU                107    indicates, that the Edge
{                                                           Enhancement submenu has been
{                                                           opened (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       SUB_NAT_MENU                 108    indicates, that the Sub/Nat
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       PEAK_OP_MENU                 109    indicates, that the PeakOp
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       DELETE_PAT_DIALOG            110    show delete patient dialog (used
{                                                           in surgery)
{                       SELECT_SCENE                 111    set/show the current scene
{                                                           number
{                                                           (currently only used in
{                                                           iDFRBedAnz)
{                       MODAL_BOX_DIALOG             112    On this code in iDFRBedAnz TUI
{                                                           shall open(1) or close(0) a
{                                                           special message box.
{                                                           On this code in sDFRNahBed2 FLC
{                                                           shall close the modal box.
{                       RESET_ZOOM                   113    zoom (and pan) shall be reset
{                                                           (ViewAll functionality)
{                       CANCEL_PROGRESS              114    cancel button on the generic
{                                                           progress bar on TUI
{                       MOVIE_MENU                   115    TUI-IF reports that the movie
{                                                           menu is opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0)
{                       COLLIMATOR_MENU              116    shall be sent from TUI-IF to
{                                                           FLC, if the collimator submenu
{                                                           is opened or closed
{                       MODE_DUAL_3D_DISPLAY         117    opens/activates dual display
{                                                           mode and submenu
{                       SWITCH_INPUT_FIELD           118    switches input field focus (e.g.
{                                                           in patient registration dialog)
{                                                           1=jump to next input field
{                                                           -1=jump to previous input field
{                       TUI_TABCARD_SWITCH           119    in sBedDFR/sDFRNahBed: TUI
{                                                           informs FLC on selected tabcard
{                                                           in iDFRNahBed/iDFRBedAnz: FLC
{                                                           selects a tabcard at TUI
{                                                           (used in surgery)
{                                                           1 = prep tabcard
{                                                           2 = proc tabcard
{                                                           3 = ext tabcard
{                                                           4 = IGS tabcard
{                       SURG_METAL_CORR              120    control metal correction feature
{                                                           (image processing)
{                                                           AKTDATA: 0=off; 1=on
{                       HIDE_GRAPHICS                121    hide all graphic overlays
{                       LARGE_TUI_PREVIEW            122    switch on/off stream for large
{                                                           image display on TUI
{                       SUBAUTOWIN                   123    autowindow for road and sub
{                                                           (1=trigger)
{                       ONSUB_ONNAT                  124    determines, if the values for
{                                                           WINDOW_LUT and INVERTIERUNG are
{                                                           to be applied on subtracted or
{                                                           native image
{                                                           0 = apply to both
{                                                           1 = apply to native
{                                                           2 = apply to subtracted
{                       SPATIAL_NOISE_FILTER         125    spatial noise filter setting
{                                                           0 = off
{                                                           1 = low
{                                                           2 = medium
{                                                           3 = high
{                       RADIATION_ON_YES             126    "yes" button at radiation on
{                                                           dialog pressed
{                       NO_ZOOMDOSE_ADPT             127    AKTDATA:
{                                                           0: normal zoom dose adaption
{                                                           1: no zoom dose adaption
{                       KWIRE                        128    indicates, that FLC shall the
{                                                           k-wire functionality
{                                                           (AKTDATA=1) switched on
{                                                           (AKTDATA=0) switched off
{                       STORE_NGS                    129    Store NGS stream as single image
{                                                           (similar to STORE_MONITOR)
{                       OPENAPPS_MAN_IMG_TRANS       130    Manual image transfer from
{                                                           imaging system to AppHost
{                       IMAGE_FOR_APP_AVAILABLE      131    a new image is available to be
{                                                           transferred to the APP
{                       STORE_SNAPSHOT               132    Snapshot active (cummulated
{                                                           fluoro image).
{                                                           This code is used to inform XCU
{                                                           in iDFRNahBed that certain
{                                                           functions must be (temporarily)
{                                                           disabled.
{                                                           (AKTDATA=0) not active
{                                                           (AKTDATA=1) snapshot active
{                       DOSE_CONTROL_ROI_MENU        133    Indicates, that the region of
{                                                           interest (ROI) for dose control
{                                                           submenu has been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed at TUI
{                       DOSE_CONTROL_ROI             134    Region of interest (ROI) for
{                                                           dose control settings shall be
{                                                           set to
{                                                           (AKTDATA=1) on
{                                                           (AKTDATA=2) off
{                                                           (AKTDATA=3) enabled
{                                                           (AKTDATA=4) disabled
{                       SCAN_3D_RECO_PROGRESS        136    indicates, that the
{                                                           reconstruction progress has
{                                                           been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed on TUI
{                       SCAN_3D_PLANE                137    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = ACS_SCAN_PLANE_ORB, 2 =
{                                                           ACS_SCAN_PLANE_ANG
{                       SCAN_3D_OBJECT               138    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = Tissue, 2 = Bone
{                       SCAN_3D_QUALITY              139    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = Low, 2 = Standard, 3 = High, 4
{                                                           = Obese
{                       NAVI_3D_ACTIVE               140
{                       SCAN_3D_PAT_ORIENTATION      141    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = supine, 2 = prone, 3 = left, 4
{                                                           = right
{                       SCAN_3D_SYS_POSITION         142    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = left, 2 = right, 3 = head, 4 =
{                                                           foot
{                       ZOOM_PAN_MENU                143    Indicates, that the zoom / pan
{                                                           menu has been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed on TUI
{                       SYSUNLOCK_ON_REQ             144    Request to show the Hipaa login
{                                                           dialog
{                                                           (AKTDATA=1) to open on FLC
{                       PAT_SIZE_SELECTION           150    This code is used in RAD3 system
{                                                           for patient size selection.
{                                                           AKTDATA=1: small size
{                                                           AKTDATA=2: medium size
{                                                           AKTDATA=3: big size
{                                                           AKTDATA=4: customized size
{                       KVM_SWITCH_CONTROL           200    Request to AppHost to switch KVM
{                                                           to imaging system.
{                                                           0 = No changes, 1 = Switch to
{                                                           imaging system
{                                                           KVM status from
{                                                           AppHost(iDFRNahBed):
{                                                           0 = no information, 1 = switched
{                                                           to imaging system, 2 = switched
{                                                           to AppHost
{                       APL_OPENAPPS_IN_USE          201
{                       VDM_ACTIVATE_3D_VIEW         2001
{                       VDM_ACTIVATE_VRT_PRESET      2002
{                       VDM_ENLARGE_3D_VIEW          2003
{                       VDM_STANDARD_ORIENTATION_3D  2004
{                       VDM_MOVE_MPR_PLANE_S         2005
{                       VDM_MOVE_MPR_PLANE_C         2006
{                       VDM_MOVE_MPR_PLANE_T         2007
{                       VDM_ROTATE_MPR_PLANE_S       2008
{                       VDM_ROTATE_MPR_PLANE_C       2009
{                       VDM_ROTATE_MPR_PLANE_T       2010
{                       VDM_ROTATE_VRT_X             2011
{                       VDM_ROTATE_VRT_Y             2012
{                       VDM_ROTATE_VRT_Z             2013
{                       VDM_MPR_THICKN_MENU          2014   indicates, that the MPR
{                                                           Thickness submenu has been
{                                                           opened/closed on TUI
{                       VDM_PARALLEL_RANGE_MENU      2015   indicates, that the Parallel
{                                                           Range submenu has been
{                                                           opened/closed on TUI
{                       VDM_HIDE_REF_LINES           2016
{                       VDM_ORTHO_ALIGNMENT          2017
{                       VDM_MPR_THICKNESS_REL        2018
{                       VDM_MPR_THICKNESS_ABS        2019   AKTDATA contains the MPR
{                                                           thickness in 0.1mm
{                                                           value -1 is used as reset
{                       VDM_SWAP_VOLUMES             2020   Swap the volume in between
{                                                           monitor A and B if AKDATA is 1.
{                                                           If AKTDATA is 0 then no
{                                                           swapping.
{                       VDM_VOL_REGIST_MENU          2021   indicates, that the Volume
{                                                           Registration submenu has been
{                                                           opened (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       VDM_SYNC_ADAPT_MONITOR       2022   Adapt changes in the monitor
{                                                           specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNC_LINK                2023   Switch linking between monitors
{                                                           on and off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNC_SYNC                2024   Synchronize settings from the
{                                                           monitor where the changes are
{                                                           adapted to the other one.
{                       VDM_SYNCW_ADAPT_MONITOR      2025   Adapt windowing changes in the
{                                                           monitor specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNCW_LINK               2026   Switch windowing parameter
{                                                           linking between monitors on and
{                                                           off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNCW_SYNC               2027   Synchronize windowing settings
{                                                           from the monitor where the
{                                                           changes are adapted to the other
{                                                           one.
{                       VDM_SYNCZ_ADAPT_MONITOR      2028   Adapt zoom/pan changes in the
{                                                           monitor specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNCZ_LINK               2029   Switch zoom/pan parameter
{                                                           linking between monitors on and
{                                                           off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNCZ_SYNC               2030   Synchronize zoom/pan settings
{                                                           from the monitor where the
{                                                           changes are adapted to the other
{                                                           one.
{                       VDM_MPR_THICKNESS_MON        2031   Monitor identifier text in MPR
{                                                           Thickness dialog.
{                                                           AKTDATA=0: ""
{                                                           AKTDATA=1: "Monitor A"
{                                                           AKTDATA=2: "Monitor B"
{                       VDM_REGIST_PAN_HOR           2032   Pan the second volume in the
{                                                           selected segment horizontally
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is right
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_PAN_VER           2033   Pan the second volume in the
{                                                           selected segment vertically
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is up
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_ROTATE            2034   Rotate the second volume in the
{                                                           selected segment
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive directions is
{                                                           clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_AUTO              2035   Start auto registration process
{                       VDM_REGIST_STORE             2036   Store the current registration
{                       VDM_REGIST_SELECT            2037   Set the selected registration
{                                                           AKTDATA = the current selection
{                       VDM_REGIST_CONSTR_MENU       2038   The Constraint Registration
{                                                           dialog was opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0)
{                       VDM_CLIPPLANE_MPR_MOVE       2039   Move clip plane forward or
{                                                           backward in MPR mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is forward
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_MPR_ROTATE     2040   Rotate clip plane left or right
{                                                           in MPR mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is right
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_MOVE       2041   Move clip plane forward or
{                                                           backward in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is forward
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_ROT_HOR    2042   Rotate clip plane around the
{                                                           horizontal axis clockwise or
{                                                           counter-clockwise in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_ROT_VER    2043   Rotate clip plane around the
{                                                           vertical axis clockwise or
{                                                           counter-clockwise in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_ENABLE         2044   Enable (AKTDATA=1) or disable
{                                                           (AKTDATA=0) the clip plane
{                       VDM_CLIPPLANE_ALIGN          2045   Align clipplane to the selected
{                                                           segment
{                       VDM_WORKMODE                 2046   switch from simple to advanced
{                                                           view
{                                                           - 1 for Simple View
{                                                           - 2 for Advanced View
{                                                           - (3 for Registration)
{                       APL_ACTIVATE_APP             2401   function related to "AppLink
{                                                           menu"
{                       APL_CONF_SWITCH_AFTER_XRAY   2403   function related to AppLink menu
{          Dimension: none

{AKTDATA Data for the command
{          Type:  Integer16     (DEC)
{          Range: -32000 ... 32000
{          Dimension: none


IDFRPATPOS

Object: IDFRPATPOS ___ID: 00AF

Description: Transfer current patient position
Sender     :   FLC
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

PAT_POS_STRING1 Current patient position, sent from ImageSystem to XCU, 12 chars UNICODE
          Type:  String16 [ 12 ]     (ASCII)
          Range: 24 ... 24
          Dimension: none

PAT_POS_STRING2 Current patient position, sent from ImageSystem to XCU, 12 chars UNICODE
          Type:  String16 [ 12 ]     (ASCII)
          Range: 24 ... 24
          Dimension: none

PAT_ACTIVE ImageSystem tells XCU whether a patient is chosen or not.
ACS_YES: A patient is selected
ACS_NO: No patient is selected
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_INFORMATION  0
                     ACS_YES         1
                     ACS_NO          2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IDFRPOWERREQ

Object: IDFRPOWERREQ ___ID: 0283

Description: ImgSys shows status of power down.
              Sent by FLC to its own APIDs to stop XCS readloops.
Sender     :   FLC
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF

List of Parameters:

SHOW_POWERDOWN Status of shutdown sequence
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     IN_ARBEIT           1   in progress
                     BEENDET             2   cancelled
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IDFRSTATUS

Object: IDFRSTATUS ___ID: 025A

Description: status of DFR. Is used to control, whether fluoro and exposure are possible
              from side of imaging system. Is also used to control checkmark and text in the
              status line on TUI and FLC
Sender     :
Receiver   :
Mode       :  DIRECT(01)
Systems    :  Rad3 and SharpfinObs

List of Parameters:

DFRAUFNBEREIT DFR is ready for exposure or the reason, why DFR is not ready for exposure
(note: just 1 and 19 are "ready")
          Type:  Byte     (DEC)
          Range: 0 ... 38
                     NEIN                            0    no
                     JA                              1    yes
                     NO_PATIENT                      2    DFR not ready because no patient
                                                          is selected
                     NO_IMAGE_MEMORY                 3    DFR not ready because there is not
                                                          enough image memory available
                     SERVICE_MODE_                   4    DFR not ready because it is in
                                                          service mode.
                     FD_ERROR_                       5    DFR not ready because there is an
                                                          Detector error.
                     FLC_ON_ERROR                    6    DFR not ready because there is an
                                                          error concerning the ImageSystem
                     ACQ_BLOCKED_BY_HIPAA            7    DFR is not ready because it is
                                                          blocked by HIPAA
                     NO_OGP_SELECTED                 8    DFR is not ready because no OGP
                                                          has been selected.
                     FD_RECOVERING                   9    DFR is not ready because the FD is
                                                          recovering.
                     FD_TOO_HOT                      11   DFR is not ready because the
                                                          Detector is too hot.
                     NO_XRAY_BEC_FOLDER_PROTECTED    12   DFR not ready because the
                                                          patient's folder is closed.
                     FLC_IN_DOC_MODE                 13   ImageSystem is in Documentation
                                                          mode
                     FLC_IN_POSTPROC_MODE            14   ImageSystem is in post processing
                                                          mode
                     FD_OFFSET_IN_PROGRESS           15   FD offset is in progress
                     FD_WLAN_TOO_LOW                 16   For Ysio: WLAN power is too low
                                                          for acquisition.
                     FLC_BLOCKING_DIALOG_OPEN        17   a blocking operation is active at
                                                          ImgSys (e.g. Exam Manager or other
                                                          dialog)
                     FD_BATTERY_TOO_LOW              18   Battery of mobile detector is too
                                                          low for Acquisition.
                     LOW_BATT_ACQ_POSSIBLE           19   Battery of wireless FD is low but
                                                          acquisition still possible (for
                                                          future use)
                     FD_NOT_IN_OP_STATE              20   Detector not in operating state
                     FD_CONFG_OUT                    21   Detector configured out
                     FD_IMG_RECOV                    22   Detector image recovery in
                                                          progress
                     NO_FD_CABLE_FOR_ORTHO           23   wi-D BK cable not connected for
                                                          Ortho acquisition
                     DFR_ORTHO_UI_NOT_IN_STEP_1      24   The Ortho UI (on ImgSys) is not in
                                                          step 1; therefore the latest
                                                          iOrgDaten being distributed was
                                                          not the one to be used for next
                                                          shot (because acq will start with
                                                          step 1 always
                     FLC_IN_COMPOSING_MODE           25   no fluoro or acquisition possible
                                                          since ImgSys is in ortho composing
                                                          mode
                     FLC_NO_IMAGE_PARTITION          26   no image partition is available
                                                          (service ongoing)
                     DROC_IQAP_IMG_RECEIVED          27   DROC has received and saved the
                                                          exposure image successfully when
                                                          performing IQAP acquisition (used
                                                          in RAD3 VA10 only)
                     DROC_IN_VIEW_MODE               32   DROC is in view mode (used in
                                                          RAD3)
                     DROC_IN_PRINT_MODE              33   DROC is in print mode (used in
                                                          RAD3)
                     AUTO_ORTHO_RANGE_NOT_CONFIRMED  37   The ortho range being
                                                          automatically determined by camera
                                                          image and AI software has not been
                                                          confirmed by user
                     IN_ORTHO_STITCHING_MODE         38   DROC is in ortho stiching mode
                                                          (used in RAD3)
          Dimension: none

DFRDLBEREIT DFR ready for fluoro or the reason why it is not ready
(note: just 1 and 19 are "ready")
          Type:  Byte     (DEC)
          Range: 0 ... 26
                     NEIN                          0    no
                     JA                            1    yes
                     NO_PATIENT                    2    DFR not ready because no patient is
                                                        selected
                     NO_IMAGE_MEMORY               3    DFR not ready because there is not
                                                        enough image memory available
                     SERVICE_MODE_                 4    DFR not ready because it is in
                                                        service mode.
                     FD_ERROR_                     5    DFR not ready because there is an
                                                        Detector error.
                     FLC_ON_ERROR                  6    DFR not ready because there is an
                                                        error concerning the ImageSystem
                     ACQ_BLOCKED_BY_HIPAA          7    DFR is not ready because it is
                                                        blocked by HIPAA
                     NO_OGP_SELECTED               8    DFR is not ready because no OGP has
                                                        been selected.
                     FD_RECOVERING                 9    DFR is not ready because the FD is
                                                        recovering.
                     NO_FLUORO_RAD_MODE_SELECTED   10   DFR not ready for fluoro because rad
                                                        mode is selected.
                     FD_TOO_HOT                    11   DFR is not ready because the
                                                        Detector is too hot.
                     NO_XRAY_BEC_FOLDER_PROTECTED  12   DFR not ready because the patient's
                                                        folder is closed.
                     FLC_IN_DOC_MODE               13   ImageSystem is in Documentation mode
                     FLC_IN_POSTPROC_MODE          14   ImageSystem is in post processing
                                                        mode
                     FD_OFFSET_IN_PROGRESS         15   FD offset is in progress
                     FD_WLAN_TOO_LOW               16   For Ysio: WLAN power is too low for
                                                        acquisition.
                     FLC_BLOCKING_DIALOG_OPEN      17   a blocking operation is active at
                                                        ImgSys (e.g. Exam Manager or other
                                                        dialog)
                     FD_BATTERY_TOO_LOW            18   Battery of mobile detector is too
                                                        low for Acquisition.
                     LOW_BATT_ACQ_POSSIBLE         19   Battery of wireless FD is low but
                                                        acquisition still possible (for
                                                        future use)
                     FD_NOT_IN_OP_STATE            20   Detector not in operating state
                     FD_CONFG_OUT                  21   Detector configured out
                     FD_IMG_RECOV                  22   Detector image recovery in progress
                     NO_FD_CABLE_FOR_ORTHO         23   wi-D BK cable not connected for
                                                        Ortho acquisition
                     DFR_ORTHO_UI_NOT_IN_STEP_1    24   The Ortho UI (on ImgSys) is not in
                                                        step 1; therefore the latest
                                                        iOrgDaten being distributed was not
                                                        the one to be used for next shot
                                                        (because acq will start with step 1
                                                        always
                     FLC_IN_COMPOSING_MODE         25   no fluoro or acquisition possible
                                                        since ImgSys is in ortho composing
                                                        mode
                     FLC_NO_IMAGE_PARTITION        26   no image partition is available
                                                        (service ongoing)
          Dimension: none


IDFRSTATUS2

Object: IDFRSTATUS2 ___ID: 0261

Description: status of image system (intended to replace iDFRStatus);
              must at least contain one status for fluoro and one status for acquisition
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

NO_STATES number of states
          Type:  Dcount     (CNT)
          Range: 1 ... 40
          Dimension: none

{FLUORO_EXPOSURE determines, if the following status value is valid for fluoro or exposure
{          Type:  Enum8     (DEC)
{          Range: 0 ... 2
{                       ACS_FLUORO    1
{                       ACS_EXPOSURE  2
{          Dimension: none

{DFRBEREIT DFR ready status or reason, why DFR is not ready
(note: just 1, 19 and 31 are "ready")
(note: the value 0 is the default for "not ready" in case none of the other reasons applies)
(note: UIS does only use the codes 0, 1, 24 and 35)
{          Type:  Byte     (DEC)
{          Range: 0 ... 39
{                       NEIN                            0    no
{                       JA                              1    yes
{                       NO_PATIENT                      2    DFR not ready because no
{                                                            patient is selected
{                       NO_IMAGE_MEMORY                 3    DFR not ready because there is
{                                                            not enough image memory
{                                                            available
{                       SERVICE_MODE_                   4    DFR not ready because it is in
{                                                            service mode.
{                       FD_ERROR_                       5    DFR not ready because there is
{                                                            an Detector error.
{                       FLC_ON_ERROR                    6    DFR not ready because there is
{                                                            an error concerning the
{                                                            ImageSystem
{                       ACQ_BLOCKED_BY_HIPAA            7    DFR is not ready because it is
{                                                            blocked by HIPAA
{                       NO_OGP_SELECTED                 8    DFR is not ready because no OGP
{                                                            has been selected.
{                       FD_RECOVERING                   9    DFR is not ready because the FD
{                                                            is recovering.
{                       NO_FLUORO_RAD_MODE_SELECTED     10   DFR not ready for fluoro
{                                                            because rad mode is selected.
{                       FD_TOO_HOT                      11   DFR is not ready because the
{                                                            Detector is too hot.
{                       NO_XRAY_BEC_FOLDER_PROTECTED    12   DFR not ready because the
{                                                            patient's folder is closed.
{                       FLC_IN_DOC_MODE                 13   ImageSystem is in Documentation
{                                                            mode
{                       FLC_IN_POSTPROC_MODE            14   ImageSystem is in post
{                                                            processing mode
{                       FD_OFFSET_IN_PROGRESS           15   FD offset is in progress
{                       FD_WLAN_TOO_LOW                 16   For Ysio: WLAN power is too low
{                                                            for acquisition.
{                       FLC_BLOCKING_DIALOG_OPEN        17   a blocking operation is active
{                                                            at ImgSys (e.g. Exam Manager or
{                                                            other dialog)
{                       FD_BATTERY_TOO_LOW              18   Battery of mobile detector is
{                                                            too low for Acquisition.
{                       LOW_BATT_ACQ_POSSIBLE           19   Battery of wireless FD is low
{                                                            but acquisition still possible
{                                                            (for future use)
{                       FD_NOT_IN_OP_STATE              20   Detector not in operating state
{                       FD_CONFG_OUT                    21   Detector configured out
{                       FD_IMG_RECOV                    22   Detector image recovery in
{                                                            progress
{                       NO_FD_CABLE_FOR_ORTHO           23   wi-D BK cable not connected for
{                                                            Ortho acquisition
{                       DFR_ORTHO_UI_NOT_IN_STEP_1      24   The Ortho UI (on ImgSys) is not
{                                                            in step 1; therefore the latest
{                                                            iOrgDaten being distributed was
{                                                            not the one to be used for next
{                                                            shot (because acq will start
{                                                            with step 1 always
{                       FLC_IN_COMPOSING_MODE           25   no fluoro or acquisition
{                                                            possible since ImgSys is in
{                                                            ortho composing mode
{                       FLC_NO_IMAGE_PARTITION          26   no image partition is available
{                                                            (service ongoing)
{                       PATIENT_POSITION_NOT_DEFINED    27   no patient position selected
{                                                            (which is mandatory for certain
{                                                            3D trajectories)
{                       MAIN_UNIT_MISMATCH              28   surgery only: main unit
{                                                            attached to trolley does not
{                                                            match
{                       PROCESS_3D_ACTIVE               29   ImageSystem is not ready since
{                                                            3D image processing is active
{                       NO_3D_CALIBRATION_DATA          30
{                       LOW_IMAGE_MEM_ACQ_POSSIBLE      31   disk space is less than 400
{                                                            frames; 3D scans are inhibited
{                                                            (used in surgery)
{                       DROC_IN_VIEW_MODE               32   DROC is in view mode (used in
{                                                            RAD3)
{                       DROC_IN_PRINT_MODE              33   DROC is in print mode (used in
{                                                            RAD3)
{                       TOO_MANY_FREE_FD_S              34   more than one large FD is in
{                                                            free position (i.e. is not in
{                                                            any tray)
{                       NO_GEN_PARAMS_SHOWN             35   Image System is currently in a
{                                                            different task and does not
{                                                            show generator parameters (as
{                                                            required before acquisition by
{                                                            law)
{                       STOP_FLUORO_FOR_AUTOSTORE       36   This is needed to stop fluoro
{                                                            before starting single shot in
{                                                            case AutoFluoroLoop is active
{                       AUTO_ORTHO_RANGE_NOT_CONFIRMED  37   The ortho range being
{                                                            automatically determined by
{                                                            camera image and AI software
{                                                            has not been confirmed by user
{                       IN_ORTHO_STITCHING_MODE         38   DROC is in ortho stiching mode
{                                                            (used in RAD3)
{                       DFR_UPDATE_RUNNING              39   the image system is not ready
{                                                            since an updated is running
{          Dimension: none


IDLANZ

Object: IDLANZ ___ID: 007B

Description: display of fluoro parameters.
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DLBA This set of Byte determines the Fluoro mode: | Bit 0(=1) Kontinuierlich continuous fluoro (=continuous wave without pulses) | Bit 1(=2) Hochkontrast high contrast (equivalent to max skin dose rate is 20 R/min instead of 10R/min | Bit 2(=4): Hand manual fluoro, kV and mA can be set manually without using automatic regulation (no longer permitted in Germany or USA) | Bit 3 (=8) Gepulst pulsed fluoro mode | Bit 4(=16) Supervision Supervision, two grabed image of a continuous fluoro are added to reduce noise | Bit 5(=32) RM Roadmap, automatic subtraction in fluoro | Samples: Standard fluoro cont: 1, Supervision: 17, Supervision Roadmap: 49, pulsed: 8, pulsed + high contrast: 10
          Type:  Byte     (DEC)
          Range: 1 ... 49
                     DLBA_KONTINUIERLICH  1
                     DLBA_HOCHKONTRAST    2
                     DLBA_HAND            4
                     DLBA_GEPULST         8
                     DLBA_SUPERVISION     16
                     DLBA_ROADMAP         32
          Dimension: set of bits

DLPROG Fluoro program number is the number of the active fluoro button On control console.
(only RFU - not used in surgery)
sample: 1 (e.g. low dose curve), 2 (medium dose curve), 3 (e.g. high dose curve) are buttons on the user control console, 4 for usual is the high contrast (higher skindose rate) fluoro button, 6 service, 9 Roadmap. If the user selects number 1 (that is marked in the user manual as low dose program) he still can change in between this program the pulse frequency or respectively the supervision mode
          Type:  Byte     (DEC)
          Range: 1 ... 19
          Dimension: none

DLSTOP fluoro stop selected, the automatic fluoro dose control is frozen
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DLHUPE fluoro buzzer, will be turned on if the DL limit is reached, and if fluoro is on
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

GEPDLSTUFE Fluoro speed step. 0=cont fluoro, 1 = 15 fps, 2 = 10fps, 3 =7.5 fps, 4 = 3 fps, 5 = 30 fps
          Type:  Byte     (DEC)
          Range: 0 ... 5
          Dimension: none

DL_LIMIT fluoro warning level (DL-limit) reached (note: the buzzer clearance button is always shown)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SKDOSEBUZZ skin dose buzzer, will be turned on if reference air kerma limit is reached and fluoro (or exposure) is on
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SKDOSELIMIT reference air kerma warning level reached
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

FL_FREQ_ACT actual pulse rate fluoro
          Type:  Word     (DEC)
          Range: 0 ... 300
          Dimension: 0.1 fps

ACQ_MODE (fluoro) acquisition mode for which the current set is valid (used in surgery)
          Type:  Enum8     (DEC)
          Range: 0 ... 7
                     ACS_NO_INFORMATION  0
                     ACS_ACQM_FLUORO     1
                     ACS_ACQM_ROADMAP    2
                     ACS_ACQM_SUB        3
                     ACS_ACQM_DR         4
                     ACS_ACQM_DCM        5
                     ACS_ACQM_3D         6   3D Acquisition mode (note: this code is used in
                                             iDLAnz only, not in sDLProgDaten)
          Dimension: none

DOSE_LEVEL doselevel for which the current set is valid (used in surgery)
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_DOSL_LOW        1
                     ACS_DOSL_NORMAL     2
                     ACS_DOSL_HIGH       3
          Dimension: none


IDLDATEN001

Object: IDLDATEN001 ___ID: 02D9

Description: current fluoro X-ray parameter of non-pulsed fluoro sent from generator to
              XCU. Is used to feed the tube load calculator, the display of the fluoro
              (iDLIstAnz) and to calculate the forecast for exposures in case of 0-pnt tech.
              DPF-RAW is not in use with current DAP-meters. (is sent in iDAPVAlue)
Sender     :   GEN-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAIST_H current of actual pulse (or of continuous fluoro)
(like MAIST in higher resolution (dimension is 0.01mA))
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: 0.01 mA

DFP_RAW nonweighted raw data of the dose area product as received directly from the measurement chamber.
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

DLABW difference of the current X-ray data to the desired dose
          Type:  Integer16     (DEC)
          Range: -40 ... 40
          Dimension: 0.25 BP

REGZUS State of the regulation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     OBERER_ANSCHLAG     1   at upper limit
                     UNTERER_ANSCHLAG    2   at lower limit
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IDLISTANZ

Object: IDLISTANZ ___ID: 007C

Description: display of the current fluoro parameters in case of non-pulsed fluoro
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

KVDL Fluoro voltage; during fluoro this is the actual voltage, in fluoro breaks the mean value since last fluoro time reset will be shown
          Type:  Integer16     (DEC)
          Range: 0 ... 1500
          Dimension: 0.1 kV

MA Current of fluoro or acquisition
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA

MIN fluoro time since last reset (e.g. a change of patient)
(Min derives from minute, although value is given in seconds)
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: sek

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IDLPULSEDDATEN

Object: IDLPULSEDDATEN ___ID: 02D7

Description: current fluoro X-ray parameter of pulsed fluoro sent from generator to XCU. Is
              used to feed the tube load calculator, the display of the fluoro (iDLIstAnz)
              and to calculate the forecast for exposures in case of 0-pnt tech. DPF-RAW is
              not in use with current DAP-meters. (is sent in iDAPVAlue)
Sender     :   GEN-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAIST current of actual fluoro pulse
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: 0.1 mA

DFP_RAW nonweighted raw data of the dose area product as received directly from the measurement chamber.
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

PULSETIME pulse width
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

PULSEPROZ Duty cycle
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 0.1 %

DLABW difference of the current X-ray data to the desired dose
          Type:  Integer16     (DEC)
          Range: -40 ... 40
          Dimension: 0.25 BP

REGZUS State of the regulation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     OBERER_ANSCHLAG     1   at upper limit
                     UNTERER_ANSCHLAG    2   at lower limit
          Dimension: none

PULSE amount of pulses combined in this telegram (this is used if frame rate is too high to send a separate telegram for each pulse)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IDLPULSEDISTANZ

Object: IDLPULSEDISTANZ ___ID: 00A3

Description: display of the current fluoro parameters in case of pulsed fluoro
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

KVDL Fluoro voltage; during fluoro this is the actual voltage, in fluoro breaks the mean value since last fluoro time reset will be shown
          Type:  Integer16     (DEC)
          Range: 0 ... 1500
          Dimension: 0.1 kV

MA Current of fluoro or acquisition
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA

PULSETIME pulse width
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

PULSEPROZ Duty cycle
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 0.1 %

MIN fluoro time since last reset (e.g. a change of patient)
(Min derives from minute, although value is given in seconds)
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: sek

REGZUS State of the regulation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     OBERER_ANSCHLAG     1   at upper limit
                     UNTERER_ANSCHLAG    2   at lower limit
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IDLSTATUS

Object: IDLSTATUS ___ID: 02C7

Description: fluoro status of generator, sent from generator to XCU
Sender     :   GEN-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

DLBEREIT Ready for fluoro
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IDOSEREQUESTED

Object: IDOSEREQUESTED ___ID: 02B9

Description: This is the requested dose to be compared with the measured dose in iDexi.
              XCU sends Dose requested to GEN(-IF) and ImageSystem if:
              - a new OGP is active
              - Zoom was changed
              - Framerate was changed
Sender     :   XCU
Receiver   :   FLC   GEN-IF   UGEN   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DOSE_REQUESTED_ACQ requested acquisition dose
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
                     VALUE_NOT_VALID  0
          Dimension: 0.01 nGy

DOSE_REQUESTED_FL requested fluoro dose
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
                     VALUE_NOT_VALID  0
          Dimension: 0.01 nGy

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY8
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IERRORLOG2

Object: IERRORLOG2 ___ID: 02B8

Description: If iFehler/iFehler2 or REP_ERR are received by XCU, it will send this
              errormessage to FLC in order to log the error in FL-C log. iErrorLog2 is sent
              direct to that component, that has sent iErrorlogsync
Sender     :   XCU
Receiver   :   FLC
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and Sharpfin

List of Parameters:

YEAR Year
          Type:  Byte     (DEC)
          Range: 0 ... 99
          Dimension: none

MONTH Month
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

DAY Day
          Type:  Byte     (DEC)
          Range: 1 ... 31
          Dimension: none

HOUR Hour
          Type:  Byte     (DEC)
          Range: 0 ... 23
          Dimension: none

MINUTE Minute
          Type:  Byte     (DEC)
          Range: 0 ... 59
          Dimension: none

SECOND Second
          Type:  Byte     (DEC)
          Range: 0 ... 59
          Dimension: none

CENTISECOND 1/100 second
          Type:  Byte     (DEC)
          Range: 0 ... 99
          Dimension: 0.01s

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FEHLERNUMMER_LONG Internal error number
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: none

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

CATEGORY Type of error: bit3..0=category, bit4=reset; bit5=yesno
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0x3F
                     RESET_USERMSG_LEGACY  0x00   obsolete - formerly used to withdraw
                                                  status 5  - will be logged as [x]
                     WARNUNG               0x01   warning - logged only - not shown at TUI
                                                  resp FLC - will be logged as [w]
                     BEHEB_FEHLER          0x02   error - shown at TUI and ImgSys with a
                                                  message box + exclamation mark and
                                                  OK-Button  - will be logged as [r]
                     NICHT_BEHEB_FEHLER    0x03   non-recoverable error - shown at ImgSys
                                                  and TUI with a messagebox  + exclamation
                                                  mark and OK-Button - will be logged as [e]
                     FATALER_FEHLER        0x04   fatal error - shown at ImgSys and TUI with
                                                  a messagebox  + white x on red background
                                                  and OK-Button - will be treated in XCU as
                                                  if received an iFEStatus(13) - will be
                                                  logged as [f]
                     USERMESSAGE           0x05   info for user - shown at FLC and TUI with
                                                  a messagebox + blue i on white background
                                                  and OK-Button - not treated as an error,
                                                  less prior than errors in case of
                                                  concurrent errors - will be logged as [i]
                     BEDIENEVENT           0x06   action - not in use - would be logged as
                                                  [a]
                                                  temporarily used in iErrorLog2 to log
                                                  status line messages
                     TELEGRAM              0x07   info in status line - will be shown at FLC
                                                  and TUI in the status line w/o Button  -
                                                  will be logged as [t]
                     MSGBOX_NO_OK_NO_TUI   0x09   info for user - shown at FLC  with
                                                  messagebox but no OK-Button - not treated
                                                  as an error, less prior than errors -
                                                  shall be logged as [o]
                     ORTHOMESSAGE          0x0A   info for user - shown at ImgSys and TUI
                                                  with messagebox but no OK-Button - not
                                                  treated as an error, less prior than
                                                  errors  - will be logged as [o]
                     ACS_FLAG_RESET        0x10   not directly used - is defined as the
                                                  withdraw flag - Shall be used as
                                                  BIT-OR-combination with the other states
                                                  (e.g. ACS_ERR_RESET|WARNUNG is identical
                                                  to RESET_WARNING)
                     RESET_WARNING         0x11   withdraw status 1 - will be logged as [x]
                     RESET_ERROR           0x12   withdraw status 2 - will be logged as [x]
                     RESET_SEVERE          0x13   withdraw severe (non-recoverable) error
                                                  status - will be logged as [x]
                     RESET_FATAL           0x14   withdraw status 4 - will be logged as [x]
                     RESET_USERMESSAGE     0x15   withdraw status 5 - will be logged as [x]
                     RESET_TELEGRAM        0x17   withdraw status 7 - will be logged as [x]
                     RESET_MSGBOX          0x19   withdraw status 9 - will be logged as [x]
                     RESET_ORTHOMSG        0x1A   withdraw status A - will be logged as [x]
                     ACS_FLAG_YESNO        0x20   not directly used, is defined as the
                                                  YES-No flag and will output a message box
                                                  with YES / NO button. Shall be used as
                                                  BIT-OR-combination with the other states
          Dimension: none

FEHLERTEXT2 Error text to display error messages to the user (language specific in iFehlerAnz2) and in English for logging in iErrorLog2, max. 499 chars UNICODE (plus delimiter)
          Type:  String16 [ 500 ]     (ASCII)
          Range: 1000 ... 1000
          Dimension: unicode

ADDTEXT2 Used to log additional text, such as module name and line number, environment parameters etc.; 80chars UNICODE
          Type:  String16 [ 80 ]     (ASCII)
          Range: 160 ... 160
          Dimension: unicode

ERRCNT Cyclic Counter for synchronizing Errlog of XCU to Errorlog in REPORT ERROR DEVICE.
Must be set to NIL if being sent by other device than XCU.
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: none


IERRORLOGSYNC

Object: IERRORLOGSYNC ___ID: 0022

Description: On this telegram XCU will re-send all errors (via REP_SYS_MSG) starting from
              the newest error entry down to the number given in iErrorLogSync.ErrCnt +1
              The maximum amount of errors being re-sent is 50.
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ERRCNT Cyclic Counter for synchronizing Errlog of XCU to Errorlog in REPORT ERROR DEVICE.
Must be set to NIL if being sent by other device than XCU.
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IERWALLGANZ

Object: IERWALLGANZ ___ID: 00A0

Description: Display of extended generator data like emergency power or temperature switch
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS   XWP
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ATEMPSCH temperature switch of tube, some tubes (Opti 154) are equipped with a temp switch, that should replace a tube load calculator
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     KEIN_TEMPSCH   1
                     TEMPERATURSCH  2
          Dimension: none

SS safety relay, switch in generator to disable radiation for service purposes
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SCREENSAVER Screen saver, controlled by XCU or ImgSys
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     SCREENSAVER_AUS      0   screensaver off
                     SCREENSAVER_STUFE_1  1   screensaver level 1
                     SCREENSAVER_STUFE_2  2   screensaver level 2
          Dimension: none

NOTSTROMSTATUS Emergency power supply; Polydoros SX has an input for the switch indicating that emergency power is enabled. In this case, high power X-ray (as acquisition) should be disabled in order to not overload the emergency power supply.
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     NOTSTROM_AUS    0   normal operation
                     NOTSTROM_AKTIV  1   emergency power supply is active
                     NOTSTROM_USV    2
          Dimension: none

XRAY_DISABLE Release of X-ray disabled or enabled
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     XRAY_DISABLE_AUS    0
                     XRAY_DISABLE_AKTIV  1
          Dimension: none

POWERDOWN Powerdown progress, if imaging system has enforced a power down
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     POWERDOWN_AUS    0
                     POWERDOWN_AKTIV  1
          Dimension: none

UNDO_STEPS Amount of possible steps for the undo function on TUI.
          Type:  Byte     (DEC)
          Range: 0 ... 64
          Dimension: none

BATTERY_LEVEL percentage of remaining battery charge
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

XRAY_SWITCH_STATE state of the x-ray release switch
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     XRAY_SWITCH_FL  0x0001 fluoro switch pressed
                     XRAY_SWITCH_VK  0x0002 pre contact pressed
                     XRAY_SWITCH_HK  0x0004 main contact pressed
                     XRAY_SWITCH_HW  0x0008 any x-ray HW-switch pressed (not used)
          Dimension: none

ADRUCKSCH oil pressure switch of tube housing
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     KEIN_DRUCK  1
                     DRUCK       2
          Dimension: none

DEMO_MODE indicates if the system is in mode for demonstration (e.g. no xray etc.) or not
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

ATUERKON room door status
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     TUER_GESCHLOSSEN  1
                     TUER_OFFEN        2
          Dimension: none

SERVICE_MODE system is in service mode
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

PARKPOS stand is in park position
(currently used for mobile system only)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

MAINS_CONNECTED reports if mains is plugged in or not (used in mobile system)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

ANALOG_MODE system is in analog mode (used in mobile system only)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

LOCKED_STATE system is locked (used in mobile system only)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

SERV_RAD_SWITCH Service Radiation Enable Switch (R/F80 = S3; UGen=CalibSwitch)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_XRAY_BY_SW  1   x-ray release also by software possible
                     ACS_XRAY_BY_HW  2   x-ray release only by HW possible
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IERWKASSANZ

Object: IERWKASSANZ ___ID: 0083

Description: Display of selected cassette subdivision, sent from XCU to displays
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

TEILGQ Subdivision transversal
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

TEILGL Subdivision longitudinal
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

TEILGFOLGE Sort order for exposures
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IERWSESTATUS

Object: IERWSESTATUS ___ID: 02D4

Description: Generator sends state of its hardware like focus, temperature switch of tube
              and AEC chambers to XCU
Sender     :   GEN-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

TEMPSCH temperature switch of tube
this will create a warning, but will not block radiation (as in contrary the pressure switch would do)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

FOCUS_SM_TUBE_1 State of small focus of tube 1
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

FOCUS_LG_TUBE_1 State of large focus of tube 1
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

FOCUS_SM_TUBE_2 State of small focus of tube 2.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

FOCUS_LG_TUBE_2 State of large focus of tube 2.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

AEC_CHANNEL_1 State of AEC channel 1.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: none

AEC_CHANNEL_2 State of AEC channel 2.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: done

AEC_CHANNEL_3 State of AEC channel 3.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: none

AEC_CHANNEL_4 State of AEC channel 4.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: none

AEC_CHANNEL_5 State of AEC channel 5.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: none

AEC_CHANNEL_6 State of AEC channel 6.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: none

BATTERY_LEVEL percentage of remaining battery charge
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

BLOCKREASON reason for the generator to (temporarily) block (used in surgery)
          Type:  Set16     (HEX)
          Range: 0x0 ... 0x3
                     ACS_BLR_NONE                 0x0000
                     ACS_BLR_UDC_NOT_READY        0x0001 Waiting for intermediate circuit to
                                                         charge up
                     ACS_BLR_CASS_EXP_PAUSE_TIME  0x0002 pause time after cassette exposure
          Dimension: it's a set

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFEHLER

Object: IFEHLER ___ID: 0005

Description: error from a component sent to XCU in order to log and or display errors,
              warnings, information etc.
              Using the same telegram an error can be set and also reset by component. For
              usual an error - if displayed is confirmed by user and the reset by XCU
              sending sFAnzloeschen
Sender     :   CCU-IF   FLC   GEN-IF   PMS   RAD-STD   TUI-IF   XWP
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

FEHLERNUMMER number of error
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

CATEGORY Type of error: bit3..0=category, bit4=reset; bit5=yesno
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0x3F
                     RESET_USERMSG_LEGACY  0x00   obsolete - formerly used to withdraw
                                                  status 5  - will be logged as [x]
                     WARNUNG               0x01   warning - logged only - not shown at TUI
                                                  resp FLC - will be logged as [w]
                     BEHEB_FEHLER          0x02   error - shown at TUI and ImgSys with a
                                                  message box + exclamation mark and
                                                  OK-Button  - will be logged as [r]
                     NICHT_BEHEB_FEHLER    0x03   non-recoverable error - shown at ImgSys
                                                  and TUI with a messagebox  + exclamation
                                                  mark and OK-Button - will be logged as [e]
                     FATALER_FEHLER        0x04   fatal error - shown at ImgSys and TUI with
                                                  a messagebox  + white x on red background
                                                  and OK-Button - will be treated in XCU as
                                                  if received an iFEStatus(13) - will be
                                                  logged as [f]
                     USERMESSAGE           0x05   info for user - shown at FLC and TUI with
                                                  a messagebox + blue i on white background
                                                  and OK-Button - not treated as an error,
                                                  less prior than errors in case of
                                                  concurrent errors - will be logged as [i]
                     BEDIENEVENT           0x06   action - not in use - would be logged as
                                                  [a]
                                                  temporarily used in iErrorLog2 to log
                                                  status line messages
                     TELEGRAM              0x07   info in status line - will be shown at FLC
                                                  and TUI in the status line w/o Button  -
                                                  will be logged as [t]
                     MSGBOX_NO_OK_NO_TUI   0x09   info for user - shown at FLC  with
                                                  messagebox but no OK-Button - not treated
                                                  as an error, less prior than errors -
                                                  shall be logged as [o]
                     ORTHOMESSAGE          0x0A   info for user - shown at ImgSys and TUI
                                                  with messagebox but no OK-Button - not
                                                  treated as an error, less prior than
                                                  errors  - will be logged as [o]
                     ACS_FLAG_RESET        0x10   not directly used - is defined as the
                                                  withdraw flag - Shall be used as
                                                  BIT-OR-combination with the other states
                                                  (e.g. ACS_ERR_RESET|WARNUNG is identical
                                                  to RESET_WARNING)
                     RESET_WARNING         0x11   withdraw status 1 - will be logged as [x]
                     RESET_ERROR           0x12   withdraw status 2 - will be logged as [x]
                     RESET_SEVERE          0x13   withdraw severe (non-recoverable) error
                                                  status - will be logged as [x]
                     RESET_FATAL           0x14   withdraw status 4 - will be logged as [x]
                     RESET_USERMESSAGE     0x15   withdraw status 5 - will be logged as [x]
                     RESET_TELEGRAM        0x17   withdraw status 7 - will be logged as [x]
                     RESET_MSGBOX          0x19   withdraw status 9 - will be logged as [x]
                     RESET_ORTHOMSG        0x1A   withdraw status A - will be logged as [x]
                     ACS_FLAG_YESNO        0x20   not directly used, is defined as the
                                                  YES-No flag and will output a message box
                                                  with YES / NO button. Shall be used as
                                                  BIT-OR-combination with the other states
          Dimension: none

UMGEBUNG1 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG2 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG3 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG4 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG5 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG6 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG7 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG8 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG9 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UMGEBUNG10 additional parameter, e.g. code module and line number
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFEHLER2

Object: IFEHLER2 ___ID: 0006

Description: error from a component sent to XCU in order to log and or display errors,
              warnings, information etc.
              (note: parameter DO_NOT_BEEP is used only in XCU internally)
Sender     :
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

FEHLERNUMMER number of error
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

CATEGORY Type of error: bit3..0=category, bit4=reset; bit5=yesno
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0x3F
                     RESET_USERMSG_LEGACY  0x00   obsolete - formerly used to withdraw
                                                  status 5  - will be logged as [x]
                     WARNUNG               0x01   warning - logged only - not shown at TUI
                                                  resp FLC - will be logged as [w]
                     BEHEB_FEHLER          0x02   error - shown at TUI and ImgSys with a
                                                  message box + exclamation mark and
                                                  OK-Button  - will be logged as [r]
                     NICHT_BEHEB_FEHLER    0x03   non-recoverable error - shown at ImgSys
                                                  and TUI with a messagebox  + exclamation
                                                  mark and OK-Button - will be logged as [e]
                     FATALER_FEHLER        0x04   fatal error - shown at ImgSys and TUI with
                                                  a messagebox  + white x on red background
                                                  and OK-Button - will be treated in XCU as
                                                  if received an iFEStatus(13) - will be
                                                  logged as [f]
                     USERMESSAGE           0x05   info for user - shown at FLC and TUI with
                                                  a messagebox + blue i on white background
                                                  and OK-Button - not treated as an error,
                                                  less prior than errors in case of
                                                  concurrent errors - will be logged as [i]
                     BEDIENEVENT           0x06   action - not in use - would be logged as
                                                  [a]
                                                  temporarily used in iErrorLog2 to log
                                                  status line messages
                     TELEGRAM              0x07   info in status line - will be shown at FLC
                                                  and TUI in the status line w/o Button  -
                                                  will be logged as [t]
                     MSGBOX_NO_OK_NO_TUI   0x09   info for user - shown at FLC  with
                                                  messagebox but no OK-Button - not treated
                                                  as an error, less prior than errors -
                                                  shall be logged as [o]
                     ORTHOMESSAGE          0x0A   info for user - shown at ImgSys and TUI
                                                  with messagebox but no OK-Button - not
                                                  treated as an error, less prior than
                                                  errors  - will be logged as [o]
                     ACS_FLAG_RESET        0x10   not directly used - is defined as the
                                                  withdraw flag - Shall be used as
                                                  BIT-OR-combination with the other states
                                                  (e.g. ACS_ERR_RESET|WARNUNG is identical
                                                  to RESET_WARNING)
                     RESET_WARNING         0x11   withdraw status 1 - will be logged as [x]
                     RESET_ERROR           0x12   withdraw status 2 - will be logged as [x]
                     RESET_SEVERE          0x13   withdraw severe (non-recoverable) error
                                                  status - will be logged as [x]
                     RESET_FATAL           0x14   withdraw status 4 - will be logged as [x]
                     RESET_USERMESSAGE     0x15   withdraw status 5 - will be logged as [x]
                     RESET_TELEGRAM        0x17   withdraw status 7 - will be logged as [x]
                     RESET_MSGBOX          0x19   withdraw status 9 - will be logged as [x]
                     RESET_ORTHOMSG        0x1A   withdraw status A - will be logged as [x]
                     ACS_FLAG_YESNO        0x20   not directly used, is defined as the
                                                  YES-No flag and will output a message box
                                                  with YES / NO button. Shall be used as
                                                  BIT-OR-combination with the other states
          Dimension: none

DO_NOT_BEEP used to suppress sound
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     NO                 0
                     ACS_SUPPRESS_BEEP  1   TUI shall suppress sound on message display
          Dimension: none

STRARG string argument to be inserted into the language dependent error message (if this contains a %s format identifier)
          Type:  String16 [ 26 ]     (ASCII)
          Range: 52 ... 52
          Dimension: unicode

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_ARGS number of arguments in the following array
          Type:  Dcount     (CNT)
          Range: 0 ... 10
          Dimension: count of arguments

{ARGUMENT parameter for additional info (e.g. arguments for error string)
The meaning depends on the error (FEHLERNUMMER).
{          Type:  Dword     (HEX)
{          Range: 0x0 ... 0xFFFFFFFF
{          Dimension: none

LOSTR_ET length of string of ETXT
          Type:  Dcount     (CNT)
          Range: 0 ... 570
          Dimension: count of elements

{ETXT internal error text, variable length, 1 char UNICODE
{          Type:  String16 [ 1 ]     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


IFEHLERANZ2

Object: IFEHLERANZ2 ___ID: 0023

Description: Control of the display of errormessages. New: unicode messages and new error
              numbers are supported. To inform user with infos and error messages. Displayed
              on TUI. The display on FLC is done via iDFRAllgAnz_2
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

FEHLERNUMMER_LONG Internal error number
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: none

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

CATEGORY Type of error: bit3..0=category, bit4=reset; bit5=yesno
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0x3F
                     RESET_USERMSG_LEGACY  0x00   obsolete - formerly used to withdraw
                                                  status 5  - will be logged as [x]
                     WARNUNG               0x01   warning - logged only - not shown at TUI
                                                  resp FLC - will be logged as [w]
                     BEHEB_FEHLER          0x02   error - shown at TUI and ImgSys with a
                                                  message box + exclamation mark and
                                                  OK-Button  - will be logged as [r]
                     NICHT_BEHEB_FEHLER    0x03   non-recoverable error - shown at ImgSys
                                                  and TUI with a messagebox  + exclamation
                                                  mark and OK-Button - will be logged as [e]
                     FATALER_FEHLER        0x04   fatal error - shown at ImgSys and TUI with
                                                  a messagebox  + white x on red background
                                                  and OK-Button - will be treated in XCU as
                                                  if received an iFEStatus(13) - will be
                                                  logged as [f]
                     USERMESSAGE           0x05   info for user - shown at FLC and TUI with
                                                  a messagebox + blue i on white background
                                                  and OK-Button - not treated as an error,
                                                  less prior than errors in case of
                                                  concurrent errors - will be logged as [i]
                     BEDIENEVENT           0x06   action - not in use - would be logged as
                                                  [a]
                                                  temporarily used in iErrorLog2 to log
                                                  status line messages
                     TELEGRAM              0x07   info in status line - will be shown at FLC
                                                  and TUI in the status line w/o Button  -
                                                  will be logged as [t]
                     MSGBOX_NO_OK_NO_TUI   0x09   info for user - shown at FLC  with
                                                  messagebox but no OK-Button - not treated
                                                  as an error, less prior than errors -
                                                  shall be logged as [o]
                     ORTHOMESSAGE          0x0A   info for user - shown at ImgSys and TUI
                                                  with messagebox but no OK-Button - not
                                                  treated as an error, less prior than
                                                  errors  - will be logged as [o]
                     ACS_FLAG_RESET        0x10   not directly used - is defined as the
                                                  withdraw flag - Shall be used as
                                                  BIT-OR-combination with the other states
                                                  (e.g. ACS_ERR_RESET|WARNUNG is identical
                                                  to RESET_WARNING)
                     RESET_WARNING         0x11   withdraw status 1 - will be logged as [x]
                     RESET_ERROR           0x12   withdraw status 2 - will be logged as [x]
                     RESET_SEVERE          0x13   withdraw severe (non-recoverable) error
                                                  status - will be logged as [x]
                     RESET_FATAL           0x14   withdraw status 4 - will be logged as [x]
                     RESET_USERMESSAGE     0x15   withdraw status 5 - will be logged as [x]
                     RESET_TELEGRAM        0x17   withdraw status 7 - will be logged as [x]
                     RESET_MSGBOX          0x19   withdraw status 9 - will be logged as [x]
                     RESET_ORTHOMSG        0x1A   withdraw status A - will be logged as [x]
                     ACS_FLAG_YESNO        0x20   not directly used, is defined as the
                                                  YES-No flag and will output a message box
                                                  with YES / NO button. Shall be used as
                                                  BIT-OR-combination with the other states
          Dimension: none

FEHLERTEXT2 Error text to display error messages to the user (language specific in iFehlerAnz2) and in English for logging in iErrorLog2, max. 499 chars UNICODE (plus delimiter)
          Type:  String16 [ 500 ]     (ASCII)
          Range: 1000 ... 1000
          Dimension: unicode

DO_NOT_BEEP used to suppress sound
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     NO                 0
                     ACS_SUPPRESS_BEEP  1   TUI shall suppress sound on message display
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFEHLERQUIT

Object: IFEHLERQUIT ___ID: 0015

Description: when the user confirms an error and the XCU has sent sResetFehler to the
              component, the component will sent this telegram to acknowledge that the error
              has been reset
Sender     :   CCU-IF   FLC   GEN-IF   PMS   RAD-STD   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs
This object has no parameters


IFESTATUS

Object: IFESTATUS ___ID: 0011

Description: boot status of a component. If 10 is sent, XCU send init blocks, 12 is ready,
              13 is dead (007 error), 11 is service mode
Sender     :   CCU-IF   DCU   FLC   GEN-IF   RAD-STD   SCU-IF   TUI-IF   UGEN   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FESTATUS boot status of a component
          Type:  Byte     (DEC)
          Range: 1 ... 13
                     APPLIKATIONSVORBEREITUNG  10   application ready to run, XCU will now
                                                    send init data to the component
                     SERVICEMODE               11   component in service mode
                     BETRIEBSBEREIT            12   ready for normal operation
                     NICHT_FUNKTIONSFAEHIG     13   component is defective
                                                    (in order to recover component needs to
                                                    send a TURN_ON plus a iFEStatus 12 to
                                                    get back)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFFA

Object: IFFA ___ID: 0324

Description: current SID (source (tube) to image (cassette, FD or image intensifier)
              distance, send from XCU to any component
Sender     :   XCU
Receiver   :   CCU-IF   FLC   RAD-STD   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FFA current SID
          Type:  Integer16     (DEC)
          Range: 1 ... 32767
          Dimension: mm

SID_VALID determination of SID
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_MANUAL_DET  0   user/manual determined
                     ACS_SID_SYSTEM_DET  1   determined by the system
                     ACS_SID_NOT_DEF     2   the system can not define the SID
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFILTER

Object: IFILTER ___ID: 0329

Description: status of CU-Filter (sent from component to XCU). If a filter is moving,
              exposures are blocked.
Sender     :   CCU-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FILTER CU filter number, the Filter number is in most cases identical with the filter thickness in 0.1 mm, so 1 means 0.1 mm
          Type:  Byte     (DEC)
          Range: 0 ... 10
          Dimension: none

FILTERSTATUS filter status
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     FILTER_AKTIV         1   filter is moving
                     FILTER_POSITIONIERT  2   filter has reached its final position
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFILTERANZ

Object: IFILTERANZ ___ID: 02B5

Description: To display CU filter status for acq and fluoro
Sender     :   XCU
Receiver   :   CCU-IF   FLC   RAD-STD   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FILTER_FLUORO number of fluoro filter; 0: no filter
          Type:  Byte     (DEC)
          Range: 0 ... 10
                     NO_FILTER  0
                     FILTER_1   1
                     FILTER_2   2
                     FILTER_3   3
                     FILTER_4   4
                     FILTER_5   5
                     FILTER_6   6
                     FILTER_7   7
                     FILTER_8   8
                     FILTER_9   9
                     FILTER_10  10
          Dimension: none

FILTER_ACQ number of acquisition filter; 0: no filter
          Type:  Byte     (DEC)
          Range: 0 ... 10
                     NO_FILTER  0
                     FILTER_1   1
                     FILTER_2   2
                     FILTER_3   3
                     FILTER_4   4
                     FILTER_5   5
                     FILTER_6   6
                     FILTER_7   7
                     FILTER_8   8
                     FILTER_9   9
                     FILTER_10  10
          Dimension: none

FILTERSTATUS filter status
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     FILTER_AKTIV         1   filter is moving
                     FILTER_POSITIONIERT  2   filter has reached its final position
          Dimension: none

FILTER_ACT Actually used filtermode: 1: fluoro; 2: acquisition
          Type:  Enum8     (DEC)
          Range: 0 ... 2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFLUOROACTANZ

Object: IFLUOROACTANZ ___ID: 03A3

Description: display of the current fluoro parameters
Sender     :   XCU
Receiver   :   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

KVDL Fluoro voltage; during fluoro this is the actual voltage, in fluoro breaks the mean value since last fluoro time reset will be shown
          Type:  Integer16     (DEC)
          Range: 0 ... 1500
          Dimension: 0.1 kV

MAIST_H current of actual pulse (or of continuous fluoro)
(like MAIST in higher resolution (dimension is 0.01mA))
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: 0.01 mA

PULSETIME pulse width
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

REGZUS State of the regulation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     OBERER_ANSCHLAG     1   at upper limit
                     UNTERER_ANSCHLAG    2   at lower limit
          Dimension: none

SYSTEM_LOAD The system load depicts, where the current status is concerning the regulation range (with regards to the given curve and the given dose)
note: shall be deduced from EP_SUM_ACT
          Type:  Byte     (DEC)
          Range: 0 ... 250
          Dimension: EP

MIN fluoro time since last reset (e.g. a change of patient)
(Min derives from minute, although value is given in seconds)
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: sek

DFP dose area product of actual acquisition / acq series / fluoro event
(fnote: formerly the dimension was defined by the parameter DFPNACHKOMMA)
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IFLUORODATA

Object: IFLUORODATA ___ID: 02DC

Description: current fluoro X-ray parameter of fluoro sent from generator to XCU. Is used
              to feed the tube load calculator, the display of the fluoro (iFluoroActDis)
              and to calculate the forecast for exposures in case of 0-pnt tech.
Sender     :   UGEN
Receiver   :   XCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  RadFluoro and show

List of Parameters:

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAIST_H current of actual pulse (or of continuous fluoro)
(like MAIST in higher resolution (dimension is 0.01mA))
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: 0.01 mA

PULSETIME pulse width
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

DLABW difference of the current X-ray data to the desired dose
          Type:  Integer16     (DEC)
          Range: -40 ... 40
          Dimension: 0.25 BP

REGZUS State of the regulation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     OBERER_ANSCHLAG     1   at upper limit
                     UNTERER_ANSCHLAG    2   at lower limit
          Dimension: none

PULSE amount of pulses combined in this telegram (this is used if frame rate is too high to send a separate telegram for each pulse)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

EP_SUM_ACT current operation point of dose regulation (water value in EP)
          Type:  Integer16     (DEC)
          Range: 0 ... 4000
          Dimension: 1/16 EP

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IGENANZ

Object: IGENANZ ___ID: 008E

Description: generator data display, sent from XCU to displays
Sender     :   GEN-IF   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

KENNL Number of the exposure curve that determines the kV from the thickness of the object to be X-rayed
In sOrgDaten this parameter will be used if parameter KV is set to 0
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: Nr

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

PROZ The parameter will reduce the max electrical power (which is given by max power value for the selected focus) to the given percentage in order to enlarge the lifespan of the tube.
Thus for a given kV it allows to reduce the current in order to artificially prolong the pulse time (which replaces the former "reduced current" techniques 8 and 20)
          Type:  Byte     (DEC)
          Range: 10 ... 100
          Dimension: %

KVAUTO automatic calculation of kV, only for techniques 0, 10, 12 - 19, this parameter should dis res. enable control elements, that are only attachable on 0-pnt techniques
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

STATUSIGENANZ This Parameter is no longer used.
          Type:  Byte     (DEC)
          Range: 0 ... 16
                     NO_QUITTUNG     0
                     KV_QUITTUNG     1
                     MAS_QUITTUNG    2
                     MS_QUITTUNG     4
                     FOKUS_QUITTUNG  8
                     LIMIT_QUITTUNG  16
          Dimension: none


IGENREADY

Object: IGENREADY ___ID: 03C9

Description: generator reports its ready state
Sender     :   UGEN
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro and show

List of Parameters:

GEN_READY generator reports that:
- filament has reached final temperature
- anode has reached the rotation speed
- generator is overall ready to release exposure
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_GEN_NOT_READY  0   generator is not ready
                     ACS_GEN_READY      1   generator is ready
          Dimension: n.a.

SAFETY_CIRCUIT_CLOSED shows if the safety circuit is closed
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IGENSTATUS2

Object: IGENSTATUS2 ___ID: 02C5

Description: shows the current state of the generator (combines the parameters from
              iDLStatus, iAufnStatus, iSEStatus and iErwSEStatus)
Sender     :   UGEN
Receiver   :   XCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  RadFluoro and show

List of Parameters:

AUFNBEREIT ready for exposure
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DLBEREIT Ready for fluoro
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

HW_SWITCH actual state of HW-switch of safety contactor (Sicherheitsschuetz) - same as SS in iSEStatus; ACS_ON = x-ray possible
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

SW_SWITCH SW control of safety contactor: ACS_ON = x-ray possible
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

SERV_RAD_SWITCH Service Radiation Enable Switch (R/F80 = S3; UGen=CalibSwitch)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_XRAY_BY_SW  1   x-ray release also by software possible
                     ACS_XRAY_BY_HW  2   x-ray release only by HW possible
          Dimension: none

XRAY_MAN_ENABLE xray manually enabled/disabled by user operation (HW input to generator)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ENABLE_XRAY   1   enable x-ray
                     ACS_DISABLE_XRAY  2   disable x-ray
          Dimension: none

MA_MEAS mA measurement
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

INTERMEDIATE_CIRCUIT Information about state of intermediate circuit in Gen F80.
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

TUERKON Room door status
Normal position is EIN (=ON). If AUS(=OFF) any X-ray will be blocked.
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DRUCKSCH Pressure switch of tube housing
Normal position is EIN (=ON). If AUS(=OFF) any X-ray will be blocked.
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

TEMPSCH temperature switch of tube
this will create a warning, but will not block radiation (as in contrary the pressure switch would do)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

CALIB_SWITCH actual state of the switch for calibration
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
          Dimension: none

FOCUS_SM_TUBE_1 State of small focus of tube 1
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

FOCUS_LG_TUBE_1 State of large focus of tube 1
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

FOCUS_SM_TUBE_2 State of small focus of tube 2.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

FOCUS_LG_TUBE_2 State of large focus of tube 2.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_READY           1   ready
                     ACS_NOT_READY       2   not ready
          Dimension: none

AEC_CHANNEL_1 State of AEC channel 1.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: none

AEC_CHANNEL_2 State of AEC channel 2.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: done

AEC_CHANNEL_3 State of AEC channel 3.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     NO_CHANGE  0   No change to the status
                     ACS_OK     1   the state is okay or accepted
                     ACS_NOK    2   the state is not okay or not accepted
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IGGAKTPOS2

Object: IGGAKTPOS2 ___ID: 0429

Description: current position of the stand/gantry, sent from component to XCU. Although
              iGGAktPos2 is using same parameters as iBewegung2, it is used for codes 90,
              91, 92. Has been made to not send data to devices that do not need them.
              (iGGAktPos2 is an enhanced iGGAktPos in order to transfer several axes at a
              time, and thus to reduce AXCS traffic)
Sender     :   SCU-IF
Receiver   :   XCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTANZAHL amount of actions
          Type:  Count     (CNT)
          Range: 1 ... 20
          Dimension: number of data blocks

{ANZCODE code of the parameter being transferred in PARAM
{          Type:  Enum16     (DEC)
{          Range: 0 ... 131
{                       A_FFA_STRAHLER                  0     SID tube
{                       A_ISOCENTER_HOEHE               1     isocenter height
{                       A_TARGET_LAENGS                 2     target longitudinal
{                       A_TARGET_QUER                   3     target transversal
{                       A_TARGET_HEBEN_SENKEN           4     target lift
{                       A_TARGET_DREHEN                 5     rotate target
{                       A_SCHWENKWINKEL_SAEULE          6     angle of column
{                       A_TUBUSKRAFT                    7     force of tubus
{                       A_TISCHPLATTENDREHUNG           8     rotate table
{                       A_FFA_TARGET                    9     SID target (SID forecast)
{                       A_TISCH_HOEHE                   10    table height
{                       A_TISCH_GERAET_KIPPEN           11    table tilt
{                       A_TISCH_LAENGS                  12    table longitudinal
{                       A_TISCH_QUER                    13    table transversal
{                       A_KIPPMULDE                     14    baby cradle
{                       A_SCHICHTHOEHE                  15    tomo height
{                       A_GERAET_HEBEN_SENKEN           16    lift gantry
{                       A_TUBE_ROT_HOR                  17    horizontal rotation of tube of
{                                                             Rad system
{                       A_STRAHLER_LAENGS               18    tube longitudinal
{                       A_STRAHLER_QUER                 19    tube transversal
{                       A_SHOCKHEAD_POSITION            20
{                       A_TUBUS_IM_STRAHLENGANG         21    tubus (compression unit)
{                       A_C_BOGEN_ORBITAL               22    position in 0.1 degree (signed
{                                                             word)
{                       A_C_BOGEN_ANGULAR               23    position in 0.1 degree (signed
{                                                             word)
{                       A_ISOCENTER_LAENGS              24    longitudinal position related
{                                                             to patient
{                                                             used by image system for care
{                                                             graphics
{                       A_FFA_BEWEGUNG                  25    SID Movement
{                       A_SID_VALID_INVALID             26    SID valid or invalid (in low
{                                                             cost systems there is no
{                                                             potentiometer to acquire the
{                                                             SID continuously, there are
{                                                             only two switches for upper
{                                                             and lower SID. If the tube is
{                                                             in between both positions, the
{                                                             collimators cannot be
{                                                             calculated because they
{                                                             require the exact position. In
{                                                             order not to expose more space
{                                                             than necessary, X-ray is
{                                                             blocked if SID is invalid.
{                                                             PARAM: 0=manual determined,
{                                                             1=SID valid, 2=SID invalid
{                       A_CALIB_SWITCH                  27    Calibration switch in Ysio
{                                                             stand.
{                                                             PARAM: 0=No Information, 1=on,
{                                                             2=off
{                       A_SID_OR_SOD                    28    ==== in sBedGG: ====
{                                                             Information whether SID or SOD
{                                                             Button is pressed to determine
{                                                             which one is measured manually
{                                                             by using the tape of the
{                                                             collimator. Sent from TUI If
{                                                             to XCU.
{                                                             Param: 0 = no information; 1 =
{                                                             SID; 2 = SOD
{                                                             ==== in iGGAnz: ====
{                                                             XCU tells TUI (via TUI
{                                                             Interface) whether manual SID
{                                                             or SOD measurement is
{                                                             possible. Also used to
{                                                             acknowledge the TUI
{                                                             operation.
{                                                             PARAM: bit-coded, transferred
{                                                             into dec:
{                                                             0 = nothing possible, nothing
{                                                             selected
{                                                             1 = SID possible, nothing
{                                                             selected
{                                                             3 = SID possible, SID
{                                                             selected
{                                                             16 = SOD possible, nothing
{                                                             selected
{                                                             48 = SOD possible, SOD
{                                                             selected
{                                                             17 = SID and SOD possible,
{                                                             nothing selected
{                                                             19 = SID and SOD possible, SID
{                                                             selected
{                                                             49 = SID and SOD possible, SOD
{                                                             selected
{                       A_ACSS_POSSIBLE_                29    For Ysio:
{                                                             XCU determines, if ACSS is
{                                                             active or not and sends
{                                                             information via SCU Interface
{                                                             to Stand
{                                                             PARAM: 0 = No Information; 1 =
{                                                             ACSS not possible; 2 = ACSS
{                                                             active
{                       A_FFA_STRAHLER_0P               30
{                       A_ISOCENTER_HOEHE_0P            31
{                       A_TARGET_LAENGS_0P              32
{                       A_TARGET_QUER_0P                33
{                       A_TARGET_HEBEN_SENKEN_0P        34
{                       A_TARGET_DREHEN_0P              35
{                       A_SCHWENKWINKEL_SAEULE_0P       36
{                       A_KOMPRESSION_0P                37
{                       A_TISCHPLATTENDREHUNG_0P        38
{                       A_FFA_TARGET_0P                 39
{                       A_TISCH_HOEHE_0P                40
{                       A_TISCH_GERAET_KIPPEN_0P        41
{                       A_TISCH_LAENGS_0P               42
{                       A_TISCH_QUER_0P                 43
{                       A_KIPPMULDE_0P                  44
{                       A_SCHICHTHOEHE_0P               45
{                       A_GERAET_HEBEN_SENKEN_0P        46
{                       A_STRAHLERDREHUNG_0P            47
{                       A_STRAHLER_LAENGS_0P            48
{                       A_STRAHLER_QUER_0P              49
{                       A_SOD_H                         50    SOD value (in 0.1 mm)
{                       A_C_BOGEN_ORBITAL_0P            52
{                       A_C_BOGEN_ANGULAR_0P            53
{                       A_ZIELGERAET_0P                 54
{                       A_AEC_CENTER_Y                  56    offset between detector center
{                                                             and center of AEC chamber
{                       A_STAND_SPEED                   57    speed class for stand
{                                                             movement:
{                                                             1=ACS_SSPEED_SLOW
{                                                             2=ACS_SSPEED_MEDIUM
{                                                             3=ACS_SSPEED_FAST
{                       A_CAREGRAPH_VALID               58    defines if the values for
{                                                             careposition/profile
{                                                             (ISOCENTER_QUER/_LAENGS) make
{                                                             sense
{                                                             1=caregraph may be shown
{                                                             0=caregraph should not be
{                                                             shown
{                       A_ISOCENTER_QUER                59    transversal position related
{                                                             to patient
{                                                             used by image system for care
{                                                             graphics
{                       A_UMBAU_1                       60
{                       A_UMBAU_2                       61
{                       A_UMBAU_3                       62
{                       A_UMBAU_4                       63
{                       A_UMBAU_5                       64
{                       A_MYELOGRAPHIE                  65
{                       A_PERI_PROGFAHRT                66
{                       A_SCHRITTVERSCHIEBUNG           67
{                       A_DET_TABLE_OUT                 68    Detector in table is pulled
{                                                             out.
{                                                             0 == detector is in tray
{                                                             1 == detector is pulled out
{                                                             555 == detector is completely
{                                                             pulled out
{                       A_DET_WALL_OUT                  69    Detector in wall stand is
{                                                             pulled out.
{                                                             0 == detector is in tray
{                                                             1 == detector is pulled out
{                                                             555 == detector is completely
{                                                             pulled out
{                       A_FESTPOSITION_1                70    peri pos 1
{                       A_FESTPOSITION_2                71    peri pos 2
{                       A_FESTPOSITION_3                72
{                       A_FESTPOSITION_4                73
{                       A_FESTPOSITION_5                74
{                       A_FESTPOSITION_6                75
{                       A_FESTPOSITION_7                76
{                       A_FESTPOSITION_8                77
{                       A_CENTRAL_BEAM_HITS             78    the x-ray beam does not or
{                                                             does only partially hit the
{                                                             detector, such that fluoro
{                                                             must be blocked
{                       A_FESTPOSITION_10               79    peri pos 10
{                       A_ZIELGERAET_BR                 80    brakes of SFD
{                       A_KOMPRESSION_BR                81    brakes of compression
{                       A_ZG_TISCHMITTE_BR              82    spotfilm device brake
{                       A_ZG_PARKPOSITION_BR            83    park pos brake
{                       A_BREMSE_5_BR                   84
{                       A_BREMSE_6_BR                   85
{                       A_BREMSE_7_BR                   86
{                       A_BREMSE_8_BR                   87
{                       A_BREMSE_9_BR                   88
{                       A_PERISCAN                      89
{                       A_POSSYS                        90    positioning detector to tube
{                                                             (alignment),
{                                                             Meaning of PARAM:
{                                                             0=ACS_NO_INFORMATION
{                                                             1=MITTIG_ZENTRIERT (aligned to
{                                                             center)
{                                                             2=OBEN_ZENTRIERT (aligned to
{                                                             upper border)
{                                                             3=MITTIG_ZENTRIERT_NICHT_ERR
{                                                             (center not reached)
{                                                             4=OBEN_ZENTRIERT_NICHT_ERR
{                                                             (top not reached)
{                       A_NACHLAUF                      91    tracking mode
{                                                             Meaning of Param in sBedGG:
{                                                             0=both tracking functions off
{                                                             2=SID tracking off / XY
{                                                             tracking on
{                                                             8=SID tracking on / XY
{                                                             tracking off
{                                                             10=both tracking functions on
{                                                             Meaning of Param in other
{                                                             telegrams:
{                                                             ( _T_ means _TRACKING_)
{                                                             0=ACS_NO_INFORMATION
{                                                             1=ACS_T_X_Y_OFF
{                                                             2=ACS_T_X_Y_ON
{                                                             3=ACS_T_X_Y_LOST
{                                                             4=ACS_T_SID_OFF
{                                                             5=ACS_T_BOTH_OFF
{                                                             6=ACS_T_X_Y_ON_SID_OFF
{                                                             7=ACS_T_X_Y_LOST_SID_OFF
{                                                             8=ACS_T_SID_ON
{                                                             9=ACS_T_X_Y_OFF_SID_ON
{                                                             10=ACS_T_BOTH_ON
{                                                             11=ACS_T_X_Y_LOST_SID_ON
{                                                             12=ACS_T_SID_LOST
{                                                             13=ACS_T_X_Y_OFF_SID_LOST
{                                                             14=ACS_T_X_Y_ON_SID_LOST
{                                                             15=ACS_T_BOTH_LOST
{                       A_TIEFENBLENDE_GEDREHT          92    collimator rotated
{                       A_SPINE_CONSTRUCTION            93
{                       A_CARE_POSITION                 94    enable/disable care position,
{                                                             virtual table movement in Last
{                                                             image hold
{                       A_TIEFENBLENDE_HOR_DEZENTRIERT  95    collimator horizontal not
{                                                             centered
{                                                             PARAM: 1=yes; 0=no
{                       A_CHANGE_ORIENTATION            96    PARAM: Bit1: horizontal
{                                                             (transversal) 0=off, 1=on
{                                                                            Bit2: vertical
{                                                             (longitudinal) 0=off, 1=on
{                                                                            Bit3:
{                                                             orientation: 0=stand,
{                                                             1=monitor
{                       A_WIGGLE_FUNCTION               97    PARAM: 1=on; 0=off
{                       A_DETECTOR_ORIENTATION          98    For Ysio: Orientation of
{                                                             detector relative to normal
{                                                             patient position.
{                                                             Param:
{                                                             1= Position 1, Pixel (0,0) in
{                                                             upper left corner (0°)
{                                                             2= Position 2, Pixel (0,0) in
{                                                             upper right corner (90°
{                                                             clockwise)
{                                                             3= Position 3, Pixel (0,0) in
{                                                             lower right corner (180°
{                                                             clockwise)
{                                                             4= Position 4, Pixel (0,0) in
{                                                             lower left corner (270°
{                                                             clockwise)
{                       A_MAGNIFICATION                 99    Factor of magnification of
{                                                             objects, i.e. relation between
{                                                             SID and SOD (in %)
{                       A_TOP_ALIGN_POSSIBLE            100   SCU reports if top alignment
{                                                             is possible (i.e. if tilt
{                                                             angle <20°)
{                                                             PARAM: 0=no; 1=yes
{                       A_BEAM_ANGLE_ALPHA              101
{                       A_TUBE_ROT_VERTICAL             102
{                       A_BEAM_POS_X                    103   Offset of the central beam
{                                                             relating to the center of the
{                                                             FD in 0.1mm
{                       A_BEAM_POS_Y                    104   Offset of the central beam
{                                                             relating to the center of the
{                                                             FD in 0.1mm
{                       A_DET_WALL_TILT                 105   Tilting angle of detector in
{                                                             wall stand.
{                                                             Value in param in 0.1°
{                       A_POSITION_VALID_FOR_STORAGE    106   Information whether a stand
{                                                             position is valid to be stored
{                                                             in an organ program.
{                                                             Param: 0: no information, 1:
{                                                             position is valid, 2: position
{                                                             is not valid
{                       A_MOVING_BEAM                   107   Limits for decentered ACSS
{                                                             shall only be updated when
{                                                             stand is not in motion
{                                                             Param: 0: Beam is stopped, 1:
{                                                             Beam is moving
{                       A_MOVING_DETECTOR               108   Limits for decentered ACSS
{                                                             shall only be updated when
{                                                             stand is not in motion
{                                                             Param: 0: Detector is stopped,
{                                                             1: Detector is moving
{                       A_MOVING_TABLE                  109   Limits for decentered ACSS
{                                                             shall only be updated when
{                                                             stand is not in motion
{                                                             Param: 0: Table is stopped, 1:
{                                                             Table is moving
{                       A_AUTO_MOVEMENT                 110   stand performs automatic
{                                                             movement:
{                                                             0 =
{                                                             ACS_AUTO_MOVEMENT_INACTIVE
{                                                             1 = ACS_AUTO_MOVEMENT_ACTIVE
{                                                             2 = ACS_AUTO_MOVEMENT_PENDING
{                       A_ORTHO_POS1                    111   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       A_ORTHO_POS2                    112   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       A_TDD                           113   table detector distance in
{                                                             0.1mm
{                       A_ORTHO_STEP                    114   current step (or state) in the
{                                                             ortho flow:
{                                                             1 not in Ortho position (Move
{                                                             button has to be pressed)
{                                                             2 mark first ortho pos
{                                                             3 mark second ortho pos
{                                                             4 ready to move to first Image
{                                                             pos
{                                                             5 ready for apply X-ray
{                                                             6 X-ray is running
{                                                             7 X-ray is over and stand is
{                                                             moving to ortho start pos
{                                                             8 ortho is completed
{                                                             9 ortho is finished
{                                                             10 ortho is aborted
{                                                             11 ortho cannot be started
{                       A_SOFTSTOP                      115   activates or deactivates the
{                                                             SoftStop function
{                       A_PATIENT_TRANSFER              116   param: 1=on, 0=off
{                       A_TOMOADJUST                    117   system shall move to a
{                                                             position in which the tomo
{                                                             fulcrum height (Schichthöhe)
{                                                             can be adjusted using the
{                                                             laser line of the collimator
{                       A_MOVE_DISABLE                  118   any movement blocked on users
{                                                             request
{                       A_BEAM_ANGLE_BETA               119
{                       A_FINAL_POSITION_REACHED        120   The OGP position is reached.
{                                                             This value is taken as a
{                                                             trigger to (re)send the OGP
{                                                             collimation values to the
{                                                             collimator
{                       A_STORE_POS                     121   store the current stand
{                                                             position (PARAM contains the
{                                                             position number); used in
{                                                             urology
{                       A_RECALL_POS                    122   recall the previously stored
{                                                             stand position; used in
{                                                             urology
{                       A_COLOR_ORBITAL                 123   defines the color of the
{                                                             display of orbital c-arm
{                                                             angle
{                                                             PARAM is divided into two
{                                                             enums: bit 7-0: COLOR; bit
{                                                             15-8: ARROW
{                                                             with COLOR: 0-don't care,
{                                                             1-normal, 2-out of range, 3-in
{                                                             range, 4-pos reached
{                                                             and ARROW: 0-don't care, 1-no
{                                                             arrow, 2-left/up,
{                                                             3-right/down, 4-pos reached
{                       A_COLOR_ANGULAR                 124   defines the color of the
{                                                             display of angular c-arm
{                                                             angle
{                                                             PARAM is divided into two
{                                                             enums: bit 7-0: COLOR; bit
{                                                             15-8: ARROW
{                                                             with COLOR: 0-don't care,
{                                                             1-normal, 2-out of range, 3-in
{                                                             range, 4-pos reached
{                                                             and ARROW: 0-don't care, 1-no
{                                                             arrow, 2-left/up,
{                                                             3-right/down, 4-pos reached
{                       A_BYPASS_PARK_POS               125   (used in Luminos Fusion)
{                       A_STORE_C_ANGLE                 126   store current c-arm angles
{                                                             (used in surgery)
{                                                             PARAM=0: disable storage
{                                                             PARAM=n store to memory
{                                                             position n
{                       A_RECALL_C_ANGLE                127   PARAM contains the position
{                                                             number to be recalled. XCU
{                                                             uses this to determine, which
{                                                             position shall be compared to
{                                                             iGGActPos
{                                                             (used in surgery)
{                       A_SET_RESET_3D_ENDPOS           128   Param: 0 = ACS_NO_INFORMATION,
{                                                             1 = Set end position, 2 =
{                                                             Reset end position
{                       A_SET_RESET_3D_STARTPOS         129   Param: 0 = ACS_NO_INFORMATION,
{                                                             1 = Set start position, 2 =
{                                                             Reset start position
{                       A_MANUAL_ALIGNMENT_KIT          130   new parameter for ACSS process
{                                                             when manual table's alignment
{                                                             kit is loosened.
{                                                             Used for reporting the
{                                                             alignment-kit's status in
{                                                             manual tube stand, eg telling
{                                                             whether tube stand and
{                                                             detector is aligned. Belongs
{                                                             to ACSS's function for manual
{                                                             tube stand configuration.
{                       A_CP_POSITION_MATCH             131   The (relative or absolute) CP
{                                                             position is more or less
{                                                             reached
{          Dimension: none

{PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
{          Type:  Integer16     (DEC)
{          Range: -32767 ... 32767
{          Dimension: none


IGGANZ2

Object: IGGANZ2 ___ID: 0086

Description: current position of the stand/gantry, sent from XCU to displays/DFR
              enhanced in order to transfer several axes at a time (thus to reduce AXCS
              traffic)
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTANZAHL amount of actions
          Type:  Count     (CNT)
          Range: 1 ... 20
          Dimension: number of data blocks

{ANZCODE code of the parameter being transferred in PARAM
{          Type:  Enum16     (DEC)
{          Range: 0 ... 131
{                       A_FFA_STRAHLER                  0     SID tube
{                       A_ISOCENTER_HOEHE               1     isocenter height
{                       A_TARGET_LAENGS                 2     target longitudinal
{                       A_TARGET_QUER                   3     target transversal
{                       A_TARGET_HEBEN_SENKEN           4     target lift
{                       A_TARGET_DREHEN                 5     rotate target
{                       A_SCHWENKWINKEL_SAEULE          6     angle of column
{                       A_TUBUSKRAFT                    7     force of tubus
{                       A_TISCHPLATTENDREHUNG           8     rotate table
{                       A_FFA_TARGET                    9     SID target (SID forecast)
{                       A_TISCH_HOEHE                   10    table height
{                       A_TISCH_GERAET_KIPPEN           11    table tilt
{                       A_TISCH_LAENGS                  12    table longitudinal
{                       A_TISCH_QUER                    13    table transversal
{                       A_KIPPMULDE                     14    baby cradle
{                       A_SCHICHTHOEHE                  15    tomo height
{                       A_GERAET_HEBEN_SENKEN           16    lift gantry
{                       A_TUBE_ROT_HOR                  17    horizontal rotation of tube of
{                                                             Rad system
{                       A_STRAHLER_LAENGS               18    tube longitudinal
{                       A_STRAHLER_QUER                 19    tube transversal
{                       A_SHOCKHEAD_POSITION            20
{                       A_TUBUS_IM_STRAHLENGANG         21    tubus (compression unit)
{                       A_C_BOGEN_ORBITAL               22    position in 0.1 degree (signed
{                                                             word)
{                       A_C_BOGEN_ANGULAR               23    position in 0.1 degree (signed
{                                                             word)
{                       A_ISOCENTER_LAENGS              24    longitudinal position related
{                                                             to patient
{                                                             used by image system for care
{                                                             graphics
{                       A_FFA_BEWEGUNG                  25    SID Movement
{                       A_SID_VALID_INVALID             26    SID valid or invalid (in low
{                                                             cost systems there is no
{                                                             potentiometer to acquire the
{                                                             SID continuously, there are
{                                                             only two switches for upper
{                                                             and lower SID. If the tube is
{                                                             in between both positions, the
{                                                             collimators cannot be
{                                                             calculated because they
{                                                             require the exact position. In
{                                                             order not to expose more space
{                                                             than necessary, X-ray is
{                                                             blocked if SID is invalid.
{                                                             PARAM: 0=manual determined,
{                                                             1=SID valid, 2=SID invalid
{                       A_CALIB_SWITCH                  27    Calibration switch in Ysio
{                                                             stand.
{                                                             PARAM: 0=No Information, 1=on,
{                                                             2=off
{                       A_SID_OR_SOD                    28    ==== in sBedGG: ====
{                                                             Information whether SID or SOD
{                                                             Button is pressed to determine
{                                                             which one is measured manually
{                                                             by using the tape of the
{                                                             collimator. Sent from TUI If
{                                                             to XCU.
{                                                             Param: 0 = no information; 1 =
{                                                             SID; 2 = SOD
{                                                             ==== in iGGAnz: ====
{                                                             XCU tells TUI (via TUI
{                                                             Interface) whether manual SID
{                                                             or SOD measurement is
{                                                             possible. Also used to
{                                                             acknowledge the TUI
{                                                             operation.
{                                                             PARAM: bit-coded, transferred
{                                                             into dec:
{                                                             0 = nothing possible, nothing
{                                                             selected
{                                                             1 = SID possible, nothing
{                                                             selected
{                                                             3 = SID possible, SID
{                                                             selected
{                                                             16 = SOD possible, nothing
{                                                             selected
{                                                             48 = SOD possible, SOD
{                                                             selected
{                                                             17 = SID and SOD possible,
{                                                             nothing selected
{                                                             19 = SID and SOD possible, SID
{                                                             selected
{                                                             49 = SID and SOD possible, SOD
{                                                             selected
{                       A_ACSS_POSSIBLE_                29    For Ysio:
{                                                             XCU determines, if ACSS is
{                                                             active or not and sends
{                                                             information via SCU Interface
{                                                             to Stand
{                                                             PARAM: 0 = No Information; 1 =
{                                                             ACSS not possible; 2 = ACSS
{                                                             active
{                       A_FFA_STRAHLER_0P               30
{                       A_ISOCENTER_HOEHE_0P            31
{                       A_TARGET_LAENGS_0P              32
{                       A_TARGET_QUER_0P                33
{                       A_TARGET_HEBEN_SENKEN_0P        34
{                       A_TARGET_DREHEN_0P              35
{                       A_SCHWENKWINKEL_SAEULE_0P       36
{                       A_KOMPRESSION_0P                37
{                       A_TISCHPLATTENDREHUNG_0P        38
{                       A_FFA_TARGET_0P                 39
{                       A_TISCH_HOEHE_0P                40
{                       A_TISCH_GERAET_KIPPEN_0P        41
{                       A_TISCH_LAENGS_0P               42
{                       A_TISCH_QUER_0P                 43
{                       A_KIPPMULDE_0P                  44
{                       A_SCHICHTHOEHE_0P               45
{                       A_GERAET_HEBEN_SENKEN_0P        46
{                       A_STRAHLERDREHUNG_0P            47
{                       A_STRAHLER_LAENGS_0P            48
{                       A_STRAHLER_QUER_0P              49
{                       A_SOD_H                         50    SOD value (in 0.1 mm)
{                       A_C_BOGEN_ORBITAL_0P            52
{                       A_C_BOGEN_ANGULAR_0P            53
{                       A_ZIELGERAET_0P                 54
{                       A_AEC_CENTER_Y                  56    offset between detector center
{                                                             and center of AEC chamber
{                       A_STAND_SPEED                   57    speed class for stand
{                                                             movement:
{                                                             1=ACS_SSPEED_SLOW
{                                                             2=ACS_SSPEED_MEDIUM
{                                                             3=ACS_SSPEED_FAST
{                       A_CAREGRAPH_VALID               58    defines if the values for
{                                                             careposition/profile
{                                                             (ISOCENTER_QUER/_LAENGS) make
{                                                             sense
{                                                             1=caregraph may be shown
{                                                             0=caregraph should not be
{                                                             shown
{                       A_ISOCENTER_QUER                59    transversal position related
{                                                             to patient
{                                                             used by image system for care
{                                                             graphics
{                       A_UMBAU_1                       60
{                       A_UMBAU_2                       61
{                       A_UMBAU_3                       62
{                       A_UMBAU_4                       63
{                       A_UMBAU_5                       64
{                       A_MYELOGRAPHIE                  65
{                       A_PERI_PROGFAHRT                66
{                       A_SCHRITTVERSCHIEBUNG           67
{                       A_DET_TABLE_OUT                 68    Detector in table is pulled
{                                                             out.
{                                                             0 == detector is in tray
{                                                             1 == detector is pulled out
{                                                             555 == detector is completely
{                                                             pulled out
{                       A_DET_WALL_OUT                  69    Detector in wall stand is
{                                                             pulled out.
{                                                             0 == detector is in tray
{                                                             1 == detector is pulled out
{                                                             555 == detector is completely
{                                                             pulled out
{                       A_FESTPOSITION_1                70    peri pos 1
{                       A_FESTPOSITION_2                71    peri pos 2
{                       A_FESTPOSITION_3                72
{                       A_FESTPOSITION_4                73
{                       A_FESTPOSITION_5                74
{                       A_FESTPOSITION_6                75
{                       A_FESTPOSITION_7                76
{                       A_FESTPOSITION_8                77
{                       A_CENTRAL_BEAM_HITS             78    the x-ray beam does not or
{                                                             does only partially hit the
{                                                             detector, such that fluoro
{                                                             must be blocked
{                       A_FESTPOSITION_10               79    peri pos 10
{                       A_ZIELGERAET_BR                 80    brakes of SFD
{                       A_KOMPRESSION_BR                81    brakes of compression
{                       A_ZG_TISCHMITTE_BR              82    spotfilm device brake
{                       A_ZG_PARKPOSITION_BR            83    park pos brake
{                       A_BREMSE_5_BR                   84
{                       A_BREMSE_6_BR                   85
{                       A_BREMSE_7_BR                   86
{                       A_BREMSE_8_BR                   87
{                       A_BREMSE_9_BR                   88
{                       A_PERISCAN                      89
{                       A_POSSYS                        90    positioning detector to tube
{                                                             (alignment),
{                                                             Meaning of PARAM:
{                                                             0=ACS_NO_INFORMATION
{                                                             1=MITTIG_ZENTRIERT (aligned to
{                                                             center)
{                                                             2=OBEN_ZENTRIERT (aligned to
{                                                             upper border)
{                                                             3=MITTIG_ZENTRIERT_NICHT_ERR
{                                                             (center not reached)
{                                                             4=OBEN_ZENTRIERT_NICHT_ERR
{                                                             (top not reached)
{                       A_NACHLAUF                      91    tracking mode
{                                                             Meaning of Param in sBedGG:
{                                                             0=both tracking functions off
{                                                             2=SID tracking off / XY
{                                                             tracking on
{                                                             8=SID tracking on / XY
{                                                             tracking off
{                                                             10=both tracking functions on
{                                                             Meaning of Param in other
{                                                             telegrams:
{                                                             ( _T_ means _TRACKING_)
{                                                             0=ACS_NO_INFORMATION
{                                                             1=ACS_T_X_Y_OFF
{                                                             2=ACS_T_X_Y_ON
{                                                             3=ACS_T_X_Y_LOST
{                                                             4=ACS_T_SID_OFF
{                                                             5=ACS_T_BOTH_OFF
{                                                             6=ACS_T_X_Y_ON_SID_OFF
{                                                             7=ACS_T_X_Y_LOST_SID_OFF
{                                                             8=ACS_T_SID_ON
{                                                             9=ACS_T_X_Y_OFF_SID_ON
{                                                             10=ACS_T_BOTH_ON
{                                                             11=ACS_T_X_Y_LOST_SID_ON
{                                                             12=ACS_T_SID_LOST
{                                                             13=ACS_T_X_Y_OFF_SID_LOST
{                                                             14=ACS_T_X_Y_ON_SID_LOST
{                                                             15=ACS_T_BOTH_LOST
{                       A_TIEFENBLENDE_GEDREHT          92    collimator rotated
{                       A_SPINE_CONSTRUCTION            93
{                       A_CARE_POSITION                 94    enable/disable care position,
{                                                             virtual table movement in Last
{                                                             image hold
{                       A_TIEFENBLENDE_HOR_DEZENTRIERT  95    collimator horizontal not
{                                                             centered
{                                                             PARAM: 1=yes; 0=no
{                       A_CHANGE_ORIENTATION            96    PARAM: Bit1: horizontal
{                                                             (transversal) 0=off, 1=on
{                                                                            Bit2: vertical
{                                                             (longitudinal) 0=off, 1=on
{                                                                            Bit3:
{                                                             orientation: 0=stand,
{                                                             1=monitor
{                       A_WIGGLE_FUNCTION               97    PARAM: 1=on; 0=off
{                       A_DETECTOR_ORIENTATION          98    For Ysio: Orientation of
{                                                             detector relative to normal
{                                                             patient position.
{                                                             Param:
{                                                             1= Position 1, Pixel (0,0) in
{                                                             upper left corner (0°)
{                                                             2= Position 2, Pixel (0,0) in
{                                                             upper right corner (90°
{                                                             clockwise)
{                                                             3= Position 3, Pixel (0,0) in
{                                                             lower right corner (180°
{                                                             clockwise)
{                                                             4= Position 4, Pixel (0,0) in
{                                                             lower left corner (270°
{                                                             clockwise)
{                       A_MAGNIFICATION                 99    Factor of magnification of
{                                                             objects, i.e. relation between
{                                                             SID and SOD (in %)
{                       A_TOP_ALIGN_POSSIBLE            100   SCU reports if top alignment
{                                                             is possible (i.e. if tilt
{                                                             angle <20°)
{                                                             PARAM: 0=no; 1=yes
{                       A_BEAM_ANGLE_ALPHA              101
{                       A_TUBE_ROT_VERTICAL             102
{                       A_BEAM_POS_X                    103   Offset of the central beam
{                                                             relating to the center of the
{                                                             FD in 0.1mm
{                       A_BEAM_POS_Y                    104   Offset of the central beam
{                                                             relating to the center of the
{                                                             FD in 0.1mm
{                       A_DET_WALL_TILT                 105   Tilting angle of detector in
{                                                             wall stand.
{                                                             Value in param in 0.1°
{                       A_POSITION_VALID_FOR_STORAGE    106   Information whether a stand
{                                                             position is valid to be stored
{                                                             in an organ program.
{                                                             Param: 0: no information, 1:
{                                                             position is valid, 2: position
{                                                             is not valid
{                       A_MOVING_BEAM                   107   Limits for decentered ACSS
{                                                             shall only be updated when
{                                                             stand is not in motion
{                                                             Param: 0: Beam is stopped, 1:
{                                                             Beam is moving
{                       A_MOVING_DETECTOR               108   Limits for decentered ACSS
{                                                             shall only be updated when
{                                                             stand is not in motion
{                                                             Param: 0: Detector is stopped,
{                                                             1: Detector is moving
{                       A_MOVING_TABLE                  109   Limits for decentered ACSS
{                                                             shall only be updated when
{                                                             stand is not in motion
{                                                             Param: 0: Table is stopped, 1:
{                                                             Table is moving
{                       A_AUTO_MOVEMENT                 110   stand performs automatic
{                                                             movement:
{                                                             0 =
{                                                             ACS_AUTO_MOVEMENT_INACTIVE
{                                                             1 = ACS_AUTO_MOVEMENT_ACTIVE
{                                                             2 = ACS_AUTO_MOVEMENT_PENDING
{                       A_ORTHO_POS1                    111   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       A_ORTHO_POS2                    112   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       A_TDD                           113   table detector distance in
{                                                             0.1mm
{                       A_ORTHO_STEP                    114   current step (or state) in the
{                                                             ortho flow:
{                                                             1 not in Ortho position (Move
{                                                             button has to be pressed)
{                                                             2 mark first ortho pos
{                                                             3 mark second ortho pos
{                                                             4 ready to move to first Image
{                                                             pos
{                                                             5 ready for apply X-ray
{                                                             6 X-ray is running
{                                                             7 X-ray is over and stand is
{                                                             moving to ortho start pos
{                                                             8 ortho is completed
{                                                             9 ortho is finished
{                                                             10 ortho is aborted
{                                                             11 ortho cannot be started
{                       A_SOFTSTOP                      115   activates or deactivates the
{                                                             SoftStop function
{                       A_PATIENT_TRANSFER              116   param: 1=on, 0=off
{                       A_TOMOADJUST                    117   system shall move to a
{                                                             position in which the tomo
{                                                             fulcrum height (Schichthöhe)
{                                                             can be adjusted using the
{                                                             laser line of the collimator
{                       A_MOVE_DISABLE                  118   any movement blocked on users
{                                                             request
{                       A_BEAM_ANGLE_BETA               119
{                       A_FINAL_POSITION_REACHED        120   The OGP position is reached.
{                                                             This value is taken as a
{                                                             trigger to (re)send the OGP
{                                                             collimation values to the
{                                                             collimator
{                       A_STORE_POS                     121   store the current stand
{                                                             position (PARAM contains the
{                                                             position number); used in
{                                                             urology
{                       A_RECALL_POS                    122   recall the previously stored
{                                                             stand position; used in
{                                                             urology
{                       A_COLOR_ORBITAL                 123   defines the color of the
{                                                             display of orbital c-arm
{                                                             angle
{                                                             PARAM is divided into two
{                                                             enums: bit 7-0: COLOR; bit
{                                                             15-8: ARROW
{                                                             with COLOR: 0-don't care,
{                                                             1-normal, 2-out of range, 3-in
{                                                             range, 4-pos reached
{                                                             and ARROW: 0-don't care, 1-no
{                                                             arrow, 2-left/up,
{                                                             3-right/down, 4-pos reached
{                       A_COLOR_ANGULAR                 124   defines the color of the
{                                                             display of angular c-arm
{                                                             angle
{                                                             PARAM is divided into two
{                                                             enums: bit 7-0: COLOR; bit
{                                                             15-8: ARROW
{                                                             with COLOR: 0-don't care,
{                                                             1-normal, 2-out of range, 3-in
{                                                             range, 4-pos reached
{                                                             and ARROW: 0-don't care, 1-no
{                                                             arrow, 2-left/up,
{                                                             3-right/down, 4-pos reached
{                       A_BYPASS_PARK_POS               125   (used in Luminos Fusion)
{                       A_STORE_C_ANGLE                 126   store current c-arm angles
{                                                             (used in surgery)
{                                                             PARAM=0: disable storage
{                                                             PARAM=n store to memory
{                                                             position n
{                       A_RECALL_C_ANGLE                127   PARAM contains the position
{                                                             number to be recalled. XCU
{                                                             uses this to determine, which
{                                                             position shall be compared to
{                                                             iGGActPos
{                                                             (used in surgery)
{                       A_SET_RESET_3D_ENDPOS           128   Param: 0 = ACS_NO_INFORMATION,
{                                                             1 = Set end position, 2 =
{                                                             Reset end position
{                       A_SET_RESET_3D_STARTPOS         129   Param: 0 = ACS_NO_INFORMATION,
{                                                             1 = Set start position, 2 =
{                                                             Reset start position
{                       A_MANUAL_ALIGNMENT_KIT          130   new parameter for ACSS process
{                                                             when manual table's alignment
{                                                             kit is loosened.
{                                                             Used for reporting the
{                                                             alignment-kit's status in
{                                                             manual tube stand, eg telling
{                                                             whether tube stand and
{                                                             detector is aligned. Belongs
{                                                             to ACSS's function for manual
{                                                             tube stand configuration.
{                       A_CP_POSITION_MATCH             131   The (relative or absolute) CP
{                                                             position is more or less
{                                                             reached
{          Dimension: none

{PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
{          Type:  Integer16     (DEC)
{          Range: -32767 ... 32767
{          Dimension: none


IGGFFA

Object: IGGFFA ___ID: 01A0

Description: current SID (source (tube) to image (cassette, FD or image intensifier)
              distance, send from component to XCU
Sender     :   CCU-IF   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FFA current SID
          Type:  Integer16     (DEC)
          Range: 1 ... 32767
          Dimension: mm

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IGGFOTA

Object: IGGFOTA ___ID: 01A4

Description: distance between focus (tube) and table, important for measuring length on
              patient, sent from component to XCU
Sender     :   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FOTA distance between focus (tube) and table
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mm

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IGGPERISCAN

Object: IGGPERISCAN ___ID: 01A6

Description: Periscanning (moving table or spotfilm device continuously (eventually with
              double speed) while acquisition series is on)
Sender     :   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

PERISCAN Periscan selection
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none


IGGPOS

Object: IGGPOS ___ID: 01AA

Description: status of alignment detector to tube and tracking mode, sent from component to
              XCU
Sender     :   CCU-IF   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

POSSYS positioning detector to tube
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION              0
                     MITTIG_ZENTRIERT                1   center to center alignment
                     OBEN_ZENTRIERT                  2   upper edge to upper edge alignment
                                                         (top alignment)
                     MITTIG_ZENTRIERT_NICHT_ERREICH  3   center alignment not reached
                     OBEN_ZENTRIERT_NICHT_ERREICHT   4   top alignment not reached
          Dimension: none

NACHLAUF Tracking mode
          Type:  Enum8     (DEC)
          Range: 0 ... 15
                     ACS_NO_INFORMATION             0
                     ACS_TRACKING_X_Y_OFF           1
                     ACS_TRACKING_X_Y_ON            2
                     ACS_TRACKING_X_Y_LOST          3
                     ACS_TRACKING_SID_OFF           4
                     ACS_TRACKING_BOTH_OFF          5
                     ACS_TRACKING_X_Y_ON_SID_OFF    6
                     ACS_TRACKING_X_Y_LOST_SID_OFF  7
                     ACS_TRACKING_SID_ON            8
                     ACS_TRACKING_X_Y_OFF_SID_ON    9
                     ACS_TRACKING_BOTH_ON           10
                     ACS_TRACKING_X_Y_LOST_SID_ON   11
                     ACS_TRACKING_SID_LOST          12
                     ACS_TRACKING_X_Y_OFF_SID_LOST  13
                     ACS_TRACKING_X_Y_ON_SID_LOST   14
                     ACS_TRACKING_BOTH_LOST         15
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IIDENT

Object: IIDENT ___ID: 0001

Description: first telegram sent from a component to XCU telling, what kind of component
Sender     :   CCU-IF   FLC   GEN-IF   RAD-STD   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs and XCU_obsolete_IF

List of Parameters:

FETYP type of functional unit
          Type:  Byte     (DEC)
          Range: 1 ... 9
                     BEDIENUNG               1   control console
                     BILDVERARBEITUNG        2   DFR
                     BV_SYSTEM               3   image intensifier system
                     GERAETEGEOMETRIE        4   gantry/stand
                     KASSETTENSYSTEM         5   cassette system
                     STRAHLUNGSERZEUGUNG     6   x-raygenerator
                     STRAHLUNGSMANIPULATION  7   collimator
                     VIDEOSYSTEM             8   image chain
                     FDDETEKTOR              9
          Dimension: none

KNOTENID Hardware node ID
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

KOMPNAME Component name, 10 chars ASCII
          Type:  String8 [ 10 ]     (ASCII)
          Range: 10 ... 10
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IINFOCOMP

Object: IINFOCOMP ___ID: 0BC9

Description: collected SW/FW-versions of all components (being sent via iKennDaten)
              sent from XCU to service PC or PMS for displaying SW versions.
              Outdated telegram; replaced by SH_VERSION or SH_VERSIONCHECK
Sender     :   XCU
Receiver   :   PMS
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

BACKUP_SET bit for telling if config data in XCU have been modified since last backup
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     DATEN_NICHT_GLEICH  1   data not equal; new backup required
                     WEITERES_IINFO      2   another iInfoComp telegramm will follow,
                                             because there is not enough space in one
          Dimension: set of bits

APANZAHL amount of AP Ids in the structure
          Type:  Count     (CNT)
          Range: 0 ... 10
          Dimension: number of data blocks

{APID Application ID (see complete list is attached to the list of all objects)
{          Type:  Byte     (HEX)
{          Range: 0x0 ... 0xFF
{          Dimension: none

{ANZAHLKENNDATEN count of SW/FW data
{          Type:  Byte     (DEC)
{          Range: 1 ... 10
{          Dimension: 2

{KENNDATUM_ID Identifier of HW/SW (SW=1; HW=2; FW=3)
{          Type:  Byte     (DEC)
{          Range: 1 ... 3
{          Dimension: none

{ANZAHLKENNEINTR how many data kenneintr are following
{          Type:  Byte     (DEC)
{          Range: 1 ... 255
{          Dimension: 1

{KENNEINTRAG SW Firmware versions, the length of the entry varies, chars ASCII
{          Type:  String8 [ 1 ]     (ASCII)
{          Range: 1 ... 1
{          Dimension: ASCII String


IINIT

Object: IINIT ___ID: 0008

Description: config data to be stored, sent from component to XCU in order to save these
              data in XCU (nearly obsolete - only used by XCU internally)
Sender     :   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

INITKENNUNG number of init block
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


IIONANZ

Object: IIONANZ ___ID: 008F

Description: control for Meas field display, sent from XCU to any display
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and Sharpfin and show

List of Parameters:

KORRIONANZ Blackening correction
          Type:  Integer16     (DEC)
          Range: -16 ... 16
          Dimension: 0.25 BP

GEWMESSF logical number of chosen measuring field
bits 0-2 define the field selection
bits 3-4 define a rotation (for 5-field chamber)
bit 7 defines histogram based dexi calculation
          Type:  Byte     (DEC)
          Range: 0 ... 128
                     KEINE_ANGABE_RUND        0     circular measuring field
                     LINKS                    1     left
                     MITTE                    2     center
                     LINKS_MITTE              3     left and center
                     RECHTS                   4     right
                     LINKS_RECHTS             5     left and right
                     MITTE_RECHTS             6     center and right
                     LINKS_MITTE_RECHTS       7     left, center, and right
                     ACS_AEC_ROT_90DEG        8     for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees in clockwise direction
                     ACS_AEC_ROT_180DEG       16    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    plus 180 degrees
                     ACS_AEC_ROT_MINUS_90DEG  24    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees counterclockwise (or 270
                                                    degrees clockwise)
                     ACS_AEC_HISTO            128   take histogram based DEXI value instead
                                                    of fixed measuring field
          Dimension: none

AKTMESSF logical number of actual measuring field (individual fields are bitcoded)
          Type:  Byte     (DEC)
          Range: 0 ... 128
                     KEINE_ANGABE_RUND        0     circular measuring field
                     LINKS                    1     left
                     MITTE                    2     center
                     LINKS_MITTE              3     left and center
                     RECHTS                   4     right
                     LINKS_RECHTS             5     left and right
                     MITTE_RECHTS             6     center and right
                     LINKS_MITTE_RECHTS       7     left, center, and right
                     ACS_AEC_ROT_90DEG        8     for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees in clockwise direction
                     ACS_AEC_ROT_180DEG       16    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    plus 180 degrees
                     ACS_AEC_ROT_MINUS_90DEG  24    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees counterclockwise (or 270
                                                    degrees clockwise)
                     ACS_AEC_HISTO            128   take histogram based DEXI value instead
                                                    of fixed measuring field
          Dimension: none

FOLIEEMPF sensitivity of foil to be displayed
          Type:  Integer16     (DEC)
          Range: 10 ... 2000
          Dimension: none

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

FOLIE (only used for iontomat, not for SDM) amplification foil for cassette film (the iontomat has three inputs with different, separately adjustable amplification for the dose
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     ACS_FOLIE_H  0   high sensitive foil (low dose), in FD systems only
                                      used for dose separation
                     ACS_FOLIE_U  1   universal (medium dose)
                     ACS_FOLIE_D  2   detailed resolution (high dose)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IIONANZ2

Object: IIONANZ2 ___ID: 018F

Description: control for meas field display; sent from XCU to any display
Sender     :   XCU
Receiver   :   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

KORRIONANZ Blackening correction
          Type:  Integer16     (DEC)
          Range: -16 ... 16
          Dimension: 0.25 BP

GEWMESSF logical number of chosen measuring field
bits 0-2 define the field selection
bits 3-4 define a rotation (for 5-field chamber)
bit 7 defines histogram based dexi calculation
          Type:  Byte     (DEC)
          Range: 0 ... 128
                     KEINE_ANGABE_RUND        0     circular measuring field
                     LINKS                    1     left
                     MITTE                    2     center
                     LINKS_MITTE              3     left and center
                     RECHTS                   4     right
                     LINKS_RECHTS             5     left and right
                     MITTE_RECHTS             6     center and right
                     LINKS_MITTE_RECHTS       7     left, center, and right
                     ACS_AEC_ROT_90DEG        8     for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees in clockwise direction
                     ACS_AEC_ROT_180DEG       16    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    plus 180 degrees
                     ACS_AEC_ROT_MINUS_90DEG  24    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees counterclockwise (or 270
                                                    degrees clockwise)
                     ACS_AEC_HISTO            128   take histogram based DEXI value instead
                                                    of fixed measuring field
          Dimension: none

AKTMESSF logical number of actual measuring field (individual fields are bitcoded)
          Type:  Byte     (DEC)
          Range: 0 ... 128
                     KEINE_ANGABE_RUND        0     circular measuring field
                     LINKS                    1     left
                     MITTE                    2     center
                     LINKS_MITTE              3     left and center
                     RECHTS                   4     right
                     LINKS_RECHTS             5     left and right
                     MITTE_RECHTS             6     center and right
                     LINKS_MITTE_RECHTS       7     left, center, and right
                     ACS_AEC_ROT_90DEG        8     for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees in clockwise direction
                     ACS_AEC_ROT_180DEG       16    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    plus 180 degrees
                     ACS_AEC_ROT_MINUS_90DEG  24    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees counterclockwise (or 270
                                                    degrees clockwise)
                     ACS_AEC_HISTO            128   take histogram based DEXI value instead
                                                    of fixed measuring field
          Dimension: none

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IIONTVAL

Object: IIONTVAL ___ID: 002E

Description: Transmission of the actual iontomat value from generator to XCU. Generator
              sends this value after every frame. 'If the frames belong to a scene, the
              value is increased by each frame as long as the scene ends. Then it will be
              reset. If the value exceeds 65535 it will be restarted at 0.
              Not used in surgery systems.
Sender     :   GEN-IF
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3

List of Parameters:

IONTOMAT_VALUE Iontomat value of last shot
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: nGy

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IIRIS

Object: IIRIS ___ID: 012F

Description: status of Iris (diaphragm in front of the TV camera) controlling the
              attenuation of the light of the image intensifier
Sender     :   FLC   FLC_TV   GEN-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF

List of Parameters:

GRAUFILTER grey filter (also called mirror), that may attenuate by app 13 BP (dB)
(not used in surgery)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION    0
                     GRAUFILTER_EINFAHREN  1   greyfilter will attenuate
                     GRAUFILTER_AUSFAHREN  2   greyfilter will not attenuate
          Dimension: none

IRISSTATUS Status of iris (not in use)
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     UNTERES_REGELENDE   1
                     OBERES_REGELENDE    2
                     REGELND             3
          Dimension: none

IRISWERT attenuation of iris, 0=fully opened (the larger the value, the darker the image)
old meaning: opening of iris (the larger the value, the less is the attenuation)
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 1/16 BP


IISTWERTEQUIT

Object: IISTWERTEQUIT ___ID: 001A

Description: confirmation to telegram aIstWertQuit, sent from component to XCU after all
              current status telegrams have been sent. If a component does not send the
              iIstwerteQuit when requested XCU will wait for several second and the boot
              phase will be extended by this time..
Sender     :   CCU-IF   FLC   GEN-IF   RAD-STD   SCU-IF   TUI-IF   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro
This object has no parameters


IJUSTAGECMD

Object: IJUSTAGECMD ___ID: 000C

Description: service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              component to XCU
Sender     :   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


IKASSANZ

Object: IKASSANZ ___ID: 0082

Description: cassette status display, sent from XCU to display
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

BILDFORMAT_Q image format division landscape
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.1 mm

BILDFORMAT_L image format division portrait
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.1 mm

KASSPOSITION Cassette position
          Type:  Byte     (DEC)
          Range: 0 ... 4
                     KEINE_FESTE_POSITION   0   position undefined
                     LADEPOSITION_LINKS     1   left loading position
                     LADEPOSITION_RECHTS    2   right loading position (cassette can be
                                                taken by the user to put it in or to take it
                                                out)
                     KASSETTE_PARKPOSITION  3   cassette park position, cassette is out of
                                                the X-ray beam, so that fluoro or DFR
                                                exposures can be taken
                     AUFNAHMEPOSITION       4   exposure position - cassette is directly
                                                underneath the tube in order to be X-rayed
          Dimension: none

KASSGEL Cassette is loaded
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

GEWTEILG current subdivision program (each kind of subdivision (e.g. 4 on 1 or 3 on 1) has a program nr)
          Type:  Byte     (DEC)
          Range: 1 ... 15
          Dimension: none

ANZAHLERLTEILG how many programs are allowed although one or more subdivisions of the currently used programs have already been exposed (e.g. if on a 3 on 1 two sub-images have been exposed, we cannot do a 2:1 anymore, but we can expose a one image of a 4:1 subdivision
          Type:  Count     (CNT)
          Range: 0 ... 15
          Dimension: number of data blocks

{ERLTEILG Allowed subdivisions of cassette in horizontal and vertical directions
{          Type:  Byte     (DEC)
{          Range: 1 ... 15
{          Dimension: none


IKASSDATEN

Object: IKASSDATEN ___ID: 01F4

Description: status and type of a cassette, sent from cassette to XCU
Sender     :   CCU-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

BILDFORMAT_Q image format division landscape
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.1 mm

BILDFORMAT_L image format division portrait
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.1 mm

IDENT Cassette status
          Type:  Byte     (DEC)
          Range: 1 ... 5
                     NEU_EINGELEGTE_KASSETTE  1   new cassette inserted
                     BELICHTETE_KASSETTE      2   cassette exposed
                     KEINE_KASSETTE           3   no cassette inserted
                     UNGUELTIGES_FORMAT       4   invalid cassette inserted
          Dimension: none

TEILANZAHL Possible subdivisions
          Type:  Count     (CNT)
          Range: 1 ... 20
          Dimension: number of data blocks

{TEILUNG_Q Current subdivision
{          Type:  Byte     (DEC)
{          Range: 1 ... 20
{          Dimension: none

{TEILUNG_L Possible subdivision supported by this cassette size.
{          Type:  Byte     (DEC)
{          Range: 1 ... 20
{          Dimension: none

KENNUNG identification string of the cassette (e.g. barcode), 20 chars ASCII
          Type:  String8 [ 20 ]     (ASCII)
          Range: 20 ... 20
          Dimension: none


IKASSPOS

Object: IKASSPOS ___ID: 01F6

Description: current position of the cassette, sent from stand to XCU
Sender     :   CCU-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

KASSPOSITION Cassette position
          Type:  Byte     (DEC)
          Range: 0 ... 4
                     KEINE_FESTE_POSITION   0   position undefined
                     LADEPOSITION_LINKS     1   left loading position
                     LADEPOSITION_RECHTS    2   right loading position (cassette can be
                                                taken by the user to put it in or to take it
                                                out)
                     KASSETTE_PARKPOSITION  3   cassette park position, cassette is out of
                                                the X-ray beam, so that fluoro or DFR
                                                exposures can be taken
                     AUFNAHMEPOSITION       4   exposure position - cassette is directly
                                                underneath the tube in order to be X-rayed
          Dimension: none

DLSTEUERUNG fluoro control, a cassette that is not in park position e.g. in load position or is currently being moved will be in X-ray beam and disturb a fluoro image, so fluoro has to disabled in those cases, same applies for collimator, if it does a search run or is "in the way"
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     DL_GESPERRT         1   fluoro blocked
                     DL_FREIGEGEBEN      2   fluoro enabled
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IKENNDATEN

Object: IKENNDATEN ___ID: 000A

Description: SW/FW version of a component, sent from component to XCU
Sender     :   CCU-IF   FLC   GEN-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs and XCU_obsolete_IF

List of Parameters:

ANZAHLKENNDATEN count of SW/FW data
          Type:  Byte     (DEC)
          Range: 1 ... 10
          Dimension: 2

{KENNDATUM_ID Identifier of HW/SW (SW=1; HW=2; FW=3)
{          Type:  Byte     (DEC)
{          Range: 1 ... 3
{          Dimension: none

{ANZAHLKENNEINTR how many data kenneintr are following
{          Type:  Byte     (DEC)
{          Range: 1 ... 255
{          Dimension: 1

{KENNEINTRAG SW Firmware versions, the length of the entry varies, chars ASCII
{          Type:  String8 [ 1 ]     (ASCII)
{          Range: 1 ... 1
{          Dimension: ASCII String


IKOLLAUFL

Object: IKOLLAUFL ___ID: 0079

Description: release collision, sent from XCU to displays
              (used in Rad3 only)
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  Rad3

List of Parameters:

AUFLANZAHL how many drives are required to release collision
          Type:  Dcount     (CNT)
          Range: 0 ... 20
          Dimension: number of data blocks

{FKTCODE function code that is invalid
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{AUFLRICHTUNG function code that is invalid
{          Type:  Integer16     (DEC)
{          Range: -1 ... 1
{                       NEG_AUFLRICHTUNG  -1
{                       POS_AUFLRICHTUNG  1
{          Dimension: none


IKOLLISION

Object: IKOLLISION ___ID: 019D

Description: collision detection, sent from component to XCU
              (used in Rad3 only)
Sender     :
Receiver   :
Mode       :  DIRECT(01)
Systems    :  Rad3

List of Parameters:

ANTRIEBSANZAHL Amount of drives
          Type:  Dcount     (CNT)
          Range: 0 ... 10
          Dimension: number of data blocks

{ANTRIEB drive: subunit which is able to perform a unit movement
{          Type:  Byte     (DEC)
{          Range: 0 ... 131
{                       FFA_STRAHLER                    0     SID tube
{                       ISOCENTER_HOEHE                 1     isocenter height
{                       TARGET_LAENGS                   2     target longitudinal
{                       TARGET_QUER                     3     target transveral
{                       TARGET_HEBEN_SENKEN             4     lift target
{                       TARGET_DREHEN                   5     rotate target
{                       SCHWENKWINKEL_SAEULE            6     angle of column
{                       TUBUSKRAFT                      7     force of tubus
{                       TISCHPLATTENDREHUNG             8     rotate table
{                       FFA_TARGET                      9     SID target
{                       TISCH_HOEHE                     10    table height
{                       TISCH_GERAET_KIPPEN             11    table tilt
{                       TISCH_LAENGS                    12    table longitudinal
{                       TISCH_QUER                      13    table transversal
{                       KIPPMULDE                       14    baby cradle
{                       SCHICHTHOEHE                    15    tomo height
{                       GERAET_HEBEN_SENKEN             16    lift gantry
{                       ACS_TUBE_ROT_HOR                17    rotate tube
{                       STRAHLER_LAENGS                 18    tube longitudinal
{                       STRAHLER_QUER                   19    tube transversal
{                       SPAETERE_ANWENDUNG              20    (reserved for future use)
{                       TUBUS_EIN_AUSFAHREN             21    move tubus (compression unit)
{                       C_BOGEN_ORBITAL                 22    c-arm orbital
{                       C_BOGEN_ANGULAR                 23    c-arm angular
{                       ISOCENTER_LAENGS                24    isocenter longitudinal
{                       FFA_BEWEGUNG                    25    SID movement
{                       ACS_SID_VALID_OR_INVALID        26    SID valid or invalid (in low
{                                                             cost systems there is no
{                                                             potentiometer to acquire the
{                                                             SID continuously, there are
{                                                             only two switches for upper
{                                                             and lower SID. If the tube is
{                                                             in between both positions, the
{                                                             collimators cannot be
{                                                             calculated because they
{                                                             require the exact SID
{                                                             position. In order not to
{                                                             expose more space than
{                                                             necessary, X-ray is blocked if
{                                                             SID is invalid.
{                                                             ANTRIEBSTATUS: 0=manual
{                                                             determined; 1=Valid; 2=Invalid
{                       ACS_CALIBRATION_SWITCH          27    Calibration switch in Ysio
{                                                             stand.
{                                                             PARAM: 0=No Information, 1=on,
{                                                             2=off
{                       ACS_SID_OR_SOD                  28    Not in use. Only a placeholder
{                                                             for the corresponding ANZCODE.
{                       ACS_ACSS_POSSIBLE_              29    For Ysio:
{                                                             XCU determines, if ACSS is
{                                                             active or not and sends
{                                                             information via SCU Interface
{                                                             to stand.
{                       ACS_SOD_H                       50    SOD value (in 0.1mm)
{                       ACS_AEC_CENTER_Y                56    offset between detector center
{                                                             and center of AEC chamber
{                       ISOCENTER_QUER                  59    isocenter lateral
{                       ACS_AUTO_MOVE_TARGET            66    see parameter
{                                                             sh_stpar_rfp.auto_move_target
{                       ACS_DET_TABLE_OUT               68    Detector or cassette in table
{                                                             is pulled out.
{                                                             Meaning of Physposition:
{                                                             0:        detector is in tray
{                                                             >0:      detector is pulled
{                                                             out
{                                                             ACS_INIL: detector is in
{                                                             intermediate position
{                       ACS_DET_WALL_OUT                69    Detector or cassette in wall
{                                                             stand is pulled out.
{                                                             Meaning of Physposition:
{                                                             0:        detector is in tray
{                                                             >0:      detector is pulled
{                                                             out
{                                                             ACS_INIL: detector is in
{                                                             intermediate position
{                       ACS_CENTRAL_BEAM_HITS           78    the x-ray beam does not or
{                                                             does only partially hit the
{                                                             detector, such that fluoro
{                                                             must be blocked
{                       ACS_DETECTOR_ORIENTATION        98    For Ysio: Orientation of
{                                                             detector relative to normal
{                                                             patient position.
{                                                             Physposition:
{                                                             1= Position 1, Pixel (0,0) in
{                                                             upper left corner (0°)
{                                                             2= Position 2, Pixel (0,0) in
{                                                             upper right corner (90°
{                                                             clockwise)
{                                                             3= Position 3, Pixel (0,0) in
{                                                             lower right corner (180°
{                                                             clockwise)
{                                                             4= Position 4, Pixel (0,0) in
{                                                             lower left corner (270°
{                                                             clockwise)
{                       ACS_BEAM_ANGLE_ALPHA            101   Beam angle alpha of tube for
{                                                             Ysio
{                       ACS_TUBE_ROT_VERTICAL           102   vertical rotation of tube for
{                                                             Ysio
{                       ACS_BEAM_POS_X                  103   deviation between center of
{                                                             beam towards center of target
{                                                             (FD, cassette, I.I.) in
{                                                             patient longitudinal direction
{                       ACS_BEAM_POS_Y                  104   deviation between center of
{                                                             beam towards center of target
{                                                             (FD, cassette, I.I.) in
{                                                             patient lateral direction
{                       ACS_DET_WALL_TILT               105   Tilting angle of detector in
{                                                             wallstand.
{                                                             Value in physposition in 0.1°
{                       ACS_POSITION_VALID_FOR_STORAGE  106   Information whether a stand
{                                                             position is valid to be stored
{                                                             in an organ program.
{                                                             Physposition: 0: no
{                                                             information, 1: position is
{                                                             valid, 2: position is not
{                                                             valid
{                       ACS_MOVING_BEAM                 107   Physposition: 0: Beam is
{                                                             stopped 1: Beam is moving
{                       ACS_MOVING_DETECTOR             108   Physposition: 0: Detector (or
{                                                             cassette tray) is stopped, 1:
{                                                             Detector (or cassette tray) is
{                                                             moving
{                       ACS_MOVING_TABLE                109   Physposition: 0: Table is
{                                                             stopped, 1: Table is moving
{                       ACS_AUTO_MOVEMENT               110   stand performs automatic
{                                                             movement:
{                                                             0 =
{                                                             ACS_AUTO_MOVEMENT_INACTIVE
{                                                             1 = ACS_AUTO_MOVEMENT_ACTIVE
{                                                             2 = ACS_AUTO_MOVEMENT_PENDING
{                       ACS_ORTHO_POS1                  111   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       ACS_ORTHO_POS2                  112   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       ACS_TDD                         113   Table Detector Distance in
{                                                             0.1mm
{                       ACS_ORTHO_STEP                  114   current step (or state) in the
{                                                             ortho flow::
{                                                             1 not in Ortho position (Move
{                                                             button has to be pressed)
{                                                             2 mark first ortho pos
{                                                             3 mark second ortho pos
{                                                             4 ready to move to first Image
{                                                             pos
{                                                             5 ready for apply X-ray
{                                                             6 X-ray is running
{                                                             7 X-ray is over and stand is
{                                                             moving to ortho start pos
{                                                             8 ortho is completed
{                                                             9 ortho is finished
{                                                             10 ortho is aborted
{                                                             11 ortho cannot be started
{                       ACS_SOFTSTOP                    115   activates or deactivates the
{                                                             SoftStop function
{                       ACS_PATIENT_TRANSFER            116   param: 1=on; 0=off
{                       ACS_TOMOADJUST                  117   system shall move to a
{                                                             position in which the tomo
{                                                             fulcrum height (Schichthöhe)
{                                                             can be adjusted using the
{                                                             laser line of the collimator
{                       ACS_MOVE_DISABLE                118   block any movement on users
{                                                             request
{                       ACS_BEAM_ANGLE__BETA            119   Beam angle beta of tube for
{                                                             Ysio
{                       ACS_FINAL_POSITION_REACHED      120   The OGP position is reached.
{                                                             This value is taken as a
{                                                             trigger to (re)send the OGP
{                                                             collimation values to the
{                                                             collimator
{                       ACS_STORE_POS                   121   store the current stand
{                                                             position
{                       ACS_RECALL_POS                  122   recall the previously stored
{                                                             stand position
{                       ACS_COLOR_ORBITAL               123   see A_COLOR_ORBITAL in ANZCODE
{                       ACS_COLOR_ANGULAR               124   see A_COLOR_ANGULAR in ANZCODE
{                       ACS_BYPASS_PARK_POS             125   (used in Luminos Fusion)
{                       ACS_CP_POSITION_MATCH           131   The (relative or absolute) CP
{                                                             position is more or less
{                                                             reached
{          Dimension: none

{ANTRIEBSRICHTUNG moving direction
{          Type:  Enum8     (DEC)
{          Range: 0 ... 2
{                       ACS_NO_INFORMATION  0
{                       POS_ENDSTELLUNG     1   positive limit
{                       NEG_ENDSTELLUNG     2   negative limit
{          Dimension: none


IMAGN

Object: IMAGN ___ID: 02E9

Description: with this object FLC tells XCU if magnification feature is possible, and which
              zoom factor is currently used
Sender     :   FLC
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

MAGN_POSSIBLE this parameter signifies, if postproc magnification feature is possible
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_YES  1
                     ACS_NO   2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MAGNIFICATION Magnification factor (in%) applied by FLC for postproc magnification feature
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: %


IMYELO

Object: IMYELO ___ID: 01A3

Description: feedback of myelograhy
Sender     :   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

STATUSMYELO Requesting myelography
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     MYELO_EIN  1   on= no stop on 0° tilt position
                     MYELO_AUS  2   off= stop on 0° tilt position
          Dimension: none


INACHANZ

Object: INACHANZ ___ID: 0090

Description: display of X-ray parameters of the last exposure being taken,
Sender     :   XCU
Receiver   :   FLC   PMS   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3

List of Parameters:

MASIST mAs value of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 100500
          Dimension: 0.01 mAs

MSIST duration of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

PULSE amount of pulses combined in this telegram (this is used if frame rate is too high to send a separate telegram for each pulse)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IONLIMIT has the exposure been terminated due to exceeding limits (like max time or max mAs)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


INETZAUFNAHME

Object: INETZAUFNAHME ___ID: 0002

Description: the component has been announced and welcome to the XCS network, answer to
              iIdent, sent from XCU to component
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   TUI-IF
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs and XCU_obsolete_IF
This object has no parameters


INIT_CONNECTION

Object: INIT_CONNECTION ___ID: 2901

Description: init and connect to the server. But this object is only sent by the method
              'connectToServer' of the client library and not by an application itself.
Sender     :   AXN
Receiver   :   AXN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

DUM_TIME_CNT counter for the dummy time
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: multiple of base

VERSION_INITCONNECTION version of the object INIT_CONNECTION
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_INITCONNECTION  1   version 1 since VE20G: new structure t2
          Dimension: none

NO_AXN_VERSIONS number of versions of AXN packages
          Type:  Count     (CNT)
          Range: 0 ... 60
          Dimension: none

{VERS_TYPE specification of version and unit
{          Type:  Enum8     (DEC)
{          Range: 1 ... 4
{                       ACS_HARDWARE   1
{                       ACS_SOFTWARE   2
{                       ACS_FIRMWARE   3
{                       ACS_ACSHEADER  4   version of the used AXCS header file
{          Dimension: none

{DUMMY1
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{UNIT_ID unique ID of a HW, SW or FW unit , 6 chars UNICODE filled up with 20h
{          Type:  String16 [ 6 ]     (ASCII)
{          Range: 12 ... 12
{          Dimension: unicode

{VERSION version of a HW, SW or FW unit , 4 chars UNICODE (filled up with 20h)
{          Type:  String16 [ 4 ]     (ASCII)
{          Range: 8 ... 8
{          Dimension: unicode


INIT_MSG

Object: INIT_MSG ___ID: 9200

Description: init message; sent with MODE = MESSAGE (2); it must not be in the inlist
Sender     :   AXN
Receiver   :   ALL
Mode       :  MESSAGE(02)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


INLIST_ENH

Object: INLIST_ENH ___ID: 2902

Description: enhancement of in-list; has to be sent with MODE = FUNCTIONAL (0)
Sender     :   ALL
Receiver   :   AXN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

NO_OBJECTS number of objects (the axnroot later than VC11E is able to handle max. 600 objects)
          Type:  Dcount     (CNT)
          Range: 0 ... 600
          Dimension: number of data blocks

{OBJECT_ID ID of the object
{          Type:  Word     (HEX)
{          Range: 0x0 ... 0xFFFE
{          Dimension: none


INLIST_RED

Object: INLIST_RED ___ID: 2903

Description: reduction of in-list; has to be sent with MODE = FUNCTIONAL (0).
              GROUP_INDEX = 0xFF means: LOGOFF to change the group.
Sender     :   ALL
Receiver   :   AXN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

NO_OBJECTS number of objects (the axnroot later than VC11E is able to handle max. 600 objects)
          Type:  Dcount     (CNT)
          Range: 0 ... 600
          Dimension: number of data blocks

{OBJECT_ID ID of the object
{          Type:  Word     (HEX)
{          Range: 0x0 ... 0xFFFE
{          Dimension: none


INOTSTROM

Object: INOTSTROM ___ID: 02D8

Description: emergency power supply, sent from Generator to XCU. If emergency power is on,
              acquisitions will be refused by XCU. Telegram flow: iNotStrom --->
              iErwAllgAnz_2
              The status will also be displayed literally in iDFRAllgAnz_2 for ImgSys and
              ST_DTEXT for TUI.
Sender     :   GEN-IF   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

NOTSTROMSTATUS Emergency power supply; Polydoros SX has an input for the switch indicating that emergency power is enabled. In this case, high power X-ray (as acquisition) should be disabled in order to not overload the emergency power supply.
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     NOTSTROM_AUS    0   normal operation
                     NOTSTROM_AKTIV  1   emergency power supply is active
                     NOTSTROM_USV    2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IOGPSTORE

Object: IOGPSTORE ___ID: 0269

Description: organ program storage message, sent from XCU to image system
              in new RadFluoro platform used as confirmation on ST_CP_DATA
Sender     :   XCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

MEMSTATUS Return value for an organ program given by the imaging system to XCU. Indicates whether program was OK in parameters and has been distributed to components
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION  0
                     ORGANSP_OK          1
                     ORGANSP_NOK         2
                     DLPRGSP_OK          3
                     DLPRGSP_NOK         4
                     PRG3D_OK            5
                     PRG3D_NOK           6
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IORGANANZ2

Object: IORGANANZ2 ___ID: 00AE

Description: display of organ program and examination set
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

PROGMAN is the current organ program original or modified
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     PROGRAMM            1   original programmed value
                     MANUAL              2   customer has done some modifications after
                                             selecting the OGP
                     OVERRIDE            3   program currently in use is completely
                                             different to stored one
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

EXAM_INDEX Index of chosen Exam Set, to synchronize List of OGPs and EXAM-Set between TUI and Fluorospot
          Type:  Integer16     (DEC)
          Range: -1 ... 32767
                     ACS_EXAM_DEFAULT  -1   FLC shall select application from default
                                            application group (used in button based surgery
                                            system)
                     KK_ABWAHL         0
                     EXAM_SET          1
                     SETS_2_TO_31      2    Exam sets 1 to 31
                     EXAM_SET_NRF      20
                     KK_PROGRAM        32
          Dimension: none

ORGAN_INDEX Index of organ program (0=no information)
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: none

TRANSPKORR transparency correction, a transparency correction is a parameter modification of the current X-parameters by one push button (e.g. very thin, thin, medium, thick, very thick) and will affect kV and/or mAs
          Type:  Integer16     (DEC)
          Range: -2 ... 2
          Dimension: 0.25 BP

ALT_INDEX Index for an alternative organ program, used for Ysio Systems.
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IORGPOSITIONS

Object: IORGPOSITIONS ___ID: 01B8

Description: XCU sends current stand positions to ImageSystem in order to store them in an
              OGP. ImageSystem has to send an aFDAufnPos before. Not applicable Parameters
              should be sent with Nil.
Sender     :   XCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TBL_X_RAD RAD only: table longitudinal position headwards / footwards
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Y_RAD RAD only: table side (transverse) offset, left / right
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Z_RAD RAD only: table lift (height)
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TBL_ROT_RAD RAD only: table left / right, + means: right
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_LONGI RAD only: Longitudinal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_TRANS RAD only: Transversal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_LIFT RAD only: Detector (or cassette) lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

DETECTOR_ROT_HOR RAD only: detector (or cassette) rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_ROT_VERTICAL RAD only: detector (or cassette) rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_TILT RAD only: detector (or cassette) tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_LONGI RAD only: Longitudinal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_TRANSVERSAL RAD only: transversal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_LIFT RAD only: Tube lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TUBE_ROT_HOR RAD only: Tube rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_VERTICAL RAD only: Tube rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

WALL_STAND_LIFT RAD only: Wall stand lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

WALL_STAND_TILT RAD only: wall stand tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

BEAM_ANGLE_ALPHA RAD only: Angle of incidence (alpha) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

BEAM_ANGLE_BETA RAD only: Angle of incidence (beta) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

COLLIMATOR_ROT_A RAD only: Collimator rotation
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TOMO_HEIGHT height for tomo
          Type:  Word     (DEC)
          Range: 0 ... 5000
          Dimension: 0.1 mm

ALIGNMENT_MODE Determines, whether tube center is aligned to detector (or cassette) center, or whether top of collimator field of view is aligned to top of detector (or cassette)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_ALIGNMENT_CENTERED  0   centered
                     ACS_ALIGNMENT_TOP       1   top
          Dimension: none

TRACKING Tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 15
                     ACS_TRACK_NOT_ACTIVE         0    tracking not active
                     ACS_TRACK_SYMMETRICAL        1    symmetrical
                     ACS_TRACK_TOP_ALIGN          2    asymmetrical top alignment
                     ACS_TRACK_BOTTOM_ALIGN       3    asymmetrical bottom alignment
                     ACS_TRACK_LEFT_ALIGN         4    asymmetrical left alignment
                     ACS_TRACK_RIGHT_ALIGN        5    asymmetrical right alignment
                     ACS_TRACK_LOST_SYMMETRICAL   11   tracking lost, symmetrical
                     ACS_TRACK_LOST_TOP_ALIGN     12   tracking lost, asymmetrical top
                                                       alignment
                     ACS_TRACK_LOST_BOTTOM_ALIGN  13   tracking lost, asymmetrical bottom
                                                       alignment
                     ACS_TRACK_LOST_LEFT_ALIGN    14   tracking lost, asymmetrical left
                                                       alignment
                     ACS_TRACK_LOST_RIGHT_ALIGN   15   tracking lost, asymmetrical right
                                                       alignment
          Dimension: none

SID_TRACKING SID tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_TRACK_NOT_ACTIVE  0   SID tracking not active
                     ACS_SID_TRACK_ACTIVE      1   SID tracking active
                     ACS_SID_TRACK_LOST        2   SID tracking lost
          Dimension: none

POS_VALID_FOR_STORAGE SCU gives information whether a stand position is valid to be stored in an organ program.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_POS_VALID       1   This position is valid to be stored in an organ
                                             program
                     ACS_POS_NOT_VALID   2   This position is not valid to be stored in an
                                             organ program.
          Dimension: none

TUBE_ROT_HOR_FLUORO tube rotation at dRF
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_LIFT_FLUORO tube lift at dRF
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TBL_TILT table tilting up / down  around Y axis, + means: head end up
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
                     ACS_HORIZONTAL_TABLE  0
          Dimension: 0.1 degree

TOWER_LONGI longitudinal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -30000 ... 30000
          Dimension: 0.1 mm

TOWER_TRANSVERSAL transversal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -10000 ... 10000
          Dimension: 0.1 mm


IORTHO

Object: IORTHO ___ID: 01AD

Description: Information of the image system about ortho parameters
Sender     :   CCU-IF   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FULL_IMAGE_SIZE Total length of the ortho exposure to be scanned
          Type:  Integer32     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mm

POS1VAL angle of the first ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°

POS2VAL angle of the second ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NR_IMAGES Number of ortho images
          Type:  Count     (CNT)
          Range: 0 ... 4
          Dimension: none

{IMAGE_SIZE Size of the current image of an ortho scene
{          Type:  Word     (DEC)
{          Range: 0 ... 4300
{          Dimension: 0.1 mm

{ORTHO_OVERLAP overlap with the next image
{          Type:  Word     (DEC)
{          Range: 0 ... 1000
{          Dimension: 0.1 mm


IORTHOACTSIZE

Object: IORTHOACTSIZE ___ID: 01AF

Description: SCU informs the XCU about the size of the current part of an ortho image.
Sender     :   CCU-IF   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

IMAGE_NR Number of the current image of an ortho sequence
          Type:  Byte     (DEC)
          Range: 0 ... 4
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IMAGE_SIZE Size of the current image of an ortho scene
          Type:  Word     (DEC)
          Range: 0 ... 4300
          Dimension: 0.1 mm

POSITION_ORTHO distance from first to actual detector position
          Type:  Integer32     (DEC)
          Range: 0 ... 25000
          Dimension: 0.1 mm

DUMMY Dummy parameter (4 chars ASCII)
          Type:  String8 [ 4 ]     (ASCII)
          Range: 4 ... 4
          Dimension: none


IPASSWORT

Object: IPASSWORT ___ID: 0F10

Description: Nowadays only the host-id is transferred via aPassWort / iPassWort mechanism,
              because in most systems the imaging system is the host for the password.
              This is used for license key as well as in surgery for compatibility check
              between Trolley and MainUnit (SCU->XCU).
Sender     :   XCU
Receiver   :   FLC   PMS   UIS   XWP
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

PWDSTATUS Which element has been modified
          Type:  Byte     (DEC)
          Range: 0 ... 5
                     PASSWORT      0   password
                     ABLAUFDATUM   1   expiration date
                     PRODUCTID     2   product ID
                     SACHNUMMER    3   serial number
                     HOSTID        4
                     ANLAGENDATUM  5   date from the system
          Dimension: none

PASSWORT Password for service, 30 chars ASCII
          Type:  String8 [ 30 ]     (ASCII)
          Range: 30 ... 30
          Dimension: ASCII String

ABLAUFDATUM expiration date of the variable password,maintained by old XCU, 11 chars ASCII
          Type:  String8 [ 11 ]     (ASCII)
          Range: 11 ... 11
          Dimension: none

PRODUKTID Product-ID of the system, 11 chars ASCII
          Type:  String8 [ 11 ]     (ASCII)
          Range: 11 ... 11
          Dimension: none

SN Serial number of the system, 11 chars ASCII
          Type:  String8 [ 11 ]     (ASCII)
          Range: 11 ... 11
          Dimension: none

HOSTID host-id of the system read-out from an id-chip (typ. MAC address)
left aligned null-terminated string, max.15 chars ASCII
          Type:  String8 [ 16 ]     (ASCII)
          Range: 16 ... 16
          Dimension: none

ANLAGENDATUM Current XCU Date (21 chars ASCII)
          Type:  String8 [ 21 ]     (ASCII)
          Range: 21 ... 21
          Dimension: none

PWDDATUM Generation date of the password, 11 chars ASCII
          Type:  String8 [ 11 ]     (ASCII)
          Range: 11 ... 11
          Dimension: none


IPERIPHASE

Object: IPERIPHASE ___ID: 02D3

Description: current peri phase, sent from XCU to DFR and generator
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

STATUSPERI Status of peri for DFR and generator.
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     STATUSPERI_NORMAL   1   normal peri
                     PROGRAMMIERFAHRT    2   programming run with fluoro
                     MASKENFAHRT         3   mask run, acquiring masks for perivision
                     AUFNAHMEFAHRT       4   fill run; run for perivision with DSA
          Dimension: none


IPRINTAUFN

Object: IPRINTAUFN ___ID: 009A

Description: printing the data of the last exposure
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3

List of Parameters:

MASIST mAs value of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 100500
          Dimension: 0.01 mAs

DFP dose area product of actual acquisition / acq series / fluoro event
(fnote: formerly the dimension was defined by the parameter DFPNACHKOMMA)
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

DOSE_FOR_PRINT Dose for telegrams iPrintAufn and iPrintDL.
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: 1 µGy

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

SKINFA Distance between Tube (Focus) and Skin of patient for calculation of Air Kerma and Air Kerma Rate from DAP
          Type:  Byte     (DEC)
          Range: 1 ... 255
          Dimension: cm

DFPNACHKOMMA This parameter determines how the DFP has to be displayed.
(note: formerly this parameter also determined the dimension of DPF)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_DFP_0    0   display no digits after the decimal point
                                      (no longer used, only for old chambers)
                     ACS_DFP_01   1   DFP in 0.1µGym²
                     ACS_DFP_001  2   DFP in 0.01µGym²
          Dimension: none

ANZBILDER Amount of images
          Type:  Integer16     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IRASTER

Object: IRASTER ___ID: 032B

Description: feedback of grid, sent from component to XCU
              Used in Uroscope only (since there we have a motorized grid)
Sender     :   CCU-IF   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

RASTERNR Grid number
          Type:  Byte     (DEC)
          Range: 0 ... 7
          Dimension: none

RASTERSTATUS Grid status
          Type:  Byte     (DEC)
          Range: 0 ... 4
                     RASTERPOS_UNDEF      0   grid status undefined (Grid is moving between
                                              in and out)
                     RASTER_AKTIV         1   grid moving
                     RASTERPOS_ERREICHT   2   grid position reached
                     RASTER_REVERSIEREND  3   grid is reversing
                     RASTER_GESTOPPT      4   grid has been stopped
          Dimension: none

RASTERPOSITION Grid position; 1 means grid is parked = not inserted, 0 = Grid is moving between in and out; 2 = grid is inserted, 3 = Grid is ready for reversing so that grid lines are invisible in image, only for reversable grids applicable
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     RASTERPOS_UNDEF        0   grid status undefined (Grid is moving
                                                between in and out)
                     PARKPOSITION           1   grid is parked = not inserted
                     ZENTRIERTPOSITION      2   grid is inserted
                     VORBEREITUNGSPOSITION  3   Grid is ready for reversing so that grid
                                                lines are invisible in image, only for
                                                reversable grids applicable
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IRASTERANZ

Object: IRASTERANZ ___ID: 0333

Description: XCU sends status of grid to the displays.
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

RASTER Grid number according to configuration
          Type:  Byte     (DEC)
          Range: 0 ... 7
                     ACS_NO_GRID_SELECTED  0   no grid selected
          Dimension: none

GRID_CHANGE State of grid for radfluoro systems
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_NO_INFORMATION   0
                     ACS_GRID_IN          1   Grid chosen in OGP is inserted.
                     ACS_GRID_IN_CHANGE   2   Grid inserted but not the one chosen in OGP.
                     ACS_GRID_OUT         3   No grid inserted.
                     ACS_GRID_OUT_CHANGE  4   No grid inserted but OGP wants a grid.
          Dimension: none

GRID_FOCUS focus of the grid
          Type:  Integer16     (DEC)
          Range: -2 ... 10000
                     ACS_GRID_5          1000
                     ACS_GRID_1          1150
                     ACS_GRID_UNIVERSAL  1400
                     ACS_GRID_2          1500
                     ACS_GRID_3          1800
                     ACS_GRID_4          3000
          Dimension: mm

GRID_CORRECT XCU reports if the currently inserted grid matches the configuration and current SID
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_GRID_WRONG           0
                     ACS_GRID_CORRECT         1
                     ACS_GRID_NOT_DETECTABLE  2   the (snap-on) grid (of the free detector)
                                                  cannot be sensed, so it can not be said,
                                                  if the grid is correct or wrong
          Dimension: none

GRID_ORIENTATION orientation of the installed grid
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_GRID_VERTICAL    0   normal orientation
                     ACS_GRID_HORIZONTAL  1   grid rotated 90 degree
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

GRID_REQUESTED shows if a grid is requested in the CP step
In a RAD3 system using DROC a dedicated Grid can be requested
          Type:  Enum8     (DEC)
          Range: 0 ... 16
                     ACS_NO_GRID_REQUESTED  0
                     ACS_GRID_REQUESTED     1
                     ACS_GRID1_REQUESTED    11
                     ACS_GRID2_REQUESTED    12
                     ACS_GRID3_REQUESTED    13
                     ACS_GRID4_REQESTED     14
                     ACS_GRID5_REQUESTED    15
                     ACS_GRID6_REQUESTED    16
          Dimension: none

GRID_FOCUS_NEEDED required focus of the grid (according to SID)
          Type:  Integer16     (DEC)
          Range: -2 ... 10000
                     ACS_GRID_NOT_DEFINED  -1     the found grid is unknown
                     ACS_GRID_5            1000
                     ACS_GRID_1            1150
                     ACS_GRID_UNIVERSAL    1400
                     ACS_GRID_2            1500
                     ACS_GRID_3            1800
                     ACS_GRID_4            3000
          Dimension: mm

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IREGELSTOP

Object: IREGELSTOP ___ID: 02D6

Description: feedback about regulation stop of X-ray from generator, sent from generator to
              XCU
Sender     :   GEN-IF   UGEN
Receiver   :   UIS   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

REGELUNGEIN Regulation status of generator (1=yes=on; 0=no=off)
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     NEIN       0   no
                     JA         1   yes
                     AUTO_NEIN  2   generator has stopped regulation automatically (after a
                                    given number of pulses for subtraction)
                                    (used in surgery)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IREGSTPMARKDFR

Object: IREGSTPMARKDFR ___ID: 0259

Description: sending X-ray regulation of generator to DFR in order to trigger the DSA mask,
              sent from XCU to DFR
              Might be used by UIS to know when the dose regulation is ON/OFF (Pike)
Sender     :   UIS   XCU
Receiver   :   FLC   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DFRREGZUS Status of regulation:
1=JA=regulation running
0=NEIN=regulation stop
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IROEANZ

Object: IROEANZ ___ID: 007D

Description: heat status of the current selected tube in the system, sent from XCU to
              displays
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TUBELD tube heat unit value in percent (calculated by XCU)
the 100 % value given kJ can be looked up in tube data
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

COLOR color of the tube load display
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_COLOUR_DEF    0   default colour
                     ACS_COLOR_GREEN   1
                     ACS_COLOR_YELLOW  2
                     ACS_COLOR_RED     3
          Dimension: none

PAUSE_FOR_XCS Recommended idle time
          Type:  Word     (DEC)
          Range: 0 ... 3600
          Dimension: sec

TUBETEMP oil temperature of monoblock in percent (used ins surgery)
0% value (e.g.25°C) and 100% value (e.g. 70°C) are parametrized in CAF
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

COLOR_TEMP color of the temperature display (used in surgery)
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_COLOUR_DEF    0   default colour
                     ACS_COLOR_GREEN   1
                     ACS_COLOR_YELLOW  2
                     ACS_COLOR_RED     3
          Dimension: none

PAUSE_FOR_3D time in seconds until the 3D run can be performed
(w/ currently selected OGP at the current location (watervalue from fluoros))
          Type:  Word     (DEC)
          Range: 0 ... 3600
          Dimension: sec


ISCHICHTANTR

Object: ISCHICHTANTR ___ID: 0199

Description: status of the tomo drives, sent from stand to XCU
Sender     :   CCU-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

ANTRIEBSANZAHL Amount of drives
          Type:  Dcount     (CNT)
          Range: 0 ... 10
          Dimension: number of data blocks

{ANTRIEB drive: subunit which is able to perform a unit movement
{          Type:  Byte     (DEC)
{          Range: 0 ... 131
{                       FFA_STRAHLER                    0     SID tube
{                       ISOCENTER_HOEHE                 1     isocenter height
{                       TARGET_LAENGS                   2     target longitudinal
{                       TARGET_QUER                     3     target transveral
{                       TARGET_HEBEN_SENKEN             4     lift target
{                       TARGET_DREHEN                   5     rotate target
{                       SCHWENKWINKEL_SAEULE            6     angle of column
{                       TUBUSKRAFT                      7     force of tubus
{                       TISCHPLATTENDREHUNG             8     rotate table
{                       FFA_TARGET                      9     SID target
{                       TISCH_HOEHE                     10    table height
{                       TISCH_GERAET_KIPPEN             11    table tilt
{                       TISCH_LAENGS                    12    table longitudinal
{                       TISCH_QUER                      13    table transversal
{                       KIPPMULDE                       14    baby cradle
{                       SCHICHTHOEHE                    15    tomo height
{                       GERAET_HEBEN_SENKEN             16    lift gantry
{                       ACS_TUBE_ROT_HOR                17    rotate tube
{                       STRAHLER_LAENGS                 18    tube longitudinal
{                       STRAHLER_QUER                   19    tube transversal
{                       SPAETERE_ANWENDUNG              20    (reserved for future use)
{                       TUBUS_EIN_AUSFAHREN             21    move tubus (compression unit)
{                       C_BOGEN_ORBITAL                 22    c-arm orbital
{                       C_BOGEN_ANGULAR                 23    c-arm angular
{                       ISOCENTER_LAENGS                24    isocenter longitudinal
{                       FFA_BEWEGUNG                    25    SID movement
{                       ACS_SID_VALID_OR_INVALID        26    SID valid or invalid (in low
{                                                             cost systems there is no
{                                                             potentiometer to acquire the
{                                                             SID continuously, there are
{                                                             only two switches for upper
{                                                             and lower SID. If the tube is
{                                                             in between both positions, the
{                                                             collimators cannot be
{                                                             calculated because they
{                                                             require the exact SID
{                                                             position. In order not to
{                                                             expose more space than
{                                                             necessary, X-ray is blocked if
{                                                             SID is invalid.
{                                                             ANTRIEBSTATUS: 0=manual
{                                                             determined; 1=Valid; 2=Invalid
{                       ACS_CALIBRATION_SWITCH          27    Calibration switch in Ysio
{                                                             stand.
{                                                             PARAM: 0=No Information, 1=on,
{                                                             2=off
{                       ACS_SID_OR_SOD                  28    Not in use. Only a placeholder
{                                                             for the corresponding ANZCODE.
{                       ACS_ACSS_POSSIBLE_              29    For Ysio:
{                                                             XCU determines, if ACSS is
{                                                             active or not and sends
{                                                             information via SCU Interface
{                                                             to stand.
{                       ACS_SOD_H                       50    SOD value (in 0.1mm)
{                       ACS_AEC_CENTER_Y                56    offset between detector center
{                                                             and center of AEC chamber
{                       ISOCENTER_QUER                  59    isocenter lateral
{                       ACS_AUTO_MOVE_TARGET            66    see parameter
{                                                             sh_stpar_rfp.auto_move_target
{                       ACS_DET_TABLE_OUT               68    Detector or cassette in table
{                                                             is pulled out.
{                                                             Meaning of Physposition:
{                                                             0:        detector is in tray
{                                                             >0:      detector is pulled
{                                                             out
{                                                             ACS_INIL: detector is in
{                                                             intermediate position
{                       ACS_DET_WALL_OUT                69    Detector or cassette in wall
{                                                             stand is pulled out.
{                                                             Meaning of Physposition:
{                                                             0:        detector is in tray
{                                                             >0:      detector is pulled
{                                                             out
{                                                             ACS_INIL: detector is in
{                                                             intermediate position
{                       ACS_CENTRAL_BEAM_HITS           78    the x-ray beam does not or
{                                                             does only partially hit the
{                                                             detector, such that fluoro
{                                                             must be blocked
{                       ACS_DETECTOR_ORIENTATION        98    For Ysio: Orientation of
{                                                             detector relative to normal
{                                                             patient position.
{                                                             Physposition:
{                                                             1= Position 1, Pixel (0,0) in
{                                                             upper left corner (0°)
{                                                             2= Position 2, Pixel (0,0) in
{                                                             upper right corner (90°
{                                                             clockwise)
{                                                             3= Position 3, Pixel (0,0) in
{                                                             lower right corner (180°
{                                                             clockwise)
{                                                             4= Position 4, Pixel (0,0) in
{                                                             lower left corner (270°
{                                                             clockwise)
{                       ACS_BEAM_ANGLE_ALPHA            101   Beam angle alpha of tube for
{                                                             Ysio
{                       ACS_TUBE_ROT_VERTICAL           102   vertical rotation of tube for
{                                                             Ysio
{                       ACS_BEAM_POS_X                  103   deviation between center of
{                                                             beam towards center of target
{                                                             (FD, cassette, I.I.) in
{                                                             patient longitudinal direction
{                       ACS_BEAM_POS_Y                  104   deviation between center of
{                                                             beam towards center of target
{                                                             (FD, cassette, I.I.) in
{                                                             patient lateral direction
{                       ACS_DET_WALL_TILT               105   Tilting angle of detector in
{                                                             wallstand.
{                                                             Value in physposition in 0.1°
{                       ACS_POSITION_VALID_FOR_STORAGE  106   Information whether a stand
{                                                             position is valid to be stored
{                                                             in an organ program.
{                                                             Physposition: 0: no
{                                                             information, 1: position is
{                                                             valid, 2: position is not
{                                                             valid
{                       ACS_MOVING_BEAM                 107   Physposition: 0: Beam is
{                                                             stopped 1: Beam is moving
{                       ACS_MOVING_DETECTOR             108   Physposition: 0: Detector (or
{                                                             cassette tray) is stopped, 1:
{                                                             Detector (or cassette tray) is
{                                                             moving
{                       ACS_MOVING_TABLE                109   Physposition: 0: Table is
{                                                             stopped, 1: Table is moving
{                       ACS_AUTO_MOVEMENT               110   stand performs automatic
{                                                             movement:
{                                                             0 =
{                                                             ACS_AUTO_MOVEMENT_INACTIVE
{                                                             1 = ACS_AUTO_MOVEMENT_ACTIVE
{                                                             2 = ACS_AUTO_MOVEMENT_PENDING
{                       ACS_ORTHO_POS1                  111   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       ACS_ORTHO_POS2                  112   Param: ACS_ORTHOPOS_NOT_SET,
{                                                             ACS_ORTHOPOS_SET,
{                                                             ACS_ORTHOPOS_INVALID
{                       ACS_TDD                         113   Table Detector Distance in
{                                                             0.1mm
{                       ACS_ORTHO_STEP                  114   current step (or state) in the
{                                                             ortho flow::
{                                                             1 not in Ortho position (Move
{                                                             button has to be pressed)
{                                                             2 mark first ortho pos
{                                                             3 mark second ortho pos
{                                                             4 ready to move to first Image
{                                                             pos
{                                                             5 ready for apply X-ray
{                                                             6 X-ray is running
{                                                             7 X-ray is over and stand is
{                                                             moving to ortho start pos
{                                                             8 ortho is completed
{                                                             9 ortho is finished
{                                                             10 ortho is aborted
{                                                             11 ortho cannot be started
{                       ACS_SOFTSTOP                    115   activates or deactivates the
{                                                             SoftStop function
{                       ACS_PATIENT_TRANSFER            116   param: 1=on; 0=off
{                       ACS_TOMOADJUST                  117   system shall move to a
{                                                             position in which the tomo
{                                                             fulcrum height (Schichthöhe)
{                                                             can be adjusted using the
{                                                             laser line of the collimator
{                       ACS_MOVE_DISABLE                118   block any movement on users
{                                                             request
{                       ACS_BEAM_ANGLE__BETA            119   Beam angle beta of tube for
{                                                             Ysio
{                       ACS_FINAL_POSITION_REACHED      120   The OGP position is reached.
{                                                             This value is taken as a
{                                                             trigger to (re)send the OGP
{                                                             collimation values to the
{                                                             collimator
{                       ACS_STORE_POS                   121   store the current stand
{                                                             position
{                       ACS_RECALL_POS                  122   recall the previously stored
{                                                             stand position
{                       ACS_COLOR_ORBITAL               123   see A_COLOR_ORBITAL in ANZCODE
{                       ACS_COLOR_ANGULAR               124   see A_COLOR_ANGULAR in ANZCODE
{                       ACS_BYPASS_PARK_POS             125   (used in Luminos Fusion)
{                       ACS_CP_POSITION_MATCH           131   The (relative or absolute) CP
{                                                             position is more or less
{                                                             reached
{          Dimension: none

{ANTRIEBSRICHTUNG moving direction
{          Type:  Enum8     (DEC)
{          Range: 0 ... 2
{                       ACS_NO_INFORMATION  0
{                       POS_ENDSTELLUNG     1   positive limit
{                       NEG_ENDSTELLUNG     2   negative limit
{          Dimension: none


ISCHICHTSCHUSS

Object: ISCHICHTSCHUSS ___ID: 0198

Description: feedback when the tomo movement has reached the X-ray position in order to
              trigger the release of X-ray, sent from stand to XCU. In most FD-systems this
              signal is sent several 100 ms (configurable) in advance to assure detector
              will be ready when stand reaches the real tomo acq position. Delay for acq
              will be added to iSchichtSchuss by XCU until X-ray is released
Sender     :   CCU-IF   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs
This object has no parameters


ISERVBETRIEB

Object: ISERVBETRIEB ___ID: 0BD5

Description: tube load units for display (at ImgSys) for normal operation,
              as well as additional system power-on time for display in PMS
Sender     :   XCU
Receiver   :   FLC   PMS
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

EINSCHALTDAUER elapsed power on time of X-ray system since lifetime
          Type:  Integer32     (DEC)
          Range: 0 ... 10000000
          Dimension: hour

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

TUBECTR how many tubes are included in the system, count for the following parameters
          Type:  Count     (CNT)
          Range: 1 ... 2
          Dimension: number of data blocks

{TUBENR Tube number (1-4)
value 0 means: generator itsself
{          Type:  Byte     (DEC)
{          Range: 0 ... 4
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY6
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BELEINH load units of the tube, a load unit is a specific value for each specific tube, usually in single technique each spin up of the anode is counted as a BE (each exposure) and in series 1sec exposure time is also counted a 1 BE
{          Type:  Integer32     (DEC)
{          Range: 0 ... 9999999
{          Dimension: BE

{AUFNWAIT exposures made although waiting time has been displayed. Waiting time will be displayed for usual if the heating status of the tube reaches 65% of the max tube load. Then the user should not do any more exposure. If he does anyway this counter will be increased
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{AUFNOL tube overload, if the max heat capacity of the tube (100%) has been reached, this counter will be increased
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{BELEINH2 load units of the second focus spot of the tube
{          Type:  Integer32     (DEC)
{          Range: 0 ... 9999999
{          Dimension: BE


ISERVBETRIEBQUIT

Object: ISERVBETRIEBQUIT ___ID: 0BE1

Description: if the service PC requested to reset the tube data to 0 (if the tube has been
              replaced by a new one) this is the feedback of the XCU, sent from XCU to
              service PC
Sender     :   XCU
Receiver   :   PMS
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STATUSBETRIEB Feedback upon erasing tube data
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NOT_DELETED  0
                     DELETED      1
          Dimension: none


ISERVINIT

Object: ISERVINIT ___ID: 0BCA

Description: Send configuration data from XCU to service PC. Is requested by aServInit and
              should be answered by iServQuit. For usually XCU sends only this iServInit
              containing AP ID and Init Nr requested by aServInit. Exceptions are:
              Init Nr is 0: then all Init blocks of this AP ID will be sent
              Init Nr. and AP ID are 0: all init blocks will be sent
              Init block has sub indices and exists several times (init 240-65, 240-70,
              240-66, 240-71) in this case always all instances of this init block will be
              sent in a row.
Sender     :   XCU
Receiver   :   PMS
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

INITKENNUNG number of init block
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


ISERVJUSTCMD

Object: ISERVJUSTCMD ___ID: 0BCB

Description: service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              XCU to service PC. For usual the flow is: sServJustCmd from SPC --- sJustCmd
              from XCU to comp - iJustCmd from Comp to XCU --- iServJustCmd to SPC
Sender     :   PMS   XCU
Receiver   :   PMS   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


ISERVQUIT

Object: ISERVQUIT ___ID: 0BD2

Description: confirmation of receiving iservinit, sent from SPC to XCU
              Still used between XCU and PMS for watervalue adjustment
Sender     :   PMS   XCU
Receiver   :   PMS   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

INITKENNUNG number of init block
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

STORESTATUS Status of storage
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     STORE_NOTOK  0
                     STORE_OK     1
          Dimension: none


ISERVSTORE

Object: ISERVSTORE ___ID: 0BD3

Description: indicates, whether the service PC has stored the config and adjustment data
              sent from XCU successfully on a backup device, sent from service PC to XCU
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

DATASTATUS received data successfully received and stored or not
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     DATASTORED     1
                     DATANOTSTORED  2
          Dimension: none


ISERVTESTCMD

Object: ISERVTESTCMD ___ID: 0BCC

Description: Similar to iServJustCmd:
              service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              XCU to service PC. For usual the flow is: sTestJustCmd from SPC ---
              sServTestCmd from XCU to comp - iTestCmd from Comp to XCU --- iServTestCmd to
              SPC
Sender     :   XCU
Receiver   :   PMS
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


ISESTATUS

Object: ISESTATUS ___ID: 02C6

Description: Status of the X-ray generator, sent from generator to XCU. The "SE" is derived
              from German word Strahlungserzeuger = X-ray generator.
              To make the system work all Parameters should be set to "1"
Sender     :   GEN-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

SS safety relay, switch in generator to disable radiation for service purposes
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

TUERKON Room door status
Normal position is EIN (=ON). If AUS(=OFF) any X-ray will be blocked.
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DRUCKSCH Pressure switch of tube housing
Normal position is EIN (=ON). If AUS(=OFF) any X-ray will be blocked.
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISOD

Object: ISOD ___ID: 01B6

Description: Source Object Distance. This is the distance between Source (tube) and skin of
              the patient. For usual this distance cannot be automatically determined in the
              system. The user has to measure it by means of a tape in the collimator.. The
              value is needed for documentation purpose and for calculating width and length
              of X-rayed objects.
Sender     :   XCU
Receiver   :   PMS   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SOD Source Object Distance
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISPANZ

Object: ISPANZ ___ID: 0092

Description: display of serial exposure parameter and the status whether single or series
              acquisition is selected, Sent from XCU to displays
Sender     :   XCU
Receiver   :   FLC   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FRATE frame rate (in ST_CP_DATA the highset freq that the user can select during the running series)
          Type:  Integer16     (DEC)
          Range: 0 ... 600
          Dimension: 0.1fps

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

AUFNZEIT exposure time
          Type:  Integer16     (DEC)
          Range: 1 ... 10000
          Dimension: ms

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

SERIE Series / single mode
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     EINZELBILD  0   single frame
                     SERIE       1   series
          Dimension: none


ISPRITZE

Object: ISPRITZE ___ID: 019C

Description: injector status, sent from stand to XCU
Sender     :   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SPRITZENSTATUS Injector status
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     SPRITZE_SCHARF        1   injector armed
                     SPRITZE_NICHT_SCHARF  2   injector not armed
          Dimension: none

AUSLOESE injector injecting
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     SPRITZE_AUS_  0   injection off
                     SPRITZE_EIN   1   injection running
                     SPRITZE_AUS   2   injection off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISPRITZEMARKDFR

Object: ISPRITZEMARKDFR ___ID: 025B

Description: injection status for DFR, sent from XCU to DFR
Sender     :   XCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

AUSLOESE injector injecting
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     SPRITZE_AUS_  0   injection off
                     SPRITZE_EIN   1   injection running
                     SPRITZE_AUS   2   injection off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISTATABSCHALT

Object: ISTATABSCHALT ___ID: 02CB

Description: reason for terminating exposure, sent from generator to XCU at the end of an
              exposure.
              XCU determines from this telegram the "limit" display. If an exposure supposed
              to use a dose value, will deliver the reason "mAs" of "ms" then limit will be
              indicated. Or if an a exposure is terminated by ms although mAs is selected
              also limit is displayed. Limit is the acronym for the user that ans safety set
              has terminated the exposure and the acquisition may result underexposed.
Sender     :   GEN-IF   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ABSCHALTUNG The Generator will tell the reason for terminating the last exposure/series. Depending on selected technique limit displays will be derived.
          Type:  Enum8     (DEC)
          Range: 0 ... 13
                     IONTOMAT            0    ionotomat has reached desired dose
                     MAS_SCHALTER        1    mAs have reached desired max value of mAs
                     ZEITSCHALTER        2    exposure time has been reached or limit has
                                              been exceeded
                     SZENEZEITSCHALTER   3    scene time exceeded
                     TUERKONTAKT         4    door has been opened during exposure
                     FEHLER_ABSCHALTUNG  5    error during exposure
                     DRUCKSCHALTER       6    pressure switch of tube
                     HK_GEOEFFNET        7    user has disengaged X-ray switch before the
                                              required values, mAs or dose have been reached
                     MIN_DOSIS           8    supervision control for dose min has stopped
                                              acquistion
                     STOP_ABSCHALTUNG    9    exposure terminated for any other reason
                     HV_TRIGGER          10   x-ray pulse terminated because HV_trigger
                                              signal ended (end of FD's x-ray window
                                              reached)
                     LIH_TIMER           11   timeout 500ms after x-ray switch HW signal
                                              went off
                                              (exposure too early aborted by user or error)
                     TIMEOUT_HV_TRIGGER  12   HV_trigger signal timeout
                     UNEXPECTED_DCV      13   IDEXI or IBSIGNAL without HV trigger signal
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FRAME_INDEX Index enumerating the frames of fluoro or scene acquisition.
          Type:  Word     (DEC)
          Range: 1 ... 65000
          Dimension: none


ISTATUSGENAUFN

Object: ISTATUSGENAUFN ___ID: 02C9

Description: status of the generator for exposure, sent from generator to XCU. Only if all
              of the three Parameters (filament, rotor and ready for acq) are set to "1" an
              exposure can be released.
Sender     :   GEN-IF   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

HEIZGOK filament has reached final temperature
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

ANODEOK anode has reached the rotation speed
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

STRABEREIT Generator is overall ready to release exposure.
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISTATUSREPORT

Object: ISTATUSREPORT ___ID: 0BCE

Description: Download control telegram. The component sends its status to the XCU using
              iFEStatus and XCU transfers this telegram service PC using iStatusReport
Sender     :   XCU
Receiver   :   PMS
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

FESTATUS boot status of a component
          Type:  Byte     (DEC)
          Range: 1 ... 13
                     APPLIKATIONSVORBEREITUNG  10   application ready to run, XCU will now
                                                    send init data to the component
                     SERVICEMODE               11   component in service mode
                     BETRIEBSBEREIT            12   ready for normal operation
                     NICHT_FUNKTIONSFAEHIG     13   component is defective
                                                    (in order to recover component needs to
                                                    send a TURN_ON plus a iFEStatus 12 to
                                                    get back)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISTELLUNG

Object: ISTELLUNG ___ID: 0197

Description: gantry/stand tells the status of reaching a position sent from stand/gantry to
              XCU. Is only used for tomo control . XCS sends sStellung to the stand using
              parameter FESTPOSTION and stand answers with iStellung as soon as targeted
              position has been reached.
Sender     :   CCU-IF   RAD-STD   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FESTPOSITION ID of the position
          Type:  Byte     (DEC)
          Range: 1 ... 50
                     PAT_UEBERNAHME   1    patient load
                     UMBAU_1          2
                     UMBAU_2          3
                     UMBAU_3          4
                     UMBAU_4          5
                     UMBAU_5          6
                     SCHICHTAUSGANG   7    tomo: middle position before pressing the button
                                           to start tomo
                     SCHICHTSTART     8    stand has reached outer border and waits for next
                                           telegram to start the tomo shape
                     SCHICHTSTOP      9    end of tomo (stand has reached after tomo shape
                                           the other outer border
                     SCHICHTABBRUCH   10
                     SCHICHTHOEHMESS  11   Move to a lateral position in which the fulcrum
                                           (Schichthöhe) can be shown using the laser line
                                           of the collimator
                     SCHRITTPOS_0     20   step 0
                     SCHRITTPOS_1     21
                     SCHRITTPOS_2     22
                     SCHRITTPOS_3     23
                     SCHRITTPOS_4     24
                     SCHRITTPOS_5     25
                     SCHRITTPOS_6     26
                     SCHRITTPOS_7     27
                     SCHRITTPOS_8     28
                     SCHRITTPOS_9     29
                     SCHRITTPOS_10    30
                     FESTPOSITION_0   40   fixed position 0
                     FESTPOSITION_1   41
                     FESTPOSITION_2   42
                     FESTPOSITION_3   43
                     FESTPOSITION_4   44
                     FESTPOSITION_5   45
                     FESTPOSITION_6   46
                     FESTPOSITION_7   47
                     FESTPOSITION_8   48
                     FESTPOSITION_9   49
                     FESTPOSITION_10  50
          Dimension: none

ANTRIEBSTATUS status of the drive
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_NO_INFORMATION      0
                     STOP_MIT_ZIELPOSITION   1   target reached and stopped
                     IN_FAHRT                2   moving
                     BLOCKIERT               3   blocked
                     STOP_OHNE_ZIELPOSITION  4   stopped but target position not reached
                     ANSTRG_NICHT_MOEGLICH   5   drive defective
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISTEPANZ

Object: ISTEPANZ ___ID: 008B

Description: display of Peri parameter, sent from XCU to displays
Sender     :   XCU
Receiver   :   FLC   RAD-STD   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

AKTSTEP current peri position
          Type:  Byte     (DEC)
          Range: 0 ... 8
                     STARTPOS   0
                     SCHRITT_1  1
                     SCHRITT_2  2
                     SCHRITT_3  3
                     SCHRITT_4  4
                     SCHRITT_5  5
                     SCHRITT_6  6
                     SCHRITT_7  7
                     SCHRITT_8  8
          Dimension: none

STEPSK How many steps are possible toward head of patient.
          Type:  Byte     (DEC)
          Range: 0 ... 8
          Dimension: none

STEPSF How many steps are possible toward feet of patient.
          Type:  Byte     (DEC)
          Range: 0 ... 8
          Dimension: none

PERIPROG is a peri program run active
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none


ISTRAHLERWAHL

Object: ISTRAHLERWAHL ___ID: 02C1

Description: feedback about selected tube, sent from generator to XCU. Is necessary for
              safety reasons in system with more than one tube. Depending on the feedback to
              sStrahlerwahl the XCU will allow an exposure is tube in sStrahlerwahl an
              iStrahlerwahl will match or it will prevent an exposure if they don't and will
              display an error. The telegram sStrahlerwahl will be send on sBedSys/sOrgDaten
              - iSystemAnz.
Sender     :   GEN-IF   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STRAHLER Number of active tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISTRAHLGAUFN

Object: ISTRAHLGAUFN ___ID: 02CA

Description: X-ray for acquisition is on, sent from generator to XCU. This telegram is only
              generated if the generator is doing radiation. In particular for FD systems:
              Only if generator has received sAufnAusl(1,1,1) AND the HW-Trigger is set to
              on the X-ray will be turned on and this telegram has to be sent. If this
              telegram is not be sent with parameter=1 although generator has received
              sAufnAusl(1,1,1), the following reasons may apply- no trigger, no HW 20 mA
              safety circuit closed, X-ray disabled by SS switch on generator.
Sender     :   GEN-IF   UGEN
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STRAHLUNG X-ray active
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

TRIGGER_REASON generators response,  in which way the x-ray was triggered
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION    0
                     ACS_TRIG_REAS_HVTRIG  1   x-ray was triggered by HV_Trigger signal (HW)
                     ACS_TRIG_REAS_HK      2   x-ray was triggered by HK signal (SW)
                                               (wait for HV_Trig has been disabled)
                     ACS_TRIG_REAS_VK      3   x-ray signal was triggered by VK signal (SW)
                                               (safety switch has been active)
          Dimension: none

USE_HV_TRIGGER what GEN-IF told generator to do with the HV_Trigger-signal
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


ISTRAHLGDL

Object: ISTRAHLGDL ___ID: 02CC

Description: X-ray for fluoro is on, sent from generator to XCU. (Similar to iStrahlgAufn
              only for fluoro) This telegram is only generated if the generator is doing
              radiation. In particular for pulsed fluoroscopy: Only if generator has
              received sDLAusl(1) AND the HW-Trigger is set to on the X-ray will be turned
              on and this telegram has to be sent. If this telegram is not be sent with
              parameter=1 although generator has received sDLAusl(1), the following reasons
              may apply- no trigger, no HW 20 mA safety circuit closed, X-ray disabled by SS
              switch on generator.
Sender     :   GEN-IF   UGEN
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STRAHLUNG X-ray active
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


ISTRMANANZ

Object: ISTRMANANZ ___ID: 0081

Description: display of collimator parameter, sent from XCU to displays
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

FILTER CU filter number, the Filter number is in most cases identical with the filter thickness in 0.1 mm, so 1 means 0.1 mm
          Type:  Byte     (DEC)
          Range: 0 ... 10
          Dimension: none

RASTER Grid number according to configuration
          Type:  Byte     (DEC)
          Range: 0 ... 7
                     ACS_NO_GRID_SELECTED  0   no grid selected
          Dimension: none

SCHRIFT used lead letter (not used, because no supporting X-ray collimators)
          Type:  Byte     (DEC)
          Range: 0 ... 10
          Dimension: none

FAUTO format automatic
          Type:  Byte     (DEC)
          Range: 1 ... 7
                     FREIE_EINBLENDUNG       1   free collimator positioning
                     VOLLAUTOMATIK           2   full auto; collimator will switch to
                                                 cassette/FD detector size with start of
                                                 acquisition
                     HALBAUTOMATIK           3   half auto
                     VOLLAUTO_HOEHENBLENDE   4   full auto height, same as full auto, but
                                                 only for height collimator
                     VOLLAUTO_BREITENBLENDE  5   full auto width, same as full auto, but
                                                 only for width collimator
                     BUCKYBETRIEB            6   bucky mode (collimators are set to cassette
                                                 size on cassette loading)
                     DFRBETRIEB              7   DFR mode, not auto is applied
          Dimension: none

FKONTR format check, collimator will show the current format of the inserted cassette
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

FILTERAUTO automatic copper filter, this applies only for fluoro mode or 0-pnt-technique and DFR exposures
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISUCHLAUF

Object: ISUCHLAUF ___ID: 032F

Description: searchrun feedback, (collimators may loose steps while normal operation,
              therefore they do a search run after some time to sync. However search runs do
              not allow X-ray, so X-ray will be blocked if the search run is active) sent
              from collimator to XCU. There are two ways of search run processes. A)
              Collimator is doing it by its own and sending aSuchLauf and XCU grants it by
              sSuchlauf if the system is ready for a search run. And collimator indicates
              end by iSuchlauf (dRF solution). OR B) the XCU tells the collimator to do a
              search run (YSIO)
Sender     :   CCU-IF   RAD-STD   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SLSTATUS Search run status
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     SL_AKTIV    1   search run active
                     SL_BEENDET  2   search run finished
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ISYSTEMANZ

Object: ISYSTEMANZ ___ID: 008C

Description: system selection status, sent from XCU to all components
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   SCU-IF   TUI-IF   UGEN   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEMNR Number of the system.
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

STRAHLER Number of active tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
          Dimension: none

SYSOK System is ready
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

EXP_TARGET exposure target (called "acquisition type" in UIS)
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     EXPT_TABLE         0
                     EXPT_BWS           1   bucky wall stand
                     EXPT_FREE          2   free exposure to portable detector (or cassette)
                     EXPT_TABLE_PULLED  3   exposure to detector in pulled-out table tray
                     EXPT_FREE_SMALL    4   free exposure to small portable detector
                                            (used in ST_ORGAN_PROG only)
          Dimension: none


ITESTCMD

Object: ITESTCMD ___ID: 0017

Description: service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              component to XCU
Sender     :   RAD-STD
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


ITISCHPOS

Object: ITISCHPOS ___ID: 025E

Description: current position of moving table in peri, sent from XCU to displays
              Not used in surgery systems.
Sender     :   XCU
Receiver   :   FLC   GEN-IF   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

BEWEGUNG stand is moving
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

TISCHPOS Current position of the table
          Type:  Enum8     (DEC)
          Range: 1 ... 10
                     GRUNDPOSITION  1
                     POSITION_2     2
                     POSITION_3     3
                     POSITION_4     4
                     POSITION_5     5
                     POSITION_6     6
                     POSITION_7     7
                     POSITION_8     8
                     POSITION_9     9
                     POSITION_10    10
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ITOMOANZ

Object: ITOMOANZ ___ID: 0085

Description: current tomo setting, sent from XCU to displays
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

TOMOZEIT tomo time, how long will X-ray be turned on during the tomo exposure
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: msec

TOMOHOEHE tomo height, there is only one plane that will be focused while a tomo run, this parameter tells the height of the focused plane relative to the table
          Type:  Integer16     (DEC)
          Range: 0 ... 5000
          Dimension: 0.1 mm

TOMOWINKEL tomo angle, how many degrees will the stand move, while X-ray is turned on during the tomo exposure
          Type:  Byte     (DEC)
          Range: 0 ... 180
          Dimension: Grad

TOMOAUTO Automated tomo run
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

TOMOSTEP step width for automated tomo run (not in use)
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 0.1 mm

TOMOUPDOWN step direction for automated tomo run (not in use)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     DOWN  0
                     UP    1
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IUGENLOG

Object: IUGENLOG ___ID: 03CA

Description: This telegram contains detailed data, that is meant for logging and data
              analysis
Sender     :   UGEN
Receiver   :   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro and show

List of Parameters:

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

FRA_SCENE number of frames (pulses) within the whole scene
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     ACS_UNLIMITED  0   e.g. for fluoro, only used in ST_objects
          Dimension: none

STRAHLER Number of active tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
          Dimension: none

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

VERSION_IUGENLOG version of the object iUGENLOG
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: none

IUGEN_MOD mode type
          Type:  Byte     (DEC)
          Range: 0 ... 16
          Dimension: none

IUGEN_ROT rot time
          Type:  Byte     (DEC)
          Range: 0 ... 0
          Dimension: sec

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IUGEN_SCN scan number
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: none

TIME seconds since January 1st 1970; ACS_LNIL if the time is not available
note that this is in local time since this is the "logging time" (and many subsystems do only have this time)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: sec

IUGEN_SCTIM_NOM nominal scan time
          Type:  Word     (DEC)
          Range: 0 ... 10000
          Dimension: ms

IUGEN_SCTIM_ACT actual scan time
          Type:  Word     (DEC)
          Range: 0 ... 10000
          Dimension: ms

IUGEN_UTNOM nominal Ut
          Type:  Integer32     (DEC)
          Range: 0 ... 150000
          Dimension: Volt

IUGEN_UTACT actual Ut
          Type:  Integer32     (DEC)
          Range: 0 ... 150000
          Dimension: Volt

IUGEN_ITUI It UI
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_ITNOM nominal It
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_ITMIN minimal It
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_ITMAX maximum It
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_ITCBG ControlBeg It
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_ITBEG begin It
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_ITMEA mean It
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_ITEND end It
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_FOC Actual Focus number RAD3
          Type:  Enum8     (DEC)
          Range: 0 ... 4
          Dimension: none

IUGEN_FQS Stator Frequency
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_FQA Anode frequency
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IUGEN_IFNOM nominal If
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_IFBEG begin If
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_IFCBG ControlBeg If
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_IFEND end If
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_IFPUS push If
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: mA

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IUGEN_DOSENO nominal dose
          Type:  Dword     (DEC)
          Range: 0 ... 800000
          Dimension: Weihnachtsmaenner

IUGEN_DOSMN minimal dose
          Type:  Dword     (DEC)
          Range: 0 ... 800000
          Dimension: Weihnachtsmaenner

IUGEN_DOSMX maximum dose
          Type:  Dword     (DEC)
          Range: 0 ... 800000
          Dimension: Weihnachtsmaenner

IUGEN_DOSEND end dose
          Type:  Dword     (DEC)
          Range: 0 ... 16781464
          Dimension: Weihnachtsmaenner

IUGEN_TINBG Temperature Cooling In Begin
          Type:  Integer32     (DEC)
          Range: -27300 ... 100000
          Dimension: 0.01°C

IUGEN_TINEN Temperature Cooling In End
          Type:  Integer32     (DEC)
          Range: -27300 ... 100000
          Dimension: 0.01°C

IUGEN_TOUBG Temperature Cooling Out Beg
          Type:  Integer32     (DEC)
          Range: -27300 ... 100000
          Dimension: 0.01°C

IUGEN_TOUEN Temperature Cooling Out End
          Type:  Integer32     (DEC)
          Range: -27300 ... 100000
          Dimension: 0.01°C

IUGEN_TGANT Temperature Gantry
          Type:  Integer32     (DEC)
          Range: -27300 ... 100000
          Dimension: 0.01°C

IUGEN_STCUA RAC Stator current acceleration mA
          Type:  Word     (DEC)
          Range: 0 ... 40000
          Dimension: mA

IUGEN_STCUE RAC Stator current End mA
          Type:  Word     (DEC)
          Range: 0 ... 40000
          Dimension: mA

IUGEN_ARS Arcing sum
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: Blitzteufel

IUGEN_ARP Arcing pos
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: Blitzteufel

IUGEN_ARN Arcing neg
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: Blitzteufel

IUGEN_HVD Number of HV drops
          Type:  Word     (DEC)
          Range: 0 ... 40000
          Dimension: number

IUGEN_XCD Number of XC drops
          Type:  Word     (DEC)
          Range: 0 ... 40000
          Dimension: number

IUGEN_ANG Start Angle
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_RDG Readings Norm
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_RGD Number of defect readings
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_LDR Last defect reading
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_REG Region
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_DOM DOM
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_SM Scan Mode
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_CR Cancel reason
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_ABO Abort controller
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

IUGEN_ECO ECO
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: Gummipunkte

IUGEN_TIM Time diff to UTC
          Type:  Integer32     (HEX)
          Range: -0x7FFFFFFF ... 0x7FFFFFFF
          Dimension: ms

IUGEN_XSR XTA serial number
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: number

IUGEN_SSR System serial number
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: number

IUGEN_MAS
          Type:  Integer32     (DEC)
          Range: 0 ... 100000
          Dimension: 0.01 mAs

IUGEN_TETY test type
          Type:  Byte     (HEX)
          Range: 0x0 ... 0x69
          Dimension: unknown

IUGEN_TR1 Test result 1
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: unknown

IUGEN_TR2 Test result 2
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: unknown

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IUGEN_UDC_A UDC Beg V
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: keine Ahnung

IUGEN_UDC_E UDC End V
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: keine Ahnung

IUGEN_FQB Start Anode frequency
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IUGEN_SCSESU Sum of Scan seconds
          Type:  Integer16     (DEC)
          Range: 0 ... 10000
          Dimension: ms

IUGEN_ENERGSU Sum of energy (in Watt*seconds)
          Type:  Integer32     (DEC)
          Range: 0 ... 100000
          Dimension: Ws

IUGEN_MASNO Nom mAs
          Type:  Integer32     (DEC)
          Range: 0 ... 100000
          Dimension: 0.01 mAs

IUGEN_MAPROZ mA measurement amplifier factor
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

IUGEN_VPROZ amplifier factor V
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

IUGEN_INVFQ Inverter resonant circuit frequency
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: unknown

IUGEN_THVT Temp HVT
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_TMRC1 Temp MRC1
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_TMRC2 Temp MRC2
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_TIND1 Temp RCE IND1
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_TIND2 Temp RCE IND2
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_I1IND Temp INV1 IND
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_I1HS1 Temp INV1 HS1
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_I1HS2 Temp INV1 HS2
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_I2IND Temp INV2 IND
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_I2HS1 Temp INV2 HS1
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_I2HS2 Temp INV2 HS2
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_TFIL Temp FIL (RFM)
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_TRAC Temp RAC (RFM)
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_TGCB Temp GCB
          Type:  Integer16     (DEC)
          Range: -27300 ... 11000
          Dimension: 0.01°C

IUGEN_PREHEAT Preheat current in mA
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_STATIC_ADD Additive component of static filament adjust result in mA
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_STATIC_MUL Multiplicative component of static filament adjust result unit:none
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: unknown

IUGEN_STATIC_PUSH_ADD Additive component of static push current in mA
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_STATIC_PUSH_MUL Multiplicative component of static push current unit:none
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: unknown

IUGEN_DYNA_ADD Additive component of dynamic filament adjust result in mA
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_DYNA_MUL Multiplicative component of dynamic filament adjust result unit:none
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: unknown

IUGEN_DYNA_PUSH_ADD Additive component of dynamic push current in mA
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mA

IUGEN_DYNA_PUSH_MUL Multiplicative component of dynamic push current unit:none
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: unknown

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY8
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IVCUBEDANZ

Object: IVCUBEDANZ ___ID: 00CB

Description: video manager status
              distributed by XCU
Sender     :   XCU
Receiver   :   SCU   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

FKTSCODEVCU function code for VideoManager control
          Type:  Enum16     (DEC)
          Range: 650 ... 680
                     STORE_VIDEO_ENDO_IMAGE  650   this command instructs VideoManager to
                                                   store the image being currently shown
                                                   (i.e. to send it via DICOM to Image
                                                   System)
                     SWITCH_NEXT_INPUT       651   this command instructs VideoManager to
                                                   switch to next input channel
                     SCAN_INPUT_SIGNALS      652   used to instruct VideoManager to scan for
                                                   and adapt to signals on all input
                                                   channels (1=start, 0=abort)
                                                   also used to show status of scanning
                                                   (1=busy, 0=ready)
                     SHOW_PIP                653   show picture in picture
                     SELECT_INPUT            654   select a specific input (number given in
                                                   PARAM)
                                                   range is 0-13
                     SWITCH_KVM              680   switch KVM between FLC and ApplHostPC
                                                   (used in surgery)
                                                   0=FLC; 1=ApplicationHosting PC;
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none


IVCUNAHBED

Object: IVCUNAHBED ___ID: 00CA

Description: video manager status
              sent from VCU to XCU
Sender     :   VCU
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

FKTSCODEVCU function code for VideoManager control
          Type:  Enum16     (DEC)
          Range: 650 ... 680
                     STORE_VIDEO_ENDO_IMAGE  650   this command instructs VideoManager to
                                                   store the image being currently shown
                                                   (i.e. to send it via DICOM to Image
                                                   System)
                     SWITCH_NEXT_INPUT       651   this command instructs VideoManager to
                                                   switch to next input channel
                     SCAN_INPUT_SIGNALS      652   used to instruct VideoManager to scan for
                                                   and adapt to signals on all input
                                                   channels (1=start, 0=abort)
                                                   also used to show status of scanning
                                                   (1=busy, 0=ready)
                     SHOW_PIP                653   show picture in picture
                     SELECT_INPUT            654   select a specific input (number given in
                                                   PARAM)
                                                   range is 0-13
                     SWITCH_KVM              680   switch KVM between FLC and ApplHostPC
                                                   (used in surgery)
                                                   0=FLC; 1=ApplicationHosting PC;
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none


IWATERVALACQ

Object: IWATERVALACQ ___ID: 02DE

Description: This telegram contains all values related to one radiation event (fluroro, acq
              series or single shot)
              All parameters are filled out in the final telegram beeing sent some time
              after the acquisition/fluoro finished.
              During series acquisition (not fluoro) this telegram is also sent per x-ray
              pulse / per frame (not all parameters filled).
              Note that parameter MAIST is filled with the mean value in final telegram.
Sender     :   XCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none

WW Water equivalent value calculated out fluoro data. This value has an offset of 80 quarter EP, so that 20 cm WEV is shown in this telegram as 160
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.25 BP

WWIST Water equivalent value calculated out acquisition data. This value has an offset of 80 quarter EP, so that 20 cm WEV is shown in this telegram as 160.
Not supported in current versions!
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.25 BP

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAIST current of actual fluoro pulse
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: 0.1 mA

FRA_SCENE number of frames (pulses) within the whole scene
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     ACS_UNLIMITED  0   e.g. for fluoro, only used in ST_objects
          Dimension: none

MASIST mAs value of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 100500
          Dimension: 0.01 mAs

MSIST duration of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

REGSTOP stop dose regulation in generator and keep kV and mAs values for all subsequent pulses
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

FLUORO_EXPOSURE determines, if the following status value is valid for fluoro or exposure
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_FLUORO    1
                     ACS_EXPOSURE  2
          Dimension: none

GEWMESSF logical number of chosen measuring field
bits 0-2 define the field selection
bits 3-4 define a rotation (for 5-field chamber)
bit 7 defines histogram based dexi calculation
          Type:  Byte     (DEC)
          Range: 0 ... 128
                     KEINE_ANGABE_RUND        0     circular measuring field
                     LINKS                    1     left
                     MITTE                    2     center
                     LINKS_MITTE              3     left and center
                     RECHTS                   4     right
                     LINKS_RECHTS             5     left and right
                     MITTE_RECHTS             6     center and right
                     LINKS_MITTE_RECHTS       7     left, center, and right
                     ACS_AEC_ROT_90DEG        8     for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees in clockwise direction
                     ACS_AEC_ROT_180DEG       16    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    plus 180 degrees
                     ACS_AEC_ROT_MINUS_90DEG  24    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees counterclockwise (or 270
                                                    degrees clockwise)
                     ACS_AEC_HISTO            128   take histogram based DEXI value instead
                                                    of fixed measuring field
          Dimension: none

EXPOSURE_TIME length of the x-ray pulse (or pulses resp.)
For pulsed fluoro/acq this is the sum of all ms values per radiation event (scene).
For single shot this equals MSIST.
          Type:  Dword     (DEC)
          Range: 0 ... 1000000000
          Dimension: ms

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

DOSISIST actual dose of last pulse / acquisition
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 1 nGy/pulse

DOSEREDUC Dose when kV is exceeded because of dose reduction
          Type:  Word     (DEC)
          Range: 0 ... 60000
          Dimension: 1 nGy/pulse

PULSE amount of pulses combined in this telegram (this is used if frame rate is too high to send a separate telegram for each pulse)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SKINFA Distance between Tube (Focus) and Skin of patient for calculation of Air Kerma and Air Kerma Rate from DAP
          Type:  Byte     (DEC)
          Range: 1 ... 255
          Dimension: cm

DFP dose area product of actual acquisition / acq series / fluoro event
(fnote: formerly the dimension was defined by the parameter DFPNACHKOMMA)
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

SKDOSE reference air kerma (accumulated)
          Type:  Integer32     (DEC)
          Range: 0 ... 10000000
          Dimension: 0.01 mGy

FILTER_ACQ number of acquisition filter; 0: no filter
          Type:  Byte     (DEC)
          Range: 0 ... 10
                     NO_FILTER  0
                     FILTER_1   1
                     FILTER_2   2
                     FILTER_3   3
                     FILTER_4   4
                     FILTER_5   5
                     FILTER_6   6
                     FILTER_7   7
                     FILTER_8   8
                     FILTER_9   9
                     FILTER_10  10
          Dimension: none

RASTER Grid number according to configuration
          Type:  Byte     (DEC)
          Range: 0 ... 7
                     ACS_NO_GRID_SELECTED  0   no grid selected
          Dimension: none

FFA current SID
          Type:  Integer16     (DEC)
          Range: 1 ... 32767
          Dimension: mm

GRID_FOCUS focus of the grid
          Type:  Integer16     (DEC)
          Range: -2 ... 10000
                     ACS_GRID_5          1000
                     ACS_GRID_1          1150
                     ACS_GRID_UNIVERSAL  1400
                     ACS_GRID_2          1500
                     ACS_GRID_3          1800
                     ACS_GRID_4          3000
          Dimension: mm

SID_VALID determination of SID
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_MANUAL_DET  0   user/manual determined
                     ACS_SID_SYSTEM_DET  1   determined by the system
                     ACS_SID_NOT_DEF     2   the system can not define the SID
          Dimension: none

DICOM_TAG indicator into which DICOM tag the skin dose needs to be reported
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION  0
                     ACS_DICOM_113860    1   skin dose for 3D
                     ACS_DICOM_113861    2   skin dose for BWS or Free Exposure (SID only)
                     ACS_DICOM_113862    3   skin dose for UnderTable (Agile UT)
                     ACS_DICOM_113863    4   skin dose for OverTable (dRF,Agile OT, Ysio
                                             Table)
                     ACS_DICOM_113864    5   skin dose for lateral 15cm from Table
                                             Centerline
                     ACS_DICOM_113964    6   skin dose for Free Exposure (SOD+SID measured)
          Dimension: none

STIME Total acquisition time: measured duration of the x-ray series (fluoro or acquisition)
For single shots STIME equals MSIST, but rounded to 100ms. Thus typically (i.e. for pulse time <50ms) the value will be 0 in this case.
          Type:  Word     (DEC)
          Range: 0 ... 10000
          Dimension: 0.1sec

ABSCHGRUND reason why an Exposure has been terminated
          Type:  Enum8     (DEC)
          Range: 0 ... 24
                     ACS_NO_INFORMATION     0
                     MAX_SZENENLAENGE       1    max scene length reached
                     KEINE_KAPAZITAET       2    out of RAM/Disk space
                     IONTOMAT_OFF           3
                     MAS_SWITCH             4
                     TIME_SWITCH            5
                     DOOR_CONTACT           6
                     ERROR_SWITCHOFF        7
                     PRESSURE_SWITCH        8
                     MAIN_CONTACT_OPEN      9
                     MIN_DOSE               10
                     GENERAL                11
                     CIRCUIT_OPEN           12   safety circuit opened at least at one point
                     GRID_MOVEMENT          13   Grid movement during acquisition
                     FILTER_MOVEMENT        14   Movement of filter during acquisition
                     COLLIMATOR_MOVEMENT    15   Movement of collimator during acquisition
                     STAND_SHUTDOWN         16   Stand sent shutdown (iBetriebsart)
                     COLLIMATOR_SEARCH_RUN  17
                     RLR_OVERHEAT           18   Overheat of tube load calculator
                     CASSETTE               19   Position of Cassette (iKassPos)
                     DFR                    20   Status of DFR (iDFRStatus)
                     ASU_STATUS             21   Status of ASU (iASUStatus)
                     FD_STATUS              22   Status of FD detector (iDetektorStatus)
                     TURNOFF_EVENT          23   Received an event which turns off
                                                 acquisition (iBedPowerReq or power fail
                                                 interrupt)
                     FFA_INTERMEDIATE       24   FFA in an intermediate position
          Dimension: none

BUMKEHR image flip and rotation
          Type:  Byte     (DEC)
          Range: 0 ... 96
                     KEINE_ANGABE_NORMAL   0    no image flip
                     UMKEHR_HORIZONTAL     1    horizontal image flip
                     UMKEHR_VERTIKAL       2    vertical image flip
                     UMKEHR_VERT_HORIZ     3    horizontal and vertical image flip
                     ACS_BILD_DREHUNG_90   32   image rotated by 90° clockwise
                     ACS_BILD_DREHUNG_180  64   image rotated by 180°
                     ACS_BILD_DREHUNG_270  96   image rotated by 270° clockwise
          Dimension: none

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DLKENNL Fluoro curve. Fluoro curve is defined in a set in the organ program and the number of the curve is sent to the generator.
          Type:  Byte     (DEC)
          Range: 1 ... 100
          Dimension: none

UEBERNAHME_KENNL Transfer curve
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: Nr

DOSE_FOR_PRINT Dose for telegrams iPrintAufn and iPrintDL.
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: 1 µGy

EXPOSED_AREA used in surgery only:
exposed area on FD (taking into account all collimators) in square millimeters
sent from COCA to XCU for skin dose calculation
          Type:  Dword     (DEC)
          Range: 0 ... 100000
          Dimension: mm**2

VK_ON_DURATION time period in which VK was active (i.e. tube filament was heated)
          Type:  Integer32     (DEC)
          Range: 0 ... 260000
          Dimension: ms

SKINFOCUSDIST Skin-Source-Distance (like SKINFA but larger range)
          Type:  Word     (DEC)
          Range: 0 ... 1000
          Dimension: cm

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BELEINH load units of the tube, a load unit is a specific value for each specific tube, usually in single technique each spin up of the anode is counted as a BE (each exposure) and in series 1sec exposure time is also counted a 1 BE
          Type:  Integer32     (DEC)
          Range: 0 ... 9999999
          Dimension: BE

AUFNWAIT exposures made although waiting time has been displayed. Waiting time will be displayed for usual if the heating status of the tube reaches 65% of the max tube load. Then the user should not do any more exposure. If he does anyway this counter will be increased
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

AUFNOL tube overload, if the max heat capacity of the tube (100%) has been reached, this counter will be increased
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

STRAHLER Number of active tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
          Dimension: none

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

HU heat unit, given as a relative value to maximum value of heat units the tube can stand
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BLENDENPOSITION position of the collimator: width for type 1-3 and 8-12, position relative to a zero pos in case of other types (4-6)
A value 0xFFFF means, that collimator shall drive to full open for current zoom level
{          Type:  Word     (DEC)
{          Range: 0 ... 65533
{          Dimension: 0.1 mm

{BLENDENWINKEL angle of the collimator, usually only used for collimators 4 to 16, because 1 to 3 cannot be rotated
{          Type:  Integer16     (DEC)
{          Range: 0 ... 3600
{          Dimension: 0.1 degree

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY6
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


IXCU_INFO_STATUS

Object: IXCU_INFO_STATUS ___ID: 0032

Description: Information on XCU status
Sender     :   XCU
Receiver   :   ACSOS   UAL
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

MAN_ACQ_OVERRIDE bitcoding of all parameters where an override of acq programs is possible: 0 = no override; 1 = with override
          Type:  Dword     (HEX)
          Range: 0x0 ... 0xFFFFFFFF
                     ACA_OV_ACQ_SYSTEM              0x00000001
                     ACS_OV_ACQ_TECHNIK             0x00000002
                     ACS_OV_ACQ_KV                  0x00000004
                     ACS_OV_ACQ_MAS                 0x00000008
                     ACS_OV_ACQ_MS                  0x00000010
                     ACS_OV_ACQ_DOSIS               0x00000020
                     ACS_OV_ACQ_KVDR                0x00000040
                     ACS_OV_ACQ_SCHWAERZKORR        0x00000080
                     ACS_OV_ACQ_SZEIT               0x00000100
                     ACS_OV_ACQ_KENNL               0x00000200
                     ACS_OV_ACQ_FOKUS               0x00000400
                     ACS_OV_ACQ_PROZ                0x00000800
                     ACS_OV_ACQ_REGSTOP             0x00001000
                     ACS_OV_ACQ_FILTERAUFN          0x00002000
                     ACS_OV_ACQ_RASTER              0x00004000
                     ACS_OV_ACQ_TOMOPROG            0x00008000
                     ACS_OV_ACQ_BUMKEHR             0x00010000
                     ACS_OV_ACQ_CALIBRATION_OGP     0x00020000
                     ACS_OV_ACQ_COLL_HEIGHT         0x00040000
                     ACS_OV_ACQ_AUTOZOOM            0x00080000
                     ACS_OV_ACQ_COLL_WIDTH          0x00100000
                     ACS_OV_ACQ_DUMMY               0x00200000
                     ACS_OV_ACQ_COLL_IRIS_DIAMETER  0x00400000
                     ACS_OV_ACQ_COLL_FINGER_POS     0x00800000
                     ACS_OV_ACQ_COLL_FINGER_ANGLE   0x01000000
                     ACS_OV_ACQ_COLL_WEDGE1_POS     0x02000000
                     ACS_OV_ACQ_COLL_WEDGE1_ANGLE   0x04000000
                     ACS_OV_ACQ_COLL_WEDGE2_POS     0x08000000
                     ACS_OV_ACQ_COLL_WEDGE2_ANGLE   0x10000000
                     ACS_OV_ACQ_BFREQ               0x20000000
                     ACS_OV_ACQ_GEWMESSF            0x40000000
                     ACS_OV_ACQ_XRPT                0x80000000
          Dimension: none

SYSTEM ID of selected System:
in surgery: 1=normal  2=cassette
in TRUMF:
No: dRF:          Ysio:            dTF:               Lum RF:       G1:
 1 Lum DFR       Table FD         Agile DFR          RF DFR        DFR Table
 2 Lum Tomo      Wall FD          Free Cass Tub1     RF Cass       DFR Wall
 3 Lum Ortho     Tomo FD          Free FD Tube 1     RF Wall       Ortho Table
 4 Free exp      Ortho (wall)     3D Wall FD         RF Free exp   Ortho Wall
 5 Wall FD       Free Cass        3D Wall Cass       RF Tomo DFR   Bed
 6 Wall Cass     Wall Cass        3D Free FD Tub2    RF Tomo Cass  Free MobFD
 7 3D Wall FD    Free Mobile FD   3D Free Cass Tub2      -         Mode3D
 8 3D Mobile FD  Table FD pulled  3D Ortho               -         SkelMal
 9 3D Wall Cass  Wall FD flipped  Table FD Tube 2        -         Ortho lat
10 3D Free Cass  Table Cass       Table Cass Tube2       -           -
11 3D Ortho      Ortho Table      Table FD pulled Tub2   -           -
12 Free MobFD Tub1   -            3D Table Ortho         -           -
note: Uroskop has just system no1 = Uro DFR
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

KVDR kV for dose reduction. If the patient thickness is too high for tube power, kV will automatically increase, because X-ray will retrieve more energy out of kV than out of mAs. To increase kV means to reduce heat power consumption. If the kV will be increased, the contrast will get worse. This kV for dose reduction determines, when kV rising will stop for a while and the dose it reduced to 50%. Decreasing the dose will make the image noisier. However at a certain point of kV it is better to get more noise than to loose more contrast
In an OGP for Mode3D this parameter is used for MaxKV (in 0-pnt technique).
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

SCHWAERZKORR Blackening correction. This value is applied to the dose in order to have more dose steps than it is possible with HUD.
          Type:  Integer16     (DEC)
          Range: -32 ... 32
          Dimension: 0.25 BP

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

KENNL Number of the exposure curve that determines the kV from the thickness of the object to be X-rayed
In sOrgDaten this parameter will be used if parameter KV is set to 0
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: Nr

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

PROZ The parameter will reduce the max electrical power (which is given by max power value for the selected focus) to the given percentage in order to enlarge the lifespan of the tube.
Thus for a given kV it allows to reduce the current in order to artificially prolong the pulse time (which replaces the former "reduced current" techniques 8 and 20)
          Type:  Byte     (DEC)
          Range: 10 ... 100
          Dimension: %

REGSTOP stop dose regulation in generator and keep kV and mAs values for all subsequent pulses
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

FILTERAUFN Cu filter used for acq. This is a bit oriented value. Bit0 is "Filter auto", Bit1 is "use filter out of OGP", Bits 4 to 5 tell the filter number. E.g.: 2 = Filter 0, 34d = 22h = Filter 2, 51d = 33h = Filter 3 and Auto is on, 32d = 20h = leave filter as it is, because Bit 1 is 0.
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

RASTER Grid number according to configuration
          Type:  Byte     (DEC)
          Range: 0 ... 7
                     ACS_NO_GRID_SELECTED  0   no grid selected
          Dimension: none

TOMOPROG Number of tomo program if tomo is selected.
If tomo is not selected and tomoprog = 10 then it means DSA.
Is also used for DR-Scan parameters with the following definition:
1: 4cm/s   feet to head
2: 4cm/s   head to feet
5: 6cm/s   feet to head
6: 6cm/s   head to feet
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MASIST mAs value of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 100500
          Dimension: 0.01 mAs

MSIST duration of last exposure
          Type:  Integer32     (DEC)
          Range: 0 ... 999999
          Dimension: 0.1 ms

KVIST Actual voltage of fluoroscopy or exposure, told by generator
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

ANFMA the current, the last exposure has been started with. Current may fall during exposure depending on selected technique
          Type:  Integer16     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA

DFP_RAW nonweighted raw data of the dose area product as received directly from the measurement chamber.
          Type:  Dword     (DEC)
          Range: 0 ... 99999999
          Dimension: 0.01 µGym²

IAUFNDATEN_SZEIT
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

PULSE amount of pulses combined in this telegram (this is used if frame rate is too high to send a separate telegram for each pulse)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_VERIF_STATE internal XCU state
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: unknown

ACQ_PREP_STATE internal XCU state
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: unknown

ACQ_PREP_XRAY_STATE internal XCU state
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: unknown

ACQ_XRAY_OFF_STATE internal XCU state
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: unknown

ACQ_VERIF_OF_SERIE_STATE internal XCU state
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: unknown

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANLAUFNBEREIT Status of exposure condition in the system
          Type:  Byte     (DEC)
          Range: 0 ... 29
                     NEIN                           0    no
                     JA                             1    yes
                     COLLIMATOR_NOT_READY           2    System not ready because collimator
                                                         is not ready.
                     GRID_NOT_READY                 3    System not ready because grid is
                                                         not ready.
                     FILTER_NOT_READY               4    System not ready because filter is
                                                         not ready.
                     BETRIEBSART_NOT_ALLOWED        5    System not ready because
                                                         acquisition system is not allowed.
                     DOOR_OPEN                      6    System not ready because door is
                                                         open.
                     ASU_STATUS_NOT_READY           7    System not ready because ASUStatus
                                                         is not ready.
                     DFR_STATUS_NOT_READY           8    System not ready because DFRStatus
                                                         is not ready.
                     DETEKTOR_STATUS_NOT_READY      9    System not ready because Detector
                                                         Status is not ready.
                     CASSETTE_STATUS_NOT_READY      10   System not ready for acquisition
                                                         because KassStatus is not ready.
                     XRAY_DISABLE_SWITCH_NOT_READY  11   System not ready because x-ray
                                                         disable switch is activated.
                     ORGAN_PROGRAM_NOT_READY        12   System not ready for acquisition
                                                         because no organ program is
                                                         selected.
                     DAP_NOT_READY                  13   System not ready because Dose Area
                                                         Product for this patient is
                                                         complete.
                     WW_NOT_READY                   14   System not ready because water
                                                         value is not ready.
                     AUFNGENSTATUS_NOT_READY        15   System not ready for acquisition
                                                         because generator is not ready.
                     LIMITSTATUS_NOT_READY          16   System not ready because Limit is
                                                         not ready.
                     MAIN_CONTACT_NOT_READY         17   System not ready because main
                                                         contact was pressed during startup
                                                         and was not reset.
                     PRE_CONTACT_NOT_READY          18   System not ready because precontact
                                                         was pressed during startup and was
                                                         not reset.
                     ERROR_NOT_CONFIRMED            19   System not ready because an error
                                                         was not confirmed yet.
                     PRESSURE_SWITCH_NOT_READY      20   System not ready because the
                                                         pressure switch is not ready.
                     INTERMEDIATE_SID_POSITION      21   SID between two allowed positions
                     MEASURING_FIELDS_NOT_READY     22   System not ready because measuring
                                                         fields are not ready.
                     INVALID_SW_VERSIONS            23   PMS detected invalid SW Versions in
                                                         System.
                     INVALID_CONFIG                 24   PMS detected invalid configuration.
                     CALIB_SWITCH_ON                25   No Acquisition possible because
                                                         calib switch is activated.
                     ANL_ORTHO_UI_NOT_IN_STEP_1     26   The Ortho UI (on ImgSys) is not in
                                                         step 1; therefore the latest
                                                         iOrgDaten being distributed was not
                                                         the one to be used for next shot
                                                         (because acq will start with step 1
                                                         always)
                     SCANNING_REQUIRES_FLUORO       27   for peri scanning it is required to
                                                         make a fluoro before an acquisition
                                                         can be made.
                     STAND_MOVING                   28
                     DFR_SERIES_REQUIRES_FLUORO     29   in case there is no AEC chamber (or
                                                         one that is only good for RAD as in
                                                         G1) it is required to make a fluoro
                                                         before an acquisition can be made.
          Dimension: none

ANLDLBEREIT Status of fluoro condition in the system
          Type:  Byte     (DEC)
          Range: 0 ... 26
                     NEIN                           0    no
                     JA                             1    yes
                     COLLIMATOR_NOT_READY           2    System not ready because collimator
                                                         is not ready.
                     GRID_NOT_READY                 3    System not ready because grid is
                                                         not ready.
                     FILTER_NOT_READY               4    System not ready because filter is
                                                         not ready.
                     BETRIEBSART_NOT_ALLOWED        5    System not ready because
                                                         acquisition system is not allowed.
                     DOOR_OPEN                      6    System not ready because door is
                                                         open.
                     ASU_STATUS_NOT_READY           7    System not ready because ASUStatus
                                                         is not ready.
                     DFR_STATUS_NOT_READY           8    System not ready because DFRStatus
                                                         is not ready.
                     DETEKTOR_STATUS_NOT_READY      9    System not ready because Detector
                                                         Status is not ready.
                     CASSETTE_STATUS_NOT_READY      10   System not ready for acquisition
                                                         because KassStatus is not ready.
                     XRAY_DISABLE_SWITCH_NOT_READY  11   System not ready because x-ray
                                                         disable switch is activated.
                     FLUORO_PROGRAM_NOT_READY       12   System not ready for fluoro because
                                                         fluoro program is not ready.
                     DAP_NOT_READY                  13   System not ready because Dose Area
                                                         Product for this patient is
                                                         complete.
                     WW_NOT_READY                   14   System not ready because water
                                                         value is not ready.
                     DLGENSTATUS_NOT_READY          15   System not ready for fluoro because
                                                         generator is not ready.
                     LIMITSTATUS_NOT_READY          16   System not ready because Limit is
                                                         not ready.
                     MAIN_CONTACT_NOT_READY         17   System not ready because main
                                                         contact was pressed during startup
                                                         and was not reset.
                     PRE_CONTACT_NOT_READY          18   System not ready because precontact
                                                         was pressed during startup and was
                                                         not reset.
                     ERROR_NOT_CONFIRMED            19   System not ready because an error
                                                         was not confirmed yet.
                     PRESSURE_SWITCH_NOT_READY      20   System not ready because the
                                                         pressure switch is not ready.
                     INTERMEDIATE_SID_POSITION      21   SID between two allowed positions
                     MEASURING_FIELDS_NOT_READY     22   System not ready because measuring
                                                         fields are not ready.
                     INVALID_SW_VERSIONS            23   PMS detected invalid SW Versions in
                                                         System.
                     INVALID_CONFIG                 24   PMS detected invalid configuration.
                     CALIB_SWITCH_ON                25   No Acquisition possible because
                                                         calib switch is activated.
                     ANL_ORTHO_UI_NOT_IN_STEP_1     26   The Ortho UI (on ImgSys) is not in
                                                         step 1; therefore the latest
                                                         iOrgDaten being distributed was not
                                                         the one to be used for next shot
                                                         (because acq will start with step 1
                                                         always)
          Dimension: none

SCREENSAVER Screen saver, controlled by XCU or ImgSys
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     SCREENSAVER_AUS      0   screensaver off
                     SCREENSAVER_STUFE_1  1   screensaver level 1
                     SCREENSAVER_STUFE_2  2   screensaver level 2
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SPRITZENSTATUS Injector status
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     SPRITZE_SCHARF        1   injector armed
                     SPRITZE_NICHT_SCHARF  2   injector not armed
          Dimension: none

DUMMY8
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY9
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY10
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FL_READY internal XCU state
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: unknown

FL_BLOCK internal XCU state
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: unknown

DETECTORTYPE internal XCU state
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: unknown

DETECTORTARGET internal XCU state
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

DETECTORMOBIL internal XCU state
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: unknown

SAUSLBED_LAST_BEDEINH internal XCU status
          Type:  Enum8     (DEC)
          Range: 0 ... 31
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
          Dimension: none

SAUSLBED_LAST_DL internal XCU status
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SAUSLBED_LAST_VORBEREITUNG internal XCU status
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SAUSLBED_LAST_HK internal XCU status
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SAUSLBED_BEFORE_BEDEINH internal XCU status
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

SAUSLBED_BEFORE_DL internal XCU status
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SAUSLBED_BEFORE_VORBEREITUNG internal XCU status
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SAUSLBED_BEFORE_HK internal XCU status
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

FEHLERNUMMER_LONG Internal error number
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: none

NO_ERR_STATES number of errorstates to follow
          Type:  Dcount     (CNT)
          Range: 0 ... 20
          Dimension: none

{ERRORSTATE error environment (enum values are defined in a separate headerfile)
{          Type:  Enum16     (DEC)
{          Range: 0 ... 193
{                       ES_NONE                         0     Unknown
{                       ES_READY                        1     Ready
{                       ES_NOT_READY                    2     Not ready
{                       ES_UNCONFIRMED_ERROR            3     There is an error unconfirmed, acquisition should be blocked
{                       ES_EMERGENCY_STOP               4     Emergency stop button was pressed
{                       ES_GRID_NOT_READY               5     Grid not ready (moving)
{                       ES_COLLIMATOR_CLOSED            6     Collimator opening is too small
{                       ES_BEAM_DISPLACED               7     Beam displaced to target
{                       ES_WAIT_FOR_COLLIMATOR          8     Collimator not ready (moving)
{                       ES_CASSETTE_NOT_READY           9     To be filled
{                       ES_TUBE_NOT_ALIGNED_FD_TABLE    10    Beam does not hit target FD at table
{                       ES_TUBE_NOT_ALIGNED_FD_BWS      11    Beam does not hit target FD at BWS
{                       ES_TUBE_NOT_ALIGNED_CASS_TABLE  12    Beam does not hit target cassette at table
{                       ES_TUBE_NOT_ALIGNED_CASS_BWS    13    Beam does not hit target cassette at BWS
{                       ES_DETECTOR_UNLOADED_TABLE      14    No detector at table
{                       ES_DETECTOR_UNLOADED_BWS        15    No detector at BWS
{                       ES_STAND_NOT_READY              16    Stand not ready
{                       ES_STAND_NOT_READY_FLUORO       17    Stand not ready for Fluoro
{                       ES_STAND_NOT_READY_PERI         18    Stand not ready at Peri
{                       ES_INVALID_SID                  19    Invalid SID value
{                       ES_INVALID_SID_PERI             20    Invalid SID value at Peri
{                       ES_DETECTOR_IN_PARKPOS          21    Detector is in parking position
{                       ES_PLANE_B_TUBE_IN_PARKPOS      22    Plane B tube is in parking position
{                       ES_PLANE_A_TUBE_NOT_IN_PARKPOS  23    Plane A tube is not in parking position
{                       ES_FLUORO_REQUIRED_AT_SCAN      24    Fluoro required at Scan technique before starting acquisition
{                       ES_FTD_BELOW_MINIMUM            25    FTD value is below minimum
{                       ES_FTD_BELOW_MINIMUM_PERI       26    FTD value is below minimum at Peri
{                       ES_FLUORO_REQ_AT_NULLPOS_PERI   27    Fluoro required at null position at Peri technique before starting acquisition
{                       ES_FLUORO_REQ_AT_BASEPOS_PERI   28    Fluoro required at base position at Peri technique before starting acquisition
{                       ES_XRAY_DISABLED                29    XRay-disable switch
{                       ES_CASSETTE_NO_FLUORO           30    Fluoro blocked by cassette at DFR
{                       ES_NO_CASSETTE_TABLE            31    No cassette inserted at table
{                       ES_NO_CASSETTE_BWS              32    No cassette inserted at wall
{                       ES_CASSETTE_FULL_TABLE          33    Cassette full at table
{                       ES_CASSETTE_FULL_BWS            34    Cassette full at wall
{                       ES_PRESSURE_SWITCH              35    Generator: pressure switch
{                       ES_DOOR_CONTACT                 36    Generator: door contact
{                       ES_SS_OFF                       37    Generator: Safety switch off (HW prevents exposure)
{                       ES_EMERGENCY_POWER              38    Generator: Emergency power is on)
{                       ES_INCORRECT_OGP_DATA           39    Incorrect OGP data received
{                       ES_WAITING_FOR_GENERATOR        40    Generator: not ready
{                       ES_TUBE_NOT_CONFIRMED           41    Generator: tube selection was not confirmed
{                       ES_MEAS_FIELD_NOT_SELECTED      42    No measurement field has been selected at AEC technique
{                       ES_SCREENSAVER_ON               43    Screensaver is on
{                       ES_ADC_ACKNOWLEDGE_REQ          44    AD acknowledge required
{                       ES_CASSETTE_PULLED_OUT_TABLE    45    Cassette pulled out at table
{                       ES_DETECTOR_PULLED_OUT_TABLE    46    Detector pulled out at table
{                       ES_NO_AEC_SELECT_MAS            47    AEC no longer in field of view, an mAs value should be selected
{                       ES_AEC_GONE                     48    Generator: mAs-Technique required (AEC not available)
{                       ES_NO_PATIENT                   49    DFR: no patient selected
{                       ES_DISK_FULL                    50    DFR: disk full
{                       ES_SERVICE_MODE                 51    DFR: service is active
{                       ES_DFD_ERROR                    52    DFR: DFD tells error state
{                       ES_FLC_ERROR                    53    DFR: FLC tells error state
{                       ES_HIPAA_BLOCKING               54    DFR: HIPAA blocks exposure
{                       ES_NO_OGP                       55    DFR: no OGP
{                       ES_OFFSETCYCLE                  56    DFR: offset cycle active
{                       ES_FD_TOO_HOT                   57    DFR: FD too hot
{                       ES_FOLDER_PROTECTED             58    DFR: folder protected
{                       ES_FLC_DOC_MODE                 59    DFR: FL-C is in Documentation mode
{                       ES_FLC_POSTPROC_MODE            60    DFR: FL-C is in post-processing mode
{                       ES_FD_OFFSET                    61    DFR: FD offset is in progress
{                       ES_WLAN_POWER_TOO_LOW           62    DFR: For NRF: WLAN power is too low for acquisition
{                       ES_FLC_EXAM_MANAGER             63    DFR: FL-C is in mode Exam Manager
{                       ES_MOBILE_BATTERY_TOO_LOW       64    DFR: Battery of mobile detector is too low for acquisition
{                       ES_DETECTOR_NOT_OPERATING       65    DFR: Detector not in operating state
{                       ES_DETECTOR_NOT_CONFIGURED      66    DFR: Detector configured out
{                       ES_DETECTOR_IMAGE_RECOVERY      67    DFR: Detector image recovery in progress
{                       ES_WID_BK_CABLE_NOT_CONNECTED   68    DFR: wi-D BK cable not connected
{                       ES_ORTHO_UI_NOT_STEP_1          69    DFR: Ortho UI not in step 1
{                       ES_DFR_OTHER_ACQ                70    DFR: (all other not ready messages from detector concerning acquisition)
{                       ES_DFR_OTHER_FLUORO             71    DFR: (all other not ready messages from detector concerning Fluoro)
{                       ES_FLC_COMPOSING_MODE           72    DFR: FL-C is in composing mode
{                       ES_AUTOCONF_REQUIRED            73    PMS: inconsistent config data; Autoconf required
{                       ES_INCONSISTENT_SW              74    PMS: inconsistent SW detected
{                       ES_OFFON_REQUIRED               75    PMS: requires power off/on
{                       ES_DELAY_AFTER_EXPOSURE         76    2-second delay after the last exposure is yet active
{                       ES_FLUORO_REQ_YANG              77    At Yang, Fluoro must be taken at position 0 before starting the exposure
{                       ES_SERVICE_SWITCH               78    PMS: Service switch is on
{                       ES_XRAY_DISABLED_SW             79    PMS: X-Ray disabled per SW
{                       ES_CALIB_SWITCH                 80    Stand operation: calib switch
{                       ES_MOVE_BUTTON                  81    To be filled
{                       ES_TUBE_PIVOTED                 82    To be filled
{                       ES_STAND_TILTED_NO_PERI         83    To be filled
{                       ES_COLLISION                    84    To be filled
{                       ES_STAND_NOT_IN_STARTPOSITION   85    To be filled
{                       ES_COLLIMATION_GREATER_FD_SIZE  86    Collimation is greater than the size of the flat detector
{                       ES_GEN_FLUORO_NOT_READY         87    Generator: not ready for Fluoro
{                       ES_COMPRESSION_FORCE            88    Compression force is greater than 20 N
{                       ES_SCAN_TECHNIQUE               89    Scan technique was selected
{                       ES_SYSW_NOT_READY               90    SYSWAHL task is not ready (Acquisition)
{                       ES_MOBIL_BATT_LOW_ACQ_POSSIBLE  91    DFR: Battery of mobile detector is too low, but acquisition is still possible
{                       ES_TEMPERATURE                  92    Generator: temperature
{                       ES_EMERGENCY_STOP_FLUORO        93    Emergency stop button was pressed, block Fluoro
{                       ES_EXPOSURE_PREPARED_SE         94    Exposure was prepared by the SE task
{                       ES_GG_NOT_READY_FLUORO          95    GG task not ready for Fluoro
{                       ES_IMAGE_ORIENTATION_CHANGED    96    Deprecated: Image orientation was changed, starting Fluoro is not allowed
{                       ES_COLLIMATOR_BLADES_MOVING     97    Collimator blades are in movement
{                       ES_DFR_ACQ_STOP_REQUESTED       98    Acquisition block is requested by DFR
{                       ES_FLUORO_TIMEOUT               99    Fluoro timeout
{                       ES_NO_FLUORO_PROG               100   No valid Fluoro program was yet selected
{                       ES_ORTHO_UNDEFINED              101   Special stati at Ortho
{                       ES_MOVEMENT_DISABLED            102   Movement is disabled by switch on the UI
{                       ES_MAX_FLUORO_TIME_EXCEEDED     103   Maximal Fluoro time was exceeded
{                       ES_MAX_SKINDOSE_EXCEEDED        104   Maximal skin dose was exceeded
{                       ES_UNCONFIRMED_ERROR_FLUORO     105   There is an error unconfirmed, Fluoro should be blocked
{                       ES_RESELECT_OGP                 106   OGP should be re-selected
{                       ES_NO_PATIENT_FL                107   DFR: no patient selected
{                       ES_DISK_FULL_FL                 108   DFR: disk full
{                       ES_SERVICE_MODE_FL              109   DFR: service is active
{                       ES_DFD_ERROR_FL                 110   DFR: DFD tells error state
{                       ES_FLC_ERROR_FL                 111   DFR: FLC tells error state
{                       ES_HIPAA_BLOCKING_FL            112   DFR: HIPAA blocks Fluoro
{                       ES_NO_OGP_FL                    113   DFR: no OGP
{                       ES_OFFSETCYCLE_FL               114   DFR: offset cycle active
{                       ES_FD_TOO_HOT_FL                115   DFR: FD too hot
{                       ES_FOLDER_PROTECTED_FL          116   DFR: folder protected
{                       ES_FLC_DOC_MODE_FL              117   DFR: FL-C is in Documentation mode
{                       ES_FLC_POSTPROC_MODE_FL         118   DFR: FL-C is in post-processing mode
{                       ES_FD_OFFSET_FL                 119   DFR: FD offset is in progress
{                       ES_WLAN_POWER_TOO_LOW_FL        120   DFR: For NRF: WLAN power is too low for Fluoro
{                       ES_FLC_EXAM_MANAGER_FL          121   DFR: FL-C is in mode Exam Manager
{                       ES_MOBILE_BATTERY_TOO_LOW_FL    122   DFR: Battery of mobile detector is too low for Fluoro
{                       ES_DETECTOR_NOT_OPERATING_FL    123   DFR: Detector not in operating state
{                       ES_DETECTOR_NOT_CONFIGURED_FL   124   DFR: Detector configured out
{                       ES_DETECTOR_IMAGE_RECOVERY_FL   125   DFR: Detector image recovery in progress
{                       ES_WID_BK_CABLE_NOT_CONNCTD_FL  126   DFR: wi-D BK cable not connected
{                       ES_FLC_COMPOSING_MODE_FL        127   DFR: FL-C is in composing mode
{                       ES_BEAM_DOES_NOT_HIT_CHAMBER    128   Beam does not hit chamber at oblique angulation on dRF
{                       ES_S5_MAS_ACTIVE                129   mAs measurement activated on generator by S5 switch
{                       ES_STAND_MOVING                 130   Stand is moving
{                       ES_SID_INTERMEDIATE             131   SID is intermediate on dRF
{                       ES_TROLLEY_STANDALONE           132   Stand disconnected from trolley
{                       ES_GEN_IC_ESU_STATUS            133   Intermediate circuit or ESU not fully charged
{                       ES_GEN_MONOBLOCK_TEMP           134   Monoblock temperature too high
{                       ES_INCOMPATIBLE_MAIN_UNIT       135   Incompatible main unit connected to the trolley
{                       ES_RAD_MODE                     136   DFR: RAD mode is selected, there is no Fluoro program
{                       ES_MEAS_FIELD_NOT_HIT_FLUORO    137   Beam does not hit measuring field, Fluoro should be blocked
{                       ES_FLC_NO_IMAGE_PARTITION_FL    138   No image partition on FL-C, Fluoro should be blocked
{                       ES_MAIN_UNIT_NOT_RECOGNIZED     139   Main unit does not return its ID within the allowed time window.
{                       ES_COMPACHECK_IN_PROGRESS       140   XCU is waiting for MCU_SCU to come up
{                       ES_RECONNECT_IN_PROGRESS        141   reconnect of main unit to trolley in progress (used in surgery)
{                       ES_SYSW_NOT_READY_FLUORO        142   SYSWAHL task is not ready (Fluoroscopy)
{                       ES_PULSE_RATE_REDUCTION         143   Surgery: Status message if pulse rate reduction is active.
{                       ES_TUBE_LOAD_BLOCK_RADIATION    144   Surgery: Tube load too high.
{                       ES_DEFAULT_PULSE_RATE           145   Surgery: Status message if default pulse rate selected.
{                       ES_TUBE_HOT                     146   Surgery: Tube load too hot.
{                       ES_CASS_EXP_PAUSE_TIME          147   Surgery: Pause time after cassette exposure.
{                       ES_FLUO_REQ_LOW_DOSE_DFR_SERIES 148   Fluoro is required before low-dose DFR series
{                       ES_TUBE_NOT_ALIGNED_FD_CEILING  149   Beam does not hit target FD at ceiling stand
{                       ES_TUBE_NOT_ALIGNED_CASS_CEILNG 150   Beam does not hit target cassette at ceiling stand
{                       ES_DETECTOR_UNLOADED_CEILING    151   No detector at table
{                       ES_PATIENT_POS_NOT_DEFINED      152   DFR: patient position hast not been defined
{                       ES_PATIENT_POS_NOT_DEFINED_FL   153   DFR: patient position hast not been defined
{                       ES_FLUORO_REQUIRED_FOR_3D       154   Fluoro required at mandatory points for 3D Run
{                       ES_TOP_ALIGNMENT_AND_TRACKING   155   Top Alignment and tracking are active
{                       ES_ASU_NOT_READY_FL             156   FL-C: ASU not ready for Fluoro
{                       ES_GEN_FLUORO_NOT_READY_UDC     157   Generator: not ready for Fluoro
{                       ES_NOT_READY_FOR_3D_RUN         158   Not ready for 3D Run
{                       ES_TUBE_TOO_WARM_FOR_3D         159   Tube too warm for selected 3D series
{                       ES_OBJECT_TOO_LARGE_FOR_3D      160   Object is too large for selected 3D series
{                       ES_OBJECT_TOO_LARGE_FOR_ANY_3D  161   Object is too large for any 3D series
{                       ES_OBJECT_TOO_SMALL_FOR_ANY_3D  162   Object is too small for any 3D series
{                       ES_WRONG_FPS_FOR_3D             163   Wrong FPS defined for 3D organ program
{                       ES_NO_ACSS                      164   ACSS is inactive, disable Fluoro
{                       ES_SID_AKR_REDUCTION_ACTIVE     165   Air Kerma reduction active due to small SID
{                       ES_SID_AKR_TOO_HIGH             166   Air Kerma too high for this SID
{                       ES_3D_SCAN_ABORTED              167   3D scanning has been aborted by user
{                       ES_GRID_CONFLICTS_WITH_OGP      168   Current grid conflicts with OGP setting
{                       ES_3D_PREPARATION_INCOMPLETE    169   3D preparation is incomplete
{                       ES_COLLIMATOR_ROTATED           170   Collimator is rotated relative to the detector
{                       ES_EMERGENCY_MODE               171   Report status of display component, no UI available
{                       ES_SID_TOO_HIGH                 172   SID is too high, Fluoro should be blocked
{                       ES_3D_DISABLED                  173   Operating mode 3D is disabled
{                       ES_3D_CARM_OUT_OF_TOLERANCE     174   C-arm position out of tolerance, cannot proceed with 3D
{                       ES_FLC_PROCESS_3D_ACTIVE        175   DFR: FLC is in 3D image processing mode
{                       ES_FLC_PROCESS_3D_ACTIVE_FL     176   DFR: FLC is in 3D image processing mode
{                       ES_TUBE_NOT_ALIGNED_FD_TABLE_FL 177   Beam does not hit target FD at table
{                       ES_TUBE_NOT_ALIGNED_FD_BWS_FL   178   Beam does not hit target FD at BWS
{                       ES_TUBE_NOT_ALIGNED_FD_CLNG_FL  179   Beam does not hit target FD at ceiling stand
{                       ES_IQAP_REQUIRED                180   Setup is npt yet ready, IQAP is required
{                       ES_DFR_OTHER_ACQ_NO_STATUSMSG   181   DFR: (all other not ready messages from detector concerning acquisition)
{                       ES_ROTATED_COLL_EXCEEDS_FD      182   rotated collimation exceeds FD size
{                       ES_SEVERE_ERROR                 183   Severe error is active
{                       ES_AUTO_MOVEMENT_PENDING        184   Automatic movement is in progress
{                       ES_GRID_MISMATCH                185   Grid does not match the OGP request
{                       ES_GRID_REQUIRED                186   Grid should be inserted
{                       ES_GRID_REMOVE                  187   Grid should be removed
{                       ES_TUBE_ROTATED_HORIZONTALLY    188   Tube is rotated horizonally
{                       ES_FL_REQ_FOR_HISTOGRAM_MF      189   Fluoro required before acquisition with histogram field
{                       ES_OGP_SELECTION_IN_PROGRESS    190   OGP selection is in progress
{                       ES_TOO_MANY_FREE_FD_S           191   More than one large FD is in free position
{                       ES_NO_GEN_PARAMS_SHOWN          192   Tabcard generator parameters is not shown
{                       ES_LOW_IMAGE_MEM_ACQ_POSSIBLE   193   Image memory is low, acquisition is possible
{          Dimension: none


IXRAY

Object: IXRAY ___ID: 007F

Description: X-ray display control, sent from XCU to displays
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   SCU-IF   TUI-IF   UIS   XWP
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

XRAY active X-Ray
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     NO_XRAY      0
                     FLUORO       1
                     ACQUISITION  2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


IXRPT

Object: IXRPT ___ID: 00B2

Description: ImgSys sends the actual x-ray window to XCU
Sender     :   FLC   HIC_IF   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

XRPT_FLRAD Detector time XRPT (for acquisition)
          Type:  Word     (DEC)
          Range: 0 ... 3200
          Dimension: ms

XRPT_FL_MAX specifies the maximum length of the xray pulse (sensitive period of detector) (for fluoro)
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: ms

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


IZOOM

Object: IZOOM ___ID: 04BB

Description: confirms the execution of the zoom change; send back from Image System to XCU
Sender     :   UIS
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ZDF
          Type:  Integer16     (DEC)
          Range: 0 ... 2000
          Dimension: 0.001

COLL_HEIGHT Height of collimation
          Type:  Integer16     (DEC)
          Range: 0 ... 6000
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

COLL_WIDTH Width of collimation
          Type:  Integer16     (DEC)
          Range: 0 ... 6000
                     NO_OVERRIDE  0
          Dimension: 0.1 mm


IZOOMANZ

Object: IZOOMANZ ___ID: 04BA

Description: show actual zoom format;
              may be useful if there are display devices that are independent on image
              system (like LED on Uroskope remote control)
Sender     :   XCU
Receiver   :   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


LCM_OFF

Object: LCM_OFF ___ID: 2912

Description: withdrawing of the LCM; has to be sent with MODE = LCM (6)
Sender     :   ACSOS   PMS
Receiver   :   AXN
Mode       :  LCM(06)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


LCM_ON

Object: LCM_ON ___ID: 2911

Description: registration of the LCM; has to be sent with MODE = LCM (6)
Sender     :   ACSOS   PMS
Receiver   :   AXN
Mode       :  LCM(06)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


MONITOR_OFF

Object: MONITOR_OFF ___ID: 9301

Description: stop the 'Network Monitor', has to be sent with MODE = MONITOR (3)
Sender     :   ACSOS
Receiver   :   AXN
Mode       :  MONITOR(03)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


MONITOR_ON

Object: MONITOR_ON ___ID: 9300

Description: start the 'Network Monitor', has to be sent with MODE = MONITOR (3)
Sender     :   ACSOS
Receiver   :   AXN
Mode       :  MONITOR(03)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


REP_BEEP

Object: REP_BEEP ___ID: 1333

Description: handle the audible warning
Sender     :   TUI-IF
Receiver   :   TUI   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEEP_SEL definition of the audible warning, in Artis only up to 12. The values > 12 are additionally in RFU systems
          Type:  Enum8     (DEC)
          Range: 1 ... 35
                     ACS_BEEP_FL_TIMER               1    fluoro timer - indicates that the
                                                          max fluoro time is almost expired
                     ACS_BEEP_HEAT_UNIT              2    heat unit - indicates that the
                                                          user shall wait for tube cooling
                                                          down
                     ACS_BEEP_HC_FLUORO              3    high contrast fluoro
                     ACS_BEEP_COLLISION              4    collision detected (stand)
                     ACS_BEEP_SAFETY                 5    safety zone penetrated (stand)
                     ACS_BEEP_ACQ_OVER               6    acquisition stopped - indicates
                                                          the end of an X-ray in case a
                                                          there is no sound played during
                                                          the X-ray
                     ACS_BEEP_ACQ                    7    during ACQ on (Plane A or B)
                     ACS_BEEP_SPEECH                 8    speech command recognized
                     ACS_BEEP_POS_REACHED            9    preprogrammed or OGP position of
                                                          stand has been reached while
                                                          motion button is pushed
                     ACS_BEEP_FLUORO                 10   during fluoro on (Plane A or B)
                                                          (if configured)
                     ACS_BEEP_DOSE_LIMIT             11   reference air kerma threshold
                                                          alert - if the given max value for
                                                          dose per patient (e.g. 2 Gy) is
                                                          exceeded
                     ACS_BEEP_GEN_LIMIT              13   mAs or ms limit reached
                     ACS_BEEP_TUBE_LIMIT             14   pressure or temperature switch of
                                                          the tube
                     ACS_BEEP_FUNC_REJ               15   operation of a function is
                                                          rejected
                     ACS_BEEP_SYSTEM_READY           16   system ready - played after boot
                                                          sequence is completed
                     ACS_BEEP_TRACKING_LOCKED        17   tracking locked
                     ACS_BEEP_TRACKING_NOT_LOCKED    18   tracking not locked
                     ACS_BEEP_CONFIRMATION_REQU      19   played if an error or information
                                                          is shown that requires
                                                          confirmation by the user
                     ACS_BEEP_ACCEPTED_DELAY         20   operation accepted, but finished
                                                          with delay
                     ACS_BEEP_PRESSURE_LIMIT         21
                     ACS_BEEP_MOTORIZED_MOVEMENT     22
                     ACS_BEEP_OGP_MOVEMENT           23
                     ACS_BEEP_MOVEMENT_BLOCKING      24
                     ACS_BEEP_SYSTEM_READY_EMGY_FLU  25
                     ACS_BEEP_EMERGENCY_STOP         26
                     ACS_BEEP_RC_FINDER              27   remote control finder
                     ACS_BEEP_OGP_POS                28
                     ACS_BEEP_SOFT_POS               29
                     ACS_BEEP_END_POS                30
                     ACS_BEEP_FL_TIMER_FLUORO        31   For the case when both
                                                          ACS_BEEP_FLUORO(10) and
                                                          ACS_BEEP_FL_TIMER(1) should be
                                                          played
                     ACS_BEEP_FL_TIMER_HC_FLUORO     32   For the case when both
                                                          ACS_BEEP_HC_FLUORO(3) and
                                                          ACS_BEEP_FL_TIMER(1) should be
                                                          played
                     ACS_BEEP_LASER                  33   The laser is on. (will be played
                                                          only once)
                     ACS_BEEP_3D_ACQ_COMPLETE        34   3D Scan (CIOS) has finished
                     ACS_BEEP_TUBE_STARTUP           35   (used in surgery)
          Dimension: none

BEEP_FUNC function of the beeper. 1 turns the beeper on, 2 turns it off. 3 will play for a dedicated amount of time. 3 is preferred if time between on and off is smaller than 300 ms
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_BEEP_ON        1   beeper on
                     ACS_BEEP_OFF       2   beeper off
                     ACS_BEEP_ONE_SHOT  3   the same as ACS_BEEP_ON, but the sound sample is
                                            only played once
          Dimension: none

VOLUME volume of audible signals (only for PMS)
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: none

ULI_BOARD number of the ULI board (only for PMS)
(not applicable in XP)
          Type:  Byte     (DEC)
          Range: 1 ... 3
          Dimension: number


REP_CONFIRM

Object: REP_CONFIRM ___ID: 0027

Description: confirm the given (error) message
Sender     :   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

ERR_ID ID of error
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: none

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

CHOICE selected option (in MSGBOX_YESNO)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


REP_ERR

Object: REP_ERR ___ID: 1331

Description: error, warning and status reporting
Sender     :   ALL   CCU_A   SCU
Receiver   :   REP   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DEP_ID department ID (MEDCOM), 3 chars UNICODE
          Type:  String16 [ 3 ]     (ASCII)
          Range: 6 ... 6
          Dimension: unicode

DOM_ID domain ID (MEDCOM), max 3 chars UNICODE
          Type:  String16 [ 3 ]     (ASCII)
          Range: 6 ... 6
          Dimension: unicode

ERR_MSG_ID ID of an error message
Values are 32 bit values laid out as follows:

 3 3 2 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1
 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
+---+-+-+-----------------------+-------------------------------+
|Sev|C|R|     Facility          |               Code            |
+---+-+-+-----------------------+-------------------------------+
where
  Sev - is the severity code
        (00-success,01-Info,10-warning,11-error)
  C - is the Customer code flag
  R - is a reserved bit
  Facility - is the facility code (8=CSA, C=relevant)
  Code - is the facility's status code (error number)
          Type:  Dword     (HEX)
          Range: 0x0 ... 0xFFFFFFFF
          Dimension: none

MSG_SET set or reset a message or an error
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_STATUS_RESET  1   reset a status message or an error
                     ACS_STATUS_SET    2   set the state of a message or an error
          Dimension: none

ERR_INTENTION constraint of the object
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_ERR_ACTUAL   0   actually reported
                     ACS_ERR_BACKLOG  1   internally buffered before in the subsystem
                     ACS_ERR_UPDATE   2   The warning was requested before
          Dimension: none

XRPARNA x-ray parameter set number plane A (see XRPARN in ST_PARAM)
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
          Dimension: none

XRPARNB x-ray parameter set number plane B (see XRPARN in ST_PARAM)
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
          Dimension: none

RECOVER_CODE recover code. If it is not 0 in REP_ERR or REP_ERROR, the subsystem gets a SW reset.
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

TIME seconds since January 1st 1970; ACS_LNIL if the time is not available
note that this is in local time since this is the "logging time" (and many subsystems do only have this time)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: sec

XRPARN_AB x-ray parameter set number. Used to block X-Ray only of biplane fluoro and acquisition (see XRPARN in ST_PARAM)
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
          Dimension: none

AP_ID_ORG RFU only: AP_ID of the original sender of the REP_ERR (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

PAR_1 parameter 1, individually defined. INIL if not used
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

PAR1_EXP exponent of parameter 1, base 10
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

PAR_2 parameter 2, individually defined. INIL if not used
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

PAR2_EXP exponent of parameter 2, base 10
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

PAR_3 parameter 3, individually defined. INIL if not used
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

PAR3_EXP exponent of parameter 3, base 10
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

LOSTR_ET length of string of ETXT
          Type:  Dcount     (CNT)
          Range: 0 ... 570
          Dimension: count of elements

{ETXT internal error text, variable length, 1 char UNICODE
{          Type:  String16 [ 1 ]     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


REP_SYS_MSG

Object: REP_SYS_MSG ___ID: 0026

Description: XCU reports an error (or warning) to UIS in order to update the view
              concerning the given error ID (either add or remove from view) and/or in order
              to log the same
Sender     :   HIC_IF   PMS   XCU
Receiver   :   UIS
Mode       :  DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

ERR_ID ID of error
          Type:  Dword     (DEC)
          Range: 0 ... 4294967294
          Dimension: none

TIME seconds since January 1st 1970; ACS_LNIL if the time is not available
note that this is in local time since this is the "logging time" (and many subsystems do only have this time)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: sec

STRARG string argument to be inserted into the language dependent error message (if this contains a %s format identifier)
          Type:  String16 [ 26 ]     (ASCII)
          Range: 52 ... 52
          Dimension: unicode

ERRCNT Cyclic Counter for synchronizing Errlog of XCU to Errorlog in REPORT ERROR DEVICE.
Must be set to NIL if being sent by other device than XCU.
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

MSG_SET set or reset a message or an error
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_STATUS_RESET  1   reset a status message or an error
                     ACS_STATUS_SET    2   set the state of a message or an error
          Dimension: none

NO_ARGS number of arguments in the following array
          Type:  Dcount     (CNT)
          Range: 0 ... 10
          Dimension: count of arguments

{ARG_KEY name of parameter
{          Type:  String16 [ 10 ]     (ASCII)
{          Range: 20 ... 20
{          Dimension: unicode

{ARGUMENT parameter for additional info (e.g. arguments for error string)
The meaning depends on the error (FEHLERNUMMER).
{          Type:  Dword     (HEX)
{          Range: 0x0 ... 0xFFFFFFFF
{          Dimension: none

CATEGORY Type of error: bit3..0=category, bit4=reset; bit5=yesno
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0x3F
                     RESET_USERMSG_LEGACY  0x00   obsolete - formerly used to withdraw
                                                  status 5  - will be logged as [x]
                     WARNUNG               0x01   warning - logged only - not shown at TUI
                                                  resp FLC - will be logged as [w]
                     BEHEB_FEHLER          0x02   error - shown at TUI and ImgSys with a
                                                  message box + exclamation mark and
                                                  OK-Button  - will be logged as [r]
                     NICHT_BEHEB_FEHLER    0x03   non-recoverable error - shown at ImgSys
                                                  and TUI with a messagebox  + exclamation
                                                  mark and OK-Button - will be logged as [e]
                     FATALER_FEHLER        0x04   fatal error - shown at ImgSys and TUI with
                                                  a messagebox  + white x on red background
                                                  and OK-Button - will be treated in XCU as
                                                  if received an iFEStatus(13) - will be
                                                  logged as [f]
                     USERMESSAGE           0x05   info for user - shown at FLC and TUI with
                                                  a messagebox + blue i on white background
                                                  and OK-Button - not treated as an error,
                                                  less prior than errors in case of
                                                  concurrent errors - will be logged as [i]
                     BEDIENEVENT           0x06   action - not in use - would be logged as
                                                  [a]
                                                  temporarily used in iErrorLog2 to log
                                                  status line messages
                     TELEGRAM              0x07   info in status line - will be shown at FLC
                                                  and TUI in the status line w/o Button  -
                                                  will be logged as [t]
                     MSGBOX_NO_OK_NO_TUI   0x09   info for user - shown at FLC  with
                                                  messagebox but no OK-Button - not treated
                                                  as an error, less prior than errors -
                                                  shall be logged as [o]
                     ORTHOMESSAGE          0x0A   info for user - shown at ImgSys and TUI
                                                  with messagebox but no OK-Button - not
                                                  treated as an error, less prior than
                                                  errors  - will be logged as [o]
                     ACS_FLAG_RESET        0x10   not directly used - is defined as the
                                                  withdraw flag - Shall be used as
                                                  BIT-OR-combination with the other states
                                                  (e.g. ACS_ERR_RESET|WARNUNG is identical
                                                  to RESET_WARNING)
                     RESET_WARNING         0x11   withdraw status 1 - will be logged as [x]
                     RESET_ERROR           0x12   withdraw status 2 - will be logged as [x]
                     RESET_SEVERE          0x13   withdraw severe (non-recoverable) error
                                                  status - will be logged as [x]
                     RESET_FATAL           0x14   withdraw status 4 - will be logged as [x]
                     RESET_USERMESSAGE     0x15   withdraw status 5 - will be logged as [x]
                     RESET_TELEGRAM        0x17   withdraw status 7 - will be logged as [x]
                     RESET_MSGBOX          0x19   withdraw status 9 - will be logged as [x]
                     RESET_ORTHOMSG        0x1A   withdraw status A - will be logged as [x]
                     ACS_FLAG_YESNO        0x20   not directly used, is defined as the
                                                  YES-No flag and will output a message box
                                                  with YES / NO button. Shall be used as
                                                  BIT-OR-combination with the other states
          Dimension: none

SUPPRESS_ERROR this parameter is needed as long as the error suppression is done in XCU instead of UIS.
0: treat normally (according to Message DescriptionFile)
1: error is in the XCU's suppression list and shall not be shown but just be logged
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

LOSTR_EXT length of string of EXTXT
          Type:  Dcount     (CNT)
          Range: 0 ... 1000
          Dimension: count of elements

{EXTXT
{          Type:  String8 [ 1 ]     (ASCII)
{          Range: 1 ... 1
{          Dimension: ASCII


REP_TRACE

Object: REP_TRACE ___ID: 1332

Description: trace reporting (used by XCU for debugging)
Sender     :
Receiver   :   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TIME seconds since January 1st 1970; ACS_LNIL if the time is not available
note that this is in local time since this is the "logging time" (and many subsystems do only have this time)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: sec

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_TRACE length of string of the trace
          Type:  Dcount     (CNT)
          Range: 0 ... 1400
          Dimension: count of elements

{TRACE_TEXT trace message, variable length UTF-8
{          Type:  String8     (ASCII)
{          Range: 1 ... 1
{          Dimension: utf-8


RJ_OBJECT

Object: RJ_OBJECT ___ID: 1342

Description: reject of request object
Sender     :   ALL
Receiver   :   ALL
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

OBJECT_ID ID of the object
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: none

PROCEDURE_ID identifier of a 'request - response' flow. It is set by the requester and sent back by the responder.
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: none

AP_ID_REQUESTER application process ID of the subsystem, that has sent the request (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none


RQ_DET_POS

Object: RQ_DET_POS ___ID: 102A

Description: trigger to detect the position of the portable detector
              -- draft proposal --
              (t.b.d. if or which parameters are needed)
Sender     :   SCU
Receiver   :   SMSN
Mode       :  DIRECT(01)
Systems    :  RadFluoro
This object has no parameters


RQ_DET_TEMP

Object: RQ_DET_TEMP ___ID: 1014

Description: request (array of) detector temperature value(s)
              used by FDCalib/IQAP
Sender     :   CSF   PMS
Receiver   :   FLC_TV
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

TIMESPAN time span in seconds for which FD temperature values are requested
(or 0 if last value is sufficient)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: sec

DETECTOR_PLANE identifier for the detector being addressed
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_NO_INFORMATION     0
                     ACS_FD_TABLE           1    detector mounted in the table
                     ACS_FD_WALL            2    FD mounted in the wall stand
                     ACS_FD_PORTABLE        3    free portable detector
                     ACS_FD_WALLCHARGER     4    portable detector in wall charger
                     ACS_FD_STAND           7    detector mounted in the dTF stand
                     ACS_FD_C_ARM           8    detector on c-arm in surgery
                     ACS_FD_FLEXIBLE        9    detector of Multitom Rax system
                     ACS_FD_SMALL_PORTABLE  10   small portable detector
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


RQ_FDR_DATA

Object: RQ_FDR_DATA ___ID: 0430

Description: request data from FDR
Sender     :   PMS
Receiver   :   FLC   HIC_IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FDR_RQ_INDEX index for each individual FDR request
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DETECTOR_PLANE identifier for the detector being addressed
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_NO_INFORMATION     0
                     ACS_FD_TABLE           1    detector mounted in the table
                     ACS_FD_WALL            2    FD mounted in the wall stand
                     ACS_FD_PORTABLE        3    free portable detector
                     ACS_FD_WALLCHARGER     4    portable detector in wall charger
                     ACS_FD_STAND           7    detector mounted in the dTF stand
                     ACS_FD_C_ARM           8    detector on c-arm in surgery
                     ACS_FD_FLEXIBLE        9    detector of Multitom Rax system
                     ACS_FD_SMALL_PORTABLE  10   small portable detector
          Dimension: none

FD_SERIAL FD serial number, max 32 chars UNICODE
          Type:  String16 [ 32 ]     (ASCII)
          Range: 64 ... 64
          Dimension: unicode

NO_FDR_DATA_REQ number of requested FDR data blocks
          Type:  Dcount     (CNT)
          Range: 0 ... 80
          Dimension: none

{FDR_PARAM_TAG identifier of the FDR parameter (the values are not consecutive!)
{          Type:  Enum8     (DEC)
{          Range: 0 ... 252
{                       ACS_FDR_SERNUM                0     Serial number of FD
{                       ACS_FDR_PLANE                 1     Plane on which FD is currently
{                                                           attached
{                       ACS_FDR_DATE_CODE             2
{                       ACS_FDR_SW_VERSION            3
{                       ACS_FDR_PART_NUM              4     Factory part number of FD
{                       ACS_FDR_CUR_TEMP              5     Current FD temperature
{                       ACS_FDR_BATT_STATUS           6     Battery charge level
{                       ACS_FDR_BATT_ID               7     battery serial number
{                       ACS_FDR_BATT_CHARGE_CYC       8     battery charge cycle count
{                       ACS_FDR_LIFE_TIME             9
{                       ACS_FDR_POWERON_CNT           10
{                       ACS_FDR_WIFI_CUR_CHANNEL      11
{                       ACS_FDR_WIFI_FE_LINK_QUALITY  12    Raw Link Quality
{                       ACS_FDR_WIFI_DATA_RATE        13
{                       ACS_FDR_CALIB_TEMP            14    detector temperature at time of
{                                                           calibration
{                       ACS_FDR_CALIB_DATE            15    date of when the current
{                                                           calibration data have been
{                                                           acquired
{                       ACS_FDR_DETECTOR_TYPE         100
{          Dimension: none


RQ_FDR_VERSION_CHECK

Object: RQ_FDR_VERSION_CHECK ___ID: 1020

Description: request whether version for fd is valid (used for wiD attachment)
Sender     :   PMS
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

DET_TYPE type of detector
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_NO_INFORMATION  0
                     ACS_FD4343RC        1
                     ACS_FD4343RCE       2
                     ACS_FD3543EZH       3
                     ACS_FD3543DR        4
                     ACS_FD2430EZ        5
          Dimension: none

IDX_FDR_VERSION index count (used to match SH_FDR_VERSION_CHECK to RQ_FDR_VERSION_CHECK)
shall be incremented each time a RQ_FDR_VERSION_CHECK is sent (continuing with 0 after 255)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FDR_CUR_VERSION current FD FW version
          Type:  String8 [ 64 ]     (ASCII)
          Range: 64 ... 64
          Dimension: none

FDR_PARTNUM FD factory part number
          Type:  String8 [ 64 ]     (ASCII)
          Range: 64 ... 64
          Dimension: none


RQ_IMAGE

Object: RQ_IMAGE ___ID: 1821

Description: request image from image system (in service)
Sender     :   PMS
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

BUFSIZE size of the shared memory (not used in RFU)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: number of bytes

IMAGE_NO number of requested image (1...n or spec. Define)
          Type:  Integer16     (DEC)
          Range: -3 ... 32767
                     ACS_IMAGE_LAST        -3  transfer last image
                     ACS_IMAGE_MULTIFRAME  -2  transfer complete multiframe image
                     ACS_IMAGE_MASK        -1  transfer mask image
                     ACS_IMAGE_BIH         0   transfer best image
          Dimension: none

PLANE_SEL selection of plane (not used in RFU, defined by last acq)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_PLANE_A  1
                     ACS_PLANE_B  2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_SHM_NAME length of SHM_NAME
          Type:  Dcount     (CNT)
          Range: 0 ... 220
          Dimension: count of elements

{SHM_NAME name of the shared memory or path for image transfer, variable length UNICODE
in RFU: path and filename (no shared mem)
default (if string is empty): "c:\export\FLC_IQP.img"
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


RQ_OBJECT

Object: RQ_OBJECT ___ID: 1341

Description: request object (The parameter AP_ID is only used if ADDRESS_MODE =
              ACS_ANSWER_INDIRECT. It may be ignored in all other cases.)
Sender     :   ALL
Receiver   :   ALL
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

OBJECT_ID ID of the object
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: none

SEND_RJ This parameter is obsolete, since the telegram RJ_OBJECT has been removed!!
(former meaning: if the requested object can not be sent, a RJ_OBJECT has to be sent instead.)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

ADDRESS_MODE Address mode of the requested object
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_ANSWER_DIRECT      1   The requested object should be sent back
                                                DIRECTLY addressed to the sender of the
                                                RQ_OBJECT
                     ACS_ANSWER_FUNCTIONAL  2   The requested object should be sent
                                                FUNCTIONALLY addressed (so that everyone can
                                                receive it)
                     ACS_ANSWER_INDIRECT    3   The requested object should be sent DIRECTLY
                                                addressed to the AP_ID specified in the next
                                                parameter AP_ID
          Dimension: none

AP_ID application process ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

VERSION_RQOBJECT version of the object RQ_OBJECT
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_RQOBJECT  1   version 1 since VE10A: new parameters PROCEDURE_ID
                                         and AP_ID
          Dimension: none

PROCEDURE_ID identifier of a 'request - response' flow. It is set by the requester and sent back by the responder.
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


S3DPARAMS

Object: S3DPARAMS ___ID: 101B

Description: Transfer 3D parameters from organ program (Image System) to XCU
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TRAJECTORY_NAME name of the trajectory, 32 chars unicode
          Type:  String16 [ 32 ]     (ASCII)
          Range: 64 ... 64
          Dimension: unicode

TRAJCT_START_POSITION Start position of the trajectory. The direction depends on the trajectory itself (e.g. height for upright trajectories)
This parameter is also put into DICOM to match the nearest calibration position.
          Type:  Dword     (DEC)
          Range: 0 ... 200000
          Dimension: 0.1mm

CALIB_MODE mode of the 3D calibration
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE        0   none
                     ACS_GEOCALIB    1   geometric calibration
                     ACS_IZEROCALIB  2   I0-calibration
          Dimension: none

FLUORO_OPTION describes which fluoro points are mandatory and subsequently how much of a testrun is needed
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_FLO_DUAL_REGULAR  0   3D trajectory requires a full collision run
                                               with two fluoros in perpendicular positions
                     ACS_FLO_SIINGLE       1   3D trajectory requires just one fluoro to be
                                               made at start position
          Dimension: none

TRAJCT_TYPE type of trajectory
used by XCU to determine which accessory needs to be considered in collision model
          Type:  Enum8     (DEC)
          Range: 1 ... 14
                     ACS_TRAJTYPE_UPR_SM   1    standing SkelMal
                     ACS_TRAJTYPE_TBL_SM   2    lying SkelMal
                     ACS_TRAJTYPE_UPRIGHT  11   for upright 3D
                     ACS_TRAJTYPE_TABLE    12   for table 3D
                     ACS_TRAJTYPE_SIDE     13   for side 3D
                     ACS_TRAJTYPE_SIDE_HR  14   for side high res 3D
          Dimension: none

NUM_OF_PHASES number of phases of the skelmal trajectory (either 1 for single side or 2 for both sides)
          Type:  Byte     (DEC)
          Range: 1 ... 2
          Dimension: none

LOWER_SM_BORDER lower border of SkelMal range, measured from top of the socket the patient stands on (upright) or from the white line on the table (lying)
          Type:  Integer16     (DEC)
          Range: -1 ... 2200
          Dimension: mm

UPPER_SM_BORDER upper border of SkelMal range, measured from top of the socket the patient stands on (upright) or from the white line on the table (lying)
          Type:  Integer16     (DEC)
          Range: -1 ... 2200
          Dimension: mm


S_POWER_RESET

Object: S_POWER_RESET ___ID: 0434

Description: change the status of the power supply of the FD
Sender     :   FLC   HIC_IF   PMS
Receiver   :   GEN-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

POWER_SUPPLY_NO number of power supply
          Type:  Byte     (DEC)
          Range: 1 ... 6
                     ACS_PSWITCH_GB_TABLE      1   In GreatBarracuda this relay switches the
                                                   power for the table
                     ACS_PSWITCH_GB_IMGSYS     2   In GreatBarracuda this relay switches the
                                                   power for the image system
                     ACS_PSWITCH_GB_STAND_AIC  3   In GreatBarracuda this relay switches the
                                                   power for the 24V supplies for the AIC
                                                   board as well as for the controllers and
                                                   drives
                     ACS_PSWITCH_GB_DETECTORS  4   In GreatBarracuda this relay switches the
                                                   power for the fixed detector(s)
          Dimension: none

POWER_SUPPLY_STATUS actual status of power supply
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

POWER_SUPPLY_TIME the time after that the power supply has to toggle the status back to the status before this telegram has been received. If another sHWReset telegram is received while the timer is running, the timer has to be cancelled.
          Type:  Word     (DEC)
          Range: 0 ... 65535
                     ACS_POWER_TIME_NOT_SET  0   Timer is not used
          Dimension: sec


SACQREQ

Object: SACQREQ ___ID: 026D

Description: This telegram will be send if the aquisition switch is pressed but image
              system has reported iDfrStatus(NO_GEN_PARAMS_SHOWN)
Sender     :   XCU
Receiver   :   UIS
Mode       :  DIRECT(01)
Systems    :  RadFluoro
This object has no parameters


SALTERNATIVELIST

Object: SALTERNATIVELIST ___ID: 02DA

Description: List of alternative organ programs for each organ program in Ysio
Sender     :   FLC
Receiver   :   TUI-IF   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

ORGAN_INDEX Index of organ program (0=no information)
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: none

PROG_NAME_USAGE usage of the list
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_OGP_LIST      1   list of names of OGPs
                     ACS_EXAM_LIST     2   list of names of examination sets
                     ACS_ALT_LIST      3   List with alternative OGPs only (used in RFU)
                     ACS_CHANGE_ENTRY  4   only used in RFU
                     ACS_ADD_ENTRY     5   only used in RFU
                     ACS_DELETE_ENTRY  6   only used in RFU
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_PROG_NAME number of program names
          Type:  Dcount     (CNT)
          Range: 0 ... 10
          Dimension: none

{PROG_INFO additional information regarding the program used at the UI
{          Type:  Enum8     (DEC)
{          Range: 0 ... 9
{                       ACS_NOT_DEFINED          0   not defined
{                       ACS_PF_WP_CASS           1   work place cassette
{                       ACS_PF_WP_TABLE          2   work place table
{                       ACS_PF_WP_WALL           3   work place wall stand
{                       ACS_PF_WP_FREE           4   work place free exposure
{                       ACS_PF_WP_3DSIDE         5   side trajectory for 3D acquisition
{                       ACS_PF_WP_3DTABLE        6   table trajectory for 3D acquisition
{                       ACS_PF_WP_3DUPRIGHT      7   upright trajectory for 3D acquisition
{                       ACS_PF_WP_TOPO_LYING     8   SkelMal at table (2D Topogram)
{                       ACS_PF_WP_TOPO_STANDING  9   upright SkelMal (2D Topogram)
{          Dimension: none

{PROG_EXECUTED For programs only: Is the program already used
{          Type:  Enum8     (DEC)
{          Range: 1 ... 2
{                       ACS_YES  1
{                       ACS_NO   2
{          Dimension: none

{ALT_INDEX Index for an alternative organ program, used for Ysio Systems.
{          Type:  Word     (DEC)
{          Range: 0 ... 32767
{          Dimension: none

{PROG_NAME name of a program of exam set (64 char unicode)
{          Type:  String16 [ 64 ]     (ASCII)
{          Range: 128 ... 128
{          Dimension: unicode


SAPPLIKATION

Object: SAPPLIKATION ___ID: 000D

Description: answer of XCU on sending iFEStatus[2], sent from XCU to component that is
              announcing to the XCS network
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   TUI-IF
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs and XCU_obsolete_IF
This object has no parameters


SAUFNAUSL

Object: SAUFNAUSL ___ID: 02C2

Description: control of X-ray for acquisition sent from XCU to generator and other
              components involved in X-ray release
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   SCU-IF   TUI-IF   UGEN   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro and show

List of Parameters:

VORBEREITUNG pre-contact, tells the generator to spin-up the tube and to heat the focus
tells the rest of the system (namely image system) to prepare for acquisition
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

HAUPTKONTAKT main contact, tells the generator to release the exposure and the image system to start triggering
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

STRAHLGBEREIT Tells all other components, that the generator is ready to X-ray. This is e.g. sent to a reversing grid or a tomo stand. So the tomo stand or the grid know, that they will trigger now the exposure as soon as they are sending <ready>
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

WAIT_FOR_TRIGGER this parameter tells the generator, if it has to wait for a trigger (in addition to HK=1) in order to release radiation (note: 0 has the same meaning as 2 (don't wait))
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION          0
                     ACS_WAIT_FOR_HW_TRIGGER     1   after the HK has been set to 1 the
                                                     generator shall wait for a HW-Trigger
                                                     (HV_Trig)
                     ACS_DONT_WAIT               2   the generator shall not wait for any
                                                     additional trigger but shall release
                                                     radiation upon HK=1 right away
                     ACS_WAIT_FOR_TRIG_TELEGRAM  3   wait for separate trigger telegram
                                                     after HK=VK=1 was received (SW trigger)
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


SAUFNDATEN

Object: SAUFNDATEN ___ID: 02BC

Description: X-ray data for the next exposure sent from XCU to generator
Sender     :   XCU
Receiver   :   GEN-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

MODE Chosen exposure mode
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     EINZELBILD  0   single frame
                     SERIE       1   series
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MA Current of fluoro or acquisition
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

PROZ The parameter will reduce the max electrical power (which is given by max power value for the selected focus) to the given percentage in order to enlarge the lifespan of the tube.
Thus for a given kV it allows to reduce the current in order to artificially prolong the pulse time (which replaces the former "reduced current" techniques 8 and 20)
          Type:  Byte     (DEC)
          Range: 10 ... 100
          Dimension: %

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IDX_AUFND index count (used to match vAufnDaten to sAufnDaten)
shall be incremented each time an sAufnAusl is sent (continuing with 0 after 255)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SAUSLBED

Object: SAUSLBED ___ID: 006F

Description: telegram from the control console to control X-ray
Sender     :   RAD-STD   SCU   SCU-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

DL fluoro requested
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

VORBEREITUNG pre-contact, tells the generator to spin-up the tube and to heat the focus
tells the rest of the system (namely image system) to prepare for acquisition
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

HK main contact, tells the generator to release the exposure
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none


SBEDALLG

Object: SBEDALLG ___ID: 006E

Description: general user commands; send from control console to XCU
Sender     :   FLC   SCU   SCU-IF   TUI-IF   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEALLG Function code
          Type:  Enum16     (DEC)
          Range: 800 ... 810
                     RAUMLICHT           800   room light (Param: 0=off; 1=on)
                     FEHLER_LOESCHEN     801   confirm error
                                               PARAM may have the same values as the
                                               parameter CHOICE in sResetFehler
                     NOTSTOP             802   emergency stop (PARAM: 1=emergency stop
                                               pressed)
                     REMOTE_OK           803   Remote access
                                               if BEDIENOBJ==4:
                                               PARAM: 1=granted; 2=denied;3=turn off;
                                               4=request for remote; 5=permanent remote
                                               request
                                               if BEDIENOBJ==2:
                                               PARAM: 1=toggle to next meaning of remote
                                               access status
                     SCREENSAVER         804   turn off screen saver
                     XRAY_DISABLE        805   disable X-ray (PARAM: 0=enable x-ray;
                                               1=disable x-ray)
                     SCREENSAVER_ON_OFF  806   Switch Screen-Saver on or off, sent from
                                               ImgSys to XCU, used to control enabling of
                                               X-ray
                     ACS_UNDO            807   Undo button on TUI.
                     ACS_REDO            808   Last organ program shall be used again (Ysio)
                     ACS_MARKRING        809   used in surgery
                                               with this code MCU tells XCU if the marker
                                               ring (for navigation) is attached or not
                                               Must be sent by MCU at startup
                     ACS_FILMCASS        810   used in surgery
                                               with this code MCU tells XCU if a film
                                               cassette is inserted in the cassette holder
                                               (for S1E)
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDBVFS

Object: SBEDBVFS ___ID: 006C

Description: detector zoom control; send from control console to XCU
Sender     :   FLC   SCU   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Sharpfin

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEBVFS Function code for BVFS
          Type:  Enum16     (DEC)
          Range: 600 ... 610
                     ZOOM  600   zoom of image intensifier / FD
                                 (PARAM: -1= autozoom; 0=no info;1= full size; 2=Zoom1;
                                 3=Zoom2; 4=Zoom3)
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDDFR

Object: SBEDDFR ___ID: 006D

Description: DFR control; send from control console to XCU
Sender     :   FLC   SCU   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEBAUSW Function code for sBedDFR (see corresponding codes in parameter AKTCODE)
          Type:  Enum16     (DEC)
          Range: 700 ... 900
                     _BLAETTERN                700
                     _DISPLAYMODE_AENDERN      701
                     _CHANGE_MARK              702
                     _HARDCOPY                 703
                     _STORE_MONITOR            704
                     _DELETE_IMAGE             705
                     _STORE_REFERENZ           706
                     _RECALL_REFERENZ          707
                     _TRANSFER_IMAGE           708
                     _VIDEOLOOP_REPLAY         709
                     _RL_MARKIERUNG            710
                     _SUB_NATIV_DARSTELLUNG    711
                     _REMASKING                712
                     _DET_SELECT               713
                     _FILTERUNGSPROGRAMM       714
                     _FILTERKERN               715
                     _FILTERENHANCEMENT        716
                     _VERGROESSERUNG           717
                     _INVERTIERUNG             718
                     _ANATOMIC_BACKGROUND      719
                     _PEAK_OPACIFICATION       720
                     _AUTOSHUTTER              721
                     _FADENKREUZ               722
                     _ROADMAP_FLH              723
                     _REFMONITOR               724
                     _W1                       725   brightness native
                     _W2                       726   contrast native
                     _W3                       727   brightness subtracted
                     _W4                       728   contrast subtracted
                     _SHUTTER_HORIZONTAL       729
                     _SHUTTER_VERTIKAL         730
                     _ROAM_HORIZONTAL          731
                     _ROAM_VERTIKAL            732
                     _KREISSHUTTER             733
                     _STORE_FL_SZENE           734
                     _REF_MON_US               735
                     _CARE_POS                 736   switch care position on/off
                     _ENDO_GRAB                737   Aktdata: 0=stop movie / 1=start movie /
                                                     2=store endo image
                     _WARNING_SIGNAL           738   Parameter: -1 Warning signal stop | 0:
                                                     No action |
                                                                        1 Warning signal
                                                     activated
                                                     Warning Signal if Shockwave reaches a
                                                     defined energy level
                                                     Attention: other use in param. Aktcode!
                     _TABCARD_TOGGLE           739   Aktdata:    0=No Action / 1=Pat /
                                                     2=Exam / 3=Postproc / 4=Doc
                     _FLIP_IMAGE_HORIZONTAL    740   Aktdata:   0=No Action / 1=Off / 2=On /
                                                     -1=Toggle
                     _FLIP_IMAGE_VERTICAL      741   Aktdata:    0=No Action / 1=Off / 2=ON
                                                     / -1=Toggle
                     _DOSECHANGE_LOW_STANDARD  742   Aktdata: 0 = Standard Dose; 1 = Low
                                                     Dose (not yet in use)
                     _DVD_RECORDER             743   Param: 0 = NO_CHANGE; 1 =
                                                     START_DVD_RECORDING; 2 =
                                                     STOP_DVD_RECORDING
                     _MARK_R_POSITION          744   Param: 0 = NO RIGHT MARK; 1 =
                                                     UPPERLEFT; 2 = UPPERRIGHT; 3 = MIDLEFT;
                                                     4 = MIDRIGHT; 5 = LOWERLEFT; 6 =
                                                     LOWERRIGHT
                     _MARK_L_POSITION          745   Param: 0 = NO LEFT MARK; 1 = UPPERLEFT;
                                                     2 = UPPERRIGHT; 3 = MIDLEFT; 4 =
                                                     MIDRIGHT; 5 = LOWERLEFT; 6 = LOWERRIGHT
                     _FORMAT_SEGMENTATION      746   Param: 0 = NO_INFORMATION; 1 = FULL; 2
                                                     = 2VER; 3 = 2AVER; 4 = 2HOR; 5 = 2AHOR;
                                                     6 = 3VER; 7 = 1OF4
                     _REFRESH_ORGAN_PROGRAM    747   Param: 0 = no change; 1 = refresh
                     _REDO_ORGAN_PROGRAM       748   Used for Ysio, last organ program shall
                                                     be used again.
                     _TOD                      749   Used to set table object distance,
                                                     param between TOD_MIN, TOD_MAX
                     _WINDOW_LUT               755   This allows the selection of a
                                                     predefined LUT (set of window values)
                                                     AKTDATA>0 number of fixed setting
                                                     AKTDATA=0 deselects all (free window
                                                     values)
                                                     -1 step to next setting
                                                     (used in surgery and urology)
                     _AVERAGING                759   plus/minus buttons to set k-factor
                                                     (used in surgery)
                     _MOTION_DET               760   selector to set the level for motion
                                                     detection (used in surgery)
                                                     param: 0=off; 1=low; 2=standard; 3=high
                     _IMG_ROTATE               761   rotate image by arbitrary amount
                     _ENABLE_AUTO_STORE        767   switch on or off automatic storage of
                                                     fluoro loop
                     _DIGITAL_ZOOM             770
                     _HOLD_REF                 775   FLC shall freeze the reference monitor
                                                     (used in surgery)
                     _SHOW_CARE_PROF           798   trigger showing care profile graphics
                                                     on image system
                     _CHANGE_BRIGHTNESS        799   change window brightness (used for
                                                     button based control in surgery)
                     _CHANGE_CONTRAST          800   change window contrast (used for button
                                                     based control in surgery)
                     _NO_ZOOMDOSE_ADPT         827   PARAM:
                                                     0: normal zoom dose adaption
                                                     1: no zoom dose adaption
                     _STORE_NGS                829   Store NGS stream as single image
                                                     (similar to _STORE_MONITOR)
                     _OPENAPPS_MAN_IMG_TRANS   830   Manual image transfer from imaging
                                                     system to AppHost
                     _STORE_SNAPSHOT           832   store a snapshot (cummulated fluoro
                                                     image)
                     _3D_SCAN_PLANE            837   Param: 0 = ACS_NO_INFORMATION, 1 =
                                                     ACS_SCAN_PLANE_ORB, 2 =
                                                     ACS_SCAN_PLANE_ANG
                     _3D_SCAN_OBJECT           838   Param: 0 = ACS_NO_INFORMATION, 1 =
                                                     Tissue, 2 = Bone
                     _3D_SCAN_QUALITY          839   Param: 0 = ACS_NO_INFORMATION, 1 =
                                                     Standard, 2 = High
                     _3D_NAVI_ACTIVE           840
                     _3D_SCAN_PAT_ORIENTATION  841   Param: 0 = ACS_NO_INFORMATION, 1 =
                                                     supine, 2 = prone, 3 = left, 4 = right
                     _3D_SCAN_SYS_POSITION     842   Param: 0 = ACS_NO_INFORMATION, 1 =
                                                     left, 2 = right, 3 = head, 4 = foot
                     _ZOOM_PAN_MENU            843   Indicates, that the zoom / pan menu has
                                                     been opened (param=1) or closed
                                                     (param=0)
                     _SYSUNLOCK_ON_REQ         844   Request to show the Hipaa login dialog
                     _KVM_SWITCH_CONTROL       900   Request to AppHost to switch KVM to
                                                     regular fluoro.
                                                     0 = No changes, 1 = Switch to fluoro
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDEINBL

Object: SBEDEINBL ___ID: 006B

Description: collimation control; send from control console to XCU
Sender     :   CCU-IF   RAD-STD   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEEINBL Function code for collimation
PARAM for insert operations: -1=close; 1=open; -2=close completely; 2=open completely
for rotation operations: -1counter clockwise; 1=clockwise; 2=set to 0° position
          Type:  Enum16     (DEC)
          Range: 550 ... 580
                     LICHTVISIER_EIN_AUS     550   lightmarker on/off
                     RECHTECKBLENDE_LAENGS   551   rectangular collimator height
                     RECHTECKBLENDE_QUER     552   rectangular collimator width
                     KREISBLENDE             553   iris collimator
                     FINGERBLENDE_DREHEN     554   rotate finger
                     FINGERBLENDE_EINFAHREN  555   insert finger
                     KONTBLENDE_DREHEN       556   rotate wedges
                     KONTBLENDE_1_EIN_AUS    557   insert wedge 1
                     KONTBLENDE_2_EIN_AUS    558   insert wedge 2
                     RECALL_LETZTE_WERTE     559   recall last stored values of collimator
                     AUSTAUSCH_KONTBLENDE    560   exchange wedges
                     AUSTAUSCH_KONTBLENDE_1  561   exchange wedge 1
                     AUSTAUSCH_KONTBLENDE_2  562   exchange wedge 2
                     DREHEN_KONTBLENDE_1     563   rotate wedge 1
                     DREHEN_KONTBLENDE_2     564   rotate wedge 2
                     HTB_AUSFAHREN           565   home position (out) for all wedges and
                                                   finger
                     KREISF_EINBLENDUNG      566   select iris collimator
                                                   PARAM: 0=rectangular collimator; 1=iris
                                                   collimator
                     BLENDENSELEKT           567   select collimator
                                                   PARAM: 0=none selected; 1=heigth;
                                                   2=width; 3=iris; 4=finger; 5=wedge1;
                                                   6=wedge2; 7=heart1; 8=heart2; 9-16=HTB1-8
                     BLENDE_SPERREN          568   Collimation is locked for manual and OGP
                                                   settings; PARAM: 0 = unlock collimator; 1
                                                   = lock collimator
                     MOV_SQUARE_LAMELLA      569   move fixed square collimator (for surgery
                                                    system)
                     MOV_IMAGE_LAMELLA       570   move rotatable square collimator (used in
                                                   surgery system)
                     MOV_SLOT_LAMELLA_1      571   move first leaf of slot collimator for
                                                   surgery
                     MOV_SLOT_LAMELLA_2      572   move second leaf of slot collimator for
                                                   surgery
                     ROT_SQUARE_LAMELLA      573   rotate fixed square collimator (for
                                                   surgery  system)
                     ROT_IMAGE_LAMELLA       574   rotate rotatable square collimator (used
                                                   in surgery system)
                     ROT_SLOT_LAMELLA_1      575   rotate first leaf of slot collimator for
                                                   surgery
                     ROT_SLOT_LAMELLA_2      576   rotate second leaf of slot collimator for
                                                   surgery
                     MOV_SLOT_LAMELLA_1_2    577   move synchronously first and second leaf
                                                   of slot collimator for surgery
                     ROT_SLOT_LAMELLA_1_2    578   rotate synchronously first and second
                                                   leaf of slot collimator for surgery
                     SLOT_AUSFAHREN          579   home position (out) for all slot
                                                   collimators
                     COMBI_LIGHT_HOR_VERT    580   directly set values for horizontal and
                                                   vertical collimation (in 0.1mm) and also
                                                   switch on light
                                                   PARAM: height
                                                   PARAM2: width
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

PARAM2 second parameter for sBed-telegrams (so far just used in sBedEinbl for code 580)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none


SBEDGEN

Object: SBEDGEN ___ID: 0066

Description: generator data control; send from control console to XCU
Sender     :   FLC   SCU   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEGEN Function code for generator
          Type:  Enum16     (DEC)
          Range: 200 ... 263
                     KV                     200   400...1500 (0.1kV) or +/-
                     MAS                    201   sBedGen: 50...8000 (0.1mAs) or +/-
                                                  sBedGen2:500...80000 (0.01mAs) or +/-
                     MS                     202   sBedGen: 20...10000 (ms) or +/-
                                                  sBedGen2: 200...100000 (0.1ms) or +/-
                     ION_EMPFINDLICHKEIT    203   iontomat sensitivity; this is used to set
                                                  the dose
                                                  In surgery the following values are used:
                                                  0=low, 1=normal, 2=high; -1=toggle thru
                                                  values
                     MESSFELD               204   measuring field (PARAM is defined like
                                                  parameter GEWMESSF in iIonAnz)
                     _3_PUNKT_MIT_IONTOMAT  205   0= no action;1= change mode
                     SCHWAERZUNG            206   blackening correction  (-16..+16(1/4EP))
                     FOKUS                  207   tube focus (1=small; 2=large)
                     ROEHRENAUSLASTUNG      208   tube load (in percent)
                     REDUZIERUNG_1_PUNKT    209   Reducing the start value for 1 point
                                                  technique for paediatric purposes or thin
                                                  patients; PARAM: 0 = Reduction off; 1 =
                                                  Reduction on
                     LIMIT_RESET            213   reset limit
                     SCHWAERZ_ADD           214   additional blackening correction
                                                  (-16..+16(1/4EP))
                     REG_STOP_CORRECTION    215   This allows to adjust the dose during
                                                  RegStop in units of .25 EPs
                                                  (Belichtungspunkte).
                                                  This is needed in surgery systems.
                     REG_STOP_AUFNAHME      216   This code is used to switch on (or off)
                                                  the regulation stop during acquisition.
                                                  This is needed in surgery systems.
                                                  PARAM=1 turn on regulation during acq,
                                                  PARAM=2 turn off regulation
                     ACQ_MODE               217   If send with BEDIENOBJ=4 the meaning of
                                                  PARAM is:
                                                  1 - fluoro; 2 - roadmap; 3 - sub; 4 - DR;
                                                  5 - DCM; 6 - 3D
                                                  If sent with BEDIENOBJ=3 the meaning of
                                                  PARAM is:
                                                  1- toggle to next mode; (-1 - toggle to
                                                  previous mode)
                     GEN_IEC_TEST           218   requests that the system makes a shot with
                                                  nominal power (for IEC testing)
                     DOSE_LEVEL             219   dose level (used in surgery)
                                                  1=low; 2=normal; 3=high
                     DL_RESET               250   fluoro data reset
                     DL_HUPE_RESET          251   fluoro buzzer/timer reset
                     DL_PROGR               252   select fluoro program
                     DL_STOP                253   fluoro regulation stop
                     DL_MFELD               254   fluoro measuring field
                                                  (0=round;1=l;2=m;3=l+m;4=r;5=l+r;6=m+r;7=l
                                                  +m+r)
                     KV_HAND                255   manual kV for fluoro
                                                  400...1100 (0.1kV) or +/-
                     DLSUPERVISION          256   fluoro supervision
                     DLROADMAP              257   fluoro roadmap
                                                  PARAM: 1=roadmap on; 0=roadmap off; -1=
                                                  toggle
                     KV_MAN                 258   400...1500 (0.1kV) oder +/-
                     MA_MAN                 259   manual mA for fluoro
                                                  1.. 2500 /0.01 mA
                     DLPULSFREQU            260   fluoro framerate steps (PARAM: 1...5 or
                                                  +/-)
                     SKDOSE_BUZZ_RESET      261   reset skin dose limit warning
                     DLPULSFREQU_VAL        262   BEDIENOBJ=2: step to next pulse rate
                                                  BEDIENOBJ=4: fluoro pulse rate value in
                                                  0.1 pulses/sec
                     DLDOSE                 263   desired target dose (="quality") for
                                                  fluoro
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDGEN2

Object: SBEDGEN2 ___ID: 00B1

Description: generator data control; sent from TUI If or ImageSystem to XCU
Sender     :   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEGEN Function code for generator
          Type:  Enum16     (DEC)
          Range: 200 ... 263
                     KV                     200   400...1500 (0.1kV) or +/-
                     MAS                    201   sBedGen: 50...8000 (0.1mAs) or +/-
                                                  sBedGen2:500...80000 (0.01mAs) or +/-
                     MS                     202   sBedGen: 20...10000 (ms) or +/-
                                                  sBedGen2: 200...100000 (0.1ms) or +/-
                     ION_EMPFINDLICHKEIT    203   iontomat sensitivity; this is used to set
                                                  the dose
                                                  In surgery the following values are used:
                                                  0=low, 1=normal, 2=high; -1=toggle thru
                                                  values
                     MESSFELD               204   measuring field (PARAM is defined like
                                                  parameter GEWMESSF in iIonAnz)
                     _3_PUNKT_MIT_IONTOMAT  205   0= no action;1= change mode
                     SCHWAERZUNG            206   blackening correction  (-16..+16(1/4EP))
                     FOKUS                  207   tube focus (1=small; 2=large)
                     ROEHRENAUSLASTUNG      208   tube load (in percent)
                     REDUZIERUNG_1_PUNKT    209   Reducing the start value for 1 point
                                                  technique for paediatric purposes or thin
                                                  patients; PARAM: 0 = Reduction off; 1 =
                                                  Reduction on
                     LIMIT_RESET            213   reset limit
                     SCHWAERZ_ADD           214   additional blackening correction
                                                  (-16..+16(1/4EP))
                     REG_STOP_CORRECTION    215   This allows to adjust the dose during
                                                  RegStop in units of .25 EPs
                                                  (Belichtungspunkte).
                                                  This is needed in surgery systems.
                     REG_STOP_AUFNAHME      216   This code is used to switch on (or off)
                                                  the regulation stop during acquisition.
                                                  This is needed in surgery systems.
                                                  PARAM=1 turn on regulation during acq,
                                                  PARAM=2 turn off regulation
                     ACQ_MODE               217   If send with BEDIENOBJ=4 the meaning of
                                                  PARAM is:
                                                  1 - fluoro; 2 - roadmap; 3 - sub; 4 - DR;
                                                  5 - DCM; 6 - 3D
                                                  If sent with BEDIENOBJ=3 the meaning of
                                                  PARAM is:
                                                  1- toggle to next mode; (-1 - toggle to
                                                  previous mode)
                     GEN_IEC_TEST           218   requests that the system makes a shot with
                                                  nominal power (for IEC testing)
                     DOSE_LEVEL             219   dose level (used in surgery)
                                                  1=low; 2=normal; 3=high
                     DL_RESET               250   fluoro data reset
                     DL_HUPE_RESET          251   fluoro buzzer/timer reset
                     DL_PROGR               252   select fluoro program
                     DL_STOP                253   fluoro regulation stop
                     DL_MFELD               254   fluoro measuring field
                                                  (0=round;1=l;2=m;3=l+m;4=r;5=l+r;6=m+r;7=l
                                                  +m+r)
                     KV_HAND                255   manual kV for fluoro
                                                  400...1100 (0.1kV) or +/-
                     DLSUPERVISION          256   fluoro supervision
                     DLROADMAP              257   fluoro roadmap
                                                  PARAM: 1=roadmap on; 0=roadmap off; -1=
                                                  toggle
                     KV_MAN                 258   400...1500 (0.1kV) oder +/-
                     MA_MAN                 259   manual mA for fluoro
                                                  1.. 2500 /0.01 mA
                     DLPULSFREQU            260   fluoro framerate steps (PARAM: 1...5 or
                                                  +/-)
                     SKDOSE_BUZZ_RESET      261   reset skin dose limit warning
                     DLPULSFREQU_VAL        262   BEDIENOBJ=2: step to next pulse rate
                                                  BEDIENOBJ=4: fluoro pulse rate value in
                                                  0.1 pulses/sec
                     DLDOSE                 263   desired target dose (="quality") for
                                                  fluoro
          Dimension: none

PARAM_32 content and meaning of this parameter depends on the code of the previous parameter
          Type:  Integer32     (DEC)
          Range: -2147483647 ... 2147483647
                     RUECKWAERTS          -1
                     BILDDRHUNG_0         0
                     LOSGELASSEN          0
                     TASTE_LOSLASSEN      0
                     BILDDRHUNG_90        1
                     GEDRUECKT            1
                     TASTE_GEDRUECKT      1
                     TASTE_PLUS_REPEAT    1
                     VORWAERTS            1
                     BILDDRHUNG_180       2
                     TASTE_PLUS_DRUCK_1   2
                     BILDDRHUNG_270       3
                     TASTE_MINUS_REPEAT   3
                     TASTE_MINUS_DRUCK_1  4
          Dimension: depends on FKTSCODEGEN


SBEDGG

Object: SBEDGG ___ID: 0064

Description: control of stand and gantry movements; send from control console to XCU
Sender     :   FLC   RAD-STD   SCU-IF   TUI-IF   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

ANZCODE code of the parameter being transferred in PARAM
          Type:  Enum16     (DEC)
          Range: 0 ... 131
                     A_FFA_STRAHLER                  0     SID tube
                     A_ISOCENTER_HOEHE               1     isocenter height
                     A_TARGET_LAENGS                 2     target longitudinal
                     A_TARGET_QUER                   3     target transversal
                     A_TARGET_HEBEN_SENKEN           4     target lift
                     A_TARGET_DREHEN                 5     rotate target
                     A_SCHWENKWINKEL_SAEULE          6     angle of column
                     A_TUBUSKRAFT                    7     force of tubus
                     A_TISCHPLATTENDREHUNG           8     rotate table
                     A_FFA_TARGET                    9     SID target (SID forecast)
                     A_TISCH_HOEHE                   10    table height
                     A_TISCH_GERAET_KIPPEN           11    table tilt
                     A_TISCH_LAENGS                  12    table longitudinal
                     A_TISCH_QUER                    13    table transversal
                     A_KIPPMULDE                     14    baby cradle
                     A_SCHICHTHOEHE                  15    tomo height
                     A_GERAET_HEBEN_SENKEN           16    lift gantry
                     A_TUBE_ROT_HOR                  17    horizontal rotation of tube of
                                                           Rad system
                     A_STRAHLER_LAENGS               18    tube longitudinal
                     A_STRAHLER_QUER                 19    tube transversal
                     A_SHOCKHEAD_POSITION            20
                     A_TUBUS_IM_STRAHLENGANG         21    tubus (compression unit)
                     A_C_BOGEN_ORBITAL               22    position in 0.1 degree (signed
                                                           word)
                     A_C_BOGEN_ANGULAR               23    position in 0.1 degree (signed
                                                           word)
                     A_ISOCENTER_LAENGS              24    longitudinal position related to
                                                           patient
                                                           used by image system for care
                                                           graphics
                     A_FFA_BEWEGUNG                  25    SID Movement
                     A_SID_VALID_INVALID             26    SID valid or invalid (in low cost
                                                           systems there is no potentiometer
                                                           to acquire the SID continuously,
                                                           there are only two switches for
                                                           upper and lower SID. If the tube
                                                           is in between both positions, the
                                                           collimators cannot be calculated
                                                           because they require the exact
                                                           position. In order not to expose
                                                           more space than necessary, X-ray
                                                           is blocked if SID is invalid.
                                                           PARAM: 0=manual determined, 1=SID
                                                           valid, 2=SID invalid
                     A_CALIB_SWITCH                  27    Calibration switch in Ysio
                                                           stand.
                                                           PARAM: 0=No Information, 1=on,
                                                           2=off
                     A_SID_OR_SOD                    28    ==== in sBedGG: ====
                                                           Information whether SID or SOD
                                                           Button is pressed to determine
                                                           which one is measured manually by
                                                           using the tape of the collimator.
                                                           Sent from TUI If to XCU.
                                                           Param: 0 = no information; 1 =
                                                           SID; 2 = SOD
                                                           ==== in iGGAnz: ====
                                                           XCU tells TUI (via TUI Interface)
                                                           whether manual SID or SOD
                                                           measurement is possible. Also
                                                           used to acknowledge the TUI
                                                           operation.
                                                           PARAM: bit-coded, transferred
                                                           into dec:
                                                           0 = nothing possible, nothing
                                                           selected
                                                           1 = SID possible, nothing
                                                           selected
                                                           3 = SID possible, SID selected
                                                           16 = SOD possible, nothing
                                                           selected
                                                           48 = SOD possible, SOD selected
                                                           17 = SID and SOD possible,
                                                           nothing selected
                                                           19 = SID and SOD possible, SID
                                                           selected
                                                           49 = SID and SOD possible, SOD
                                                           selected
                     A_ACSS_POSSIBLE_                29    For Ysio:
                                                           XCU determines, if ACSS is active
                                                           or not and sends information via
                                                           SCU Interface to Stand
                                                           PARAM: 0 = No Information; 1 =
                                                           ACSS not possible; 2 = ACSS
                                                           active
                     A_FFA_STRAHLER_0P               30
                     A_ISOCENTER_HOEHE_0P            31
                     A_TARGET_LAENGS_0P              32
                     A_TARGET_QUER_0P                33
                     A_TARGET_HEBEN_SENKEN_0P        34
                     A_TARGET_DREHEN_0P              35
                     A_SCHWENKWINKEL_SAEULE_0P       36
                     A_KOMPRESSION_0P                37
                     A_TISCHPLATTENDREHUNG_0P        38
                     A_FFA_TARGET_0P                 39
                     A_TISCH_HOEHE_0P                40
                     A_TISCH_GERAET_KIPPEN_0P        41
                     A_TISCH_LAENGS_0P               42
                     A_TISCH_QUER_0P                 43
                     A_KIPPMULDE_0P                  44
                     A_SCHICHTHOEHE_0P               45
                     A_GERAET_HEBEN_SENKEN_0P        46
                     A_STRAHLERDREHUNG_0P            47
                     A_STRAHLER_LAENGS_0P            48
                     A_STRAHLER_QUER_0P              49
                     A_SOD_H                         50    SOD value (in 0.1 mm)
                     A_C_BOGEN_ORBITAL_0P            52
                     A_C_BOGEN_ANGULAR_0P            53
                     A_ZIELGERAET_0P                 54
                     A_AEC_CENTER_Y                  56    offset between detector center
                                                           and center of AEC chamber
                     A_STAND_SPEED                   57    speed class for stand movement:
                                                           1=ACS_SSPEED_SLOW
                                                           2=ACS_SSPEED_MEDIUM
                                                           3=ACS_SSPEED_FAST
                     A_CAREGRAPH_VALID               58    defines if the values for
                                                           careposition/profile
                                                           (ISOCENTER_QUER/_LAENGS) make
                                                           sense
                                                           1=caregraph may be shown
                                                           0=caregraph should not be shown
                     A_ISOCENTER_QUER                59    transversal position related to
                                                           patient
                                                           used by image system for care
                                                           graphics
                     A_UMBAU_1                       60
                     A_UMBAU_2                       61
                     A_UMBAU_3                       62
                     A_UMBAU_4                       63
                     A_UMBAU_5                       64
                     A_MYELOGRAPHIE                  65
                     A_PERI_PROGFAHRT                66
                     A_SCHRITTVERSCHIEBUNG           67
                     A_DET_TABLE_OUT                 68    Detector in table is pulled out.
                                                           0 == detector is in tray
                                                           1 == detector is pulled out
                                                           555 == detector is completely
                                                           pulled out
                     A_DET_WALL_OUT                  69    Detector in wall stand is pulled
                                                           out.
                                                           0 == detector is in tray
                                                           1 == detector is pulled out
                                                           555 == detector is completely
                                                           pulled out
                     A_FESTPOSITION_1                70    peri pos 1
                     A_FESTPOSITION_2                71    peri pos 2
                     A_FESTPOSITION_3                72
                     A_FESTPOSITION_4                73
                     A_FESTPOSITION_5                74
                     A_FESTPOSITION_6                75
                     A_FESTPOSITION_7                76
                     A_FESTPOSITION_8                77
                     A_CENTRAL_BEAM_HITS             78    the x-ray beam does not or does
                                                           only partially hit the detector,
                                                           such that fluoro must be blocked
                     A_FESTPOSITION_10               79    peri pos 10
                     A_ZIELGERAET_BR                 80    brakes of SFD
                     A_KOMPRESSION_BR                81    brakes of compression
                     A_ZG_TISCHMITTE_BR              82    spotfilm device brake
                     A_ZG_PARKPOSITION_BR            83    park pos brake
                     A_BREMSE_5_BR                   84
                     A_BREMSE_6_BR                   85
                     A_BREMSE_7_BR                   86
                     A_BREMSE_8_BR                   87
                     A_BREMSE_9_BR                   88
                     A_PERISCAN                      89
                     A_POSSYS                        90    positioning detector to tube
                                                           (alignment),
                                                           Meaning of PARAM:
                                                           0=ACS_NO_INFORMATION
                                                           1=MITTIG_ZENTRIERT (aligned to
                                                           center)
                                                           2=OBEN_ZENTRIERT (aligned to
                                                           upper border)
                                                           3=MITTIG_ZENTRIERT_NICHT_ERR
                                                           (center not reached)
                                                           4=OBEN_ZENTRIERT_NICHT_ERR (top
                                                           not reached)
                     A_NACHLAUF                      91    tracking mode
                                                           Meaning of Param in sBedGG:
                                                           0=both tracking functions off
                                                           2=SID tracking off / XY tracking
                                                           on
                                                           8=SID tracking on / XY tracking
                                                           off
                                                           10=both tracking functions on
                                                           Meaning of Param in other
                                                           telegrams:
                                                           ( _T_ means _TRACKING_)
                                                           0=ACS_NO_INFORMATION
                                                           1=ACS_T_X_Y_OFF
                                                           2=ACS_T_X_Y_ON
                                                           3=ACS_T_X_Y_LOST
                                                           4=ACS_T_SID_OFF
                                                           5=ACS_T_BOTH_OFF
                                                           6=ACS_T_X_Y_ON_SID_OFF
                                                           7=ACS_T_X_Y_LOST_SID_OFF
                                                           8=ACS_T_SID_ON
                                                           9=ACS_T_X_Y_OFF_SID_ON
                                                           10=ACS_T_BOTH_ON
                                                           11=ACS_T_X_Y_LOST_SID_ON
                                                           12=ACS_T_SID_LOST
                                                           13=ACS_T_X_Y_OFF_SID_LOST
                                                           14=ACS_T_X_Y_ON_SID_LOST
                                                           15=ACS_T_BOTH_LOST
                     A_TIEFENBLENDE_GEDREHT          92    collimator rotated
                     A_SPINE_CONSTRUCTION            93
                     A_CARE_POSITION                 94    enable/disable care position,
                                                           virtual table movement in Last
                                                           image hold
                     A_TIEFENBLENDE_HOR_DEZENTRIERT  95    collimator horizontal not
                                                           centered
                                                           PARAM: 1=yes; 0=no
                     A_CHANGE_ORIENTATION            96    PARAM: Bit1: horizontal
                                                           (transversal) 0=off, 1=on
                                                                          Bit2: vertical
                                                           (longitudinal) 0=off, 1=on
                                                                          Bit3: orientation:
                                                           0=stand, 1=monitor
                     A_WIGGLE_FUNCTION               97    PARAM: 1=on; 0=off
                     A_DETECTOR_ORIENTATION          98    For Ysio: Orientation of detector
                                                           relative to normal patient
                                                           position.
                                                           Param:
                                                           1= Position 1, Pixel (0,0) in
                                                           upper left corner (0°)
                                                           2= Position 2, Pixel (0,0) in
                                                           upper right corner (90°
                                                           clockwise)
                                                           3= Position 3, Pixel (0,0) in
                                                           lower right corner (180°
                                                           clockwise)
                                                           4= Position 4, Pixel (0,0) in
                                                           lower left corner (270°
                                                           clockwise)
                     A_MAGNIFICATION                 99    Factor of magnification of
                                                           objects, i.e. relation between
                                                           SID and SOD (in %)
                     A_TOP_ALIGN_POSSIBLE            100   SCU reports if top alignment is
                                                           possible (i.e. if tilt angle
                                                           <20°)
                                                           PARAM: 0=no; 1=yes
                     A_BEAM_ANGLE_ALPHA              101
                     A_TUBE_ROT_VERTICAL             102
                     A_BEAM_POS_X                    103   Offset of the central beam
                                                           relating to the center of the FD
                                                           in 0.1mm
                     A_BEAM_POS_Y                    104   Offset of the central beam
                                                           relating to the center of the FD
                                                           in 0.1mm
                     A_DET_WALL_TILT                 105   Tilting angle of detector in wall
                                                           stand.
                                                           Value in param in 0.1°
                     A_POSITION_VALID_FOR_STORAGE    106   Information whether a stand
                                                           position is valid to be stored in
                                                           an organ program.
                                                           Param: 0: no information, 1:
                                                           position is valid, 2: position is
                                                           not valid
                     A_MOVING_BEAM                   107   Limits for decentered ACSS shall
                                                           only be updated when stand is not
                                                           in motion
                                                           Param: 0: Beam is stopped, 1:
                                                           Beam is moving
                     A_MOVING_DETECTOR               108   Limits for decentered ACSS shall
                                                           only be updated when stand is not
                                                           in motion
                                                           Param: 0: Detector is stopped, 1:
                                                           Detector is moving
                     A_MOVING_TABLE                  109   Limits for decentered ACSS shall
                                                           only be updated when stand is not
                                                           in motion
                                                           Param: 0: Table is stopped, 1:
                                                           Table is moving
                     A_AUTO_MOVEMENT                 110   stand performs automatic
                                                           movement:
                                                           0 = ACS_AUTO_MOVEMENT_INACTIVE
                                                           1 = ACS_AUTO_MOVEMENT_ACTIVE
                                                           2 = ACS_AUTO_MOVEMENT_PENDING
                     A_ORTHO_POS1                    111   Param: ACS_ORTHOPOS_NOT_SET,
                                                           ACS_ORTHOPOS_SET,
                                                           ACS_ORTHOPOS_INVALID
                     A_ORTHO_POS2                    112   Param: ACS_ORTHOPOS_NOT_SET,
                                                           ACS_ORTHOPOS_SET,
                                                           ACS_ORTHOPOS_INVALID
                     A_TDD                           113   table detector distance in 0.1mm
                     A_ORTHO_STEP                    114   current step (or state) in the
                                                           ortho flow:
                                                           1 not in Ortho position (Move
                                                           button has to be pressed)
                                                           2 mark first ortho pos
                                                           3 mark second ortho pos
                                                           4 ready to move to first Image
                                                           pos
                                                           5 ready for apply X-ray
                                                           6 X-ray is running
                                                           7 X-ray is over and stand is
                                                           moving to ortho start pos
                                                           8 ortho is completed
                                                           9 ortho is finished
                                                           10 ortho is aborted
                                                           11 ortho cannot be started
                     A_SOFTSTOP                      115   activates or deactivates the
                                                           SoftStop function
                     A_PATIENT_TRANSFER              116   param: 1=on, 0=off
                     A_TOMOADJUST                    117   system shall move to a position
                                                           in which the tomo fulcrum height
                                                           (Schichthöhe) can be adjusted
                                                           using the laser line of the
                                                           collimator
                     A_MOVE_DISABLE                  118   any movement blocked on users
                                                           request
                     A_BEAM_ANGLE_BETA               119
                     A_FINAL_POSITION_REACHED        120   The OGP position is reached. This
                                                           value is taken as a trigger to
                                                           (re)send the OGP collimation
                                                           values to the collimator
                     A_STORE_POS                     121   store the current stand position
                                                           (PARAM contains the position
                                                           number); used in urology
                     A_RECALL_POS                    122   recall the previously stored
                                                           stand position; used in urology
                     A_COLOR_ORBITAL                 123   defines the color of the display
                                                           of orbital c-arm angle
                                                           PARAM is divided into two enums:
                                                           bit 7-0: COLOR; bit 15-8: ARROW
                                                           with COLOR: 0-don't care,
                                                           1-normal, 2-out of range, 3-in
                                                           range, 4-pos reached
                                                           and ARROW: 0-don't care, 1-no
                                                           arrow, 2-left/up, 3-right/down,
                                                           4-pos reached
                     A_COLOR_ANGULAR                 124   defines the color of the display
                                                           of angular c-arm angle
                                                           PARAM is divided into two enums:
                                                           bit 7-0: COLOR; bit 15-8: ARROW
                                                           with COLOR: 0-don't care,
                                                           1-normal, 2-out of range, 3-in
                                                           range, 4-pos reached
                                                           and ARROW: 0-don't care, 1-no
                                                           arrow, 2-left/up, 3-right/down,
                                                           4-pos reached
                     A_BYPASS_PARK_POS               125   (used in Luminos Fusion)
                     A_STORE_C_ANGLE                 126   store current c-arm angles (used
                                                           in surgery)
                                                           PARAM=0: disable storage
                                                           PARAM=n store to memory position
                                                           n
                     A_RECALL_C_ANGLE                127   PARAM contains the position
                                                           number to be recalled. XCU uses
                                                           this to determine, which position
                                                           shall be compared to iGGActPos
                                                           (used in surgery)
                     A_SET_RESET_3D_ENDPOS           128   Param: 0 = ACS_NO_INFORMATION, 1
                                                           = Set end position, 2 = Reset end
                                                           position
                     A_SET_RESET_3D_STARTPOS         129   Param: 0 = ACS_NO_INFORMATION, 1
                                                           = Set start position, 2 = Reset
                                                           start position
                     A_MANUAL_ALIGNMENT_KIT          130   new parameter for ACSS process
                                                           when manual table's alignment kit
                                                           is loosened.
                                                           Used for reporting the
                                                           alignment-kit's status in manual
                                                           tube stand, eg telling whether
                                                           tube stand and detector is
                                                           aligned. Belongs to ACSS's
                                                           function for manual tube stand
                                                           configuration.
                     A_CP_POSITION_MATCH             131   The (relative or absolute) CP
                                                           position is more or less reached
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDKS

Object: SBEDKS ___ID: 0065

Description: control of cassette system; send from control console to XCU
Sender     :   CCU-IF   RAD-STD   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEKS Function code for cassette system
          Type:  Enum16     (DEC)
          Range: 100 ... 105
                     ENTLADETASTE          100   unload cassette
                     KASETTENTEILUNG_PROG  101   cassette subdivision
                     UNTERTEILUNG_WEITER   102   next subdivision
                     START_PROG_MISCHPROG  103   start mix program
                     STOP_PROG_MISCHPROG   104   stop mix program
                     SPEICHERN_MISCHPROG   105   store program
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDORG

Object: SBEDORG ___ID: 0069

Description: organ program selection; send from control console to XCU
Sender     :   FLC   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEORG Function code for organ program selection
          Type:  Enum16     (DEC)
          Range: 450 ... 459
                     REGION                      450   region number
                     ORGAN                       451   organ number
                     DICK_DUENN_KORREKTUR        452   transparency correction
                     UEBERNAHME_EIN_0_PUNKT      453   0-pnt technique on
                     UEBERNAHMEKENNLINIE         454   0-pnt- exposure curve number
                     PROGRAMM_SPEICHERN          455   store program
                     SET_ORGANPAR_GERAET         456   set organ program parameter of the
                                                       stand
                     HIDE_ORGANPAR_GERAET        457   hide organ program parameter
                     ALTERNATIVE_OGP             458   Alternative organ program was chosen
                                                       (Ysio)
                     SEL_OGP_FROM_DEFAULT_GROUP  459   select an application (organ) from
                                                       the default group (default region)
                                                       (used in surgery)
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDSP

Object: SBEDSP ___ID: 0067

Description: control of series parameter; send from control console to XCU
Sender     :   FLC   SCU   TUI-IF   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODESP Function code for series parameters
          Type:  Enum16     (DEC)
          Range: 300 ... 308
                     SERIE_EINZELBILD        300   series (0=single;1=series)
                     BILDFREQUENZ            301   frame rate (in 0.1f/s)
                     DOSIS_BILD              302   dose per frame (in nGy)
                     MAX_AUFNAHMEZEIT        303   max exp time (in ms)
                     REGSTOP_WAEHREND_SZENE  304   regulation stop in a series (0=no stop;
                                                   1=regstop)
                     KV_FUER_DOSISREDUKTION  305   kV for dose reduction
                     MAX_SZENEZEIT           306   max scene time (in s)
                     SUBTRAKTION_DSA         307   subtraction (0=off; 1=on)
                     BFREQ_RED               308   reduce frame rate (1=next framerate)
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDSTRM

Object: SBEDSTRM ___ID: 006A

Description: collimator control ; send from control console to XCU
Sender     :   CCU-IF   RAD-STD   TUI-IF   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODESTRM Function code for collimator control
          Type:  Enum16     (DEC)
          Range: 500 ... 506
                     FILTER_EINFAHREN  500   CU filter number (for acquisition)
                     RASTER            501   grid number (0=no grid)
                     FORMATKONTROLLE   504   check format (0=off; 1=on)
                     FILTERAUTOMATIK   505   filter automatic (0=off; 1=on)
                     FILTER_DL         506   directly control copper filter for fluoro
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDSYS

Object: SBEDSYS ___ID: 0068

Description: system selection; send from control console to XCU
Sender     :   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODESYS Function code for system selection
          Type:  Enum16     (DEC)
          Range: 400 ... 400
                     SYSTEMAUSWAHL  400   select system
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDTOMO

Object: SBEDTOMO ___ID: 0075

Description: tomo control; send from control console to XCU
Sender     :   CCU-IF   RAD-STD   TUI-IF
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODETOMO Function code for tomography
          Type:  Enum16     (DEC)
          Range: 270 ... 274
                     SCHICHTPROGRAMM    270   tomo program
                     TOMO_STEP_AUTO     271   Tomostep auto
                     TOMO_STEP_UP_DOWN  272   Tomostep (1=up; -1=down)
                     TOMOSCHRITTWEITE   273   tomo step width
                     TOMO_TESTRUN       274   Tomo Testrun for Ysio. PARAM: 0 = no
                                              information; 1= testrun
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDVCU

Object: SBEDVCU ___ID: 00C8

Description: VideoManager control; send from control panel to XCU
Sender     :   FLC   SCU   TUI-IF   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BEDEINH type of user interface. This parameter is currently only important for exposure release (sAuslBed) in order to allow exposures only from the dedicated device;
and sBedStrm (Filter) in order to find the difference whether a filter is controlled by the collimator or by the RCC/TUI
          Type:  Enum8     (DEC)
          Range: 0 ... 34
                     ACS_NO_INFORMATION           0
                     GERAETENAHBEDIENUNG          1    stand control console
                     GERAETEFERNBEDIENUNG         2    remote control console
                     ZENTRALBEDIENUNG             3    standard control console
                     BLENDENBEDIENUNG             4    collimator control console
                     GENERATORBEDIENUNG           5    generator control console
                     DFR_BEDIENUNG                6    DFR control console
                     PATIENTENEINGABE             7    patient data control console
                     SONSTIGE_BEDIENUNG           8    other control console
                     SERVICEPC                    9
                     ACS_REMOTE_SWITCH_1          11   Xray release switch on RCC 1 (control
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_1      12   Xray release footswitch on RCC 1
                                                       (control room)
                     ACS_REMOTE_SWITCH_2          13   Xray release switch on RCC 2 (exam
                                                       room)
                     ACS_REMOTE_FOOTSWITCH_2      14   Xray release footswitch on RCC 2
                                                       (exam room)
                     ACS_REMOTE_SWITCH_3          15   Xray release switch on TUI 3
                     ACS_REMOTE_FOOTSWITCH_3      16   Xray release footswitch on TUI 3
                     ACS_REMOTE_JOYSTICKSWITCH_1  17   Xray release joystick-switch on TUI 1
                     ACS_REMOTE_JOYSTICKSWITCH_2  18   Xray release joystick-switch on TUI 2
                     ACS_REMOTE_JOYSTICKSWITCH_3  19   Xray release joystick-switch on TUI 3
                     ACS_FOOTSW1_PEDAL1           20   primary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL2           21   secondary footswitch pedal (used in
                                                       surgery)
                     ACS_FOOTSW1_PEDAL3           22   primary basic footswitch pedal acts
                                                       like the handswitch
                                                       (used in surgery)
                     ACS_FOOTSW1_PEDAL4           23   footswitch configured as button for
                                                       store image/scene
                     ACS_FOOTSW2_PEDAL1           30   primary footswitch pedal of wireless
                                                       footswitch (used in surgery)
                     ACS_FOOTSW2_PEDAL2           31   secondary footswitch pedal of
                                                       wireless footswitch (used in surgery)
                     ACS_FOOTSW_WIRELESS          32   wireless footswitch (used in TRUF)
                     ACS_LITHOTRIPTER             34   x-ray switch at lithotripter
          Dimension: none

BEDIENOBJ type of the control element
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION        0
                     EIN_AUS_TASTE             1   On/off button
                                                   This type allows values "EIN" and "AUS"
                     DRUCKORIENTIERTE_TASTE    2   This code is used to transfer a trigger
                                                   event (e.g. from a pushbutton); thus just
                                                   value "EIN" is allowed
                     PLUS_MINUS_TASTEN         3   plus/minus button(s)
                                                   meaning of PARAM: 0: off; 1: "++"; 2:
                                                   "+"; 3:"--"; 4: "-"
                     SELEKTIONSTASTEN          4   selection buttons / radio buttons
                     EIN_AUS_BEDIENHEBEL       5   on/off lever (joystick)
                     AUSSCHLAGABH_BEDIENHEBEL  6   potentiometer joystick
          Dimension: none

FKTSCODEVCU function code for VideoManager control
          Type:  Enum16     (DEC)
          Range: 650 ... 680
                     STORE_VIDEO_ENDO_IMAGE  650   this command instructs VideoManager to
                                                   store the image being currently shown
                                                   (i.e. to send it via DICOM to Image
                                                   System)
                     SWITCH_NEXT_INPUT       651   this command instructs VideoManager to
                                                   switch to next input channel
                     SCAN_INPUT_SIGNALS      652   used to instruct VideoManager to scan for
                                                   and adapt to signals on all input
                                                   channels (1=start, 0=abort)
                                                   also used to show status of scanning
                                                   (1=busy, 0=ready)
                     SHOW_PIP                653   show picture in picture
                     SELECT_INPUT            654   select a specific input (number given in
                                                   PARAM)
                                                   range is 0-13
                     SWITCH_KVM              680   switch KVM between FLC and ApplHostPC
                                                   (used in surgery)
                                                   0=FLC; 1=ApplicationHosting PC;
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEDZOOM

Object: SBEDZOOM ___ID: 0070

Description: request to change the zoom; send from control console to XCU
Sender     :   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBETRIEB

Object: SBETRIEB ___ID: 000E

Description: selected component shall leave service mode and switch to normal mode; sent
              from XCU to component
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs
This object has no parameters


SBETRIEBSART

Object: SBETRIEBSART ___ID: 0191

Description: X-ray mode the system is in, sent from XCU to stand/gantry
              Not used in surgery systems.
Sender     :   XCU
Receiver   :   GEN-IF   RAD-STD   SCU-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BETRIEBSART Exposure mode
          Type:  Byte     (DEC)
          Range: 1 ... 10
                     NORMALBETRIEB    1    normal mode (cassette or film mode)
                     SCHICHTBETRIEB   2    tomo
                     DFR_AUFNAHME     3    DFR acquisition (=HW triggered regardless whether
                                           image intensifier or FD is used)
                     DFR_SCHICHTEN    4    DFR Tomo, HW-triggered TOMO and FD Tomo (although
                                           FD Tomo is not HW triggered)
                     PERIPHERE_ANGIO  5    Peristepping
                     DSA_ANGIO        6    Perivision
                     ORTHO_LONGLEG    7    Ortho mode in FD
                     DR_LITHO         8    Litho mode like DFR but with cross hair in image
                     DUAL_ENERGY      9    Dual Energy technique for Ysio
                     RUN_3D           10   acquisition of 3D volume (used in G1)
                                           (similar to DFR series, but different WW
                                           calculation)
          Dimension: none

TARGET target for the exposure (RFU only)
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     BILDVERSTAERKER     0   fixed FD (or image intensifier)
                     FREIEAUFNAHME       1   free exposure
                     RASTERWANDGERAET    2   bucky wall stand
                     KATAPULTRASTERLADE  3   KRL
                     ZIELGERAET          4   spotfilm device
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBEWEGUNG

Object: SBEWEGUNG ___ID: 0190

Description: command for a move of any drive
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ANTRIEB drive: subunit which is able to perform a unit movement
          Type:  Byte     (DEC)
          Range: 0 ... 131
                     FFA_STRAHLER                    0     SID tube
                     ISOCENTER_HOEHE                 1     isocenter height
                     TARGET_LAENGS                   2     target longitudinal
                     TARGET_QUER                     3     target transveral
                     TARGET_HEBEN_SENKEN             4     lift target
                     TARGET_DREHEN                   5     rotate target
                     SCHWENKWINKEL_SAEULE            6     angle of column
                     TUBUSKRAFT                      7     force of tubus
                     TISCHPLATTENDREHUNG             8     rotate table
                     FFA_TARGET                      9     SID target
                     TISCH_HOEHE                     10    table height
                     TISCH_GERAET_KIPPEN             11    table tilt
                     TISCH_LAENGS                    12    table longitudinal
                     TISCH_QUER                      13    table transversal
                     KIPPMULDE                       14    baby cradle
                     SCHICHTHOEHE                    15    tomo height
                     GERAET_HEBEN_SENKEN             16    lift gantry
                     ACS_TUBE_ROT_HOR                17    rotate tube
                     STRAHLER_LAENGS                 18    tube longitudinal
                     STRAHLER_QUER                   19    tube transversal
                     SPAETERE_ANWENDUNG              20    (reserved for future use)
                     TUBUS_EIN_AUSFAHREN             21    move tubus (compression unit)
                     C_BOGEN_ORBITAL                 22    c-arm orbital
                     C_BOGEN_ANGULAR                 23    c-arm angular
                     ISOCENTER_LAENGS                24    isocenter longitudinal
                     FFA_BEWEGUNG                    25    SID movement
                     ACS_SID_VALID_OR_INVALID        26    SID valid or invalid (in low cost
                                                           systems there is no potentiometer
                                                           to acquire the SID continuously,
                                                           there are only two switches for
                                                           upper and lower SID. If the tube
                                                           is in between both positions, the
                                                           collimators cannot be calculated
                                                           because they require the exact
                                                           SID position. In order not to
                                                           expose more space than necessary,
                                                           X-ray is blocked if SID is
                                                           invalid.
                                                           ANTRIEBSTATUS: 0=manual
                                                           determined; 1=Valid; 2=Invalid
                     ACS_CALIBRATION_SWITCH          27    Calibration switch in Ysio
                                                           stand.
                                                           PARAM: 0=No Information, 1=on,
                                                           2=off
                     ACS_SID_OR_SOD                  28    Not in use. Only a placeholder
                                                           for the corresponding ANZCODE.
                     ACS_ACSS_POSSIBLE_              29    For Ysio:
                                                           XCU determines, if ACSS is active
                                                           or not and sends information via
                                                           SCU Interface to stand.
                     ACS_SOD_H                       50    SOD value (in 0.1mm)
                     ACS_AEC_CENTER_Y                56    offset between detector center
                                                           and center of AEC chamber
                     ISOCENTER_QUER                  59    isocenter lateral
                     ACS_AUTO_MOVE_TARGET            66    see parameter
                                                           sh_stpar_rfp.auto_move_target
                     ACS_DET_TABLE_OUT               68    Detector or cassette in table is
                                                           pulled out.
                                                           Meaning of Physposition:
                                                           0:        detector is in tray
                                                           >0:      detector is pulled out
                                                           ACS_INIL: detector is in
                                                           intermediate position
                     ACS_DET_WALL_OUT                69    Detector or cassette in wall
                                                           stand is pulled out.
                                                           Meaning of Physposition:
                                                           0:        detector is in tray
                                                           >0:      detector is pulled out
                                                           ACS_INIL: detector is in
                                                           intermediate position
                     ACS_CENTRAL_BEAM_HITS           78    the x-ray beam does not or does
                                                           only partially hit the detector,
                                                           such that fluoro must be blocked
                     ACS_DETECTOR_ORIENTATION        98    For Ysio: Orientation of detector
                                                           relative to normal patient
                                                           position.
                                                           Physposition:
                                                           1= Position 1, Pixel (0,0) in
                                                           upper left corner (0°)
                                                           2= Position 2, Pixel (0,0) in
                                                           upper right corner (90°
                                                           clockwise)
                                                           3= Position 3, Pixel (0,0) in
                                                           lower right corner (180°
                                                           clockwise)
                                                           4= Position 4, Pixel (0,0) in
                                                           lower left corner (270°
                                                           clockwise)
                     ACS_BEAM_ANGLE_ALPHA            101   Beam angle alpha of tube for Ysio
                     ACS_TUBE_ROT_VERTICAL           102   vertical rotation of tube for
                                                           Ysio
                     ACS_BEAM_POS_X                  103   deviation between center of beam
                                                           towards center of target (FD,
                                                           cassette, I.I.) in patient
                                                           longitudinal direction
                     ACS_BEAM_POS_Y                  104   deviation between center of beam
                                                           towards center of target (FD,
                                                           cassette, I.I.) in patient
                                                           lateral direction
                     ACS_DET_WALL_TILT               105   Tilting angle of detector in
                                                           wallstand.
                                                           Value in physposition in 0.1°
                     ACS_POSITION_VALID_FOR_STORAGE  106   Information whether a stand
                                                           position is valid to be stored in
                                                           an organ program.
                                                           Physposition: 0: no information,
                                                           1: position is valid, 2: position
                                                           is not valid
                     ACS_MOVING_BEAM                 107   Physposition: 0: Beam is stopped
                                                           1: Beam is moving
                     ACS_MOVING_DETECTOR             108   Physposition: 0: Detector (or
                                                           cassette tray) is stopped, 1:
                                                           Detector (or cassette tray) is
                                                           moving
                     ACS_MOVING_TABLE                109   Physposition: 0: Table is
                                                           stopped, 1: Table is moving
                     ACS_AUTO_MOVEMENT               110   stand performs automatic
                                                           movement:
                                                           0 = ACS_AUTO_MOVEMENT_INACTIVE
                                                           1 = ACS_AUTO_MOVEMENT_ACTIVE
                                                           2 = ACS_AUTO_MOVEMENT_PENDING
                     ACS_ORTHO_POS1                  111   Param: ACS_ORTHOPOS_NOT_SET,
                                                           ACS_ORTHOPOS_SET,
                                                           ACS_ORTHOPOS_INVALID
                     ACS_ORTHO_POS2                  112   Param: ACS_ORTHOPOS_NOT_SET,
                                                           ACS_ORTHOPOS_SET,
                                                           ACS_ORTHOPOS_INVALID
                     ACS_TDD                         113   Table Detector Distance in 0.1mm
                     ACS_ORTHO_STEP                  114   current step (or state) in the
                                                           ortho flow::
                                                           1 not in Ortho position (Move
                                                           button has to be pressed)
                                                           2 mark first ortho pos
                                                           3 mark second ortho pos
                                                           4 ready to move to first Image
                                                           pos
                                                           5 ready for apply X-ray
                                                           6 X-ray is running
                                                           7 X-ray is over and stand is
                                                           moving to ortho start pos
                                                           8 ortho is completed
                                                           9 ortho is finished
                                                           10 ortho is aborted
                                                           11 ortho cannot be started
                     ACS_SOFTSTOP                    115   activates or deactivates the
                                                           SoftStop function
                     ACS_PATIENT_TRANSFER            116   param: 1=on; 0=off
                     ACS_TOMOADJUST                  117   system shall move to a position
                                                           in which the tomo fulcrum height
                                                           (Schichthöhe) can be adjusted
                                                           using the laser line of the
                                                           collimator
                     ACS_MOVE_DISABLE                118   block any movement on users
                                                           request
                     ACS_BEAM_ANGLE__BETA            119   Beam angle beta of tube for Ysio
                     ACS_FINAL_POSITION_REACHED      120   The OGP position is reached. This
                                                           value is taken as a trigger to
                                                           (re)send the OGP collimation
                                                           values to the collimator
                     ACS_STORE_POS                   121   store the current stand position
                     ACS_RECALL_POS                  122   recall the previously stored
                                                           stand position
                     ACS_COLOR_ORBITAL               123   see A_COLOR_ORBITAL in ANZCODE
                     ACS_COLOR_ANGULAR               124   see A_COLOR_ANGULAR in ANZCODE
                     ACS_BYPASS_PARK_POS             125   (used in Luminos Fusion)
                     ACS_CP_POSITION_MATCH           131   The (relative or absolute) CP
                                                           position is more or less reached
          Dimension: none

FUNKTION function to be executed
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION      0
                     ANTRIEB_BREMSE_STARTEN  1   release break
                     ANTRIEB_BREMSE_STOPPEN  2   apply brake
          Dimension: none

LOGPOSITION logical position of the drive
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     POS_ENDSTELLUNG     1   positive limit
                     NEG_ENDSTELLUNG     2   negative limit
                     NULL_POSITION       3   zero position
          Dimension: none

GESCHW Speed
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: mm/sec Grad/sec

PHYSPOSITION Physical position of the drive
          Type:  Integer16     (DEC)
          Range: -32000 ... 32000
          Dimension: 0.1 mm,0.1Grad,N

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBILD

Object: SBILD ___ID: 0384

Description: image display on imaging system, sent from XCU to DFR or camera
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

BILD_V Image flip vertical (lower nibble) and rotation (upper nibble)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
                     BILD_V_BUK_AUS_DREHUNG_0  0x00   no flip, no rot
                     BILD_V_BUK_EIN            0x01   flip vertically
                     BILD_V_DREHUNG_90         0x20   rotate by 90° (clockwise)
                     BILD_V_DREHUNG_180        0x40   rotate by 180°
                     BILD_V_DREHUNG_270        0x60   rotate by 270° (clockwise)
          Dimension: none

BILD_H Image flip horizontal
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

AVR_REQUEST control automatic gain control
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     FESTVERSTAERKUNG_1  1   fixed gain 1
                     FESTVERSTAERKUNG_2  2   fixed gain 2
                     AVR_ANFORDERUNG     3   select AGC on
                     AVR_STOP            4   freeze AGC at current value
          Dimension: none

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number


SBLENDENPOS

Object: SBLENDENPOS ___ID: 0321

Description: setting collimators, sent from XCU to collimators
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

COL_TRACKING RFU only:
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_COL_TRACK       1   tracking of collimator blades to keep current
                                             collimation on target stable, following the SID
                                             (as ACS_YES)
                     ACS_COL_NO_TRACK    2   no movement of collimator blades when SID is
                                             changing (as ACS_NO)
                                             in RFU: tracking still enabled but DSA
                                             collimator does no longer follow
                     ACS_COL_TRACK_NONE  3   no moving of colliator blades when SID or
                                             centering is changing (used during 3D run)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BLENDENPOSITION position of the collimator: width for type 1-3 and 8-12, position relative to a zero pos in case of other types (4-6)
A value 0xFFFF means, that collimator shall drive to full open for current zoom level
{          Type:  Word     (DEC)
{          Range: 0 ... 65533
{          Dimension: 0.1 mm

{BLENDENWINKEL angle of the collimator, usually only used for collimators 4 to 16, because 1 to 3 cannot be rotated
{          Type:  Integer16     (DEC)
{          Range: 0 ... 3600
{          Dimension: 0.1 degree

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SBREMSUNG

Object: SBREMSUNG ___ID: 019E

Description: control of brakes; sent from XCU to gantry/stand
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

BREMSE brake command
          Type:  Byte     (DEC)
          Range: 1 ... 9
                     ZG_BREMSE        1   Spotfilm device brake (for undertable stands like
                                          sireskop the SFD can manually moved  in order to
                                          get no motion artefacts caused by SFD movements
                                          the SFD will be braked during exposure
                     KOMPRESSION      2   compression
                     ZG_TISCHMITTE    3   spotfilm device table
                     ZG_PARKPOSITION  4   Spotfilm device in park position braked
                     BREMSE_5         5
                     BREMSE_6         6
                     BREMSE_7         7
                     BREMSE_8         8
                     BREMSE_9         9
          Dimension: none

BREMSCMD brake command
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     BREMSE_ANZIEHEN  1   apply brake
                     BREMSE_ABFALLEN  2   release brake
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SBV

Object: SBV ___ID: 012C

Description: controlling Zoom of detector, sent from XCU to ImageSystem (which parametrizes
              ImageChain)
Sender     :   XCU
Receiver   :   GEN-IF   GG_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

MESSF Measuring field (individual fields are bitcoded)
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     KEINE_ANGABE_RUND              0    circular measuring field
                     ACS_MEAS_FLD_I                 1    center field
                     ACS_MEAS_FLD_II                2    3-chamber: left field
                                                         5-chamber: lower right field
                     ACS_MEAS_FLD_I_AND_II          3
                     ACS_MEAS_FLD_III               4    3-chamber: right field
                                                         5-chamber: lower left field
                     ACS_MEAS_FLD_I_AND_III         5
                     ACS_MEAS_FLD_II_AND_III        6
                     ACS_MEAS_FLD_I_AND_II_AND_III  7
                     ACS_MEAS_FLD_IV                8    5-chamber: upper right field
                     ACS_MEAS_FLD_I_AND_IV          9
                     ACS_MEAS_FLD_II_AND_IV         10
                     ACS_MEAS_FLD_I_AND_II_AND_IV   11
                     ACS_MEAS_FLD_V                 16   5-chamber: upper left field
                     ACS_MEAS_FLD_I_AND_V           17
                     ACS_MEAS_FLD_III_AND_V         20
                     ACS_MEAS_FLD_I_AND_III_AND_V   21
                     ACS_MEAS_FLD_IV_AND_V          24
                     ACS_MEAS_FLD_IV_AND_I_AND_V    25
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SCLOSE

Object: SCLOSE ___ID: 0BB8

Description: End of a Service PC session; sent from Service PC to XCU
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs
This object has no parameters


SDATE

Object: SDATE ___ID: 0BBA

Description: set up XCU time; sent from a component to XCU
Sender     :   FLC
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

YEAR Year
          Type:  Byte     (DEC)
          Range: 0 ... 99
          Dimension: none

MONTH Month
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

DAY Day
          Type:  Byte     (DEC)
          Range: 1 ... 31
          Dimension: none

HOUR Hour
          Type:  Byte     (DEC)
          Range: 0 ... 23
          Dimension: none

MINUTE Minute
          Type:  Byte     (DEC)
          Range: 0 ... 59
          Dimension: none

SECOND Second
          Type:  Byte     (DEC)
          Range: 0 ... 59
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDETEKTORSTART

Object: SDETEKTORSTART ___ID: 03B6

Description: sDetektorStart is sent to FD-detector in order to trigger a RAD exposure
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs
This object has no parameters


SDFRBLENDENDATA

Object: SDFRBLENDENDATA ___ID: 026A

Description: dimension and size of collimators, sent from XCU to DFR for displaying the
              correct size of semi transparent collimators
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BLENDENBREITE width of collimator, the width is important in order to show the correct width in a care profile graphic on DFR, the width is known by the collimator, so the collimator sends the value to the DFR
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: 0.1 mm


SDFRFOBVA

Object: SDFRFOBVA ___ID: 0272

Description: SID sent from XCU to DFR
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3

List of Parameters:

FOBVA distance Tube to image intensifier
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: 0.1 mm

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDFRFOTA

Object: SDFRFOTA ___ID: 0273

Description: distance between focus (tube) and table, important for measuring length on
              patient, sent from XCU to DFR
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

FOTA distance between focus (tube) and table
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mm

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDFRNAHBED2

Object: SDFRNAHBED2 ___ID: 0260

Description: remote control of image system; meant to replace sDFRNahBed
              contains additional parameter to control the reply
Sender     :   TUI-IF   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and Rad3

List of Parameters:

REPLY_REQ determines if and which reply is requested by ImgSys
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_REPL_NONE    0   do not reply
                     ACS_REPL_BEDANZ  1   reply with iDFRBedAnz (to TUI-IF)
                     ACS_REPL_NAHBED  2   reply with iDFRNahBed to XCU (compatibility to
                                          sDFRNahBed)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTANZAHL amount of actions
          Type:  Count     (CNT)
          Range: 1 ... 20
          Dimension: number of data blocks

{AKTCODE Code for remote control
{          Type:  Enum16     (DEC)
{          Range: 0 ... 2500
{                       BLAETTERN                    0      0=no action;
{                                                           1=image forward;
{                                                           -1=image backward;
{                                                           2=scene plus.;
{                                                           -2=scene minus
{                                                           3=page down (in doc mode)
{                                                           -3=page up (in doc mode)
{                                                           4=next multiframe scene (skip
{                                                           single images)
{                                                           -4=previous multiframe scene
{                                                           (skip single images)
{                       DISPLAY_MODE                 1      change from single display to
{                                                           4x4 display:
{                                                           0=no action
{                                                           1=Single image
{                                                           -1=splitmon (Stack Mode)
{                                                           2=Change Mode
{                                                           -2=Stripe Mode
{                       CHANGE_MARK                  2
{                       HARDCOPY                     3
{                       STORE_MONITOR                4
{                       DELETE_IMAGE                 5
{                       STORE_REFERENZ               6
{                       RECALL_REFERENZ              7
{                       TRANSFER_IMAGE               8      Transfer Image to network (DICOM
{                                                           export)
{                       VIDEOLOOP_REPLAY             9      control/show video loop status:
{                                                           0=no action; 1=replay
{                                                           active;2=replay stopped;-1=mode
{                                                           changed
{                       RL_MARKIERUNG                10     control left/right marker:
{                                                           0=no action; 1=no mark; 2=R;
{                                                           3=L; 4=misc1; 5=misc2; 6=misc3;
{                                                           7=misc4
{                       SUBTRAKTION_NATIV            11     sDFRNahBed: toggle between sub
{                                                           and native display
{                                                           iDFRNahBed: 1=sub; 2=nat;
{                                                           3=sub&nat
{                       REMASKING                    12     switch remasking on (PARAM=1) or
{                                                           off (PARAM=2)
{                       DETECTOR_SELECTION           13     If more than one wireless
{                                                           detector is attached to the
{                                                           system, the user can select at
{                                                           the TUI, if large or small
{                                                           detector shall be taken.
{                                                           AKTDATA: 1=large; 2=small
{                       FILTERUNGSPROGRAMM           14
{                       FILTERKERN                   15
{                       FILTERENHANCEMENT            16
{                       VERGROESSERUNG               17     switch on/off fixed digital zoom
{                                                           (x2):
{                                                           -1 = toggle
{                                                           1 = switch zoom off
{                                                           2 = switch zoom on
{                       INVERTIERUNG                 18
{                       ANATOMIC_BACKGROUND          19
{                       PEAK_OPACIFICATION           20
{                       AUTOSHUTTER                  21
{                       ZIELFADENKREUZ               22     AKTDATA=1: crosshair on
{                                                           AKTDATA=0: crosshair off
{                       ROADMAP_FLH                  23
{                       TRANSFER_REFMON              24     transfer image to reference
{                                                           monitor:
{                                                           AKTDATA=1: conventional AtoB
{                                                           AKTDATA=2: swap images: AtoB and
{                                                           BtoA
{                       W1                           25     brightness native
{                       W2                           26     contrast native
{                       W3                           27     brightness subtracted
{                       W4                           28     contrast subtracted
{                       SHUTTER_HOR                  29     horizontal shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       SHUTTER_VER                  30     vertical shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       ROAM_HOR                     31     roam horizontally: 1=right;
{                                                           2=left
{                       ROAM_VER                     32     roam verticallly
{                       KREIS_SHUT                   33     circular shutter: 1=opening;
{                                                           -1=closing; 2=completely open;
{                                                           -2 =completely closed
{                       STORE_FL_SZENE               34
{                       DISPLAY_FRAME                35     Reference monitor assigned to
{                                                           ultra sound device
{                                                           Aktdata:  0= reference 1 =
{                                                           Ultrasound
{                       CARE_POS                     36     switch ShowCarePosition on or
{                                                           off
{                                                           AKTDATA: 0=off; 1=on; -1=toggle
{                       ENDO_GRAB                    37     Aktdata: 0=stop movie / 1=start
{                                                           movie / 2=store endo image
{                       EMERGENCY_LEVEL              38     Aktdata:    0=OFF / 1=ON
{                       TABCARD_TOGGLE               39     Aktdata:    0=No Action / 1=Pat
{                                                           / 2=Exam / 3=Postproc / 4=Doc
{                       FLIP_IMG_HORIZONTAL          40     Aktdata:   0=No Action / 1=Off /
{                                                           2=On / -1=Toggle
{                       FLIP_IMG_VERTICAL            41     Aktdata:    0=No Action / 1=Off
{                                                           / 2=ON / -1=Toggle
{                       DOSECHANGE_LOW_STANDARD      42     Aktdata: 0 = Standard Dose; 1 =
{                                                           Low Dose
{                       DVD_RECORDER                 43     Param: 0 = NO_CHANGE; 1 =
{                                                           START_DVD_RECORDING; 2 =
{                                                           STOP_DVD_RECORDING
{                       MARK_R_POSITION              44     Aktdata: 0 = NO RIGHT MARK; 1 =
{                                                           UPPERLEFT; 2 = UPPERRIGHT; 3 =
{                                                           MIDLEFT; 4 = MIDRIGHT; 5 =
{                                                           LOWERLEFT; 6 = LOWERRIGHT; 7 =
{                                                           NO_MARK_SELECTED
{                       MARK_L_POSITION              45     Aktdata: 0 = NO LEFT MARK; 1 =
{                                                           UPPERLEFT; 2 = UPPERRIGHT; 3 =
{                                                           MIDLEFT; 4 = MIDRIGHT; 5 =
{                                                           LOWERLEFT; 6 = LOWERRIGHT; 7 =
{                                                           NO_MARK_SELECTED
{                       FORMAT_SEGMENTATION          46     Aktdata: 0 = NO_INFORMATION; 1 =
{                                                           FULL; 2 = 2VER; 3 = 2AVER; 4 =
{                                                           2HOR; 5 = 2AHOR; 6 = 3VER; 7 =
{                                                           1OF4
{                       REFRESH_ORGAN_PROGRAM        47     Param: 0 = no change; 1 =
{                                                           refresh
{                       REDO_ORGAN_PROGRAM           48     Used for Ysio, last organ
{                                                           program shall be used again.
{                       TOD                          49     Used to set table object
{                                                           distance, param between TOD_MIN,
{                                                           TOD_MAX
{                       LABEL_SELECT                 50     select label language; 1=R/L
{                                                           2=D/G 3=DEX/SIN
{                       PAT_EDIT                     51     button 'new patient' or 'correct
{                                                           patient data' pressed
{                                                           0=close pat dialog
{                                                           1=new patient
{                                                           2=show pat data
{                                                           3=generate ID
{                                                           4=delete
{                                                           5=filter
{                                                           6=unfilter
{                                                           7=protect
{                                                           8=unprotect
{                                                           9=save changes (=correct pat
{                                                           data)
{                       PAT_REGISTER                 52     button 'exam', 'add to worklist'
{                                                           or  'emergency patient' pressed
{                                                           AKTDATA: 1=exam, 2=add to
{                                                           worklist 3=emergency
{                       PAT_LIST                     53     buttons 'worklist' or 'previous
{                                                           patients' pressed
{                                                           AKT_DATA: 1=worklist,
{                                                           2=prevPatient, 0="return to
{                                                           patlist"
{                       PAT_CLOSE                    54     button 'end exam' pressed
{                                                           AKTDATA.bit0: (unused)
{                                                           AKTDATA.bit1: print summary
{                                                           AKTDATA.bit2: export summary
{                                                           AKTDATA.bit3: send MPPS
{                       WINDOW_LUT                   55     This allows the selection of a
{                                                           predefined LUT (set of window
{                                                           values)
{                                                           AKTDATA>0 number of fixed
{                                                           setting
{                                                           AKTDATA=0 deselects all (free
{                                                           window values)
{                                                           -1 step to next setting
{                                                           (used in surgery and urology)
{                       SAVE_FOR_UNDO                56     on receiving this code, FLC
{                                                           shall save the current set of
{                                                           image processing parameters for
{                                                           latter undo function
{                       UNDO_PROC                    57     FLC shall undo the recent change
{                                                           of image processing parameters
{                                                           AKTDATA=0: reset to loading
{                                                           default
{                                                           AKTDATA=1: go back to parameter
{                                                           set previously being saved with
{                                                           SAVE_FOR_UNDO
{                       INJCT_SYMB                   58     show injector symbol
{                                                           in iDFRNahBed also: mask has
{                                                           been successfully acquired
{                                                           (averaged)
{                       AVERAGING                    59     determines the averaging applied
{                                                           for LIH
{                                                           1=low; 2=normal; 3=high
{                                                           (fixed modification factor
{                                                           applied to value out of
{                                                           application/OGP)
{                       MOTION_DET                   60     selector to set the level for
{                                                           motion detection and k-factor
{                                                           (used in surgery)
{                                                           motion detector off: 1=low;
{                                                           2=standard; 3=high; 4=heart
{                                                           motion detector on: 11=low;
{                                                           12=standard;13=high
{                       IMG_ROTATE_REL               61     rotate image by the amount given
{                                                           in degrees AKTDATA relative to
{                                                           the current position
{                       IMG_ROTATE_ABS               62     rotate image to the value given
{                                                           in degrees AKTDATA
{                       MOVIE_SPEED                  63     defines the speed of the movie
{                                                           replay; iDFRNahBed uses code 0,
{                                                           iDFRBedAnz use codes 1-3
{                                                           following values are defined:
{                                                           0 - step to next; 1-slow;
{                                                           2-normal, 3-fast
{                       SELECT_FRAME                 64     image system shall show the
{                                                           frame number given in AKTDATA
{                                                           out of the current scene
{                       SET_SCENE_LIMIT              65     sets or resets the lower or
{                                                           upper delimiter for scene
{                                                           replay
{                                                           1=set lower limit, 2=set upper
{                                                           limit, 101=reset lower limit,
{                                                           102=reset upper limit
{                       STORAGE_RATE                 66     set storage rate reduction;
{                                                           param:
{                                                           1=100% store every frame
{                                                           2=50% store every other frame
{                                                           3=33% store every third frame
{                                                           4=25%, 5=20%, 10=10%
{                       ENABLE_AUTO_STORE            67     control autostore (in surgery):
{                                                           0=disable auto storage of fluoro
{                                                           scenes
{                                                           1=enable auto storage of LIH
{                                                           2= enable auto storage of LSH
{                                                           (last scene hold)
{                       AUTOWINDOW                   68     set the auto window function
{                                                           (0=off; 1=on)
{                       EXPORT_DIALOG                69     show export sub/nat select
{                                                           dialog (used in iDFRBedAnz for
{                                                           surgery)
{                                                           AKTDATA.bit0: 1-show, 0-hide
{                                                           AKTDATA.bit1: store native
{                                                           AKTDATA.bit2: store subtracted
{                                                           AKTDATA.bit3: store raw data
{                                                           AKTDATA.bit4: 1-PeakOp 0-entire
{                                                           scene
{                       DIGITAL_ZOOM                 70     slider position for digital zoom
{                                                           (used in surgery)
{                       BUTTONFIELD_ENA              71     enables or disables the buttons
{                                                           in the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                                                           note: since first button will
{                                                           always be active, bit0 is used
{                                                           to indicate, if there is a next
{                                                           page (i.e. if element16 rather
{                                                           than element0 is existing)
{                       MODE_RANGE                   72     activates or deactivates the
{                                                           range selection mode
{                       SELECT_RANGE_START           73     transfers the item number of the
{                                                           range start
{                                                           (used for multi-select in DOC
{                                                           mode in surgery)
{                       BUTTONFIELD_SEL              74     activates or deactivates the
{                                                           buttons in the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                       HOLD_REF                     75     ImageSystem shall freeze the
{                                                           reference monitor
{                       ENTER_SERVICE                76     start service
{                       CALC_PEAKOP                  77     triggers the calculation and
{                                                           storage of a new PeakOp image
{                       MODE_PAN                     78     enter(1) or leave(0) Pan Mode
{                                                           (CURSOR_HOR and CURSOR_VER refer
{                                                           to panning)
{                       CURSOR_HOR                   79     move cursor horizontally by the
{                                                           given amount
{                                                           (used for pan, pixel shift, draw
{                                                           line and quant)
{                       CURSOR_VER                   80     move cursor vertically  by the
{                                                           given amount
{                                                           (used for pan, pixel shift, draw
{                                                           line and quant)
{                       MODE_PIXEL_SHIFT             81     enter (1) or leave(0) the pixel
{                                                           shift mode
{                                                           (CURSOR_HOR and CURSOR_VER refer
{                                                           to pixel shift)
{                                                           (note: pixel shift values are in
{                                                           1/16 pixels
{                       AUTO_PIXEL_SHIFT             82     activates or deactivates auto
{                                                           pixel shift
{                                                           0=off; 1=on
{                       CALC_PIXEL_SHIFT             83     ImageSystem is requested to
{                                                           calculate the pixels shift (for
{                                                           all successful images?!)
{                       MODE_DRAW_LINE               84     activate or deactivate the draw
{                                                           line mode
{                                                           0=deactivate draw line mode
{                                                           1=activate draw line mode
{                                                           2=set point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=cancel
{                                                           6=end line
{                                                           7=edit line
{                       MODE_QUANT                   85     control the quant mode
{                                                           0=deactivate quant mode
{                                                           1=activate quant mode
{                                                           2=set point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=reset quant
{                                                           6=delete line
{                                                           7=calc contour
{                                                           8=correct contour
{                                                           9=move line 1 up
{                                                           10=move line 1 down
{                                                           11=move line 2 up
{                                                           12=move line 2 down
{                       CLOSE_PAT_DIALOG             86     show close patient dialog (used
{                                                           in surgery)
{                                                           AKTDATA.bit0: 1-show, 0-hide
{                                                           AKTDATA.bit1: print summary
{                                                           AKTDATA.bit2: export summary
{                                                           AKTDATA.bit3: send MPPS
{                                                           AKTDATA.bit8: 1-PatExistsDialog,
{                                                           0-ClosePatDialog
{                       BLOW_UP                      87     enable (1) or disable(0) blowup
{                                                           mode (i.e. segment from overview
{                                                           is shown enlarged on 2nd
{                                                           display)
{                       MODE_MULTISEL                88     activates/deactivates the multi
{                                                           selection mode (used in surgery
{                                                           to mark images)
{                       SHUTTER_CTRL                 89     bit0=left shutter; bit1=right
{                                                           shutter; bit2=upper shutter;
{                                                           bit3=lower shutter
{                                                           bit4: 1=shutter disabled;
{                                                           0=shutter normal
{                                                           bit5: 1=rotate shutter; 0=normal
{                                                           (move in/out)
{                                                           bit8-15: signed char specifying
{                                                           the amount to move the shutter
{                       NUM_MARKED                   90     number of elements (images in
{                                                           study or frames in image) that
{                                                           are marked
{                       RADIATION_ON_RQ              91     in sDFRNahBed XCU requests FLC
{                                                           to show the passcode dialog (to
{                                                           enable or disable x-ray):
{                                                           AKTDATA: 1=show passcode dialog;
{                                                           0=close passcode dialog
{                                                           FLC replies with iDFRNahBed:
{                                                           AKTDATA: 1=request granted;
{                                                           0=request denied
{                       BUTTONFIELD_MARK_VESS        92     activates or deactivates a
{                                                           vessel symbol on the buttons in
{                                                           the selection field
{                                                           AKTDATA contains a bitfield with
{                                                           each bit deflecting the status
{                                                           of one button of the 4x4 field
{                                                           (0=inactive, 1=active)
{                       MODE_ANNOTATE                93     control the annotate measure
{                                                           mode
{                                                           0=deactivate annotate measure
{                                                           mode
{                                                           1=activate annotate measure
{                                                           mode
{                                                           2=set 1st point
{                                                           3=delete point
{                                                           4=delete all
{                                                           5=calibrate
{                                                           6=delete graph
{                                                           7=set 2nd point
{                                                           8=text mode
{                                                           9=line mode
{                                                           10=angle mode
{                                                           11=free text mode
{                       SELECT_ANNOTATION            94     indicates the selection out of
{                                                           the list of predefined
{                                                           annotation text strings (that
{                                                           has been sent with sAnnotation)
{                       SHUTTER_MENU                 95     shall be sent from TUI-IF to
{                                                           FLC, if the shutter submenu is
{                                                           opened or closed
{                       AUTOLOOP                     96     autoloop button (used in surgery
{                                                           only); overrides the setting of
{                                                           the OGP/application:
{                                                           PARAM=0: image system shall show
{                                                           LIH
{                                                           PARAM=1: loop display shall be
{                                                           started right after acquisition
{                       SELECT_PEAKOP                97     select PeakOp (used in surgery)
{                                                           PARAM: -1=previous; +1=next
{                       SHOW_CARE_PROF               98     This code triggers display of
{                                                           care profile graphics on
{                                                           ImageSystem
{                       CHANGE_BRIGHTNESS            99     change window brightness (FLC
{                                                           knows if nat or sub)
{                                                           (used for button based control
{                                                           in surgery)
{                                                           AKTDATA=4: decrease brightness
{                                                           AKTDATA=2: increase brightness
{                                                           AKTDATA=0: off
{                       CHANGE_CONTRAST              100    change window contrast (FLC
{                                                           knows if nat or sub)
{                                                           (used for button based control
{                                                           in surgery)
{                                                           AKTDATA=4: decrease contrast
{                                                           AKTDATA=2: increase contrast
{                                                           AKTDATA=0: off
{                       SELECT_BUTTON                101    select a button in the overview
{                                                           buttonfield (on surgery xCP)
{                                                           AKTDATA contains the button
{                                                           number (0-15)
{                       MODE_MANAGED                 102    activates managed mode on FLC
{                       MODE_3D_DISP                 103    opens/activates 3D display and
{                                                           submenu
{                       ROT_FLIP_MENU                104    indicates, that the Rotate/Flip
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       BRIGHT_CONT_MENU             105    indicates, that the
{                                                           Brightness/Contrast submenu has
{                                                           been opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0) on TUI
{                       CLOSE_KEYB                   106    keyboard on TUI has been closed
{                       EDGE_ENH_MENU                107    indicates, that the Edge
{                                                           Enhancement submenu has been
{                                                           opened (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       SUB_NAT_MENU                 108    indicates, that the Sub/Nat
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       PEAK_OP_MENU                 109    indicates, that the PeakOp
{                                                           submenu has been opened
{                                                           (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       DELETE_PAT_DIALOG            110    show delete patient dialog (used
{                                                           in surgery)
{                       SELECT_SCENE                 111    set/show the current scene
{                                                           number
{                                                           (currently only used in
{                                                           iDFRBedAnz)
{                       MODAL_BOX_DIALOG             112    On this code in iDFRBedAnz TUI
{                                                           shall open(1) or close(0) a
{                                                           special message box.
{                                                           On this code in sDFRNahBed2 FLC
{                                                           shall close the modal box.
{                       RESET_ZOOM                   113    zoom (and pan) shall be reset
{                                                           (ViewAll functionality)
{                       CANCEL_PROGRESS              114    cancel button on the generic
{                                                           progress bar on TUI
{                       MOVIE_MENU                   115    TUI-IF reports that the movie
{                                                           menu is opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0)
{                       COLLIMATOR_MENU              116    shall be sent from TUI-IF to
{                                                           FLC, if the collimator submenu
{                                                           is opened or closed
{                       MODE_DUAL_3D_DISPLAY         117    opens/activates dual display
{                                                           mode and submenu
{                       SWITCH_INPUT_FIELD           118    switches input field focus (e.g.
{                                                           in patient registration dialog)
{                                                           1=jump to next input field
{                                                           -1=jump to previous input field
{                       TUI_TABCARD_SWITCH           119    in sBedDFR/sDFRNahBed: TUI
{                                                           informs FLC on selected tabcard
{                                                           in iDFRNahBed/iDFRBedAnz: FLC
{                                                           selects a tabcard at TUI
{                                                           (used in surgery)
{                                                           1 = prep tabcard
{                                                           2 = proc tabcard
{                                                           3 = ext tabcard
{                                                           4 = IGS tabcard
{                       SURG_METAL_CORR              120    control metal correction feature
{                                                           (image processing)
{                                                           AKTDATA: 0=off; 1=on
{                       HIDE_GRAPHICS                121    hide all graphic overlays
{                       LARGE_TUI_PREVIEW            122    switch on/off stream for large
{                                                           image display on TUI
{                       SUBAUTOWIN                   123    autowindow for road and sub
{                                                           (1=trigger)
{                       ONSUB_ONNAT                  124    determines, if the values for
{                                                           WINDOW_LUT and INVERTIERUNG are
{                                                           to be applied on subtracted or
{                                                           native image
{                                                           0 = apply to both
{                                                           1 = apply to native
{                                                           2 = apply to subtracted
{                       SPATIAL_NOISE_FILTER         125    spatial noise filter setting
{                                                           0 = off
{                                                           1 = low
{                                                           2 = medium
{                                                           3 = high
{                       RADIATION_ON_YES             126    "yes" button at radiation on
{                                                           dialog pressed
{                       NO_ZOOMDOSE_ADPT             127    AKTDATA:
{                                                           0: normal zoom dose adaption
{                                                           1: no zoom dose adaption
{                       KWIRE                        128    indicates, that FLC shall the
{                                                           k-wire functionality
{                                                           (AKTDATA=1) switched on
{                                                           (AKTDATA=0) switched off
{                       STORE_NGS                    129    Store NGS stream as single image
{                                                           (similar to STORE_MONITOR)
{                       OPENAPPS_MAN_IMG_TRANS       130    Manual image transfer from
{                                                           imaging system to AppHost
{                       IMAGE_FOR_APP_AVAILABLE      131    a new image is available to be
{                                                           transferred to the APP
{                       STORE_SNAPSHOT               132    Snapshot active (cummulated
{                                                           fluoro image).
{                                                           This code is used to inform XCU
{                                                           in iDFRNahBed that certain
{                                                           functions must be (temporarily)
{                                                           disabled.
{                                                           (AKTDATA=0) not active
{                                                           (AKTDATA=1) snapshot active
{                       DOSE_CONTROL_ROI_MENU        133    Indicates, that the region of
{                                                           interest (ROI) for dose control
{                                                           submenu has been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed at TUI
{                       DOSE_CONTROL_ROI             134    Region of interest (ROI) for
{                                                           dose control settings shall be
{                                                           set to
{                                                           (AKTDATA=1) on
{                                                           (AKTDATA=2) off
{                                                           (AKTDATA=3) enabled
{                                                           (AKTDATA=4) disabled
{                       SCAN_3D_RECO_PROGRESS        136    indicates, that the
{                                                           reconstruction progress has
{                                                           been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed on TUI
{                       SCAN_3D_PLANE                137    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = ACS_SCAN_PLANE_ORB, 2 =
{                                                           ACS_SCAN_PLANE_ANG
{                       SCAN_3D_OBJECT               138    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = Tissue, 2 = Bone
{                       SCAN_3D_QUALITY              139    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = Low, 2 = Standard, 3 = High, 4
{                                                           = Obese
{                       NAVI_3D_ACTIVE               140
{                       SCAN_3D_PAT_ORIENTATION      141    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = supine, 2 = prone, 3 = left, 4
{                                                           = right
{                       SCAN_3D_SYS_POSITION         142    Param: 0 = ACS_NO_INFORMATION, 1
{                                                           = left, 2 = right, 3 = head, 4 =
{                                                           foot
{                       ZOOM_PAN_MENU                143    Indicates, that the zoom / pan
{                                                           menu has been
{                                                           (AKTDATA=1) opened or
{                                                           (AKTDATA=0) closed on TUI
{                       SYSUNLOCK_ON_REQ             144    Request to show the Hipaa login
{                                                           dialog
{                                                           (AKTDATA=1) to open on FLC
{                       PAT_SIZE_SELECTION           150    This code is used in RAD3 system
{                                                           for patient size selection.
{                                                           AKTDATA=1: small size
{                                                           AKTDATA=2: medium size
{                                                           AKTDATA=3: big size
{                                                           AKTDATA=4: customized size
{                       KVM_SWITCH_CONTROL           200    Request to AppHost to switch KVM
{                                                           to imaging system.
{                                                           0 = No changes, 1 = Switch to
{                                                           imaging system
{                                                           KVM status from
{                                                           AppHost(iDFRNahBed):
{                                                           0 = no information, 1 = switched
{                                                           to imaging system, 2 = switched
{                                                           to AppHost
{                       APL_OPENAPPS_IN_USE          201
{                       VDM_ACTIVATE_3D_VIEW         2001
{                       VDM_ACTIVATE_VRT_PRESET      2002
{                       VDM_ENLARGE_3D_VIEW          2003
{                       VDM_STANDARD_ORIENTATION_3D  2004
{                       VDM_MOVE_MPR_PLANE_S         2005
{                       VDM_MOVE_MPR_PLANE_C         2006
{                       VDM_MOVE_MPR_PLANE_T         2007
{                       VDM_ROTATE_MPR_PLANE_S       2008
{                       VDM_ROTATE_MPR_PLANE_C       2009
{                       VDM_ROTATE_MPR_PLANE_T       2010
{                       VDM_ROTATE_VRT_X             2011
{                       VDM_ROTATE_VRT_Y             2012
{                       VDM_ROTATE_VRT_Z             2013
{                       VDM_MPR_THICKN_MENU          2014   indicates, that the MPR
{                                                           Thickness submenu has been
{                                                           opened/closed on TUI
{                       VDM_PARALLEL_RANGE_MENU      2015   indicates, that the Parallel
{                                                           Range submenu has been
{                                                           opened/closed on TUI
{                       VDM_HIDE_REF_LINES           2016
{                       VDM_ORTHO_ALIGNMENT          2017
{                       VDM_MPR_THICKNESS_REL        2018
{                       VDM_MPR_THICKNESS_ABS        2019   AKTDATA contains the MPR
{                                                           thickness in 0.1mm
{                                                           value -1 is used as reset
{                       VDM_SWAP_VOLUMES             2020   Swap the volume in between
{                                                           monitor A and B if AKDATA is 1.
{                                                           If AKTDATA is 0 then no
{                                                           swapping.
{                       VDM_VOL_REGIST_MENU          2021   indicates, that the Volume
{                                                           Registration submenu has been
{                                                           opened (AKTDATA=1) or closed
{                                                           (AKTDATA=0) on TUI
{                       VDM_SYNC_ADAPT_MONITOR       2022   Adapt changes in the monitor
{                                                           specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNC_LINK                2023   Switch linking between monitors
{                                                           on and off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNC_SYNC                2024   Synchronize settings from the
{                                                           monitor where the changes are
{                                                           adapted to the other one.
{                       VDM_SYNCW_ADAPT_MONITOR      2025   Adapt windowing changes in the
{                                                           monitor specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNCW_LINK               2026   Switch windowing parameter
{                                                           linking between monitors on and
{                                                           off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNCW_SYNC               2027   Synchronize windowing settings
{                                                           from the monitor where the
{                                                           changes are adapted to the other
{                                                           one.
{                       VDM_SYNCZ_ADAPT_MONITOR      2028   Adapt zoom/pan changes in the
{                                                           monitor specified in AKTDATA.
{                                                           AKTDATA=1: Monitor A
{                                                           AKDTATA=2: Monitor B
{                       VDM_SYNCZ_LINK               2029   Switch zoom/pan parameter
{                                                           linking between monitors on and
{                                                           off.
{                                                           AKTDATA=0: linking is switched
{                                                           off (button is pressed)
{                                                           AKTDATA=1: linking is switched
{                                                           on (button released)
{                       VDM_SYNCZ_SYNC               2030   Synchronize zoom/pan settings
{                                                           from the monitor where the
{                                                           changes are adapted to the other
{                                                           one.
{                       VDM_MPR_THICKNESS_MON        2031   Monitor identifier text in MPR
{                                                           Thickness dialog.
{                                                           AKTDATA=0: ""
{                                                           AKTDATA=1: "Monitor A"
{                                                           AKTDATA=2: "Monitor B"
{                       VDM_REGIST_PAN_HOR           2032   Pan the second volume in the
{                                                           selected segment horizontally
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is right
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_PAN_VER           2033   Pan the second volume in the
{                                                           selected segment vertically
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is up
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_ROTATE            2034   Rotate the second volume in the
{                                                           selected segment
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive directions is
{                                                           clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_REGIST_AUTO              2035   Start auto registration process
{                       VDM_REGIST_STORE             2036   Store the current registration
{                       VDM_REGIST_SELECT            2037   Set the selected registration
{                                                           AKTDATA = the current selection
{                       VDM_REGIST_CONSTR_MENU       2038   The Constraint Registration
{                                                           dialog was opened (AKTDATA=1) or
{                                                           closed (AKTDATA=0)
{                       VDM_CLIPPLANE_MPR_MOVE       2039   Move clip plane forward or
{                                                           backward in MPR mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is forward
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_MPR_ROTATE     2040   Rotate clip plane left or right
{                                                           in MPR mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is right
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_MOVE       2041   Move clip plane forward or
{                                                           backward in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is forward
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_ROT_HOR    2042   Rotate clip plane around the
{                                                           horizontal axis clockwise or
{                                                           counter-clockwise in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_VRT_ROT_VER    2043   Rotate clip plane around the
{                                                           vertical axis clockwise or
{                                                           counter-clockwise in VRT mode
{                                                           AKTDATA = speed
{                                                           speed is positive or negative
{                                                           according to direction:
{                                                           positive direction is clockwise
{                                                           magnitude of speed = 1, 2 or 3
{                                                           according to ramp function
{                       VDM_CLIPPLANE_ENABLE         2044   Enable (AKTDATA=1) or disable
{                                                           (AKTDATA=0) the clip plane
{                       VDM_CLIPPLANE_ALIGN          2045   Align clipplane to the selected
{                                                           segment
{                       VDM_WORKMODE                 2046   switch from simple to advanced
{                                                           view
{                                                           - 1 for Simple View
{                                                           - 2 for Advanced View
{                                                           - (3 for Registration)
{                       APL_ACTIVATE_APP             2401   function related to "AppLink
{                                                           menu"
{                       APL_CONF_SWITCH_AFTER_XRAY   2403   function related to AppLink menu
{          Dimension: none

{AKTDATA Data for the command
{          Type:  Integer16     (DEC)
{          Range: -32000 ... 32000
{          Dimension: none


SDFRPATWECHSEL

Object: SDFRPATWECHSEL ___ID: 0262

Description: indicating change of patient from DFR to XCU, will trigger e.g. a reset of
              fluoro data (accum. time, DAP, AirKerma) and collimator search run.
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

PAT_ACTION status of the patient registration
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     ACS_EMERGENCY_PAT   1   patient registered in an emergency mode
                     ACS_PAT_EXAM        2   patient has been registered for examination
                     ACS_PAT_CLOSED      3   patient has been closed
                     ACS_PAT_SERVICE     4   service patient has been opened for examination
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDFRPOWERREQ

Object: SDFRPOWERREQ ___ID: 0282

Description: tells DFR the status of the power down (used in mobile system)
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

POWERREQ Power management by DFR
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     POWER_OFF  0   request power off
                     POWER_ON   1   cancel power off
                     SHUTDOWN   2   request shutdown
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDFRREDBF

Object: SDFRREDBF ___ID: 0270

Description: reducing framerate during acquisition; from XCU to DFR
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro
This object has no parameters


SDFRSERIE

Object: SDFRSERIE ___ID: 0265

Description: selecting single or series for DFR; sent from XCU to DFR
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3

List of Parameters:

SERIE Series / single mode
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     EINZELBILD  0   single frame
                     SERIE       1   series
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDLAUSL

Object: SDLAUSL ___ID: 02C3

Description: fluoro release, sent from XCU to generator
Sender     :   SCU   XCU
Receiver   :   FLC   GEN-IF   RAD-STD   TUI-IF   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro and show

List of Parameters:

DL fluoro requested
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

AUTO_DL This parameter shows, if the fluoro has been released manually or automatically (e.g. as part of 3D run)
This is needed by image system in order to switch off fluoro loop storage.
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     ACS_DL_MANUAL  0   fluoro was released manually
                     ACS_DL_AUTO    1   fluoro was released automatically (e.g. as part of
                                        3D run)
          Dimension: none

SHOT_FROM_FLUORO indicates if the fluoro shall be followed by an acquisition immediately
(note: does only make sense on DL=0)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


SDLDATA

Object: SDLDATA ___ID: 02B4

Description: Sends fluoro curves referring to fluoro programs to generator.
              Not used in surgery systems.
Sender     :   XCU
Receiver   :   GEN-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NUM_PROG_DATA Number of Fluoro Program Data
          Type:  Count     (CNT)
          Range: 0 ... 5
          Dimension: number of data blocks

{DLMEMNR Fluoro memory number, for usual identical to DLKennl
{          Type:  Byte     (DEC)
{          Range: 1 ... 99
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY6
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SDLDATEN

Object: SDLDATEN ___ID: 02BE

Description: select fluoro data
Sender     :   XCU
Receiver   :   GEN-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro and show

List of Parameters:

DLMODE Fluoro mode; | Samples: Standard fluoro cont: 1, Supervision: 17, Supervision Roadmap: 49, pulsed: 8, pulsed + high contrast: 10
          Type:  Byte     (DEC)
          Range: 1 ... 49
                     KONTINUIERLICH  1    continuous fluoro (=continuous wave without
                                          pulses)
                     HOCHKONTRAST    2    high contrast (equivalent to max skin dose rate is
                                          20 R/min instead of 10R/min)
                     DL_HAND         4    manual fluoro, kV and mA can be set manually
                                          without using automatic regulation (no longer
                                          permitted in Germany or USA)
                     GEPULST         8    pulsed fluoro mode
                     SUPERVISION     16   supervision, two grabbed images of a continuous
                                          fluoro are added to reduce noise
                     ROADMAP         32   Roadmap, automatic subtraction in fluoro
          Dimension: none

DLKENNL Fluoro curve. Fluoro curve is defined in a set in the organ program and the number of the curve is sent to the generator.
          Type:  Byte     (DEC)
          Range: 1 ... 100
          Dimension: none

DOSISL dose rate
          Type:  Word     (DEC)
          Range: 1 ... 65535
          Dimension: nGy/s

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MA Current of fluoro or acquisition
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA

REGSTOP stop dose regulation in generator and keep kV and mAs values for all subsequent pulses
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

IONCH iontomat channel (Polydoros SX has six channels for connection up to six chambers for six targets, Polydoros F80 supports less for CAN-iontomat channels)
          Type:  Byte     (DEC)
          Range: 0 ... 8
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDLDCMD

Object: SDLDCMD ___ID: 0003

Description: download type selection, sent from XCU to a component
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

KOMMANDO download command
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     START_DOWNLOAD         1   start download
                     PROGSPEICHER_LOESCHEN  2   erase flash eprom
                     DLD_BEENDEN            3   download finished
                     DOWNLOAD_FLOPPY        4   download from floppy
          Dimension: none

PROZESSOR Which processor system has to be downloaded (0=host; 1-254=sub processors)
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     HOSTPROZ  0
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SDLDDATA

Object: SDLDDATA ___ID: 0004

Description: download data, sent from XCU to a component
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

SELEKTOR Data type
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     DLDHEADER    0   download header
                     DLDDATEN     1   download data
                     DLDCHECKSUM  2   download checksum
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SDLPROGDATEN

Object: SDLPROGDATEN ___ID: 02B0

Description: Data for FD fluoro program
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

MAN_FLU_OVERRIDE bitcoding of all parameters where an override of fluoro programs is possible: 0 = no override; 1 = with override
          Type:  Dword     (HEX)
          Range: 0x0 ... 0xFFFFFFFF
                     ACS_OV_FLU_DLMODE          0x00000001
                     ACS_OV_FLU_DLKENNL         0x00000002
                     ACS_OV_FLU_DLBFREQ         0x00000004
                     ACS_OV_FLU_DOSIS           0x00000008
                     ACS_OV_FLU_DOSERATE_INDEX  0x00000010
                     ACS_OV_FLU_DLREGACTION     0x00000020
                     ACS_OV_FLU_FILTERDL        0x00000040
          Dimension: none

FL_FREQ_ACT actual pulse rate fluoro
          Type:  Word     (DEC)
          Range: 0 ... 300
          Dimension: 0.1 fps

XRPT_FL pulse width fluoro
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: ms

DEFAULT_ACQ_MODE specifies the default acquisition mode for this application (used in surgery)
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     ACS_NO_INFORMATION  0
                     ACS_ACQM_FLUORO     1
                     ACS_ACQM_ROADMAP    2
                     ACS_ACQM_SUB        3
                     ACS_ACQM_DR         4
                     ACS_ACQM_3D         6   3D Acquisition mode (note: this code is used in
                                             iDLAnz only, not in sDLProgDaten)
          Dimension: none

NUM_MASK_FRAMES number of mask frames for sub (used in surgery)
          Type:  Byte     (DEC)
          Range: 0 ... 64
          Dimension: number

APPLY_ZDF the configured zoom dose factor shall be applied to requested dose
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NUM_PROG Number of fluoro programs
          Type:  Count     (CNT)
          Range: 1 ... 15
          Dimension: number of data blocks

{DLMODE Fluoro mode; | Samples: Standard fluoro cont: 1, Supervision: 17, Supervision Roadmap: 49, pulsed: 8, pulsed + high contrast: 10
{          Type:  Byte     (DEC)
{          Range: 1 ... 49
{                       KONTINUIERLICH  1    continuous fluoro (=continuous wave without
{                                            pulses)
{                       HOCHKONTRAST    2    high contrast (equivalent to max skin dose rate
{                                            is 20 R/min instead of 10R/min)
{                       DL_HAND         4    manual fluoro, kV and mA can be set manually
{                                            without using automatic regulation (no longer
{                                            permitted in Germany or USA)
{                       GEPULST         8    pulsed fluoro mode
{                       SUPERVISION     16   supervision, two grabbed images of a continuous
{                                            fluoro are added to reduce noise
{                       ROADMAP         32   Roadmap, automatic subtraction in fluoro
{          Dimension: none

{DLKENNL Fluoro curve. Fluoro curve is defined in a set in the organ program and the number of the curve is sent to the generator.
{          Type:  Byte     (DEC)
{          Range: 1 ... 100
{          Dimension: none

{DLBFREQ Fluoro pulse rate
{          Type:  Integer16     (DEC)
{          Range: 0 ... 600
{          Dimension: 0.1 f/s

{DOSISDR Dose for fluoro (dose rate)
{          Type:  Word     (DEC)
{          Range: 0 ... 65530
{          Dimension: 0.1 nGy/pulse

{DOSERATE_INDEX factor for dose change while framerate changes:
DRI = 1    doserate is kept constant (dose/pulse increased by 100% at half framerate)
DRI = 0.5  dose/pulse increased by 50% at half frame rate
DRI = 0    dose/pulse is kept constant for all pulserates
{          Type:  Byte     (DEC)
{          Range: 0 ... 10
{          Dimension: 0.1

{IDL_PULSE_LENGTH_FACTOR in fluoro (IDL): number of 33ms frames to be summed up into one image (IDL k-Factor)
in DRsum: number of frames to be summed up into one image (DRsum k-Factor)
{          Type:  Byte     (DEC)
{          Range: 1 ... 64
{          Dimension: number of 33ms periods

{FILTERDL Filter for fluoro
This is a bit oriented value.Bit0 is "Filter auto", Bit1 is "use filter out of OGP", Bit 4 to 7 tell the filter number. E.g.: 2 = Filter 0, 34=22h = Filter 2, 51=33h = Filter 3 and Auto is on, 32=20h = leave filter as it is, because Bit 1 is 0.
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{ACQ_MODE (fluoro) acquisition mode for which the current set is valid (used in surgery)
{          Type:  Enum8     (DEC)
{          Range: 0 ... 7
{                       ACS_NO_INFORMATION  0
{                       ACS_ACQM_FLUORO     1
{                       ACS_ACQM_ROADMAP    2
{                       ACS_ACQM_SUB        3
{                       ACS_ACQM_DR         4
{                       ACS_ACQM_DCM        5
{                       ACS_ACQM_3D         6   3D Acquisition mode (note: this code is used
{                                               in iDLAnz only, not in sDLProgDaten)
{          Dimension: none

{DOSE_LEVEL doselevel for which the current set is valid (used in surgery)
{          Type:  Enum8     (DEC)
{          Range: 0 ... 3
{                       ACS_NO_INFORMATION  0
{                       ACS_DOSL_LOW        1
{                       ACS_DOSL_NORMAL     2
{                       ACS_DOSL_HIGH       3
{          Dimension: none

{IS_DEFAULT this set is the default (dose level) for this ACQ_MODE (used in surgery)
{          Type:  Enum8     (DEC)
{          Range: 0 ... 2
{                       ACS_NO_INFORMATION  0
{                       ACS_YES             1
{                       ACS_NO              2
{          Dimension: none


SDOWNLOAD

Object: SDOWNLOAD ___ID: 000F

Description: advices the component to switch to download mode, sent from XCU to a component
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs
This object has no parameters


SE_EMERGENCY

Object: SE_EMERGENCY ___ID: E09C

Description: For Can to AXCS Interface (used in XCU module test)
Sender     :   TEST-SW
Receiver   :   VCI
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_NMT_ERROR_CONTROL

Object: SE_NMT_ERROR_CONTROL ___ID: E71C

Description: For Can to AXCS Interface (used in XCU module test)
Sender     :   TEST-SW   VCI
Receiver   :   TEST-SW   VCI
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_PDO1_RX

Object: SE_PDO1_RX ___ID: E21C

Description: Virtual CAN to AXCS (used in XCU module test)
Sender     :   VCI
Receiver   :   TEST-SW
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_PDO1_TX

Object: SE_PDO1_TX ___ID: E19C

Description: Virtual Can to AXCS Object (used in XCU module test)
Sender     :   TEST-SW
Receiver   :   VCI
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_PDO2_RX

Object: SE_PDO2_RX ___ID: E31C

Description: Virtual CAN to AXCS (used in XCU module test)
Sender     :   VCI
Receiver   :   TEST-SW
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_PDO2_TX

Object: SE_PDO2_TX ___ID: E29C

Description: Virtual Can Interface to AXCS (used in XCU module test)
Sender     :   TEST-SW
Receiver   :   VCI
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_PDO3_TX

Object: SE_PDO3_TX ___ID: E39C

Description: Virtual CAN to AXCS (used in XCU module test)
Sender     :   TEST-SW
Receiver   :   VCI
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_SDO_RX

Object: SE_SDO_RX ___ID: E61C

Description: Virtual CAN to AXCS (used in XCU module test)
Sender     :   VCI
Receiver   :   TEST-SW
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SE_SDO_TX

Object: SE_SDO_TX ___ID: E59C

Description: Translation of CAN into AXCS (used in XCU module test)
Sender     :   TEST-SW
Receiver   :   VCI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs and XcuTester

List of Parameters:

RTR Remote Transmit Request
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none

DLC Data Length Control
          Type:  Count     (CNT)
          Range: 0 ... 8
          Dimension: none

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SEND_LIST

Object: SEND_LIST ___ID: 9302

Description: send protocol object for the Network Monitor; sent with MODE = MONITOR (3); it
              must not be in the inlist
Sender     :   AXN
Receiver   :   ACSOS
Mode       :  MONITOR(03)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

SEND_SERVER_ID ID of axcs server (see parameter SERVER_ID below)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_RECIP number of recipients
          Type:  Count     (CNT)
          Range: 1 ... 255
          Dimension: none

{AP_ID application process ID (see complete list is attached to the list of all objects)
{          Type:  Byte     (HEX)
{          Range: 0x0 ... 0xFF
{          Dimension: none

{GROUP_INDEX communication group ("Funktionskreis"), it's a bit set
{          Type:  Byte     (HEX)
{          Range: 0x1 ... 0xFF
{                       ACS_ANGIO_GROUP  0x01   group 1 as used in Artis and RFU
{          Dimension: none

{DEVICE_ID internal or external communication
{          Type:  Enum8     (DEC)
{          Range: 1 ... 2
{                       ACS_VIRTUELL_COM  1   communication within one server
{                       ACS_EXT_NET       2   communication with other servers
{          Dimension: none

{SERVER_ID ID of axcs server.
110 till 119 reserved for SP applications
{          Type:  Enum8     (DEC)
{          Range: 1 ... 255
{                       ACS_SERV_ECC_1      5     ECC 1 or TUI 1
{                       ACS_SERV_ECC_2      6     ECC 2 or TUI 2
{                       ACS_SERV_ECC_3      7     ECC 3 or TUI 3
{                       ACS_SERV_WS         11    workstation
{                       ACS_SERV_VOICE      12    voice control
{                       ACS_SERV_UGEN       13    unified generator (unfortunately colliding
{                                                 with Kojen-PCs (ACS_SERV_TEST1))
{                       ACS_SERV_TEST_2     14    CRST testautomat, Factory test PC, ACSOS2,
{                                                 ALCIP, XCU TestSystem
{                       ACS_SERV_WS2        19    2. workstation, Carto XP, Carto 3
{                       ACS_SERV_WSHW       20    Workstation HW (AXBP)
{                       ACS_SERV_XCU        24    XCU in RFU systems
{                       ACS_SERV_UIS        25    UIS in XP systems
{                       ACS_SERV_STAND      26    Stand in RFU systems or system control DXP
{                                                 in Lithoskop
{                       ACS_SERV_TEST_4     28    test station 4 in RFU systems
{                       ACS_SERV_STREAM     80    camera streaming device
{                       ACS_SERV_CVC        82    CVC board (Jetson Nano) as part of Smart
{                                                 Sensing Subsystem
{                       ACS_SERV_ECC_DEF    100   default address, not used in a running
{                                                 system
{                       ACS_SERV_VIDEO_MGR  111   Video Manager, video switch to show 3rd
{                                                 party applications in Urology and Surgery
{          Dimension: none


Server IDs

All Server IDs (IP-addresses):

  ACS_SERV_ECC_1      5     ECC 1 or TUI 1
  ACS_SERV_ECC_2      6     ECC 2 or TUI 2
  ACS_SERV_ECC_3      7     ECC 3 or TUI 3
  ACS_SERV_WS         11    workstation
  ACS_SERV_VOICE      12    voice control
  ACS_SERV_UGEN       13    unified generator (unfortunately colliding with Kojen-PCs
                            (ACS_SERV_TEST1))
  ACS_SERV_TEST_2     14    CRST testautomat, Factory test PC, ACSOS2, ALCIP, XCU TestSystem
  ACS_SERV_WS2        19    2. workstation, Carto XP, Carto 3
  ACS_SERV_WSHW       20    Workstation HW (AXBP)
  ACS_SERV_XCU        24    XCU in RFU systems
  ACS_SERV_UIS        25    UIS in XP systems
  ACS_SERV_STAND      26    Stand in RFU systems or system control DXP in Lithoskop
  ACS_SERV_TEST_4     28    test station 4 in RFU systems
  ACS_SERV_STREAM     80    camera streaming device
  ACS_SERV_CVC        82    CVC board (Jetson Nano) as part of Smart Sensing Subsystem
  ACS_SERV_ECC_DEF    100   default address, not used in a running system
  ACS_SERV_VIDEO_MGR  111   Video Manager, video switch to show 3rd party applications in
                            Urology and Surgery


SEXAMLIST

Object: SEXAMLIST ___ID: 02B2

Description: Sends list of exam sets from FLC to TUI-IF. TUI-IF will pass it to TUI via
              SHPROGNAME
Sender     :   FLC
Receiver   :   TUI-IF   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

PROG_NAME_USAGE usage of the list
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_OGP_LIST      1   list of names of OGPs
                     ACS_EXAM_LIST     2   list of names of examination sets
                     ACS_ALT_LIST      3   List with alternative OGPs only (used in RFU)
                     ACS_CHANGE_ENTRY  4   only used in RFU
                     ACS_ADD_ENTRY     5   only used in RFU
                     ACS_DELETE_ENTRY  6   only used in RFU
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_EXAM_NAMES number of examination sets (long form)
          Type:  Dcount     (CNT)
          Range: 0 ... 3
          Dimension: number of data blocks

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{EXAM_INDEX Index of chosen Exam Set, to synchronize List of OGPs and EXAM-Set between TUI and Fluorospot
{          Type:  Integer16     (DEC)
{          Range: -1 ... 32767
{                       ACS_EXAM_DEFAULT  -1   FLC shall select application from default
{                                              application group (used in button based
{                                              surgery system)
{                       KK_ABWAHL         0
{                       EXAM_SET          1
{                       SETS_2_TO_31      2    Exam sets 1 to 31
{                       EXAM_SET_NRF      20
{                       KK_PROGRAM        32
{          Dimension: none

{EXAM_NAME_FLRAD Name of an Exam set for Rad or Fluoro, 64 chars UNICODE
{          Type:  String16 [ 64 ]     (ASCII)
{          Range: 128 ... 128
{          Dimension: unicode


SFANZLOESCHEN

Object: SFANZLOESCHEN ___ID: 0095

Description: clear error display, sent from XCU to displays.Telegram flow sample:
              (REP_ERR--->) iFehler ---> iFehlerAnz_2 ---> iErrorLog ---> ST_DTEXT --->
              sBedAllg ---> sResetFehler ---> iFehlerQuit ---> sFAnzLoeschen
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs
This object has no parameters


SFILTER

Object: SFILTER ___ID: 0328

Description: request of insertion of an internal copper filter; sent from XCU to
              collimator. Telegram flow sample: sBedStrm/sOrgDaten ---> sFilter ---> iFilter
              ---> iStrManAnz
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FILTER CU filter number, the Filter number is in most cases identical with the filter thickness in 0.1 mm, so 1 means 0.1 mm
          Type:  Byte     (DEC)
          Range: 0 ... 10
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SFKREKONFIG

Object: SFKREKONFIG ___ID: 0018

Description: request a change of the group-id in the XCS network. Is used in case two tubes
              are available. Then components service tube 1 are switched to group-id 1, and
              vice versa. Telegram flow sample: sOrgDaten/sBedSys ---> iSystemAnz.NotReady
              ---> sFKReKonfig ---> TurnOff.InOldGroup ---> TurnOn.InNewGroup.-->
              iSystemAnz.Ready
Sender     :   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   SCU-IF   TUI-IF   UGEN   UIS
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ZIELFKTKREIS target group-id, that should now be used by the AP-ID'(s)
          Type:  Byte     (HEX)
          Range: 0x1 ... 0x80
          Dimension: none

APANZAHL amount of AP Ids in the structure
          Type:  Count     (CNT)
          Range: 0 ... 10
          Dimension: number of data blocks

{APID Application ID (see complete list is attached to the list of all objects)
{          Type:  Byte     (HEX)
{          Range: 0x0 ... 0xFF
{          Dimension: none


SFLUORODATA

Object: SFLUORODATA ___ID: 03BE

Description: select fluoro data
Sender     :   UGEN
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

DLMODE Fluoro mode; | Samples: Standard fluoro cont: 1, Supervision: 17, Supervision Roadmap: 49, pulsed: 8, pulsed + high contrast: 10
          Type:  Byte     (DEC)
          Range: 1 ... 49
                     KONTINUIERLICH  1    continuous fluoro (=continuous wave without
                                          pulses)
                     HOCHKONTRAST    2    high contrast (equivalent to max skin dose rate is
                                          20 R/min instead of 10R/min)
                     DL_HAND         4    manual fluoro, kV and mA can be set manually
                                          without using automatic regulation (no longer
                                          permitted in Germany or USA)
                     GEPULST         8    pulsed fluoro mode
                     SUPERVISION     16   supervision, two grabbed images of a continuous
                                          fluoro are added to reduce noise
                     ROADMAP         32   Roadmap, automatic subtraction in fluoro
          Dimension: none

REGSTOP stop dose regulation in generator and keep kV and mAs values for all subsequent pulses
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MA Current of fluoro or acquisition
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA


SGENMODE

Object: SGENMODE ___ID: 02E5

Description: certain parameters for the next exposure sent from XCU to generator
Sender     :
Receiver   :
Mode       :  DIRECT(01)
Systems    :  SharpfinObs

List of Parameters:

ANODE_SPEED rotation speed of the x-ray tube anode
          Type:  Integer16     (DEC)
          Range: 0 ... 500
          Dimension: Hz

GEN_MODE generator mode (pulsed/cont.)
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_GEN_CONTINUOUS     1    generator shall emit continuous radiation
                     ACS_GEN_PULSED         2    generator shall emit pulsed radiation
                     ACS_GEN_DR_SINGLE      3    generator shall make single shot and
                                                 correct DCV with 100% (single puls mode for
                                                 single shot)
                     ACS_GEN_IEC_TEST       4    in this mode the generator shall ignore all
                                                 other parameters and shall produce a
                                                 special x-ray pulse for IEC power
                                                 measurement (100kV,100ms,max. power) on
                                                 next x-ray release
                     ACS_GEN_IDL            5    generator shall make IDL mode (interrupted
                                                 continuous fluoro mode)
                     ACS_GEN_DR_CONT_SUM    6    generator shall make DRSum mode and correct
                                                 DCV with 100% (continuous fluoro mode for
                                                 single shot)
                     ACS_GEN_DR_PULSED_SUM  7    generator shall make DRSum mode and correct
                                                 DCV with 100% (pulsed fluoro mode for
                                                 single shot)
                     ACS_GEN_3DMODE         8    special 3D mode, in which no observation of
                                                 HV-trigger is possible
                     ACS_GEN_DCM            9    DCM mode which has different handling than
                                                 "gen_pulsed"
                     ACS_GEN_DCM_CONT       10   DCM mode which has different handling for
                                                 30pps in S1P
          Dimension: none

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

DLBFREQ Fluoro pulse rate
          Type:  Integer16     (DEC)
          Range: 0 ... 600
          Dimension: 0.1 f/s

ANODE_DRIVE_REPETITION_RATE interval in which the generator shall speed up the anode (0 means: generator default)
used to avoid vibration during mask acquisition
          Type:  Byte     (DEC)
          Range: 0 ... 20
          Dimension: sec

XRPT_FL_MAX specifies the maximum length of the xray pulse (sensitive period of detector) (for fluoro)
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: ms

DLKENNL Fluoro curve. Fluoro curve is defined in a set in the organ program and the number of the curve is sent to the generator.
          Type:  Byte     (DEC)
          Range: 1 ... 100
          Dimension: none

DLKENNL_SUBIDX sub-index of fluoro curve
          Type:  Byte     (DEC)
          Range: 0 ... 9
          Dimension: none

IDL_PULSE_LENGTH_FACTOR in fluoro (IDL): number of 33ms frames to be summed up into one image (IDL k-Factor)
in DRsum: number of frames to be summed up into one image (DRsum k-Factor)
          Type:  Byte     (DEC)
          Range: 1 ... 64
          Dimension: number of 33ms periods

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

INITIAL_DLBFREQ Initial pulse rate, will be switched by image chain at certain events, such as specified frames/time or stable dose regulation (0 means not used)
          Type:  Integer16     (DEC)
          Range: 0 ... 600
          Dimension: 0.1 f/s


SGGAKTPOS

Object: SGGAKTPOS ___ID: 0427

Description: request to move, sent from XCU to stand/gantry. Telegram flow sample:
              sFDAufnDat ---> sGGAktPos ---> iGGAktPos ---> iGGAnz
Sender     :   XCU
Receiver   :   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

ANZCODE code of the parameter being transferred in PARAM
          Type:  Enum16     (DEC)
          Range: 0 ... 131
                     A_FFA_STRAHLER                  0     SID tube
                     A_ISOCENTER_HOEHE               1     isocenter height
                     A_TARGET_LAENGS                 2     target longitudinal
                     A_TARGET_QUER                   3     target transversal
                     A_TARGET_HEBEN_SENKEN           4     target lift
                     A_TARGET_DREHEN                 5     rotate target
                     A_SCHWENKWINKEL_SAEULE          6     angle of column
                     A_TUBUSKRAFT                    7     force of tubus
                     A_TISCHPLATTENDREHUNG           8     rotate table
                     A_FFA_TARGET                    9     SID target (SID forecast)
                     A_TISCH_HOEHE                   10    table height
                     A_TISCH_GERAET_KIPPEN           11    table tilt
                     A_TISCH_LAENGS                  12    table longitudinal
                     A_TISCH_QUER                    13    table transversal
                     A_KIPPMULDE                     14    baby cradle
                     A_SCHICHTHOEHE                  15    tomo height
                     A_GERAET_HEBEN_SENKEN           16    lift gantry
                     A_TUBE_ROT_HOR                  17    horizontal rotation of tube of
                                                           Rad system
                     A_STRAHLER_LAENGS               18    tube longitudinal
                     A_STRAHLER_QUER                 19    tube transversal
                     A_SHOCKHEAD_POSITION            20
                     A_TUBUS_IM_STRAHLENGANG         21    tubus (compression unit)
                     A_C_BOGEN_ORBITAL               22    position in 0.1 degree (signed
                                                           word)
                     A_C_BOGEN_ANGULAR               23    position in 0.1 degree (signed
                                                           word)
                     A_ISOCENTER_LAENGS              24    longitudinal position related to
                                                           patient
                                                           used by image system for care
                                                           graphics
                     A_FFA_BEWEGUNG                  25    SID Movement
                     A_SID_VALID_INVALID             26    SID valid or invalid (in low cost
                                                           systems there is no potentiometer
                                                           to acquire the SID continuously,
                                                           there are only two switches for
                                                           upper and lower SID. If the tube
                                                           is in between both positions, the
                                                           collimators cannot be calculated
                                                           because they require the exact
                                                           position. In order not to expose
                                                           more space than necessary, X-ray
                                                           is blocked if SID is invalid.
                                                           PARAM: 0=manual determined, 1=SID
                                                           valid, 2=SID invalid
                     A_CALIB_SWITCH                  27    Calibration switch in Ysio
                                                           stand.
                                                           PARAM: 0=No Information, 1=on,
                                                           2=off
                     A_SID_OR_SOD                    28    ==== in sBedGG: ====
                                                           Information whether SID or SOD
                                                           Button is pressed to determine
                                                           which one is measured manually by
                                                           using the tape of the collimator.
                                                           Sent from TUI If to XCU.
                                                           Param: 0 = no information; 1 =
                                                           SID; 2 = SOD
                                                           ==== in iGGAnz: ====
                                                           XCU tells TUI (via TUI Interface)
                                                           whether manual SID or SOD
                                                           measurement is possible. Also
                                                           used to acknowledge the TUI
                                                           operation.
                                                           PARAM: bit-coded, transferred
                                                           into dec:
                                                           0 = nothing possible, nothing
                                                           selected
                                                           1 = SID possible, nothing
                                                           selected
                                                           3 = SID possible, SID selected
                                                           16 = SOD possible, nothing
                                                           selected
                                                           48 = SOD possible, SOD selected
                                                           17 = SID and SOD possible,
                                                           nothing selected
                                                           19 = SID and SOD possible, SID
                                                           selected
                                                           49 = SID and SOD possible, SOD
                                                           selected
                     A_ACSS_POSSIBLE_                29    For Ysio:
                                                           XCU determines, if ACSS is active
                                                           or not and sends information via
                                                           SCU Interface to Stand
                                                           PARAM: 0 = No Information; 1 =
                                                           ACSS not possible; 2 = ACSS
                                                           active
                     A_FFA_STRAHLER_0P               30
                     A_ISOCENTER_HOEHE_0P            31
                     A_TARGET_LAENGS_0P              32
                     A_TARGET_QUER_0P                33
                     A_TARGET_HEBEN_SENKEN_0P        34
                     A_TARGET_DREHEN_0P              35
                     A_SCHWENKWINKEL_SAEULE_0P       36
                     A_KOMPRESSION_0P                37
                     A_TISCHPLATTENDREHUNG_0P        38
                     A_FFA_TARGET_0P                 39
                     A_TISCH_HOEHE_0P                40
                     A_TISCH_GERAET_KIPPEN_0P        41
                     A_TISCH_LAENGS_0P               42
                     A_TISCH_QUER_0P                 43
                     A_KIPPMULDE_0P                  44
                     A_SCHICHTHOEHE_0P               45
                     A_GERAET_HEBEN_SENKEN_0P        46
                     A_STRAHLERDREHUNG_0P            47
                     A_STRAHLER_LAENGS_0P            48
                     A_STRAHLER_QUER_0P              49
                     A_SOD_H                         50    SOD value (in 0.1 mm)
                     A_C_BOGEN_ORBITAL_0P            52
                     A_C_BOGEN_ANGULAR_0P            53
                     A_ZIELGERAET_0P                 54
                     A_AEC_CENTER_Y                  56    offset between detector center
                                                           and center of AEC chamber
                     A_STAND_SPEED                   57    speed class for stand movement:
                                                           1=ACS_SSPEED_SLOW
                                                           2=ACS_SSPEED_MEDIUM
                                                           3=ACS_SSPEED_FAST
                     A_CAREGRAPH_VALID               58    defines if the values for
                                                           careposition/profile
                                                           (ISOCENTER_QUER/_LAENGS) make
                                                           sense
                                                           1=caregraph may be shown
                                                           0=caregraph should not be shown
                     A_ISOCENTER_QUER                59    transversal position related to
                                                           patient
                                                           used by image system for care
                                                           graphics
                     A_UMBAU_1                       60
                     A_UMBAU_2                       61
                     A_UMBAU_3                       62
                     A_UMBAU_4                       63
                     A_UMBAU_5                       64
                     A_MYELOGRAPHIE                  65
                     A_PERI_PROGFAHRT                66
                     A_SCHRITTVERSCHIEBUNG           67
                     A_DET_TABLE_OUT                 68    Detector in table is pulled out.
                                                           0 == detector is in tray
                                                           1 == detector is pulled out
                                                           555 == detector is completely
                                                           pulled out
                     A_DET_WALL_OUT                  69    Detector in wall stand is pulled
                                                           out.
                                                           0 == detector is in tray
                                                           1 == detector is pulled out
                                                           555 == detector is completely
                                                           pulled out
                     A_FESTPOSITION_1                70    peri pos 1
                     A_FESTPOSITION_2                71    peri pos 2
                     A_FESTPOSITION_3                72
                     A_FESTPOSITION_4                73
                     A_FESTPOSITION_5                74
                     A_FESTPOSITION_6                75
                     A_FESTPOSITION_7                76
                     A_FESTPOSITION_8                77
                     A_CENTRAL_BEAM_HITS             78    the x-ray beam does not or does
                                                           only partially hit the detector,
                                                           such that fluoro must be blocked
                     A_FESTPOSITION_10               79    peri pos 10
                     A_ZIELGERAET_BR                 80    brakes of SFD
                     A_KOMPRESSION_BR                81    brakes of compression
                     A_ZG_TISCHMITTE_BR              82    spotfilm device brake
                     A_ZG_PARKPOSITION_BR            83    park pos brake
                     A_BREMSE_5_BR                   84
                     A_BREMSE_6_BR                   85
                     A_BREMSE_7_BR                   86
                     A_BREMSE_8_BR                   87
                     A_BREMSE_9_BR                   88
                     A_PERISCAN                      89
                     A_POSSYS                        90    positioning detector to tube
                                                           (alignment),
                                                           Meaning of PARAM:
                                                           0=ACS_NO_INFORMATION
                                                           1=MITTIG_ZENTRIERT (aligned to
                                                           center)
                                                           2=OBEN_ZENTRIERT (aligned to
                                                           upper border)
                                                           3=MITTIG_ZENTRIERT_NICHT_ERR
                                                           (center not reached)
                                                           4=OBEN_ZENTRIERT_NICHT_ERR (top
                                                           not reached)
                     A_NACHLAUF                      91    tracking mode
                                                           Meaning of Param in sBedGG:
                                                           0=both tracking functions off
                                                           2=SID tracking off / XY tracking
                                                           on
                                                           8=SID tracking on / XY tracking
                                                           off
                                                           10=both tracking functions on
                                                           Meaning of Param in other
                                                           telegrams:
                                                           ( _T_ means _TRACKING_)
                                                           0=ACS_NO_INFORMATION
                                                           1=ACS_T_X_Y_OFF
                                                           2=ACS_T_X_Y_ON
                                                           3=ACS_T_X_Y_LOST
                                                           4=ACS_T_SID_OFF
                                                           5=ACS_T_BOTH_OFF
                                                           6=ACS_T_X_Y_ON_SID_OFF
                                                           7=ACS_T_X_Y_LOST_SID_OFF
                                                           8=ACS_T_SID_ON
                                                           9=ACS_T_X_Y_OFF_SID_ON
                                                           10=ACS_T_BOTH_ON
                                                           11=ACS_T_X_Y_LOST_SID_ON
                                                           12=ACS_T_SID_LOST
                                                           13=ACS_T_X_Y_OFF_SID_LOST
                                                           14=ACS_T_X_Y_ON_SID_LOST
                                                           15=ACS_T_BOTH_LOST
                     A_TIEFENBLENDE_GEDREHT          92    collimator rotated
                     A_SPINE_CONSTRUCTION            93
                     A_CARE_POSITION                 94    enable/disable care position,
                                                           virtual table movement in Last
                                                           image hold
                     A_TIEFENBLENDE_HOR_DEZENTRIERT  95    collimator horizontal not
                                                           centered
                                                           PARAM: 1=yes; 0=no
                     A_CHANGE_ORIENTATION            96    PARAM: Bit1: horizontal
                                                           (transversal) 0=off, 1=on
                                                                          Bit2: vertical
                                                           (longitudinal) 0=off, 1=on
                                                                          Bit3: orientation:
                                                           0=stand, 1=monitor
                     A_WIGGLE_FUNCTION               97    PARAM: 1=on; 0=off
                     A_DETECTOR_ORIENTATION          98    For Ysio: Orientation of detector
                                                           relative to normal patient
                                                           position.
                                                           Param:
                                                           1= Position 1, Pixel (0,0) in
                                                           upper left corner (0°)
                                                           2= Position 2, Pixel (0,0) in
                                                           upper right corner (90°
                                                           clockwise)
                                                           3= Position 3, Pixel (0,0) in
                                                           lower right corner (180°
                                                           clockwise)
                                                           4= Position 4, Pixel (0,0) in
                                                           lower left corner (270°
                                                           clockwise)
                     A_MAGNIFICATION                 99    Factor of magnification of
                                                           objects, i.e. relation between
                                                           SID and SOD (in %)
                     A_TOP_ALIGN_POSSIBLE            100   SCU reports if top alignment is
                                                           possible (i.e. if tilt angle
                                                           <20°)
                                                           PARAM: 0=no; 1=yes
                     A_BEAM_ANGLE_ALPHA              101
                     A_TUBE_ROT_VERTICAL             102
                     A_BEAM_POS_X                    103   Offset of the central beam
                                                           relating to the center of the FD
                                                           in 0.1mm
                     A_BEAM_POS_Y                    104   Offset of the central beam
                                                           relating to the center of the FD
                                                           in 0.1mm
                     A_DET_WALL_TILT                 105   Tilting angle of detector in wall
                                                           stand.
                                                           Value in param in 0.1°
                     A_POSITION_VALID_FOR_STORAGE    106   Information whether a stand
                                                           position is valid to be stored in
                                                           an organ program.
                                                           Param: 0: no information, 1:
                                                           position is valid, 2: position is
                                                           not valid
                     A_MOVING_BEAM                   107   Limits for decentered ACSS shall
                                                           only be updated when stand is not
                                                           in motion
                                                           Param: 0: Beam is stopped, 1:
                                                           Beam is moving
                     A_MOVING_DETECTOR               108   Limits for decentered ACSS shall
                                                           only be updated when stand is not
                                                           in motion
                                                           Param: 0: Detector is stopped, 1:
                                                           Detector is moving
                     A_MOVING_TABLE                  109   Limits for decentered ACSS shall
                                                           only be updated when stand is not
                                                           in motion
                                                           Param: 0: Table is stopped, 1:
                                                           Table is moving
                     A_AUTO_MOVEMENT                 110   stand performs automatic
                                                           movement:
                                                           0 = ACS_AUTO_MOVEMENT_INACTIVE
                                                           1 = ACS_AUTO_MOVEMENT_ACTIVE
                                                           2 = ACS_AUTO_MOVEMENT_PENDING
                     A_ORTHO_POS1                    111   Param: ACS_ORTHOPOS_NOT_SET,
                                                           ACS_ORTHOPOS_SET,
                                                           ACS_ORTHOPOS_INVALID
                     A_ORTHO_POS2                    112   Param: ACS_ORTHOPOS_NOT_SET,
                                                           ACS_ORTHOPOS_SET,
                                                           ACS_ORTHOPOS_INVALID
                     A_TDD                           113   table detector distance in 0.1mm
                     A_ORTHO_STEP                    114   current step (or state) in the
                                                           ortho flow:
                                                           1 not in Ortho position (Move
                                                           button has to be pressed)
                                                           2 mark first ortho pos
                                                           3 mark second ortho pos
                                                           4 ready to move to first Image
                                                           pos
                                                           5 ready for apply X-ray
                                                           6 X-ray is running
                                                           7 X-ray is over and stand is
                                                           moving to ortho start pos
                                                           8 ortho is completed
                                                           9 ortho is finished
                                                           10 ortho is aborted
                                                           11 ortho cannot be started
                     A_SOFTSTOP                      115   activates or deactivates the
                                                           SoftStop function
                     A_PATIENT_TRANSFER              116   param: 1=on, 0=off
                     A_TOMOADJUST                    117   system shall move to a position
                                                           in which the tomo fulcrum height
                                                           (Schichthöhe) can be adjusted
                                                           using the laser line of the
                                                           collimator
                     A_MOVE_DISABLE                  118   any movement blocked on users
                                                           request
                     A_BEAM_ANGLE_BETA               119
                     A_FINAL_POSITION_REACHED        120   The OGP position is reached. This
                                                           value is taken as a trigger to
                                                           (re)send the OGP collimation
                                                           values to the collimator
                     A_STORE_POS                     121   store the current stand position
                                                           (PARAM contains the position
                                                           number); used in urology
                     A_RECALL_POS                    122   recall the previously stored
                                                           stand position; used in urology
                     A_COLOR_ORBITAL                 123   defines the color of the display
                                                           of orbital c-arm angle
                                                           PARAM is divided into two enums:
                                                           bit 7-0: COLOR; bit 15-8: ARROW
                                                           with COLOR: 0-don't care,
                                                           1-normal, 2-out of range, 3-in
                                                           range, 4-pos reached
                                                           and ARROW: 0-don't care, 1-no
                                                           arrow, 2-left/up, 3-right/down,
                                                           4-pos reached
                     A_COLOR_ANGULAR                 124   defines the color of the display
                                                           of angular c-arm angle
                                                           PARAM is divided into two enums:
                                                           bit 7-0: COLOR; bit 15-8: ARROW
                                                           with COLOR: 0-don't care,
                                                           1-normal, 2-out of range, 3-in
                                                           range, 4-pos reached
                                                           and ARROW: 0-don't care, 1-no
                                                           arrow, 2-left/up, 3-right/down,
                                                           4-pos reached
                     A_BYPASS_PARK_POS               125   (used in Luminos Fusion)
                     A_STORE_C_ANGLE                 126   store current c-arm angles (used
                                                           in surgery)
                                                           PARAM=0: disable storage
                                                           PARAM=n store to memory position
                                                           n
                     A_RECALL_C_ANGLE                127   PARAM contains the position
                                                           number to be recalled. XCU uses
                                                           this to determine, which position
                                                           shall be compared to iGGActPos
                                                           (used in surgery)
                     A_SET_RESET_3D_ENDPOS           128   Param: 0 = ACS_NO_INFORMATION, 1
                                                           = Set end position, 2 = Reset end
                                                           position
                     A_SET_RESET_3D_STARTPOS         129   Param: 0 = ACS_NO_INFORMATION, 1
                                                           = Set start position, 2 = Reset
                                                           start position
                     A_MANUAL_ALIGNMENT_KIT          130   new parameter for ACSS process
                                                           when manual table's alignment kit
                                                           is loosened.
                                                           Used for reporting the
                                                           alignment-kit's status in manual
                                                           tube stand, eg telling whether
                                                           tube stand and detector is
                                                           aligned. Belongs to ACSS's
                                                           function for manual tube stand
                                                           configuration.
                     A_CP_POSITION_MATCH             131   The (relative or absolute) CP
                                                           position is more or less reached
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none


SGGNAVIPOS

Object: SGGNAVIPOS ___ID: 01B9

Description: navigation system sends desired values to SCU.
              This is put into the position memory in SCU, such that it can be recalled by
              "move to stored position"
              (used in surgey)
Sender     :   XWP
Receiver   :   GG_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

POSNO current preselect memory position
          Type:  Integer16     (DEC)
          Range: 0 ... 50
                     ACS_PRESENT_POSITION  0
          Dimension: Position Number

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANGUL_A angulation (geometric angle) in A
          Type:  Integer16     (DEC)
          Range: -3600 ... 3600
          Dimension: 0.1 degree

ORBITAL_A orbital (geometric angle) in A
          Type:  Integer16     (DEC)
          Range: -3600 ... 3600
          Dimension: 0.1 degree


SGGPERISCAN

Object: SGGPERISCAN ___ID: 01A5

Description: Selecting periscanning (moving table or spotfilm device continuously
              (eventually with double speed) while acquisition series is on);= Brakes are
              released during acq. Sent from XCU to components Telegram flow sample: sBedGG
              ---> sGGPeriscan ---> iGGPeriscan ---> iGGAnz
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

PERISCAN Periscan selection
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none


SGGPOS

Object: SGGPOS ___ID: 01A9

Description: control of tube/detector positioning and tracking mode for Aristos sent from
              XCU to components.
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

POSSYS positioning detector to tube
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION              0
                     MITTIG_ZENTRIERT                1   center to center alignment
                     OBEN_ZENTRIERT                  2   upper edge to upper edge alignment
                                                         (top alignment)
                     MITTIG_ZENTRIERT_NICHT_ERREICH  3   center alignment not reached
                     OBEN_ZENTRIERT_NICHT_ERREICHT   4   top alignment not reached
          Dimension: none

NACHLAUF Tracking mode
          Type:  Enum8     (DEC)
          Range: 0 ... 15
                     ACS_NO_INFORMATION             0
                     ACS_TRACKING_X_Y_OFF           1
                     ACS_TRACKING_X_Y_ON            2
                     ACS_TRACKING_X_Y_LOST          3
                     ACS_TRACKING_SID_OFF           4
                     ACS_TRACKING_BOTH_OFF          5
                     ACS_TRACKING_X_Y_ON_SID_OFF    6
                     ACS_TRACKING_X_Y_LOST_SID_OFF  7
                     ACS_TRACKING_SID_ON            8
                     ACS_TRACKING_X_Y_OFF_SID_ON    9
                     ACS_TRACKING_BOTH_ON           10
                     ACS_TRACKING_X_Y_LOST_SID_ON   11
                     ACS_TRACKING_SID_LOST          12
                     ACS_TRACKING_X_Y_OFF_SID_LOST  13
                     ACS_TRACKING_X_Y_ON_SID_LOST   14
                     ACS_TRACKING_BOTH_LOST         15
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SGROUP

Object: SGROUP ___ID: 0BC7

Description: sGroup has to be sent, in order to make XCU sent telegrams like sServTestCmd,
              sServJustCmd, sService; sent from Service PC to XCU. Is only necessary for
              components still using XCS service like Uroskop, Luminos dRF and Luminos RF
              classic Telegram flow sample aPassWort ---> iPassWort ---> sGroup
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs
This object has no parameters


SH_3D_PARAMS

Object: SH_3D_PARAMS ___ID: 101A

Description: information on current position and status of the 3D trajectory
Sender     :   SCU
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TRAJCT_CUR_POS current position on the trajectory (refering to acq runtime)
          Type:  Dword     (DEC)
          Range: 0 ... 200000
          Dimension: ms

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SID_A source image distance (the ANG is not able to handle more than 4200 mm)
          Type:  Integer16     (DEC)
          Range: 500 ... 4200
          Dimension: mm

TRAJCT_STATE status of the 3D procedure
          Type:  Enum8     (DEC)
          Range: 0 ... 13
                     ACS_NO_INFORMATION          0
                     ACS_TRAJ_INITIAL            1    the trajectory (w/o transfer position)
                                                      has been selected
                     ACS_TRAJ_START_POS          2    the initial OGP position has been
                                                      reached, but the test run has not been
                                                      performed
                     ACS_TRAJ_TEST_RUN           3    the system has left the OGP position
                                                      to perform the test run
                     ACS_TRAJ_END_POS_REACHED    6    the end position of the trajectory has
                                                      been reached during test run
                     ACS_TRAJ_ABORTED            7    the trajectory run has been aborted
                                                      (e.g. by blocking or by manual user
                                                      action)
                     ACS_TRAJ_START_POS_REACHED  8    test run has been performed
                                                      successively and system is back at
                                                      start position
                     ACS_TRAJ_READY_FOR_SCAN     9    test run is finalized, system is at
                                                      start position and ready for
                                                      acquisition run
                     ACS_TRAJ_SCANNING           10   the acquisition scan is running
                     ACS_TRAJ_SCAN_COMPLETE      11   the acquisition scan is complete
                     ACS_TRAJ_TRANSFER_POS       12   system is in patient transfer position
                                                      (for this trajectory)
                     ACS_TRAJ_INITIAL_TRANS_POS  13   the trajectory with transfer position
                                                      has been selected
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

TRAJCT_FLAGS state flags refering to the current trajectory position
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_TRAJFLG_FLUOROPOS_1  0x0001 first fluoro position reached
                     ACS_TRAJFLG_FLUOROPOS_2  0x0002 second fluoro position reached
          Dimension: it's a set

TRAJCT_START_POSITION Start position of the trajectory. The direction depends on the trajectory itself (e.g. height for upright trajectories)
This parameter is also put into DICOM to match the nearest calibration position.
          Type:  Dword     (DEC)
          Range: 0 ... 200000
          Dimension: 0.1mm

CERA_VOL_ROT_A rotation angle of reconstructed volume (depends on trajectory)
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1°

CERA_VOL_ROT_B rotation angle of reconstructed volume (depends on trajectory)
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1°

CERA_VOL_ROT_C rotation angle of reconstructed volume (depends on trajectory)
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1°

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_ADJUST

Object: SH_ADJUST ___ID: 1804

Description: show actual adjustment (defined in PMS document)
Sender     :   ALL   CCU_A   SCU   TUI
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ADJ_STATUS status
          Type:  Enum8     (DEC)
          Range: 1 ... 18
                     ACS_ADJ_RUNNING            1    ADJ_DURATION required
                     ACS_ADJ_COMPLETED          2
                     ACS_ADJ_ABORTED            3
                     ACS_ADJ_ERROR              4
                     ACS_ADJ_DATA               5    data in DATA_AREA
                     ACS_ADJ_FILETRANS_OK       6    adjust data transfer successful
                     ACS_ADJ_FILETRANS_NOK      7    error while adjust data transfer
                     ACS_ADJ_REQ_INPUT          8
                     ACS_ADJ_FILETRANS_NODATA   9    no data available
                     ACS_ADJ_RETRY              10
                     ACS_ADJ_FILETRANS_RUNNING  11   File transfer running
                     ACS_ADJ_DATARESET_OK       12
                     ACS_ADJ_DATARESET_NOK      13
                     ACS_ADJ_MESSAGE            14   ADJ_DATA contains a message to be
                                                     displayed
                     ACS_ADJ_INPUT_OK           15   input settings ok
                     ACS_ADJ_INPUT_NOK          16   input settings not ok
                     ACS_ADJ_MOVING             17
                     ACS_ADJ_STEP_COMPLETED     18
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IDENTIFIER identifier for adjust and diag
          Type:  Integer16     (DEC)
          Range: -1 ... 30000
                     ACS_ADJ_ALL_FILES               -1
                     ACS_ADJUST_ID_TUBE_STRAHLER1    1     initiate tube adjust
                     ACS_ADJUST_ID_TUBE_STRAHLER2    2     initiate tube adjust
                     ACS_ADJUST_ID_MAS_RELAIS        3
                     ACS_ADJUST_ID_INVERTER          4
                     ACS_ADJUST_ID_FLUORO            5
                     ACS_ADJUST_ID_SP_INVERTER       6
                     ACS_ADJUST_ID_F80_IONTO         7     dose iontomat: sensitivity and
                                                           "Vorhalt".
                                                           (replaces GEN_ICO_F80_DOSE
                                                           _IONTOMAT_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_RESP  8     voltage curve
                                                           (replaces GEN_ICO_F80_VOLTAGE
                                                           _RESPONSE_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_COR   9     AEC dose correction.
                                                           (replaces GEN_ICO_F80
                                                           _VOLTAGE_CORRECTION_ADJUST_ID)
                     ACS_ADJUST_ID_F80_DEXI          10    DEXI adjust:
                                                           -> generator set to adjust in 1/4
                                                           EP steps (rather than 1/2 EP)
                                                           -> ImgSys switches to DEXI adjust
                     ACS_ADJUST_ID_II_DOSE_IRIS      11    mA reference value (determined
                                                           during "Dose TV Iris" adjustment)
                     ACS_ADJUST_ID_II_IRIS_BRIGHT    12    correction value for Iris (in BP)
                                                            (determined during "Dose TV
                                                           Iris" adjustment)
                     ACS_ADJUST_ID_II_ZOOM_IRIS      13    correction value for iris in zoom
                                                           mode (in BP)  (determined during
                                                           "Zoom Iris Correction"
                                                           adjustment)
                     ACS_ADJUST_ID_II_TV_PARAM       14    value for iris in video mode (in
                                                           EP) (determined during "TV
                                                           Parameters" adjustment)
                     ACS_ADJUST_ID_GEN_WARMUP        15    used to start automatic warm up
                                                           procedure on generator
                     ACS_ADJUST_ID_COLL_ADAPT        16    adjustment needed for collimator
                                                           adaption
                     ACS_ADJUST_ID_COOLPUMP          17    manually switch cooling pump on
                                                           or off for service
                     ACS_ADJUST_ID_II_IRIS_RANGE     18    maximum attenuation of the iris
                                                           (w/o gray filter)
                     ACS_ADJUST_ID_GRAY_FLT_STRT_PT  19    maximum opening of the iris with
                                                           gray filter
                                                           (in case the gray filter does not
                                                           cover the full opening of the
                                                           iris)
                     ACS_ADJUST_ID_FD_ATTACH         20    start attachment procedure of
                                                           detector and docking station
                     ACS_ADJUST_ID_FD_BATTCAL        21    start battery calibration of
                                                           portable FD detector
                     ACS_ADJUST_ID_FD_WLAN           22    set WLAN settings
                     ACS_ADJUST_ID_COLL_ACCURACY     23    adjust collimator accuracy
                                                           (needed in Rad3)
                     ACS_ADJUST_ID_TUBE_CONDITION    24    tube conditioning (used with
                                                           unified generator)
                     ACS_ADJUST_ID_IRISCALIBRATION   25    start iris calibration procedure
                     ACS_ADJUST_ID_AIR_KERMA_RATE    26    start air kerma rate adjustment
                     ACS_ADJUST_ID_RCP_ATTACHMENT    27    start TUI/RCP attachment
                     ACS_ADJUST_ID_CARM_ATTACHMENT   28    start C-ARM attachment
                     ACS_ADJUST_ID_DICOM_WLAN        29    adjust DICOM access point
                     ACS_ADJUST_ID_FDCAL_TEMP        30
                     ACS_ADJUST_ID_FDCAL_MULTIGAIN   31
                     ACS_ADJUST_ID_FDCAL_STAT_DELTA  32
                     ACS_ADJUST_ID_FDCAL_DYN_DELTA   33
                     ACS_ADJUST_ID_FDCAL_DEFECT_DET  34
                     ACS_ADJUST_ID_SCU_ROTACQ        40    SCU settings rotational acq
                     ACS_ADJUST_ID_SCU_ROTACQ_POS    41    SCU rotational acq, reachability
                                                           of start position
                     ACS_ADJUST_ID_MCU_ANGULAR_ZERO  50    set C-Arm angular angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_ZERO  51    set C-Arm orbital angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_MAX   52
                     ACS_ADJUST_ID_MCU_ORBITAL_MIN   53
                     ACS_ADJUST_ID_MCU_HF_SIGNALS    54    monitors MCU hand/footswitch
                                                           signals
                     ACS_ADJUST_ID_MCU_HW_SIGNALS    55    monitors MCU hardware signals
                     ACS_ADJUST_ID_MCU_FORMAT_FS     56    format file system on MCU
                     ACS_ADJUST_ID_MCU_RESET_TEMP    57    reset min max temperature
                     ACS_ADJUST_ID_MCU_VRT_TORQUE    58    set high torque for vertical lift
                                                           drive
                     ACS_ADJUST_ID_ETH_CONNECTIONS   59    monitor ethernet connections
                     ACS_ADJUST_ID_MCU_MOVE_SIGNALS  60    monitors MCU movement signals
                     ACS_ADJUST_ID_MCU_EMCY_SIGNALS  61    monitors MCU emergency and power
                                                           supply signals
                     ACS_ADJUST_ID_MCU_RESET_MILAGE  62    reset orbital/angular milage
                                                           information
                     ACS_ADJUST_ID_MCU_WFSW_PAIRING  64    enter pairing mode of the
                                                           wireless receiver
                     ACS_ADJUST_ID_MCU_WFSW_MONITOR  65    monitors status information of
                                                           wireless footswitch
                     ACS_ADJUST_ID_CALIB3D_GEO       70    3D geometric calibration
                     ACS_ADJUST_ID_CALIB3D_IZERO     71    iZero calibration for 3D
                     ACS_ADJUST_ID_CALIBTOPO_IZERO   72    iZero calibration for 2D_TOPO
                                                           (=SKELMAL)
                     ACS_ADJUST_ID_CAM3D_CALIB       75    calibration of 3D camera at tube
                                                           head
                     ACS_ADJUST_ID_RESET_MRAM        80    reset MRAM of XCU or MCU (thus
                                                           restore factory defaults)
                     ACS_ADJUST_ID_SELECT_TUBE1      85
                     ACS_ADJUST_ID_SELECT_TUBE2      86
                     ACS_ADJUST_ID_CTRL_XRAY         87    X-Ray Control
                     ACS_ADJUST_ID_WW                90    water value correction
                     ACS_ADJUST_ID_IEC_TEST          91    Set specific x-ray parameters
                                                           (working points) for IEC tests.
                                                           (used in surgery)
                     ACS_ADJUST_ID_NORMATIVE_TESTS   92    Set specific x-ray parameters
                                                           (working points) for various
                                                           normative tests. (used in
                                                           surgery)
                     ACS_ADJUST_ID_APH_SOLIDFICATN   101   AppHosting: manage solidification
                                                           software
                     ACS_ADJUST_ID_APH_SWITCH_MODE   102   AppHosting: switch to App Mode
                                                           via Service
                     ACS_ADJUST_ID_APH_SWITCH_ENV    103   AppHosting: switch the active
                                                           environment
                     ACS_ADJUST_ID_APH_CREATE_ENV    104   AppHosting: create a new
                                                           environment
                     ACS_ADJUST_ID_APH_EXPORT_DATA   105   AppHosting: export vendor data
                                                           (logfiles)
                     ACS_ADJUST_ID_APH_LICENSES      106   AppHosting: manage application
                                                           licenses
                     ACS_ADJUST_ID_APH_INSTALL_APP   107   AppHosting: install or update
                                                           applications
                     ACS_ADJUST_ID_APH_LANGUAGE      108   AppHosting: change language
                                                           settings
                     ACS_ADJUST_ID_APH_BIOS          109   AppHosting: access BIOS
                     ACS_ADJUST_ID_STAND_CENTERING   157   The number 157 is used in SCU for
                                                           Centering Adjustment
                     ACS_DIAG_ID_IS_VERSION          300
                     ACS_DIAG_ID_IS_HOST_ID          301
                     ACS_DIAG_ID_IS_DONGLE_ID        302
                     ACS_DIAG_ID_IS_FREE_HD          303
                     ACS_DIAG_ID_IS_FREE_MEMORY      304
                     ACS_DIAG_ID_IS_CONFIG_ISSUE     305
                     ACS_DIAG_ID_IS_OS_INFO          306
                     ACS_DIAG_ID_CPU_INFO            307
                     ACS_DIAG_ID_DICOM_ARCH_NODE     308
                     ACS_DIAG_ID_DICOM_MPPS_NODE     309
                     ACS_DIAG_ID_DICOM_MWL_NODE      310
                     ACS_DIAG_ID_DICOM_PRINT_NODE    311
                     ACS_DIAG_ID_FD2430_TYPE         340
                     ACS_DIAG_ID_FD2430_SN           341
                     ACS_DIAG_ID_FD2430_SW           342
                     ACS_DIAG_ID_FD2430_FW           343
                     ACS_DIAG_ID_FD2430_LIFETIME     344
                     ACS_DIAG_ID_FD2430_POWERON      345
                     ACS_DIAG_ID_FD2430_TEMPERATURE  346
                     ACS_DIAG_ID_FD2430_WIFI         347
                     ACS_DIAG_ID_FD2430_SHOCK        348
                     ACS_DIAG_ID_FD3543_TYPE         360
                     ACS_DIAG_ID_FD3543_SN           361
                     ACS_DIAG_ID_FD3543_SW           362
                     ACS_DIAG_ID_FD3543_FW           363
                     ACS_DIAG_ID_FD3543_LIFETIME     364
                     ACS_DIAG_ID_FD3543_POWERON      365
                     ACS_DIAG_ID_FD3543_TEMPERATURE  366
                     ACS_DIAG_ID_FD3543_WIFI         367
                     ACS_DIAG_ID_FD3543_SHOCK        368
                     ACS_DIAG_ID_FD4343_TYPE         380
                     ACS_DIAG_ID_FD4343_SN           381
                     ACS_DIAG_ID_FD4343_SW           382
                     ACS_DIAG_ID_FD4343_FW           383
                     ACS_DIAG_ID_FD4343_LIFETIME     384
                     ACS_DIAG_ID_FD4343_POWERON      385
                     ACS_DIAG_ID_FD4343_TEMPERATURE  386
                     ACS_DIAG_ID_FD4343_WIFI         387
                     ACS_DIAG_ID_FD4343_SHOCK        388
          Dimension: none

ADJ_DURATION duration of adjust (INIL or -1 will show "--" in PMS)
          Type:  Integer16     (DEC)
          Range: 0 ... 3600
          Dimension: 1 sec

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_ADJ_DATA length of data array
          Type:  Dcount     (CNT)
          Range: 0 ... 1440
          Dimension: [Byte]

{ADJ_DATA data array, may be an ASCII string too
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SH_COL_A

Object: SH_COL_A ___ID: 2526

Description: show COL A ready for x-ray
Sender     :   CCU_A
Receiver   :   CCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

RSTATUS ready status information
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_READY      1   ready
                     ACS_NOT_READY  2   not ready
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

XRPARN x-ray parameter set number
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_ACQ_MIN_PS  0x0001 range 0001H to 00FFH is for ACQ
                     ACS_ACQ_MASK    0x00FF mask for all possible acq programs
                     ACS_FL_MIN_PS   0x0100 range 0100H to FF00H is for FLUORO
                     ACS_FL_MASK     0x0F00 mask for all possible fluoro programs
                     ACS_EMERG_PS    0x8000 value 8000H is emergency fluoro
          Dimension: none

INDEX index for x-ray release (SH_PREP etc.)
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: none

NEXT_POS last position in case of review values, next position while moving, else position reached
          Type:  Integer8     (DEC)
          Range: -11 ... 11
          Dimension: Position No

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_COLPAR_A

Object: SH_COLPAR_A ___ID: 1213

Description: show collimator values plane A
Sender     :   CCU_A
Receiver   :   CCU-IF   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

DISMODE indicates preview, actual settings or review values. Used in different objects, but not all values are always available.
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_PREVIEW            1   Forecast
                     ACS_ACTUAL_SETTINGS    2   Actual values
                     ACS_REVIEW             3   Values after x-ray
                     ACS_PREVIEW_ON_REQ     4   Forecast on request (SH_DYNA_PAR only)
                     ACS_COLLISION_CHECKED  5   collision checked (SH_STPAR only)
                     ACS_DISPLAY_GRAPHIC    6   display graphic (SH_STPAR only), (EAS only)
          Dimension: none

VERSION_SHCOLPAR version of the object SH_COLPAR_A\B
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHCOLPAR  1   version 0 from the beginning
                                         version 1 since VD00D: extension for asym.
                                         Collimation in RFU only
          Dimension: none

NEXT_POS last position in case of review values, next position while moving, else position reached
          Type:  Integer8     (DEC)
          Range: -11 ... 11
          Dimension: Position No

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MOVE_COL RFU only: kind of movement of the collimator
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_COL_MAN_MOVEMENT   0   manual movement by an user
                     ACS_COL_AUTO_MOVEMENT  1   automatic movement of the collimator
          Dimension: none

BL_WIDTH beam limitation width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_HEIGHT beam limitation height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_DIAM beam limitation diameter
          Type:  Integer16     (DEC)
          Range: 0 ... 32000
          Dimension: 0.1 mm

RE_WIDTH rectangular shutter width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

RE_HEIGHT rectangular shutter height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

IR_DIAM diameter iris
          Type:  Integer16     (DEC)
          Range: 0 ... 7200
          Dimension: 0.1 mm

FI_ANG finger turn angle
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

FI_POS finger position
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

FI_SIZE size of the semitransparent finger filter
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: 0.1 mm

AT_ANG1 semitransparent attenuator turn angle 1
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS1 semitransparent attenuator position 1
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE1 size of semitransparent attenuator 1
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

AT_ANG2 semitransparent attenuator turn angle 2
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS2 semitransparent attenuator position 2
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE2 size of semitransparent attenuator 2
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

COL_SHUTTER kind of collimation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY   0   do not display the icons of semitr.
                     ACS_DISP_SQUARE  1   display the icon of square
                     ACS_DISP_IRIS    2   display the icon of iris
          Dimension: none

COL_SEMITRANS kind of semitransparent filters
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY       0   do not display the icons of semitr.
                     ACS_DISP_FINGER      1   display the icon of finger filter
                     ACS_DISP_ATTENUATOR  2   display the icon of attenuator
          Dimension: none

COL_SHUTTERHOME rectangular shutter is fully open
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

COL_DSAHOME DSA collimator (semitransparent filters) fully open / out of visible field
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

COL_OFFSET_X RFU only: offset X of the symmetric collimator relating to the middle of the image
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm

COL_OFFSET_Y RFU only: offset Y of the symmetric collimator relating to the middle of the image
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm

LIGHT_LOC RFU only: light localizer
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
                     ACS_TOGGLE          3   toggle
          Dimension: none

COLL_ROT_SWITCH RFU only: actual state of switch for collimator rotation
1=ON=collimator aligned
2=OFF=collimator rotated
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MEASURED_VALUE RFU only: measured value
          Type:  Integer32     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

COL_MANUAL Defines User-Events for XCU
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0xF
                     BUTTON_EVENT_HOME_ALL        0x01   Home Button All active
                     BUTTON_EVENT_HOME_RECT_IRIS  0x02   Home Button Rect/Iris active
                     JOY_KNOB_MOVE_EVENT_RECT     0x04   Joystick or Knobs active
          Dimension: it's a set

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_COLPAR_B

Object: SH_COLPAR_B ___ID: 1214

Description: show collimator values plane B
Sender     :   CCU_B
Receiver   :   CCU-IF   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

DISMODE indicates preview, actual settings or review values. Used in different objects, but not all values are always available.
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_PREVIEW            1   Forecast
                     ACS_ACTUAL_SETTINGS    2   Actual values
                     ACS_REVIEW             3   Values after x-ray
                     ACS_PREVIEW_ON_REQ     4   Forecast on request (SH_DYNA_PAR only)
                     ACS_COLLISION_CHECKED  5   collision checked (SH_STPAR only)
                     ACS_DISPLAY_GRAPHIC    6   display graphic (SH_STPAR only), (EAS only)
          Dimension: none

VERSION_SHCOLPAR version of the object SH_COLPAR_A\B
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHCOLPAR  1   version 0 from the beginning
                                         version 1 since VD00D: extension for asym.
                                         Collimation in RFU only
          Dimension: none

NEXT_POS last position in case of review values, next position while moving, else position reached
          Type:  Integer8     (DEC)
          Range: -11 ... 11
          Dimension: Position No

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MOVE_COL RFU only: kind of movement of the collimator
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_COL_MAN_MOVEMENT   0   manual movement by an user
                     ACS_COL_AUTO_MOVEMENT  1   automatic movement of the collimator
          Dimension: none

BL_WIDTH beam limitation width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_HEIGHT beam limitation height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_DIAM beam limitation diameter
          Type:  Integer16     (DEC)
          Range: 0 ... 32000
          Dimension: 0.1 mm

RE_WIDTH rectangular shutter width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

RE_HEIGHT rectangular shutter height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

IR_DIAM diameter iris
          Type:  Integer16     (DEC)
          Range: 0 ... 7200
          Dimension: 0.1 mm

FI_ANG finger turn angle
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

FI_POS finger position
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

FI_SIZE size of the semitransparent finger filter
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: 0.1 mm

AT_ANG1 semitransparent attenuator turn angle 1
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS1 semitransparent attenuator position 1
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE1 size of semitransparent attenuator 1
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

AT_ANG2 semitransparent attenuator turn angle 2
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS2 semitransparent attenuator position 2
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE2 size of semitransparent attenuator 2
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

COL_SHUTTER kind of collimation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY   0   do not display the icons of semitr.
                     ACS_DISP_SQUARE  1   display the icon of square
                     ACS_DISP_IRIS    2   display the icon of iris
          Dimension: none

COL_SEMITRANS kind of semitransparent filters
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY       0   do not display the icons of semitr.
                     ACS_DISP_FINGER      1   display the icon of finger filter
                     ACS_DISP_ATTENUATOR  2   display the icon of attenuator
          Dimension: none

COL_SHUTTERHOME rectangular shutter is fully open
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

COL_DSAHOME DSA collimator (semitransparent filters) fully open / out of visible field
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

COL_OFFSET_X RFU only: offset X of the symmetric collimator relating to the middle of the image
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm

COL_OFFSET_Y RFU only: offset Y of the symmetric collimator relating to the middle of the image
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm

LIGHT_LOC RFU only: light localizer
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
                     ACS_TOGGLE          3   toggle
          Dimension: none

COLL_ROT_SWITCH RFU only: actual state of switch for collimator rotation
1=ON=collimator aligned
2=OFF=collimator rotated
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MEASURED_VALUE RFU only: measured value
          Type:  Integer32     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

COL_MANUAL Defines User-Events for XCU
          Type:  Enum8     (HEX)
          Range: 0x0 ... 0xF
                     BUTTON_EVENT_HOME_ALL        0x01   Home Button All active
                     BUTTON_EVENT_HOME_RECT_IRIS  0x02   Home Button Rect/Iris active
                     JOY_KNOB_MOVE_EVENT_RECT     0x04   Joystick or Knobs active
          Dimension: it's a set

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_COMP_STATE

Object: SH_COMP_STATE ___ID: 1035

Description: This telegram is sent by XCU upon request via RQ_OBJECT. It is used to show
              the components and their status seen by XCU.
Sender     :   XCU
Receiver   :   ALL
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

NO_COMPONENTS
          Type:  Dcount     (CNT)
          Range: 1 ... 50
          Dimension: number of components

{AP_ID application process ID (see complete list is attached to the list of all objects)
{          Type:  Byte     (HEX)
{          Range: 0x0 ... 0xFF
{          Dimension: none

{READY_STATUS ready status information
{          Type:  Enum8     (DEC)
{          Range: 1 ... 2
{                       ACS_READY      1   ready
{                       ACS_NOT_READY  2   not ready
{          Dimension: none


SH_CONFIG

Object: SH_CONFIG ___ID: 1802

Description: accept new configuration as defined in ST_CONFIG
Sender     :   CCU_A   SCU   TUI
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

CFG_ACK acknowledge configuration
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_OK      1   the state is okay or accepted
                     ACS_NOK     2   the state is not okay or not accepted
                     ACS_NODATA  3   no data available
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_REPLY length of string
          Type:  Dcount     (CNT)
          Range: 0 ... 80
          Dimension: count of elements

{REPLY_TEXT reply, if something is not ok, variable length UNICODE
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


SH_CUR_DET_DATA

Object: SH_CUR_DET_DATA ___ID: 1018

Description: This object contains some data of the currently selected FD detector. It is
              meant to be sent periodically.
Sender     :   FLC_TV
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

DETECTOR_PLANE identifier for the detector being addressed
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_NO_INFORMATION     0
                     ACS_FD_TABLE           1    detector mounted in the table
                     ACS_FD_WALL            2    FD mounted in the wall stand
                     ACS_FD_PORTABLE        3    free portable detector
                     ACS_FD_WALLCHARGER     4    portable detector in wall charger
                     ACS_FD_STAND           7    detector mounted in the dTF stand
                     ACS_FD_C_ARM           8    detector on c-arm in surgery
                     ACS_FD_FLEXIBLE        9    detector of Multitom Rax system
                     ACS_FD_SMALL_PORTABLE  10   small portable detector
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DET_ANGLE_PITCH detected rotation of portable detector
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DET_ANGLE_ROLL detected rotation of portable detector
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DET_ANGLE_YAW detected rotation of portable detector
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree


SH_DATA_TRANS

Object: SH_DATA_TRANS ___ID: 180A

Description: Confirm transfer of data.The parameter DATA_IDENT is the reply of
              ST_DATA_TRANS. If it can not provided, ACS_NOT_DEFINED should be sent.
Sender     :   CCU_A   SCU   TUI
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DATA_ACK acknowledge data transfer
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_OK             1   the state is okay or accepted
                     ACS_NOK            2   the state is not okay or not accepted
                     ACS_NODATA         3   no data available
                     ACS_STILL_RUNNING  4   Adjust is still running
          Dimension: none

DATA_IDENT Identifier of data transfer
          Type:  Enum8     (DEC)
          Range: 0 ... 16
                     ACS_NOT_DEFINED           0    not defined
                     ACS_DAT_OGP_EXAM          1    transfer EXAMSETS package
                     ACS_DAT_GENERAL           2    transfer GENERAL package
                     ACS_DAT_GEN_PLUS_CAF      3    transfer GENERAL package plus CAF file
                                                    (only with DATA_SUPPLY)
                     ACS_DAT_UI_FLASH          4    transfer flash file system (ECC and
                                                    DDIS)
                     ACS_DAT_REPORT            5    transfer REPORT package
                     ACS_DAT_FDDATA            6    transfer FDDATA package
                     ACS_DAT_START_POS_LIST    7    transfer list of start positions
                     ACS_DAT_FDCALIB           8    transfer data from RadFluoro Detector
                                                    (Pixelshift, DefectMap,TempMatrix)
                     ACS_DAT_LD_LAYOUTS        9    transfer layouts of large display (WSD)
                     ACS_DAT_LD_SNAPSHOT_CH_1  10   transfer snapshot of LargeDisplay
                                                    (channel 1)
                     ACS_DAT_LC_SNAPSHOT_CH_1  11   transfer snapshot of Lab Cockpit channel
                                                    1
                     ACS_DAT_LC_SNAPSHOT_CH_2  12   transfer snapshot of Lab Cockpit channel
                                                    2
                     ACS_DAT_IC_DIRECT         13   Transfer files of COCA board
                                                    (configuration, calibration results)
                     ACS_DAT_ERROR_LOG         14   transfer error log data
                     ACS_DAT_ERROR_SUPPRESS    15   transfer error suppress list
                     ACS_DAT_FLUORO_AAF        16   transfer of fluoro aaf
          Dimension: none

DATA_PROGRESS progress of data transfer
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_REPLY length of string
          Type:  Dcount     (CNT)
          Range: 0 ... 80
          Dimension: count of elements

{REPLY_TEXT reply, if something is not ok, variable length UNICODE
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


SH_DET_POS

Object: SH_DET_POS ___ID: 102B

Description: show the current position of the portable detector (in tube coordinates)
              -- draft proposal --
Sender     :   SMSN
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

DETPOS_RESULT state of the detector position search
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_DETPOS_ERROR      0   the detector position detection SW
                                               encountered an undefined error
                     ACS_DETPOS_SUCCESS    1   detector position detection was successfull
                                               and the position parameters are filled
                     ACS_DETPOS_NOT_FOUND  2   the SW did not find a detector in the current
                                               camera image
                     ACS_DETPOS_NO_CALIB   3   the detector position cannot be determined
                                               since there is no camera calibration data
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

TIME seconds since January 1st 1970; ACS_LNIL if the time is not available
note that this is in local time since this is the "logging time" (and many subsystems do only have this time)
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: sec

DET_POS_X detector x-coordinate (relative to tube)
          Type:  Integer16     (DEC)
          Range: -10000 ... 10000
          Dimension: mm

DET_POS_Y detector y-coordinate (relative to tube)
          Type:  Integer16     (DEC)
          Range: -10000 ... 10000
          Dimension: mm

DET_POS_Z detector z-coordinate (relative to tube) (=SID)
          Type:  Integer16     (DEC)
          Range: 0 ... 10000
          Dimension: mm

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DET_QUAT_X X value of detector angle quaternion
          Type:  Float32     (DEC)
          Range: -30000 ... 30000
          Dimension: quaternion

DET_QUAT_Y Y value of detector angle quaternion
          Type:  Float32     (DEC)
          Range: -30000 ... 30000
          Dimension: quaternion

DET_QUAT_Z Z value of detector angle quaternion
          Type:  Float32     (DEC)
          Range: -30000 ... 30000
          Dimension: quaternion

DET_QUAT_W Y value of detector angle quaternion
          Type:  Float32     (DEC)
          Range: -30000 ... 30000
          Dimension: quaternion


SH_DET_TEMP

Object: SH_DET_TEMP ___ID: 1015

Description: reports FD temperature values
Sender     :   FLC_TV
Receiver   :   CSF   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

TIMEINTERVAL time interval in seconds
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: sec

NO_TEMP number of temperate values
          Type:  Dcount     (CNT)
          Range: 1 ... 350
          Dimension: none

{TEMP temperature of FD
{          Type:  Integer16     (DEC)
{          Range: 0 ... 10000
{          Dimension: 0.1 degree centigrade


SH_DIAG

Object: SH_DIAG ___ID: 1806

Description: show diagnostic
Sender     :   AXN   SCU   TUI-IF
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DIAG_STATUS status
          Type:  Enum8     (DEC)
          Range: 1 ... 7
                     ACS_DIAG_RUNNING              1
                     ACS_DIAG_COMPLETED            2
                     ACS_DIAG_ABORTED              3
                     ACS_DIAG_ERROR                4
                     ACS_DIAG_REQ_INT_DATA         5
                     ACS_DIAG_REQ_CHOICE           6
                     ACS_DIAG_REQ_MULTIPLE_CHOICE  7
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IDENTIFIER identifier for adjust and diag
          Type:  Integer16     (DEC)
          Range: -1 ... 30000
                     ACS_ADJ_ALL_FILES               -1
                     ACS_ADJUST_ID_TUBE_STRAHLER1    1     initiate tube adjust
                     ACS_ADJUST_ID_TUBE_STRAHLER2    2     initiate tube adjust
                     ACS_ADJUST_ID_MAS_RELAIS        3
                     ACS_ADJUST_ID_INVERTER          4
                     ACS_ADJUST_ID_FLUORO            5
                     ACS_ADJUST_ID_SP_INVERTER       6
                     ACS_ADJUST_ID_F80_IONTO         7     dose iontomat: sensitivity and
                                                           "Vorhalt".
                                                           (replaces GEN_ICO_F80_DOSE
                                                           _IONTOMAT_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_RESP  8     voltage curve
                                                           (replaces GEN_ICO_F80_VOLTAGE
                                                           _RESPONSE_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_COR   9     AEC dose correction.
                                                           (replaces GEN_ICO_F80
                                                           _VOLTAGE_CORRECTION_ADJUST_ID)
                     ACS_ADJUST_ID_F80_DEXI          10    DEXI adjust:
                                                           -> generator set to adjust in 1/4
                                                           EP steps (rather than 1/2 EP)
                                                           -> ImgSys switches to DEXI adjust
                     ACS_ADJUST_ID_II_DOSE_IRIS      11    mA reference value (determined
                                                           during "Dose TV Iris" adjustment)
                     ACS_ADJUST_ID_II_IRIS_BRIGHT    12    correction value for Iris (in BP)
                                                            (determined during "Dose TV
                                                           Iris" adjustment)
                     ACS_ADJUST_ID_II_ZOOM_IRIS      13    correction value for iris in zoom
                                                           mode (in BP)  (determined during
                                                           "Zoom Iris Correction"
                                                           adjustment)
                     ACS_ADJUST_ID_II_TV_PARAM       14    value for iris in video mode (in
                                                           EP) (determined during "TV
                                                           Parameters" adjustment)
                     ACS_ADJUST_ID_GEN_WARMUP        15    used to start automatic warm up
                                                           procedure on generator
                     ACS_ADJUST_ID_COLL_ADAPT        16    adjustment needed for collimator
                                                           adaption
                     ACS_ADJUST_ID_COOLPUMP          17    manually switch cooling pump on
                                                           or off for service
                     ACS_ADJUST_ID_II_IRIS_RANGE     18    maximum attenuation of the iris
                                                           (w/o gray filter)
                     ACS_ADJUST_ID_GRAY_FLT_STRT_PT  19    maximum opening of the iris with
                                                           gray filter
                                                           (in case the gray filter does not
                                                           cover the full opening of the
                                                           iris)
                     ACS_ADJUST_ID_FD_ATTACH         20    start attachment procedure of
                                                           detector and docking station
                     ACS_ADJUST_ID_FD_BATTCAL        21    start battery calibration of
                                                           portable FD detector
                     ACS_ADJUST_ID_FD_WLAN           22    set WLAN settings
                     ACS_ADJUST_ID_COLL_ACCURACY     23    adjust collimator accuracy
                                                           (needed in Rad3)
                     ACS_ADJUST_ID_TUBE_CONDITION    24    tube conditioning (used with
                                                           unified generator)
                     ACS_ADJUST_ID_IRISCALIBRATION   25    start iris calibration procedure
                     ACS_ADJUST_ID_AIR_KERMA_RATE    26    start air kerma rate adjustment
                     ACS_ADJUST_ID_RCP_ATTACHMENT    27    start TUI/RCP attachment
                     ACS_ADJUST_ID_CARM_ATTACHMENT   28    start C-ARM attachment
                     ACS_ADJUST_ID_DICOM_WLAN        29    adjust DICOM access point
                     ACS_ADJUST_ID_FDCAL_TEMP        30
                     ACS_ADJUST_ID_FDCAL_MULTIGAIN   31
                     ACS_ADJUST_ID_FDCAL_STAT_DELTA  32
                     ACS_ADJUST_ID_FDCAL_DYN_DELTA   33
                     ACS_ADJUST_ID_FDCAL_DEFECT_DET  34
                     ACS_ADJUST_ID_SCU_ROTACQ        40    SCU settings rotational acq
                     ACS_ADJUST_ID_SCU_ROTACQ_POS    41    SCU rotational acq, reachability
                                                           of start position
                     ACS_ADJUST_ID_MCU_ANGULAR_ZERO  50    set C-Arm angular angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_ZERO  51    set C-Arm orbital angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_MAX   52
                     ACS_ADJUST_ID_MCU_ORBITAL_MIN   53
                     ACS_ADJUST_ID_MCU_HF_SIGNALS    54    monitors MCU hand/footswitch
                                                           signals
                     ACS_ADJUST_ID_MCU_HW_SIGNALS    55    monitors MCU hardware signals
                     ACS_ADJUST_ID_MCU_FORMAT_FS     56    format file system on MCU
                     ACS_ADJUST_ID_MCU_RESET_TEMP    57    reset min max temperature
                     ACS_ADJUST_ID_MCU_VRT_TORQUE    58    set high torque for vertical lift
                                                           drive
                     ACS_ADJUST_ID_ETH_CONNECTIONS   59    monitor ethernet connections
                     ACS_ADJUST_ID_MCU_MOVE_SIGNALS  60    monitors MCU movement signals
                     ACS_ADJUST_ID_MCU_EMCY_SIGNALS  61    monitors MCU emergency and power
                                                           supply signals
                     ACS_ADJUST_ID_MCU_RESET_MILAGE  62    reset orbital/angular milage
                                                           information
                     ACS_ADJUST_ID_MCU_WFSW_PAIRING  64    enter pairing mode of the
                                                           wireless receiver
                     ACS_ADJUST_ID_MCU_WFSW_MONITOR  65    monitors status information of
                                                           wireless footswitch
                     ACS_ADJUST_ID_CALIB3D_GEO       70    3D geometric calibration
                     ACS_ADJUST_ID_CALIB3D_IZERO     71    iZero calibration for 3D
                     ACS_ADJUST_ID_CALIBTOPO_IZERO   72    iZero calibration for 2D_TOPO
                                                           (=SKELMAL)
                     ACS_ADJUST_ID_CAM3D_CALIB       75    calibration of 3D camera at tube
                                                           head
                     ACS_ADJUST_ID_RESET_MRAM        80    reset MRAM of XCU or MCU (thus
                                                           restore factory defaults)
                     ACS_ADJUST_ID_SELECT_TUBE1      85
                     ACS_ADJUST_ID_SELECT_TUBE2      86
                     ACS_ADJUST_ID_CTRL_XRAY         87    X-Ray Control
                     ACS_ADJUST_ID_WW                90    water value correction
                     ACS_ADJUST_ID_IEC_TEST          91    Set specific x-ray parameters
                                                           (working points) for IEC tests.
                                                           (used in surgery)
                     ACS_ADJUST_ID_NORMATIVE_TESTS   92    Set specific x-ray parameters
                                                           (working points) for various
                                                           normative tests. (used in
                                                           surgery)
                     ACS_ADJUST_ID_APH_SOLIDFICATN   101   AppHosting: manage solidification
                                                           software
                     ACS_ADJUST_ID_APH_SWITCH_MODE   102   AppHosting: switch to App Mode
                                                           via Service
                     ACS_ADJUST_ID_APH_SWITCH_ENV    103   AppHosting: switch the active
                                                           environment
                     ACS_ADJUST_ID_APH_CREATE_ENV    104   AppHosting: create a new
                                                           environment
                     ACS_ADJUST_ID_APH_EXPORT_DATA   105   AppHosting: export vendor data
                                                           (logfiles)
                     ACS_ADJUST_ID_APH_LICENSES      106   AppHosting: manage application
                                                           licenses
                     ACS_ADJUST_ID_APH_INSTALL_APP   107   AppHosting: install or update
                                                           applications
                     ACS_ADJUST_ID_APH_LANGUAGE      108   AppHosting: change language
                                                           settings
                     ACS_ADJUST_ID_APH_BIOS          109   AppHosting: access BIOS
                     ACS_ADJUST_ID_STAND_CENTERING   157   The number 157 is used in SCU for
                                                           Centering Adjustment
                     ACS_DIAG_ID_IS_VERSION          300
                     ACS_DIAG_ID_IS_HOST_ID          301
                     ACS_DIAG_ID_IS_DONGLE_ID        302
                     ACS_DIAG_ID_IS_FREE_HD          303
                     ACS_DIAG_ID_IS_FREE_MEMORY      304
                     ACS_DIAG_ID_IS_CONFIG_ISSUE     305
                     ACS_DIAG_ID_IS_OS_INFO          306
                     ACS_DIAG_ID_CPU_INFO            307
                     ACS_DIAG_ID_DICOM_ARCH_NODE     308
                     ACS_DIAG_ID_DICOM_MPPS_NODE     309
                     ACS_DIAG_ID_DICOM_MWL_NODE      310
                     ACS_DIAG_ID_DICOM_PRINT_NODE    311
                     ACS_DIAG_ID_FD2430_TYPE         340
                     ACS_DIAG_ID_FD2430_SN           341
                     ACS_DIAG_ID_FD2430_SW           342
                     ACS_DIAG_ID_FD2430_FW           343
                     ACS_DIAG_ID_FD2430_LIFETIME     344
                     ACS_DIAG_ID_FD2430_POWERON      345
                     ACS_DIAG_ID_FD2430_TEMPERATURE  346
                     ACS_DIAG_ID_FD2430_WIFI         347
                     ACS_DIAG_ID_FD2430_SHOCK        348
                     ACS_DIAG_ID_FD3543_TYPE         360
                     ACS_DIAG_ID_FD3543_SN           361
                     ACS_DIAG_ID_FD3543_SW           362
                     ACS_DIAG_ID_FD3543_FW           363
                     ACS_DIAG_ID_FD3543_LIFETIME     364
                     ACS_DIAG_ID_FD3543_POWERON      365
                     ACS_DIAG_ID_FD3543_TEMPERATURE  366
                     ACS_DIAG_ID_FD3543_WIFI         367
                     ACS_DIAG_ID_FD3543_SHOCK        368
                     ACS_DIAG_ID_FD4343_TYPE         380
                     ACS_DIAG_ID_FD4343_SN           381
                     ACS_DIAG_ID_FD4343_SW           382
                     ACS_DIAG_ID_FD4343_FW           383
                     ACS_DIAG_ID_FD4343_LIFETIME     384
                     ACS_DIAG_ID_FD4343_POWERON      385
                     ACS_DIAG_ID_FD4343_TEMPERATURE  386
                     ACS_DIAG_ID_FD4343_WIFI         387
                     ACS_DIAG_ID_FD4343_SHOCK        388
          Dimension: none

DIAG_DURATION duration of diag
          Type:  Integer16     (DEC)
          Range: 0 ... 3600
          Dimension: 1 sec

PAR_1 parameter 1, individually defined. INIL if not used
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

PAR_2 parameter 2, individually defined. INIL if not used
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_DIAG length of string in SH_DIAG
          Type:  Dcount     (CNT)
          Range: 0 ... 200
          Dimension: count of elements

{DIAG_STRING usage defined by DIAG, variable string in UNICODE
{          Type:  String16 [ 1 ]     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


SH_DISP_ICON

Object: SH_DISP_ICON ___ID: 1387

Description: display different icons
Sender     :   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

VERSION_SHDISPICON version of the object SH_DISP_ICON
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_DISP_ICONS number of data blocks of this object
          Type:  Dcount     (CNT)
          Range: 0 ... 61
          Dimension: none

{DISP_STYLE attribute of the displayed value
{          Type:  Enum8     (DEC)
{          Range: 0 ... 4
{                       ACS_DISP_NORMAL           0   normal display
{                       ACS_DISP_BLANK            1   the field should be blank
{                       ACS_DISP_BLINKING         2   blinking
{                       ACS_DISP_INVERT           3   inverted
{                       ACS_DISP_INVERT_BLINKING  4   inverted and blinking
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DISP_FUNC function code of DISP_VALUE
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{DISP_ICON icon of the joystick; defined in AXCS_UI.H
{          Type:  Integer32     (DEC)
{          Range: 0 ... 1000
{          Dimension: none


SH_DISP_LONG

Object: SH_DISP_LONG ___ID: 1385

Description: display different values with longer text fields
Sender     :   FLC   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

VERSION_SHDISPLONG version of the object SH_DISP_LONG
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHDISPLONG  0   version from the beginning
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_DISP_LONG number of data blocks
          Type:  Dcount     (CNT)
          Range: 0 ... 8
          Dimension: none

{DISP_STYLE attribute of the displayed value
{          Type:  Enum8     (DEC)
{          Range: 0 ... 4
{                       ACS_DISP_NORMAL           0   normal display
{                       ACS_DISP_BLANK            1   the field should be blank
{                       ACS_DISP_BLINKING         2   blinking
{                       ACS_DISP_INVERT           3   inverted
{                       ACS_DISP_INVERT_BLINKING  4   inverted and blinking
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DISP_FUNC function code of DISP_VALUE
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{DISP_VALUE_LONG value to be displayed (80 chars UNICODE)
{          Type:  String16 [ 80 ]     (ASCII)
{          Range: 160 ... 160
{          Dimension: unicode


SH_DISP_VALUE

Object: SH_DISP_VALUE ___ID: 1386

Description: display different values
Sender     :   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

VERSION_SHDISPVALUE version of the object SH_DISP_VALUE
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHDISPVALUE  0   version from the beginning
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_DISP_VALUES number of data blocks
          Type:  Dcount     (CNT)
          Range: 0 ... 50
          Dimension: none

{DISP_STYLE attribute of the displayed value
{          Type:  Enum8     (DEC)
{          Range: 0 ... 4
{                       ACS_DISP_NORMAL           0   normal display
{                       ACS_DISP_BLANK            1   the field should be blank
{                       ACS_DISP_BLINKING         2   blinking
{                       ACS_DISP_INVERT           3   inverted
{                       ACS_DISP_INVERT_BLINKING  4   inverted and blinking
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DISP_FUNC function code of DISP_VALUE
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{DISP_VALUE value to be displayed (12 char unicode)
{          Type:  String16 [ 12 ]     (ASCII)
{          Range: 24 ... 24
{          Dimension: unicode


SH_DOWNLOAD

Object: SH_DOWNLOAD ___ID: 1808

Description: acknowledge to ST_DOWNLOAD
Sender     :   CCU_A   SCU   TUI
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ACKNOWLEDGE acknowledge
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_OK    1   the state is okay or accepted
                     ACS_NOK   2   the state is not okay or not accepted
                     ACS_BUSY  3   receiver is currently busy
                                   (so far only used in SH_ORGAN_PROG)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DLD_STATUS status of download
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_DLD_NOT_USED   0   parameter is not used
                     ACS_DLD_RUNNING    1   download is running
                     ACS_DLD_COMPLETED  2   download is successfully completed
                     ACS_DLD_ABORTED    3   download interrupted
                     ACS_DLD_ERROR      4   download stopped with error
                     ACS_DLD_POPUP      5   download is running and a popup should be
                                            displayed
          Dimension: none

DLD_PROGRESS progress of download
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: %

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_DOWNLOAD length of string in SH_DOWNLOAD
          Type:  Dcount     (CNT)
          Range: 0 ... 200
          Dimension: count of elements

{DOWNLOAD_STRING usage defined by download, variable string in UNICODE
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


SH_ENTER_CALIB

Object: SH_ENTER_CALIB ___ID: 1017

Description: confirmation for entering/leaving calibration mode
Sender     :   FLC   HIC_IF
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ACKNOWLEDGE acknowledge
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_OK    1   the state is okay or accepted
                     ACS_NOK   2   the state is not okay or not accepted
                     ACS_BUSY  3   receiver is currently busy
                                   (so far only used in SH_ORGAN_PROG)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_ERROR_RESET

Object: SH_ERROR_RESET ___ID: 1514

Description: reset the locally stored error (equals sResetFehler)
Sender     :   SCU-IF
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_EXAM_STUDY

Object: SH_EXAM_STUDY ___ID: 1029

Description: confirm starting exam in service
Sender     :   UIS
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

EXAM_STUDY
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_STUDY_SERVICE   1   an examintaion study for service shall be
                                             opened / is open
                     ACS_STUDY_CLOSE     2   the current exam study shall be closed / is
                                             closed
          Dimension: none

ACKNOWLEDGE acknowledge
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_OK    1   the state is okay or accepted
                     ACS_NOK   2   the state is not okay or not accepted
                     ACS_BUSY  3   receiver is currently busy
                                   (so far only used in SH_ORGAN_PROG)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_EXPORT_FDDATA

Object: SH_EXPORT_FDDATA ___ID: 1027

Description: acknowledge for ST_EXPORT_FDDATA
Sender     :   FLC
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

ACKNOWLEDGE acknowledge
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_OK    1   the state is okay or accepted
                     ACS_NOK   2   the state is not okay or not accepted
                     ACS_BUSY  3   receiver is currently busy
                                   (so far only used in SH_ORGAN_PROG)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FEHLERTEXT2 Error text to display error messages to the user (language specific in iFehlerAnz2) and in English for logging in iErrorLog2, max. 499 chars UNICODE (plus delimiter)
          Type:  String16 [ 500 ]     (ASCII)
          Range: 1000 ... 1000
          Dimension: unicode


SH_FD_CONNECT

Object: SH_FD_CONNECT ___ID: 1023

Description: acknowledge to ST_FD_CONNECT
Sender     :   FLC
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

CONNECT_STATE connection state of FD
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_FDR_DATA

Object: SH_FDR_DATA ___ID: 0431

Description: show data of FDR
Sender     :   FLC   HIC_IF
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

FDR_ACK acknowledge of FDR request
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_OK   1   the state is okay or accepted
                     ACS_NOK  2   the state is not okay or not accepted
          Dimension: none

FDR_RQ_INDEX index for each individual FDR request
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DETECTOR_PLANE identifier for the detector being addressed
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_NO_INFORMATION     0
                     ACS_FD_TABLE           1    detector mounted in the table
                     ACS_FD_WALL            2    FD mounted in the wall stand
                     ACS_FD_PORTABLE        3    free portable detector
                     ACS_FD_WALLCHARGER     4    portable detector in wall charger
                     ACS_FD_STAND           7    detector mounted in the dTF stand
                     ACS_FD_C_ARM           8    detector on c-arm in surgery
                     ACS_FD_FLEXIBLE        9    detector of Multitom Rax system
                     ACS_FD_SMALL_PORTABLE  10   small portable detector
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_FDR_DATA number of FDR data blocks
          Type:  Dcount     (CNT)
          Range: 0 ... 21
          Dimension: none

{FDR_PARAM_TAG identifier of the FDR parameter (the values are not consecutive!)
{          Type:  Enum8     (DEC)
{          Range: 0 ... 252
{                       ACS_FDR_SERNUM                0     Serial number of FD
{                       ACS_FDR_PLANE                 1     Plane on which FD is currently
{                                                           attached
{                       ACS_FDR_DATE_CODE             2
{                       ACS_FDR_SW_VERSION            3
{                       ACS_FDR_PART_NUM              4     Factory part number of FD
{                       ACS_FDR_CUR_TEMP              5     Current FD temperature
{                       ACS_FDR_BATT_STATUS           6     Battery charge level
{                       ACS_FDR_BATT_ID               7     battery serial number
{                       ACS_FDR_BATT_CHARGE_CYC       8     battery charge cycle count
{                       ACS_FDR_LIFE_TIME             9
{                       ACS_FDR_POWERON_CNT           10
{                       ACS_FDR_WIFI_CUR_CHANNEL      11
{                       ACS_FDR_WIFI_FE_LINK_QUALITY  12    Raw Link Quality
{                       ACS_FDR_WIFI_DATA_RATE        13
{                       ACS_FDR_CALIB_TEMP            14    detector temperature at time of
{                                                           calibration
{                       ACS_FDR_CALIB_DATE            15    date of when the current
{                                                           calibration data have been
{                                                           acquired
{                       ACS_FDR_DETECTOR_TYPE         100
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{FDR_PARAM value of the parameter, returned as string.
NULL is returned if this parameter is not available.
{          Type:  String8 [ 64 ]     (ASCII)
{          Range: 64 ... 64
{          Dimension: ASCII


SH_FDR_VERSION_CHECK

Object: SH_FDR_VERSION_CHECK ___ID: 1021

Description: show whether version for fd is valid (used for wiD attachment)
Sender     :   FLC
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

VERS_STATUS information about the FD's version status
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NOT_DEFINED         0   not defined
                     ACS_UP_TO_DATE          1   the detected version is fine
                     ACS_OUT_OF_DATE         2   the detected version is outdated but okay
                     ACS_UPDATE_MANDATORY    3   the detected version is invalid and must be
                                                 updated immediately
                     ACS_VERS_NOT_SUPPORTED  4   the detected version is invalid and should
                                                 not be used with this system version
          Dimension: none

IDX_FDR_VERSION index count (used to match SH_FDR_VERSION_CHECK to RQ_FDR_VERSION_CHECK)
shall be incremented each time a RQ_FDR_VERSION_CHECK is sent (continuing with 0 after 255)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_FILTER_A

Object: SH_FILTER_A ___ID: 1243

Description: show the actual filter plane A
Sender     :   CCU_A
Receiver   :   CCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

XRPARN x-ray parameter set number
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_ACQ_MIN_PS  0x0001 range 0001H to 00FFH is for ACQ
                     ACS_ACQ_MASK    0x00FF mask for all possible acq programs
                     ACS_FL_MIN_PS   0x0100 range 0100H to FF00H is for FLUORO
                     ACS_FL_MASK     0x0F00 mask for all possible fluoro programs
                     ACS_EMERG_PS    0x8000 value 8000H is emergency fluoro
          Dimension: none

XR_FILTER x-ray filter (e.g. copper)
          Type:  Byte     (DEC)
          Range: 0 ... 15
                     ACS_NO_FILTER    0
                     ACS_AUTO_FILTER  15   this value is only used in ST_PARAM
          Dimension: 0.1 mm Cu

NEXT_XR_FILTER during movement the filter that will be installed. If it is identical to the current filter the installation is finished
          Type:  Byte     (DEC)
          Range: 0 ... 9
          Dimension: 0.1 mm Cu


SH_FILTER_B

Object: SH_FILTER_B ___ID: 1244

Description: show the actual filter plane B
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

XRPARN x-ray parameter set number
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_ACQ_MIN_PS  0x0001 range 0001H to 00FFH is for ACQ
                     ACS_ACQ_MASK    0x00FF mask for all possible acq programs
                     ACS_FL_MIN_PS   0x0100 range 0100H to FF00H is for FLUORO
                     ACS_FL_MASK     0x0F00 mask for all possible fluoro programs
                     ACS_EMERG_PS    0x8000 value 8000H is emergency fluoro
          Dimension: none

XR_FILTER x-ray filter (e.g. copper)
          Type:  Byte     (DEC)
          Range: 0 ... 15
                     ACS_NO_FILTER    0
                     ACS_AUTO_FILTER  15   this value is only used in ST_PARAM
          Dimension: 0.1 mm Cu

NEXT_XR_FILTER during movement the filter that will be installed. If it is identical to the current filter the installation is finished
          Type:  Byte     (DEC)
          Range: 0 ... 9
          Dimension: 0.1 mm Cu


SH_GLOB_GAIN

Object: SH_GLOB_GAIN ___ID: 1011

Description: report current global gain and global offset value
              send from ImgSys to FDCalib/IQAP
Sender     :   FLC_TV   HIC_IF
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DPP_GLOBAL_GAIN set global gain of FD
          Type:  Integer32     (DEC)
          Range: -1 ... 2147483647
                     ACS_AUTO_GAIN  -1
          Dimension: 0.001

DPP_GLOB_OFFSET FD global offset (used by FDCAlib/IQAP)
          Type:  Integer32     (DEC)
          Range: -1 ... 2147483647
          Dimension: none


SH_GRID

Object: SH_GRID ___ID: 1513

Description: show values of scatter radiation grid. The SH_GRID will be translated to
              iRaster and iRasterAnz. However SH_GRID identifies grids by focus, the other
              telegrams by number. The association is done via configuration.
Sender     :   SCU
Receiver   :   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

VERSION_SHGRID version of the object SH_GRID
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHGRID  1   version 1 since VD16C: new parameter GRID_TARGET
          Dimension: none

GRID_STATE actual state of the grid
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_GRID_UNDEF    0   position undefined
                     ACS_GRID_ACTIVE   1   grid active
                     ACS_GRID_END_POS  2   end position reached
                     ACS_GRID_REVERS   3   moving revers
          Dimension: none

GRID_POS actual grid position
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_GRID_NDEF         0   not defined
                     ACS_GRID_PARK_POS     1   park position
                     ACS_GRID_CENTRAL      2   grid centered
                     ACS_GRID_PREPARATION  3   position for preparation
          Dimension: none

GRID_TARGET Target, where the grid is used
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_NONE                  0   none
                     ACS_GRID_TARGET_TABLE     1   table
                     ACS_GRID_TARGET_WALL      2
                     ACS_GRID_TARGET_SFD       3   spot film device of LdRF / LdTF
                     ACS_GRID_TARGET_FREE_3D   4   grid in top of portable detector, if the
                                                   tube of a 3D device is used.
                     ACS_GRID_TARGET_FREE_SFD  5   grid in top of portable detector, if the
                                                   tube of a spot film device is used.
          Dimension: none

GRID_FOCUS focus of the grid
          Type:  Integer16     (DEC)
          Range: -2 ... 10000
                     ACS_GRID_5          1000
                     ACS_GRID_1          1150
                     ACS_GRID_UNIVERSAL  1400
                     ACS_GRID_2          1500
                     ACS_GRID_3          1800
                     ACS_GRID_4          3000
          Dimension: mm

GRID_LINES number of lines of the grid
          Type:  Word     (DEC)
          Range: 0 ... 1000
          Dimension: number

GRID_RATION Ratio of the anti-scatter grid, definition: [value:1]
          Type:  Word     (DEC)
          Range: 0 ... 50
          Dimension: none

GRID_ORIENTATION orientation of the installed grid
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_GRID_VERTICAL    0   normal orientation
                     ACS_GRID_HORIZONTAL  1   grid rotated 90 degree
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_IMAGE

Object: SH_IMAGE ___ID: 1822

Description: sent upon RQ_IMAGE when action is done
Sender     :   FLC
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

IMG_RESULT result of image request
          Type:  Enum8     (DEC)
          Range: 1 ... 5
                     ACS_IMAGE_OK           1   requested image stored
                     ACS_IMAGE_NOT_AVAIL    2   requested image not available
                     ACS_IMAGE_ERROR        3   error storing image to exchange board
                     ACS_FILE_CREATE_ERROR  4   failed to create the dicom file
                     ACS_BUFFER_TOO_SMALL   5   buffer too small for an image
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IMAGE_NO number of requested image (1...n or spec. Define)
          Type:  Integer16     (DEC)
          Range: -3 ... 32767
                     ACS_IMAGE_LAST        -3  transfer last image
                     ACS_IMAGE_MULTIFRAME  -2  transfer complete multiframe image
                     ACS_IMAGE_MASK        -1  transfer mask image
                     ACS_IMAGE_BIH         0   transfer best image
          Dimension: none


SH_IMPORT_FDDATA

Object: SH_IMPORT_FDDATA ___ID: 1025

Description: acknowledge for ST_IMPORT_FDDTA
Sender     :   FLC
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

ACKNOWLEDGE acknowledge
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_OK    1   the state is okay or accepted
                     ACS_NOK   2   the state is not okay or not accepted
                     ACS_BUSY  3   receiver is currently busy
                                   (so far only used in SH_ORGAN_PROG)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FEHLERTEXT2 Error text to display error messages to the user (language specific in iFehlerAnz2) and in English for logging in iErrorLog2, max. 499 chars UNICODE (plus delimiter)
          Type:  String16 [ 500 ]     (ASCII)
          Range: 1000 ... 1000
          Dimension: unicode


SH_LIST

Object: SH_LIST ___ID: 2299

Description: Transfer a list of strings with fix length. Is used to tell ImgSys and others
              the contents of kV, mAs, ms and other list boxes
Sender     :   TUI-IF
Receiver   :   FLC   TUI   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

REF_OBJECT_ID ID of the object to which this list refers (e.g. UI_BSR=2201, UI_3DANGIO=2281, UI_OSD=2208)
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: none

SEL_FUNC function to be selected;  all values are defined in an additional include file
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

MIN_LIST_INDEX Index (0,...) in the list of the minimum selectable value
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: none

MAX_LIST_INDEX Index (0,...) in the list of the maximum selectable value
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY8
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_STRING_LIST number of strings with fix length
          Type:  Dcount     (CNT)
          Range: 0 ... 44
          Dimension: none

{STRING_INDEX Index of this string in the list
{          Type:  Word     (DEC)
{          Range: 1 ... 65534
{          Dimension: none

{STRING_FIX string with a fix length (15 char unicode).
{          Type:  String16 [ 15 ]     (ASCII)
{          Range: 30 ... 30
{          Dimension: unicode


SH_MODE

Object: SH_MODE ___ID: 1322

Description: show the actual mode
Sender     :   SCU
Receiver   :   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEM_MODE mode in the system
          Type:  Enum8     (DEC)
          Range: 1 ... 8
                     ACS_NORMAL         1   All planes are out of BYPASS
                     ACS_SERVICE        2
                     ACS_EMERGENCY      3   BYPASS mode
                     ACS_DOWNLOAD       4
                     ACS_SW_RESET       5
                     ACS_PLANE_B_ERROR  6   biplane systems only
                     ACS_PLANE_A_ERROR  7   biplane systems only
                     ACS_FACTORY_RESET  8   reset to factory defaults
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_ORGAN_PROG

Object: SH_ORGAN_PROG ___ID: 100F

Description: Status object to inform about a successful or failed set organ program
Sender     :   FLC   UIS
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ACKNOWLEDGE acknowledge
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_OK    1   the state is okay or accepted
                     ACS_NOK   2   the state is not okay or not accepted
                     ACS_BUSY  3   receiver is currently busy
                                   (so far only used in SH_ORGAN_PROG)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_ORTHO

Object: SH_ORTHO ___ID: 1234

Description: forecast and actual values of the stand concerning ORTHO
Sender     :   SCU
Receiver   :   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

VERSION_SHORTHO version of the object SH_ORTHO
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHORTHO  2   version 1 since VD18M: new parameter
                                        ORTHO_PREP_PHASE
                                        version 2 since VE62L: new parameters POS1VAL and
                                        POS2VAL
          Dimension: none

DISMODE indicates preview, actual settings or review values. Used in different objects, but not all values are always available.
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_PREVIEW            1   Forecast
                     ACS_ACTUAL_SETTINGS    2   Actual values
                     ACS_REVIEW             3   Values after x-ray
                     ACS_PREVIEW_ON_REQ     4   Forecast on request (SH_DYNA_PAR only)
                     ACS_COLLISION_CHECKED  5   collision checked (SH_STPAR only)
                     ACS_DISPLAY_GRAPHIC    6   display graphic (SH_STPAR only), (EAS only)
          Dimension: none

ORTHO_NO_ACT_IMG ORTHO: number of the actual image. In case of forecast = ACS_BNIL
          Type:  Byte     (DEC)
          Range: 0 ... 4
          Dimension: none

POS1 flag if first ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

POS2 flag if second ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

ORTHO_PREP_PHASE This parameter is used to describe the different states during ortho preparation.
It is used by XCU to generate an appropriate user message
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NOT_DEFINED                0   not defined
                     ACS_MOVING_TO_ORTHO_START_POS  1   This state is set, if an ortho organ
                                                        program has been selected, but the
                                                        ortho start position is not reached
                     ACS_DEFINE_ORTHO_LIMITS        2   This state is set, if the initial
                                                        start position is reached, but the
                                                        ortho limits are not yet (fully)
                                                        defined
                     ACS_ORTHO_PREP_READY           3   This status is sent, if the ortho
                                                        preparation is read, i.e. if both
                                                        limit positions are defined, and SCU
                                                        is ready for ortho acquisition
                     ACS_INVALID_STARTPOS           4   The start position out of organ
                                                        program is either invalid or missing
          Dimension: none

POS1VAL angle of the first ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°

POS2VAL angle of the second ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ORTHO_FULL_IMG_SIZE complete area that should be scanned
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mm

NO_ORTHO_IMAGES number of images for the complete ORTHO run
          Type:  Dcount     (CNT)
          Range: 0 ... 4
          Dimension: none

{ORTHO_IMG_SIZE size of one particular image
{          Type:  Word     (DEC)
{          Range: 0 ... 4300
{          Dimension: 0.1 mm

{ORTHO_OVERLAP overlap with the next image
{          Type:  Word     (DEC)
{          Range: 0 ... 1000
{          Dimension: 0.1 mm

{ORTHO_DISTANCE distance from first to actual detector position
{          Type:  Word     (DEC)
{          Range: 0 ... 25000
{          Dimension: 0.1 mm

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SH_POSITION

Object: SH_POSITION ___ID: 2623

Description: show table position / movements
Sender     :   SCU
Receiver   :   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STEPMOV start or end of a stepping movement
          Type:  Enum8     (DEC)
          Range: 1 ... 5
                     ACS_STARTED             1   operation has been started
                     ACS_STOPPED             2   operation has stopped
                     ACS_SET_ZEROPOS         3
                     ACS_MOVE_CONTINUOUS     4   continuous movement during scanning
                     ACS_POS_NEARLY_REACHED  5   Indication that the desired position is
                                                 nearly reached.
                                                 This is used in ortho flow, in order to
                                                 trigger tube restart.
          Dimension: none

NEXT_POS last position in case of review values, next position while moving, else position reached
          Type:  Integer8     (DEC)
          Range: -11 ... 11
          Dimension: Position No

MAX_POS maximum number of positions during PERI
          Type:  Integer8     (DEC)
          Range: 0 ... 12
          Dimension: none

UIF_MODE mode for acquisition and fluoro
          Type:  Enum8     (DEC)
          Range: 0 ... 21
                     ACS_NO_MODE        0    no mode specified
                     ACS_DR_MODE        1    digital radiography (DR)
                     ACS_DSA_MODE       2    DSA
                     ACS_PERI_MODE      3    Peri-DSA
                     ACS_DR_STEP_MODE   4    DR stepping
                     ACS_DR_DYNA_MODE   5    DR Dynavision (native)
                     ACS_DYNA_MODE      6    Dynavision with subtraction
                     ACS_CARD_MODE      7    Card
                     ACS_DIRECT         8    direct technique
                     ACS_3D_MODE        9    3D acquisition
                     ACS_BYPASS_FLUORO  19   bypass fluoro
                     ACS_ROADMAP        20   roadmap fluoro
                     ACS_NORMAL_FLUORO  21   normal fluoro
          Dimension: none

SPHASE show the phase of every Acq run divided into different phases
          Type:  Enum8     (DEC)
          Range: 0 ... 45
                     ACS_NOT_DEFINED    0    not defined
                     ACS_TEST_PHASE     1    for PERI, DR-STEP, DYNA, DR-DYNA, 3D-ACQ
                     ACS_MASK_PHASE     2    for PERI, DR-STEP, DYNA, DR-DYNA, 3D-ACQ
                     ACS_FILL_PHASE     3    only for PERI, DR-STEP, DYNA, DR-DYNA, 3D-ACQ,
                                             but without 3D-Card
                     ACS_NORMAL_PHASE   4
                     ACS_INJEC_PHASE    5    only for DYNA, DR-DYNA, 3D-ACQ if programmed
                     ACS_WASHOUT_PHASE  6    only for DYNA
                     ACS_RETURN_PHASE   7    only for DYNA, 3D-ACQ
                     ACS_FILL_1         11   fill run 1 for 3D
                     ACS_FILL_2         12   fill run 2 for 3D
                     ACS_FILL_3         13   fill run 3 for 3D
                     ACS_FILL_4         14   fill run 4 for 3D
                     ACS_FILL_5         15   fill run 5 for 3D
                     ACS_FILL_6         16   fill run 6 for 3D
                     ACS_FILL_7         17   fill run 7 for 3D
                     ACS_FILL_8         18   fill run 8 for 3D
                     ACS_FILL_9         19   fill run 9 for 3D
                     ACS_FILL_10        20   fill run 10 for 3D
                     ACS_VFR_1          21   variable frame rate phase 1
                     ACS_VFR_2          22   variable frame rate phase 2
                     ACS_VFR_3          23   variable frame rate phase 3
                     ACS_VFR_4          24   variable frame rate phase 4
                     ACS_FILL_11        31   fill run 11 for 3D
                     ACS_FILL_12        32
                     ACS_FILL_13        33
                     ACS_FILL_14        34
                     ACS_FILL_15        35
                     ACS_FILL_16        36
                     ACS_FILL_17        37
                     ACS_FILL_18        38
                     ACS_FILL_19        39
                     ACS_FILL_20        40
                     ACS_FILL_21        41
                     ACS_FILL_22        42
                     ACS_FILL_23        43
                     ACS_FILL_24        44
                     ACS_FILL_25        45
          Dimension: none

OVERLAP_DIR direction of overlap of a 3D acq
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_OVERLAP_NO   0   no overlap
                     ACS_OVERLAP_POS  1   positive overlap
                     ACS_OVERLAP_NEG  2   negative overlap
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_PRE_PRO_PAR

Object: SH_PRE_PRO_PAR ___ID: 1013

Description: show image preprocessing parameters
              used by FDCalib/IQAP
Sender     :   FLC   HIC_IF
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

AVR automatic gain control
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_AVR_ON    1   AGC on
                     ACS_AVR_OFF   2   AGC off
                     ACS_AVR_HAND  3   AGC off; predefined fixed gain
          Dimension: none

MEC_INHIBIT DIPP memory effect algo on/off
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DIPP_MODE DIPP operational modes
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
                     DIPPMODE_BYPASS    0xE111
                     DIPPMODE_SHUTDOWN  0xE222
                     DIPPMODE_IDLE      0xEEEE
          Dimension: none

STATUS_SPPP success status
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_OK              1   the state is okay or accepted
                     ACS_NOK             2   the state is not okay or not accepted
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_PREP

Object: SH_PREP ___ID: 2511

Description: show the state of preparation
Sender     :   XCU
Receiver   :   CCU_A   PMS   SCU   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

INDEX index for x-ray release (SH_PREP etc.)
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: none

PLACE_XR place of x-ray release
          Type:  Enum8     (DEC)
          Range: 1 ... 5
                     ACS_REL_TAB     1   release at table side
                     ACS_REL_EXAM    2   release in the examination room
                     ACS_REL_CTRL    3   release in the control room
                     ACS_REL_SER_SW  4   release by service software
                     ACS_REL_GRIP    5   release at opti grip on image tower (Luminos dTF)
          Dimension: none

BIPLANE biplane or not
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_YES  1
                     ACS_NO   2
          Dimension: none

XRAY_LAYOUT select a predefined layout with start of x-ray
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_LAYOUT_STANDARD        0   select standard layout for x-ray
                     ACS_LAYOUT_RDMP            1   select predefined layout for roadmap
                     ACS_LAYOUT_CLEARSTENTLIVE  2   select layout for CLEARstent Live
          Dimension: none

PREPA show the actual preparation in plane A
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_SET_PREP  1   preparation for x-ray is started
                     ACS_DONE      2   preparation phase is finished
                     ACS_XRAY_OFF  3   x-ray is finished
          Dimension: none

XRPARNA x-ray parameter set number plane A (see XRPARN in ST_PARAM)
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
          Dimension: none

FRARATE_A frame rate (and pulse rate) plane A
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     ACS_FRA_CONTINUOUS  0      continuous fluoro
                     ACS_FRA_SINGLE      1      frame rate for single shot
                     ACS_FRA_ECG_TRG     1500   basic frame rate for ECG triggered fluoro
                                                and acq
                     ACS_FRA_CONT_FL     3000   frame rate for continuous fluoro
          Dimension: 0.01 Frames / s

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

PREPB show the actual preparation in plane B
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_SET_PREP  1   preparation for x-ray is started
                     ACS_DONE      2   preparation phase is finished
                     ACS_XRAY_OFF  3   x-ray is finished
          Dimension: none

XRPARNB x-ray parameter set number plane B (see XRPARN in ST_PARAM)
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
          Dimension: none

FRARATE_B frame rate (and pulse rate) plane B
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     ACS_FRA_CONTINUOUS  0      continuous fluoro
                     ACS_FRA_SINGLE      1      frame rate for single shot
                     ACS_FRA_ECG_TRG     1500   basic frame rate for ECG triggered fluoro
                                                and acq
                     ACS_FRA_CONT_FL     3000   frame rate for continuous fluoro
          Dimension: 0.01 Frames / s

INDEX_A plane A index for x-ray release
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: none

INDEX_B plane B index for x-ray release
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: none

PREP_INFO_A additional information according PREPA/PREPB
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NORMAL_PREP        0   normal x-ray release cycle
                     ACS_XRAY_INTERRUPTION  1   the x-ray run is only interrupted and will
                                                be continued using the same INDEX
                     ACS_XRAY_OVERLAP       2   the footswitch was not released, but an
                                                additional footswitch was pressed
          Dimension: none

PREP_INFO_B additional information according PREPA/PREPB
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NORMAL_PREP        0   normal x-ray release cycle
                     ACS_XRAY_INTERRUPTION  1   the x-ray run is only interrupted and will
                                                be continued using the same INDEX
                     ACS_XRAY_OVERLAP       2   the footswitch was not released, but an
                                                additional footswitch was pressed
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_PROG_NAME

Object: SH_PROG_NAME ___ID: 2297

Description: Sends list of organ programs to be displayed on TUI from TUI-IF(XCU) to TUI).
              Contains information about Target (table, free exposure, wall), exposed (has
              been already been in use in this session. TUI-IF will translate this sExamList
              to this AXCS-style telegram SH_PROG_NAME.
Sender     :   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

REF_OBJECT_ID ID of the object to which this list refers (e.g. UI_BSR=2201, UI_3DANGIO=2281, UI_OSD=2208)
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: none

SEL_FUNC function to be selected;  all values are defined in an additional include file
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

PROG_NAME_USAGE usage of the list
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_OGP_LIST      1   list of names of OGPs
                     ACS_EXAM_LIST     2   list of names of examination sets
                     ACS_ALT_LIST      3   List with alternative OGPs only (used in RFU)
                     ACS_CHANGE_ENTRY  4   only used in RFU
                     ACS_ADD_ENTRY     5   only used in RFU
                     ACS_DELETE_ENTRY  6   only used in RFU
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_PROG_NAME number of program names
          Type:  Dcount     (CNT)
          Range: 0 ... 10
          Dimension: none

{PROG_INFO additional information regarding the program used at the UI
{          Type:  Enum8     (DEC)
{          Range: 0 ... 9
{                       ACS_NOT_DEFINED          0   not defined
{                       ACS_PF_WP_CASS           1   work place cassette
{                       ACS_PF_WP_TABLE          2   work place table
{                       ACS_PF_WP_WALL           3   work place wall stand
{                       ACS_PF_WP_FREE           4   work place free exposure
{                       ACS_PF_WP_3DSIDE         5   side trajectory for 3D acquisition
{                       ACS_PF_WP_3DTABLE        6   table trajectory for 3D acquisition
{                       ACS_PF_WP_3DUPRIGHT      7   upright trajectory for 3D acquisition
{                       ACS_PF_WP_TOPO_LYING     8   SkelMal at table (2D Topogram)
{                       ACS_PF_WP_TOPO_STANDING  9   upright SkelMal (2D Topogram)
{          Dimension: none

{PROG_EXECUTED For programs only: Is the program already used
{          Type:  Enum8     (DEC)
{          Range: 1 ... 2
{                       ACS_YES  1
{                       ACS_NO   2
{          Dimension: none

{ORGAN_INDEX Index of organ program (0=no information)
{          Type:  Word     (DEC)
{          Range: 0 ... 32767
{          Dimension: none

{PROG_NAME name of a program of exam set (64 char unicode)
{          Type:  String16 [ 64 ]     (ASCII)
{          Range: 128 ... 128
{          Dimension: unicode


SH_RADIATION

Object: SH_RADIATION ___ID: 180C

Description: confirm start/stop of xray, released by software and hands free movement
              controlled by software
Sender     :   GEN-IF
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

RAD_ACK acknowledge in SH_RADIATION
          Type:  Enum8     (DEC)
          Range: 1 ... 5
                     ACS_XRAY_ENABLED    1
                     ACS_XRAY_DISABLED   2
                     ACS_XRAY_ABORTED    3
                     ACS_XRAY_NOK        4   Last action not accepted
                     ACS_XRAY_CONTINUED  5   x-ray continued
          Dimension: none

ECG_SIM_ACK acknowledge in object SH_RADIATION
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_ECG_SIM_ENABLED   1
                     ACS_ECG_SIM_DISABLED  2
                     ACS_ECG_SIM_ABORTED   3
                     ACS_ECG_SIM_NOK       4   Last action not accepted
          Dimension: none

ALIVE_TAG This value has to be incremented by the sender and sent back in SH_RADIATION
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SW_CONTROL_STATUS status of software controlled function
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SW_CONTROLLED     0   the SW controlled function is running
                     ACS_FOOTSWITCH_ACTIV  1   x-ray footswitch activated
                     ACS_HANDSWITCH_ACTIV  2   x-ray handswitch activated
          Dimension: none


SH_READY

Object: SH_READY ___ID: 1311

Description: show ready for p-transfer and x-ray
Sender     :   CCU_A   SCU   TUI
Receiver   :   CCU-IF   SCU-IF   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

RSTATUS ready status information
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_READY      1   ready
                     ACS_NOT_READY  2   not ready
          Dimension: none

AUTO_RECOVER component tries to recover (or additional information)
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_YES         1
                     ACS_NO          2
                     ACS_LOGOFF      3   LOG OFF, logon necessary for recover (proposal for
                                         HIPAA)
                     ACS_RED_LIMITS  4   ANG: The PUN is using reduced limits
                     ACS_POWEROFF    5   power off required for recovery
                     ACS_EMGY_STOP   6   emergency stop button
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_SEARCH_RUN

Object: SH_SEARCH_RUN ___ID: 1511

Description: actual state of the search run of a collimator
Sender     :   CCU_A
Receiver   :   CCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

COL_SR_STATE actual state of collimator search run
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SR_REQUEST   0   request for a search run
                     ACS_SR_STARTED   1   search run has been started and is running
                     ACS_SR_FINISHED  2   search run is finished
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_SERVICE_WF

Object: SH_SERVICE_WF ___ID: 1824

Description: show service workflow data
Sender     :   HIC_IF
Receiver   :   PMS
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

WF_STATUS result of the action triggered by the workflow
          Type:  Enum8     (DEC)
          Range: 1 ... 16
                     ACS_WF_RUNNING          1
                     ACS_WF_COMPLETED        2
                     ACS_WF_ABORTED          3
                     ACS_WF_UI_UPDATE        4
                     ACS_WF_UI_ALERT         5
                     ACS_WF_UI_CONFIRM       6
                     ACS_WF_IDLE             7
                     ACS_WF_LOAD_UI          8
                     ACS_WF_UI_DATA          9
                     ACS_WF_SET_CPSTEP       10
                     ACS_WF_CPSTEP_DATA      11
                     ACS_WF_ACQ_START        12
                     ACS_WF_ACQ_STOP         13
                     ACS_WF_EXIT             14
                     ACS_WF_GET_SYS_INFO     15
                     ACS_WF_REPORT_TRANSFER  16
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

WF_ID workflow ID
          Type:  Enum16     (DEC)
          Range: 1 ... 8
                     ACS_WF_FDCALIB        1
                     ACS_WF_IQAP           2
                     ACS_WF_EXI            3   	Detector Sensitivity & EXI
                     ACS_WF_RESET_FD_LIST  4   Reset attached detector list
                     ACS_WF_DEL_FIX_FD     5   Delete fixed FD data
                     ACS_WF_DEL_WID        6   	Delete wiD data
                     ACS_WF_IC_TEST        7   Image Chain Tests
                     ACS_WF_DEXI           8   dexi adjust
          Dimension: none

WF_STEP_ID workflow step ID
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_WF_STEP_UNKNOWN         0
                     ACS_WF_STEP_INIT            1
                     ACS_WF_STEP_CALIB_SEL_DET   2
                     ACS_WF_STEP_CALIB_PREP      3
                     ACS_WF_STEP_CALIB_MODE_SEL  4
                     ACS_WF_STEP_CALIB_RESULT    5
                     ACS_WF_STEP_ACQ             6
                     ACS_WF_STEP_ACQ_SERIES      7
                     ACS_WF_STEP_FINAL           8
          Dimension: none

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_WF_DATA number of WF data blocks
          Type:  Dcount     (CNT)
          Range: 0 ... 27
          Dimension: number of data blocks

{WF_PARAM_TAG identifier of the FDR parameter (the values are not consecutive!)
{          Type:  String8 [ 16 ]     (ASCII)
{          Range: 16 ... 16
{          Dimension: char

{LVALUE integer value of the parameter defined in wf_param_tag
{          Type:  Integer32     (DEC)
{          Range: -20000000 ... 20000000
{          Dimension: none

{SVALUE value of the parameter, returned as string
{          Type:  String8 [ 32 ]     (ASCII)
{          Range: 32 ... 32
{          Dimension: char


SH_SKELMAL

Object: SH_SKELMAL ___ID: 1031

Description:
Sender     :   SCU
Receiver   :   FLC   UIS   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

LOWER_SM_BORDER lower border of SkelMal range, measured from top of the socket the patient stands on (upright) or from the white line on the table (lying)
          Type:  Integer16     (DEC)
          Range: -1 ... 2200
          Dimension: mm

UPPER_SM_BORDER upper border of SkelMal range, measured from top of the socket the patient stands on (upright) or from the white line on the table (lying)
          Type:  Integer16     (DEC)
          Range: -1 ... 2200
          Dimension: mm

POS1 flag if first ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

POS2 flag if second ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

SKELMAL_STATE This parameter is used to describe the different states during skelmal preparation.
It is used by XCU to generate an appropriate user message
          Type:  Enum8     (DEC)
          Range: 0 ... 12
                     ACS_SKML_INITIAL            0    the SkelMal projection (w/o transfer)
                                                      has been selected, but no system
                                                      movement so far
                     ACS_SKML_PAT_TRANS          1    the patient transfer position has been
                                                      reached
                     ACS_SKML_TOP_EDGE           2    the TOP EDGE position (from OGP) has
                                                      been reached
                     ACS_SKML_POS1_DEF           3    the position one (upper limit) has
                                                      been defined
                     ACS_SKML_BOTTOM_EDGE        4    the BOTTOM EDGE position (from OGP)
                                                      has been reached
                     ACS_SKML_POS2_DEF           5    the position two (lower limit) has
                                                      been defined
                     ACS_SKML_START_POS_REACHED  6    the scan start position has been
                                                      reached
                     ACS_SKML_INTERMEDIATE       7
                     ACS_SKML_SCANNING_1         8    the scan is running
                     ACS_SKML_SCANNING_2         9    the scan is running (2nd part)
                     ACS_SKML_FINISHED           10   the skelmal runs has finished
                     ACS_SKML_ABORTED            11   the skelmal run has been aborted
                     ACS_SKML_INITIAL_TRANS      12   the SkelMal projection with transfer
                                                      has been selected, but no system
                                                      movement so far
          Dimension: none

NO_SM_PHASES number of skelmal phases
          Type:  Count     (CNT)
          Range: 0 ... 2
          Dimension: number of data blocks

{START_TIME start of active region (in ms from beginning of phase)
{          Type:  Word     (DEC)
{          Range: 0 ... 40000
{          Dimension: ms

{END_TIME end of active region (in ms from beginning of phase)
{          Type:  Word     (DEC)
{          Range: 0 ... 40000
{          Dimension: ms


SH_SS

Object: SH_SS ___ID: 11A3

Description: actual state of the safety switch. For usual requested by PMS using RQ_OBJECT
              to check if requested switch is in requested position.
Sender     :   GEN-IF
Receiver   :   PMS   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin and Rad3Obs

List of Parameters:

HW_SWITCH actual state of HW-switch of safety contactor (Sicherheitsschuetz) - same as SS in iSEStatus; ACS_ON = x-ray possible
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

SW_SWITCH SW control of safety contactor: ACS_ON = x-ray possible
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

SERV_RAD_SWITCH Service Radiation Enable Switch (R/F80 = S3; UGen=CalibSwitch)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_XRAY_BY_SW  1   x-ray release also by software possible
                     ACS_XRAY_BY_HW  2   x-ray release only by HW possible
          Dimension: none

XRAY_MAN_ENABLE xray manually enabled/disabled by user operation (HW input to generator)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ENABLE_XRAY   1   enable x-ray
                     ACS_DISABLE_XRAY  2   disable x-ray
          Dimension: none

MA_MEAS mA measurement
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

INTERMEDIATE_CIRCUIT Information about state of intermediate circuit in Gen F80.
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

GRID_SERVICE_SWITCH service switch of grid control of A100G, ACS_ON = x-ray possible
ACS_OFF = heat current active, but high voltage disabled
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NOT_SUPPORTED  0   not supported
                     ACS_ON             1   On
                     ACS_OFF            2   Off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_STPAR_RFP

Object: SH_STPAR_RFP ___ID: 100A

Description: This object reports stand parameters and states of RFU systems.
Sender     :   SCU
Receiver   :   CCU_A   CCU_B   SCU-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

VERSION_SHSTPARRFP version of RFU-specific SH_STPAR_RFP
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHSTPARRFP  5   version 0 from initial RFU VC10 to VE10
                                           version 1 since VE46B: new parameter
                                           TABLE_FD_TRANS, changed meaning of parameter
                                           DETECTOR_TRANS
                                           version 2 since VE47D: new parameter
                                           ISOCENTER_TRANS
                                           version 3 since VE53K and VE61T: new extension
                                           for parameter ISOCENTER_LIFT
                                           version 4 since VE53R and VE61X: new parameter
                                           SID_FORECAST
                                           version 5 since VE53U/VE62N: new parameter
                                           SOD_H_A
          Dimension: none

PROJECTION projections operated by the system (RAD/FLUORO)
          Type:  Enum8     (DEC)
          Range: 0 ... 28
                     ACS_PJ_POS_REQ          0    request of the position
                     ACS_PJ_TABLE            1    for Table YSIO and for RAD-Mode in dRF
                     ACS_PJ_WALL             2    combination of 3D tube and wall stand FD
                     ACS_PJ_OVER_TABLE_RAD   3    This projection is used for dRF RAD mode
                     ACS_PJ_TOMO             6    tomo mode using 3D tube and FD of rad
                                                  system
                     ACS_PJ_ORTHO            7
                     ACS_PJ_CASSETTE         8    free exposure using 3D tube on film
                                                  cassette
                     ACS_PJ_CASSETTE_WALL    9    combination of 3D tube and wall stand film
                                                  cassette
                     ACS_PJ_FREE_FD          10
                     ACS_PJ_UNDER_TABLE      13   normal mode for Luminos dTF (e.g. used for
                                                  fluoro)
                     ACS_PJ_TABLE_ORTHO      14   ortho on table of Ysio or Luminos
                     ACS_PJ_OVER_TABLE       15   This projection is used for dRF fluoro
                                                  mode
                     ACS_PJ_SCAN             16   projection for DR scanning mode
                     ACS_PJ_CASSETTE_B       17   free exposure using tube of fluoro system
                                                  and film cassette
                     ACS_PJ_WALL_B           18   combination of fluoro system tube and wall
                                                  stand FD
                     ACS_PJ_CASSETTE_WALL_B  19   combination of fluoro system tube with
                                                  film cassette in wall stand
                     ACS_PJ_FREE_FD_B        20   free exposure using fluoro system tube and
                                                  freely positioned mobile FD
                     ACS_PJ_TOMO_B           21   tomo mode using fluoro system tube and
                                                  fluoro system FD
                     ACS_PJ_TABLE_ORTHO_B    22   ortho on fluoro table using fluoro system
                                                  tube and fluoro system FD
                     ACS_PJ_SCAN_3D          24
                     ACS_PJ_SKELMAL          25
                     ACS_PJ_ORTHO_LATERAL    26
          Dimension: none

ALIGNMENT_MODE Determines, whether tube center is aligned to detector (or cassette) center, or whether top of collimator field of view is aligned to top of detector (or cassette)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_ALIGNMENT_CENTERED  0   centered
                     ACS_ALIGNMENT_TOP       1   top
          Dimension: none

TOP_ALIGN_POSSIBLE SCU reports if top alignment is possible (i.e. if tilt angle <20°)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

SID_A source image distance (the ANG is not able to handle more than 4200 mm)
          Type:  Integer16     (DEC)
          Range: 500 ... 4200
          Dimension: mm

SID_B source image distance (the ANG is not able to handle more than 4200 mm)
          Type:  Integer16     (DEC)
          Range: 500 ... 4200
          Dimension: mm

SID_H_A SID with higher resolution (used e.g. by CCU)
          Type:  Integer32     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

SID_H_B SID of plane B with higher resolution (used e.g. by CCU)
          Type:  Integer32     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1mm

SID_A_VALID determines if an SID makes sense at all in this plane
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_SID_MANUAL_DET        0   user/manual determined
                     ACS_SID_SYSTEM_DET        1   determined by the system
                     ACS_SID_NOT_DEF           2   the system can not define the SID
                     ACS_SID_ORTHO_CALCULATED  3   This value is sent if ortho start
                                                   position is reached and user will perform
                                                   collimation.
                                                   In this case parameter SID_A will reflect
                                                   the current SID (for TUI), and SID_A_H
                                                   will show the calculated maximum SID (for
                                                   CCU).
          Dimension: none

SID_B_VALID determines if an SID makes sense at all in this plane
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_MANUAL_DET  0   user/manual determined
                     ACS_SID_SYSTEM_DET  1   determined by the system
                     ACS_SID_NOT_DEF     2   the system can not define the SID
          Dimension: none

FOTA distance between focus (tube) and table
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: mm

CENTERING_STATUS Current centering status of the stand in RAD
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_CENT_CENTERED      0   centered
                     ACS_CENT_NOT_CENTERED  1   not centered
          Dimension: none

SID_TRACKING SID tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_TRACK_NOT_ACTIVE  0   SID tracking not active
                     ACS_SID_TRACK_ACTIVE      1   SID tracking active
                     ACS_SID_TRACK_LOST        2   SID tracking lost
          Dimension: none

SID_TRACKING_POSSIBLE For semi-motorized Ysio systems: Stand gives information, if SID Tracking is possible.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

TRACKING Tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 15
                     ACS_TRACK_NOT_ACTIVE         0    tracking not active
                     ACS_TRACK_SYMMETRICAL        1    symmetrical
                     ACS_TRACK_TOP_ALIGN          2    asymmetrical top alignment
                     ACS_TRACK_BOTTOM_ALIGN       3    asymmetrical bottom alignment
                     ACS_TRACK_LEFT_ALIGN         4    asymmetrical left alignment
                     ACS_TRACK_RIGHT_ALIGN        5    asymmetrical right alignment
                     ACS_TRACK_LOST_SYMMETRICAL   11   tracking lost, symmetrical
                     ACS_TRACK_LOST_TOP_ALIGN     12   tracking lost, asymmetrical top
                                                       alignment
                     ACS_TRACK_LOST_BOTTOM_ALIGN  13   tracking lost, asymmetrical bottom
                                                       alignment
                     ACS_TRACK_LOST_LEFT_ALIGN    14   tracking lost, asymmetrical left
                                                       alignment
                     ACS_TRACK_LOST_RIGHT_ALIGN   15   tracking lost, asymmetrical right
                                                       alignment
          Dimension: none

TRACKING_POSSIBLE For semi-motorized Ysio systems: stand gives information, if tracking is possible in the current position.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

NOTCH_STATUS status of notches in x- and y-direction
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NOTCH_NONE  0   no notch active
                     ACS_NOTCH_X     1   notch active in x-direction
                     ACS_NOTCH_Y     2   notch active in y-direction
                     ACS_NOTCH_XY    3   notch active in x- and y-direction
          Dimension: none

SOFTSTOP activates or deactivates the SoftStop function
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SOFT_ACTIVE    1   SoftStop function is or shall be active
                     ACS_SOFT_INACTIVE  2   SoftStop function is or shall be deactivated
          Dimension: none

TABLE_FD_TRANS position of detector tray in table
          Type:  Enum8     (DEC)
          Range: 0 ... 55
                     ACS_TABLE_TRAY_IN          0    table tray is in (detector is in zero
                                                     position)
                     ACS_TRAY_INTERMEDIATE_POS  1    detector tray is in intermediate
                                                     position
                     ACS_TABLE_TRAY_OUT         55   tabletray is in outmost position
          Dimension: none

TBL_X_RAD RAD only: table longitudinal position headwards / footwards
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Y_RAD RAD only: table side (transverse) offset, left / right
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Z_RAD RAD only: table lift (height)
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TBL_TILT table tilting up / down  around Y axis, + means: head end up
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
                     ACS_HORIZONTAL_TABLE  0
          Dimension: 0.1 degree

DETECTOR_LONGI RAD only: Longitudinal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_TRANSV RAD only: Transversal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_LIFT RAD only: Detector (or cassette) lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

DETECTOR_ROT_HOR RAD only: detector (or cassette) rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_ROT_VERTICAL RAD only: detector (or cassette) rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_TILT RAD only: detector (or cassette) tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TOWER_LONGI longitudinal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -30000 ... 30000
          Dimension: 0.1 mm

TOWER_TRANSVERSAL transversal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -10000 ... 10000
          Dimension: 0.1 mm

TUBE_LONGI RAD only: Longitudinal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_TRANSVERSAL RAD only: transversal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_LIFT RAD only: Tube lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TUBE_ROT_HOR RAD only: Tube rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_VERTICAL RAD only: Tube rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_HOR_FLUORO tube rotation at dRF
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_LIFT_FLUORO tube lift at dRF
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

ISOCENTER_LONGI longitudinal position related to patient
used by image system for care graphics
          Type:  Integer16     (DEC)
          Range: -30000 ... 30000
          Dimension: 0.1mm

WALL_STAND_LIFT RAD only: Wall stand lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

WALL_STAND_TILT RAD only: wall stand tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

WALL_STAND_FD_TRANS transversal movement of wall stand detector or cassette
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

COLLIMATOR_ROT_A RAD only: Collimator rotation
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

COLLTV_A Angle between collimator and detector of plane A. If both are in sync, the value is 0.
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1 degree

ACSS Information if ACSS is possible; sent from stand to XCU (SH_STPAR_RFP); XCU then distributes (iACSS)
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ACSS_OFF      0   ACSS is not possible.
                     ACS_ACSS_ON       1   ACSS is possible.
                     ACS_ACSS_ORTHO    2   This shall be used if ortho start position is
                                           reached, and user wants to perform collimation.
                                           In this case ACSS shall be enabled towards CCU
                                           even though central beam might currently not hit
                                           the detector.
                     ACS_ACSS_OBLIQUE  3   oblique position; fluoro shall be possible,
                                           collimation shall be adapted but measuring fields
                                           shall be on manual
          Dimension: none

CP_POSITION_MATCH The (relative or absolute) CP position is more or less reached
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     NO   0
                     YES  1
          Dimension: none

ACSS_CONDITIONS Only for developers: which conditions for ACSS are true (=1) or false (=0).
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_ACSS_FD_AVAILABLE       0x0001 Is a target available in the current
                                                        system?
                     ACS_ACSS_SYSTEM_READY       0x0002 Is current system ready?
                     ACS_ACSS_SID_VALID          0x0004 Is the SID value valid?
                     ACS_ACSS_SID_SUFFICIENT     0x0008 Is the SID value sufficient (large
                                                        enough)?
                     ACS_ACSS_ANGLE_A_RIGHT      0x0010 Is the alpha beam angle righted?
                     ACS_ACSS_ANGLE_B_RIGHT      0x0020 Is the beta beam angle righted?
                     ACS_ACSS_POSITION_X         0x0040 Is the beam X position inside of the
                                                        detector?
                     ACS_ACSS_POSITION_Y         0x0080 Is the beam Y position inside of the
                                                        detector?
                     ACS_ACSS_NOT_ROTATED        0x0100 Is the image not rotated relative to
                                                        the patient?
                     ACS_ACSS_BEAM_HITS          0x0200 Does the central beam hit the
                                                        detector?
                     ACS_ACSS_NO_TRACKING        0x0400 Not used, always set. (Kept for
                                                        version compatibility)
                     ACS_ACSS_TUBE_NOT_VERT_ROT  0x0800 Is tube vertical rotation not
                                                        greater than 3 degrees?
                                                        (within all perpendicular
                                                        rotations,
                                                        i.e. ( abs(rotation) + 3 ) % 90 ) <=
                                                        6)
                     ACS_ACSS_NOT_DECENTERED     0x1000 Is the beam not decentered, or
                                                        decentered ACSS is not disabled?
                     ACS_ACSS_COLL_NOT_CALIBR    0x2000 Is collimator calibration not in
                                                        progress?
          Dimension: none

TARGET_HEIGHT height of detector or cassette in holder
          Type:  Integer16     (DEC)
          Range: 0 ... 15000
          Dimension: 0.1 mm

TARGET_WIDTH width of detector or cassette in holder
          Type:  Integer16     (DEC)
          Range: 0 ... 15000
          Dimension: 0.1 mm

TARGET_ORIENTATION orientation of detector or cassette in holder
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE       0   none
                     ACS_PORTRAIT   1
                     ACS_LANDSCAPE  2
          Dimension: none

TARGET_TYPE type of target
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE             0   none
                     ACS_TARGET_CASSETTE  1
                     ACS_TARGET_DETECTOR  2
          Dimension: none

TARGET_TYPE_BWS TARGET_TYPE of bucky wall stand x-ray receptor (nothing, FD or cassette)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE             0   none
                     ACS_TARGET_CASSETTE  1
                     ACS_TARGET_DETECTOR  2
          Dimension: none

TARGET_TYPE_TABLE TARGET_TYPE of table receptor (nothing, FD or cassette)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE             0   none
                     ACS_TARGET_CASSETTE  1
                     ACS_TARGET_DETECTOR  2
          Dimension: none

BEAM_ANGLE_ALPHA RAD only: Angle of incidence (alpha) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

BEAM_ANGLE_BETA RAD only: Angle of incidence (beta) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

BEAM_POS_X Offset of the central beam relating to the center of the FD
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm

BEAM_POS_Y Offset of the central beam relating to the center of the FD
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm

CENTRAL_BEAM_HITS central beam hits target (i.e. detector)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_YES  1
                     ACS_NO   2
          Dimension: none

MOVE_DET detector (or cassette) is moving
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_MOVING      1
                     ACS_NOT_MOVING  2
          Dimension: none

MOVE_TUBE tube is moving
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_MOVING      1
                     ACS_NOT_MOVING  2
          Dimension: none

MOVE_TBL table is moving
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_MOVING      1
                     ACS_NOT_MOVING  2
          Dimension: none

COLLISION stand in collision
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_YES  1
                     ACS_NO   2
          Dimension: none

LIGHT_LOC RFU only: light localizer
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
                     ACS_TOGGLE          3   toggle
          Dimension: none

FINAL_POSITION_REACHED SCU shows that the final position of a motorized movement is reached.
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_YES  1
                     ACS_NO   2
          Dimension: none

POS_VALID_FOR_STORAGE SCU gives information whether a stand position is valid to be stored in an organ program.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_POS_VALID       1   This position is valid to be stored in an organ
                                             program
                     ACS_POS_NOT_VALID   2   This position is not valid to be stored in an
                                             organ program.
          Dimension: none

AUTO_MOVEMENT automatic movement
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_AUTO_MOVEMENT_INACTIVE  0
                     ACS_AUTO_MOVEMENT_ACTIVE    1
                     ACS_AUTO_MOVEMENT_PENDING   2   an auto movement is pending that shall
                                                     be executed on pressing the x-ray
                                                     switch
          Dimension: none

AUTO_MOVEMENT_TARGET target of automatic movement
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_AUTO_MOVE_UNKNOWN_TARGET    0
                     ACS_AUTO_MOVE_OGP_TARGET        1
                     ACS_AUTO_MOVE_PARKPOS_TARGET    2
                     ACS_AUTO_MOVE_CENTERING_TARGET  3
                     ACS_AUTO_MOVE_BEAMPOS_TARGET    4
          Dimension: none

STAND3D_PARK ceiling mounted 3d stand for 2nd plane is in park position
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_YES  1
                     ACS_NO   2
          Dimension: none

DETECTOR_PARKPOS detector park position for Luminos dTF
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION    0
                     ACS_DET_PARK_IN       1   Detector is in park position
                     ACS_DET_PARK_BETWEEN  2   detector is between park an normal position
                     ACS_DET_PARK_OUT      3   detector is out of park position (i.e. in
                                               normal acq position)
          Dimension: none

CALIB_SWITCH actual state of the switch for calibration
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
          Dimension: none

EMERGENCY_STOP emergency stop of the stand pressed
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_YES  1
                     ACS_NO   2
          Dimension: none

STPAR_ACT action with the ST_STPAR
          Type:  Enum8     (DEC)
          Range: 1 ... 10
                     ACS_SELECT_POSNO     1
                     ACS_STORE_USER       2    user position
                     ACS_STORE_DIRECT     3    direct position
                     ACS_STORE_SYSTEM     4    system position
                     ACS_DELETE           5
                     ACS_CHECK            6    check the (3D start-) position for collision
                     ACS_AUTO_MAP         7    indicates AUTO MAP
                     ACS_CHECK_COLLISION  8    Check, if the final position is not in
                                               collision and if it is reachable
                     ACS_CALCULATE        9    calculate a SH_STPAR to display the graphic
                     ACS_CALCULATE_PED    10   calculate a SH_STPAR to display the graphic
                                               for PED
          Dimension: none

CAREGRAPH_VALID do care position values (ISOCENTER_TRANS/_LONGI) make sense (regarding alignment, centering, tracking, oblique angle etc.)
note: this flag can be used not only for careposition display but also for careprofile
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

POSNO current preselect memory position
          Type:  Integer16     (DEC)
          Range: 0 ... 50
                     ACS_PRESENT_POSITION  0
          Dimension: Position Number

DISMODE indicates preview, actual settings or review values. Used in different objects, but not all values are always available.
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_PREVIEW            1   Forecast
                     ACS_ACTUAL_SETTINGS    2   Actual values
                     ACS_REVIEW             3   Values after x-ray
                     ACS_PREVIEW_ON_REQ     4   Forecast on request (SH_DYNA_PAR only)
                     ACS_COLLISION_CHECKED  5   collision checked (SH_STPAR only)
                     ACS_DISPLAY_GRAPHIC    6   display graphic (SH_STPAR only), (EAS only)
          Dimension: none

POS_FIX select position
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_POS_CENTER   0
                     ACS_POS_START    1
                     ACS_POS_SWING    2
                     ACS_TOMO_CANCEL  3   Cancelling of tomo acquisition.
                     ACS_TOMO_ADJUST  4   system shall move to a position in which the tomo
                                          fulcrum height (Schichthöhe) can be adjusted using
                                          the laser line of the collimator
          Dimension: none

TOMO_ANGLE angle for tomo or tilt for beam tilt
          Type:  Integer16     (DEC)
          Range: 0 ... 18000
          Dimension: 0.01 degree

TOMO_HEIGHT height for tomo
          Type:  Word     (DEC)
          Range: 0 ... 5000
          Dimension: 0.1 mm

TOMO_TIME time for tomo
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: ms

MOVEMENT_DISABLE system shall block any movement on users request
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

OBLIQUE_BEAM_ROT defines asymmetric collimation:
YES if the tube is freely rotated, or
NO if we have FD tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

OBLIQUE_BEAM_ANGLE angle of the central x-ray beam due to pivoting of column at dRF
          Type:  Integer16     (DEC)
          Range: -9000 ... 9000
          Dimension: 0.01 degree

COMPRESSION_FORCE the force of the compression tubus (in steps from 1-15)
          Type:  Byte     (BIN)
          Range: 00000000b ... 00001111b
          Dimension: steps

STAND_SPEED speed level for stand movement
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_SSPEED_SLOW     1
                     ACS_SSPEED_MEDIUM   2
                     ACS_SSPEED_FAST     3
          Dimension: none

C_ARM_ORBITAL angle of c-arm rotation
          Type:  Integer16     (DEC)
          Range: -3600 ... 3600
          Dimension: 0.1°

ISOCENTER_TRANS transversal position related to patient
used by image system for care graphics
          Type:  Integer16     (DEC)
          Range: -30000 ... 30000
          Dimension: 0.1mm

CONSIDER_3DSUPPORT the 3D support shall be (ST_) or is (SH_) part of the collision model (used only for upright trajectories in 3D OGPs)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

CONSIDER_3D_ARMREST the 3D arm rest shall be (ST_) or is (SH_) part of the collision model (used only for side trajectories in 3D OGPs)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

AEC_CENTER_Y offset between detector center and center of AEC chamber (does only make sense with BWS, which allows the detector to be inserted in protrait or landscape)
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1mm

ISOCENTER_LIFT sagittal height (used in skelmal)
          Type:  Integer16     (DEC)
          Range: -30000 ... 30000
          Dimension: 0.1mm

COLLTV_FORECAST forecast for the angle between collimator and detector (used for SkelMal)
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
          Dimension: 0.1 degree

SID_FORECAST In this parameter the SCU sends a forecast value for the SID, which is used for grid range checking. This may differ from the current SID in case of ortho table.
          Type:  Integer16     (DEC)
          Range: 500 ... 4200
          Dimension: mm

SOD_H_A source object distance
(0 means value unknown or invalid)
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm


SH_STPAR_TUI

Object: SH_STPAR_TUI ___ID: 100B

Description: this object contains a subset of the parameters of SH_STPAR_RFP; just those
              that are needed for display on TUI
Sender     :   SCU
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

TBL_X_RAD RAD only: table longitudinal position headwards / footwards
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Y_RAD RAD only: table side (transverse) offset, left / right
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Z_RAD RAD only: table lift (height)
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

DETECTOR_ROT_HOR RAD only: detector (or cassette) rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_ROT_VERTICAL RAD only: detector (or cassette) rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_TILT RAD only: detector (or cassette) tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_HOR RAD only: Tube rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_VERTICAL RAD only: Tube rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

WALL_STAND_LIFT RAD only: Wall stand lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

WALL_STAND_TILT RAD only: wall stand tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

BEAM_ANGLE_ALPHA RAD only: Angle of incidence (alpha) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

BEAM_ANGLE_BETA RAD only: Angle of incidence (beta) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

MOVE_TBL table is moving
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_MOVING      1
                     ACS_NOT_MOVING  2
          Dimension: none

MOVE_DET detector (or cassette) is moving
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_MOVING      1
                     ACS_NOT_MOVING  2
          Dimension: none

MOVE_TUBE tube is moving
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_MOVING      1
                     ACS_NOT_MOVING  2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_UI_IMAGE

Object: SH_UI_IMAGE ___ID: 2234

Description: Display an image at the UIP (RFU only)
Sender     :   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

SEL_FUNC function to be selected;  all values are defined in an additional include file
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_SHM_NAME length of SHM_NAME
          Type:  Dcount     (CNT)
          Range: 0 ... 220
          Dimension: count of elements

{SHM_NAME name of the shared memory or path for image transfer, variable length UNICODE
in RFU: path and filename (no shared mem)
default (if string is empty): "c:\export\FLC_IQP.img"
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


SH_UI_TABCARD

Object: SH_UI_TABCARD ___ID: 2205

Description: a new tab card is selected / deselected
Sender     :   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

TC_SELECTED selected tab card (not all are used in every project)
          Type:  Enum8     (DEC)
          Range: 1 ... 42
                     ACS_PREP              1
                     ACS_EXAM              2
                     ACS_POSTPROC          3
                     ACS_QUANT             4
                     ACS_FILMING           5
                     ACS_PHYSIOLOGIC       6
                     ACS_INSPACE           7
                     ACS_IVUSMAP           8    IVUS map
                     ACS_4D                9
                     ACS_RAD_POSITIONS     20   Device Positions Tabcard
                     ACS_RAD_TOMO          21   Tomo Tabcard
                     ACS_RAD_GENERATOR     22   Generator Tabcard
                     ACS_RAD_TAPE_MEASURE  23   Tape Measure Tabcard.
                     ACS_RAD_ORTHO         24   Ortho Tabcard
                     ACS_RAD_SETUP         25   setup tabcard
                     ACS_FLUORO_IMAGE      40   Image Tabcard
                     ACS_FLUORO_TOOLS      41   Tools Tabcard
                     ACS_FLUORO_SETUP      42   Setup Tabcard
          Dimension: none

TC_DESELECTED deselected tab card
          Type:  Enum8     (DEC)
          Range: 1 ... 42
                     ACS_PREP              1
                     ACS_EXAM              2
                     ACS_POSTPROC          3
                     ACS_QUANT             4
                     ACS_FILMING           5
                     ACS_PHYSIOLOGIC       6
                     ACS_INSPACE           7
                     ACS_IVUSMAP           8    IVUS map
                     ACS_4D                9
                     ACS_RAD_POSITIONS     20   Device Positions Tabcard
                     ACS_RAD_TOMO          21   Tomo Tabcard
                     ACS_RAD_GENERATOR     22   Generator Tabcard
                     ACS_RAD_TAPE_MEASURE  23   Tape Measure Tabcard.
                     ACS_RAD_ORTHO         24   Ortho Tabcard
                     ACS_RAD_SETUP         25   setup tabcard
                     ACS_FLUORO_IMAGE      40   Image Tabcard
                     ACS_FLUORO_TOOLS      41   Tools Tabcard
                     ACS_FLUORO_SETUP      42   Setup Tabcard
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SH_UI_XCU

Object: SH_UI_XCU ___ID: 2232

Description: Advice the TUI (user display panel) which buttons to dim, to show or to hide.
Sender     :   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

SEL_FUNC_ACK the same meaning as SEL_FUNC (function to be selected)
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

UI_ACK acknowledge
          Type:  Integer32     (DEC)
          Range: 0 ... 2
                     ACS_FUNC_NOK    0   this function is not ok
                     ACS_FUNC_OK     1   the function is ok
                     ACS_FUNC_ASYNC  2   the function is set asynchronously
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_FUNC number of functions in this object
          Type:  Dcount     (CNT)
          Range: 0 ... 239
          Dimension: none

{SEL_FUNC function to be selected;  all values are defined in an additional include file
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{FUNC_PARAMS parameters of SEL_FUNC; all values are defined in an additional include file
{          Type:  Set16     (HEX)
{          Range: 0x0 ... 0xFFFF
{          Dimension: it's a SET

{SEL_STATUS selectivity of the function
{          Type:  Enum8     (DEC)
{          Range: 0 ... 9
{                       ACS_NOT_SELECTABLE            0   the function is dimmed
{                       ACS_SELECTABLE                1   the function is not dimmed
{                       ACS_HIDDEN                    2   function should be hidden
{                       ACS_DISPLAY_ONLY              3   field is only displayed, but not
{                                                         selectable (only used for TUI in
{                                                         RFU). SP only: The function is
{                                                         dimmed; associated dependencies
{                                                         are not updated
{                       ACS_SELECTABLE_NO_DEP_UPDATE  4   SP only: The function is not
{                                                         dimmed; associated dependencies
{                                                         are not updated
{                       ACS_HIDDEN_NO_DEP_UPDATE      5   SP only:  Function should be
{                                                         hidden; associated dependencies
{                                                         are not updated
{                       ACS_INT_HIDDEN                6   SP only: Function should be
{                                                         internal hidden
{                       ACS_INT_HIDDEN_NO_DEP_UPDATE  7   SP only: Function should be
{                                                         internal hidden; associated
{                                                         dependencies are not updated
{                       ACS_INT_NA                    8   SP only: Function should be
{                                                         internal na
{                       ACS_INT_NA_NO_DEP_UPDATE      9   SP only: Function should be
{                                                         internal na; associated
{                                                         dependencies are not updated
{          Dimension: none

{DUMMY7
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SH_VERSION

Object: SH_VERSION ___ID: 1312

Description: This telegram is sent by any component upon request by RQ_OBJECT. It is used
              to show the version of HW, FW and SW in the PMS-Version-Check-Dialog
Sender     :   ALL
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

NO_VERSIONS number of HW, SW and FW versions
          Type:  Dcount     (CNT)
          Range: 0 ... 60
          Dimension: none

{VERS_TYPE specification of version and unit
{          Type:  Enum8     (DEC)
{          Range: 1 ... 4
{                       ACS_HARDWARE   1
{                       ACS_SOFTWARE   2
{                       ACS_FIRMWARE   3
{                       ACS_ACSHEADER  4   version of the used AXCS header file
{          Dimension: none

{DUMMY1
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{UNIT_ID unique ID of a HW, SW or FW unit , 6 chars UNICODE filled up with 20h
{          Type:  String16 [ 6 ]     (ASCII)
{          Range: 12 ... 12
{          Dimension: unicode

{VERSION version of a HW, SW or FW unit , 4 chars UNICODE (filled up with 20h)
{          Type:  String16 [ 4 ]     (ASCII)
{          Range: 8 ... 8
{          Dimension: unicode


SH_VERSION_CHECK

Object: SH_VERSION_CHECK ___ID: 1317

Description: show version with extended strings
Sender     :   ALL
Receiver   :   PMS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

VERSION_SHVERSIONCHECK version of the object SH_VERSION_CHECK
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_SHVERSIONCHECK  0   version 0 from the beginning
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_VERSIONS_LONG number of HW, SW and FW versions in the object SH_VERSION_CHECK
          Type:  Dcount     (CNT)
          Range: 0 ... 15
          Dimension: none

{VERS_TYPE specification of version and unit
{          Type:  Enum8     (DEC)
{          Range: 1 ... 4
{                       ACS_HARDWARE   1
{                       ACS_SOFTWARE   2
{                       ACS_FIRMWARE   3
{                       ACS_ACSHEADER  4   version of the used AXCS header file
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY6
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{UNIT_ID_LONG unique ID of a HW, SW or FW unit , 12 chars UNICODE
{          Type:  String16 [ 12 ]     (ASCII)
{          Range: 24 ... 24
{          Dimension: unicode

{VERSION_LONG (long) version of hardware, software, etc. 32 char unicode
{          Type:  String16 [ 32 ]     (ASCII)
{          Range: 64 ... 64
{          Dimension: unicode


SINIT

Object: SINIT ___ID: 0007

Description: init data; sent on boot up from XCU to component. Init data will be send as
              soon component sends iFEStatus=10. An sInt(0,0) signals the end of the init
              data stream of sInits
Sender     :   XCU
Receiver   :   FLC   GEN-IF   RAD-STD   TUI-IF
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs and XCU_obsolete_IF

List of Parameters:

INITKENNUNG number of init block
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SIONDATEN

Object: SIONDATEN ___ID: 02BD

Description: selecting AEC chamber and dose for acquisition, sent from XCU to generator.
              In RadFluoro platform the dose is multiplied (within XCU) with the correction
              factor of the selected AEC chamber resulting from AEC adjust.
              In Rad3 this factor is applied within generator.
Sender     :   XCU
Receiver   :   GEN-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SCHWAERZKORR Blackening correction. This value is applied to the dose in order to have more dose steps than it is possible with HUD.
          Type:  Integer16     (DEC)
          Range: -32 ... 32
          Dimension: 0.25 BP

MESSF Measuring field (individual fields are bitcoded)
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     KEINE_ANGABE_RUND              0    circular measuring field
                     ACS_MEAS_FLD_I                 1    center field
                     ACS_MEAS_FLD_II                2    3-chamber: left field
                                                         5-chamber: lower right field
                     ACS_MEAS_FLD_I_AND_II          3
                     ACS_MEAS_FLD_III               4    3-chamber: right field
                                                         5-chamber: lower left field
                     ACS_MEAS_FLD_I_AND_III         5
                     ACS_MEAS_FLD_II_AND_III        6
                     ACS_MEAS_FLD_I_AND_II_AND_III  7
                     ACS_MEAS_FLD_IV                8    5-chamber: upper right field
                     ACS_MEAS_FLD_I_AND_IV          9
                     ACS_MEAS_FLD_II_AND_IV         10
                     ACS_MEAS_FLD_I_AND_II_AND_IV   11
                     ACS_MEAS_FLD_V                 16   5-chamber: upper left field
                     ACS_MEAS_FLD_I_AND_V           17
                     ACS_MEAS_FLD_III_AND_V         20
                     ACS_MEAS_FLD_I_AND_III_AND_V   21
                     ACS_MEAS_FLD_IV_AND_V          24
                     ACS_MEAS_FLD_IV_AND_I_AND_V    25
          Dimension: none

FOLIE (only used for iontomat, not for SDM) amplification foil for cassette film (the iontomat has three inputs with different, separately adjustable amplification for the dose
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     ACS_FOLIE_H  0   high sensitive foil (low dose), in FD systems only
                                      used for dose separation
                     ACS_FOLIE_U  1   universal (medium dose)
                     ACS_FOLIE_D  2   detailed resolution (high dose)
          Dimension: none

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

IONCH iontomat channel (Polydoros SX has six channels for connection up to six chambers for six targets, Polydoros F80 supports less for CAN-iontomat channels)
          Type:  Byte     (DEC)
          Range: 0 ... 8
          Dimension: none

IDX_IONDA index count (used to match vIonDaten to sIonDaten)
shall be incremented each time an sIonDaten is sent (continuing with 0 after 255)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SIRIS

Object: SIRIS ___ID: 012D

Description: In Image intensifier systems sent for controlling iris of a TV camera input in
              front of image intensifier; sent from XCU to generator or stand or imaging
              system(depends, who is controlling the iris). The iris will closed more when
              level of dose is increased
Sender     :   XCU
Receiver   :   FLC   GEN-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

GRAUFILTER grey filter (also called mirror), that may attenuate by app 13 BP (dB)
(not used in surgery)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION    0
                     GRAUFILTER_EINFAHREN  1   greyfilter will attenuate
                     GRAUFILTER_AUSFAHREN  2   greyfilter will not attenuate
          Dimension: none

IRISREGELUNG defines how the setting shall be done
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     REGELUNG_EIN        1   during radiation (to be executed fast and
                                             smoothly)
                     REGELUNG_AUS        2   outside of acquisition (to be executed
                                             precisely)
          Dimension: none

IRISWERT attenuation of iris, 0=fully opened (the larger the value, the darker the image)
old meaning: opening of iris (the larger the value, the less is the attenuation)
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 1/16 BP


SJUSTAGECMD

Object: SJUSTAGECMD ___ID: 000B

Description: service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              XCU to component. It is similar to a sTestCmd. Telegram flow sample:
              sServJustCmd ---> sJustageCmd ---> iJustageCmd ---> iServJustCmd
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SKALIBRIERUNG

Object: SKALIBRIERUNG ___ID: 027A

Description: Indicating calibration of an FD detector; sent by XCU. Send to indicate to
              other components that calibration is active e.g. collimators may open wider
              than usually
Sender     :   XCU
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

KALLECMD Calibration command
          Type:  Byte     (DEC)
          Range: 1 ... 6
                     KALLESTART         1   start of calibration
                     KALLEABBRUCH       2   cancel calibration
                     KALLEAKTIV         3   calibration is active
                     KALLEENDE          4   calibration finished
                     KALLESEQUENZSTART  5   start sequence
                     KALLESEQUENZENDE   6   end sequence
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SKASSPOS

Object: SKASSPOS ___ID: 01F5

Description: positioning of a cassette; sent from XCU to cassette
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

KASSPOSITION Cassette position
          Type:  Byte     (DEC)
          Range: 0 ... 4
                     KEINE_FESTE_POSITION   0   position undefined
                     LADEPOSITION_LINKS     1   left loading position
                     LADEPOSITION_RECHTS    2   right loading position (cassette can be
                                                taken by the user to put it in or to take it
                                                out)
                     KASSETTE_PARKPOSITION  3   cassette park position, cassette is out of
                                                the X-ray beam, so that fluoro or DFR
                                                exposures can be taken
                     AUFNAHMEPOSITION       4   exposure position - cassette is directly
                                                underneath the tube in order to be X-rayed
          Dimension: none

TEILNR Which subdivision of the cassette film will be used for this exposure.
          Type:  Byte     (DEC)
          Range: 1 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SLICHTVISIER_2

Object: SLICHTVISIER_2 ___ID: 0334

Description: switch light localizer (RFU) or laser (surgery) of collimator on and off
Sender     :   XCU
Receiver   :   CCU-IF   SM_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FUNCTIONMODE define behavior of collimation light
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_FM_TIMEOUT_MODE  0   collimation light shall operate in timeout
                                              mode
                     ACS_FM_TOGGLE_MODE   1   collimation light shall operate in toggle mode
                     ACS_FM_SWITCH_ON     2   switch on explicitly
                     ACS_FM_SWITCH_OFF    3   switch off explicitly
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SLIHVERZ

Object: SLIHVERZ ___ID: 02CF

Description: control whether 20 mA X-ray safety signal must be extended for some hundred ms
              or not (RFU: typ. 400ms). Is used for Vidoemed DI and DIC systems as well as
              surgery systems with II/TV
Sender     :   XCU
Receiver   :   GEN-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

STATUSLIH Status for Last Image Hold
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SLIMIT

Object: SLIMIT ___ID: 0320

Description: Tell the collimator the limitation for the max opening; sent from XCU to
              collimator. XCU is using zoom size for sending the limit. Iris limit only
              necessary in case of image intensifier systems (IRIS and II are round ...)
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

BLOCKIERUNG disable manual setting of the collimators
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     BLOCKIERUNG_EIN     1   manual settings disabled
                     BLOCKIERUNG_AUS     2   manual settings enabled
          Dimension: none

KREISFORM Circular collimation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     KREISFOERMIG_EIN    1   circular
                     KREISFOERMIG_AUS    2   rectangular
          Dimension: none

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{LIMITAKTION Activity of collimator when reaching limit
{          Type:  Byte     (DEC)
{          Range: 0 ... 4
{                       WERT_ALS_LIMIT           0   value of OEFFNUNG to be used as limit
{                                                    (max opening)
{                       WERT_ALS_LIMIT_ANFAHREN  1   value of OEFFNUNG to be used as limit
{                                                    (max opening) and collimator shall be
{                                                    opened to that value
{                       MAX_ALS_LIMIT            2   the max possible value shall be set as
{                                                    max opening
{                       MAX_ALS_LIMIT_ANFAHREN   3   the max possible value shall be set as
{                                                    max opening and collimator shall be
{                                                    opened to that value
{                       WERT_ALS_MIN_LIMIT       4   value of OEFFNUNG to be used as inner
{                                                    limit (min opening)
{          Dimension: none

{OEFFNUNG opening of the collimator measured on the target (FD-detector, Image intensifier of film cassette.
{          Type:  Word     (DEC)
{          Range: 1 ... 65534
{          Dimension: 0.1 mm


SMAGN

Object: SMAGN ___ID: 02E8

Description: with this object TUI-IF tells FLC if magnification feature is selected, and
              which center point shall be used
Sender     :   TUI-IF
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

MAGN_SELECTED this parameter signifies, if the postproc magnification feature is selected (on TUI)
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_YES         1
                     ACS_NO          2
                     ACS_MAGN_COORD  3   indicates that coordinate values are supplied in
                                         the COORD parameters
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

COORD_X x coordinate
          Type:  Integer16     (DEC)
          Range: 0 ... 2047
          Dimension: pixel

COORD_Y y coordinate
          Type:  Integer16     (DEC)
          Range: 0 ... 2047
          Dimension: pixel


SMYELO

Object: SMYELO ___ID: 01A2

Description: selection of myelograhie. Will tell the stand not to stop the tilting if the
              table is in the horizontal position.
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

STATUSMYELO Requesting myelography
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     MYELO_EIN  1   on= no stop on 0° tilt position
                     MYELO_AUS  2   off= stop on 0° tilt position
          Dimension: none


SNACHANZLOESCHEN

Object: SNACHANZLOESCHEN ___ID: 00A5

Description: Will make the the display clear the data display of kV/mAs applied in the last
              made acquisition; sent from XCU to displays
Sender     :   XCU
Receiver   :   FLC   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3
This object has no parameters


SORGANSELECT

Object: SORGANSELECT ___ID: 02B1

Description: Tells the FL-C which Organ has been chosen. Telegram flow sample:UI_XCU-->
              sBedOrg ---> iOrganAnz ---> sOrganSelect ---> sOrgDaten
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

EXAM_INDEX Index of chosen Exam Set, to synchronize List of OGPs and EXAM-Set between TUI and Fluorospot
          Type:  Integer16     (DEC)
          Range: -1 ... 32767
                     ACS_EXAM_DEFAULT  -1   FLC shall select application from default
                                            application group (used in button based surgery
                                            system)
                     KK_ABWAHL         0
                     EXAM_SET          1
                     SETS_2_TO_31      2    Exam sets 1 to 31
                     EXAM_SET_NRF      20
                     KK_PROGRAM        32
          Dimension: none

ORGAN_INDEX Index of organ program (0=no information)
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: none

ALT_INDEX Index for an alternative organ program, used for Ysio Systems.
          Type:  Word     (DEC)
          Range: 0 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

PROG_NAME name of a program of exam set (64 char unicode)
          Type:  String16 [ 64 ]     (ASCII)
          Range: 128 ... 128
          Dimension: unicode


SORGDATEN

Object: SORGDATEN ___ID: 02AF

Description: Data for FD Organprogram. The telegram is used to send system data from
              imaging system (organ program master) to the the other components. In case of
              RAD system sORGDaten is combined with sORGPositions, in case of fluoro systems
              it is combined with sDLProgData
Sender     :   FLC
Receiver   :   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

MAN_ACQ_OVERRIDE bitcoding of all parameters where an override of acq programs is possible: 0 = no override; 1 = with override
          Type:  Dword     (HEX)
          Range: 0x0 ... 0xFFFFFFFF
                     ACA_OV_ACQ_SYSTEM              0x00000001
                     ACS_OV_ACQ_TECHNIK             0x00000002
                     ACS_OV_ACQ_KV                  0x00000004
                     ACS_OV_ACQ_MAS                 0x00000008
                     ACS_OV_ACQ_MS                  0x00000010
                     ACS_OV_ACQ_DOSIS               0x00000020
                     ACS_OV_ACQ_KVDR                0x00000040
                     ACS_OV_ACQ_SCHWAERZKORR        0x00000080
                     ACS_OV_ACQ_SZEIT               0x00000100
                     ACS_OV_ACQ_KENNL               0x00000200
                     ACS_OV_ACQ_FOKUS               0x00000400
                     ACS_OV_ACQ_PROZ                0x00000800
                     ACS_OV_ACQ_REGSTOP             0x00001000
                     ACS_OV_ACQ_FILTERAUFN          0x00002000
                     ACS_OV_ACQ_RASTER              0x00004000
                     ACS_OV_ACQ_TOMOPROG            0x00008000
                     ACS_OV_ACQ_BUMKEHR             0x00010000
                     ACS_OV_ACQ_CALIBRATION_OGP     0x00020000
                     ACS_OV_ACQ_COLL_HEIGHT         0x00040000
                     ACS_OV_ACQ_AUTOZOOM            0x00080000
                     ACS_OV_ACQ_COLL_WIDTH          0x00100000
                     ACS_OV_ACQ_DUMMY               0x00200000
                     ACS_OV_ACQ_COLL_IRIS_DIAMETER  0x00400000
                     ACS_OV_ACQ_COLL_FINGER_POS     0x00800000
                     ACS_OV_ACQ_COLL_FINGER_ANGLE   0x01000000
                     ACS_OV_ACQ_COLL_WEDGE1_POS     0x02000000
                     ACS_OV_ACQ_COLL_WEDGE1_ANGLE   0x04000000
                     ACS_OV_ACQ_COLL_WEDGE2_POS     0x08000000
                     ACS_OV_ACQ_COLL_WEDGE2_ANGLE   0x10000000
                     ACS_OV_ACQ_BFREQ               0x20000000
                     ACS_OV_ACQ_GEWMESSF            0x40000000
                     ACS_OV_ACQ_XRPT                0x80000000
          Dimension: none

SYSTEM ID of selected System:
in surgery: 1=normal  2=cassette
in TRUMF:
No: dRF:          Ysio:            dTF:               Lum RF:       G1:
 1 Lum DFR       Table FD         Agile DFR          RF DFR        DFR Table
 2 Lum Tomo      Wall FD          Free Cass Tub1     RF Cass       DFR Wall
 3 Lum Ortho     Tomo FD          Free FD Tube 1     RF Wall       Ortho Table
 4 Free exp      Ortho (wall)     3D Wall FD         RF Free exp   Ortho Wall
 5 Wall FD       Free Cass        3D Wall Cass       RF Tomo DFR   Bed
 6 Wall Cass     Wall Cass        3D Free FD Tub2    RF Tomo Cass  Free MobFD
 7 3D Wall FD    Free Mobile FD   3D Free Cass Tub2      -         Mode3D
 8 3D Mobile FD  Table FD pulled  3D Ortho               -         SkelMal
 9 3D Wall Cass  Wall FD flipped  Table FD Tube 2        -         Ortho lat
10 3D Free Cass  Table Cass       Table Cass Tube2       -           -
11 3D Ortho      Ortho Table      Table FD pulled Tub2   -           -
12 Free MobFD Tub1   -            3D Table Ortho         -           -
note: Uroskop has just system no1 = Uro DFR
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

KVDR kV for dose reduction. If the patient thickness is too high for tube power, kV will automatically increase, because X-ray will retrieve more energy out of kV than out of mAs. To increase kV means to reduce heat power consumption. If the kV will be increased, the contrast will get worse. This kV for dose reduction determines, when kV rising will stop for a while and the dose it reduced to 50%. Decreasing the dose will make the image noisier. However at a certain point of kV it is better to get more noise than to loose more contrast
In an OGP for Mode3D this parameter is used for MaxKV (in 0-pnt technique).
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

SCHWAERZKORR Blackening correction. This value is applied to the dose in order to have more dose steps than it is possible with HUD.
          Type:  Integer16     (DEC)
          Range: -32 ... 32
          Dimension: 0.25 BP

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

KENNL Number of the exposure curve that determines the kV from the thickness of the object to be X-rayed
In sOrgDaten this parameter will be used if parameter KV is set to 0
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: Nr

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

PROZ The parameter will reduce the max electrical power (which is given by max power value for the selected focus) to the given percentage in order to enlarge the lifespan of the tube.
Thus for a given kV it allows to reduce the current in order to artificially prolong the pulse time (which replaces the former "reduced current" techniques 8 and 20)
          Type:  Byte     (DEC)
          Range: 10 ... 100
          Dimension: %

REGSTOP stop dose regulation in generator and keep kV and mAs values for all subsequent pulses
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

FILTERAUFN Cu filter used for acq. This is a bit oriented value. Bit0 is "Filter auto", Bit1 is "use filter out of OGP", Bits 4 to 5 tell the filter number. E.g.: 2 = Filter 0, 34d = 22h = Filter 2, 51d = 33h = Filter 3 and Auto is on, 32d = 20h = leave filter as it is, because Bit 1 is 0.
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

RASTER Grid number according to configuration
          Type:  Byte     (DEC)
          Range: 0 ... 7
                     ACS_NO_GRID_SELECTED  0   no grid selected
          Dimension: none

TOMOPROG Number of tomo program if tomo is selected.
If tomo is not selected and tomoprog = 10 then it means DSA.
Is also used for DR-Scan parameters with the following definition:
1: 4cm/s   feet to head
2: 4cm/s   head to feet
5: 6cm/s   feet to head
6: 6cm/s   head to feet
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: none

BUMKEHR image flip and rotation
          Type:  Byte     (DEC)
          Range: 0 ... 96
                     KEINE_ANGABE_NORMAL   0    no image flip
                     UMKEHR_HORIZONTAL     1    horizontal image flip
                     UMKEHR_VERTIKAL       2    vertical image flip
                     UMKEHR_VERT_HORIZ     3    horizontal and vertical image flip
                     ACS_BILD_DREHUNG_90   32   image rotated by 90° clockwise
                     ACS_BILD_DREHUNG_180  64   image rotated by 180°
                     ACS_BILD_DREHUNG_270  96   image rotated by 270° clockwise
          Dimension: none

CALIBRATION_OGP OGP is used for calibration. (If yes, XCU will block any inputs of TUI and allow 2 point technique in DFR mode (=series DFR with fixed mAs)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     NORMAL_OGP       0
                     CALIBRATION_OGP  1
          Dimension: none

COLL_HEIGHT Height of collimation
          Type:  Integer16     (DEC)
          Range: 0 ... 6000
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

AUTO_ZOOM Auto Zoom will make the zoom follow the collimation given in this telegram. In case of Auto Zoom the system will set the Zoom that way that the zoom size in mm is as close to the max of collimator width and height but still larger or equal than this width and height.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
          Dimension: none

MIN_PULSE_WIDTH This is needed for SkelMal
A value of 0 means "determined by XCU"
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: 0.1ms

COLL_WIDTH Width of collimation
          Type:  Integer16     (DEC)
          Range: 0 ... 6000
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

SKELMAL_PREP_COLLHEIGHT a value of 0 means "use normal coll height for prep"
          Type:  Integer16     (DEC)
          Range: 0 ... 6000
          Dimension: 0.1mm

COLL_IRIS_DIAMETER Diameter of iris collimator
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

COLL_FINGER_POS Position of finger wedge collimator
in surgery not used
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

COLL_FINGER_ANGLE Angle of finger wedge collimator
In surgery used for angle of rectangle image collimator
          Type:  Integer16     (DEC)
          Range: 0 ... 3600
                     NO_OVERRIDE  0
          Dimension: 0.1 °

COLL_WEDGE1_POS Position of wedge collimator 1
used for SLOT_LAMELLA_1 in surgery
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

COLL_WEDGE1_ANGLE Angle of wedge collimator 1
used SLOT_LAMELLA_1 in surgery
          Type:  Integer16     (DEC)
          Range: 0 ... 3600
                     NO_OVERRIDE  0
          Dimension: 0.1 °

COLL_WEDGE2_POS Position of Wedge collimator 2
used SLOT_LAMELLA_2 in surgery
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

COLL_WEDGE2_ANGLE Angle of wedge collimator 2
used SLOT_LAMELLA_2 in surgery
          Type:  Integer16     (DEC)
          Range: 0 ... 3600
                     NO_OVERRIDE  0
          Dimension: 0.1 °

NUM_STEPPARA Number of step-parameters
          Type:  Dcount     (CNT)
          Range: 1 ... 8
          Dimension: number of data blocks

{FRATE frame rate (in ST_CP_DATA the highset freq that the user can select during the running series)
{          Type:  Integer16     (DEC)
{          Range: 0 ... 600
{          Dimension: 0.1fps

{GEWMESSF logical number of chosen measuring field
bits 0-2 define the field selection
bits 3-4 define a rotation (for 5-field chamber)
bit 7 defines histogram based dexi calculation
{          Type:  Byte     (DEC)
{          Range: 0 ... 128
{                       KEINE_ANGABE_RUND        0     circular measuring field
{                       LINKS                    1     left
{                       MITTE                    2     center
{                       LINKS_MITTE              3     left and center
{                       RECHTS                   4     right
{                       LINKS_RECHTS             5     left and right
{                       MITTE_RECHTS             6     center and right
{                       LINKS_MITTE_RECHTS       7     left, center, and right
{                       ACS_AEC_ROT_90DEG        8     for 5-chamber AEC:
{                                                      selection (bits 0-2) shall be rotated
{                                                      by 90 degrees in clockwise direction
{                       ACS_AEC_ROT_180DEG       16    for 5-chamber AEC:
{                                                      selection (bits 0-2) shall be rotated
{                                                      by plus 180 degrees
{                       ACS_AEC_ROT_MINUS_90DEG  24    for 5-chamber AEC:
{                                                      selection (bits 0-2) shall be rotated
{                                                      by 90 degrees counterclockwise (or
{                                                      270 degrees clockwise)
{                       ACS_AEC_HISTO            128   take histogram based DEXI value
{                                                      instead of fixed measuring field
{          Dimension: none

{DUMMY1
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{XRPT_FLRAD Detector time XRPT (for acquisition)
{          Type:  Word     (DEC)
{          Range: 0 ... 3200
{          Dimension: ms


SORGPOSITIONS

Object: SORGPOSITIONS ___ID: 02BA

Description: Image System sends Stand Positions (for RAD Systems) of Organ Programs to XCU.
              Not applicable Parameters should be sent with NIL. XCU will distribute the
              parameters to the SCU.. If user then presses the move button the stand should
              move to the dedicated position
Sender     :   FLC   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TBL_X_RAD RAD only: table longitudinal position headwards / footwards
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Y_RAD RAD only: table side (transverse) offset, left / right
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Z_RAD RAD only: table lift (height)
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TBL_ROT_RAD RAD only: table left / right, + means: right
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_LONGI RAD only: Longitudinal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_TRANS RAD only: Transversal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_LIFT RAD only: Detector (or cassette) lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

DETECTOR_ROT_HOR RAD only: detector (or cassette) rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_ROT_VERTICAL RAD only: detector (or cassette) rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_TILT RAD only: detector (or cassette) tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_LONGI RAD only: Longitudinal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_TRANSVERSAL RAD only: transversal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_LIFT RAD only: Tube lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TUBE_ROT_HOR RAD only: Tube rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_VERTICAL RAD only: Tube rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

WALL_STAND_LIFT RAD only: Wall stand lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

WALL_STAND_TILT RAD only: wall stand tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

BEAM_ANGLE_ALPHA RAD only: Angle of incidence (alpha) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

BEAM_ANGLE_BETA RAD only: Angle of incidence (beta) of the central beam to the detector (or cassette)
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01 degree

COLLIMATOR_ROT_A RAD only: Collimator rotation
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TOMO_HEIGHT height for tomo
          Type:  Word     (DEC)
          Range: 0 ... 5000
          Dimension: 0.1 mm

ALIGNMENT_MODE Determines, whether tube center is aligned to detector (or cassette) center, or whether top of collimator field of view is aligned to top of detector (or cassette)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_ALIGNMENT_CENTERED  0   centered
                     ACS_ALIGNMENT_TOP       1   top
          Dimension: none

TRACKING Tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 15
                     ACS_TRACK_NOT_ACTIVE         0    tracking not active
                     ACS_TRACK_SYMMETRICAL        1    symmetrical
                     ACS_TRACK_TOP_ALIGN          2    asymmetrical top alignment
                     ACS_TRACK_BOTTOM_ALIGN       3    asymmetrical bottom alignment
                     ACS_TRACK_LEFT_ALIGN         4    asymmetrical left alignment
                     ACS_TRACK_RIGHT_ALIGN        5    asymmetrical right alignment
                     ACS_TRACK_LOST_SYMMETRICAL   11   tracking lost, symmetrical
                     ACS_TRACK_LOST_TOP_ALIGN     12   tracking lost, asymmetrical top
                                                       alignment
                     ACS_TRACK_LOST_BOTTOM_ALIGN  13   tracking lost, asymmetrical bottom
                                                       alignment
                     ACS_TRACK_LOST_LEFT_ALIGN    14   tracking lost, asymmetrical left
                                                       alignment
                     ACS_TRACK_LOST_RIGHT_ALIGN   15   tracking lost, asymmetrical right
                                                       alignment
          Dimension: none

SID_TRACKING SID tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_TRACK_NOT_ACTIVE  0   SID tracking not active
                     ACS_SID_TRACK_ACTIVE      1   SID tracking active
                     ACS_SID_TRACK_LOST        2   SID tracking lost
          Dimension: none

ORTHO_DIR direction of ortho acquisition
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_HEAD_TO_FEET  0   direction of acquisition (ortho)
                     ACS_FEET_TO_HEAD  1   direction of acquisition (ortho)
                     ACS_TRANSVERSAL   2   for ortho panorama
          Dimension: none

TUBE_ROT_HOR_FLUORO tube rotation at dRF
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_LIFT_FLUORO tube lift at dRF
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TBL_TILT table tilting up / down  around Y axis, + means: head end up
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
                     ACS_HORIZONTAL_TABLE  0
          Dimension: 0.1 degree

TOWER_LONGI longitudinal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -30000 ... 30000
          Dimension: 0.1 mm

TOWER_TRANSVERSAL transversal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -10000 ... 10000
          Dimension: 0.1 mm


SORTHO

Object: SORTHO ___ID: 01AE

Description: XCU informs image system about ortho parameters
Sender     :   XCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FULL_IMAGE_SIZE Total length of the ortho exposure to be scanned
          Type:  Integer32     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mm

POS1VAL angle of the first ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°

POS2VAL angle of the second ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°

SOURCE_OF_RANGE this parameter tells the source of the collimator size or ortho range
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION   0
                     ACS_SRCRNG_MANUAL    1   collimator size was determined using knobs at
                                              the collimator or
                                              ortho size has been determined by tube tilting
                     ACS_SRCRNG_VIRTUAL   2   collimator size was determined by dragging the
                                              virtual collimator
                     ACS_SRCRNG_AUTOALGO  3   colimator size was determined by automatic
                                              algorithm (SmartSensing)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NR_IMAGES Number of ortho images
          Type:  Count     (CNT)
          Range: 0 ... 4
          Dimension: none

{IMAGE_SIZE Size of the current image of an ortho scene
{          Type:  Word     (DEC)
{          Range: 0 ... 4300
{          Dimension: 0.1 mm

{ORTHO_OVERLAP overlap with the next image
{          Type:  Word     (DEC)
{          Range: 0 ... 1000
{          Dimension: 0.1 mm


SORTHOACTSIZE

Object: SORTHOACTSIZE ___ID: 01B0

Description: XCU informs the imaging system about the size of the current part of an ortho
              image. Telegram flow sample iOrtho ---> sOrtho ---> SH_ORTHO -->iOrthoActSize
              ---> sOrthoActSize
Sender     :   XCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

IMAGE_NR Number of the current image of an ortho sequence
          Type:  Byte     (DEC)
          Range: 0 ... 4
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IMAGE_SIZE Size of the current image of an ortho scene
          Type:  Word     (DEC)
          Range: 0 ... 4300
          Dimension: 0.1 mm

POSITION_ORTHO distance from first to actual detector position
          Type:  Integer32     (DEC)
          Range: 0 ... 25000
          Dimension: 0.1 mm

DUMMY Dummy parameter (4 chars ASCII)
          Type:  String8 [ 4 ]     (ASCII)
          Range: 4 ... 4
          Dimension: none


SPATWECHSEL

Object: SPATWECHSEL ___ID: 02D2

Description: indicating change of patient ; will trigger a reset of fluoro data SPATWECHSEL
              is sent upon image system sending sDFRPatWechsel. The telegram is also used to
              reset programmed OGP positions in the stand.
Sender     :   XCU
Receiver   :   CCU-IF   GEN-IF   SCU-IF   TUI-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

PAT_ACTION status of the patient registration
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     ACS_EMERGENCY_PAT   1   patient registered in an emergency mode
                     ACS_PAT_EXAM        2   patient has been registered for examination
                     ACS_PAT_CLOSED      3   patient has been closed
                     ACS_PAT_SERVICE     4   service patient has been opened for examination
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SPROGRAMLIST

Object: SPROGRAMLIST ___ID: 02B3

Description: Sends list of organ programs to be displayed on TUI from FLC to XCU (TUI-IF).
              Contains information about Target (table, free exposure, wall), and if it
              already has been in use in this session. TUI-IF will translate this telegram
              to the AXCS-style telegram SH_PROG_NAME.
              Will be sent to PMS during 3D-Calibration.
Sender     :   FLC
Receiver   :   PMS   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

EXAM_INDEX Index of chosen Exam Set, to synchronize List of OGPs and EXAM-Set between TUI and Fluorospot
          Type:  Integer16     (DEC)
          Range: -1 ... 32767
                     ACS_EXAM_DEFAULT  -1   FLC shall select application from default
                                            application group (used in button based surgery
                                            system)
                     KK_ABWAHL         0
                     EXAM_SET          1
                     SETS_2_TO_31      2    Exam sets 1 to 31
                     EXAM_SET_NRF      20
                     KK_PROGRAM        32
          Dimension: none

PROG_NAME_USAGE usage of the list
          Type:  Enum8     (DEC)
          Range: 1 ... 6
                     ACS_OGP_LIST      1   list of names of OGPs
                     ACS_EXAM_LIST     2   list of names of examination sets
                     ACS_ALT_LIST      3   List with alternative OGPs only (used in RFU)
                     ACS_CHANGE_ENTRY  4   only used in RFU
                     ACS_ADD_ENTRY     5   only used in RFU
                     ACS_DELETE_ENTRY  6   only used in RFU
          Dimension: none

UPDATE_LAST_SELECTION ImageSystem tells XCU whether last organ program shall still be active:
ACS_YES: last organ program shall still be active
ACS_NO: last organ program shall no longer be active
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

NO_PROG_NAME number of program names
          Type:  Dcount     (CNT)
          Range: 0 ... 10
          Dimension: none

{PROG_INFO additional information regarding the program used at the UI
{          Type:  Enum8     (DEC)
{          Range: 0 ... 9
{                       ACS_NOT_DEFINED          0   not defined
{                       ACS_PF_WP_CASS           1   work place cassette
{                       ACS_PF_WP_TABLE          2   work place table
{                       ACS_PF_WP_WALL           3   work place wall stand
{                       ACS_PF_WP_FREE           4   work place free exposure
{                       ACS_PF_WP_3DSIDE         5   side trajectory for 3D acquisition
{                       ACS_PF_WP_3DTABLE        6   table trajectory for 3D acquisition
{                       ACS_PF_WP_3DUPRIGHT      7   upright trajectory for 3D acquisition
{                       ACS_PF_WP_TOPO_LYING     8   SkelMal at table (2D Topogram)
{                       ACS_PF_WP_TOPO_STANDING  9   upright SkelMal (2D Topogram)
{          Dimension: none

{PROG_EXECUTED For programs only: Is the program already used
{          Type:  Enum8     (DEC)
{          Range: 1 ... 2
{                       ACS_YES  1
{                       ACS_NO   2
{          Dimension: none

{ORGAN_INDEX Index of organ program (0=no information)
{          Type:  Word     (DEC)
{          Range: 0 ... 32767
{          Dimension: none

{PROGRAM_NAME Organ Program Name for Rad Fluoro, 64 chars UNICODE
{          Type:  String16 [ 64 ]     (ASCII)
{          Range: 128 ... 128
{          Dimension: unicode


SPULTUPDATE

Object: SPULTUPDATE ___ID: 00AB

Description: Telegram sent by XCU to UIS to indicate that the CP selection (i.e. setting of
              CP parameters within the system) is entirely done
Sender     :   XCU
Receiver   :   TUI-IF   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

UPDATE update trigger for desk
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     KEINE_AKTUALISIERUNG       0   no refresh
                     PULTANZEIGE_AKTUALISIEREN  1   Refresh of display on generator desk
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SRASTER

Object: SRASTER ___ID: 032A

Description: Controlling the grid; sent from XCU to stand.
              Used in Uroscope only (since there we have a motorized grid)
              Typical telegram flow for automatic grids: sBedStrm ---> sRaster ---> iRaster.
              For dRF and Ysio the grid is given in the organ program. Grid numbers are for
              usual not assigned fixed to a grid focus, This is done dynamically by
              configuration. In case of Ysio the iRaster is derived from a SH_GRID (SH_GRID
              does not use grid number but uses the focus instead) and the sRaster would end
              in a ST_GRID.
Sender     :   XCU
Receiver   :   RAD-STD   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

RASTERNR Grid number
          Type:  Byte     (DEC)
          Range: 0 ... 7
          Dimension: none

RASTERAKTION Grid position
          Type:  Byte     (DEC)
          Range: 1 ... 5
                     PARKPOSITION           1   grid is parked = not inserted
                     ZENTRIERTPOSITION      2   grid is inserted
                     VORBEREITUNGSPOSITION  3   Grid is ready for reversing so that grid
                                                lines are invisible in image, only for
                                                reversable grids applicable
                     REVERSIEREN            4   start reversion
                     RASTERSTOPP            5   stop reversion
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SRAUMLICHT

Object: SRAUMLICHT ___ID: 02CE

Description: control of the roomlight via a relais in the generator; sent from XCU to
              generator. Roomlight is controlled twice: by configuration depending of turn
              off/on fluoro and or acquisition and by a switch controlled by the user. For
              usual user wants to have a dark room while fluoro is running because roomlight
              in a surgery lab may be to bright so that use cannot see the details on X-ray
              monitor. Some users use the relais to dim the lights and not to turn them off
              completely. The manual switch is invoked by sBedAllg
Sender     :   XCU
Receiver   :   GEN-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STATUSRLICHT state of the roomlight relais
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SREGELDATEN

Object: SREGELDATEN ___ID: 02BF

Description: When an acquisition series is taken, the telegram traffic is too slow to
              control mAs and kV of the single images of a series. Therefore the generator
              will do that by itself. This telegram is telling the curve how to change kV,
              mA and ms depending on the transparency of the object; The telegram is sent
              from XCU to generator.
Sender     :   XCU
Receiver   :   GEN-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

STARTW Start value for the first exposure, identical to the one send in sAufnDaten.
The resolution depends on RESOLUTION_STARTW.
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 1/4 or 1/16 EP

RESOLUTION_STARTW defines the resolution of the value in parameter STARTW (used in surgery)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_RESOL_STARTW_4   0   resolution is in 0.25=1/4th EP
                     ACS_RESOL_STARTW_16  1   resolution is 1/16th EP
          Dimension: none

PUNKTE how many points are on the curve
          Type:  Count     (CNT)
          Range: 1 ... 8
          Dimension: number of data blocks

{BP_PUNKTE sum of the following three Exposure points of kV, mA and ms
{          Type:  Integer16     (DEC)
{          Range: 0 ... 1000
{          Dimension: 0.25 BP

{KV_PUNKTE Voltage in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 1000
{          Dimension: 0.25 BP

{MA_PUNKTE current in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 1000
{          Dimension: 0.25 BP

{MS_PUNKTE Acquisition time in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 1000
{          Dimension: 0.25 BP


SREGELDATEN2

Object: SREGELDATEN2 ___ID: 03BF

Description: When an acquisition series is taken, the telegram traffic is too slow to
              control mAs and kV of the single images of a series. Therefore the generator
              will do that by itself. This telegram is telling the curve how to change kV,
              mA and ms depending on the transparency of the object; The telegram is sent
              from XCU to generator.
              Compared to sRegeldaten this telegram has all values in 1/16 EP.
Sender     :   XCU
Receiver   :   UGEN
Mode       :  DIRECT(01)
Systems    :  RadFluoro and show

List of Parameters:

STARTVAL Start value for the first exposure, identical to the one send in sAufnDaten.
          Type:  Integer16     (DEC)
          Range: 0 ... 4000
                     ACS_USE_CURRENT  0   use the actual (=last valid) EP sum
          Dimension: 1/16 EP

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_SUPP_PNTS number of supporting points of the given curve
          Type:  Count     (CNT)
          Range: 0 ... 40
          Dimension: count of elements

{EP_POINTS sum of the following Exposure points (= x-axis of curve)
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{KV_POINTS voltage in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{MA_POINTS current in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{MS_POINTS pulse time in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{DR_POINTS dose reduction
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP


SREGELDATENDL

Object: SREGELDATENDL ___ID: 04BF

Description: In order to harmonize the image impression between fluoro and DR, the same
              curves shall be used (except for different mAs range). This telegram is used
              by XCU to send the curve for fluoro to generator.
Sender     :   XCU
Receiver   :   UGEN
Mode       :  DIRECT(01)
Systems    :  RadFluoro and show

List of Parameters:

STARTVAL Start value for the first exposure, identical to the one send in sAufnDaten.
          Type:  Integer16     (DEC)
          Range: 0 ... 4000
                     ACS_USE_CURRENT  0   use the actual (=last valid) EP sum
          Dimension: 1/16 EP

FRATE frame rate (in ST_CP_DATA the highset freq that the user can select during the running series)
          Type:  Integer16     (DEC)
          Range: 0 ... 600
          Dimension: 0.1fps

XRPT_FL_MAX specifies the maximum length of the xray pulse (sensitive period of detector) (for fluoro)
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: ms

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_SUPP_PNTS number of supporting points of the given curve
          Type:  Count     (CNT)
          Range: 0 ... 40
          Dimension: count of elements

{EP_POINTS sum of the following Exposure points (= x-axis of curve)
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{KV_POINTS voltage in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{MA_POINTS current in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{MS_POINTS pulse time in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{DR_POINTS dose reduction
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP


SREGELSTOP

Object: SREGELSTOP ___ID: 02D5

Description: Advising stop acquisition regulation stop to the generator, sent from XCU to
              generator before acq will start.
              In S1 also used during running fluoro.
              In RFU only for acquisition - not supposed to control regulation stop in
              fluoro. Cannot be sent while a series is running - only before series is
              started. The amount of images to wait for regulation stop depends on the image
              frequency. The regulation stop for DSA is necessary to have a stable mask. The
              waiting time results from the fact that the filament current is not stable in
              the first second of an acq scene.
Sender     :   FLC   XCU
Receiver   :   FLC   GEN-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

REGACTION Type of regulation stop for exposure (not for fluoro)
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEIN_STOP_REG_EIN  0   no regstop, dose regulation shall stay active
                     REGSTOP_SOFORT     1   regstop shall get active immediately
                     REGSTOP_X_BILDER   2   regstop shall get active after the number of
                                            pulses given in REGPARA
          Dimension: none

REGPARA Image to be taken after stop applies
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: none

TWIN_MODE twinmode means, that an image is read twice (first time after half of the pulse time is over, second time after the x-ray pulse is completed) in order to reduce noise. This parameter will tell the generator to generate a second trigger in the mid of an x-ray pulse
(used with II/TV systems only)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     NO   0
                     YES  1
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SRESET

Object: SRESET ___ID: 0012

Description: Reset of a component, formerly send from XCU to a component.
              The only component listening to that telegram is the generator.
Sender     :   PMS   XCU
Receiver   :   CCU-IF   FLC   GEN-IF   RAD-STD   TUI-IF
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs
This object has no parameters


SRESETFEHLER

Object: SRESETFEHLER ___ID: 0014

Description: Reset an error of generator, sent from XCU to generator. This telegram will
              make the component to perform the measures to reset an error. For instance if
              the iontomat in the generator has an error the generator will restart iontomat
              software upon this telegram.
              If ACS_ERR_YESNO bit was set in CATEGORY in iFehler, the parameter CHOICE can
              transmit the user decision.
              Still used by UnifiedGenerator.
Sender     :   XCU
Receiver   :   GEN-IF   GEN-MOBI   UGEN
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

CHOICE selected option (in MSGBOX_YESNO)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SSCHICHT

Object: SSCHICHT ___ID: 0192

Description: data for tomo; sent from XCU to stand. Containing Angle, Time and height for
              Tomo. Angle and Time are stored in a -Program- and cannot be changed
              individually. The height may be changed separately. Changing of program be
              done by sBedTomo, height by sBedGG.Code=15
Sender     :   XCU
Receiver   :   RAD-STD   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

TOMOWINKEL tomo angle, how many degrees will the stand move, while X-ray is turned on during the tomo exposure
          Type:  Byte     (DEC)
          Range: 0 ... 180
          Dimension: Grad

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

TOMOZEIT tomo time, how long will X-ray be turned on during the tomo exposure
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: msec

TOMOHOEHE tomo height, there is only one plane that will be focused while a tomo run, this parameter tells the height of the focused plane relative to the table
          Type:  Integer16     (DEC)
          Range: 0 ... 5000
          Dimension: 0.1 mm

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SSELECTCOMP

Object: SSELECTCOMP ___ID: 0BBB

Description: requesting components to set in service of normal mode, sent from service PC
              to XCU. Telegram flow sample: sSelectComp ---> sService ---> iFEStatus --->
              iStatusReport
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

SELFUNKTION Service function
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     START_SERVICE  1
                     ENDE_SERVICE   2
          Dimension: none

APANZAHL amount of AP Ids in the structure
          Type:  Count     (CNT)
          Range: 0 ... 10
          Dimension: number of data blocks

{APID Application ID (see complete list is attached to the list of all objects)
{          Type:  Byte     (HEX)
{          Range: 0x0 ... 0xFF
{          Dimension: none


SSERVBETRIEB

Object: SSERVBETRIEB ___ID: 0BE0

Description: reset life time counter of tube data (in case a tube has to be replaced) |
              direct mode
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

TUBENR Tube number (1-4)
value 0 means: generator itsself
          Type:  Byte     (DEC)
          Range: 0 ... 4
          Dimension: none


SSERVBETRIEB2

Object: SSERVBETRIEB2 ___ID: 0BE3

Description: receiver (XCU or generator) shall set (or reset) tube load data
              The purpose is to allow synchronization between two locations where tube
              information is stored
Sender     :   PMS
Receiver   :   UGEN   XCU
Mode       :  DIRECT(01)
Systems    :  RadFluoro and Rad3

List of Parameters:

SERVBETRCMD code that defines what shall be done with the given values
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_SBC_RESET   1   the tube load values in the receiver device shall
                                         be deleted
                                         (same function as sServBetrieb)
                     ACS_SBC_SETVAL  2   the tube load values given shall be stored in the
                                         receiver device
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

TUBECTR how many tubes are included in the system, count for the following parameters
          Type:  Count     (CNT)
          Range: 1 ... 2
          Dimension: number of data blocks

{TUBENR Tube number (1-4)
value 0 means: generator itsself
{          Type:  Byte     (DEC)
{          Range: 0 ... 4
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{BELEINH load units of the tube, a load unit is a specific value for each specific tube, usually in single technique each spin up of the anode is counted as a BE (each exposure) and in series 1sec exposure time is also counted a 1 BE
{          Type:  Integer32     (DEC)
{          Range: 0 ... 9999999
{          Dimension: BE

{AUFNWAIT exposures made although waiting time has been displayed. Waiting time will be displayed for usual if the heating status of the tube reaches 65% of the max tube load. Then the user should not do any more exposure. If he does anyway this counter will be increased
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{AUFNOL tube overload, if the max heat capacity of the tube (100%) has been reached, this counter will be increased
{          Type:  Word     (DEC)
{          Range: 0 ... 65535
{          Dimension: none

{BELEINH2 load units of the second focus spot of the tube
{          Type:  Integer32     (DEC)
{          Range: 0 ... 9999999
{          Dimension: BE


SSERVDLDCMD

Object: SSERVDLDCMD ___ID: 0BC5

Description: download type selection, sent from Service PC to XCU. Telegram flow sample:
              sServDownload ---> sReset ---> iIdent ---> iNetzaufnahme ---> iFEStatus --->
              sDownload ---> iFEStatus ---> iStatusReport ---> iFEStatus ---> sDownload --->
              iFEStatus ---> iStatusReport ---> sServDldCmd ---> sDLDCmd ---> iFEStatus --->
              iStatusReport ---> sServDldData ---> sDLDData
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

KOMMANDO download command
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     START_DOWNLOAD         1   start download
                     PROGSPEICHER_LOESCHEN  2   erase flash eprom
                     DLD_BEENDEN            3   download finished
                     DOWNLOAD_FLOPPY        4   download from floppy
          Dimension: none

PROZESSOR Which processor system has to be downloaded (0=host; 1-254=sub processors)
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     HOSTPROZ  0
          Dimension: none


SSERVDLDDATA

Object: SSERVDLDDATA ___ID: 0BC6

Description: Download data, sent from Service PC to XCU. sServDownload ---> sReset --->
              iIdent ---> iNetzaufnahme ---> iFEStatus ---> sDownload ---> iFEStatus --->
              iStatusReport ---> iFEStatus ---> sDownload ---> iFEStatus ---> iStatusReport
              ---> sServDldCmd ---> sDLDCmd ---> iFEStatus ---> iStatusReport --->
              sServDldData ---> sDLDData
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

SELEKTOR Data type
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     DLDHEADER    0   download header
                     DLDDATEN     1   download data
                     DLDCHECKSUM  2   download checksum
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SSERVDOWNLOAD

Object: SSERVDOWNLOAD ___ID: 0BC4

Description: Advices the XCU, which component will be set to download mode and what is the
              destination for following download telegrams sent from Service PC to XCU. Used
              for downloading collimator and BUC sw of Uroskop and Luminos dRF
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none


SSERVERRORLOG

Object: SSERVERRORLOG ___ID: 0BC2

Description: Command for deleting the errorlog in the XCU, sent from Service PC to XCU.
              Errorlog in XCU of Polydoros LX is 100 errors, in SX it is 500 errors, in
              F55/80/R80 it is 1500 errors. The separation between warning and error buffer
              is only valid for LX - XCU. All other XCU support only one buffer.The answer
              should iServErrolog
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

ERRORCMD This parameter is no longer used, since in the meantime both error and warning buffer are the same in the XCU.
          Type:  Byte     (DEC)
          Range: 1 ... 3
                     ERROR_WARNUNG_BUF  1
                     ERROR_BUF          2
                     WARNUNG_BUF        3
          Dimension: none


SSERVINIT

Object: SSERVINIT ___ID: 0BBD

Description: Store initdata blocks in XCU, sent from service PC to XCU. SSERVINIT (0,0)
              will erase all init blocks in XCU.
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

INITKENNUNG number of init block
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SSERVJUSTCMD

Object: SSERVJUSTCMD ___ID: 0BBF

Description: service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              service PC to XCU.
              Meaning of CMDKENNUNG:
              1=WaterEqivalentCalibration,
              2= Send of sIris based on new adjusts,
              3=turn off sending of iBinOK,
              4=FluoroDoseFactor for DoseAdjust
              5=Deactive fluoro and buzzer timer for tube adjust and suppress grid error
              message cause there is no user to change grid, allow collimator opening
              greater than limit
              6=DownloadMode (suppress of errors)
              7=generator shall not wait for HW-Trigger from image system (PMS can release
              radiation w/o ImgSys being ready)
              8=filter 0mm is allowed in fluoro
              9=XCU shall ignore sBedAusl from MCU (footswitch used as service switch in
              surgery)
              10=GEN-IF sends iGenStatus not just direct to XCU but also indirect (used in
              surgery)
              11=XCU will stop sending sBlendenPos (allowing PMS to do so)
              12=deactivates air-kerma-rate-limitation of fluoro curve
              13=set acquisition index
              14=release of x-ray only allowed by hand-switch
              15=RELATIVE_CP_POS_USAGE will be overwritten to "absolute" in ST_STPAR_RFP
              (used for centering adjustment)
              16=send iWatervalAcq on "dark" acquisitions
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SSERVTESTCMD

Object: SSERVTESTCMD ___ID: 0BC0

Description: Service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              PMS to XCU. XCU will send a sTestCmd to the specific component as long as
              component is not the XCU.
              Currently there is only one code defined for CMDKENNUNG:
              5=set Tube load (HU) to 62% HU for test of audible tube alarm, that will be
              invoked at 65%
Sender     :   PMS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

APID Application ID (see complete list is attached to the list of all objects)
          Type:  Byte     (HEX)
          Range: 0x0 ... 0xFF
          Dimension: none

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SSPINE

Object: SSPINE ___ID: 01AC

Description: Control and display of spine reconstruction sent from XCU to components. Spine
              reconstruction is also called DR-SCAN or Long leg display and is done by a
              continuously moving stand by a doing series exposures with the height
              collimator closed to 5 - 10 cm.
Sender     :   XCU
Receiver   :   RAD-STD   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

SPINE_SPEED Speed of spine reconstruction
1: 40mm/s   feet to head;
2: 40mm/s    head to feet;
3: 50mm/s   feet to head;
4: 50mm/s    head to feet;
5: 60mm/s   feet to head;
6: 60mm/s    head to feet
7: 70mm/s   feet to head;
8: 70mm/s    head to feet
9: 80mm/s   feet to head;
10: 80mm/s    head to feet
all other: 60mm/s (even values mean head to feet, odd values mean feet to head)
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     SPINE_OFF  0
          Dimension: Geschwindigkeitsklasse

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SSPRITZE

Object: SSPRITZE ___ID: 0195

Description: Control of injector; sent from XCU to stand. The injection system will be
              triggered as soon as the rest of the system component's is ready for radiation
              in order to inject contrast agent only if the X-ray is ON
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

AUSLOESE injector injecting
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     SPRITZE_AUS_  0   injection off
                     SPRITZE_EIN   1   injection running
                     SPRITZE_AUS   2   injection off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SSTELLUNG

Object: SSTELLUNG ___ID: 0193

Description: Set gantry/stand for a fixed position. For usual used to control the stand's
              position for TOMO by the XCU.
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD   SCU-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FESTPOSITION ID of the position
          Type:  Byte     (DEC)
          Range: 1 ... 50
                     PAT_UEBERNAHME   1    patient load
                     UMBAU_1          2
                     UMBAU_2          3
                     UMBAU_3          4
                     UMBAU_4          5
                     UMBAU_5          6
                     SCHICHTAUSGANG   7    tomo: middle position before pressing the button
                                           to start tomo
                     SCHICHTSTART     8    stand has reached outer border and waits for next
                                           telegram to start the tomo shape
                     SCHICHTSTOP      9    end of tomo (stand has reached after tomo shape
                                           the other outer border
                     SCHICHTABBRUCH   10
                     SCHICHTHOEHMESS  11   Move to a lateral position in which the fulcrum
                                           (Schichthöhe) can be shown using the laser line
                                           of the collimator
                     SCHRITTPOS_0     20   step 0
                     SCHRITTPOS_1     21
                     SCHRITTPOS_2     22
                     SCHRITTPOS_3     23
                     SCHRITTPOS_4     24
                     SCHRITTPOS_5     25
                     SCHRITTPOS_6     26
                     SCHRITTPOS_7     27
                     SCHRITTPOS_8     28
                     SCHRITTPOS_9     29
                     SCHRITTPOS_10    30
                     FESTPOSITION_0   40   fixed position 0
                     FESTPOSITION_1   41
                     FESTPOSITION_2   42
                     FESTPOSITION_3   43
                     FESTPOSITION_4   44
                     FESTPOSITION_5   45
                     FESTPOSITION_6   46
                     FESTPOSITION_7   47
                     FESTPOSITION_8   48
                     FESTPOSITION_9   49
                     FESTPOSITION_10  50
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SSTRAHLERWAHL

Object: SSTRAHLERWAHL ___ID: 02C0

Description: select tube according to selected system
              will be sent from XCU to generator upon sBedSys/sOrgDaten - iSystemAnz
              (at startup (or reconnect) after generator has sent iFEStatus(ready))
Sender     :   XCU
Receiver   :   GEN-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STRAHLER Number of active tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


SSUCHLAUF

Object: SSUCHLAUF ___ID: 032E

Description: XCU tells the collimator to start the search run; sent from XCU to collimator.
              (collimators may loose steps while normal operation, therefore they do a
              search run after some time to sync. However search runs do not allow X-ray, so
              X-ray will be blocked if the search run is active) sent from collimator to
              XCU. There are two ways of search run processes. A) Collimator is doing it by
              its own and sending aSuchLauf and XCU grants it by sSuchlauf if the system is
              ready for a search run. And collimator indicates end by iSuchlauf (dRF
              solution). OR B) the XCU tells the collimator to do a search run (YSIO)
Sender     :   XCU
Receiver   :   CCU-IF   SM_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro
This object has no parameters


ST_3D_PARAMS

Object: ST_3D_PARAMS ___ID: 1019

Description: select 3D mode and set the appropriate parameters (i.e. select trajectory)
Sender     :   XCU
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TRAJECTORY_NAME name of the trajectory, 32 chars unicode
          Type:  String16 [ 32 ]     (ASCII)
          Range: 64 ... 64
          Dimension: unicode

TRAJCT_START_POSITION Start position of the trajectory. The direction depends on the trajectory itself (e.g. height for upright trajectories)
This parameter is also put into DICOM to match the nearest calibration position.
          Type:  Dword     (DEC)
          Range: 0 ... 200000
          Dimension: 0.1mm

CALIB_MODE mode of the 3D calibration
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE        0   none
                     ACS_GEOCALIB    1   geometric calibration
                     ACS_IZEROCALIB  2   I0-calibration
          Dimension: none

FLUORO_OPTION describes which fluoro points are mandatory and subsequently how much of a testrun is needed
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_FLO_DUAL_REGULAR  0   3D trajectory requires a full collision run
                                               with two fluoros in perpendicular positions
                     ACS_FLO_SIINGLE       1   3D trajectory requires just one fluoro to be
                                               made at start position
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_ACSOS_CMD

Object: ST_ACSOS_CMD ___ID: 101D

Description: telegram to control ACSOS via XCS
Sender     :   ALL
Receiver   :   ACSOS
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TRACE_STATE state of tracer function
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_TRACE_STOP   0
                     ACS_TRACE_START  1
                     ACS_TRACE_PAUSE  2
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

TRACE_NAME name of trace file; if not empty the trace shall be saved to this file.
          Type:  String16 [ 40 ]     (ASCII)
          Range: 80 ... 80
          Dimension: unicode

FILTER_STATE switches on/off filter function of ACSOS
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_FILTER_DEACTIVE  0
                     ACS_FILTER_ACTIVE    1
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FILTER_NAME name of filter file; if not empty ACSOS shall load the filter from this file
          Type:  String16 [ 40 ]     (ASCII)
          Range: 80 ... 80
          Dimension: unicode

MACRO_STATE
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_MACRO_DEACTIVE  0
                     ACS_MACRO_ACTIVE    1
                     ACS_MACRO_PAUSED    2
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MACRO_NAME name of macro file; if not empty the ACSOS shall load the macro(s) from this file
          Type:  String16 [ 40 ]     (ASCII)
          Range: 80 ... 80
          Dimension: unicode

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_ACTUATOR

Object: ST_ACTUATOR ___ID: 1032

Description: This allows the automated test (SITA) to simulate actuation of button or other
              UI Elements.
Sender     :   TEST-SW
Receiver   :   SCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_ACTUATORS number of actuator blocks
          Type:  Count     (CNT)
          Range: 1 ... 170
          Dimension: count of elements

{IO_MODULE_ID Group or location of the actuator
{          Type:  Word     (DEC)
{          Range: 0 ... 50
{                       TABLE_CONTROL_MODULE  43   type="IOTypeDS401" mappedto="8"
{          Dimension: none

{IO_SIGNAL_ID identifies the actuator to be triggered
{          Type:  Word     (DEC)
{          Range: 0 ... 100
{                       DET_PARKPOS_IN   0   msgid="0x1ab" startbit="0" ui="button
{                       DET_PARKPOS_OUT  1   msgid="0x1ab" startbit="1" ui="button
{          Dimension: none

{IO_SIGNAL_VALUE Parameter for the actuator. Depending on the type of the signal (io_signal_id) this may be a bool or a signed or an unsigned integer.
{          Type:  Dword     (DEC)
{          Range: 0 ... 4294967294
{          Dimension: none


ST_ADJUST

Object: ST_ADJUST ___ID: 1803

Description: set new adjustment
Sender     :   PMS
Receiver   :   ALL
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

ADJ_ACTION action for adjust
          Type:  Enum8     (DEC)
          Range: 1 ... 12
                     ACS_ADJ_START        1
                     ACS_ADJ_ABORT        2
                     ACS_ADJ_STOP         3
                     ACS_ADJ_SUPPLY_DATA  4    RFU: send AAF
                     ACS_ADJ_STORE_DATA   5
                     ACS_ADJ_ABORT_DATA   6
                     ACS_ADJ_INPUT        7    value in adj_input required
                     ACS_ADJ_SET_DATA     8
                     ACS_ADJ_RESET_DATA   9
                     ACS_ADJ_GET_DATA     10   send data using SH_ADJUST()
                     ACS_ADJ_MOVE         11   used as alive trigger for SW-controlled
                                               movement
                     ACS_ADJ_STOP_MOVING  12
          Dimension: non

ADJ_ADD_INPUT additional input data for adjustment, defined by PMS
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IDENTIFIER identifier for adjust and diag
          Type:  Integer16     (DEC)
          Range: -1 ... 30000
                     ACS_ADJ_ALL_FILES               -1
                     ACS_ADJUST_ID_TUBE_STRAHLER1    1     initiate tube adjust
                     ACS_ADJUST_ID_TUBE_STRAHLER2    2     initiate tube adjust
                     ACS_ADJUST_ID_MAS_RELAIS        3
                     ACS_ADJUST_ID_INVERTER          4
                     ACS_ADJUST_ID_FLUORO            5
                     ACS_ADJUST_ID_SP_INVERTER       6
                     ACS_ADJUST_ID_F80_IONTO         7     dose iontomat: sensitivity and
                                                           "Vorhalt".
                                                           (replaces GEN_ICO_F80_DOSE
                                                           _IONTOMAT_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_RESP  8     voltage curve
                                                           (replaces GEN_ICO_F80_VOLTAGE
                                                           _RESPONSE_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_COR   9     AEC dose correction.
                                                           (replaces GEN_ICO_F80
                                                           _VOLTAGE_CORRECTION_ADJUST_ID)
                     ACS_ADJUST_ID_F80_DEXI          10    DEXI adjust:
                                                           -> generator set to adjust in 1/4
                                                           EP steps (rather than 1/2 EP)
                                                           -> ImgSys switches to DEXI adjust
                     ACS_ADJUST_ID_II_DOSE_IRIS      11    mA reference value (determined
                                                           during "Dose TV Iris" adjustment)
                     ACS_ADJUST_ID_II_IRIS_BRIGHT    12    correction value for Iris (in BP)
                                                            (determined during "Dose TV
                                                           Iris" adjustment)
                     ACS_ADJUST_ID_II_ZOOM_IRIS      13    correction value for iris in zoom
                                                           mode (in BP)  (determined during
                                                           "Zoom Iris Correction"
                                                           adjustment)
                     ACS_ADJUST_ID_II_TV_PARAM       14    value for iris in video mode (in
                                                           EP) (determined during "TV
                                                           Parameters" adjustment)
                     ACS_ADJUST_ID_GEN_WARMUP        15    used to start automatic warm up
                                                           procedure on generator
                     ACS_ADJUST_ID_COLL_ADAPT        16    adjustment needed for collimator
                                                           adaption
                     ACS_ADJUST_ID_COOLPUMP          17    manually switch cooling pump on
                                                           or off for service
                     ACS_ADJUST_ID_II_IRIS_RANGE     18    maximum attenuation of the iris
                                                           (w/o gray filter)
                     ACS_ADJUST_ID_GRAY_FLT_STRT_PT  19    maximum opening of the iris with
                                                           gray filter
                                                           (in case the gray filter does not
                                                           cover the full opening of the
                                                           iris)
                     ACS_ADJUST_ID_FD_ATTACH         20    start attachment procedure of
                                                           detector and docking station
                     ACS_ADJUST_ID_FD_BATTCAL        21    start battery calibration of
                                                           portable FD detector
                     ACS_ADJUST_ID_FD_WLAN           22    set WLAN settings
                     ACS_ADJUST_ID_COLL_ACCURACY     23    adjust collimator accuracy
                                                           (needed in Rad3)
                     ACS_ADJUST_ID_TUBE_CONDITION    24    tube conditioning (used with
                                                           unified generator)
                     ACS_ADJUST_ID_IRISCALIBRATION   25    start iris calibration procedure
                     ACS_ADJUST_ID_AIR_KERMA_RATE    26    start air kerma rate adjustment
                     ACS_ADJUST_ID_RCP_ATTACHMENT    27    start TUI/RCP attachment
                     ACS_ADJUST_ID_CARM_ATTACHMENT   28    start C-ARM attachment
                     ACS_ADJUST_ID_DICOM_WLAN        29    adjust DICOM access point
                     ACS_ADJUST_ID_FDCAL_TEMP        30
                     ACS_ADJUST_ID_FDCAL_MULTIGAIN   31
                     ACS_ADJUST_ID_FDCAL_STAT_DELTA  32
                     ACS_ADJUST_ID_FDCAL_DYN_DELTA   33
                     ACS_ADJUST_ID_FDCAL_DEFECT_DET  34
                     ACS_ADJUST_ID_SCU_ROTACQ        40    SCU settings rotational acq
                     ACS_ADJUST_ID_SCU_ROTACQ_POS    41    SCU rotational acq, reachability
                                                           of start position
                     ACS_ADJUST_ID_MCU_ANGULAR_ZERO  50    set C-Arm angular angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_ZERO  51    set C-Arm orbital angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_MAX   52
                     ACS_ADJUST_ID_MCU_ORBITAL_MIN   53
                     ACS_ADJUST_ID_MCU_HF_SIGNALS    54    monitors MCU hand/footswitch
                                                           signals
                     ACS_ADJUST_ID_MCU_HW_SIGNALS    55    monitors MCU hardware signals
                     ACS_ADJUST_ID_MCU_FORMAT_FS     56    format file system on MCU
                     ACS_ADJUST_ID_MCU_RESET_TEMP    57    reset min max temperature
                     ACS_ADJUST_ID_MCU_VRT_TORQUE    58    set high torque for vertical lift
                                                           drive
                     ACS_ADJUST_ID_ETH_CONNECTIONS   59    monitor ethernet connections
                     ACS_ADJUST_ID_MCU_MOVE_SIGNALS  60    monitors MCU movement signals
                     ACS_ADJUST_ID_MCU_EMCY_SIGNALS  61    monitors MCU emergency and power
                                                           supply signals
                     ACS_ADJUST_ID_MCU_RESET_MILAGE  62    reset orbital/angular milage
                                                           information
                     ACS_ADJUST_ID_MCU_WFSW_PAIRING  64    enter pairing mode of the
                                                           wireless receiver
                     ACS_ADJUST_ID_MCU_WFSW_MONITOR  65    monitors status information of
                                                           wireless footswitch
                     ACS_ADJUST_ID_CALIB3D_GEO       70    3D geometric calibration
                     ACS_ADJUST_ID_CALIB3D_IZERO     71    iZero calibration for 3D
                     ACS_ADJUST_ID_CALIBTOPO_IZERO   72    iZero calibration for 2D_TOPO
                                                           (=SKELMAL)
                     ACS_ADJUST_ID_CAM3D_CALIB       75    calibration of 3D camera at tube
                                                           head
                     ACS_ADJUST_ID_RESET_MRAM        80    reset MRAM of XCU or MCU (thus
                                                           restore factory defaults)
                     ACS_ADJUST_ID_SELECT_TUBE1      85
                     ACS_ADJUST_ID_SELECT_TUBE2      86
                     ACS_ADJUST_ID_CTRL_XRAY         87    X-Ray Control
                     ACS_ADJUST_ID_WW                90    water value correction
                     ACS_ADJUST_ID_IEC_TEST          91    Set specific x-ray parameters
                                                           (working points) for IEC tests.
                                                           (used in surgery)
                     ACS_ADJUST_ID_NORMATIVE_TESTS   92    Set specific x-ray parameters
                                                           (working points) for various
                                                           normative tests. (used in
                                                           surgery)
                     ACS_ADJUST_ID_APH_SOLIDFICATN   101   AppHosting: manage solidification
                                                           software
                     ACS_ADJUST_ID_APH_SWITCH_MODE   102   AppHosting: switch to App Mode
                                                           via Service
                     ACS_ADJUST_ID_APH_SWITCH_ENV    103   AppHosting: switch the active
                                                           environment
                     ACS_ADJUST_ID_APH_CREATE_ENV    104   AppHosting: create a new
                                                           environment
                     ACS_ADJUST_ID_APH_EXPORT_DATA   105   AppHosting: export vendor data
                                                           (logfiles)
                     ACS_ADJUST_ID_APH_LICENSES      106   AppHosting: manage application
                                                           licenses
                     ACS_ADJUST_ID_APH_INSTALL_APP   107   AppHosting: install or update
                                                           applications
                     ACS_ADJUST_ID_APH_LANGUAGE      108   AppHosting: change language
                                                           settings
                     ACS_ADJUST_ID_APH_BIOS          109   AppHosting: access BIOS
                     ACS_ADJUST_ID_STAND_CENTERING   157   The number 157 is used in SCU for
                                                           Centering Adjustment
                     ACS_DIAG_ID_IS_VERSION          300
                     ACS_DIAG_ID_IS_HOST_ID          301
                     ACS_DIAG_ID_IS_DONGLE_ID        302
                     ACS_DIAG_ID_IS_FREE_HD          303
                     ACS_DIAG_ID_IS_FREE_MEMORY      304
                     ACS_DIAG_ID_IS_CONFIG_ISSUE     305
                     ACS_DIAG_ID_IS_OS_INFO          306
                     ACS_DIAG_ID_CPU_INFO            307
                     ACS_DIAG_ID_DICOM_ARCH_NODE     308
                     ACS_DIAG_ID_DICOM_MPPS_NODE     309
                     ACS_DIAG_ID_DICOM_MWL_NODE      310
                     ACS_DIAG_ID_DICOM_PRINT_NODE    311
                     ACS_DIAG_ID_FD2430_TYPE         340
                     ACS_DIAG_ID_FD2430_SN           341
                     ACS_DIAG_ID_FD2430_SW           342
                     ACS_DIAG_ID_FD2430_FW           343
                     ACS_DIAG_ID_FD2430_LIFETIME     344
                     ACS_DIAG_ID_FD2430_POWERON      345
                     ACS_DIAG_ID_FD2430_TEMPERATURE  346
                     ACS_DIAG_ID_FD2430_WIFI         347
                     ACS_DIAG_ID_FD2430_SHOCK        348
                     ACS_DIAG_ID_FD3543_TYPE         360
                     ACS_DIAG_ID_FD3543_SN           361
                     ACS_DIAG_ID_FD3543_SW           362
                     ACS_DIAG_ID_FD3543_FW           363
                     ACS_DIAG_ID_FD3543_LIFETIME     364
                     ACS_DIAG_ID_FD3543_POWERON      365
                     ACS_DIAG_ID_FD3543_TEMPERATURE  366
                     ACS_DIAG_ID_FD3543_WIFI         367
                     ACS_DIAG_ID_FD3543_SHOCK        368
                     ACS_DIAG_ID_FD4343_TYPE         380
                     ACS_DIAG_ID_FD4343_SN           381
                     ACS_DIAG_ID_FD4343_SW           382
                     ACS_DIAG_ID_FD4343_FW           383
                     ACS_DIAG_ID_FD4343_LIFETIME     384
                     ACS_DIAG_ID_FD4343_POWERON      385
                     ACS_DIAG_ID_FD4343_TEMPERATURE  386
                     ACS_DIAG_ID_FD4343_WIFI         387
                     ACS_DIAG_ID_FD4343_SHOCK        388
          Dimension: none

ADJ_INPUT input for adjust
          Type:  Integer32     (DEC)
          Range: -2147483647 ... 2147483647
          Dimension: none

ADJ_INPUT2 additional input for adjust
          Type:  Integer32     (DEC)
          Range: -2147483647 ... 2147483647
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_ADJ_PARAM number of parameter blocks for ST_ADJUST
          Type:  Dcount     (CNT)
          Range: 0 ... 179
          Dimension: none

{ADJ_PARAM1 parameter 1 for adjustment, mainly as an identifier
{          Type:  Integer32     (DEC)
{          Range: -2147483647 ... 2147483647
{          Dimension: none

{ADJ_PARAM2 parameter for adjustment, mainly as data related to ADJ_PARAM1
{          Type:  Integer32     (DEC)
{          Range: -2147483647 ... 2147483647
{          Dimension: none


ST_ADJUST_WLAN

Object: ST_ADJUST_WLAN ___ID: 0436

Description: set WLAN settings for portable Rad Detector
Sender     :   PMS
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

ADJ_ACTION action for adjust
          Type:  Enum8     (DEC)
          Range: 1 ... 12
                     ACS_ADJ_START        1
                     ACS_ADJ_ABORT        2
                     ACS_ADJ_STOP         3
                     ACS_ADJ_SUPPLY_DATA  4    RFU: send AAF
                     ACS_ADJ_STORE_DATA   5
                     ACS_ADJ_ABORT_DATA   6
                     ACS_ADJ_INPUT        7    value in adj_input required
                     ACS_ADJ_SET_DATA     8
                     ACS_ADJ_RESET_DATA   9
                     ACS_ADJ_GET_DATA     10   send data using SH_ADJUST()
                     ACS_ADJ_MOVE         11   used as alive trigger for SW-controlled
                                               movement
                     ACS_ADJ_STOP_MOVING  12
          Dimension: non

DETECTOR_PLANE identifier for the detector being addressed
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_NO_INFORMATION     0
                     ACS_FD_TABLE           1    detector mounted in the table
                     ACS_FD_WALL            2    FD mounted in the wall stand
                     ACS_FD_PORTABLE        3    free portable detector
                     ACS_FD_WALLCHARGER     4    portable detector in wall charger
                     ACS_FD_STAND           7    detector mounted in the dTF stand
                     ACS_FD_C_ARM           8    detector on c-arm in surgery
                     ACS_FD_FLEXIBLE        9    detector of Multitom Rax system
                     ACS_FD_SMALL_PORTABLE  10   small portable detector
          Dimension: none

IDENTIFIER identifier for adjust and diag
          Type:  Integer16     (DEC)
          Range: -1 ... 30000
                     ACS_ADJ_ALL_FILES               -1
                     ACS_ADJUST_ID_TUBE_STRAHLER1    1     initiate tube adjust
                     ACS_ADJUST_ID_TUBE_STRAHLER2    2     initiate tube adjust
                     ACS_ADJUST_ID_MAS_RELAIS        3
                     ACS_ADJUST_ID_INVERTER          4
                     ACS_ADJUST_ID_FLUORO            5
                     ACS_ADJUST_ID_SP_INVERTER       6
                     ACS_ADJUST_ID_F80_IONTO         7     dose iontomat: sensitivity and
                                                           "Vorhalt".
                                                           (replaces GEN_ICO_F80_DOSE
                                                           _IONTOMAT_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_RESP  8     voltage curve
                                                           (replaces GEN_ICO_F80_VOLTAGE
                                                           _RESPONSE_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_COR   9     AEC dose correction.
                                                           (replaces GEN_ICO_F80
                                                           _VOLTAGE_CORRECTION_ADJUST_ID)
                     ACS_ADJUST_ID_F80_DEXI          10    DEXI adjust:
                                                           -> generator set to adjust in 1/4
                                                           EP steps (rather than 1/2 EP)
                                                           -> ImgSys switches to DEXI adjust
                     ACS_ADJUST_ID_II_DOSE_IRIS      11    mA reference value (determined
                                                           during "Dose TV Iris" adjustment)
                     ACS_ADJUST_ID_II_IRIS_BRIGHT    12    correction value for Iris (in BP)
                                                            (determined during "Dose TV
                                                           Iris" adjustment)
                     ACS_ADJUST_ID_II_ZOOM_IRIS      13    correction value for iris in zoom
                                                           mode (in BP)  (determined during
                                                           "Zoom Iris Correction"
                                                           adjustment)
                     ACS_ADJUST_ID_II_TV_PARAM       14    value for iris in video mode (in
                                                           EP) (determined during "TV
                                                           Parameters" adjustment)
                     ACS_ADJUST_ID_GEN_WARMUP        15    used to start automatic warm up
                                                           procedure on generator
                     ACS_ADJUST_ID_COLL_ADAPT        16    adjustment needed for collimator
                                                           adaption
                     ACS_ADJUST_ID_COOLPUMP          17    manually switch cooling pump on
                                                           or off for service
                     ACS_ADJUST_ID_II_IRIS_RANGE     18    maximum attenuation of the iris
                                                           (w/o gray filter)
                     ACS_ADJUST_ID_GRAY_FLT_STRT_PT  19    maximum opening of the iris with
                                                           gray filter
                                                           (in case the gray filter does not
                                                           cover the full opening of the
                                                           iris)
                     ACS_ADJUST_ID_FD_ATTACH         20    start attachment procedure of
                                                           detector and docking station
                     ACS_ADJUST_ID_FD_BATTCAL        21    start battery calibration of
                                                           portable FD detector
                     ACS_ADJUST_ID_FD_WLAN           22    set WLAN settings
                     ACS_ADJUST_ID_COLL_ACCURACY     23    adjust collimator accuracy
                                                           (needed in Rad3)
                     ACS_ADJUST_ID_TUBE_CONDITION    24    tube conditioning (used with
                                                           unified generator)
                     ACS_ADJUST_ID_IRISCALIBRATION   25    start iris calibration procedure
                     ACS_ADJUST_ID_AIR_KERMA_RATE    26    start air kerma rate adjustment
                     ACS_ADJUST_ID_RCP_ATTACHMENT    27    start TUI/RCP attachment
                     ACS_ADJUST_ID_CARM_ATTACHMENT   28    start C-ARM attachment
                     ACS_ADJUST_ID_DICOM_WLAN        29    adjust DICOM access point
                     ACS_ADJUST_ID_FDCAL_TEMP        30
                     ACS_ADJUST_ID_FDCAL_MULTIGAIN   31
                     ACS_ADJUST_ID_FDCAL_STAT_DELTA  32
                     ACS_ADJUST_ID_FDCAL_DYN_DELTA   33
                     ACS_ADJUST_ID_FDCAL_DEFECT_DET  34
                     ACS_ADJUST_ID_SCU_ROTACQ        40    SCU settings rotational acq
                     ACS_ADJUST_ID_SCU_ROTACQ_POS    41    SCU rotational acq, reachability
                                                           of start position
                     ACS_ADJUST_ID_MCU_ANGULAR_ZERO  50    set C-Arm angular angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_ZERO  51    set C-Arm orbital angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_MAX   52
                     ACS_ADJUST_ID_MCU_ORBITAL_MIN   53
                     ACS_ADJUST_ID_MCU_HF_SIGNALS    54    monitors MCU hand/footswitch
                                                           signals
                     ACS_ADJUST_ID_MCU_HW_SIGNALS    55    monitors MCU hardware signals
                     ACS_ADJUST_ID_MCU_FORMAT_FS     56    format file system on MCU
                     ACS_ADJUST_ID_MCU_RESET_TEMP    57    reset min max temperature
                     ACS_ADJUST_ID_MCU_VRT_TORQUE    58    set high torque for vertical lift
                                                           drive
                     ACS_ADJUST_ID_ETH_CONNECTIONS   59    monitor ethernet connections
                     ACS_ADJUST_ID_MCU_MOVE_SIGNALS  60    monitors MCU movement signals
                     ACS_ADJUST_ID_MCU_EMCY_SIGNALS  61    monitors MCU emergency and power
                                                           supply signals
                     ACS_ADJUST_ID_MCU_RESET_MILAGE  62    reset orbital/angular milage
                                                           information
                     ACS_ADJUST_ID_MCU_WFSW_PAIRING  64    enter pairing mode of the
                                                           wireless receiver
                     ACS_ADJUST_ID_MCU_WFSW_MONITOR  65    monitors status information of
                                                           wireless footswitch
                     ACS_ADJUST_ID_CALIB3D_GEO       70    3D geometric calibration
                     ACS_ADJUST_ID_CALIB3D_IZERO     71    iZero calibration for 3D
                     ACS_ADJUST_ID_CALIBTOPO_IZERO   72    iZero calibration for 2D_TOPO
                                                           (=SKELMAL)
                     ACS_ADJUST_ID_CAM3D_CALIB       75    calibration of 3D camera at tube
                                                           head
                     ACS_ADJUST_ID_RESET_MRAM        80    reset MRAM of XCU or MCU (thus
                                                           restore factory defaults)
                     ACS_ADJUST_ID_SELECT_TUBE1      85
                     ACS_ADJUST_ID_SELECT_TUBE2      86
                     ACS_ADJUST_ID_CTRL_XRAY         87    X-Ray Control
                     ACS_ADJUST_ID_WW                90    water value correction
                     ACS_ADJUST_ID_IEC_TEST          91    Set specific x-ray parameters
                                                           (working points) for IEC tests.
                                                           (used in surgery)
                     ACS_ADJUST_ID_NORMATIVE_TESTS   92    Set specific x-ray parameters
                                                           (working points) for various
                                                           normative tests. (used in
                                                           surgery)
                     ACS_ADJUST_ID_APH_SOLIDFICATN   101   AppHosting: manage solidification
                                                           software
                     ACS_ADJUST_ID_APH_SWITCH_MODE   102   AppHosting: switch to App Mode
                                                           via Service
                     ACS_ADJUST_ID_APH_SWITCH_ENV    103   AppHosting: switch the active
                                                           environment
                     ACS_ADJUST_ID_APH_CREATE_ENV    104   AppHosting: create a new
                                                           environment
                     ACS_ADJUST_ID_APH_EXPORT_DATA   105   AppHosting: export vendor data
                                                           (logfiles)
                     ACS_ADJUST_ID_APH_LICENSES      106   AppHosting: manage application
                                                           licenses
                     ACS_ADJUST_ID_APH_INSTALL_APP   107   AppHosting: install or update
                                                           applications
                     ACS_ADJUST_ID_APH_LANGUAGE      108   AppHosting: change language
                                                           settings
                     ACS_ADJUST_ID_APH_BIOS          109   AppHosting: access BIOS
                     ACS_ADJUST_ID_STAND_CENTERING   157   The number 157 is used in SCU for
                                                           Centering Adjustment
                     ACS_DIAG_ID_IS_VERSION          300
                     ACS_DIAG_ID_IS_HOST_ID          301
                     ACS_DIAG_ID_IS_DONGLE_ID        302
                     ACS_DIAG_ID_IS_FREE_HD          303
                     ACS_DIAG_ID_IS_FREE_MEMORY      304
                     ACS_DIAG_ID_IS_CONFIG_ISSUE     305
                     ACS_DIAG_ID_IS_OS_INFO          306
                     ACS_DIAG_ID_CPU_INFO            307
                     ACS_DIAG_ID_DICOM_ARCH_NODE     308
                     ACS_DIAG_ID_DICOM_MPPS_NODE     309
                     ACS_DIAG_ID_DICOM_MWL_NODE      310
                     ACS_DIAG_ID_DICOM_PRINT_NODE    311
                     ACS_DIAG_ID_FD2430_TYPE         340
                     ACS_DIAG_ID_FD2430_SN           341
                     ACS_DIAG_ID_FD2430_SW           342
                     ACS_DIAG_ID_FD2430_FW           343
                     ACS_DIAG_ID_FD2430_LIFETIME     344
                     ACS_DIAG_ID_FD2430_POWERON      345
                     ACS_DIAG_ID_FD2430_TEMPERATURE  346
                     ACS_DIAG_ID_FD2430_WIFI         347
                     ACS_DIAG_ID_FD2430_SHOCK        348
                     ACS_DIAG_ID_FD3543_TYPE         360
                     ACS_DIAG_ID_FD3543_SN           361
                     ACS_DIAG_ID_FD3543_SW           362
                     ACS_DIAG_ID_FD3543_FW           363
                     ACS_DIAG_ID_FD3543_LIFETIME     364
                     ACS_DIAG_ID_FD3543_POWERON      365
                     ACS_DIAG_ID_FD3543_TEMPERATURE  366
                     ACS_DIAG_ID_FD3543_WIFI         367
                     ACS_DIAG_ID_FD3543_SHOCK        368
                     ACS_DIAG_ID_FD4343_TYPE         380
                     ACS_DIAG_ID_FD4343_SN           381
                     ACS_DIAG_ID_FD4343_SW           382
                     ACS_DIAG_ID_FD4343_FW           383
                     ACS_DIAG_ID_FD4343_LIFETIME     384
                     ACS_DIAG_ID_FD4343_POWERON      385
                     ACS_DIAG_ID_FD4343_TEMPERATURE  386
                     ACS_DIAG_ID_FD4343_WIFI         387
                     ACS_DIAG_ID_FD4343_SHOCK        388
          Dimension: none

WLAN_MODE defines the operating mode - enum defined in FDR.dll interface (WiFi_disabled, WiFi_enabled, or WiFi_automatic)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

WLAN_STD defines the WLAN standard to be used (WLAN_Std_80211a or WLAN_Std_80211g)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

WLAN_BAND selects the band to be used
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_WLAN_BAND_24    1   select 2.4GHz band
                     ACS_WLAN_BAND_50    2   select 5GHz band
          Dimension: none

WLAN_BANDWIDTH
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_WLAN_BW_20      1   bandwidth of 20MHz
                     ACS_WLAN_BW_40      2   bandwidth of 40MHz
          Dimension: none

WLAN_CHANNEL force channel for WIFI Transmission
          Type:  Integer32     (DEC)
          Range: 0 ... 255
          Dimension: none

WLAN_FE_POWER power on FE channel
          Type:  Integer16     (DEC)
          Range: 0 ... 255
          Dimension: mW

WLAN_DS_POWER power on DS channel
          Type:  Integer16     (DEC)
          Range: 0 ... 255
          Dimension: mW

WLAN_COUNTRYCODE country code according to ISO3166 (2 characters plus 0 termination)
          Type:  String8 [ 3 ]     (ASCII)
          Range: 3 ... 3
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_COLPAR_A

Object: ST_COLPAR_A ___ID: 1211

Description: set collimator plane A
Sender     :   CCU-IF
Receiver   :   CCU_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

COL_LIMITATION RFU only:
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_COL_LIMITED     1   collimation is limited to the format of the
                                             target (ACSS)
                     ACS_COL_MANU        2   manual collimation without any beam limitation
                                             (as ACS_NO)
          Dimension: none

COL_TRACKING RFU only:
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_COL_TRACK       1   tracking of collimator blades to keep current
                                             collimation on target stable, following the SID
                                             (as ACS_YES)
                     ACS_COL_NO_TRACK    2   no movement of collimator blades when SID is
                                             changing (as ACS_NO)
                                             in RFU: tracking still enabled but DSA
                                             collimator does no longer follow
                     ACS_COL_TRACK_NONE  3   no moving of colliator blades when SID or
                                             centering is changing (used during 3D run)
          Dimension: none

NEXT_POS last position in case of review values, next position while moving, else position reached
          Type:  Integer8     (DEC)
          Range: -11 ... 11
          Dimension: Position No

VERSION_STCOLPAR version of the object ST_STCOLPAR_A/B
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_STCOLPAR  2   version 0 from the beginning
                                         version 1 since VD00D: extension for asym.
                                         Collimation in RFU only
                                         version 2 since VE21C/VE13P: removed unused
                                         extension; keep new parameter LIGHT_LOC
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BL_WIDTH beam limitation width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_HEIGHT beam limitation height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_DIAM beam limitation diameter
          Type:  Integer16     (DEC)
          Range: 0 ... 32000
          Dimension: 0.1 mm

RE_WIDTH rectangular shutter width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

RE_HEIGHT rectangular shutter height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

IR_DIAM diameter iris
          Type:  Integer16     (DEC)
          Range: 0 ... 7200
          Dimension: 0.1 mm

FI_ANG finger turn angle
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

FI_POS finger position
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

FI_SIZE size of the semitransparent finger filter
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: 0.1 mm

AT_ANG1 semitransparent attenuator turn angle 1
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS1 semitransparent attenuator position 1
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE1 size of semitransparent attenuator 1
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

AT_ANG2 semitransparent attenuator turn angle 2
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS2 semitransparent attenuator position 2
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE2 size of semitransparent attenuator 2
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

COL_SHUTTER kind of collimation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY   0   do not display the icons of semitr.
                     ACS_DISP_SQUARE  1   display the icon of square
                     ACS_DISP_IRIS    2   display the icon of iris
          Dimension: none

COL_SEMITRANS kind of semitransparent filters
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY       0   do not display the icons of semitr.
                     ACS_DISP_FINGER      1   display the icon of finger filter
                     ACS_DISP_ATTENUATOR  2   display the icon of attenuator
          Dimension: none

LIGHT_LOC RFU only: light localizer
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
                     ACS_TOGGLE          3   toggle
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_COLPAR_B

Object: ST_COLPAR_B ___ID: 1212

Description: set collimator plane B
Sender     :   CCU-IF2
Receiver   :   CCU_B
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

COL_LIMITATION RFU only:
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_COL_LIMITED     1   collimation is limited to the format of the
                                             target (ACSS)
                     ACS_COL_MANU        2   manual collimation without any beam limitation
                                             (as ACS_NO)
          Dimension: none

COL_TRACKING RFU only:
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_COL_TRACK       1   tracking of collimator blades to keep current
                                             collimation on target stable, following the SID
                                             (as ACS_YES)
                     ACS_COL_NO_TRACK    2   no movement of collimator blades when SID is
                                             changing (as ACS_NO)
                                             in RFU: tracking still enabled but DSA
                                             collimator does no longer follow
                     ACS_COL_TRACK_NONE  3   no moving of colliator blades when SID or
                                             centering is changing (used during 3D run)
          Dimension: none

NEXT_POS last position in case of review values, next position while moving, else position reached
          Type:  Integer8     (DEC)
          Range: -11 ... 11
          Dimension: Position No

VERSION_STCOLPAR version of the object ST_STCOLPAR_A/B
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_STCOLPAR  2   version 0 from the beginning
                                         version 1 since VD00D: extension for asym.
                                         Collimation in RFU only
                                         version 2 since VE21C/VE13P: removed unused
                                         extension; keep new parameter LIGHT_LOC
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BL_WIDTH beam limitation width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_HEIGHT beam limitation height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

BL_DIAM beam limitation diameter
          Type:  Integer16     (DEC)
          Range: 0 ... 32000
          Dimension: 0.1 mm

RE_WIDTH rectangular shutter width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

RE_HEIGHT rectangular shutter height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

IR_DIAM diameter iris
          Type:  Integer16     (DEC)
          Range: 0 ... 7200
          Dimension: 0.1 mm

FI_ANG finger turn angle
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

FI_POS finger position
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

FI_SIZE size of the semitransparent finger filter
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: 0.1 mm

AT_ANG1 semitransparent attenuator turn angle 1
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS1 semitransparent attenuator position 1
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE1 size of semitransparent attenuator 1
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

AT_ANG2 semitransparent attenuator turn angle 2
          Type:  Integer16     (DEC)
          Range: -1799 ... 1800
          Dimension: 0.1 degree

AT_POS2 semitransparent attenuator position 2
          Type:  Integer16     (DEC)
          Range: -5000 ... 5000
          Dimension: 0.1 mm

AT_SIZE2 size of semitransparent attenuator 2
          Type:  Integer16     (DEC)
          Range: 0 ... 8000
          Dimension: 0.1 mm

COL_SHUTTER kind of collimation
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY   0   do not display the icons of semitr.
                     ACS_DISP_SQUARE  1   display the icon of square
                     ACS_DISP_IRIS    2   display the icon of iris
          Dimension: none

COL_SEMITRANS kind of semitransparent filters
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_DISPLAY       0   do not display the icons of semitr.
                     ACS_DISP_FINGER      1   display the icon of finger filter
                     ACS_DISP_ATTENUATOR  2   display the icon of attenuator
          Dimension: none

LIGHT_LOC RFU only: light localizer
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
                     ACS_TOGGLE          3   toggle
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_COLPAR_OGP_A

Object: ST_COLPAR_OGP_A ___ID: 1217

Description: collimation data from organ program which is needed by SCU. If collimation
              data of OGP contains NO_INFORMATION, then the current collimation is sent
Sender     :   SCU-IF
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

VERSION_STCOLPAROGP version of the object ST_COLPAR_OGP_A
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_STCOLPAROGP  0   version from the beginning
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

RE_WIDTH rectangular shutter width
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

RE_HEIGHT rectangular shutter height
          Type:  Integer16     (DEC)
          Range: 0 ... 23000
          Dimension: 0.1 mm

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_CONFIG

Object: ST_CONFIG ___ID: 1801

Description: set new configuration
Sender     :   PMS
Receiver   :   ALL
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

CFG_ACTION action for ST_CONFIG
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_CFG_SUPPLY_DATA  1   copy to the host
                     ACS_CFG_STORE_DATA   2   copy from the host
                     ACS_CFG_ABORT_DATA   3   abort
                     ACS_CFG_COMPARE      4   compare config data
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_CP_DATA

Object: ST_CP_DATA ___ID: 02AE

Description: used to communicate Clinical Protocol data from CP database into system
Sender     :   PMS   UIS
Receiver   :   PMS   XCU
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

EXP_TARGET exposure target (called "acquisition type" in UIS)
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     EXPT_TABLE         0
                     EXPT_BWS           1   bucky wall stand
                     EXPT_FREE          2   free exposure to portable detector (or cassette)
                     EXPT_TABLE_PULLED  3   exposure to detector in pulled-out table tray
                     EXPT_FREE_SMALL    4   free exposure to small portable detector
                                            (used in ST_ORGAN_PROG only)
          Dimension: none

RELATIVE_CP_POS_USAGE defines if the parameters for relative CP position are to be used or not (i.e. POSITION_CP, SID, OBLIQUE_BEAM_ANGLE)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_USE_ABS_POS  0   use normal absolute parameters
                     ACS_USE_REL_POS  1   use the relative CP positions
          Dimension: none

STRAHLER Number of active tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
          Dimension: none

PARTIAL_CP this parameter shows if ST_CP_DATA is a full CP selection, or just used to check/validate the generator parameters
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_CP_NORMAL        0   normal full CP selection
                     ACS_CP_PARTIAL       1   partial CP only, which means that XCU shall
                                              not forward anything to SCU (used in ortho for
                                              the sub-step parameters)
                     ACS_CP_REPEAT_ORTHO  2   repeat the (aborted) ortho acquisition (used
                                              in RAD3)
          Dimension: none

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

OPERATION_MODE former BETRIEBSART
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     OPM_NORMAL    0   normal RAD or DFR acquisition
                     OPM_ORTHO     1   (stitched) multi-image acquisition
                     OPM_RUN3D     2   3D run (Mrax)
                     OPM_TOMO      3
                     OPM_DRSCAN    4   DR scanning
                     OPM_CASSETTE  5   film cassette (or foreign detector)
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

KVDR kV for dose reduction. If the patient thickness is too high for tube power, kV will automatically increase, because X-ray will retrieve more energy out of kV than out of mAs. To increase kV means to reduce heat power consumption. If the kV will be increased, the contrast will get worse. This kV for dose reduction determines, when kV rising will stop for a while and the dose it reduced to 50%. Decreasing the dose will make the image noisier. However at a certain point of kV it is better to get more noise than to loose more contrast
In an OGP for Mode3D this parameter is used for MaxKV (in 0-pnt technique).
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

SCHWAERZKORR Blackening correction. This value is applied to the dose in order to have more dose steps than it is possible with HUD.
          Type:  Integer16     (DEC)
          Range: -32 ... 32
          Dimension: 0.25 BP

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

KENNL Number of the exposure curve that determines the kV from the thickness of the object to be X-rayed
In sOrgDaten this parameter will be used if parameter KV is set to 0
          Type:  Byte     (DEC)
          Range: 0 ... 100
          Dimension: Nr

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

PROZ The parameter will reduce the max electrical power (which is given by max power value for the selected focus) to the given percentage in order to enlarge the lifespan of the tube.
Thus for a given kV it allows to reduce the current in order to artificially prolong the pulse time (which replaces the former "reduced current" techniques 8 and 20)
          Type:  Byte     (DEC)
          Range: 10 ... 100
          Dimension: %

REGSTOP stop dose regulation in generator and keep kV and mAs values for all subsequent pulses
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     NEIN  0   no
                     JA    1   yes
          Dimension: none

FILTERAUFN Cu filter used for acq. This is a bit oriented value. Bit0 is "Filter auto", Bit1 is "use filter out of OGP", Bits 4 to 5 tell the filter number. E.g.: 2 = Filter 0, 34d = 22h = Filter 2, 51d = 33h = Filter 3 and Auto is on, 32d = 20h = leave filter as it is, because Bit 1 is 0.
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

GRID_REQUESTED shows if a grid is requested in the CP step
In a RAD3 system using DROC a dedicated Grid can be requested
          Type:  Enum8     (DEC)
          Range: 0 ... 16
                     ACS_NO_GRID_REQUESTED  0
                     ACS_GRID_REQUESTED     1
                     ACS_GRID1_REQUESTED    11
                     ACS_GRID2_REQUESTED    12
                     ACS_GRID3_REQUESTED    13
                     ACS_GRID4_REQESTED     14
                     ACS_GRID5_REQUESTED    15
                     ACS_GRID6_REQUESTED    16
          Dimension: none

ORTHO_RANGE_DEF_METHOD Indicates which method is used to define the ortho range
Needed by XCU (message selection) as well as SCU (initial heigt for table ortho)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_ORTHO_RANGE_TUBE_ANGLE  0   conventional method using tube tilting
                     ACS_ORTHO_RANGE_CAMERA      1   advanced method using a graphic element
                                                     on the camera image
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

CP_CATEGORY
          Type:  Enum8     (DEC)
          Range: 0 ... 6
                     CP_NORMAL       0   CP for clinical use
                     CP_FD_CALIB     1   CP for FD calibration
                     CP_IQAP         2   CP for Image Quality Check
                     CP_ADJUSTMENT   3   CP for adjustments
                     CP_MAINTENANCE  4   CP for Maintenance
                     CP_QC           5   CP for Quality Control
          Dimension: none

COLL_HEIGHT Height of collimation
          Type:  Integer16     (DEC)
          Range: 0 ... 6000
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

COLL_WIDTH Width of collimation
          Type:  Integer16     (DEC)
          Range: 0 ... 6000
                     NO_OVERRIDE  0
          Dimension: 0.1 mm

AUTO_ZOOM Auto Zoom will make the zoom follow the collimation given in this telegram. In case of Auto Zoom the system will set the Zoom that way that the zoom size in mm is as close to the max of collimator width and height but still larger or equal than this width and height.
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
          Dimension: none

PAT_BMI patient body mass index (values 1-3 have special meaning)
          Type:  Byte     (DEC)
          Range: 0 ... 50
                     PAT_THN_M   0   medium size patient
                     PAT_THN_S   1   thin patient
                     PAT_THN_L   2   thick patient
                     PAT_THN_XL  3   very thick patient
          Dimension: BMI

POSITION_CP relative position (from clinical protocol - measured from patient feet)
          Type:  Integer16     (DEC)
          Range: -1000 ... 10000
          Dimension: mm

SID source object distance
          Type:  Integer16     (DEC)
          Range: 500 ... 5000
          Dimension: mm

OBLIQUE_BEAM_ANGLE angle of the central x-ray beam due to pivoting of column at dRF
          Type:  Integer16     (DEC)
          Range: -9000 ... 9000
          Dimension: 0.01 degree

ALIGNMENT_MODE Determines, whether tube center is aligned to detector (or cassette) center, or whether top of collimator field of view is aligned to top of detector (or cassette)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_ALIGNMENT_CENTERED  0   centered
                     ACS_ALIGNMENT_TOP       1   top
          Dimension: none

TRACKING Tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 15
                     ACS_TRACK_NOT_ACTIVE         0    tracking not active
                     ACS_TRACK_SYMMETRICAL        1    symmetrical
                     ACS_TRACK_TOP_ALIGN          2    asymmetrical top alignment
                     ACS_TRACK_BOTTOM_ALIGN       3    asymmetrical bottom alignment
                     ACS_TRACK_LEFT_ALIGN         4    asymmetrical left alignment
                     ACS_TRACK_RIGHT_ALIGN        5    asymmetrical right alignment
                     ACS_TRACK_LOST_SYMMETRICAL   11   tracking lost, symmetrical
                     ACS_TRACK_LOST_TOP_ALIGN     12   tracking lost, asymmetrical top
                                                       alignment
                     ACS_TRACK_LOST_BOTTOM_ALIGN  13   tracking lost, asymmetrical bottom
                                                       alignment
                     ACS_TRACK_LOST_LEFT_ALIGN    14   tracking lost, asymmetrical left
                                                       alignment
                     ACS_TRACK_LOST_RIGHT_ALIGN   15   tracking lost, asymmetrical right
                                                       alignment
          Dimension: none

SID_TRACKING SID tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_TRACK_NOT_ACTIVE  0   SID tracking not active
                     ACS_SID_TRACK_ACTIVE      1   SID tracking active
                     ACS_SID_TRACK_LOST        2   SID tracking lost
          Dimension: none

ORTHO_DIR direction of ortho acquisition
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_HEAD_TO_FEET  0   direction of acquisition (ortho)
                     ACS_FEET_TO_HEAD  1   direction of acquisition (ortho)
                     ACS_TRANSVERSAL   2   for ortho panorama
          Dimension: none

FRATE frame rate (in ST_CP_DATA the highset freq that the user can select during the running series)
          Type:  Integer16     (DEC)
          Range: 0 ... 600
          Dimension: 0.1fps

GEWMESSF logical number of chosen measuring field
bits 0-2 define the field selection
bits 3-4 define a rotation (for 5-field chamber)
bit 7 defines histogram based dexi calculation
          Type:  Byte     (DEC)
          Range: 0 ... 128
                     KEINE_ANGABE_RUND        0     circular measuring field
                     LINKS                    1     left
                     MITTE                    2     center
                     LINKS_MITTE              3     left and center
                     RECHTS                   4     right
                     LINKS_RECHTS             5     left and right
                     MITTE_RECHTS             6     center and right
                     LINKS_MITTE_RECHTS       7     left, center, and right
                     ACS_AEC_ROT_90DEG        8     for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees in clockwise direction
                     ACS_AEC_ROT_180DEG       16    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    plus 180 degrees
                     ACS_AEC_ROT_MINUS_90DEG  24    for 5-chamber AEC:
                                                    selection (bits 0-2) shall be rotated by
                                                    90 degrees counterclockwise (or 270
                                                    degrees clockwise)
                     ACS_AEC_HISTO            128   take histogram based DEXI value instead
                                                    of fixed measuring field
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

XRPT_FLRAD Detector time XRPT (for acquisition)
          Type:  Word     (DEC)
          Range: 0 ... 3200
          Dimension: ms


ST_DATA_2

Object: ST_DATA_2 ___ID: 2892

Description: general object to transfer data for private use without special meaning. It
              should be sent only directly addressed. It is a 'dummy objects'. It can be
              used for tests etc.
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_DATA number of data in the following array
          Type:  Dcount     (CNT)
          Range: 0 ... 1448
          Dimension: count of elements

{DATA_ASCII general data, used as an ASCII string
{          Type:  String8     (ASCII)
{          Range: 1 ... 1
{          Dimension: ASCII


ST_DATA_3

Object: ST_DATA_3 ___ID: 2893

Description: general object to transfer data for private use without special meaning. It
              should be sent only directly addressed. It is a 'dummy objects'. It can be
              used for tests etc.
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_DATA_UNICODE number of characters in the following array
          Type:  Dcount     (CNT)
          Range: 0 ... 720
          Dimension: count of elements

{DATA_UNICODE general data (unicode)
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


ST_DATA_CHUNK

Object: ST_DATA_CHUNK ___ID: 2894

Description: Made to transfer a large amount of data via AXCS in several chunks
Sender     :   SCU
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

CURRENT_CHUNK_NUMBER number of this chunk (must be within 1 and TOTAL_NUM_OF_CHUNKS)
          Type:  Word     (DEC)
          Range: 1 ... 60000
          Dimension: none

TOTAL_NUM_OF_CHUNKS number of chunks (= telegrams) in this transfer
          Type:  Word     (DEC)
          Range: 1 ... 60000
          Dimension: none

BYTE_OFFSET offset in bytes of this data chunk
          Type:  Dword     (DEC)
          Range: 0 ... 86159999
          Dimension: none

TOTAL_NUM_OF_BYTES total number of bytes in this transfer
          Type:  Dword     (DEC)
          Range: 1 ... 86160000
          Dimension: none

TRANSFER_ID ID of this transfer. The ID will be the same in all telegrams that belong to this transfer.
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: none

NO_BYTES number of bytes in the byte array that follows
          Type:  Dcount     (CNT)
          Range: 1 ... 1436
          Dimension: number of bytes

{DATA_BYTES Data Bytes for VCI2AXCS Interface
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


ST_DATA_TRANS

Object: ST_DATA_TRANS ___ID: 1809

Description: transfer of data in service mode
Sender     :   PMS
Receiver   :   ALL
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DATA_ACTION kind of data transfer
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_DATA_SUPPLY       1   copy to the host
                     ACS_DATA_STORE        2   copy from the host
                     ACS_DATA_TRANS_ABORT  3   abort data transfer
                     ACS_DATA_COMPARE      4   compare files
          Dimension: none

DATA_TRANS_PARAM1 if DATA_IDENT equals ACS_DAT_FDCALIB, then this parameter contains the detector identifier (as defined in parameter DETECTOR)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DATA_IDENT Identifier of data transfer
          Type:  Enum8     (DEC)
          Range: 0 ... 16
                     ACS_NOT_DEFINED           0    not defined
                     ACS_DAT_OGP_EXAM          1    transfer EXAMSETS package
                     ACS_DAT_GENERAL           2    transfer GENERAL package
                     ACS_DAT_GEN_PLUS_CAF      3    transfer GENERAL package plus CAF file
                                                    (only with DATA_SUPPLY)
                     ACS_DAT_UI_FLASH          4    transfer flash file system (ECC and
                                                    DDIS)
                     ACS_DAT_REPORT            5    transfer REPORT package
                     ACS_DAT_FDDATA            6    transfer FDDATA package
                     ACS_DAT_START_POS_LIST    7    transfer list of start positions
                     ACS_DAT_FDCALIB           8    transfer data from RadFluoro Detector
                                                    (Pixelshift, DefectMap,TempMatrix)
                     ACS_DAT_LD_LAYOUTS        9    transfer layouts of large display (WSD)
                     ACS_DAT_LD_SNAPSHOT_CH_1  10   transfer snapshot of LargeDisplay
                                                    (channel 1)
                     ACS_DAT_LC_SNAPSHOT_CH_1  11   transfer snapshot of Lab Cockpit channel
                                                    1
                     ACS_DAT_LC_SNAPSHOT_CH_2  12   transfer snapshot of Lab Cockpit channel
                                                    2
                     ACS_DAT_IC_DIRECT         13   Transfer files of COCA board
                                                    (configuration, calibration results)
                     ACS_DAT_ERROR_LOG         14   transfer error log data
                     ACS_DAT_ERROR_SUPPRESS    15   transfer error suppress list
                     ACS_DAT_FLUORO_AAF        16   transfer of fluoro aaf
          Dimension: none

DATA_TRANS_PARAM2 if DATA_IDENT equals ACS_DAT_FDCALIB or ACS_DAT_IC_DIRECT, then this parameter contains the identifier of the data/file to be sent
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_DIAG

Object: ST_DIAG ___ID: 1805

Description: set diagnostic
Sender     :   PMS
Receiver   :   ALL
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DIAG_ACTION action for diag
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_DIAG_START        1
                     ACS_DIAG_ABORT        2
                     ACS_DIAG_SUPPLY_DATA  3
                     ACS_DIAG_FINISH       4   finish diag test
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IDENTIFIER identifier for adjust and diag
          Type:  Integer16     (DEC)
          Range: -1 ... 30000
                     ACS_ADJ_ALL_FILES               -1
                     ACS_ADJUST_ID_TUBE_STRAHLER1    1     initiate tube adjust
                     ACS_ADJUST_ID_TUBE_STRAHLER2    2     initiate tube adjust
                     ACS_ADJUST_ID_MAS_RELAIS        3
                     ACS_ADJUST_ID_INVERTER          4
                     ACS_ADJUST_ID_FLUORO            5
                     ACS_ADJUST_ID_SP_INVERTER       6
                     ACS_ADJUST_ID_F80_IONTO         7     dose iontomat: sensitivity and
                                                           "Vorhalt".
                                                           (replaces GEN_ICO_F80_DOSE
                                                           _IONTOMAT_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_RESP  8     voltage curve
                                                           (replaces GEN_ICO_F80_VOLTAGE
                                                           _RESPONSE_ADJUST_ID)
                     ACS_ADJUST_ID_F80_VOLTAGE_COR   9     AEC dose correction.
                                                           (replaces GEN_ICO_F80
                                                           _VOLTAGE_CORRECTION_ADJUST_ID)
                     ACS_ADJUST_ID_F80_DEXI          10    DEXI adjust:
                                                           -> generator set to adjust in 1/4
                                                           EP steps (rather than 1/2 EP)
                                                           -> ImgSys switches to DEXI adjust
                     ACS_ADJUST_ID_II_DOSE_IRIS      11    mA reference value (determined
                                                           during "Dose TV Iris" adjustment)
                     ACS_ADJUST_ID_II_IRIS_BRIGHT    12    correction value for Iris (in BP)
                                                            (determined during "Dose TV
                                                           Iris" adjustment)
                     ACS_ADJUST_ID_II_ZOOM_IRIS      13    correction value for iris in zoom
                                                           mode (in BP)  (determined during
                                                           "Zoom Iris Correction"
                                                           adjustment)
                     ACS_ADJUST_ID_II_TV_PARAM       14    value for iris in video mode (in
                                                           EP) (determined during "TV
                                                           Parameters" adjustment)
                     ACS_ADJUST_ID_GEN_WARMUP        15    used to start automatic warm up
                                                           procedure on generator
                     ACS_ADJUST_ID_COLL_ADAPT        16    adjustment needed for collimator
                                                           adaption
                     ACS_ADJUST_ID_COOLPUMP          17    manually switch cooling pump on
                                                           or off for service
                     ACS_ADJUST_ID_II_IRIS_RANGE     18    maximum attenuation of the iris
                                                           (w/o gray filter)
                     ACS_ADJUST_ID_GRAY_FLT_STRT_PT  19    maximum opening of the iris with
                                                           gray filter
                                                           (in case the gray filter does not
                                                           cover the full opening of the
                                                           iris)
                     ACS_ADJUST_ID_FD_ATTACH         20    start attachment procedure of
                                                           detector and docking station
                     ACS_ADJUST_ID_FD_BATTCAL        21    start battery calibration of
                                                           portable FD detector
                     ACS_ADJUST_ID_FD_WLAN           22    set WLAN settings
                     ACS_ADJUST_ID_COLL_ACCURACY     23    adjust collimator accuracy
                                                           (needed in Rad3)
                     ACS_ADJUST_ID_TUBE_CONDITION    24    tube conditioning (used with
                                                           unified generator)
                     ACS_ADJUST_ID_IRISCALIBRATION   25    start iris calibration procedure
                     ACS_ADJUST_ID_AIR_KERMA_RATE    26    start air kerma rate adjustment
                     ACS_ADJUST_ID_RCP_ATTACHMENT    27    start TUI/RCP attachment
                     ACS_ADJUST_ID_CARM_ATTACHMENT   28    start C-ARM attachment
                     ACS_ADJUST_ID_DICOM_WLAN        29    adjust DICOM access point
                     ACS_ADJUST_ID_FDCAL_TEMP        30
                     ACS_ADJUST_ID_FDCAL_MULTIGAIN   31
                     ACS_ADJUST_ID_FDCAL_STAT_DELTA  32
                     ACS_ADJUST_ID_FDCAL_DYN_DELTA   33
                     ACS_ADJUST_ID_FDCAL_DEFECT_DET  34
                     ACS_ADJUST_ID_SCU_ROTACQ        40    SCU settings rotational acq
                     ACS_ADJUST_ID_SCU_ROTACQ_POS    41    SCU rotational acq, reachability
                                                           of start position
                     ACS_ADJUST_ID_MCU_ANGULAR_ZERO  50    set C-Arm angular angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_ZERO  51    set C-Arm orbital angle to zero
                                                           (used in surgery)
                     ACS_ADJUST_ID_MCU_ORBITAL_MAX   52
                     ACS_ADJUST_ID_MCU_ORBITAL_MIN   53
                     ACS_ADJUST_ID_MCU_HF_SIGNALS    54    monitors MCU hand/footswitch
                                                           signals
                     ACS_ADJUST_ID_MCU_HW_SIGNALS    55    monitors MCU hardware signals
                     ACS_ADJUST_ID_MCU_FORMAT_FS     56    format file system on MCU
                     ACS_ADJUST_ID_MCU_RESET_TEMP    57    reset min max temperature
                     ACS_ADJUST_ID_MCU_VRT_TORQUE    58    set high torque for vertical lift
                                                           drive
                     ACS_ADJUST_ID_ETH_CONNECTIONS   59    monitor ethernet connections
                     ACS_ADJUST_ID_MCU_MOVE_SIGNALS  60    monitors MCU movement signals
                     ACS_ADJUST_ID_MCU_EMCY_SIGNALS  61    monitors MCU emergency and power
                                                           supply signals
                     ACS_ADJUST_ID_MCU_RESET_MILAGE  62    reset orbital/angular milage
                                                           information
                     ACS_ADJUST_ID_MCU_WFSW_PAIRING  64    enter pairing mode of the
                                                           wireless receiver
                     ACS_ADJUST_ID_MCU_WFSW_MONITOR  65    monitors status information of
                                                           wireless footswitch
                     ACS_ADJUST_ID_CALIB3D_GEO       70    3D geometric calibration
                     ACS_ADJUST_ID_CALIB3D_IZERO     71    iZero calibration for 3D
                     ACS_ADJUST_ID_CALIBTOPO_IZERO   72    iZero calibration for 2D_TOPO
                                                           (=SKELMAL)
                     ACS_ADJUST_ID_CAM3D_CALIB       75    calibration of 3D camera at tube
                                                           head
                     ACS_ADJUST_ID_RESET_MRAM        80    reset MRAM of XCU or MCU (thus
                                                           restore factory defaults)
                     ACS_ADJUST_ID_SELECT_TUBE1      85
                     ACS_ADJUST_ID_SELECT_TUBE2      86
                     ACS_ADJUST_ID_CTRL_XRAY         87    X-Ray Control
                     ACS_ADJUST_ID_WW                90    water value correction
                     ACS_ADJUST_ID_IEC_TEST          91    Set specific x-ray parameters
                                                           (working points) for IEC tests.
                                                           (used in surgery)
                     ACS_ADJUST_ID_NORMATIVE_TESTS   92    Set specific x-ray parameters
                                                           (working points) for various
                                                           normative tests. (used in
                                                           surgery)
                     ACS_ADJUST_ID_APH_SOLIDFICATN   101   AppHosting: manage solidification
                                                           software
                     ACS_ADJUST_ID_APH_SWITCH_MODE   102   AppHosting: switch to App Mode
                                                           via Service
                     ACS_ADJUST_ID_APH_SWITCH_ENV    103   AppHosting: switch the active
                                                           environment
                     ACS_ADJUST_ID_APH_CREATE_ENV    104   AppHosting: create a new
                                                           environment
                     ACS_ADJUST_ID_APH_EXPORT_DATA   105   AppHosting: export vendor data
                                                           (logfiles)
                     ACS_ADJUST_ID_APH_LICENSES      106   AppHosting: manage application
                                                           licenses
                     ACS_ADJUST_ID_APH_INSTALL_APP   107   AppHosting: install or update
                                                           applications
                     ACS_ADJUST_ID_APH_LANGUAGE      108   AppHosting: change language
                                                           settings
                     ACS_ADJUST_ID_APH_BIOS          109   AppHosting: access BIOS
                     ACS_ADJUST_ID_STAND_CENTERING   157   The number 157 is used in SCU for
                                                           Centering Adjustment
                     ACS_DIAG_ID_IS_VERSION          300
                     ACS_DIAG_ID_IS_HOST_ID          301
                     ACS_DIAG_ID_IS_DONGLE_ID        302
                     ACS_DIAG_ID_IS_FREE_HD          303
                     ACS_DIAG_ID_IS_FREE_MEMORY      304
                     ACS_DIAG_ID_IS_CONFIG_ISSUE     305
                     ACS_DIAG_ID_IS_OS_INFO          306
                     ACS_DIAG_ID_CPU_INFO            307
                     ACS_DIAG_ID_DICOM_ARCH_NODE     308
                     ACS_DIAG_ID_DICOM_MPPS_NODE     309
                     ACS_DIAG_ID_DICOM_MWL_NODE      310
                     ACS_DIAG_ID_DICOM_PRINT_NODE    311
                     ACS_DIAG_ID_FD2430_TYPE         340
                     ACS_DIAG_ID_FD2430_SN           341
                     ACS_DIAG_ID_FD2430_SW           342
                     ACS_DIAG_ID_FD2430_FW           343
                     ACS_DIAG_ID_FD2430_LIFETIME     344
                     ACS_DIAG_ID_FD2430_POWERON      345
                     ACS_DIAG_ID_FD2430_TEMPERATURE  346
                     ACS_DIAG_ID_FD2430_WIFI         347
                     ACS_DIAG_ID_FD2430_SHOCK        348
                     ACS_DIAG_ID_FD3543_TYPE         360
                     ACS_DIAG_ID_FD3543_SN           361
                     ACS_DIAG_ID_FD3543_SW           362
                     ACS_DIAG_ID_FD3543_FW           363
                     ACS_DIAG_ID_FD3543_LIFETIME     364
                     ACS_DIAG_ID_FD3543_POWERON      365
                     ACS_DIAG_ID_FD3543_TEMPERATURE  366
                     ACS_DIAG_ID_FD3543_WIFI         367
                     ACS_DIAG_ID_FD3543_SHOCK        368
                     ACS_DIAG_ID_FD4343_TYPE         380
                     ACS_DIAG_ID_FD4343_SN           381
                     ACS_DIAG_ID_FD4343_SW           382
                     ACS_DIAG_ID_FD4343_FW           383
                     ACS_DIAG_ID_FD4343_LIFETIME     384
                     ACS_DIAG_ID_FD4343_POWERON      385
                     ACS_DIAG_ID_FD4343_TEMPERATURE  386
                     ACS_DIAG_ID_FD4343_WIFI         387
                     ACS_DIAG_ID_FD4343_SHOCK        388
          Dimension: none

DIAG_VALUE supplied value for ST_DIAG
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_DOWNLOAD

Object: ST_DOWNLOAD ___ID: 1807

Description: request for download
Sender     :   PMS
Receiver   :   ALL
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DOWNLOAD download
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_STARTED  1   operation has been started
                     ACS_STOP     2   stop the operation
          Dimension: none

PACKAGE package for download etc.
          Type:  Enum8     (DEC)
          Range: 0 ... 13
                     ACS_NOT_DEFINED     0    not defined
                     ACS_PACK_LD         1    large display
                     ACS_PACK_LC         2    lab cockpit
                     ACS_PACK_SYSTEM     3    download system software (used in XP)
                     ACS_PACK_DEVICE_1   4    download device 1 firmware
                     ACS_PACK_PROFILE_1  5    download device 1 profile
                     ACS_PACK_DEVICE_2   6    download device 2 firmware
                     ACS_PACK_PROFILE_2  7    download device 2 profile
                     ACS_PACK_DEVICE_3   8    download device 3 firmware
                     ACS_PACK_PROFILE_3  9    download device 3 profile
                     ACS_PACK_DEVICE_4   10   download device 4 firmware
                     ACS_PACK_PROFILE_4  11   download device 4 profile
                     ACS_PACK_DEVICE_5   12   download device 5 firmware
                     ACS_PACK_PROFILE_5  13   download device 5 profile
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_DOWNLOAD_FD

Object: ST_DOWNLOAD_FD ___ID: 101F

Description: request for fd download
Sender     :   FLC
Receiver   :   EXT-SERVIF
Mode       :  DIRECT(01)
Systems    :  TRUMF

List of Parameters:

DOWNLOAD download
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_STARTED  1   operation has been started
                     ACS_STOP     2   stop the operation
          Dimension: none

DET_TYPE type of detector
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_NO_INFORMATION  0
                     ACS_FD4343RC        1
                     ACS_FD4343RCE       2
                     ACS_FD3543EZH       3
                     ACS_FD3543DR        4
                     ACS_FD2430EZ        5
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FD_SERIAL8 serial number of FD
          Type:  String8 [ 64 ]     (ASCII)
          Range: 64 ... 64
          Dimension: ASCII

FDR_PARTNUM FD factory part number
          Type:  String8 [ 64 ]     (ASCII)
          Range: 64 ... 64
          Dimension: none


ST_DTEXT

Object: ST_DTEXT ___ID: 1361

Description: set display text
Sender     :   PMS   SCU   TUI-IF
Receiver   :   TUI   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DIS_ACTION select type of display (the values >11 are only used at XP)
          Type:  Enum8     (DEC)
          Range: 4 ... 21
                     ACS_CL_PPUGUIDE_LINE         4    clear post processing user guidance
                                                       msg line
                     ACS_DIS_PPUGUIDE_LINE        5    display text on the post processing
                                                       user guidance msg line
                     ACS_CL_SYS_LINE              6    clear system msg line
                     ACS_DIS_SYS_LINE             7    display text on system msg line
                     ACS_CL_ACQ_LINE              8    clear ACQ msg line
                     ACS_DIS_ACQ_LINE             9    display text on ACQ msg line
                     ACS_CL_STAND_LINE            10   remove the service text box at the
                                                       TUI
                     ACS_DIS_STAND_LINE           11   display text in a service text box at
                                                       the TUI
                     ACS_CL_TUI_MSG               12   clear the message box of TUI
                     ACS_DIS_TUI_MSG              13   set the message box of TUI
                     ACS_CL_TUI_MSG_CONFIRM       14   clear the message box and also the
                                                       'ok button'
                     ACS_DIS_TUI_MSG_CONFIRM      15   display a message box and also an 'ok
                                                       button' to confirm the message
                     ACS_DIS_TUI_MSG_CONFIRM_MOD  16   display a message box and also an 'ok
                                                       button' to confirm the message and
                                                       disable all inputs except 'ok'
                     ACS_CL_SERVICE_MSG           17   remove service layout and switch back
                                                       to normal button labels (RFU only)
                     ACS_DIS_SERVICE_MSG          18   switches the button labels at the TUI
                                                       to service layout (RFU only)
                     ACS_CL_TUI_MSG_RDY           19   clear 'ready' message box (RFU only)
                     ACS_DIS_TUI_MSG_RDY          20   set 'ready' message box (RFU only)
                     ACS_DIS_COLL_MSG             21   string to be displayed at collimator
                                                       display
          Dimension: none

COLOUR colour of the display (will be defined later)
          Type:  Enum8     (DEC)
          Range: 0 ... 255
                     ACS_COLOUR_DEF  0   default colour
          Dimension: none

DISP_ATTRIB attributes for the displayed text
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_DISP_DEFAULT  0   default attribute for the selected display
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

LOSTR_DTEXT length of string of DTEXT
          Type:  Dcount     (CNT)
          Range: 0 ... 600
          Dimension: count of elements

{DIS_TEXT display text, variable string in UNICODE
{          Type:  String16 [ 1 ]     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


ST_ENTER_CALIB

Object: ST_ENTER_CALIB ___ID: 1016

Description: FDCalib requests ImageSystem/image chain to globally enter calibration mode
Sender     :   PMS
Receiver   :   FLC_TV
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

ENTER_CALIB_ACTION
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_EXIT_CALIB   0   exit calibration mode in ImgSys/image chain
                     ACS_ENTER_CALIB  1   globally enter calibration mode in ImgSys/image
                                          chain
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_EXAM_STUDY

Object: ST_EXAM_STUDY ___ID: 1028

Description: start or stop examination in service
Sender     :   PMS
Receiver   :   UIS
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

EXAM_STUDY
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_STUDY_SERVICE   1   an examintaion study for service shall be
                                             opened / is open
                     ACS_STUDY_CLOSE     2   the current exam study shall be closed / is
                                             closed
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

STUDY_NAME name of study to be opened
          Type:  String16 [ 64 ]     (ASCII)
          Range: 128 ... 128
          Dimension: unicode


ST_EXPORT_FDDATA

Object: ST_EXPORT_FDDATA ___ID: 1026

Description: trigger for exporting a fddata package to the FD
Sender     :   PMS
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

FPATH file path and name
          Type:  String16 [ 260 ]     (ASCII)
          Range: 520 ... 520
          Dimension: unicode

FD_SERIAL8 serial number of FD
          Type:  String8 [ 64 ]     (ASCII)
          Range: 64 ... 64
          Dimension: ASCII


ST_FD_CONNECT

Object: ST_FD_CONNECT ___ID: 1022

Description: connect/disconnect specific detector
Sender     :   PMS
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

CONNECT_FD connect or disconnect FD
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FD_SERIAL8 serial number of FD
          Type:  String8 [ 64 ]     (ASCII)
          Range: 64 ... 64
          Dimension: ASCII


ST_FDR_DATA

Object: ST_FDR_DATA ___ID: 0438

Description: set FD parameters
Sender     :   PMS
Receiver   :   FLC_TV
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF

List of Parameters:

FDR_RQ_INDEX index for each individual FDR request
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DETECTOR_PLANE identifier for the detector being addressed
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_NO_INFORMATION     0
                     ACS_FD_TABLE           1    detector mounted in the table
                     ACS_FD_WALL            2    FD mounted in the wall stand
                     ACS_FD_PORTABLE        3    free portable detector
                     ACS_FD_WALLCHARGER     4    portable detector in wall charger
                     ACS_FD_STAND           7    detector mounted in the dTF stand
                     ACS_FD_C_ARM           8    detector on c-arm in surgery
                     ACS_FD_FLEXIBLE        9    detector of Multitom Rax system
                     ACS_FD_SMALL_PORTABLE  10   small portable detector
          Dimension: none

NO_FDR_DATA number of FDR data blocks
          Type:  Dcount     (CNT)
          Range: 0 ... 21
          Dimension: none

{FDR_PARAM_TAG identifier of the FDR parameter (the values are not consecutive!)
{          Type:  Enum8     (DEC)
{          Range: 0 ... 252
{                       ACS_FDR_SERNUM                0     Serial number of FD
{                       ACS_FDR_PLANE                 1     Plane on which FD is currently
{                                                           attached
{                       ACS_FDR_DATE_CODE             2
{                       ACS_FDR_SW_VERSION            3
{                       ACS_FDR_PART_NUM              4     Factory part number of FD
{                       ACS_FDR_CUR_TEMP              5     Current FD temperature
{                       ACS_FDR_BATT_STATUS           6     Battery charge level
{                       ACS_FDR_BATT_ID               7     battery serial number
{                       ACS_FDR_BATT_CHARGE_CYC       8     battery charge cycle count
{                       ACS_FDR_LIFE_TIME             9
{                       ACS_FDR_POWERON_CNT           10
{                       ACS_FDR_WIFI_CUR_CHANNEL      11
{                       ACS_FDR_WIFI_FE_LINK_QUALITY  12    Raw Link Quality
{                       ACS_FDR_WIFI_DATA_RATE        13
{                       ACS_FDR_CALIB_TEMP            14    detector temperature at time of
{                                                           calibration
{                       ACS_FDR_CALIB_DATE            15    date of when the current
{                                                           calibration data have been
{                                                           acquired
{                       ACS_FDR_DETECTOR_TYPE         100
{          Dimension: none

{DUMMY1
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY2
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{FDR_PARVAL value to be set; depends on FDR_PARAM_TAG
{          Type:  Dword     (DEC)
{          Range: 0 ... 4294967294
{          Dimension: none


ST_FILTER_A

Object: ST_FILTER_A ___ID: 1241

Description: set filters in plane A
Sender     :   CCU-IF
Receiver   :   CCU_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_FILTERS number of filters
          Type:  Dcount     (CNT)
          Range: 0 ... 4
          Dimension: none

{XRPARN x-ray parameter set number
{          Type:  Set16     (HEX)
{          Range: 0x0 ... 0xFFFF
{                       ACS_ACQ_MIN_PS  0x0001 range 0001H to 00FFH is for ACQ
{                       ACS_ACQ_MASK    0x00FF mask for all possible acq programs
{                       ACS_FL_MIN_PS   0x0100 range 0100H to FF00H is for FLUORO
{                       ACS_FL_MASK     0x0F00 mask for all possible fluoro programs
{                       ACS_EMERG_PS    0x8000 value 8000H is emergency fluoro
{          Dimension: none

{XR_FILTER x-ray filter (e.g. copper)
{          Type:  Byte     (DEC)
{          Range: 0 ... 15
{                       ACS_NO_FILTER    0
{                       ACS_AUTO_FILTER  15   this value is only used in ST_PARAM
{          Dimension: 0.1 mm Cu

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


ST_FILTER_B

Object: ST_FILTER_B ___ID: 1242

Description: set filters in plane B
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_FILTERS number of filters
          Type:  Dcount     (CNT)
          Range: 0 ... 4
          Dimension: none

{XRPARN x-ray parameter set number
{          Type:  Set16     (HEX)
{          Range: 0x0 ... 0xFFFF
{                       ACS_ACQ_MIN_PS  0x0001 range 0001H to 00FFH is for ACQ
{                       ACS_ACQ_MASK    0x00FF mask for all possible acq programs
{                       ACS_FL_MIN_PS   0x0100 range 0100H to FF00H is for FLUORO
{                       ACS_FL_MASK     0x0F00 mask for all possible fluoro programs
{                       ACS_EMERG_PS    0x8000 value 8000H is emergency fluoro
{          Dimension: none

{XR_FILTER x-ray filter (e.g. copper)
{          Type:  Byte     (DEC)
{          Range: 0 ... 15
{                       ACS_NO_FILTER    0
{                       ACS_AUTO_FILTER  15   this value is only used in ST_PARAM
{          Dimension: 0.1 mm Cu

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


ST_GRID

Object: ST_GRID ___ID: 1512

Description: set values for scatter radiation grid
Sender     :   SCU-IF
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

VERSION_STGRID version of the object ST_GRID
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_STGRID  0   version from the beginning
          Dimension: none

GRID_ACTION new position of the grid
          Type:  Enum8     (DEC)
          Range: 1 ... 5
                     ACS_GRID_PARK_POS     1   park position
                     ACS_GRID_CENTRAL      2   grid centered
                     ACS_GRID_PREPARATION  3   position for preparation
                     ACS_GRID_REVERS_STOP  5   stop revers
          Dimension: none

GRID_FOCUS focus of the grid
          Type:  Integer16     (DEC)
          Range: -2 ... 10000
                     ACS_GRID_5          1000
                     ACS_GRID_1          1150
                     ACS_GRID_UNIVERSAL  1400
                     ACS_GRID_2          1500
                     ACS_GRID_3          1800
                     ACS_GRID_4          3000
          Dimension: mm

GRID_LINES number of lines of the grid
          Type:  Word     (DEC)
          Range: 0 ... 1000
          Dimension: number

GRID_RATION Ratio of the anti-scatter grid, definition: [value:1]
          Type:  Word     (DEC)
          Range: 0 ... 50
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_IMG_INV

Object: ST_IMG_INV ___ID: 11B1

Description: set or change the orientation of the image
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs and XCU_obsolete_IF

List of Parameters:

STTYPE select type of data handling
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_CHANGE_IMMEDIATELY  1   make it valid immediately
                     ACS_CHANGE_BY_VALID     2   make it valid by AMC (valid)
          Dimension: none

IDX index for the P-Transfer
          Type:  Byte     (DEC)
          Range: 1 ... 254
          Dimension: none

INVERT_A inversion of the image in DIPP-A
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_INVERT_HORIZONTAL   1   flip left/right
                     ACS_INVERT_VERTICAL     2   flip up/down
                     ACS_INVERT_H_AND_V      3   flip left/right and up/down
                     ACS_NO_FRAME_INVERSION  4   no flip
          Dimension: none

INVERT_B inversion of the image in DIPP-B
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_INVERT_HORIZONTAL   1   flip left/right
                     ACS_INVERT_VERTICAL     2   flip up/down
                     ACS_INVERT_H_AND_V      3   flip left/right and up/down
                     ACS_NO_FRAME_INVERSION  4   no flip
          Dimension: none

INVERT_DISPLAY_A inversion of the image in the display only
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_INVERT_HORIZONTAL   1   flip left/right
                     ACS_INVERT_VERTICAL     2   flip up/down
                     ACS_INVERT_H_AND_V      3   flip left/right and up/down
                     ACS_NO_FRAME_INVERSION  4   no flip
          Dimension: NONE

INVERT_DISPLAY_B inversion of the image in the display only
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_INVERT_HORIZONTAL   1   flip left/right
                     ACS_INVERT_VERTICAL     2   flip up/down
                     ACS_INVERT_H_AND_V      3   flip left/right and up/down
                     ACS_NO_FRAME_INVERSION  4   no flip
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_IMPORT_FDDATA

Object: ST_IMPORT_FDDATA ___ID: 1024

Description: trigger for importing a fddata package
Sender     :   PMS
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

FPATH file path and name
          Type:  String16 [ 260 ]     (ASCII)
          Range: 520 ... 520
          Dimension: unicode


ST_KVCURVE

Object: ST_KVCURVE ___ID: 04BE

Description: transfer desired kV-curve (over watervalue) from image system (CP) to XCU for
              common usage in fluoro and acquisition
Sender     :   UIS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

EP_THRESHOLD_1 this parameter specifies the first point from which on the dose shall be reduced by DOSE_REDUC_1 before the curve continues
          Type:  Integer16     (DEC)
          Range: 0 ... 4000
          Dimension: 1/16 EP

DOSE_REDUC_1 value by which the dose shall be reduced at the EP_THRESHOLD_1
          Type:  Integer16     (DEC)
          Range: 0 ... 256
          Dimension: 1/16 EP

EP_THRESHOLD_2 this parameter specifies the second point from which on the dose shall be reduced by DOSE_REDUC_2 before the curve continues
          Type:  Integer16     (DEC)
          Range: 0 ... 4000
          Dimension: 1/16 EP

DOSE_REDUC_2 value by which the dose shall be reduced at the EP_THRESHOLD_2
          Type:  Integer16     (DEC)
          Range: 0 ... 256
          Dimension: 1/16 EP

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_SUPP_PNTS number of supporting points of the given curve
          Type:  Count     (CNT)
          Range: 0 ... 40
          Dimension: count of elements

{EP_POINTS sum of the following Exposure points (= x-axis of curve)
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP

{KV_POINTS voltage in exposure points
{          Type:  Integer16     (DEC)
{          Range: 0 ... 4000
{          Dimension: 1/16 EP


ST_MODE

Object: ST_MODE ___ID: 1321

Description: set the mode of the system
Sender     :   PMS   SCU-IF   TEST-SW
Receiver   :   ALL   SCU   TUI   TUI_2
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEM_MODE mode in the system
          Type:  Enum8     (DEC)
          Range: 1 ... 8
                     ACS_NORMAL         1   All planes are out of BYPASS
                     ACS_SERVICE        2
                     ACS_EMERGENCY      3   BYPASS mode
                     ACS_DOWNLOAD       4
                     ACS_SW_RESET       5
                     ACS_PLANE_B_ERROR  6   biplane systems only
                     ACS_PLANE_A_ERROR  7   biplane systems only
                     ACS_FACTORY_RESET  8   reset to factory defaults
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

RECOVER_CODE recover code. If it is not 0 in REP_ERR or REP_ERROR, the subsystem gets a SW reset.
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none


ST_ORGAN_PROG

Object: ST_ORGAN_PROG ___ID: 100E

Description: Is used to enable PMS to select an Organ program at ImgSys by name and to
              superseed the values in the OGP data by the given data below.
Sender     :   PMS
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

PROG_NAME name of a program of exam set (64 char unicode)
          Type:  String16 [ 64 ]     (ASCII)
          Range: 128 ... 128
          Dimension: unicode

NUM_FRAMES number of frames to be acquired
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: Number

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

FILTER CU filter number, the Filter number is in most cases identical with the filter thickness in 0.1 mm, so 1 means 0.1 mm
          Type:  Byte     (DEC)
          Range: 0 ... 10
          Dimension: none

DARKIMAGE "yes" means COCA shall also deliver (i.e. not suppress) dark images
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE  0   none
                     ACS_YES   1
          Dimension: none

DISABLE_NORMALIZATION "yes" means ImageSystem shall send targetlevel=0 to Image Chain
"no" or "none" means configured targetlevel shall be taken
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NONE  0   none
                     ACS_YES   1
                     ACS_NO    2
          Dimension: none

IMAGE_SOURCE defines which )(test-)image shall be taken as source for the image pipeline
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_IMGSRC_NORMAL       0
                     ACS_IMGSRC_DET_TESTIMG  1
                     ACS_IMGSRC_GPU_TESTIMG  2
                     ACS_IMGSRC_IQ1_TESTIMG  3
                     ACS_IMGSRC_IQ2_TESTIMG  4
                     ACS_IMGSRC_IQ3_TESTIMG  5
          Dimension: none

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

EXP_TARGET exposure target (called "acquisition type" in UIS)
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     EXPT_TABLE         0
                     EXPT_BWS           1   bucky wall stand
                     EXPT_FREE          2   free exposure to portable detector (or cassette)
                     EXPT_TABLE_PULLED  3   exposure to detector in pulled-out table tray
                     EXPT_FREE_SMALL    4   free exposure to small portable detector
                                            (used in ST_ORGAN_PROG only)
          Dimension: none

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

DET_SIZE specifies if the large or the small portable detector is meant
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_DET_LARGE  0   large portable detector
                     ACS_DET_SMALL  1   small portable detector
          Dimension: none

FRATE frame rate (in ST_CP_DATA the highset freq that the user can select during the running series)
          Type:  Integer16     (DEC)
          Range: 0 ... 600
          Dimension: 0.1fps

XRPT_FLRAD Detector time XRPT (for acquisition)
          Type:  Word     (DEC)
          Range: 0 ... 3200
          Dimension: ms


ST_ORTHO

Object: ST_ORTHO ___ID: 1008

Description: communicate to SCU, that the limit positions are reached
Sender     :   TUI-IF   UIS
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TOD table object distance (center of the patient). This value is configurable.
          Type:  Integer16     (DEC)
          Range: 0 ... 1500
          Dimension: mm

POS1 flag if first ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

POS2 flag if second ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

POS1VAL angle of the first ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°

POS2VAL angle of the second ortho limit
used when ortho range is defined on camera image
          Type:  Integer16     (DEC)
          Range: -18000 ... 18000
          Dimension: 0.01°


ST_PAT

Object: ST_PAT ___ID: 1121

Description: set patient
Sender     :   CCU-IF
Receiver   :   CCU_A   CCU_B
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

STTYPE select type of data handling
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_CHANGE_IMMEDIATELY  1   make it valid immediately
                     ACS_CHANGE_BY_VALID     2   make it valid by AMC (valid)
          Dimension: none

IDX index for the P-Transfer
          Type:  Byte     (DEC)
          Range: 1 ... 254
          Dimension: none

PAT_POS patient position, the lateral positions are preliminary
          Type:  Enum8     (DEC)
          Range: 1 ... 8
                     ACS_HEAD_FIRST_SUPINE     1   face up; head toward gantry
                     ACS_FEET_FIRST_SUPINE     2   face up; feet toward gantry
                     ACS_HEAD_FIRST_PRONE      3   face down; head toward gantry
                     ACS_FEET_FIRST_PRONE      4   face down; feet toward gantry
                     ACS_HEAD_FIRST_RIGHT_LAT  5   right side downwards; head toward gantry
                     ACS_FEET_FIRST_RIGHT_LAT  6   right side downwards; feet toward gantry
                     ACS_HEAD_FIRST_LEFT_LAT   7   left side downwards; head toward gantry
                     ACS_FEET_FIRST_LEFT_LAT   8   left side downwards; feet toward gantry
          Dimension: none

PAT_ENTRY patient entry
          Type:  Enum8     (DEC)
          Range: 1 ... 5
                     ACS_NEW_PATIENT       1   new patient created
                     ACS_PAT_ORIENTATION   2   orientation of patient changed
                     ACS_PAT_RECOVER       3   recover with the previous patient
                     ACS_PAT_CORRECT       4   correct patient data
                     ACS_PAT_NEW_EMGY_PAT  5   create new emergency patient (by SYC)
          Dimension: none

VERSION_STPAT version of the object ST_PAT
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_STPAT  1   version 1 since VC13O: new parameter SER_COOUNTER
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SER_COUNTER series counter
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: none

SESSION_ID internal session identifier, unique within one Artis system; It is created with every 'new patient' or 'new emergency patient' (32 char unicode).
          Type:  String16 [ 32 ]     (ASCII)
          Range: 64 ... 64
          Dimension: unicode


ST_PRE_PRO_PAR

Object: ST_PRE_PRO_PAR ___ID: 1012

Description: set image preprocessing parameters
              used by FDCalib/IQAP
Sender     :   PMS
Receiver   :   FLC   FLC_TV   HIC_IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

AVR automatic gain control
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_AVR_ON    1   AGC on
                     ACS_AVR_OFF   2   AGC off
                     ACS_AVR_HAND  3   AGC off; predefined fixed gain
          Dimension: none

MEC_INHIBIT DIPP memory effect algo on/off
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

DIPP_MODE DIPP operational modes
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
                     DIPPMODE_BYPASS    0xE111
                     DIPPMODE_SHUTDOWN  0xE222
                     DIPPMODE_IDLE      0xEEEE
          Dimension: none


ST_PWR_OFF

Object: ST_PWR_OFF ___ID: 1315

Description: request power off
              Send either as request from GenSW to UIS
              or as a command from UIS to XCU, SCU and UGEN.
              (or in forced shutdown as command from UGEN to all)
Sender     :   SCU-IF   UGEN   UIS
Receiver   :   SCU   UGEN   UIS   XCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SHUTDOWN shutdown sequence
          Type:  Enum8     (DEC)
          Range: 1 ... 4
                     ACS_REQ_PWR_OFF     1   request to shut down
                     ACS_SHUTDOWN_APP    2   command to shutdown right away
                     ACS_PWR_OFF_CANCEL  4   cancel power off (delay = NIL)
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DELAY delay time
          Type:  Integer16     (DEC)
          Range: 0 ... 32767
          Dimension: 1 sec


ST_RADIATION

Object: ST_RADIATION ___ID: 180B

Description: Start/Stop acquisition or fluoro without hardware release and hands free
              movement controlled by software
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

XRAY_ACTION x-ray release by software
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_ENABLE_XRAY    1   enable x-ray
                     ACS_DISABLE_XRAY   2   disable x-ray
                     ACS_CONTINUE_XRAY  3   alive flag, send cyclically (ALIVE_INTERVAL)
          Dimension: none

ECG_SIMULATION simulation of ECG triggering (the value 0 has meanwhile the meaning ACS_DISABLE_ECG_SIM)
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_ENABLE_ECG_SIM    1   enable ECG simulation
                     ACS_DISABLE_ECG_SIM   2   disable ECG simulation
                     ACS_CONTINUE_ECG_SIM  3   alive flag, send cyclically (ALIVE_INTERVAL)
          Dimension: none

XRPARN x-ray parameter set number
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_ACQ_MIN_PS  0x0001 range 0001H to 00FFH is for ACQ
                     ACS_ACQ_MASK    0x00FF mask for all possible acq programs
                     ACS_FL_MIN_PS   0x0100 range 0100H to FF00H is for FLUORO
                     ACS_FL_MASK     0x0F00 mask for all possible fluoro programs
                     ACS_EMERG_PS    0x8000 value 8000H is emergency fluoro
          Dimension: none

ALIVE_INTERVAL time to send an alive message
          Type:  Integer16     (DEC)
          Range: 100 ... 5000
          Dimension: ms

ALIVE_TAG This value has to be incremented by the sender and sent back in SH_RADIATION
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

SW_CONTROL_FUNC control different functions by software instead of hardware
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_CTRL_XRAY      0   x-ray as defined in XRPARN
                     ACS_CTRL_MOVEMENT  1   hands free movement
                     ACS_CTRL_XMOVE     2   hands free movement and x-ray release
          Dimension: none


ST_REMOVE_IMGS

Object: ST_REMOVE_IMGS ___ID: 0435

Description: Used by PMS to remove remotely all images from service folder (except the ones
              being marked as non-removable)
Sender     :   PMS
Receiver   :   FLC   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro
This object has no parameters


ST_SEARCH_RUN

Object: ST_SEARCH_RUN ___ID: 1510

Description: control the search run of the collimator
Sender     :   CCU-IF
Receiver   :   CCU_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

COL_SR_CONTOL control of collimator search run
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     SR_START  0   start collimator search run
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_SERVICE_WF

Object: ST_SERVICE_WF ___ID: 1823

Description: set service workflow
Sender     :   PMS
Receiver   :   HIC_IF
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  RadFluoro

List of Parameters:

WF_ACTION action triggered by the workflow
          Type:  Enum8     (DEC)
          Range: 0 ... 10
                     ACS_WF_START           1
                     ACS_WF_STOP            2
                     ACS_WF_ACTION_TRIGGER  3
                     ACS_WF_GET_NEXT_STEP   4
                     ACS_WF_SUPPLY_UI_DATA  5
                     ACS_WF_CP_STEP_DATA    6
                     ACS_WF_ACQ_READY       7
                     ACS_WF_ACQ_FINISHED    8
                     ACS_WF_SYS_INFO_DATA   9
                     ACS_WF_REPORT_STATUS   10
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

WF_ID workflow ID
          Type:  Enum16     (DEC)
          Range: 1 ... 8
                     ACS_WF_FDCALIB        1
                     ACS_WF_IQAP           2
                     ACS_WF_EXI            3   	Detector Sensitivity & EXI
                     ACS_WF_RESET_FD_LIST  4   Reset attached detector list
                     ACS_WF_DEL_FIX_FD     5   Delete fixed FD data
                     ACS_WF_DEL_WID        6   	Delete wiD data
                     ACS_WF_IC_TEST        7   Image Chain Tests
                     ACS_WF_DEXI           8   dexi adjust
          Dimension: none

WF_STEP_ID workflow step ID
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_WF_STEP_UNKNOWN         0
                     ACS_WF_STEP_INIT            1
                     ACS_WF_STEP_CALIB_SEL_DET   2
                     ACS_WF_STEP_CALIB_PREP      3
                     ACS_WF_STEP_CALIB_MODE_SEL  4
                     ACS_WF_STEP_CALIB_RESULT    5
                     ACS_WF_STEP_ACQ             6
                     ACS_WF_STEP_ACQ_SERIES      7
                     ACS_WF_STEP_FINAL           8
          Dimension: none

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_WF_DATA number of WF data blocks
          Type:  Dcount     (CNT)
          Range: 0 ... 27
          Dimension: number of data blocks

{WF_PARAM_TAG identifier of the FDR parameter (the values are not consecutive!)
{          Type:  String8 [ 16 ]     (ASCII)
{          Range: 16 ... 16
{          Dimension: char

{LVALUE integer value of the parameter defined in wf_param_tag
{          Type:  Integer32     (DEC)
{          Range: -20000000 ... 20000000
{          Dimension: none

{SVALUE value of the parameter, returned as string
{          Type:  String8 [ 32 ]     (ASCII)
{          Range: 32 ... 32
{          Dimension: char


ST_SKELMAL

Object: ST_SKELMAL ___ID: 1030

Description:
Sender     :   FLC   TUI-IF   UIS
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TOD table object distance (center of the patient). This value is configurable.
          Type:  Integer16     (DEC)
          Range: 0 ... 1500
          Dimension: mm

POS1 flag if first ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

POS2 flag if second ortho limit position has been defined
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_ORTHOPOS_NOT_SET  0   ortho limit position not set
                     ACS_ORTHOPOS_SET      1   ortho limit position set and valid
                     ACS_ORTHOPOS_INVALID  2   ortho limit position is invalid
                     ACS_ORTHOPOS_BY_VAL   3   the ortho limit is given in the value
                                               parameter
          Dimension: n.a.

LOWER_SM_BORDER lower border of SkelMal range, measured from top of the socket the patient stands on (upright) or from the white line on the table (lying)
          Type:  Integer16     (DEC)
          Range: -1 ... 2200
          Dimension: mm

UPPER_SM_BORDER upper border of SkelMal range, measured from top of the socket the patient stands on (upright) or from the white line on the table (lying)
          Type:  Integer16     (DEC)
          Range: -1 ... 2200
          Dimension: mm


ST_SS

Object: ST_SS ___ID: 11A1

Description: set the safety switch (Sicherheitsschuetz)
Sender     :   PMS
Receiver   :   GEN-IF   UGEN
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

STTYPE select type of data handling
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_CHANGE_IMMEDIATELY  1   make it valid immediately
                     ACS_CHANGE_BY_VALID     2   make it valid by AMC (valid)
          Dimension: none

IDX index for the P-Transfer
          Type:  Byte     (DEC)
          Range: 1 ... 254
          Dimension: none

SW_SWITCH SW control of safety contactor: ACS_ON = x-ray possible
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ON   1   On
                     ACS_OFF  2   Off
          Dimension: none

XRAY_MAN_ENABLE xray manually enabled/disabled by user operation (HW input to generator)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_ENABLE_XRAY   1   enable x-ray
                     ACS_DISABLE_XRAY  2   disable x-ray
          Dimension: none


ST_STATE

Object: ST_STATE ___ID: 229A

Description: Display x-ray state on TUI (used in RFU systems only)
Sender     :   TUI-IF
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

XRAY_READY_STATE system ready for fluoro and/or acquisition (to be displayed on TUI)
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_FLUORO_ACQ_NOT_READY  0   not ready for fluoro or acq
                     ACS_FLUORO_READY          1   ready for fluoro
                     ACS_ACQ_READY             2   ready for acq
                     ACS_FLUORO_ACQ_READY      3   ready for fluoro and acq
                     ACS_FLUORO_ACQ_NA         4   value for empty ready/not-ready ICON for
                                                   TUI of 2nd plane, if this is in park
                                                   position
          Dimension: none

XRAY_STATE state of Fluoro and Acquisition
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_FLUORO_ACQ_OFF  0   ACQ and Fluoro off
                     ACS_FLUORO_ON       1   Fluoro on, acq off
                     ACS_ACQ_ON          2   acq on, fluoro off
          Dimension: none

MISC_STATE miscellaneous states in the system
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_NOTHING_ACTIVE      0   nothing active
                     ACS_CALIBRATION_ACTIVE  1   calibration active
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


ST_STEP

Object: ST_STEP ___ID: 2612

Description: set next step
Sender     :   SCU-IF
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

NEXT_POS last position in case of review values, next position while moving, else position reached
          Type:  Integer8     (DEC)
          Range: -11 ... 11
          Dimension: Position No

SPHASE show the phase of every Acq run divided into different phases
          Type:  Enum8     (DEC)
          Range: 0 ... 45
                     ACS_NOT_DEFINED    0    not defined
                     ACS_TEST_PHASE     1    for PERI, DR-STEP, DYNA, DR-DYNA, 3D-ACQ
                     ACS_MASK_PHASE     2    for PERI, DR-STEP, DYNA, DR-DYNA, 3D-ACQ
                     ACS_FILL_PHASE     3    only for PERI, DR-STEP, DYNA, DR-DYNA, 3D-ACQ,
                                             but without 3D-Card
                     ACS_NORMAL_PHASE   4
                     ACS_INJEC_PHASE    5    only for DYNA, DR-DYNA, 3D-ACQ if programmed
                     ACS_WASHOUT_PHASE  6    only for DYNA
                     ACS_RETURN_PHASE   7    only for DYNA, 3D-ACQ
                     ACS_FILL_1         11   fill run 1 for 3D
                     ACS_FILL_2         12   fill run 2 for 3D
                     ACS_FILL_3         13   fill run 3 for 3D
                     ACS_FILL_4         14   fill run 4 for 3D
                     ACS_FILL_5         15   fill run 5 for 3D
                     ACS_FILL_6         16   fill run 6 for 3D
                     ACS_FILL_7         17   fill run 7 for 3D
                     ACS_FILL_8         18   fill run 8 for 3D
                     ACS_FILL_9         19   fill run 9 for 3D
                     ACS_FILL_10        20   fill run 10 for 3D
                     ACS_VFR_1          21   variable frame rate phase 1
                     ACS_VFR_2          22   variable frame rate phase 2
                     ACS_VFR_3          23   variable frame rate phase 3
                     ACS_VFR_4          24   variable frame rate phase 4
                     ACS_FILL_11        31   fill run 11 for 3D
                     ACS_FILL_12        32
                     ACS_FILL_13        33
                     ACS_FILL_14        34
                     ACS_FILL_15        35
                     ACS_FILL_16        36
                     ACS_FILL_17        37
                     ACS_FILL_18        38
                     ACS_FILL_19        39
                     ACS_FILL_20        40
                     ACS_FILL_21        41
                     ACS_FILL_22        42
                     ACS_FILL_23        43
                     ACS_FILL_24        44
                     ACS_FILL_25        45
          Dimension: none

INDEX index for x-ray release (SH_PREP etc.)
          Type:  Word     (DEC)
          Range: 1 ... 65534
          Dimension: none


ST_STPAR_RFP

Object: ST_STPAR_RFP ___ID: 1009

Description: This object contains the RFU specific parameters/extensions of ST_STPAR
Sender     :   PMS   SCU-IF   SMSN
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

VERSION_STSTPARRFP version of RFU-specific ST_STPAR_RFP
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_STSTPARRFP  2   0: initial version RFU-VC10
                                           version 1 since VE61D: added parameters for
                                           relative CP position
                                           version 2 since VE61H: added BEAM_POS parameters
          Dimension: none

PROJECTION projections operated by the system (RAD/FLUORO)
          Type:  Enum8     (DEC)
          Range: 0 ... 28
                     ACS_PJ_POS_REQ          0    request of the position
                     ACS_PJ_TABLE            1    for Table YSIO and for RAD-Mode in dRF
                     ACS_PJ_WALL             2    combination of 3D tube and wall stand FD
                     ACS_PJ_OVER_TABLE_RAD   3    This projection is used for dRF RAD mode
                     ACS_PJ_TOMO             6    tomo mode using 3D tube and FD of rad
                                                  system
                     ACS_PJ_ORTHO            7
                     ACS_PJ_CASSETTE         8    free exposure using 3D tube on film
                                                  cassette
                     ACS_PJ_CASSETTE_WALL    9    combination of 3D tube and wall stand film
                                                  cassette
                     ACS_PJ_FREE_FD          10
                     ACS_PJ_UNDER_TABLE      13   normal mode for Luminos dTF (e.g. used for
                                                  fluoro)
                     ACS_PJ_TABLE_ORTHO      14   ortho on table of Ysio or Luminos
                     ACS_PJ_OVER_TABLE       15   This projection is used for dRF fluoro
                                                  mode
                     ACS_PJ_SCAN             16   projection for DR scanning mode
                     ACS_PJ_CASSETTE_B       17   free exposure using tube of fluoro system
                                                  and film cassette
                     ACS_PJ_WALL_B           18   combination of fluoro system tube and wall
                                                  stand FD
                     ACS_PJ_CASSETTE_WALL_B  19   combination of fluoro system tube with
                                                  film cassette in wall stand
                     ACS_PJ_FREE_FD_B        20   free exposure using fluoro system tube and
                                                  freely positioned mobile FD
                     ACS_PJ_TOMO_B           21   tomo mode using fluoro system tube and
                                                  fluoro system FD
                     ACS_PJ_TABLE_ORTHO_B    22   ortho on fluoro table using fluoro system
                                                  tube and fluoro system FD
                     ACS_PJ_SCAN_3D          24
                     ACS_PJ_SKELMAL          25
                     ACS_PJ_ORTHO_LATERAL    26
          Dimension: none

ALIGNMENT_MODE Determines, whether tube center is aligned to detector (or cassette) center, or whether top of collimator field of view is aligned to top of detector (or cassette)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_ALIGNMENT_CENTERED  0   centered
                     ACS_ALIGNMENT_TOP       1   top
          Dimension: none

STPAR_ACT action with the ST_STPAR
          Type:  Enum8     (DEC)
          Range: 1 ... 10
                     ACS_SELECT_POSNO     1
                     ACS_STORE_USER       2    user position
                     ACS_STORE_DIRECT     3    direct position
                     ACS_STORE_SYSTEM     4    system position
                     ACS_DELETE           5
                     ACS_CHECK            6    check the (3D start-) position for collision
                     ACS_AUTO_MAP         7    indicates AUTO MAP
                     ACS_CHECK_COLLISION  8    Check, if the final position is not in
                                               collision and if it is reachable
                     ACS_CALCULATE        9    calculate a SH_STPAR to display the graphic
                     ACS_CALCULATE_PED    10   calculate a SH_STPAR to display the graphic
                                               for PED
          Dimension: none

POSNO current preselect memory position
          Type:  Integer16     (DEC)
          Range: 0 ... 50
                     ACS_PRESENT_POSITION  0
          Dimension: Position Number

CONSIDER_3DSUPPORT the 3D support shall be (ST_) or is (SH_) part of the collision model (used only for upright trajectories in 3D OGPs)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

CONSIDER_3D_ARMREST the 3D arm rest shall be (ST_) or is (SH_) part of the collision model (used only for side trajectories in 3D OGPs)
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

TBL_X_RAD RAD only: table longitudinal position headwards / footwards
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Y_RAD RAD only: table side (transverse) offset, left / right
          Type:  Integer32     (DEC)
          Range: -50000 ... 50000
          Dimension: 0.1 mm

TBL_Z_RAD RAD only: table lift (height)
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TBL_TILT table tilting up / down  around Y axis, + means: head end up
          Type:  Integer16     (DEC)
          Range: -1800 ... 1800
                     ACS_HORIZONTAL_TABLE  0
          Dimension: 0.1 degree

DETECTOR_PARKPOS detector park position for Luminos dTF
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION    0
                     ACS_DET_PARK_IN       1   Detector is in park position
                     ACS_DET_PARK_BETWEEN  2   detector is between park an normal position
                     ACS_DET_PARK_OUT      3   detector is out of park position (i.e. in
                                               normal acq position)
          Dimension: none

ORTHO_DIR direction of ortho acquisition
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_HEAD_TO_FEET  0   direction of acquisition (ortho)
                     ACS_FEET_TO_HEAD  1   direction of acquisition (ortho)
                     ACS_TRANSVERSAL   2   for ortho panorama
          Dimension: none

SOFTSTOP activates or deactivates the SoftStop function
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SOFT_ACTIVE    1   SoftStop function is or shall be active
                     ACS_SOFT_INACTIVE  2   SoftStop function is or shall be deactivated
          Dimension: none

JOYSTICK_ORIENTATION define joystick orientation:
  Bit0: horizontal joystick (transversal) 0=off, 1=on
  Bit1: vertical joystick  (longitudinal) 0=off, 1=on
  Bit2: joystick orientation:     0=stand,  1=monitor
  Bit3: Flip H (left/right):  0 = no flip, 1= flipped
  Bit4: Flip V (up/down):     0 = no flip, 1= flipped
          Type:  Byte     (HEX)
          Range: 0x0 ... 0x31
          Dimension: it's a SET

DETECTOR_LONGI RAD only: Longitudinal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_TRANS RAD only: Transversal movement of the detector (or cassette)
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

DETECTOR_LIFT RAD only: Detector (or cassette) lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

DETECTOR_ROT_HOR RAD only: detector (or cassette) rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_ROT_VERTICAL RAD only: detector (or cassette) rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

DETECTOR_TILT RAD only: detector (or cassette) tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TOWER_LONGI longitudinal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -30000 ... 30000
          Dimension: 0.1 mm

TOWER_TRANSVERSAL transversal position of the tower of Luminos dTF
          Type:  Integer16     (DEC)
          Range: -10000 ... 10000
          Dimension: 0.1 mm

TUBE_LONGI RAD only: Longitudinal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_TRANSVERSAL RAD only: transversal movement of the tube
          Type:  Integer32     (DEC)
          Range: -100000 ... 100000
          Dimension: 0.1 mm

TUBE_LIFT RAD only: Tube lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

TUBE_ROT_HOR RAD only: Tube rotation horizontal
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_VERTICAL RAD only: Tube rotation vertical
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_ROT_HOR_FLUORO tube rotation at dRF
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

TUBE_LIFT_FLUORO tube lift at dRF
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

WALL_STAND_LIFT RAD only: Wall stand lift
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

WALL_STAND_TILT RAD only: wall stand tilt
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

COLLIMATOR_ROT_A RAD only: Collimator rotation
          Type:  Integer16     (DEC)
          Range: -27000 ... 27000
          Dimension: 0.01 degree

SID_MEASURED manually measured SID
          Type:  Integer32     (DEC)
          Range: 0 ... 50000
          Dimension: 0.1 mm

SID_VALID determination of SID
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_MANUAL_DET  0   user/manual determined
                     ACS_SID_SYSTEM_DET  1   determined by the system
                     ACS_SID_NOT_DEF     2   the system can not define the SID
          Dimension: none

SID_TRACKING SID tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_SID_TRACK_NOT_ACTIVE  0   SID tracking not active
                     ACS_SID_TRACK_ACTIVE      1   SID tracking active
                     ACS_SID_TRACK_LOST        2   SID tracking lost
          Dimension: none

TRACKING Tracking
          Type:  Enum8     (DEC)
          Range: 0 ... 15
                     ACS_TRACK_NOT_ACTIVE         0    tracking not active
                     ACS_TRACK_SYMMETRICAL        1    symmetrical
                     ACS_TRACK_TOP_ALIGN          2    asymmetrical top alignment
                     ACS_TRACK_BOTTOM_ALIGN       3    asymmetrical bottom alignment
                     ACS_TRACK_LEFT_ALIGN         4    asymmetrical left alignment
                     ACS_TRACK_RIGHT_ALIGN        5    asymmetrical right alignment
                     ACS_TRACK_LOST_SYMMETRICAL   11   tracking lost, symmetrical
                     ACS_TRACK_LOST_TOP_ALIGN     12   tracking lost, asymmetrical top
                                                       alignment
                     ACS_TRACK_LOST_BOTTOM_ALIGN  13   tracking lost, asymmetrical bottom
                                                       alignment
                     ACS_TRACK_LOST_LEFT_ALIGN    14   tracking lost, asymmetrical left
                                                       alignment
                     ACS_TRACK_LOST_RIGHT_ALIGN   15   tracking lost, asymmetrical right
                                                       alignment
          Dimension: none

POS_FIX select position
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_POS_CENTER   0
                     ACS_POS_START    1
                     ACS_POS_SWING    2
                     ACS_TOMO_CANCEL  3   Cancelling of tomo acquisition.
                     ACS_TOMO_ADJUST  4   system shall move to a position in which the tomo
                                          fulcrum height (Schichthöhe) can be adjusted using
                                          the laser line of the collimator
          Dimension: none

TOMO_ANGLE angle for tomo or tilt for beam tilt
          Type:  Integer16     (DEC)
          Range: 0 ... 18000
          Dimension: 0.01 degree

TOMO_HEIGHT height for tomo
          Type:  Word     (DEC)
          Range: 0 ... 5000
          Dimension: 0.1 mm

TOMO_TIME time for tomo
          Type:  Word     (DEC)
          Range: 0 ... 50000
          Dimension: ms

ORTHO_RANGE_DEF_METHOD Indicates which method is used to define the ortho range
Needed by XCU (message selection) as well as SCU (initial heigt for table ortho)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_ORTHO_RANGE_TUBE_ANGLE  0   conventional method using tube tilting
                     ACS_ORTHO_RANGE_CAMERA      1   advanced method using a graphic element
                                                     on the camera image
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

MOVEMENT_DISABLE system shall block any movement on users request
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NO_INFORMATION  0
                     ACS_YES             1
                     ACS_NO              2
          Dimension: none

RELATIVE_CP_POS_USAGE defines if the parameters for relative CP position are to be used or not (i.e. POSITION_CP, SID, OBLIQUE_BEAM_ANGLE)
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_USE_ABS_POS  0   use normal absolute parameters
                     ACS_USE_REL_POS  1   use the relative CP positions
          Dimension: none

OBLIQUE_BEAM_ANGLE angle of the central x-ray beam due to pivoting of column at dRF
          Type:  Integer16     (DEC)
          Range: -9000 ... 9000
          Dimension: 0.01 degree

COMPRESSION_FORCE the force of the compression tubus (in steps from 1-15)
          Type:  Byte     (BIN)
          Range: 00000000b ... 00001111b
          Dimension: steps

STAND_SPEED speed level for stand movement
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_SSPEED_SLOW     1
                     ACS_SSPEED_MEDIUM   2
                     ACS_SSPEED_FAST     3
          Dimension: none

SCAN_SPEED speed of DR scanning in steps
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: mm/s

SCAN_DIR direction of DR scanning
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_HEAD_TO_FEET  0   direction of acquisition (ortho)
                     ACS_FEET_TO_HEAD  1   direction of acquisition (ortho)
          Dimension: none

SID source object distance
          Type:  Integer16     (DEC)
          Range: 500 ... 5000
          Dimension: mm

POSITION_CP relative position (from clinical protocol - measured from patient feet)
          Type:  Integer16     (DEC)
          Range: -1000 ... 10000
          Dimension: mm

BEAM_POS_X Offset of the central beam relating to the center of the FD
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm

BEAM_POS_Y Offset of the central beam relating to the center of the FD
          Type:  Integer16     (DEC)
          Range: -4000 ... 4000
          Dimension: 0.1 mm


ST_SYSTEM_STATE

Object: ST_SYSTEM_STATE ___ID: 1811

Description: set new system state
Sender     :   PMS
Receiver   :   XCU
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEM_STATE system state with all exceptional states
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
                     ACS_STATE_CONSISTENT         0x0000 everything ok
                     ACS_STATE_DOWNLOAD           0x0001 inconsistent: download is running
                     ACS_STATE_DIAG               0x0002 inconsistent: DIAG is running
                     ACS_STATE_CONFIG             0x0004 inconsistent: config is running
                     ACS_STATE_SW_INCONSISTENT    0x0008 inconsistent: SW
                     ACS_STATE_CONF_INCONSISTENT  0x0010 inconsistent: config data
                     ACS_STATE_FULL_ACCESS        0x0020 external access
                     ACS_STATE_NO_LICENCE         0x0040 not all licences available
                     ACS_STATE_RESTART_PENDING    0x0080 Power Off/on necessary (only RFU)
                     ACS_STATE_SERVICE_SESSION    0x0100 System is in state service mode
                     ACS_STATE_SW_UPDATE          0x0200 SW update is running
                     ACS_STATE_SYSTEM_RESTORE     0x0400 system restore is running
                     ACS_STATE_FDCALIB_RUNNING    0x0800 FD calibration is running (used in
                                                         RFU systems)
                     ACS_STATE_OEM_WORKFLOW       0x1000 OEM workflow running
                     ACS_STATE_IQAP_INCOMPLETE    0x2000 Basic or Handover test report does
                                                         not exist
          Dimension: none

SER_SUB_STATE Service sub-state
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_SER_STATE_NORMAL  0   all other states
                     ACS_SER_STATE_ADJUST  1   Adjust is running
          Dimension: none

SERVICE_LEVEL Actual service level
          Type:  Byte     (DEC)
          Range: 0 ... 9
          Dimension: none


ST_TEXT_LONG

Object: ST_TEXT_LONG ___ID: 1360

Description: transfer a long sting in unicode
Sender     :   FLC
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

DISP_FUNC function code of DISP_VALUE
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

DISP_ATTRIB attributes for the displayed text
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_DISP_DEFAULT  0   default attribute for the selected display
          Dimension: none

COLOUR colour of the display (will be defined later)
          Type:  Enum8     (DEC)
          Range: 0 ... 255
                     ACS_COLOUR_DEF  0   default colour
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

NO_DATA_UNICODE number of characters in the following array
          Type:  Dcount     (CNT)
          Range: 0 ... 720
          Dimension: count of elements

{DATA_UNICODE general data (unicode)
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


ST_ZOOM

Object: ST_ZOOM ___ID: 1161

Description: set zoom (just needed to compile CCU...)
Sender     :   CCU-IF
Receiver   :   CCU_A   CCU_B
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

STTYPE select type of data handling
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_CHANGE_IMMEDIATELY  1   make it valid immediately
                     ACS_CHANGE_BY_VALID     2   make it valid by AMC (valid)
          Dimension: none

IDX index for the P-Transfer
          Type:  Byte     (DEC)
          Range: 1 ... 254
          Dimension: none

ZOOM_A zoom number A
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_ZOOM_0  0   full format
                     ACS_ZOOM_1  1
                     ACS_ZOOM_2  2
                     ACS_ZOOM_3  3
                     ACS_ZOOM_4  4
                     ACS_ZOOM_5  5
          Dimension: Zoom Number

ZOOM_B zoom number B
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_ZOOM_0  0   full format
                     ACS_ZOOM_1  1
                     ACS_ZOOM_2  2
                     ACS_ZOOM_3  3
                     ACS_ZOOM_4  4
                     ACS_ZOOM_5  5
          Dimension: Zoom Number

DIGZOOM_A digital zoom mode selection in plane A, not used in EAS (NIL or DZ_OFF)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_DZ_2    1   digital zoom: 2 times
                     ACS_DZ_OFF  2   digital zoom: off
          Dimension: none

DIGZOOM_B digital zoom mode selection in plane B, not used in EAS (NIL or DZ_OFF)
          Type:  Enum8     (DEC)
          Range: 1 ... 2
                     ACS_DZ_2    1   digital zoom: 2 times
                     ACS_DZ_OFF  2   digital zoom: off
          Dimension: none

IMG_ROT_A Image rotation A in relation to default patient position
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NOT_ROTATED  0   default orientation
                     ACS_ROTATED_CW   1   rotated in a clockwise direction
                     ACS_ROTATED_CCW  2   rotated in a counterclockwise direction
          Dimension: none

IMG_ROT_B Image rotation B in relation to default patient position
          Type:  Enum8     (DEC)
          Range: 0 ... 2
                     ACS_NOT_ROTATED  0   default orientation
                     ACS_ROTATED_CW   1   rotated in a clockwise direction
                     ACS_ROTATED_CCW  2   rotated in a counterclockwise direction
          Dimension: none


STEACHINGMODEAUSL

Object: STEACHINGMODEAUSL ___ID: 02F2

Description: simulated acquisition with images from disk
              sent from XCU to ImageSystem
Sender     :   XCU
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

DL fluoro requested
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

ACQ_INDEX Index for an acquisition or fluoro (used in sAufnAusl and sDLAusl as well as in many other telegrams)
          Type:  Dword     (DEC)
          Range: 0 ... 4294967295
          Dimension: none


STEILUNG

Object: STEILUNG ___ID: 01F7

Description: XCU tells the cassette system, which subdivision to use; sent from XCU to
              cassette
Sender     :   XCU
Receiver   :   CCU-IF   RAD-STD
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

TEILUNG_Q Current subdivision
          Type:  Byte     (DEC)
          Range: 1 ... 20
          Dimension: none

TEILUNG_L Possible subdivision supported by this cassette size.
          Type:  Byte     (DEC)
          Range: 1 ... 20
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


STESTCMD

Object: STESTCMD ___ID: 0016

Description: service telegram for adjustments, used to bypass telegram definitions in
              service mode and use telegram without literal parameter definition, sent from
              XCU to component
Sender     :   XCU
Receiver   :   RAD-STD
Mode       :  DIRECT(01)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

CMDKENNUNG code that defines certain actions during service
          Type:  Enum8     (DEC)
          Range: 0 ... 255
          Dimension: none

AKTIVIERUNG determines, whether an adjustment has to be started or stopped
          Type:  Byte     (DEC)
          Range: 0 ... 3
                     KEINEANGABE       0
                     STARTAKTIVIERUNG  1   start activation
                     STOPAKTIVIERUNG   2   cancel activation
                     ENDEAKTIVIERUNG   3   terminate activation
          Dimension: none

ANZAHLDATEN how many data are stored in the init block
          Type:  Dcount     (CNT)
          Range: 0 ... 490
          Dimension: number of data blocks

{DATEN
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


STUIBUTTONS_2

Object: STUIBUTTONS_2 ___ID: 02EA

Description: Sent from FL-C (or VCU) to TUI Interface in order to control the status of
              several buttons . The buttons should only light up if FL-C supports that
              function at that time.
Sender     :   FLC   VCU
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_FUNC number of functions in this object
          Type:  Dcount     (CNT)
          Range: 0 ... 239
          Dimension: none

{TUI_ITEM item to be set
{          Type:  Enum16     (DEC)
{          Range: 1 ... 2500
{                       BTN_REMASK                      1      Remask and Native/DSA display
{                                                              toggle is only possible, if a
{                                                              DSA image is displayed
{                       BTN_NATIVE                      2      Native/DSA display toggle is
{                                                              only possible, if a DSA image
{                                                              is displayed
{                       BTN_MONITOR_SPLIT               3      Split screen is only
{                                                              possible, if an image is
{                                                              displayed
{                       BTN_IMAGE_PLUS                  4      "image +" and "image -" are
{                                                              only possible, if an image is
{                                                              displayed and there is a
{                                                              previous or next image
{                       BTN_IMAGE_MINUS                 5      "image +" and "image -" are
{                                                              only possible, if an image is
{                                                              displayed and there is a
{                                                              previous or next image
{                       BTN_STORE_FLUORO_LOOP           6      store fluoro loop is only
{                                                              possible, if a fluoro scene
{                                                              has been acquired and is
{                                                              available on ImgSys
{                       BTN_STORE_MONITOR               7      store monitor is only
{                                                              possible, if an image is
{                                                              displayed
{                       BTN_DVD_RECORDER                8      DVD-Recorder-Control is only
{                                                              possible is a DVD disk is the
{                                                              recorder
{                       BTN_STORE_REFERENCE             9      Reference Store if an image
{                                                              is selected
{                       BTN_RECALL_REFERENCE            10     Reference Recall is only
{                                                              possible, if a patient is
{                                                              selected
{                       BTN_PRINTER_FILM_SUBDIVISIONS   11     Printer film sheet
{                                                              subdivisions are only
{                                                              possible, is a printer is
{                                                              connected and ready (this was
{                                                              a systems requirement that
{                                                              has been missed by FLC and
{                                                              XCU, but for Japan we have to
{                                                              integrate printer control
{                                                              with subdivision 1:1. 1:2,
{                                                              2:1, 1:3 and 1:4 from TUI
{                                                              (and XCU has to control
{                                                              collimator, so that customer
{                                                              feels like having old style
{                                                              cassette on a modern
{                                                              FD-system
{                       BTN_MARK_IMAGE                  12     Mark image only possible, if
{                                                              a markable image (no LIH) is
{                                                              active
{                       BTN_PRESELECTION_OF_LABELS      13     Preselection of Label R and
{                                                              Label L only possible, if
{                                                              patient is selected
{                       BTN_RESTORE_OGP                 14     Restore OGP values is only
{                                                              possible, if there has been a
{                                                              previous OGP and an OGP has
{                                                              been selected
{                       BTN_ROADMAP                     15     Roadmap only possible when
{                                                              patient is selected and DSA
{                                                              option available
{                       BTN_START_FLUORO_LOOP           16     Start / stop loop is only
{                                                              possible if option fluoro
{                                                              loop is available and a
{                                                              patient is selected
{                       BTN_SINGLE_SERIES               17     State of Single / Series
{                                                              button on TUI, sent by FL-C
{                       BTN_SCENE_PLUS                  18     "scene +" and "scene -" are
{                                                              only possible, if a scene is
{                                                              displayed and there is a
{                                                              previous or next scene
{                                                              (values see REMASK of object
{                                                              sTuiButtons)
{                       BTN_SCENE_MINUS                 19     "scene +" and "scene -" are
{                                                              only possible, if a scene is
{                                                              displayed and there is a
{                                                              previous or next scene
{                                                              (values see REMASK of object
{                                                              sTuiButtons)
{                       BTN_CAREPOSITION                20     status of careposition button
{                                                              is controlled by ImageSystem
{                                                              (values see REMASK of object
{                                                              sTuiButtons)
{                       BTN_REDO                        21     ImageSystem is master of the
{                                                              redo button on TUI.
{                       BTN_MAGN_TABCARD                22     button for Magnification
{                                                              Tabcard/Popup
{                       KEYBOARD                        23     used to open and close the
{                                                              keyboard on TUI (in surgery)
{                                                              allowed codes are 1=normal
{                                                              and 4=hidden
{                       BTN_EXAM                        24
{                       FLD_DETECTOR_ANGLES             25     icons and text fields for the
{                                                              detector angle display
{                       BTN_METAL_CORR                  26     controls the button for metal
{                                                              correction (surgery only)
{                       BTN_BRIGHT_CONTR                27
{                       BTN_EDGE_ENH                    28
{                       BTN_HARDCOPY                    29     print button
{                       BTN_TRANSFER                    30     Export button
{                       BTN_MOVIE                       31
{                       BTN_STRIPE_MODE                 32     enabled or disabled depending
{                                                              on if the selected image is a
{                                                              multiframe (scene) or a
{                                                              single image
{                       BTN_STACK_MODE                  33
{                       BTN_STDY_PROTECT                34     transfers the protection
{                                                              status of the currently
{                                                              selected study
{                                                              used to activate "protect"
{                                                              and to dim "delete" button
{                                                              (used in surgery)
{                       BTN_DSA_GROUP                   35     used to disable the
{                                                              sub/native buttons in
{                                                              windowing submenu
{                       BTN_HIDE_SHUTTER                36
{                       BTN_CALC_PEAKOP                 37
{                       BTN_DEL_DRAW                    38     enables the delete buttons on
{                                                              "Draw AA Line" submenu once
{                                                              there is something to be
{                                                              deleted
{                       BTN_DEL_QUANT_P                 39     controls if the is a point to
{                                                              be deleted
{                       BTN_DEL_QUANT_L                 40     controls if the is a line to
{                                                              be deleted
{                       BTN_QUANT_LINE1                 41     enables up/down buttons if
{                                                              line 1 exists
{                       BTN_QUANT_LINE2                 42     enables up/down buttons if
{                                                              line 2 exists
{                       BTN_CLOSE_PAT                   43     close patient button (must be
{                                                              dimmed if not patient is open
{                                                              for exam)
{                       BTN_HOLD_REF                    44
{                       BTN_END_LINE                    45     control END LINE button in
{                                                              AAA line submenu
{                       POP_PASSCODE                    46     used to open and close the
{                                                              popup dialog for passcode
{                                                              entry to unlock x-ray (GB
{                                                              option for surgery)
{                                                              allowed codes are 1=normal
{                                                              and 4=hidden
{                       BTN_SUB_AND_NAT                 47
{                       BTN_SUB_NAT_REF                 48
{                       BTN_DRAW_LINE                   49
{                       BTN_QUANT                       50
{                       BTN_BLOWUP                      51
{                       BTN_3D_DISP                     52     button that opens/activates
{                                                              3D display and submenu
{                       BTN_KB_DISP_IMG                 53     control "Display Images"
{                                                              button on TUI keyboard
{                       BTN_KB_SHOW_PATDAT              54     control "Show Patient Data"
{                                                              button on TUI keyboard
{                       BTN_KB_BACK_PATLST              55     control "Back To Pat List"
{                                                              button on TUI keyboard
{                       BTN_KB_CORR_PATDAT              56     control "Correct Pat Data"
{                                                              button on TUI keyboard
{                       BTN_KB_EMERGENCY                57     control "Emergency" button on
{                                                              TUI keyboard
{                       BTN_KB_GEN_ID                   58     control "Generate ID" button
{                                                              on TUI keyboard
{                       BTN_KB_DELETE                   59     control "Delete" button on
{                                                              TUI keyboard
{                       BTN_KB_FILTER                   60     control "Filter" button on
{                                                              TUI keyboard
{                       BTN_KB_SERVICE                  61     control "Service" button on
{                                                              TUI keyboard
{                       BTN_KB_ADD_WORKLST              62     control "Add To Worklist"
{                                                              button on TUI keyboard
{                       BTN_ANNO_DEL_POINT              63     controls the TUI button
{                                                              "Delete Point" in Annotation
{                                                              submenu
{                                                              (used in surgery)
{                       BTN_ANNO_DEL_GRAPH              64     controls the TUI button
{                                                              "Delete Graph" in Annotation
{                                                              submenu
{                                                              (used in surgery)
{                       BTN_ANNO_CALIB                  65     controls the TUI button
{                                                              "Calibrate" in Annotation
{                                                              submenu
{                                                              (used in surgery)
{                       BTN_PEAKOP                      66     controls the TUI button
{                                                              "PeakOP" (which opens Peakop
{                                                              submenu)
{                                                              (used in surgery)
{                       BTN_PIXEL_SHIFT                 67     controls the TUI button
{                                                              "PixelShift" (used in
{                                                              surgery)
{                       TEXT_FLD_KEM                    68     controls visibility of the
{                                                              text field in TUI Keyboard
{                                                              (used in surgery)
{                       SILDER_LANDMARK                 69     allows to dim or hide the
{                                                              landmark slider (used in
{                                                              surgery)
{                       BTN_FLIP_ROT                    70     controls the TUI button
{                                                              "Flip/Rotate" (used in
{                                                              surgery)
{                       BTN_RESET_ALL                   71     controls the TUI button
{                                                              "Reset All" (used in surgery)
{                       BTN_ZOOM_PAN                    72     controls the TUI button
{                                                              "Zoom/Pan" (used in surgery)
{                       BTN_ANNOT_MEAS                  73     controls the TUI button
{                                                              "Annotate/Measure" (used in
{                                                              surgery)
{                       BTN_TRANSFER_A2B                74     controls the TUI button
{                                                              "Transfer A->B" (used in
{                                                              surgery)
{                       BTN_DATA_SYSTEM                 75     controls the TUI button "Data
{                                                              System" (used in surgery)
{                       BTN_RESET_ZOOM                  76     controls the TUI button
{                                                              "Reset Zoom/Pan" (used in
{                                                              surgery)
{                       BTN_PAN_N                       77     controls the upper button for
{                                                              PAN (used in surgery)
{                       BTN_PAN_NE                      78     controls the upper right
{                                                              button for PAN (used in
{                                                              surgery)
{                       BTN_PAN_E                       79     controls the right button for
{                                                              PAN (used in surgery)
{                       BTN_PAN_SE                      80     controls the lower right
{                                                              button for PAN (used in
{                                                              surgery)
{                       BTN_PAN_S                       81     controls the lower button for
{                                                              PAN (used in surgery)
{                       BTN_PAN_SW                      82     controls the lower left
{                                                              button for PAN (used in
{                                                              surgery)
{                       BTN_PAN_W                       83     controls the left button for
{                                                              PAN (used in surgery)
{                       BTN_PAN_NW                      84     controls the upper left
{                                                              button for PAN (used in
{                                                              surgery)
{                       BTN_GROUP_2D_ONLY               85     used to hide button which are
{                                                              not wanted in 3D (used in
{                                                              surgery)
{                       BTN_WIN_LUT1                    86     controls the window LUT1
{                                                              button in bright/contrast
{                                                              submenu
{                       BTN_WIN_LUT2                    87
{                       BTN_WIN_LUT3                    88
{                       BTN_WIN_AUTO                    89     controls the "default" button
{                                                              in bright/contrast submenu
{                                                              (used in surgery)
{                       BAR_PROGRESS                    90     shows/hides a generic
{                                                              progress bar;
{                                                              the progress in percent shall
{                                                              be given in the additional
{                                                              parameter PARAM_8
{                       BTN_PREV_PEAKOP                 91
{                       BTN_NEXT_PEAKOP                 92
{                       BTN_DRAWAAA_EDIT_LINE           93
{                       BTN_DRAWAAA_DEL_ALL             94
{                       BTN_DUAL_3D_DISP                95
{                       BTN_DETECTOR_SELECTION          96     used to dim or hide the
{                                                              button/list for detector
{                                                              selection
{                       BTN_DRAWAAA_SET_POINT           97
{                       BTN_RECALC_PEAKOP_GRP           98     used to dim a group of
{                                                              buttons in PeakOp submenu
{                       POP_SPLASH                      99     splash screen on xCP (used in
{                                                              surgery)
{                       BTN_SPATIAL_NOISE_FILTER        100
{                       BTN_VCU_STORE                   101    button on TUI belonging to
{                                                              VCU that triggers VCU to
{                                                              store an image
{                       BTN_VCU_NEXT                    102    button on TUI belonging to
{                                                              VCU that triggers VCU to
{                                                              switch to next source
{                       BTN_VCU_SCAN                    103    button on TUI belonging to
{                                                              VCU that activates VCU to
{                                                              scan inputs
{                       BTN_VCU_PIP                     104    button on TUI belonging to
{                                                              VCU that activates VCU to
{                                                              show picture-in-picture
{                       BTN_VCU_SOURCE1                 111
{                       BTN_VCU_SOURCE2                 112
{                       BTN_VCU_SOURCE3                 113
{                       BTN_VCU_SOURCE4                 114
{                       BTN_VCU_SOURCE5                 115
{                       BTN_PIXSHFT_ACCEPT              120    "accept" button at pixelshift
{                                                              submenu
{                       BTN_PIXSHFT_UNDO                121    "undo" button at pixelshift
{                                                              submenu
{                       BTN_PIXSHFT_RESET               122    "reset" button at pixelshift
{                                                              submenu
{                       BTN_PIXSHFT_VIEWPEAKOP          123    "preview PeakOP" button at
{                                                              pixelshift submenu
{                       BTN_OGP_SELECTION               125    used to inhibit OGP selection
{                                                              at certain points of time
{                                                              (used in RFU)
{                       BTN_PEAK_SET_START              126    control set start button at
{                                                              peakop submenu (used in
{                                                              surgery)
{                       BTN_PEAK_SET_END                127    control set end button at
{                                                              peakop submenu (used in
{                                                              surgery)
{                       BTN_KWIRE                       128    control k-wire button on TUI
{                                                              main menu
{                       BTN_APPS_IMG_TRANS              129    Button for manual image
{                                                              transfer to AppHost
{                       BTN_ENA_AUTO_STORE              130    Button to enable automatic
{                                                              fluoro loop storage (see
{                                                              AKTCODE 67)
{                       BTN_STORE_SNAPSHOT              132    Button to store a cummulated
{                                                              fluoro image (see AKTCODE
{                                                              132)
{                       BTN_NEWPAT                      133    new patient
{                       BTN_EMERGPAT                    134    emergency patient
{                       BTN_PREVPAT                     135    previous patient
{                       BTN_WORKLIST                    136    patient worklist
{                       SLIDER_IMAGE                    137    allows to dim or hide the
{                                                              image slider (used in
{                                                              surgery)
{                       BTN_PATIENT_SIZE                150    radio button group to select
{                                                              patient size (in RAD3)
{                       BTN_ACTIVATE_3D_VIEW_MPR_S      2001
{                       BTN_ACTIVATE_3D_VIEW_MPR_T      2002
{                       BTN_ACTIVATE_3D_VIEW_MPR_C      2003
{                       BTN_ACTIVATE_3D_VIEW_VRT        2004
{                       BTN_ACTIVATE_VRT_PRESET_1       2005
{                       BTN_ACTIVATE_VRT_PRESET_2       2006
{                       BTN_ACTIVATE_VRT_PRESET_3       2007
{                       BTN_ENLARGE_3D_VIEW             2008
{                       BTN_STANDARD_ORIENTATION_3D     2009
{                       BTN_MPR_THICKNESS_DIALOG_3D     2010
{                       BTN_PARALLEL_RANGE_DIALOG_3D    2011
{                       BTN_MOVE_MPR_PLANE_S_POS        2012
{                       BTN_MOVE_MPR_PLANE_S_NEG        2013
{                       BTN_MOVE_MPR_PLANE_C_POS        2014
{                       BTN_MOVE_MPR_PLANE_C_NEG        2015
{                       BTN_MOVE_MPR_PLANE_T_POS        2016
{                       BTN_MOVE_MPR_PLANE_T_NEG        2017
{                       BTN_ROTATE_MPR_PLANE_S          2018
{                       BTN_ROTATE_MPR_PLANE_C          2019
{                       BTN_ROTATE_MPR_PLANE_T          2020
{                       BTN_ROTATE_VRT_X                2021
{                       BTN_ROTATE_VRT_Y                2022
{                       BTN_ROTATE_VRT_Z                2023
{                       BTN_HIDE_REF_LINES              2024
{                       BTN_ORTHO_ALIGNMENT             2025
{                       BTN_MPR_THICK_DOWN              2026
{                       BTN_MPR_THICK_UP                2027
{                       BTN_RESET_MPR_THICK             2028
{                       BTN_SWAP_VOLUMES                2029   toggle button for switching
{                                                              on the volume swapping
{                       BTN_VOL_REGIST_MENU             2030   control button for Volume
{                                                              Registration dialog
{                       BTN_SYNC_ADAPT                  2031   radio button group for "Adapt
{                                                              Monitor A" and "Adapt Monitor
{                                                              B" buttons
{                       BTN_SYNC_LINK                   2032   toggle button for switching
{                                                              on and off the parameter
{                                                              linking
{                       BTN_SYNC_SYNC                   2033   push button for synchronizing
{                                                              the settings between the
{                                                              monitors
{                       BTN_SYNCW_ADAPT                 2034   radio button group in
{                                                              Brightness/Contrast dialog
{                                                              for "Adapt Monitor A" and
{                                                              "Adapt Monitor B" buttons
{                       BTN_SYNCW_LINK                  2035   toggle button in
{                                                              Brightness/Contrast dialog
{                                                              for switching on and off the
{                                                              parameter linking
{                       BTN_SYNCW_SYNC                  2036   push button in
{                                                              Brightness/Contrast dialog
{                                                              for synchronizing the
{                                                              settings between the monitors
{                       BTN_SYNCZ_ADAPT                 2037   radio button group in
{                                                              Zoom/Pan dialog for "Adapt
{                                                              Monitor A" and "Adapt Monitor
{                                                              B" buttons
{                       BTN_SYNCZ_LINK                  2038   toggle button in Zoom/Pan
{                                                              dialog for switching on and
{                                                              off the parameter linking
{                       BTN_SYNCZ_SYNC                  2039   push button in Zoom/Pan
{                                                              dialog for synchronizing the
{                                                              settings between the monitors
{                       BTN_REGIST_PAN_UP               2040   autorepeat push button for
{                                                              panning the second volume in
{                                                              the selected segment up
{                       BTN_REGIST_PAN_DOWN             2041   autorepeat push button for
{                                                              panning the second volume in
{                                                              the selected segment down
{                       BTN_REGIST_PAN_LEFT             2042   autorepeat push button for
{                                                              panning the second volume in
{                                                              the selected segment left
{                       BTN_REGIST_PAN_RIGHT            2043   autorepeat push button for
{                                                              panning the second volume in
{                                                              the selected segment right
{                       BTN_REGIST_ROTATE_LEFT          2044   autorepeat push button for
{                                                              rotating the second volume in
{                                                              the selected segment left
{                       BTN_REGIST_ROTATE_RIGHT         2045   autorepeat push button for
{                                                              rotating the second volume in
{                                                              the selected segment right
{                       BTN_REGIST_AUTO                 2046   pushbutton for starting the
{                                                              automatic registration
{                       BTN_REGIST_STORE                2047   pushbutton for storing the
{                                                              current registration
{                       BTN_REGIST_SELECTION            2048   combo box for selecting a
{                                                              stored registration
{                       BTN_REGIST_CONSTR_MENU          2049   control button for the
{                                                              Constraint Registration
{                                                              dialog
{                       BTN_CLIPPLANE_MPR_MOVE_FW       2050   autorepeat push button for
{                                                              moving the clip plane forward
{                                                              in MPR mode
{                       BTN_CLIPPLANE_MPR_MOVE_BK       2051   autorepeat push button for
{                                                              moving the clip plane
{                                                              backward in MPR mode
{                       BTN_CLIPPLANE_MPR_ROTATE_LEFT   2052   autorepeat push button for
{                                                              rotating the clip plane left
{                                                              in MPR mode
{                       BTN_CLIPPLANE_MPR_ROTATE_RIGHT  2053   autorepeat push button for
{                                                              rotating the clip plane right
{                                                              in MPR mode
{                       BTN_CLIPPLANE_VRT_MOVE_FW       2054   autorepeat push button for
{                                                              moving the clip plane forward
{                                                              in VRT mode
{                       BTN_CLIPPLANE_VRT_MOVE_BK       2055   autorepeat push button for
{                                                              moving the clip plane
{                                                              backward in VRT mode
{                       BTN_CLIPPLANE_VRT_ROT_HOR_CW    2056   autorepeat push button for
{                                                              rotating the clip plane
{                                                              around the horizontal middle
{                                                              axis clockwise in VRT mode
{                       BTN_CLIPPLANE_VRT_ROT_HOR_CCW   2057   autorepeat push button for
{                                                              rotating the clip plane
{                                                              around the horizontal middle
{                                                              axis counter-clockwise in VRT
{                                                              mode
{                       BTN_CLIPPLANE_VRT_ROT_VER_CW    2058   autorepeat push button for
{                                                              rotating the clip plane
{                                                              around the vertical middle
{                                                              axis clockwise in VRT mode
{                       BTN_CLIPPLANE_VRT_ROT_VER_CCW   2059   autorepeat push button for
{                                                              rotating the clip plane
{                                                              around the vertical middle
{                                                              axis counter-clockwise in VRT
{                                                              mode
{                       BTN_CLIPPLANE_ENABLE            2060   toggle button for enabling
{                                                              the clip plane
{                       BTN_CLIPPLANE_ALIGN             2061   pushbutton for align the
{                                                              clip-plane to the selected
{                                                              segment
{                       BTN_WORKMODE_SIMPLE             2062   radio button to switch to
{                                                              simple view
{                       BTN_WORKMODE_ADVANCED           2063   radio button to switch to
{                                                              advanced view
{                       BTN_WORKMODE_REGIST             2064   radio button to switch to
{                                                              registration view
{                       BTN_APL_SELECT                  2201   button related to the
{                                                              "AppLink menu"
{                       BTN_APL_ACTIVATE                2202   button related to the
{                                                              "AppLink menu"
{                       BTN_APL_CONF_SWITCH_AFTER_XRAY  2203   button related to AppLink
{                                                              menu
{          Dimension: none

{ITEM_STATE state of the UI element
{          Type:  Enum8     (DEC)
{          Range: 0 ... 5
{                       NORMAL            1   This TUI Button should be normally visible.
{                       HIGHLIGHTED       2   This TUI button should be highlighted
{                       DIMMED            3   This TUI button should be dimmed.
{                       HIDDEN            4   This TUI Button should be hidden.
{                       DIMMED_HIGHLIGHT  5   Button is highlighted but not selectable
{          Dimension: none

{PARAM_8 optional parameter
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


STV_PARA

Object: STV_PARA ___ID: 038E

Description: setting up video parameters; sent from XCU to video camera
Sender     :   XCU
Receiver   :   FLC_TV
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

VBLNK_LEV blanking lever (only for tube cameras)
          Type:  Integer16     (DEC)
          Range: -1000 ... 1000
          Dimension: mV

GAMMA gamma curve
          Type:  Byte     (DEC)
          Range: 0 ... 64
                     ACS_GAM_CURVE_00  0
                     ACS_GAM_LOG_100   1    log / 100
                     ACS_GAM_03_100    2    0.3 / 100
                     ACS_GAM_04_100    3
                     ACS_GAM_05_100    4
                     ACS_GAM_05_90     5
                     ACS_GAM_05_80     6
                     ACS_GAM_05_70     7
                     ACS_GAM_05_60     8
                     ACS_GAM_06_100    9
                     ACS_GAM_06_90     10
                     ACS_GAM_06_80     11
                     ACS_GAM_06_70     12
                     ACS_GAM_06_60     13
                     ACS_GAM_07_100    14
                     ACS_GAM_07_90     15
                     ACS_GAM_07_80     16
                     ACS_GAM_07_70     17
                     ACS_GAM_07_60     18
                     ACS_GAM_10_100    19   1.0 / 100
                     ACS_GAM_IIFD1     20   curve for II or FD
                     ACS_GAM_IIFD2     21
                     ACS_GAM_IIFD3     22
                     ACS_GAM_IIFD4     23
                     ACS_GAM_IIFD5     24
                     ACS_GAM_IIFD6     25
                     ACS_GAM_IIFD7     26
                     ACS_GAM_IIFD8     27
                     ACS_GAM_IIFD9     28
                     ACS_GAM_IIFD10    29
                     ACS_GAM_CURVE_30  30
                     ACS_GAM_CURVE_31  31
                     ACS_GAM_CURVE_32  32
                     ACS_GAM_CURVE_33  33
                     ACS_GAM_CURVE_34  34
                     ACS_GAM_CURVE_35  35
                     ACS_GAM_CURVE_36  36
                     ACS_GAM_CURVE_37  37
                     ACS_GAM_CURVE_38  38
                     ACS_GAM_CURVE_39  39
                     ACS_GAM_CURVE_40  40
                     ACS_GAM_CURVE_41  41
                     ACS_GAM_CURVE_42  42
                     ACS_GAM_CURVE_43  43
                     ACS_GAM_CURVE_44  44
                     ACS_GAM_CURVE_45  45
                     ACS_GAM_CURVE_46  46
                     ACS_GAM_CURVE_47  47
                     ACS_GAM_CURVE_48  48
                     ACS_GAM_CURVE_49  49
                     ACS_GAM_CURVE_50  50
                     ACS_GAM_CURVE_51  51
                     ACS_GAM_CURVE_52  52
                     ACS_GAM_CURVE_53  53
                     ACS_GAM_CURVE_54  54
                     ACS_GAM_CURVE_55  55
                     ACS_GAM_CURVE_56  56
                     ACS_GAM_CURVE_57  57
                     ACS_GAM_CURVE_58  58
                     ACS_GAM_CURVE_59  59
                     ACS_GAM_CURVE_60  60
                     ACS_GAM_CURVE_61  61
                     ACS_GAM_CURVE_62  62
                     ACS_GAM_CURVE_63  63
                     ACS_GAM_CURVE_64  64
          Dimension: none

SPITZ Peak value reduction (only for tube cameras)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SPITZ_LEV Threshold for peak value reduction (only for tube cameras).
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

VORLI bias light (only for tube cameras)
          Type:  Byte     (DEC)
          Range: 1 ... 2
                     NIEDRIG  1   low
                     HOCH     2   high
          Dimension: none

FSMODE video mode (only for tube cameras)
          Type:  Enum8     (DEC)
          Range: 1 ... 8
                     NAMZZ                     1
                     NAOZZ                     2
                     PA                        3
                     LA_2_LANGSAM_ABTASTUNG    4
                     LA_3_LANGSAM_ABTASTUNG    5
                     LA_4_LANGSAM_ABTASTUNG    6
                     LA_5_LANGSAM_ABTASTUNG    7
                     HZA_HOCHZEILEN_ABTASTUNG  8
          Dimension: none

AVR automatic gain control
          Type:  Enum8     (DEC)
          Range: 1 ... 3
                     ACS_AVR_ON    1   AGC on
                     ACS_AVR_OFF   2   AGC off
                     ACS_AVR_HAND  3   AGC off; predefined fixed gain
          Dimension: none

SPITZ_2 Peak value reduction 2 (only for tube cameras)
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     AUS  0   off
                     EIN  1   on
          Dimension: none

SPITZ_LEV_2 Threshold for peak value reduction 2 (only for tube cameras).
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none


SVCUNAHBED

Object: SVCUNAHBED ___ID: 00C9

Description: VideoManager control; send from XCU to VCU
Sender     :   XCU
Receiver   :   VCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

FKTSCODEVCU function code for VideoManager control
          Type:  Enum16     (DEC)
          Range: 650 ... 680
                     STORE_VIDEO_ENDO_IMAGE  650   this command instructs VideoManager to
                                                   store the image being currently shown
                                                   (i.e. to send it via DICOM to Image
                                                   System)
                     SWITCH_NEXT_INPUT       651   this command instructs VideoManager to
                                                   switch to next input channel
                     SCAN_INPUT_SIGNALS      652   used to instruct VideoManager to scan for
                                                   and adapt to signals on all input
                                                   channels (1=start, 0=abort)
                                                   also used to show status of scanning
                                                   (1=busy, 0=ready)
                     SHOW_PIP                653   show picture in picture
                     SELECT_INPUT            654   select a specific input (number given in
                                                   PARAM)
                                                   range is 0-13
                     SWITCH_KVM              680   switch KVM between FLC and ApplHostPC
                                                   (used in surgery)
                                                   0=FLC; 1=ApplicationHosting PC;
          Dimension: none

PARAM content and meaning of this parameter depends on FKTSCODExxx or ANZCODE
(for some specific defines see PARAM_32 in sBedGen2)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none


SVERSTELLUNG

Object: SVERSTELLUNG ___ID: 0322

Description: manual setting of collimators; sent from XCU to collimators
Sender     :   XCU
Receiver   :   CCU-IF   CCU-IF2   SM_A
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3Obs and SharpfinObs

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

BLENDENANZAHL Amount of collimators
          Type:  Count     (CNT)
          Range: 0 ... 16
          Dimension: number of data blocks

{BLENDENAUSWAHL Type of collimator
{          Type:  Byte     (DEC)
{          Range: 1 ... 19
{                       HOEHENBLENDE            1    height
{                       BREITENBLENDE           2    width
{                       IRIS                    3
{                       FINGER                  4    finger wedge
{                       KEILBLENDE_1            5    wedge 1
{                       KEILBLENDE_2            6    wedge 2
{                       SQUARE_LAMELLA          8    fixed square collimator (for surgery
{                                                    system)
{                       IMAGE_LAMELLA           9    rotatable square collimator (used in
{                                                    surgery system)
{                       SLOT_LAMELLA_1          10   first leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_2          11   second leaf of slot collimator for
{                                                    surgery
{                       SLOT_LAMELLA_1_2        12   both leafs of slot collimator
{                                                    synchronously
{                       ACS_ASYM_HEIGHT_OFFSET  17   Vertical offset for asymmetrical
{                                                    collimation.
{                       ACS_ASYM_WIDTH_OFFSET   18   Horizontal offset for asymmetrical
{                                                    collimation.
{          Dimension: none

{VERSTELLRICHTUNG Moving direction
{          Type:  Byte     (DEC)
{          Range: 1 ... 12
{                       VERSTELLUNG_POS  1    positive linear movement
{                       VERSTELLUNG_NEG  2    negative linear movement
{                       DREHUNG_POS      11   start/stop turning the collimator clockwise
{                       DREHUNG_NEG      12   start/stop turning the collimator
{                                             counterclockwise
{          Dimension: none

{VERSTELLAKTION Move collimator(s)
{          Type:  Byte     (DEC)
{          Range: 1 ... 2
{                       VERSTELLUNG_STOP   1
{                       VERSTELLUNG_START  2
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


SVOLUMEREGLIST

Object: SVOLUMEREGLIST ___ID: 0439

Description: list entries for volume registration list (used in surgery by VDM)
Sender     :   FLC
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00) and DIRECT(01)
Systems    :  TRUMF

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

NO_STRING_LIST_LONG number of strings with fix length
          Type:  Dcount     (CNT)
          Range: 0 ... 8
          Dimension: none

{STRING_INDEX Index of this string in the list
{          Type:  Word     (DEC)
{          Range: 1 ... 65534
{          Dimension: none

{STRING_FIX_LONG string with a fix length (87 char unicode)
{          Type:  String16 [ 87 ]     (ASCII)
{          Range: 174 ... 174
{          Dimension: unicode


SZOOM

Object: SZOOM ___ID: 04BC

Description: XCU instructs the subsystem that executes the zoom (Image System ->
              ImageChain->Detector) to change the zoom format
Sender     :   XCU
Receiver   :   UIS
Mode       :  FUNCTIONAL(00)
Systems    :  RadFluoro

List of Parameters:

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


TelegramsA

 Anlage: SharpfinObs Version: E62P

<numerical order>

All objects: in alphabetical order

0BB9 ADATE                       02CB ISTATABSCHALT               2511 SH_PREP
02A7 AFDAUFNPOS                  02C9 ISTATUSGENAUFN              1013 SH_PRE_PRO_PAR
0BD6 AINFOCOMP                   0BCE ISTATUSREPORT               2297 SH_PROG_NAME
0019 AISTWERTE                   0197 ISTELLUNG                   180C SH_RADIATION
0009 AKENNDATEN                  008B ISTEPANZ                    1311 SH_READY
0F0B APASSWORT                   02C1 ISTRAHLERWAHL               1511 SH_SEARCH_RUN
0BD4 ASERVBETRIEB                02CA ISTRAHLGAUFN                1824 SH_SERVICE_WF
0BBE ASERVINIT                   02CC ISTRAHLGDL                  1031 SH_SKELMAL
02D0 ASTRFR                      0081 ISTRMANANZ                  11A3 SH_SS
032D ASUCHLAUF                   032F ISUCHLAUF                   100A SH_STPAR_RFP
0432 A_POWER_RESET               008C ISYSTEMANZ                  100B SH_STPAR_TUI
E800 CAN_FILTER                  0017 ITESTCMD                    2234 SH_UI_IMAGE
E000 CAN_NMT_MODULE_CONTROL      025E ITISCHPOS                   2205 SH_UI_TABCARD
E080 CAN_SYNC                    0085 ITOMOANZ                    2232 SH_UI_XCU
9406 CLIENT_DATA_RP              03CA IUGENLOG                    1312 SH_VERSION
9405 CLIENT_DATA_RQ              00CB IVCUBEDANZ                  1317 SH_VERSION_CHECK
9603 CONNECTION                  00CA IVCUNAHBED                  0007 SINIT
9204 DUMMY_MSG                   02DE IWATERVALACQ                02BD SIONDATEN
2914 ERRORLOG_OFF                0032 IXCU_INFO_STATUS            012D SIRIS
2913 ERRORLOG_ON                 007F IXRAY                       000B SJUSTAGECMD
9201 ERROR_MSG                   00B2 IXRPT                       027A SKALIBRIERUNG
9501 ERR_INFO                    04BB IZOOM                       01F5 SKASSPOS
101C I3DPARAMS                   04BA IZOOMANZ                    0334 SLICHTVISIER_2
01B7 IACSS                       0433 I_POWER_RESET               02CF SLIHVERZ
0099 IALLGANZ                    2912 LCM_OFF                     0320 SLIMIT
025D IANLBEREIT                  2911 LCM_ON                      02E8 SMAGN
0257 IANLBEREIT2                 9301 MONITOR_OFF                 01A2 SMYELO
0276 IASUSTATUS                  9300 MONITOR_ON                  00A5 SNACHANZLOESCHEN
02C4 IAUFNDATEN                  1333 REP_BEEP                    02B1 SORGANSELECT
02C8 IAUFNSTATUS                 0027 REP_CONFIRM                 02AF SORGDATEN
0084 IAUFNZANZ                   1331 REP_ERR                     02BA SORGPOSITIONS
00A8 IBEDPOWERREQ                0026 REP_SYS_MSG                 01AE SORTHO
019B IBETRIEBSART                1332 REP_TRACE                   01B0 SORTHOACTSIZE
019A IBEWEGUNG2                  1342 RJ_OBJECT                   02D2 SPATWECHSEL
0386 IBILD                       102A RQ_DET_POS                  02B3 SPROGRAMLIST
01F8 IBILDFORMAT                 1014 RQ_DET_TEMP                 00AB SPULTUPDATE
0020 IBINOK                      0430 RQ_FDR_DATA                 032A SRASTER
0323 IBLENDE                     1020 RQ_FDR_VERSION_CHECK        02CE SRAUMLICHT
026B IBLENDEANZ                  1821 RQ_IMAGE                    02BF SREGELDATEN
0331 IBLENDENDATA                1341 RQ_OBJECT                   03BF SREGELDATEN2
00A4 IBLENDESELANZ               101B S3DPARAMS                   04BF SREGELDATENDL
019F IBREMSUNG                   026D SACQREQ                     02D5 SREGELSTOP
02DB IBSIGNAL                    02DA SALTERNATIVELIST            0012 SRESET
012E IBV                         000D SAPPLIKATION                0014 SRESETFEHLER
0080 IBVFSANZ                    02C2 SAUFNAUSL                   0192 SSCHICHT
02F4 ICPEXI                      02BC SAUFNDATEN                  0BBB SSELECTCOMP
00B0 IDAPVALUE                   006F SAUSLBED                    0BE0 SSERVBETRIEB
0BC8 IDATE                       006E SBEDALLG                    0BE3 SSERVBETRIEB2
03B8 IDETEKTORSTATUS             006C SBEDBVFS                    0BC5 SSERVDLDCMD
03B7 IDETNR                      006D SBEDDFR                     0BC6 SSERVDLDDATA
02B7 IDEXI                       006B SBEDEINBL                   0BC4 SSERVDOWNLOAD
00AD IDFPANZ2                    0066 SBEDGEN                     0BC2 SSERVERRORLOG
026E IDFRABSCHALTUNG             00B1 SBEDGEN2                    0BBD SSERVINIT
02B6 IDFRALLGANZ2                0064 SBEDGG                      0BBF SSERVJUSTCMD
00A6 IDFRBEDANZ                  0065 SBEDKS                      0BC0 SSERVTESTCMD
0268 IDFRNAHBED                  0069 SBEDORG                     01AC SSPINE
00AF IDFRPATPOS                  0067 SBEDSP                      0195 SSPRITZE
0283 IDFRPOWERREQ                006A SBEDSTRM                    0193 SSTELLUNG
025A IDFRSTATUS                  0068 SBEDSYS                     02C0 SSTRAHLERWAHL
0261 IDFRSTATUS2                 0075 SBEDTOMO                    032E SSUCHLAUF
007B IDLANZ                      00C8 SBEDVCU                     02F2 STEACHINGMODEAUSL
02D9 IDLDATEN001                 0070 SBEDZOOM                    01F7 STEILUNG
007C IDLISTANZ                   000E SBETRIEB                    0016 STESTCMD
02D7 IDLPULSEDDATEN              0191 SBETRIEBSART                02EA STUIBUTTONS_2
00A3 IDLPULSEDISTANZ             0190 SBEWEGUNG                   038E STV_PARA
02C7 IDLSTATUS                   0384 SBILD                       1019 ST_3D_PARAMS
02B9 IDOSEREQUESTED              0321 SBLENDENPOS                 101D ST_ACSOS_CMD
02B8 IERRORLOG2                  019E SBREMSUNG                   1032 ST_ACTUATOR
0022 IERRORLOGSYNC               012C SBV                         1803 ST_ADJUST
00A0 IERWALLGANZ                 0BB8 SCLOSE                      0436 ST_ADJUST_WLAN
0083 IERWKASSANZ                 0BBA SDATE                       1211 ST_COLPAR_A
02D4 IERWSESTATUS                03B6 SDETEKTORSTART              1212 ST_COLPAR_B
0005 IFEHLER                     026A SDFRBLENDENDATA             1217 ST_COLPAR_OGP_A
0006 IFEHLER2                    0272 SDFRFOBVA                   1801 ST_CONFIG
0023 IFEHLERANZ2                 0273 SDFRFOTA                    02AE ST_CP_DATA
0015 IFEHLERQUIT                 0260 SDFRNAHBED2                 2892 ST_DATA_2
0011 IFESTATUS                   0262 SDFRPATWECHSEL              2893 ST_DATA_3
0324 IFFA                        0282 SDFRPOWERREQ                2894 ST_DATA_CHUNK
0329 IFILTER                     0270 SDFRREDBF                   1809 ST_DATA_TRANS
02B5 IFILTERANZ                  0265 SDFRSERIE                   1805 ST_DIAG
03A3 IFLUOROACTANZ               02C3 SDLAUSL                     1807 ST_DOWNLOAD
02DC IFLUORODATA                 02B4 SDLDATA                     101F ST_DOWNLOAD_FD
008E IGENANZ                     02BE SDLDATEN                    1361 ST_DTEXT
03C9 IGENREADY                   0003 SDLDCMD                     1016 ST_ENTER_CALIB
02C5 IGENSTATUS2                 0004 SDLDDATA                    1028 ST_EXAM_STUDY
0429 IGGAKTPOS2                  02B0 SDLPROGDATEN                1026 ST_EXPORT_FDDATA
0086 IGGANZ2                     000F SDOWNLOAD                   0438 ST_FDR_DATA
01A0 IGGFFA                      9302 SEND_LIST                   1022 ST_FD_CONNECT
01A4 IGGFOTA                     02B2 SEXAMLIST                   1241 ST_FILTER_A
01A6 IGGPERISCAN                 E09C SE_EMERGENCY                1242 ST_FILTER_B
01AA IGGPOS                      E71C SE_NMT_ERROR_CONTROL        1512 ST_GRID
0001 IIDENT                      E21C SE_PDO1_RX                  11B1 ST_IMG_INV
0BC9 IINFOCOMP                   E19C SE_PDO1_TX                  1024 ST_IMPORT_FDDATA
0008 IINIT                       E31C SE_PDO2_RX                  04BE ST_KVCURVE
008F IIONANZ                     E29C SE_PDO2_TX                  1321 ST_MODE
018F IIONANZ2                    E39C SE_PDO3_TX                  100E ST_ORGAN_PROG
002E IIONTVAL                    E61C SE_SDO_RX                   1008 ST_ORTHO
012F IIRIS                       E59C SE_SDO_TX                   1121 ST_PAT
001A IISTWERTEQUIT               0095 SFANZLOESCHEN               1012 ST_PRE_PRO_PAR
000C IJUSTAGECMD                 0328 SFILTER                     1315 ST_PWR_OFF
0082 IKASSANZ                    0018 SFKREKONFIG                 180B ST_RADIATION
01F4 IKASSDATEN                  03BE SFLUORODATA                 0435 ST_REMOVE_IMGS
01F6 IKASSPOS                    02E5 SGENMODE                    1510 ST_SEARCH_RUN
000A IKENNDATEN                  0427 SGGAKTPOS                   1823 ST_SERVICE_WF
0079 IKOLLAUFL                   01B9 SGGNAVIPOS                  1030 ST_SKELMAL
019D IKOLLISION                  01A5 SGGPERISCAN                 11A1 ST_SS
02E9 IMAGN                       01A9 SGGPOS                      229A ST_STATE
01A3 IMYELO                      0BC7 SGROUP                      2612 ST_STEP
0090 INACHANZ                    101A SH_3D_PARAMS                1009 ST_STPAR_RFP
0002 INETZAUFNAHME               1804 SH_ADJUST                   1811 ST_SYSTEM_STATE
2901 INIT_CONNECTION             1213 SH_COLPAR_A                 1360 ST_TEXT_LONG
9200 INIT_MSG                    1214 SH_COLPAR_B                 1161 ST_ZOOM
2902 INLIST_ENH                  2526 SH_COL_A                    00C9 SVCUNAHBED
2903 INLIST_RED                  1035 SH_COMP_STATE               0322 SVERSTELLUNG
02D8 INOTSTROM                   1802 SH_CONFIG                   0439 SVOLUMEREGLIST
0269 IOGPSTORE                   1018 SH_CUR_DET_DATA             04BC SZOOM
00AE IORGANANZ2                  180A SH_DATA_TRANS               0434 S_POWER_RESET
01B8 IORGPOSITIONS               102B SH_DET_POS                  232D TEST_3DLOADCALC
01AD IORTHO                      1015 SH_DET_TEMP                 2329 TEST_ADRDATEN
01AF IORTHOACTSIZE               1806 SH_DIAG                     232C TEST_APSDATEN
0F10 IPASSWORT                   1387 SH_DISP_ICON                232A TEST_EIN_AUS
02D3 IPERIPHASE                  1385 SH_DISP_LONG                2328 TEST_WWDATEN
009A IPRINTAUFN                  1386 SH_DISP_VALUE               9402 TOPO_NET_RP
032B IRASTER                     1808 SH_DOWNLOAD                 9401 TOPO_NET_RQ
0333 IRASTERANZ                  1017 SH_ENTER_CALIB              9404 TOPO_VERI_RP
02D6 IREGELSTOP                  1514 SH_ERROR_RESET              9403 TOPO_VERI_RQ
0259 IREGSTPMARKDFR              1029 SH_EXAM_STUDY               9704 TRACELOG_OFF
007D IROEANZ                     1027 SH_EXPORT_FDDATA            9703 TRACELOG_ON
0199 ISCHICHTANTR                0431 SH_FDR_DATA                 9203 TURN_OFF
0198 ISCHICHTSCHUSS              1021 SH_FDR_VERSION_CHECK        9202 TURN_ON
0BD5 ISERVBETRIEB                1023 SH_FD_CONNECT               2416 UIPACTION
0BE1 ISERVBETRIEBQUIT            1243 SH_FILTER_A                 2219 UI_COLLIMATOR
0BCA ISERVINIT                   1244 SH_FILTER_B                 2233 UI_COORDINATES
0BCB ISERVJUSTCMD                1011 SH_GLOB_GAIN                1005 UI_SCU
0BD2 ISERVQUIT                   1513 SH_GRID                     2285 UI_SLIDER
0BD3 ISERVSTORE                  1822 SH_IMAGE                    2238 UI_STRING
0BCC ISERVTESTCMD                1025 SH_IMPORT_FDDATA            2204 UI_TABCARD
02C6 ISESTATUS                   2299 SH_LIST                     2231 UI_XCU
01B6 ISOD                        1322 SH_MODE                     02F8 VAUFNDATEN
0092 ISPANZ                      100F SH_ORGAN_PROG               02F9 VIONDATEN
019C ISPRITZE                    1234 SH_ORTHO                    FFFE _GEN_DEFINITIONS_RFP
025B ISPRITZEMARKDFR             2623 SH_POSITION                 FFFD _GEN_DEFINITIONS_SHARPFIN


TEST_3DLOADCALC

Object: TEST_3DLOADCALC ___ID: 232D

Description: test object to monitor load calcuation for Mode3D
Sender     :   XCU
Receiver   :   ACSOS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEM ID of selected System:
in surgery: 1=normal  2=cassette
in TRUMF:
No: dRF:          Ysio:            dTF:               Lum RF:       G1:
 1 Lum DFR       Table FD         Agile DFR          RF DFR        DFR Table
 2 Lum Tomo      Wall FD          Free Cass Tub1     RF Cass       DFR Wall
 3 Lum Ortho     Tomo FD          Free FD Tube 1     RF Wall       Ortho Table
 4 Free exp      Ortho (wall)     3D Wall FD         RF Free exp   Ortho Wall
 5 Wall FD       Free Cass        3D Wall Cass       RF Tomo DFR   Bed
 6 Wall Cass     Wall Cass        3D Free FD Tub2    RF Tomo Cass  Free MobFD
 7 3D Wall FD    Free Mobile FD   3D Free Cass Tub2      -         Mode3D
 8 3D Mobile FD  Table FD pulled  3D Ortho               -         SkelMal
 9 3D Wall Cass  Wall FD flipped  Table FD Tube 2        -         Ortho lat
10 3D Free Cass  Table Cass       Table Cass Tube2       -           -
11 3D Ortho      Ortho Table      Table FD pulled Tub2   -           -
12 Free MobFD Tub1   -            3D Table Ortho         -           -
note: Uroskop has just system no1 = Uro DFR
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

WW1 Water equivalent value resulting from fluoro1 (value is given w/o offset, so that 80 equates to 20 cm WEV)
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.25 BP

WW2 Water equivalent value resulting from fluoro2 (value is given w/o offset, so that 80 equates to 20 cm WEV)
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.25 BP

MIN_MA minimal current
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.1 mA

MAX_MA maximal current
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.1 mA

MIN_MS minimal pulse time
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.1 ms

MAX_MS maximal pulse time
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.1 ms

REQUIRED_POWER forecasted average power of a 3D scan with other parameters in this telegram
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 10W

AVAILABLE_POWER available power the tube can provide, given the scene duration and duty cycle
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 10W

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

PULSEPROZ Duty cycle
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 0.1 %

DOSIS_BP Dose in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 0.25 BP

RASTERKORR_BP Grid correction in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

FILTERKORR_BP Filter attenuation at the current voltage in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

GXKORR_BP GX correction in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

UNDER_EXP_CNT how many frames are under exposed
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: cnt

OVER_EXP_CNT how many frames are over exposed
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


TEST_ADRDATEN

Object: TEST_ADRDATEN ___ID: 2329

Description: exposure data calculation
Sender     :   XCU
Receiver   :   ACSOS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEM ID of selected System:
in surgery: 1=normal  2=cassette
in TRUMF:
No: dRF:          Ysio:            dTF:               Lum RF:       G1:
 1 Lum DFR       Table FD         Agile DFR          RF DFR        DFR Table
 2 Lum Tomo      Wall FD          Free Cass Tub1     RF Cass       DFR Wall
 3 Lum Ortho     Tomo FD          Free FD Tube 1     RF Wall       Ortho Table
 4 Free exp      Ortho (wall)     3D Wall FD         RF Free exp   Ortho Wall
 5 Wall FD       Free Cass        3D Wall Cass       RF Tomo DFR   Bed
 6 Wall Cass     Wall Cass        3D Free FD Tub2    RF Tomo Cass  Free MobFD
 7 3D Wall FD    Free Mobile FD   3D Free Cass Tub2      -         Mode3D
 8 3D Mobile FD  Table FD pulled  3D Ortho               -         SkelMal
 9 3D Wall Cass  Wall FD flipped  Table FD Tube 2        -         Ortho lat
10 3D Free Cass  Table Cass       Table Cass Tube2       -           -
11 3D Ortho      Ortho Table      Table FD pulled Tub2   -           -
12 Free MobFD Tub1   -            3D Table Ortho         -           -
note: Uroskop has just system no1 = Uro DFR
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

WW Water equivalent value calculated out fluoro data. This value has an offset of 80 quarter EP, so that 20 cm WEV is shown in this telegram as 160
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.25 BP

MODE Chosen exposure mode
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     EINZELBILD  0   single frame
                     SERIE       1   series
          Dimension: none

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

APS sum of exposure points
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.25 BP

DOSIS_BP Dose in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 0.25 BP


TEST_APSDATEN

Object: TEST_APSDATEN ___ID: 232C

Description: exposure point protocol
Sender     :   XCU
Receiver   :   ACSOS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEM ID of selected System:
in surgery: 1=normal  2=cassette
in TRUMF:
No: dRF:          Ysio:            dTF:               Lum RF:       G1:
 1 Lum DFR       Table FD         Agile DFR          RF DFR        DFR Table
 2 Lum Tomo      Wall FD          Free Cass Tub1     RF Cass       DFR Wall
 3 Lum Ortho     Tomo FD          Free FD Tube 1     RF Wall       Ortho Table
 4 Free exp      Ortho (wall)     3D Wall FD         RF Free exp   Ortho Wall
 5 Wall FD       Free Cass        3D Wall Cass       RF Tomo DFR   Bed
 6 Wall Cass     Wall Cass        3D Free FD Tub2    RF Tomo Cass  Free MobFD
 7 3D Wall FD    Free Mobile FD   3D Free Cass Tub2      -         Mode3D
 8 3D Mobile FD  Table FD pulled  3D Ortho               -         SkelMal
 9 3D Wall Cass  Wall FD flipped  Table FD Tube 2        -         Ortho lat
10 3D Free Cass  Table Cass       Table Cass Tube2       -           -
11 3D Ortho      Ortho Table      Table FD pulled Tub2   -           -
12 Free MobFD Tub1   -            3D Table Ortho         -           -
note: Uroskop has just system no1 = Uro DFR
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

WW Water equivalent value calculated out fluoro data. This value has an offset of 80 quarter EP, so that 20 cm WEV is shown in this telegram as 160
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.25 BP

KORRIONANZ Blackening correction
          Type:  Integer16     (DEC)
          Range: -16 ... 16
          Dimension: 0.25 BP

RASTERKORR_BP Grid correction in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

FILTERNR Filter number
          Type:  Byte     (DEC)
          Range: 0 ... 10
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

FILTERKORR_BP Filter attenuation at the current voltage in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

BVFAKORR_BP image intensifier SID correction
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

DOSIS_BP Dose in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: 0 ... 1000
          Dimension: 0.25 BP

GXKORR_BP GX correction in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

SCHRAEGKORR_BP Tilt angle correction
          Type:  Integer16     (DEC)
          Range: 0 ... 255
          Dimension: 0.25 BP

WWABGLEICH Water equivalent correction
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

APS sum of exposure points
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: 0.25 BP


TEST_EIN_AUS

Object: TEST_EIN_AUS ___ID: 232A

Description: turn on test telegram
Sender     :   ACSOS
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  TRUMF and RadFluoro

List of Parameters:

TEST turn-on of water equivalent value test telegrams
          Type:  Byte     (DEC)
          Range: 0 ... 1
          Dimension: none


TEST_WWDATEN

Object: TEST_WWDATEN ___ID: 2328

Description: water equivalent value
Sender     :   XCU
Receiver   :   ACSOS
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SYSTEM ID of selected System:
in surgery: 1=normal  2=cassette
in TRUMF:
No: dRF:          Ysio:            dTF:               Lum RF:       G1:
 1 Lum DFR       Table FD         Agile DFR          RF DFR        DFR Table
 2 Lum Tomo      Wall FD          Free Cass Tub1     RF Cass       DFR Wall
 3 Lum Ortho     Tomo FD          Free FD Tube 1     RF Wall       Ortho Table
 4 Free exp      Ortho (wall)     3D Wall FD         RF Free exp   Ortho Wall
 5 Wall FD       Free Cass        3D Wall Cass       RF Tomo DFR   Bed
 6 Wall Cass     Wall Cass        3D Free FD Tub2    RF Tomo Cass  Free MobFD
 7 3D Wall FD    Free Mobile FD   3D Free Cass Tub2      -         Mode3D
 8 3D Mobile FD  Table FD pulled  3D Ortho               -         SkelMal
 9 3D Wall Cass  Wall FD flipped  Table FD Tube 2        -         Ortho lat
10 3D Free Cass  Table Cass       Table Cass Tube2       -           -
11 3D Ortho      Ortho Table      Table FD pulled Tub2   -           -
12 Free MobFD Tub1   -            3D Table Ortho         -           -
note: Uroskop has just system no1 = Uro DFR
          Type:  Byte     (DEC)
          Range: 1 ... 12
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

WW Water equivalent value calculated out fluoro data. This value has an offset of 80 quarter EP, so that 20 cm WEV is shown in this telegram as 160
          Type:  Word     (DEC)
          Range: 0 ... 65534
          Dimension: 0.25 BP

KV_BP Voltage in exposure points
          Type:  Integer16     (DEC)
          Range: 0 ... 255
          Dimension: 0.25 BP

MA_BP current in exposure points
          Type:  Integer16     (DEC)
          Range: 0 ... 255
          Dimension: 0.25 BP

DLABW difference of the current X-ray data to the desired dose
          Type:  Integer16     (DEC)
          Range: -40 ... 40
          Dimension: 0.25 BP

DOSISL_BP Dose rate in exposure points
          Type:  Integer16     (DEC)
          Range: 0 ... 255
          Dimension: 0.25 BP

BVFAKORR_BP image intensifier SID correction
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

RASTERKORR_BP Grid correction in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

GXKORR_BP GX correction in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

FILTERKORR_BP Filter attenuation at the current voltage in 1/4 exposure points
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP

WWABGLEICH Water equivalent correction
          Type:  Integer16     (DEC)
          Range: -255 ... 255
          Dimension: 0.25 BP


TOPO_NET_RP

Object: TOPO_NET_RP ___ID: 9402

Description: Reply of network topology. It shows the internal clients known by the server.
              Sent with MODE = SERVICE (4); it must not be in the inlist.
Sender     :   AXN
Receiver   :   ACSOS   PMS
Mode       :  SERVICE(04)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

TCPIP_ADDRESS TCP/IP-address of a axcs server (e.g.: 0401010A == 10.1.1.4)
          Type:  Dword     (HEX)
          Range: 0x0 ... 0xFFFFFFFF
          Dimension: TCPIP Format

SW_VERS version of the loaded software, max 4 chars UNICODE
          Type:  String16 [ 4 ]     (ASCII)
          Range: 8 ... 8
          Dimension: unicode

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_CLIENTS number of clients
          Type:  Dcount     (CNT)
          Range: 0 ... 120
          Dimension: none

{AP_ID application process ID (see complete list is attached to the list of all objects)
{          Type:  Byte     (HEX)
{          Range: 0x0 ... 0xFF
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


TOPO_NET_RQ

Object: TOPO_NET_RQ ___ID: 9401

Description: network topology request; has to be sent with MODE = SERVICE (4)
Sender     :   ACSOS   PMS
Receiver   :   AXN
Mode       :  SERVICE(04)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


TOPO_VERI_RP

Object: TOPO_VERI_RP ___ID: 9404

Description: Reply of network topology. It shows the external clients known by the server.
              Sent with MODE = SERVICE (4); it must not be in the inlist
Sender     :   AXN
Receiver   :   ACSOS   PMS
Mode       :  SERVICE(04)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_CLIENTS number of clients
          Type:  Dcount     (CNT)
          Range: 0 ... 120
          Dimension: none

{AP_ID application process ID (see complete list is attached to the list of all objects)
{          Type:  Byte     (HEX)
{          Range: 0x0 ... 0xFF
{          Dimension: none

{DUMMY3
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY4
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none

{DUMMY5
{          Type:  Byte     (DEC)
{          Range: 0 ... 255
{          Dimension: none


TOPO_VERI_RQ

Object: TOPO_VERI_RQ ___ID: 9403

Description: request of network topology; has to be sent with MODE = SERVICE (4)
Sender     :   ACSOS   PMS
Receiver   :   AXN
Mode       :  SERVICE(04)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


TRACELOG_OFF

Object: TRACELOG_OFF ___ID: 9704

Description: Stop to send all objects to the trace logger; sent with MODE = TRACE (7)
Sender     :   UAL   XCU
Receiver   :   AXN
Mode       :  TRACE(07)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


TRACELOG_ON

Object: TRACELOG_ON ___ID: 9703

Description: Start to send all objects to the trace logger; sent with MODE = TRACE (7)
Sender     :   UAL   XCU
Receiver   :   AXN
Mode       :  TRACE(07)
Systems    :  TRUMF and AXN and RadFluoro
This object has no parameters


TURN_OFF

Object: TURN_OFF ___ID: 9203

Description: turn off message; sent with MODE = MESSAGE (2); it must not be in the inlist
Sender     :   AXN
Receiver   :   ALL
Mode       :  MESSAGE(02)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

NO_OBJECTS number of objects (the axnroot later than VC11E is able to handle max. 600 objects)
          Type:  Dcount     (CNT)
          Range: 0 ... 600
          Dimension: number of data blocks

{OBJECT_ID ID of the object
{          Type:  Word     (HEX)
{          Range: 0x0 ... 0xFFFE
{          Dimension: none


TURN_ON

Object: TURN_ON ___ID: 9202

Description: turn on message; sent with MODE = MESSAGE (2); it must not be in the inlist
Sender     :   AXN
Receiver   :   ALL
Mode       :  MESSAGE(02)
Systems    :  TRUMF and AXN and RadFluoro

List of Parameters:

NO_OBJECTS number of objects (the axnroot later than VC11E is able to handle max. 600 objects)
          Type:  Dcount     (CNT)
          Range: 0 ... 600
          Dimension: number of data blocks

{OBJECT_ID ID of the object
{          Type:  Word     (HEX)
{          Range: 0x0 ... 0xFFFE
{          Dimension: none


UI_COLLIMATOR

Object: UI_COLLIMATOR ___ID: 2219

Description: move the collimator manually (only RFU)
Sender     :
Receiver   :
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Sharpfin

List of Parameters:

VERSION_UICOLLIMATOR version of the object UI_COLLIMATOR
          Type:  Byte     (DEC)
          Range: 0 ... 255
                     ACS_V_UICOLLIMATOR  0   version from the beginning
          Dimension: none

LIGHT_LOC RFU only: light localizer
          Type:  Enum8     (DEC)
          Range: 0 ... 3
                     ACS_NO_INFORMATION  0
                     ACS_ON              1   On
                     ACS_OFF             2   Off
                     ACS_TOGGLE          3   toggle
          Dimension: none

MOVE_RE_WIDTH move rectangular collimator width with the defined speed, 0 means no movement
          Type:  Integer16     (DEC)
          Range: -100 ... 100
          Dimension: %

MOVE_RE_HEIGHT move rectangular collimator height with the defined speed, 0 means no movement
          Type:  Integer16     (DEC)
          Range: -100 ... 100
          Dimension: %

MOVE_OFFSET_X move rectangular collimator width with the defined speed, 0 means no movement
          Type:  Integer16     (DEC)
          Range: -100 ... 100
          Dimension: %

MOVE_OFFSET_Y move collimator offset Y with the defined speed, 0 means no movement
          Type:  Integer16     (DEC)
          Range: -100 ... 100
          Dimension: %

MOVE_IRIS move collimator iris with the defined speed, 0 means no movement
          Type:  Integer16     (DEC)
          Range: -100 ... 100
          Dimension: %

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


UI_COORDINATES

Object: UI_COORDINATES ___ID: 2233

Description: transfer x- and y-coordinates of pixels from UIP (RFU only)
Sender     :   TUI
Receiver   :   FLC
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

SEL_FUNC function to be selected;  all values are defined in an additional include file
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

COORD_X x coordinate
          Type:  Integer16     (DEC)
          Range: 0 ... 2047
          Dimension: pixel

COORD_Y y coordinate
          Type:  Integer16     (DEC)
          Range: 0 ... 2047
          Dimension: pixel


UI_SCU

Object: UI_SCU ___ID: 1005

Description: allows SITA to control functions of the SCU
Sender     :   TEST-SW
Receiver   :   SCU
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and RadFluoro

List of Parameters:

SCU_FUNC RFU only: functions selectable by the SCU
          Type:  Enum8     (DEC)
          Range: 0 ... 5
                     ACS_SF_NOT_DEF  0   not defined
                     ACS_SF_APS_ON   1   APS button pressed
          Dimension: none

SCU_FOOTSWITCH Artis only: footswitch pressed for a function controlled by SCU
          Type:  Enum8     (DEC)
          Range: 0 ... 1
                     ACS_FS_NOT_PRESSED  0   footswitch for hands-free movement not pressed
                     ACS_FS_PRESSED      1   footswitch for hands-free movement pressed in
                                             case of virtual biplane
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


UI_SLIDER

Object: UI_SLIDER ___ID: 2285

Description: slider function request
Sender     :   TUI
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF

List of Parameters:

SEL_FUNC function to be selected;  all values are defined in an additional include file
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

SLIDER_VAL current value of the slider
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


UI_STRING

Object: UI_STRING ___ID: 2238

Description: transfer a string from UI back to the host
Sender     :   TUI
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

OBJ_COUNT number of objects, 1..(n-1), -n (minus = last one)
          Type:  Integer16     (DEC)
          Range: -32767 ... 32767
                     ACS_ONLY_ONE_OBJECT  -1   only one object has to be sent
          Dimension: Object Number / Count

REF_OBJECT_ID ID of the object to which this list refers (e.g. UI_BSR=2201, UI_3DANGIO=2281, UI_OSD=2208)
          Type:  Word     (HEX)
          Range: 0x0 ... 0xFFFE
          Dimension: none

SEL_FUNC function to be selected;  all values are defined in an additional include file
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

NO_STRING_VAR number of elements, length of the complete string with variable parts
          Type:  Dcount     (CNT)
          Range: 0 ... 720
          Dimension: none

{STRING_VAR one element of a string that could be used with variable length (1 char unicode)
{          Type:  String16     (ASCII)
{          Range: 2 ... 2
{          Dimension: unicode


UI_TABCARD

Object: UI_TABCARD ___ID: 2204

Description: A tab card should be selected
Sender     :   TUI
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

TC_REQUESTED requested tab card
          Type:  Enum8     (DEC)
          Range: 1 ... 42
                     ACS_PREP              1
                     ACS_EXAM              2
                     ACS_POSTPROC          3
                     ACS_QUANT             4
                     ACS_FILMING           5
                     ACS_PHYSIOLOGIC       6
                     ACS_INSPACE           7
                     ACS_IVUSMAP           8    IVUS map
                     ACS_4D                9
                     ACS_RAD_POSITIONS     20   Device Positions Tabcard
                     ACS_RAD_TOMO          21   Tomo Tabcard
                     ACS_RAD_GENERATOR     22   Generator Tabcard
                     ACS_RAD_TAPE_MEASURE  23   Tape Measure Tabcard.
                     ACS_RAD_ORTHO         24   Ortho Tabcard
                     ACS_RAD_SETUP         25   setup tabcard
                     ACS_RAD_PANORAMA      26
                     ACS_RAD_TOPOGRAM      27
                     ACS_FLUORO_IMAGE      40   Image Tabcard
                     ACS_FLUORO_TOOLS      41   Tools Tabcard
                     ACS_FLUORO_SETUP      42   Setup Tabcard
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


UI_XCU

Object: UI_XCU ___ID: 2231

Description: selection at the UI panel
Sender     :   TUI
Receiver   :   TUI-IF
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and Rad3 and SharpfinObs

List of Parameters:

SEL_FUNC function to be selected;  all values are defined in an additional include file
          Type:  Word     (DEC)
          Range: 0 ... 65535
          Dimension: none

FUNC_PARAMS parameters of SEL_FUNC; all values are defined in an additional include file
          Type:  Set16     (HEX)
          Range: 0x0 ... 0xFFFF
          Dimension: it's a SET

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY4
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY5
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY6
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY7
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY8
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


UIPACTION

Object: UIPACTION ___ID: 2416

Description: ECC/TUI internal synchronization object
Sender     :   TUI
Receiver   :   TUI
Mode       :  FUNCTIONAL(00)
Systems    :  TRUMF and SharpfinObs

List of Parameters:

UIP_ACTION action that has to be synchronized
          Type:  Enum8     (DEC)
          Range: 1 ... 255
                     ACS_SOUND_ON        1   sound on
                     ACS_SOUND_OFF       2   sound off
                     ACS_SOUND_ONE_SHOT  3   the sound is only played once
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

UIP_PARAM1 UI platform parameter 1
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: none

UIP_PARAM2 UI platform parameter 2
          Type:  Integer32     (DEC)
          Range: 0 ... 2147483647
          Dimension: none


VAUFNDATEN

Object: VAUFNDATEN ___ID: 02F8

Description: verification of desired acquisition parameters
              sent by generator upon receiving sAufnDaten
Sender     :   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  RadFluoro and Rad3

List of Parameters:

TECHNIK exposure technique
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     _1_PUNKT_TECHNIK         1    1-pnt-technique (kV given, mA typically
                                                   max., generator switches off when dose
                                                   reported by AEC matches the one given in
                                                   sIonDaten)
                     _2_PUNKT_TECHNIK         2    2-pnt-technique (kV and mAs given; XCU
                                                   determines mA; generator switches off
                                                   when mAs reached)
                     _3_PUNKT_TECHNIK         3    3-pnt-technique (User determines kV, mAs,
                                                   ms manually)
                     _3_PUNKT_T_MIT_IONT      4    3-pnt-technique using AEC (User
                                                   determines dose as given value, mAs, ms
                                                   as limit; Generator receives dose, mAs
                                                   and ms as limit and will turn off X-ray
                                                   if one of the three limits is reached.)
                     DR_0_PUNKT_TECHNIK       10   First pulse is done in 1pnt technique
                                                   using AEC (compared to dose in
                                                   sIonDaten).
                                                   Subsequent pulses are done in
                                                   0-pnt-technique using DEXI (compared to
                                                   dose in iDoseRequested).
                     DUAL_ENERGY_HEI          21   Dual Energy technique for Ysio; Used for
                                                   x-ray parameter for the first shot
                     DUAL_ENERGY_LEI          22   Dual Energy technique for Ysio; used for
                                                   x-ray parameter for the second shot
                     DE_HEI_2_POINT           25   Dual Energy: High Energy Image parameters
                                                   for 2 point technique (for future use)
                     DE_LEI_2_POINT           26   Dual Energy: Low Energy Image parameters
                                                   for 2 point technique (for future use)
                     DFR_2PT_1PT_BSIG_NO_AEC  28   First pulse is done in 2-point technique
                                                   using the given kV/mAs.
                                                   Subsequent pulses are done in 0-point
                                                   technique using DEXI.
          Dimension: none

MODE Chosen exposure mode
          Type:  Byte     (DEC)
          Range: 0 ... 1
                     EINZELBILD  0   single frame
                     SERIE       1   series
          Dimension: none

KV Voltage for exposure
In sOrgDaten a value of 0 means "use parameter KENNL and determine the kV automatically"
          Type:  Integer16     (DEC)
          Range: 400 ... 1500
          Dimension: 0.1 kV

MA Current of fluoro or acquisition
          Type:  Word     (DEC)
          Range: 0 ... 20000
          Dimension: 0.1 mA

FOKUS selected focus of the tube
          Type:  Byte     (DEC)
          Range: 1 ... 4
                     KLEINER_FOKUS  1   small focus (more detailed image, but cannot stand
                                        so much power (e.g. 40 kW max)
                     GROSSER_FOKUS  2   large focus (more fuzzy image, but can stand more
                                        power (e.g. 80 kW))
                     _3_FOKUS       3   3rd focus, for usual micro-focus; not in use in
                                        XCS-systems
                     AUTOFOCUS      4   autofocus tries to use small focus as long as
                                        possible and switches automatically, if power
                                        increases due to more patient thickness or more dose
                                        to the large focus
          Dimension: none

PROZ The parameter will reduce the max electrical power (which is given by max power value for the selected focus) to the given percentage in order to enlarge the lifespan of the tube.
Thus for a given kV it allows to reduce the current in order to artificially prolong the pulse time (which replaces the former "reduced current" techniques 8 and 20)
          Type:  Byte     (DEC)
          Range: 10 ... 100
          Dimension: %

MAS in i-objects: (nominal) mAs value to be shown
in s-objects: mAs in case of 2 pnt tech. In case of other techniques this is the upper limit for mAs, that the generator should use, in case that any other tech (time or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 100200
          Dimension: 0.01 mAs

MS in i-objects: (nominal) ms value to be shown
in s-objects: In case of 3-pnt-technique and tomo this is the acquisition time, in case of other techniques this is the upper limit value, that the generator should use, in case that any other tech (mAs or dose) did not turn off radiation as supposed to do.
          Type:  Integer32     (DEC)
          Range: 0 ... 1000000
          Dimension: 0.1 ms

SZEIT Duration of series if parameter pulse is not equal 1
          Type:  Byte     (DEC)
          Range: 0 ... 254
          Dimension: sec

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

IDX_AUFND index count (used to match vAufnDaten to sAufnDaten)
shall be incremented each time an sAufnAusl is sent (continuing with 0 after 255)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


VIONDATEN

Object: VIONDATEN ___ID: 02F9

Description: verification of desired dose
              sent by generator upon receiving sIonDaten
Sender     :   UGEN
Receiver   :   XCU
Mode       :  DIRECT(01)
Systems    :  RadFluoro and Rad3

List of Parameters:

SCHWAERZKORR Blackening correction. This value is applied to the dose in order to have more dose steps than it is possible with HUD.
          Type:  Integer16     (DEC)
          Range: -32 ... 32
          Dimension: 0.25 BP

MESSF Measuring field (individual fields are bitcoded)
          Type:  Byte     (DEC)
          Range: 0 ... 31
                     KEINE_ANGABE_RUND              0    circular measuring field
                     ACS_MEAS_FLD_I                 1    center field
                     ACS_MEAS_FLD_II                2    3-chamber: left field
                                                         5-chamber: lower right field
                     ACS_MEAS_FLD_I_AND_II          3
                     ACS_MEAS_FLD_III               4    3-chamber: right field
                                                         5-chamber: lower left field
                     ACS_MEAS_FLD_I_AND_III         5
                     ACS_MEAS_FLD_II_AND_III        6
                     ACS_MEAS_FLD_I_AND_II_AND_III  7
                     ACS_MEAS_FLD_IV                8    5-chamber: upper right field
                     ACS_MEAS_FLD_I_AND_IV          9
                     ACS_MEAS_FLD_II_AND_IV         10
                     ACS_MEAS_FLD_I_AND_II_AND_IV   11
                     ACS_MEAS_FLD_V                 16   5-chamber: upper left field
                     ACS_MEAS_FLD_I_AND_V           17
                     ACS_MEAS_FLD_III_AND_V         20
                     ACS_MEAS_FLD_I_AND_III_AND_V   21
                     ACS_MEAS_FLD_IV_AND_V          24
                     ACS_MEAS_FLD_IV_AND_I_AND_V    25
          Dimension: none

FOLIE (only used for iontomat, not for SDM) amplification foil for cassette film (the iontomat has three inputs with different, separately adjustable amplification for the dose
          Type:  Byte     (DEC)
          Range: 0 ... 2
                     ACS_FOLIE_H  0   high sensitive foil (low dose), in FD systems only
                                      used for dose separation
                     ACS_FOLIE_U  1   universal (medium dose)
                     ACS_FOLIE_D  2   detailed resolution (high dose)
          Dimension: none

DOSIS dose in case of DFR regulation without iontomat. The values 0, 1 and 2 in telegram sOrgDaten are used as HUD (sensitivity) for cassette systems
          Type:  Word     (DEC)
          Range: 0 ... 15000
          Dimension: 1 nGy/pulse

ZOOM zoom number
          Type:  Enum8     (DEC)
          Range: 0 ... 4
                     ACS_NO_INFORMATION  0
                     UEBERSICHT          1   overview (full size)
                     ZOOM_1              2
                     ZOOM_2              3
                     ZOOM_3              4
          Dimension: Zoom Number

IONCH iontomat channel (Polydoros SX has six channels for connection up to six chambers for six targets, Polydoros F80 supports less for CAN-iontomat channels)
          Type:  Byte     (DEC)
          Range: 0 ... 8
          Dimension: none

IDX_IONDA index count (used to match vIonDaten to sIonDaten)
shall be incremented each time an sIonDaten is sent (continuing with 0 after 255)
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY1
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY2
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none

DUMMY3
          Type:  Byte     (DEC)
          Range: 0 ... 255
          Dimension: none


Compatibility

Compatibility and restrictions

ACSOS version 7 is backwards compatible. The object description files and trace files of all previous versions can be read.

Restrictions:

If a large object (more than ca. 50 parameters) is displayed using "Keep Name" and/or "Keep Sender" together with "Auto Update" and this objects is sent faster than 10 objects per second, ACSOS can get very slow and the display cannot be updated in time.

If ACSOS automatically stores a trace into a file (configuration), and if the trace exceeds the maximum length of the file (5 MByte ~ about 15.000 objects) and has to be stored into consecutive files, the trace can contain a gap of about 1 second during the transition from one file to the next.


Configuration Menu 4

Configuration version

Run as monitor

ACSOS runs as a network monitor and receives all objects, even the objects that are sent directly addressed to another station. This function is independent of the inlist. Therefore it is recommended to work with an empty inlist.

Only if this function is active ACSOS displays graphically the sender and receiver of the objects:

The sender is displayed as a circle. If the circle is filled, the sender also receives the object.

The receivers are shown as arrows. The direction of the arrows is always from the sender to the receiver.

Show SEND_LIST

From version 4 (till version 3.8 see view menu): The object SEND_LIST (only internally used by ACSOS) is displayed or not.

Show Alive Objects

The DUMMY_MSG (Alive Objects) is displayed or not.

In List/Ego

A dialog to edit the inlist and the current station and group will be shown. This dialog also allows to add or to delete an Ego (definition of a station) to or from the AXCS network. This information is saved and retrieved from file (*.inl).

See Inlist and Ego

Station List

The Station List dialog is shown. In this dialog it is possible to edit the affiliation between a station ID and the name shown in the monitor view or the netlist. To sort the stations list press the UP or DOWN button. The station list can be saved and retrieved from file. (*.cfg)

Object List

A dialog allows the user to select a file with the object list which should be loaded (extension ‘*.obl’). It is not possible to edit the object list within ACSOS.

Parameter List

The list of symbolic constants for enumerations can be loaded (extension ‘*.ptl’) from version 6.

Trace settings

This sub menu defines everything regarding the trace..

See Submenu trace settings

Minimize at start

ACSOS is automatically minimized after start.

Start macro at start

When ACSOS is started the macro is automatically started too..

Select keep name

The check box ‘keep name’ of the object view is checked as default after start of ACSOS

Range check for traces

ACSOS does a range check of all parameters.

Select help file

A dialog allows the user to select a help file which should be loaded (extension ‘*.chm’, till version 5: ‘*..hlp’).

ini file

The complete configuration is now stored in an ”ini file” in ASCII format and no longer in the registry. It also contains the paths of all files needed to run ACSOS. If these files are stored in the same folder or in a subfolder of ACSOS the paths are stored as relative paths, in all other cases as absolute paths.

This makes it easier to run ACSOS from a memory stick or to hold different environments. The ”ini file” can be specified as a parameter if ACSOS is started. The default ”ini file” must be stored in the same folder as the executable and must have the name acsos.ini.


How to edit and activate a filter

How to edit and activate filters

Start the filter editor by selecting the menu item [Filter] [Edit]. A dialog opens where you can edit, open, save and close and activate a filter. The latest used filter will be shown automatically.

When you enter an individual Sender ID in the edit field “Sender”, the filter will set for the sender and the objects. You will only see the selected objects from this special sender. If you enter “00” or “—” you will see the selected objects from all senders.

The objects will be selected by choosing if they should be visible or not. Therefore you can click onto the object. If the object is visible, the “Visible” row contains a cross, otherwise it is an empty field. With the buttons “Select All” and “Select None” the status visible / invisible is set for all objects.

An edited filter has to be closed and activated with the button “Close&Activate” before it is active. But it is only temporary if you only choose the button “Close&Activate”. If you want to save the changes you have you press the “Save” or the “Save As” button.

You can also select a filter by open it with the menu item [Filter] [Load]. A dialog opens where you can select the filter file and open it.

After the closing and activating or the loading the name of the loaded filter will be displayed in the statusbar. Filter files have the extension “.flt”.

If the filter is just loaded but not activated, the statusbar contains the text: “Filter loaded: <filter.flt>”. When the filter is activated, the statusbar contains the text: “Filter active: <filter.flt>”.

To activate / deactivate a loaded filter select the menu item [Filter] [Activate] or the green / yellow filter button in the toolbar. An activated filter will be deactivated automatically by loading another filter.


How to edit and execute macros

Start the macro editor by selecting the menu item [Macro] [Open] or [Macro] [New]. A dialog opens where you can edit, open, save and compile/load a macro. With [Macro] [Open], the latest used macro will be shown automatically.

The macro is a kind of sequential control. There are events (like hitting a key, receiving an object) and reactions on this event (display a value, send an object, change a variable). A special reaction is the change for the context with a call of a subfunction. Now, all events and reactions of this subfunction become active until the special ”CallSub” to “Return” is executed. “Return” means always a return to the main function (not to the calling function).

An edited macro has to be compiled and loaded with the button “Compile/Load” or the menu item [Macro] [Load] before it is possible to start it. If there are errors, the first error will be displayed in a message box. Otherwise, the loading was successful and the name of the loaded macro will be displayed in the statusbar. Macro files have the extension “.mac”.

To start/stop the execution of a successfully loaded macro select the menu item [Macro] [Start]/[Stop] or press the “cogwheel” button in the toolbar. A running macro will be stopped automatically by loading another macro.

Note: Macro execution and recording are independent. It is not necessary to start recording in order to execute a macro. In this case, the object traffic is invisible.

AXCS objects can be copied into the macro from a trace or another macro using Copy/Paste. It work within the same instance of between different instances of ACSOS.

See Syntax of Macros


File menu

Open (trace)

The “Open File” dialog box is displayed. You can select a trace file to open.

Save trace

In dependency of a selection of some recorded objects a “Save selection” dialog box is displayed in order to allow the choice of saving the whole or the selected objects in a trace file.
Afterwards the “File save as” dialog box is displayed in order to allow the saving of the currently recorded objects in a trace file:

· Enter a new file name or select an existing name to overwrite a file.

· Press “Save” to save the current trace file

· Press “Cancel” to escape without saving

Save (trace) as ZIP

The complete trace is stored compressed as a zip file.
Note: Till version 5.0 the path where ACSOS is stored must not contain any space!

Save current profile

From version 4: The configuration is stored in the profile (ini file).

ASCII

In dependency of a selection of some recorded objects a “Save selection” dialog box is displayed in order to allow the choice of saving the whole or the selected objects in an ASCII file.
The “File save as” dialog box is displayed in order to allow the saving of the currently recorded objects in an ASCII file:

· Enter a new file name or select an existing name to overwrite a file.

· Press “Save” to save the current trace file

· Press “Cancel” to escape without saving

Exit

The ACSOS application is closed.

See also How to record, save and reload trace files


Filter menu

edit filter

The filter edit dialog is opened with the currently loaded filter settings.

load filter

A file open dialog is opened in order to select a filter which should be loaded.

See also How to edit and activate a filter


Help menu

Contents

Starts the Windows help system and displays the table of contents for the ACSOS online documentation.
The online help is also available anytime by pressing F1.

About ...

Displays information about

· object description list (not fully supported with early versions)

· the trace file, that is currently opened or that is currently written (not fully supported with early versions)

· the tool ACSOS itself


How to use the tool ACSOS

ACSOS is a monitor and simulation tool for the axcs network. These are the main features:

· All objects transferred on AXCS can be stored in a trace independently of the sender or receiver. In this case ACSOS should run with an empty inlist and ‘View/Monitor’ and ‘Configuration/Monitor Objects’ selected.

· To simulate the behavior of a certain application only predefined objects can be stored in a trace. In this case ACSOS should use a specific inlist.

· Every single object can be filled out and sent.

· The objects as well as all parameters are displayed with predefined names (the same names as in the documentation).

· All traces may be stored. External traces may be opened and evaluated.

· Macros are supported:

o a certain reaction can be defined

o a sequence of objects can be defined

o These are events to trigger a macro: a key, a mouse click, another object, a parameter of an object.


Inlist and Ego

How to edit an inlist and to send an ego (logon)

Each communication device in the AXCS network starts the communication by sending its station ID, the group and the Inlist to the network (AxnRoot). The Inlist is the list of AXCS objects that the communication device wants to receive. This start of communication is called “adding the ego” or station logon. ACSOS allows to act more than one communication device simultaneously, that means, you can add more than one ego at a time. Be aware, that by adding additional egos you receive the same object as many times as you have ego’s added, if all instances are running in monitor mode.

At program startup, ACSOS adds the last saved Ego/Inlist automatically. Therefore you will be able to watch all the AXCS objects that are in this inlist without further actions.
Note that by default the ego APID is 0x62 (ACS_ACSOS) and the inlist is empty (but ACSOS is running as a monitor thus receiving all telegrams).

To change the current ego or to add or delete, open the Inlist/Ego dialog with the menu item [Configuration] [Inlist / Ego]. Changing of the current ego requires to press the “Logoff (Delete)” button, do the changes with the station ID, group and inlist and to press the “Logon (Add)” button when done.

For a logoff, the inlist is not relevant. If you want to keep the current ego definition, save it for later reloading. Ego/Inlist files have the extension “.inl”.


Installation of ACSOS version 4

How to install ACSOS

ACSOS must not be installed. It's sufficient to copy all the files onto the PC. But a separate directory is recommended. Additionally AXNROOT including axnroot.cfg and broadcast.ini must be available on the PC. If it is located in the same folder, then ACSOS will start it automatically (unless it is already running).

It is recommended to run ACSOS with all necessary files stored at a local device. The access over the network might be restricted by enterprise policy.

ACSOS can also be used to evaluate traces from other ACSOS stations without being connected to the axcs network. In this case AXNROOT has to run locally. For more details see readme-axnroot.txt

ACSOS stores its settings and configuration in an ‘ini file’. This must be stored in the same folder as ACSOS. To get ACSOS running the first time, you can edit this ‘ini file’ using any normal text editor, or you can start ACSOS, and ACSOS prompts for all necessary information. If there isn’t any ’ini file’ in the very beginning, you will have to start ACSOS twice (the first time ACSOS creates a default ‘ini file’ (acsos.ini), which can be used afterwards).

The first time, ACSOS is started, additional information and configuration might be necessary. The following flow describes this procedure (not all inputs are always necessary):

<...> means: Input of the user

’...’ means: Messages of the system

· on a PC: Open Windows Explorer and go to the directory where ACSOS is located

· on Artis/BSR: Open Windows Explorer and go to the directory C:\AXIOM\tools\bin

· on Artis/IVS: Open Windows Explorer and go to the directory C:\AXIOM\tools\ACSOS

· on a PC: Double click on ACSOS.exe (ACSOS is started)

· ’Object list file not found’ is displayed

· <ok>

· select the file 'axcs.obl'

· <Open>

· ’Station list not found’ is displayed

· <ok>

· <Open>

· select the file station.cfg

· <Open>

· <Save>

· <Close>

· ’Macro file not found’ (this message arrives asynchronously)

· <ok>

· select the menu 'Macro / Load'

· select the file 'default.mac'

· <Open>

· ’Filter file not found’ (this message arrives asynchronously)

· <ok>

· select the menu 'Filter / Load'

· select the file 'default.mac'

· <Open>

· ’Ego/Inlist file not found’ is displayed

· <ok>

· ·<Open) (in the 'Inlist & Ego' window)

· select the file 'empty.inl'

· <Open>

· <Save>

· <Close>

· select the menu 'Configuration / Monitor Objects' (this item should be marked)

· select the menu 'Configuration / Show SEND_LIST' (this item should not be marked)

· select the menu 'View / Monitor' (this item should be marked)

· select the menu 'File / Exit'

· ACSOS is closed and stores the configuration in the ‘ini file’

Now ACSOS is ready to run.

Used files:

These files belong to ACSOS:

· ACSOS.exe ACSOS executable

· zip.exe zip tool used by ACSOS

· ACSOS.INI ACSOS configuration, may be changed by any editor too

· libaxnclientif.dll interface to axnroot (32 or 64 bit)

Additional Microsoft windows DLLs:

· ·mfc140u.dll

· ·msvcp140.dll

· ·vcruntime140.dll

Additional application and user specific files:

· default.inl an empty INLIST (normally used for ACSOS)

· default.mac default macro file

· default.flt default filter file

Files specific for the version of the project or system, in which ACSOS is used

· axcs.obl the object description file (there may be other obl-files for other versions as well)

· AcsosHelp.chm ACSOS help file

· ParamValueTextList.ptl symbolic constants

· station.cfg list of all clients of the axcs network and the sequence in the ACSOS display window; may be redefined by the user

Every user may define its own files for the INLIST, the macros and the filters. They can be separately opened by ACSOS.

It’s recommended that all these files are located in a separate directory.


Keymappingrsion _

Key mapping and Icons

F1 |  | Starts the online help documentation
F7 |  | Opens the send dialog
Ctrl + O |  | Opens a trace file (recorded data)
Ctrl + S |  | Saves the recorded object data to a trace file
Ctrl + U |  | Toggles view update on/off
Ctrl + R |  | Toggles record start/stop
Ctrl + M |  | Toggles macro start/stop
--- |  | Copy to clipboard of an object in ASCII format
Ctrl+T | --- | Toggles monitor mode on/off
Ctrl+D | --- | Opens a detail view (object view) dialog
Ctrl+I | --- | Opens the simulation dialog
Ctrl+N | --- | Opens the Netlist dialog
Ctrl+L | --- | Opens the macro load dialog
Ctrl+F | --- | Opens the View – Search Dialog


Macro menu

start macro

Starts a loaded macro. If there is no macro loaded, a file open dialog is shown in order to select a macro that should be started.

stop macro

Stops a started macro.

new macro

The macro edit dialog is opened with an empty macro.

edit macro

The macro edit dialog is opened with the currently loaded macro.

load macro

A file open dialog is opened in order to select a macro which should be loaded.

See also How to edit and execute macros and Syntax of Macros


New features version 6

New features of ACSOS version 6.3

· single byte strings of variable length will now be displayed correctly (in object view)


NIL-Values

A definition for ’NIL’ exists for every type of data. The value "...NIL" is not considered in the range, but it is additionally valid for every data type. It means that the content of the parameter currently does not exists or it is not known. If a value has been sent in a previous telegram of the same type, this value shall remain valid.

Depending on the data type the NIL value is:

ACS_SCHAR: ACS_SCNIL = 80 (H) = - 128 (D)

ACS_BYTE: ACS_BNIL = FF (H) = 255 (D)

ACS_INT: ACS_INIL = 8000 (H) = - 32768 (D)

ACS_WORD: ACS_WNIL = FFFF (H) = 65 535 (D)

ACS_LINT: ACS_LNIL = 80000000(H) = -2 147 483 648 (D)

ACS_DWORD: ACS_DWNIL = FFFFFFFF (H) = 4 294 967 295 (D)

ACS_ENUM: ACS_ENIL = FF (H) = 255 (D)

ACS_SET: ACS_SNIL = FFFF (H) = 65535 (D)

ACS_DUMMY: ACS_DNIL = 0


Main menu

ACSOS Help V6.3, overview and workflows

Compatibility and restrictions | How to use ACSOS
New features of version 6.3 | Receive / send objects
Trace area | Record, save trace files
File menu | Edit and execute macros
View menu | Syntax of macros
Record menu | Edit and activate a filter
Macro | Inlist and ego
Filter | Installation
Configuration | Start of ACSOS
Help | Search Dialog
Key mapping and Icons | Time synchronization
List of Objects
List of AP-IDs
NIL Values

Copyright © Siemens Healthcare GmbH 2020. All rights reserved. Restricted.

Sector, SHS DI XP


Record menu

start record
Starts recording into a new trace file.
In case OnlineTraceActive is not set to active (=1) in the INI-file, a previous recording will be lost if it hasn‘t been saved before!.

stop record
Stops recording and closes the trace file (if online trace is active).
In case OnlineTraceActive is not set to active (=1) in the INI-file, it is necessary to select “File-Save” to save the recorded objects.

online trace file
If Online trace is selected ACSOS enters the trace mode automatically after it gets started and stores everything in a trace file. The following can be specified in the configuration:

· the max length

· the path

· a fixed part of the name of the file, date and time is added automatically

· if the trace is full: Restart trace or stop tracing


How to receive and send objects

ACSOS must be connected to the axcs network either in the monitor mode or with an inlist as a certain component

Receive and view objects

Start the recording:

Menu:[Record] [Start] or use Toolbar Button with the red circle.
[View Update] or the button with the “walking green man” have to be checked

To investigate the parameters of a received object, double click on the object.

Only if ACSOS is running in monitor mode the sender and receiver of the objects are graphically displayed :

The sender is displayed as a circle. If the circle is filled, the sender also receives the object.

The receivers are shown as arrows. The direction of the arrows is always from the sender to the receiver.

Send objects

Select the menu item [View] [Send] or press the “envelope” button in the toolbar.

Select the name of the object from the drop down list box or enter the name directly.

Selected the parameters by a left mouse click.

Navigate between the edit fields with the TAB key.

Send the object by pressing the "Send" button.


Filter Menu

Search dialog

Search function for objects, parameters and contents of parameters. The result can be stored in a text file as a ‘semicolon separated list’. The search commands can be stored as a script for later use.

Syntax of Search String

In the field ‘Search String’ strings can be entered, which will be searched after pressing ‘Do it’ or ‘Enter’. A check box defines in which part of an AXCS telegram the search shall be performed. The following search settings are applicable, they can also be combined:

· Exact Spelling

· Telegram Name => Search in telegram name

· Parameter Name => Search in parameter name

· Value Content => Search in values of parameters.

· Objects can also be selected using a scroll box, which contains all objects existing in the associated trace.

· It is possible to add or remove a ‘Search String’ to or from the list of results. These strings can also be selected from the history list.

· With the button ‘RangeError’ all parameters of the search result are checked according to their defined range. If a range violation occurs, the telegram is added to the ‘Search Results’.

· The button ‘Delete Search’ deletes all search entries and the history.

· The content of the history scroll box, containing all executed search commands, can be storable to a file by pressing a button ‘Save as Script’ with the suffix ‘.mks’.

· These files can be loaded using the button ‘Script Search’; all search commands are automatically executed.

Search Result

The search result contains the following information listed in a table

Object Number in trace

· Time Stamp of telegram

· Object Name

· Group

· Sender

· X or ! – X means something changes since receiving the last same telegram. ! means nothing has been changed. Telegram has the same content as last same telegram.

A setting defines, if a double click at an object

· switches to trace window and marks it in the trace.

· opens a detail view window with the object as double click in Main Window does.

The result of the search can be saved in a text file with all parameters separated by semicolons. The suffix of the file is ‘.csv’ (although the separator is a semicolon and not a comma).

The check box ‘ValueName’ displays the names (symbolic constants) of the parameter values, if a ptl-file is loaded.

It is possible to define a color scheme for each object displayed in the ‘Search Result’ window. The color scheme can be stored in a file with the extension ‘.asc’ and later loaded again for further use.


Start of ACSOS version 4

How to start ACSOS

After installation ACSOS may be started by

  • a double click on a trace file
  • a double click on the executable (a shortcut may be used too)
  • in a command window (or a batch file)

In all these case ACSOS takes all the paths and adjustments out of the registry of windows.

If ACSOS is started in a command window or a batch file the ‘ini file’ may be added as a parameter. If the ‘ini file’ is not located at the same folder as the executable the path has to be added too.

Example:

acsosnt.exe D:\Daten\MyTest\MyAcsos.ini


Macro syntax

Syntax of macros

Every line of a macro contains the following columns:

#:The line number

Name:The name of the macro line is only a comment. If the line defines a key event with a button field assigned, the name will be displayed in the simulation dialog on the according button.

Type:Event type on which the macro has to react. The following event types are possible:

Object:React on a received object

Variable:React on a variable that fulfils a condition

Key: React on a specified key (when the simulation dialog has the input focus)

Nothing:When the event type field is empty, the line defines additional reactions to the previous event.

Event:Specifies details for the event. In dependency of the type, the event field contains the following information:

Object:The name of the object and all the values of its parameters. A dialog will be opened to allow the selection of an object and to enter the values which must match when the object is received. Two dashes for a parameter means that the value is “don’t care”.

Variable:The name of the variable

Key: A key character (case sensitive)

Nothing :No input allowed

Value:Specifies an additional value for the event. In dependency of the type, the value contains the following information:

Object:No input allowed

Variable:The operator and the value e.g. > 20, = 10, <=30

Key: The button position where the key is to be displayed in the simulation dialog

Nothing :No input allowed

Type:The response type specifies how the macro has to react when an event occurs. Note that it is allowed to define more than one response to an event by using additional macro lines with the event type nothing. The following response types are possible:

VarToPara:Send an AXCS object (eventually with delay) with some parameters defined by variables. All other parameters get a normal invariable value.

ParaToVar:Get the data of the latest AXCS object with the given name that has been received. Some of the parameter values have to be copied to variables for later use.

Object:Send an AXCS object (eventually with delay).

Variable:The value of a variable has to be changed

DispPara:Get the data of the latest AXCS object with the given name that has been received. Display one or more parameters of this object in the simulation dialog.

DispVar:Display a variable in the simulation dialog

CallSub:Call a subroutine

Response:Specifies details for the response. In dependency of the response type, the response field contains the following information:

VarToPara:The name of the object and the parameter list. A dialog allows to enter variable names for the parameter values where a parameter should be set from a variable before sending.

ParaToVar:A dialog allows to select an object and to enter variable names for parameters which are to be copied into variables.

Object:A dialog allows to select an object and to enter parameter values.

Variable:The name of the variable which has to be changed.

DispPara:A dialog allows to select an object and to assign display positions (in the simulation dialog) for the object parameters.

DispVar:The name of a variable that has to be displayed in the simulation dialog.

CallSub:The name of a subroutine. If the subroutine doesn‘t exist yet, the editor automatically adds a start and end line for this subroutine.

Value:Specifies an additional value for the response. In dependency of the response type, the value contains the following information:

VartoPara:The send delay in milliseconds

ParatoVar:No input allowed

Object:The send delay in milliseconds

Variable:The operator and the value e.g. = 20, +1, -5

DispPara:No input allowed

DispVar:The display position for the variable in the simulation dialog.

CallSub:No input allowed

Active:Sets the status of the macro line. If “Active” has the status “ON” the macro line will be executed. If “Active” has the status “OFF” it will not be execute and the macro will run like this line is not written. The status “OFF” will mark the current macro line as something like a comment.

Note: It is possible to implement macro algorithms which effect the normal program execution this way that ACSOS or AxnRoot hangs or crashes.

Examples for this behaviour are:

Endless Loop: Sending the same object that was just received without delay
Avalanche Effect: When ACSOS is logged in as two stations it will receive a sent object two times. If the macro reacts with sending an object which is also an event object, the resulting number of involved objects will double up every time.


File Menu

Time synchronization

If the object iDate is received, ACSOS synchronizes the internal time of the trace, that the time stamps in the trace fit to the time of the sender of the object iDate. This is only used in the ‘XCS world’, where the imaging systems sends iDate.


Main window

Trace area.

Column Group ID |  | Group Id which was used to send the object. This column can be set or removed by configuration.
Column Comment |  |
 | Monitor | ACSOS is running in monitor mode. The object has been sent functionally addressed
 | Mon.Direct | ACSOS is running in monitor mode. The object has been sent directly addressed
 | Mon.Message | ACSOS is running in monitor mode. The object (also called message) has been created by the AXN server
 | Direct | The object was directly sent to ACSOS
 | Functional | ACSOS has this object in its inlist. The object has been sent functionally addressed
Flow diagram |  | The flow diagram at the right side shows the sender and, in the headline, all the subsystems involved in the communication. The following symbols are used:
 |  | This is the sender of the object
 |  | This is the sender of the object, and the object is also received by the sender
 | or | This is a receiver of the object; there might be several receivers of one object

Note: One object can be displayed twice, if it is send directly to ACSOS or if ACSOS is running in monitor mode and has additionally this object in its inlist.


How to record, save and reload trace files

It is possible to record all received and sent AXCS objects in a file. To start or stop the recording, select the menu item [Record] [Start] / [Stop] or press the red record button in the toolbar. Unless OnlineTraceActive is disabled in the INI-file, the data will be stored into a file that has an automatically generated name. An explicit name can be set by the menu item [File] [Save] or by pressing the toolbar button with the disk symbol. A new record start command or loading of another trace file will always close the current trace file.

If you don’t need the whole data you can also select the needed objects and save them with the menu item [File] [Save]. A dialog will appear where you can choose, if you want to save the selected objects or all the objects. You can select single objects, but the objects in between the first and the last selected object will be saved as a block.

The recorded files with the AXCS objects are called trace files and have the file extension “.trc”. To reload a trace file, select the menu item [File] [Open] or press the “folder” button in the toolbar.


Trace settings Submenu

Trace Settings

Online trace active

If Online trace is selected ACSOS enters the trace mode automatically after it has been started and stores all objects in a trace file.

The following parameters can be specified in the INI-file additionally (i.e. require a restart of ACSOS):

Save directory

Folder where the online trace files are stored. It is recommended to store the files at the local disk and not at a memory stick or at the network

Suffix of trace file

A fixed part of the name of the file, date and time is added automatically.

Max numbers of trace files

Since nowadays disk space is not really limited any more, MaxTraceNumber-Setting in the INI-file is not used any more.


View menu

Update

If UPDATE is enabled, the main view is updated instantly with every new object that has been received. If the new line is not visible, the window scrolls to ensure that the line is visible. Since updating may happen very frequently, it is possible to disable the updating for a while.

The background color of the main view reflects the update state. White means that updating is in effect, grey means that updating is disabled.

Send (object)

The send dialog box will be shown. Select an object from the list and edit its parameters. To send the object press the SEND button. To copy the selected object into the clipboard press the COPY button. To insert an object from the clipboard press the PASTE button. To close the window click [x] at the upper right corner of the title bar.

· The send window can be minimized

· The window contains a help button to show the description of the currently displayed object.

· Copy and paste of objects is now possible between different instances of ACSOS.

Object (detail view)

The detail view dialog for received objects will be shown. The object with all its parameters can be investigated. It is possible to open more than one detail view dialog. Within the dialog it is possible to step between the received objects with navigation buttons (first, previous, next, last object). If the checkbox ‘Keep Name’ is checked, only objects with the same name (ID) as the current are shown. The checkbox ‘Auto Update’ allows to watch currently received objects. To copy the shown object to the clipboard press the COPY button. To insert an object from the clipboard press the PASTE button. To go to the corresponding position in the trace view press the Goto Trace button.

· The detail window can be minimized.

· Different values of a parameter are marked in red if someone goes through a trace in ‘Detail View’ with ‘Keep Name’, even online with ”auto update”.

· The window contains a help button to show the description of the currently displayed object.

· Copy to clipboard of an object in ASCII format is possible.

· Copy and paste of objects into the send window or a macro is possible, even between different instances of ACSOS.

· If ‘Keep Param’ is activated, the list of parameters gets white and a certain value of several parameters can be defined in the column ‘value’. The next object can be searched, which fulfilling ALL the expressions set for the parameters. This function must not be used in trace mode, but only, if tracing is stopped or if a trace is loaded. The function does not work consecutively, but only once.

· ‘Clear Param’ is used to delete the parameter values and replace them with a wildcard.

· ‘Keep Param’ automatically deselects ‘Auto Update’, both are mutually exclusive.

· If ‘Range check for traces’ is configured, ACSOS checks the ranges of all parameters and marks a violation in green (red is already used for changed parameters). Range check has a higher priority.

Search Dialog

Extended search function to evaluate trace file.
See Search Dialog

Simulation

The simulation dialog is shown. This dialog is useful only with a started macro and shows the buttons, keys and values that have been defined in the macro, but only what is defined in the part of the current main and subroutine.

The key matrix in the upper part of the window displays ten fields numbered from 1.1 (upper left field) to 2.5 (lower right field). The key matrix shows the keys which are defined as an event in the loaded and activated macro. If you press a defined key, the response will be activated immediately.

The display matrix in the lower part of the window displays 15 fields numbered from 1.1 (upper left field) to 3.5 (lower right field). The display matrix shows variables or parameters of an object defined as a response in the active macro.

Net List

The NetList dialog is shown. On the left side of the dialog contains the stations which are logged on to the network, the right side displays the Inlist of the selected station.

The NetList is the list of all stations currently logged on. It is kept up to date in the background. To get station names displayed instead of station ID numbers, edit the Stationlist and assign the missing station names.


Filter Menu

Watch List dialog

The Watch List is a new function to watch certain parameters. It can be activated via Menu (View -> Watch List) or by the hotkey Ctrl+W.

It is very helpfully if you want to watch just a few parameters from different telegrams during an online session.

Once the Watch List Dialog is open, you can add parameters to the watch list by clicking the “add to watchlist” button in the telegram details dialog.

The Watch List Dialog also allows to save and load watch lists (as a WTL file). The format of the WTL-file is actually quite simple, since it is a text file. Each list entry consists of two lines: the first line contains the name of the object(=telegram) and the second line the name of the parameter.